Bug#895927: sha256 checksum of output database not reproducible with command line tools

2019-02-17 Thread Hannes von Haugwitz
tags 895927 + unreproducible thanks Hi Marc, On Tue, Apr 17, 2018 at 04:13:33PM +0200, Marc Haber wrote: > I would like to verify the database mentioned in aide output before > copying it over to the input database name. That does not seem to work: > > [19/5003]mh@ivanova:~ $ ls -al

Bug#922502: plasma-desktop: regional settings allow do select system incompatible locales

2019-02-17 Thread Charlemagne Lasse
Package: plasma-desktop Version: 4:5.14.5-1 Severity: critical Justification: makes unrelated software break on the system The "regional settings" allow to select various regions which are not available on the system (even with locales-all). An example here is en_DE (Germany) for "Time". This is

Bug#922508: prosody-modules: please add mod_onions

2019-02-17 Thread Sandro Knauß
Package: prosody-modules Version: 0.0~hg20190203.b54e98d5c4a1+dfsg-1 Severity: wishlist please add mod_onions, which allows to serve XMPP via tor see: https://modules.prosody.im/mod_onions.html hefee

Bug#919638: solr-tomcat: Permission problems after update to tomcat9

2019-02-17 Thread Markus Koschany
Control: reassign -1 src:tomcat9 Am 17.02.19 um 06:58 schrieb Michael Welsh Duggan: [...] > Based on your prior tip, I had already done that. (Only the > /var/lib/solr/ entry seemed to be necessary.) This caused things to > work again. Thank you for the confirmation. Then I think reassigning

Bug#922213: Bug#922500: tex-common: Fails to install with LC_TIME=en_DE.UTF-8

2019-02-17 Thread Charlemagne Lasse
> On Sun, 17 Feb 2019, Charlemagne Lasse wrote: > > perl: warning: Setting locale failed. > > perl: warning: Please check that your locale settings: > > LANGUAGE = "en_US:en", > > LC_ALL = (unset), > > LC_TIME = "en_DE.UTF-8", > > LANG = "C" > > are supported and installed on your system. > > >

Bug#922507: wml: Missing depends on libgd-perl

2019-02-17 Thread Kurt Roeckx
Package: wml Version: 2.12.2~ds1-1 Severity: serious Hi, I'm getting the following error: Can't locate GD.pm in @INC (you may need to install the GD module) (@INC contains: /etc/perl /usr/local/lib/x86_64-linux-gnu/perl/5.28.1 /usr/local/share/perl/5.28.1 /usr/lib/x86_64-linux-gnu/perl5/5.28

Bug#922509: security issue in PEP plugin (CVE-2019-1000021)

2019-02-17 Thread W. Martin Borgert
Source: slixmpp Version: 1.2.2-1.1 Severity: grave Tags: security patch upstream See https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-121 for details. A fixed version for stretch-security is on its way.

Bug#922386: VICE Commodore 8bit emulator does not play sound

2019-02-17 Thread Cambays Water
Control: tags -1 +moreinfo On Fri, Feb 15, 2019 at 11:33 AM Cambays Water wrote: > Vice seems to need package libmp3lame0 in order to play sound. It should _not_ as it's an mp3 encoding library and not a sound player. > I also had to issue this command: > > ln -s

Bug#922478: upgrade linux-image-4.9.0-8-armmp-lpae:armhf from 4.9.130-2 to 4.9.144-3 renders Bananapi and Lamobo R1 unbootable

2019-02-17 Thread Reco
Hi all. I'd like to add that plain armmp (non-lpae) is broken too. At least for Armada385/Caiman and QEMU's virt. Reco

Bug#922513: capstone: Block from entering testing

2019-02-17 Thread Hilko Bengen
Source: capstone Version: 3.0.5-4 Severity: grave I recently uploaded the capstone4 as a separate source package, assuming that this would not have consequences in testing. As I was told on #debian-release, that is not the case because the capstone4 package takes over python-capstone,

Bug#915298: gdebi FTBFS with pyflakes 2.0.0-1

2019-02-17 Thread Andrey Rahmatullin
Here is the actual pyflakes3 output: ./gdebi-kde:92: local variable 'e' is assigned to but never used ./gdebi-gtk:80: local variable 'e' is assigned to but never used ./GDebi/KDEAptDialogs.py:147: local variable 'e' is assigned to but never used ./GDebi/GDebiKDE.py:363: local variable 'msg' is

Bug#909856: [Pkg-owncloud-maintainers] Bug#909856: owncloud-client: Build against libsecret

2019-02-17 Thread Sandro Knauß
Control: reassign -1 libqt5keychain1 0.9.1-1 Control: forcemerge 909588 -1 Hey, the bug is inside qtkeychain and not in owncloud-client. Regards, hefee -- On Samstag, 26. Januar 2019 11:36:46 CET Thomas Maaß wrote: > Source: owncloud-client > Followup-For: Bug #909856 > > Dear Maintainer, >

Bug#922503: closed by Samuel Thibault (Re: Bug#922503: espeakup 0.80+deb9u3 is damaged)

2019-02-17 Thread Samuel Thibault
Hello, Fran Torres, le dim. 17 févr. 2019 11:15:43 +0100, a ecrit: > on the espeakup package was disapear the error on log > and apear other error. I believe that's just a deprecation warning. Samuel

Bug#922510: galternatives: [INTL:de] Updated German translation

2019-02-17 Thread Chris Leick
Package: galternatives Version: 1.0.3 Severity: wishlist Tags: l10n patch Hi, please find attached the newest German translation. Kind regards, Chris de.po.gz Description: application/gzip

Bug#922511: pkg-config-references-unknown-shared-library false positive when using variables

2019-02-17 Thread Faidon Liambotis
Package: lintian Version: 2.7.0 Severity: normal Hi there, jemalloc's pc has this: [...] install_suffix= [...] Libs: -L${libdir} -ljemalloc${install_suffix} (install_suffix is autoconf-interpolated at build time, so there is a reason it exists despite being purposefully empty in Debian)

Bug#921803: python-scrapy: FTBFS randomly (failing tests)

2019-02-17 Thread Santiago Vila
retitle 921803 python-scrapy: FTBFS randomly (failing tests) severity 921803 important thanks On Sun, Feb 17, 2019 at 02:37:42PM +0500, Andrey Rahmatullin wrote: > I cannot reproduce this on the current sid chroot. > Unfortunately the log excerpt in the bug is not helpful and I couldn't > access

Bug#904462: RFS: uefitool/0.25.1-1 [ITP]

2019-02-17 Thread Yangfl
Andrey Rahmatullin 于2019年2月17日周日 下午6:42写道: > > Control: owner -1 ! > > Please upgrade to the new upstream version and the new packaging > standards and I'll sponsor it. > > -- > WBR, wRAR Updated. Thank you.

Bug#922514: release.debian.org: RM: capstone4/4.0.1-2

2019-02-17 Thread Hilko Bengen
Package: release.debian.org Severity: normal User: release.debian@packages.debian.org Usertags: rm Please remove the capstone4 package from unstable. I recently uploaded the capstone4 as a separate source package, assuming that this would not have consequences in testing. As I was told on

Bug#877202: Bug #877202 in pyxdg marked as pending

2019-02-17 Thread Simon McVittie
On Thu, 14 Feb 2019 at 11:02:33 +, Simon McVittie wrote: > Alternatively, uploading a version closely resembling the one in Ubuntu > would be a low-risk option with a minimal fix for this bug. For now I've done this, on a new debian/buster branch, and merged that branch into master. smcv

Bug#834331: test code fails and ignored for ibus

2019-02-17 Thread Osamu Aoki
Hi, On Sun, Feb 17, 2019 at 11:02:45AM +, Simon McVittie wrote: > On Sun, 17 Feb 2019 at 15:44:07 +0900, Osamu Aoki wrote: > > ./runtest: 113: ./runtest: pushd: not found > > pushd is a bash feature (a "bashism"). If runtest needs to use it, > then it should be a #!/bin/bash script, not a

Bug#911859: Seems to be

2019-02-17 Thread John Talbut
I found that the setting: "Use SQL-92 naming constraints" in Edit > Database > Advanced settings" was set. I unset it and the problem seems to be resolved. Is this a new setting that defaults to being set? Or a setting that has been changed to default to set? I suppose I could have

Bug#902204: monit: spurious "monit alert -- Link up eth0" messages

2019-02-17 Thread Vincent Lefevre
On 2019-02-17 14:13:45 +0300, Sergey B Kirpichev wrote: > On Sat, 22 Dec 2018 03:17:27 +0100 Vincent Lefevre wrote: > > So, it seems to be a bug in the monit code that makes it think that > > the link is up while it is not. > > > > In validate.c, I see: > > > > [...] > > for

Bug#739636: postfix: Exagerated error on authentication server connexion issue

2019-02-17 Thread Samuel Thibault
Control: reopen -1 Control: reassign -1 dovecot Control: retitle -1 dovecot: should provide a way for exim to know that an authentication error is temporary Scott Kitterman, le dim. 17 févr. 2019 03:42:14 -0500, a ecrit: > On Tue, 23 May 2017 09:52:14 +0200 Samuel Thibault > wrote: > > Scott

Bug#922504: socket-activate: FTBFS in sid (failing tests)

2019-02-17 Thread Santiago Vila
Package: src:socket-activate Version: 0.1-1 Severity: serious Tags: ftbfs Dear maintainer: I tried to build this package in sid but it failed: [...] debian/rules binary-indep dh binary-indep

Bug#922505: Please relax the dependencies of lxqt-branding-debian

2019-02-17 Thread Jordi Pujol
Package: lxqt-branding-debian Version: 0.14.0.2 Severity: normal Hello, The dependencies of this new package are demanding 150MB of disk space. However, the lxqt environment worked well without them before. Consider that lxqt-core not really depends on it, and lxqt-branding-debian may be only

Bug#921790: liquidsoap: FTBFS (ld: cannot find -lexif)

2019-02-17 Thread Andrey Rahmatullin
On Sat, Feb 09, 2019 at 12:15:34AM +, Santiago Vila wrote: > OCAMLOPT -o liquidsoap > /usr/bin/ld: cannot find -lexif libexif-dev is indeed not installed but my build fails even earlier: OCAMLOPT -c tools/file_watcher.ml OCAMLOPT -c tools/file_watcher_mtime.ml OCAMLOPT -c configure.mli

Bug#922506: [libvirt0] lxc: internal error: child reported (status=125): Kernel does not provide mount namespace: No such file or directory

2019-02-17 Thread Dirk Heinrichs
Package: libvirt0 Version: 5.0.0-1 Severity: normal --- Please enter the report below this line. --- I currently see above error when I try to stop an LXC container running under libvirtd using # virsh --connect lxc:///system shutdown myContainer error: Failed to shutdown domain

Bug#904462: RFS: uefitool/0.25.1-1 [ITP]

2019-02-17 Thread Andrey Rahmatullin
Control: owner -1 ! Please upgrade to the new upstream version and the new packaging standards and I'll sponsor it. -- WBR, wRAR signature.asc Description: PGP signature

Bug#922512: minissdpd: [INTL:pt] Updated Portuguese translation - debconf messages

2019-02-17 Thread Américo Monteiro
Package: minissdpd Version: 1.5.20180223-6 Tags: l10n, patch Severity: wishlist Updated Portuguese translation for minissdpd's debconf messages Translator: Américo Monteiro Feel free to use it. For translation updates please contact 'Last Translator' -- Melhores cumprimentos/Best regards,

Bug#922502: plasma-desktop: regional settings allow do select system incompatible locales

2019-02-17 Thread Charlemagne Lasse
See also https://bugs.debian.org/922500

Bug#922503: closed by Samuel Thibault (Re: Bug#922503: espeakup 0.80+deb9u3 is damaged)

2019-02-17 Thread Fran Torres
Hello, after add the /bin/ before sh -c, the dpkg was configured the rest of packages but, on the espeakup package was disapear the error on log and apear other error. In this case, i'm not capable found the problem. I add you a log (syslog, espeakup.service and output of apt) in a unique log for

Bug#896468: [Pkg-javascript-devel] Bug#896468: Bug#896468: libjs-chartjs: Please upload newer versions

2019-02-17 Thread Pirate Praveen
On Sun, Feb 17, 2019 at 2:47 AM, Paul Gevers wrote: Hi, On 15-02-2019 07:46, Pirate Praveen wrote: Thanks Jonas for the confirmation. I have uploaded 2.7.3 to experimental. Since browserify is not available in the archive, I have used rollup to build the umd bundle. Please review, test

Bug#922486: python3-sbml5: libsbml fails to import

2019-02-17 Thread Liubov Chuprikova
Hi Andreas, On Sat, 16 Feb 2019 at 22:43, Andreas Tille wrote: > > If you see any chance to hunt this issue in libsbml down this would be > really welcome. I would like to fix this if I have time in the following week. I can't say right now. JFI: Just looking onto the files installed with

Bug#922500: tex-common: Fails to install with LC_TIME=en_DE.UTF-8

2019-02-17 Thread Charlemagne Lasse
Package: tex-common Version: 6.10 Severity: serious Justification: Fails to install on a normal KDE installation with "Germany" setting as Time localization The installation works fine with LC_TIME=C but not with the setting generated by KDE LC_TIME=en_DE.UTF-8. The aptitude output follows and at

Bug#922501: ERROR: No runner implements step with keys grub, root-part, device, console, root-fs

2019-02-17 Thread Martin Pitt
Package: vmdb2 Version: 0.13.2+git20190215-1 I'm trying to build a stretch VM image using autopkgtest's tool: autopkgtest-build-qemu stretch /tmp/autopkgtest-stretch-amd64.qcow2 which under the hood calls vmdb2 --verbose --image=/tmp/autopkgtest-stretch-amd64.qcow2.raw /tmp/config I'm

Bug#922489: qtkeychain: relies on existence of libsecret-1.so -dev symlink

2019-02-17 Thread Sandro Knauß
Control: Forwarded -1 https://github.com/frankosterfeld/qtkeychain/pull/139 Hey, thanks for the fast reply, that gave me the right direction to search for the bugfix. > I think this is a qtkeychain bug. This code that appears to be responsible > for dlopen()ing libsecret: > >

Bug#902204: monit: spurious "monit alert -- Link up eth0" messages

2019-02-17 Thread Sergey B Kirpichev
tags 902204 -moreinfo thanks On Sat, 22 Dec 2018 03:17:27 +0100 Vincent Lefevre wrote: > So, it seems to be a bug in the monit code that makes it think that > the link is up while it is not. > > In validate.c, I see: > > [...] > for (LinkStatus_T link = s->linkstatuslist; link; link =

Bug#921803: python-scrapy: FTBFS (failing tests)

2019-02-17 Thread Andrey Rahmatullin
I cannot reproduce this on the current sid chroot. Unfortunately the log excerpt in the bug is not helpful and I couldn't access the RB website. -- WBR, wRAR signature.asc Description: PGP signature

Bug#834331: test code fails and ignored for ibus

2019-02-17 Thread Simon McVittie
On Sun, 17 Feb 2019 at 15:44:07 +0900, Osamu Aoki wrote: > ./runtest: 113: ./runtest: pushd: not found pushd is a bash feature (a "bashism"). If runtest needs to use it, then it should be a #!/bin/bash script, not a #!/bin/sh script. > NOT FOUNND ibus-memconf. Need configure --enable-memconf It

Bug#921573: lintian: binary-from-other-architecture only works sometimes

2019-02-17 Thread Mattia Rizzolo
On Thu, Feb 07, 2019 at 04:52:26PM +0100, Chris Lamb wrote: > You don't still have it, so no worries. I don't get what the big > deal is. :) For the advantage of everybody, here are links to the cross-builds from amd64 to mips64el and arm64 of procmail. just dget this url (which is more

Bug#922520: libiio: please make the documentation reproducible

2019-02-17 Thread Chris Lamb
Source: libiio Version: 0.16-1 Severity: wishlist Tags: patch User: reproducible-bui...@lists.alioth.debian.org Usertags: buildpath X-Debbugs-Cc: reproducible-b...@lists.alioth.debian.org Hi, Whilst working on the Reproducible Builds effort [0], we noticed that libiio could not be build its

Bug#922525: procps: typo in sysctl.conf

2019-02-17 Thread Nobuhiro Ban
Package: procps Version: 2:3.3.15-2 Severity: minor Tags: patch Dear Maintainer, I found a (very) small typo in /etc/sysctl.conf. Please apply this patch to fix. --- procps/etc/sysctl.conf2018-04-10 20:49:54.0 +0900 +++ sysctl.conf2019-02-17 19:03:21.227782340 +0900 @@ -9,7 +9,7

Bug#834053: openjdk-8: java.awt.Font#deriveFont(int style) corrupts font size

2019-02-17 Thread Nobuhiro Ban
Ping. Or, should I send this report to upstream? Regards, Nobuhiro Ban

Bug#922478: upgrade linux-image-4.9.0-8-armmp-lpae:armhf from 4.9.130-2 to 4.9.144-3 renders Bananapi and Lamobo R1 unbootable

2019-02-17 Thread Cyril Brulebois
Hi folks, Jürgen Löb (2019-02-16): > Package: linux-image-4.9.0-8-armmp-lpae > Version: 4.9.144-3 > Severity: serious > > Updated my Lamobo R1 board with apt update;apt upgrade > > After the update uboot is struck at "Starting kernel". There is no > further output after "Starting kernel". Same

Bug#922477: postfix: FTBFS under Linux > 4

2019-02-17 Thread Sven Joachim
On 2019-02-17 15:55 +, Scott Kitterman wrote: > Can you change: > > Linux.[34].*) SYSTYPE=LINUX$RELEASE_MAJOR > > to: > > Linux.[345].*) SYSTYPE=LINUX$RELEASE_MAJOR > > in makedefs and verify it builds and works (just a smoke test is fine) > with your kernel? I also had to change

Bug#922478: upgrade linux-image-4.9.0-8-armmp-lpae:armhf from 4.9.130-2 to 4.9.144-3 renders Bananapi and Lamobo R1 unbootable

2019-02-17 Thread Cyril Brulebois
Hi, Reco (2019-02-17): > Did this already in QEMU (virt board). > 4.9.135-1 works. > 4.9.144-1 (next one) is broken. Is there any chance you could share how to get such a VM set up in QEMU? I'd be happy to try a few kernel builds, but having a quick way to check whether a given kernel build is

Bug#922533: please document location of accounting file

2019-02-17 Thread Marc Haber
Package: acct Version: 6.6.4-2 Severity: wishlist Hi, my package atop needs to adapt itself to acct being installed or not. If acct is installed, atop reads from acct's log files, while establishing its own accounting interface it acct is not installed. Historically, the pacct file is found in

Bug#922478: upgrade linux-image-4.9.0-8-armmp-lpae:armhf from 4.9.130-2 to 4.9.144-3 renders Bananapi and Lamobo R1 unbootable

2019-02-17 Thread Cyril Brulebois
Hi, Reco (2019-02-17): > 1) Install qemu-system-arm. > > 2) Unpack kernel .deb, locate vmlinuz-4.9.0-8-armmp. > Or search your just-built zImage. > > 3) Run qemu (no root required): > > qemu-system-arm -M virt -nographic -kernel vmlinuz-4.9.0-8-armmp > > If you see a kernel panic - the

Bug#922539: new upstream release available

2019-02-17 Thread Antoine Beaupre
Package: fail2ban Version: 0.10.2-2.1 Severity: wishlist Hi, there are two new upstream releases available for fail2ban (0.10.3 and 0.10.4, at the time of writing, which include a lot of bugfixes and performance improvements. I think it would be important to ship those with buster, at the very

Bug#912586: python-cobra still fails it's autopkg tests

2019-02-17 Thread Liubov Chuprikova
Hi, I have just pushed a fix for this. In fact, the solution was proposed in one of the previous messages [1]: the test suite was returning True some time ago, but now it returns the exit code instead. Some tests are `xfail`-ing (in the beginning I thought that's was the problem) but as I

Bug#922507: wml: Missing depends on libgd-perl

2019-02-17 Thread Axel Beckert
Control: tag -1 + confirmed Hi Kurt, thanks for the bug report! Kurt Roeckx wrote: > I'm getting the following error: > Can't locate GD.pm in @INC (you may need to install the GD module) (@INC > contains: /etc/perl /usr/local/lib/x86_64-linux-gnu/perl/5.28.1 > /usr/local/share/perl/5.28.1

Bug#915547: Use iso639-3.xml file

2019-02-17 Thread Osamu Aoki
control: forwarded -1 https://github.com/ibus/ibus/issues/2062 Looks like pull request https://github.com/ibus/ibus/pull/2061 is already applied to fujiwara's https://github.com/fujiwarat/ibus repo for 1.5.20. 1cd52548 ("src: use iso 639-3 to have names for more languages", 2018-12-17) He

Bug#922518: ITP: libdata-methodproxy-perl -- module to inject dynamic data into static data

2019-02-17 Thread gregor herrmann
Package: wnpp Owner: gregor herrmann Severity: wishlist X-Debbugs-CC: debian-de...@lists.debian.org, debian-p...@lists.debian.org * Package name: libdata-methodproxy-perl Version : 0.03 Upstream Author : Aran Clary Deltac * URL :

Bug#922521: flake FTCBFS: performs a native build

2019-02-17 Thread Helmut Grohne
Source: flake Version: 0.11-3 Tags: patch User: helm...@debian.org Usertags: rebootstrap flake fails to cross build from source, because it performs a native build. To perform a cross build, one has to supply --cc=... and --cross-compile. After doing so, flake cross builds successfully. Please

Bug#917467: wmbiff: tlscomm_expect() does not handle EAGAIN or GNUTLS_E_AGAIN

2019-02-17 Thread Torrance, Douglas
On 2/17/19 11:49 AM, Andreas Metzler wrote: > On 2019-02-13 Nye Liu wrote: >> On February 13, 2019 9:54:12 AM PST, Andreas Metzler >> wrote: >>> I am not sure about the second part of the patch. I understand wmbiff >>> breaking on GNUTLS_E_AGAIN from gnutls_read, because this only started >>>

Bug#922478: upgrade linux-image-4.9.0-8-armmp-lpae:armhf from 4.9.130-2 to 4.9.144-3 renders Bananapi and Lamobo R1 unbootable

2019-02-17 Thread Reco
Hi. On Sun, Feb 17, 2019 at 07:38:18PM +0100, Cyril Brulebois wrote: > Hi folks, > > Jürgen Löb (2019-02-16): > > Package: linux-image-4.9.0-8-armmp-lpae > > Version: 4.9.144-3 > > Severity: serious > > > > Updated my Lamobo R1 board with apt update;apt upgrade > > > > After the

Bug#922532: Debian 9.8 does'nt starts on Cubieboard

2019-02-17 Thread M.Gergo
Package: linux-base Version: 4.5 Description: After I upgraded to debian9.8 the kernel does'nt starts on Cubieboard2 (Allwinner/armhf). The debian installer is also affected. The system is freezed after displaying 'Starting kernel ...' line Previously, there was an error (since debian9.0) I

Bug#922478: upgrade linux-image-4.9.0-8-armmp-lpae:armhf from 4.9.130-2 to 4.9.144-3 renders Bananapi and Lamobo R1 unbootable

2019-02-17 Thread Reco
Hi. On Sun, Feb 17, 2019 at 08:27:34PM +0100, Cyril Brulebois wrote: > Hi, > > Reco (2019-02-17): > > Did this already in QEMU (virt board). > > 4.9.135-1 works. > > 4.9.144-1 (next one) is broken. > > Is there any chance you could share how to get such a VM set up in QEMU? > > I'd be

Bug#922537: ansible: CVE-2019-3828

2019-02-17 Thread Salvatore Bonaccorso
Source: ansible Version: 2.7.6+dfsg-1 Severity: grave Tags: security upstream Forwarded: https://github.com/ansible/ansible/pull/52133 Hi, The following vulnerability was published for ansible. CVE-2019-3828[0]: path traversal in the fetch module If you fix the vulnerability please also make

Bug#922540: Please give back ocaml-gettext on all architectures

2019-02-17 Thread Hilko Bengen
Package: release.debian.org Severity: normal src:ocaml-gettext could not be built because src:camomile was broken up to version 1.0.1-2, see #922271. The recent upload of src:camomile/1.0.1-3 fixes the issue; please give back ocaml-gettext on all architectures. gb ocaml-gettext_0.3.7-1 . amd64

Bug#922500: tex-common: Fails to install with LC_TIME=en_DE.UTF-8

2019-02-17 Thread Norbert Preining
You set the locale for root while installing, this has nothing to do with user settings what so ever. If you remove bash and a different program fails to install, do you think this is an error of the program bring installed? If locales are not properly set up, then luatex fails to build a

Bug#917467: wmbiff: tlscomm_expect() does not handle EAGAIN or GNUTLS_E_AGAIN

2019-02-17 Thread Andreas Metzler
On 2019-02-13 Nye Liu wrote: > On February 13, 2019 9:54:12 AM PST, Andreas Metzler wrote: >> I am not sure about the second part of the patch. I understand wmbiff >> breaking on GNUTLS_E_AGAIN from gnutls_read, because this only started >> to happen recently (with TLS1.3) on blocking sockets.

Bug#922524: syslog-ng-core: warning message on start

2019-02-17 Thread Nobuhiro Ban
Package: syslog-ng-core Version: 3.19.1-3 Severity: minor Dear Maintainer, syslog-ng (with default config files) warns on start. /etc/syslog-ng/syslog-ng.conf: ># First, set some global options. >options { chain_hostnames(off); flush_lines(0); use_dns(no); use_fqdn(no); > owner("root");

Bug#922528: ITP: golang-github-arduino-go-timeutils -- Functions to handle timezones in golang

2019-02-17 Thread Rock Storm
Package: wnpp Severity: wishlist Owner: Rock Storm * Package name: golang-github-arduino-go-timeutils Version : 0.0~git20171220.d1dd9e3-1 Upstream Author : Arduino * URL : https://github.com/arduino/go-timeutils * License : GPL-2.0 Programming Lang: Go

Bug#922527: x2gobroker: [INTL:pt] Updated Portuguese translation - debconf messages

2019-02-17 Thread Américo Monteiro
Package: x2gobroker Version: 0.0.4.0-3 Tags: l10n, patch Severity: wishlist Updated Portuguese translation for x2gobroker's debconf messages Translator: Américo Monteiro Feel free to use it. For translation updates please contact 'Last Translator' -- Melhores cumprimentos/Best regards,

Bug#921598: No METAR available since noaa.gov switched to https

2019-02-17 Thread Dr. Tobias Quathamer
Am 16.02.2019 um 17:18 schrieb Gabriel F. T. Gomes: > On Sat, Feb 16 2019, Florent Rougon wrote: >> >> As has been discussed on flightgear-devel and despite the commit >> message, commit [1] is not a proper fix and will probably be reverted (I >> mean, the "if( responseCode() >= 400 )" part, not

Bug#922536: notmuch-emacs: notmuch breaks on directory removal

2019-02-17 Thread Joerg Jaspert
Package: notmuch-emacs Version: 0.28-2~bpo9+1 Severity: normal Dear Maintainer, *** Reporter, please consider answering these questions, where appropriate *** * What led up to the situation? Open notmuch "from" a random buffer. Keep the notmuch-hello open. Remove the directory of that

Bug#919504: Info received ([kmail] blank page on print preview)

2019-02-17 Thread hlehmbruch
When i start kmail from the konsole, open the printpreview and than is reproducible crashing (mostly every time) i get this information. As attachment i send the crash report from drkonqi. greetz Hendrik :~$ LANG=C kmail org.kde.pim.kidentitymanagement: IdentityManager: There was no default

Bug#922538: cultivation FTCBFS: performs a native build

2019-02-17 Thread Helmut Grohne
Source: cultivation Version: 9+dfsg1-2 Tags: patch User: helm...@debian.org Usertags: rebootstrap cultivation fails to cross build from source, because it does not pass any cross tools to make. The easiest way of doing so - using dh_auto_build - does not quite fix that, because cultivation uses

Bug#922515: python-xarray: Fix CRS being WKT instead of PROJ.4

2019-02-17 Thread Antonio Valentino
Source: python-xarray Version: 0.11.3-1 Severity: wishlist Dear Maintainer, as discussed in [1,2] it seems that some change in rasterio introduces some breakage in packages depending on it. IN particular I'm interested in the satpy package that started failing tests at the end of January [3].

Bug#922516: missing binary gtk-query-immodules-3.0

2019-02-17 Thread Jeremy Bicha
On Sun, Feb 17, 2019 at 8:51 AM Osamu Aoki wrote: > As I see the source package gtk+3.0-3.24.5/debian/libgtk-3-bin.install > is missing entry for usr/bin/gtk-query-immodules-3.0 > > This may be intentional since you may wish to make this in 64 and 32 bit > version. But not having any is buggy.

Bug#922519: ITP: ruby-data-uri -- URI::Data class for parsing RFC2397 data URIs

2019-02-17 Thread Utkarsh Gupta
Package: wnpp Severity: wishlist Owner: Utkarsh Gupta * Package name : ruby-data-uri Version : 0.1.0 Upstream Author : Donald Ball * URL : https://github.com/dball/data_uri * License : Expat Programming Lang : Ruby Description : URI::Data class

Bug#919831: Javadoc -link makes broken links if module name matches package name

2019-02-17 Thread tony mancill
On Fri, Feb 15, 2019 at 08:22:14PM +0100, Markus Koschany wrote: > Am 15.02.19 um 15:42 schrieb tony mancill: > [...] > > Any thoughts on whether we should focus on fixing javadoc generation or > > look at other ways to mitigate the FTBFS? > > Like burning all those -doc packages? :) > > In my

Bug#922522: ITP: waylandpp -- wayland compositor infrastructure - C++ development files

2019-02-17 Thread Balint Reczey
Package: wnpp Owner: Balint Reczey Severity: wishlist X-Debbugs-CC: debian-de...@lists.debian.org * Package name: waylandpp Version : 0.2.4 Upstream Author : Nils Brause * URL : https://github.com/NilsBrause/waylandpp * License : GPL-3+ Programming Lang: C++

Bug#922523: RFS: dav-text/0.8.9-1 - minimalist ncurses-based text editor

2019-02-17 Thread Adam Bilbrough
Package: sponsorship-requests Severity: normal Dear mentors, I am looking for a sponsor for my package "dav-text" Package name: dav-text Version: 0.8.9-1 Upstream Author : Adam Bilbrough URL: https://github.com/atsb/dav-text License: GPLv2 Section: text It builds those binary

Bug#922324: clojure breaks nrepl-clojure autopkgtest

2019-02-17 Thread Elana Hashman
On Thu, Feb 14, 2019 at 04:45:48PM +0100, Paul Gevers wrote: > autopkgtest [12:11:27]: test hello-nrepl: [--- > WARNING: requiring-resolve already refers to: > #'clojure.core/requiring-resolve in namespace: user, being replaced by: > #'nrepl.misc/requiring-resolve >

Bug#922535: tea FTCBFS: uses the wrong pkg-config

2019-02-17 Thread Helmut Grohne
Source: tea Version: 47.0.1-1 Tags: patch upstream User: helm...@debian.org Usertags: rebootstrap tea fails to cross build from source, because tea-qmake.pro hard codes "pkg-config" in a few places and thus uses the wrong pkg-config. The attached patch fixes that and makes tea cross buildable.

Bug#922534: lintian: Typo fixes

2019-02-17 Thread Guillem Jover
Package: lintian Version: 2.7.0 Severity: minor Hi! Here's a couple of patches I had sitting on my local lintian tree. Thanks, Guillem From af1af30e9973e7da6f59fec405611392d1bf2aaf Mon Sep 17 00:00:00 2001 From: Guillem Jover Date: Sun, 17 Feb 2019 20:28:53 +0100 Subject: [PATCH 1/2]

Bug#922516: missing binary gtk-query-immodules-3.0

2019-02-17 Thread Osamu Aoki
Package: src:gtk+3.0 Version: 3.24.5-1 Severity: normal What is the problem: gtk-query-immodules-3.0 binary should be packaged into libgtk-3-bin Please build it and add it to libgtk-3-bin.install I was trying to compile ibus and realized: | FAIL: ibus-compose | == | |

Bug#922500: tex-common: Fails to install with LC_TIME=en_DE.UTF-8

2019-02-17 Thread Norbert Preining
And by the way, quoting from your first message > LANG=C sudo aptitude > Warning: Invalid locale (please review locale settings, this might > lead to problems later): And it did. Best wishes On February 17, 2019 3:11:41 PM GMT+01:00, Norbert Preining wrote: >You set the locale for root

Bug#922353: ITP: socket-activate -- Run a socket-activated daemon with minimal dependencies

2019-02-17 Thread Peter Pentchev
On Sat, Feb 16, 2019 at 03:32:46PM +0100, Guillem Jover wrote: > Hi! > > On Fri, 2019-02-15 at 10:46:43 -0500, Daniel Kahn Gillmor wrote: > > Control: clone 922353 -2 > > Control: reassign -2 dpkg > > Control: retitle -2 start-stop-daemon should support socket-activation via > > the

Bug#919917: yui-compressor: insufficient java dependency in jessie

2019-02-17 Thread Markus Koschany
Contol: severity -1 normal On Mon, 21 Jan 2019 20:13:37 -0800 tony mancill wrote: > On Sun, Jan 20, 2019 at 06:14:31PM +0100, Andreas Beckmann wrote: > > Package: yui-compressor > > Version: 2.4.7-2 > > Severity: serious > > Tags: jessie > > User: debian...@lists.debian.org > > Usertags:

Bug#922516: missing binary gtk-query-immodules-3.0

2019-02-17 Thread Simon McVittie
On Sun, 17 Feb 2019 at 22:52:14 +0900, Osamu Aoki wrote: > gtk-query-immodules-3.0 binary should be packaged into libgtk-3-bin If it was in libgtk-3-bin, it would become misleading to mark libgtk-3-bin as Multi-Arch: foreign. On Debian, it's in libgtk-3-0, in a multiarch directory. Please add

Bug#921790: liquidsoap: FTBFS (ld: cannot find -lexif)

2019-02-17 Thread Kyle Robbertze
Hi, On 2019/02/17 11:52, Andrey Rahmatullin wrote: > On Sat, Feb 09, 2019 at 12:15:34AM +, Santiago Vila wrote: >> OCAMLOPT -o liquidsoap >> /usr/bin/ld: cannot find -lexif > libexif-dev is indeed not installed but my build fails even earlier: > > OCAMLOPT -c tools/file_watcher.ml > OCAMLOPT

Bug#913576: Update

2019-02-17 Thread bkw+1542031175
Hi Mattia, Unfortunately, I haven't heard anything from the Debian developers regarding this error. However, this morning, with adequate time and careful preparation, I decided to perform a reboot on this server. I'm very happy to report that the server booted successfully. So, it appears

Bug#922478: upgrade linux-image-4.9.0-8-armmp-lpae:armhf from 4.9.130-2 to 4.9.144-3 renders Bananapi and Lamobo R1 unbootable

2019-02-17 Thread Timo Sigurdsson
Hi, I've also been hit by this bug on two systems (both are Lemaker Bananapi). The first system upgraded the kernel via unattended-upgrades and failed to come up after reboot. I don't have a serial cable, but I did hook up the board to a HDMI display. U-Boot loads the kernel, dtb and initramfs

Bug#918578: gosa: GOsa web interface missing password field

2019-02-17 Thread Wolfgang Schweer
On Mon, Jan 14, 2019 at 03:43:26PM +, Holger Levsen wrote: > On Mon, Jan 14, 2019 at 05:15:59PM +0200, Eliza Ralph wrote: > > So are you saying it's not possible to fix GOsa in this case? > > it's not gosa that is broken but your php setup. After upgrading a Debian Edu main server (Stretch

Bug#921790: liquidsoap: FTBFS (ld: cannot find -lexif)

2019-02-17 Thread Andrey Rahmatullin
On Sun, Feb 17, 2019 at 04:58:58PM +0200, Kyle Robbertze wrote: > This is because version 1.0.1 of Camomile is in unstable. I am busy > packaging liquidsoap 1.3.4, which is compatible with newer versions of > Camomile and will fix both these issues. Please note the freeze policy. -- WBR, wRAR

Bug#922529: libtool: Emits warnings in very alarming bold red color

2019-02-17 Thread Guillem Jover
Package: libtool Version: 2.4.6-9 Severity: normal Hi! The libtool program emits warnings in bold red which is a very unexpected and confusing color for a warning (in contrast to an error), and it always triggers alarms when I see it scroll by, for example for: ,--- libtool: warning:

Bug#746426: Debian Bug#746426: marked as done (gcc: Enable -fasynchronous-unwind-tables on more arches.)

2019-02-17 Thread Kurt Roeckx
On Wed, Jan 23, 2019 at 07:54:57PM +0100, Kurt Roeckx wrote: > > But those pass at least run-backtrace-native: arm64, armel, armhf, > i386, ppc64el, s390x, powerpc, ppc64, sparc64 > > This means that for the arches we release for, mips* is the only > one that does not pass run-backtrace-native.

Bug#904462: RFS: uefitool/0.25.1-1 [ITP]

2019-02-17 Thread Andrey Rahmatullin
Thank you, uploaded. -- WBR, wRAR signature.asc Description: PGP signature

Bug#922477: postfix: FTBFS under Linux > 4

2019-02-17 Thread Scott Kitterman
Can you change: Linux.[34].*) SYSTYPE=LINUX$RELEASE_MAJOR to: Linux.[345].*) SYSTYPE=LINUX$RELEASE_MAJOR in makedefs and verify it builds and works (just a smoke test is fine) with your kernel? I'm having discussions with upstream about this and that would be helpful in moving things

Bug#922531: lintian: Please make package-uses-vendor-specific-patch-series Debian-archive specific

2019-02-17 Thread Guillem Jover
Package: lintian Version: 2.7.0 Severity: wishlist Hi! As the maintainer of dpkg, I do not agree at all (well I'd go as far as to consider them to be just bogus :) with the rationale and conclusions that were arrived to get the package-uses-vendor-specific-patch-series tag implemented. But the

Bug#921418: Kernel update from 4.18 to 4.19 breaks vlc (update)

2019-02-17 Thread Sebastian Ramacher
Control: reassign -1 linux 4.19.12-1 Hi Hartmut On 2019-02-16 12:00:15, Hartmut Buhrmester wrote: > The latest kernel update for stretch-backports seems to solve the problems > with vlc. This update was on Thu, Feb 14 2019. The logfile /var/log/aptitude > says: > > > Aptitude 0.8.7: log report

Bug#922478: upgrade linux-image-4.9.0-8-armmp-lpae:armhf from 4.9.130-2 to 4.9.144-3 renders Bananapi and Lamobo R1 unbootable

2019-02-17 Thread Timo Sigurdsson
Hi, Cyril Brulebois schrieb am 17.02.2019 19:38: > Hi folks, > > Jürgen Löb (2019-02-16): >> Package: linux-image-4.9.0-8-armmp-lpae >> Version: 4.9.144-3 >> Severity: serious >> >> Updated my Lamobo R1 board with apt update;apt upgrade >> >> After the update uboot is struck at "Starting

Bug#823892: fail2ban: very slow startup *and* shutdown

2019-02-17 Thread Antoine Beaupré
Control: tags -1 +confirmed I can confirm both bugs here. During the last upgrade, needrestart noticed fail2ban needed a restart, so it did. Here's what systemd sees right now: root@marcos:/home/anarcat# systemctl status fail2ban ● fail2ban.service - Fail2Ban Service Loaded: loaded

Bug#834331: test code fails and ignored for ibus

2019-02-17 Thread Osamu Aoki
control: retitle -1 build package with test fully enabled Test code issue summary: BASHISM: pushed -> comited patch to salsa master --enable-memconf -> ChromeOS feature I created branch to enable this and tagged it as memconf Still fails FAIL: ibus-compose FAIL: ibus-keypres

Bug#922516: missing binary gtk-query-immodules-3.0

2019-02-17 Thread Jeremy Bicha
On Sun, Feb 17, 2019 at 9:08 AM Jeremy Bicha wrote: > See https://salsa.debian.org/gnome-team/gtk3/commit/e447da62 Never mind. That commit is unrelated. Jeremy

Bug#907898: gmap: autopkgtest regression

2019-02-17 Thread Liubov Chuprikova
Hi Andreas, I have just found the easiest bug to solve :-) This one was solved in the very next version 2018-07-04-4 and since then the autopkgtest is passing everywhere [1]. With regards, Liubov [1] https://ci.debian.net/packages/g/gmap/

Bug#922517: libconfig-model-dpkg-perl: Doesn't know debhelper-compat

2019-02-17 Thread gregor herrmann
Package: libconfig-model-dpkg-perl Version: 2.121 Severity: normal -BEGIN PGP SIGNED MESSAGE- Hash: SHA512 Running `cme fix dpkg-control' in a package with 'debhelper-compat (= 12)' leads to: Connecting to api.ftp-master.debian.org to check debhelper-compat versions. Please wait... got

  1   2   3   >