Bug#780963: skydns ITP status?

2015-12-12 Thread Jelmer Vernooij
Hi Tim, How's the packaging of skydns going? Anything I can help with/test? Cheers, Jelmer signature.asc Description: PGP signature

Bug#809666: dovecot: Dovecot v2.2.21 released and code repository moved to Github

2016-01-02 Thread Jelmer Vernooij
severity 809666 wishlist thanks On Sat, Jan 02, 2016 at 05:09:56PM +0200, Guilhem Moulin wrote: > Furthermore the repository has moved to Github, so d/{control,watch} > should be updated accordingly. The URLs in debian/control refer to the debian packaging repository, not the upstream repository.

Bug#808769: [Pkg-samba-maint] Bug#808769: LDB build failure isn't a regression

2016-01-02 Thread Jelmer Vernooij
On Sun, Jan 03, 2016 at 10:38:12AM +1300, Andrew Bartlett wrote: > On Thu, 2015-12-31 at 18:53 +1300, Andrew Bartlett wrote: > > Just a quick note to say that the LDB build failure isn't a > > regression > > - whatever is going on here has always been going on, it just wasn't > > tested before

Bug#808769: [Pkg-samba-maint] Bug#808769: LDB build failure isn't a regression

2016-01-02 Thread Jelmer Vernooij
On Sat, Jan 02, 2016 at 09:51:34PM +, Jelmer Vernooij wrote: > On Sun, Jan 03, 2016 at 10:38:12AM +1300, Andrew Bartlett wrote: > > On Thu, 2015-12-31 at 18:53 +1300, Andrew Bartlett wrote: > > > Just a quick note to say that the LDB build failure isn't a > > > r

Bug#808769: [Pkg-samba-maint] Bug#808769: Bug#808769: Bug#808769: LDB build failure isn't a regression

2016-01-02 Thread Jelmer Vernooij
On Sun, Jan 03, 2016 at 11:36:18AM +1300, Andrew Bartlett wrote: > On Sat, 2016-01-02 at 22:22 +0000, Jelmer Vernooij wrote: > > On Sun, Jan 03, 2016 at 11:00:44AM +1300, Andrew Bartlett wrote: > > > On Sat, 2016-01-02 at 21:51 +0000, Jelmer Vernooij wrote: > > > > On S

Bug#808769: [Pkg-samba-maint] Bug#808769: Bug#808769: LDB build failure isn't a regression

2016-01-02 Thread Jelmer Vernooij
On Sun, Jan 03, 2016 at 11:00:44AM +1300, Andrew Bartlett wrote: > On Sat, 2016-01-02 at 21:51 +0000, Jelmer Vernooij wrote: > > On Sun, Jan 03, 2016 at 10:38:12AM +1300, Andrew Bartlett wrote: > > > On Thu, 2015-12-31 at 18:53 +1300, Andrew Bartlett wrote: > > >

Bug#800728: heimdal: Build unreliable with dh --parallel

2016-01-27 Thread Jelmer Vernooij
Hi Brian, Yes, this seems like a reasonable patch to send upstream. Jelmer On Thu, Jan 28, 2016 at 01:32:39PM +1100, Brian May wrote: > Jelmer, > > Do you think this is a patch that should go upstream? > > Regards > > > diff -Nru

Bug#814928: [Pkg-samba-maint] Bug#814928: updated patch

2016-02-24 Thread Jelmer Vernooij
Thanks for the patch; I've committed it to git, will upload later. Two small further comments: On Fri, Feb 19, 2016 at 11:03:05AM +0100, Matthias Klose wrote: > updated patch, the .install files need the x bit set. > * Build python3 packages. > * Bump debhelper and standards version. > *

Bug#812398: openldap: FTBFS: can't read /usr/lib/x86_64-linux-gnu/libhdb.la

2016-01-23 Thread Jelmer Vernooij
On Sun, Jan 24, 2016 at 11:44:53AM +1100, Brian May wrote: > Ryan Tandy writes: > > > Since the .la files moved from /usr/lib/$arch to /usr/lib/$arch/heimdal, > > looks like their contents also need to be updated. > > According to debian/changelog I deleted the *.la files in

Bug#812398: openldap: FTBFS: can't read /usr/lib/x86_64-linux-gnu/libhdb.la

2016-01-23 Thread Jelmer Vernooij
On Sun, Jan 24, 2016 at 11:44:53AM +1100, Brian May wrote: > Ryan Tandy writes: > > > Since the .la files moved from /usr/lib/$arch to /usr/lib/$arch/heimdal, > > looks like their contents also need to be updated. > > According to debian/changelog I deleted the *.la files in

Bug#814539: [Pkg-bazaar-maint] Bug#814539: bzrtools: Uninstallable with current sid bzr and python-bzrlib (2.7.0-2)

2016-02-15 Thread Jelmer Vernooij
On Fri, Feb 12, 2016 at 09:34:03PM +0100, Vincent Ladeuil wrote: > > Agustin Martin writes: > > > Package: bzrtools > > Version: 2.6.0-2 > > Severity: serious > > Justification: uninstallable in sid > > > Dear Maintainer, > > > Seems that

Bug#759010: [Pkg-samba-maint] Bug#759010: Bug#759010: samba: FTBFS on hurd-i386

2016-04-03 Thread Jelmer Vernooij
On Sun, Apr 03, 2016 at 06:53:51AM +0200, Mathieu Parent wrote: > On Sat, 23 Aug 2014 22:45:02 +0200 Jelmer Vernooij wrote: > > On Sat, Aug 23, 2014 at 02:49:59PM -0400, Manuel Menal wrote: > > > samba FTBFS on hurd-i386 because lib/tevent/testsuite.c uses PIPE_BUF > > >

Bug#815331: Still reproducible?

2016-04-03 Thread Jelmer Vernooij
severity 815331 important tags 815331 +moreinfo thanks Can you still reproduce this with current pypy? It doesn't segfault for me. signature.asc Description: PGP signature

Bug#820015: [Pkg-samba-maint] Bug#820015: Samba breaks with talloc 2.1.6

2016-04-04 Thread Jelmer Vernooij
On Tue, Apr 05, 2016 at 07:32:10AM +1200, Andrew Bartlett wrote: > Package: samba > Version: 2:4.3.6+dfsg-1 > > Samba will not provision if the new talloc 2.1.6 is packaged and > installed, due to a type mixup that is now checked for in the improved > python-talloc bindings. > > The patches for

Bug#820015: [Pkg-samba-maint] Bug#820015: Bug#820015: Samba breaks with talloc 2.1.6

2016-04-04 Thread Jelmer Vernooij
On Tue, Apr 05, 2016 at 09:45:15AM +1200, Andrew Bartlett wrote: > On Tue, 2016-04-05 at 09:36 +1200, Andrew Bartlett wrote: > > On Mon, 2016-04-04 at 21:15 +0000, Jelmer Vernooij wrote: > > > On Tue, Apr 05, 2016 at 07:32:10AM +1200, Andrew Bartlett wrote: > > > > Pac

Bug#820015: [Pkg-samba-maint] Bug#820015: Bug#820015: Samba breaks with talloc 2.1.6

2016-04-04 Thread Jelmer Vernooij
On Tue, Apr 05, 2016 at 09:36:39AM +1200, Andrew Bartlett wrote: > On Mon, 2016-04-04 at 21:15 +0000, Jelmer Vernooij wrote: > > On Tue, Apr 05, 2016 at 07:32:10AM +1200, Andrew Bartlett wrote: > > > Package: samba > > > Version: 2:4.3.6+dfsg-1 > > > >

Bug#820015: [Pkg-samba-maint] Bug#820015: Bug#820015: Samba breaks with talloc 2.1.6

2016-04-04 Thread Jelmer Vernooij
On Tue, Apr 05, 2016 at 09:36:39AM +1200, Andrew Bartlett wrote: > On Mon, 2016-04-04 at 21:15 +0000, Jelmer Vernooij wrote: > > On Tue, Apr 05, 2016 at 07:32:10AM +1200, Andrew Bartlett wrote: > > > Package: samba > > > Version: 2:4.3.6+dfsg-1 > > > >

Bug#823985: ITP: quasselc -- C Library for connecting to Quassel cores

2016-05-10 Thread Jelmer Vernooij
Package: wnpp Severity: wishlist Owner: "Jelmer Vernooij" <jel...@debian.org> * Package name: quasselc Version : 0.0.0 Upstream Author : Pierre-Hugues Husson <phhus...@gmail.com> * URL : https://github.com/phhusson/quasselc * License : GP

Bug#824240: ITP: python-onvif -- Python Client for ONVIF Cameras

2016-05-13 Thread Jelmer Vernooij
Package: wnpp Severity: wishlist Owner: "Jelmer Vernooij" <jel...@debian.org> * Package name: python-onvif Version : 0.1.1 Upstream Author : Cherish Chen <sinchb...@gmail.com> * URL : https://github.com/quatanium/python-onvif * License :

Bug#824238: python-coherence: fails comparing twisted versions

2016-05-13 Thread Jelmer Vernooij
Package: python-coherence Version: 0.6.6.2-8 Severity: normal With current version of python-coherence in Unstable, I get a traceback: Traceback (most recent call last): File "/usr/bin/upnp-inspector", line 23, in from coherence import __version__ as coherence_version File

Bug#750593: This bug prevents Samba including correct manpages

2016-05-02 Thread Jelmer Vernooij
On Sat, Apr 30, 2016 at 07:46:08PM +1200, Andrew Bartlett wrote: > Just a note to say that this bug prevents Samba from including correct > manpages. > > While the Samba Team provides pre-built manpages, those will not pick > up the path customisation performed by Debian. > > When xstlproc

Bug#821121: [Pkg-samba-maint] Bug#821121: Bug#821121: samba-libs: libsamba-debug.so unavailable

2016-04-15 Thread Jelmer Vernooij
On Sat, Apr 16, 2016 at 09:55:07AM +1200, Andrew Bartlett wrote: > On Fri, 2016-04-15 at 21:24 +0000, Jelmer Vernooij wrote: > > On Fri, Apr 15, 2016 at 08:15:11PM +0200, Benjamin Bouvier wrote: > > > Package: samba-libs > > > Version: 2:4.2.10+dfsg-0+deb8u

Bug#821121: [Pkg-samba-maint] Bug#821121: samba-libs: libsamba-debug.so unavailable

2016-04-15 Thread Jelmer Vernooij
On Fri, Apr 15, 2016 at 08:15:11PM +0200, Benjamin Bouvier wrote: > Package: samba-libs > Version: 2:4.2.10+dfsg-0+deb8u2 > Severity: important > > Dear Maintainer, > >* What led up to the situation? > The samba-libs package renders greyhole (redundant storage pooling using > Samba)

Bug#832880: [Pkg-samba-maint] Bug#832880: samba: Upgrade jessie => stretch

2016-07-29 Thread Jelmer Vernooij
On Fri, Jul 29, 2016 at 01:52:24PM +0200, louis van belle wrote: > Package: samba > Followup-For: Bug #832880 > > > > -- System Information: > Debian Release: 8.5 > APT prefers stable-updates > APT policy: (500, 'stable-updates'), (500, 'stable') > Architecture: amd64 (x86_64) > > Kernel:

Bug#830571: (no subject)

2016-07-09 Thread Jelmer Vernooij
sath...@debian.org Bcc: jel...@jelmer.uk Subject: Re: [Pkg-samba-maint] Bug#830571: samba: FTBFS on x32: Testsuite runs infinitely and consumes lots of CPU Reply-To: In-Reply-To:

Bug#832880: Reproduced

2016-08-01 Thread Jelmer Vernooij
Thanks, it looks like http://packages.debian.org/jessie/samba links to the wrong file list - despite the fact that http://packages.debian.org/jessie/samba covers the version in jessie-updates, the filelist links point to the contents in jessie itself, before updates. I've now removed the

Bug#829474: ITP: node-jstransformer -- Node library to normalize the API of any jstransformer

2016-07-03 Thread Jelmer Vernooij
Package: wnpp Severity: wishlist Owner: "Jelmer Vernooij" <jel...@debian.org> * Package name: node-jstransformer Version : 1.0.0 Upstream Author : Forbes Lindesay * URL : https://github.com/jstransformers/jstransformer * License : MIT

Bug#846099: ping

2017-01-31 Thread Jelmer Vernooij
Any news on this? There's a fair amount of (Russian) spam coming in daily that's quite annoying. signature.asc Description: PGP signature

Bug#836681: cmor: please depend on krb5-multidev | heimdal-multidev

2016-09-04 Thread Jelmer Vernooij
Source: cmor Severity: normal Dear Maintainer, cmor currently depends on heimdal-multidev. However, Heimdal is going to be removed from testing in the near future. See http://bugs.debian.org/834654 Please build-depend on krb5-multidev instead, or 'krb5-multidev | heimdal-multidev'. The only

Bug#806274: Heimdal now slated for removal from testing

2016-09-04 Thread Jelmer Vernooij
See https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=834654 signature.asc Description: PGP signature

Bug#836683: pike7.8-kerberos: please build-depend on libkrb5-multidev

2016-09-04 Thread Jelmer Vernooij
Package: pike7.8-kerberos Severity: normal Dear Maintainer, pike currently depends on heimdal-multidev. However, Heimdal is going to be removed from testing in the near future. See http://bugs.debian.org/834654 Please build-depend on libkrb5-multidev instead, or build-depend on 'krb5-multidev

Bug#837695: libpam-krb5-migrate: Removal of Heimdal from testing

2016-09-13 Thread Jelmer Vernooij
Package: libpam-krb5-migrate Severity: normal Dear Maintainer, Because of the state of upstream Heimdal, the package maintainers are planning to remove it from testing. Please rebuild your package against just MIT. -- System Information: Debian Release: stretch/sid APT prefers unstable-debug

Bug#820965: [Pkg-samba-maint] Bug#820965: marked as pending

2016-09-14 Thread Jelmer Vernooij
On Wed, Sep 14, 2016 at 11:51:14AM +0300, Vlad Orlov wrote: > Hi, > > I'd like to know if there's any progress on uploading the new > version to jessie-security. Just want to check if the update > would fix https://bugs.debian.org/831851 as well. See

Bug#795976: reopening 795976

2016-09-13 Thread Jelmer Vernooij
On Fri, Sep 09, 2016 at 12:04:09PM +0300, Dmitry Shachnev wrote: > Hi Jelmer, > > On Sun, May 15, 2016 at 06:29:21PM +0000, Jelmer Vernooij wrote: > > reopen 795976 > > thanks > > Should this bug be still open? > > Sphinx build should be reproducible. It

Bug#837724: libsasl2-modules-gssapi-heimdal: removal of heimdal from testing

2016-09-13 Thread Jelmer Vernooij
Package: libsasl2-modules-gssapi-heimdal Severity: normal FYI: Because of the state of upstream Heimdal, the Heimdal packagers are in the process of requesting the removal of Heimdal from testing. Please consider dropping the libsasl2-modules-gssapi-heimdal package. -- System Information: Debian

Bug#837728: RM: heimdal/1.7~git20150920+dfsg-4

2016-09-13 Thread Jelmer Vernooij
Package: release.debian.org Severity: normal User: release.debian@packages.debian.org Usertags: rm Please remove the heimdal source package from testing. As maintainers, we believe that Heimdal is not in a good enough state to be included in a stable release. There is still some activity in

Bug#836795: jessie-pu: package samba/2:4.1.17+dfsg-2+deb8u2

2016-10-08 Thread Jelmer Vernooij
On Sat, Sep 24, 2016 at 08:14:38PM +0100, Adam D. Barratt wrote: > Control: tags -1 -moreinfo +confirmed > > On Mon, 2016-09-05 at 20:50 +0000, Jelmer Vernooij wrote: > > I'd like to update Samba in jessie to 4.2.14+dfsg. Debdiff is attached. > > > > The 4 Samba relea

Bug#836795: jessie-pu: package samba/2:4.1.17+dfsg-2+deb8u2

2016-10-09 Thread Jelmer Vernooij
On Sun, Oct 09, 2016 at 10:34:55AM +0100, Adam D. Barratt wrote: > On Sun, 2016-10-09 at 00:16 +0000, Jelmer Vernooij wrote: > > On Sat, Sep 24, 2016 at 08:14:38PM +0100, Adam D. Barratt wrote: > > > Control: tags -1 -moreinfo +confirmed > > > > > > On Mo

Bug#837728: RM: heimdal/1.7~git20150920+dfsg-4

2016-10-02 Thread Jelmer Vernooij
Hi Emilio, On Sun, Oct 02, 2016 at 06:28:05PM +0200, Emilio Pozuelo Monfort wrote: > On 14/09/16 01:23, Jelmer Vernooij wrote: > > Package: release.debian.org > > Severity: normal > > User: release.debian@packages.debian.org > > Usertags: rm > > > > P

Bug#841869: unable to connect to headset

2016-10-23 Thread Jelmer Vernooij
Package: blueman Version: 2.1~alpha1-1 Severity: normal I can't connect to my headset via blueman, but can do so using e.g. command-line tools. The following error appears on stdout: Traceback (most recent call last): File "/usr/lib/python3/dist-packages/blueman/plugins/applet/RecentConns.py",

Bug#837724: Patch to drop Heimdal support

2016-10-18 Thread Jelmer Vernooij
The attached patch drops Heimdal support. commit 11ef3ad8ad7272ef6c8a2666460703be2340eb90 Author: Jelmer Vernooij <jel...@debian.org> Date: Tue Oct 18 14:16:47 2016 + Drop support for Heimdal. Closes: #837724 diff --git a/debian/changelog b/debian/changelog index 65a9e41..f7e62fd

Bug#845342: [Pkg-samba-maint] Bug#845342: samba-common-bin: nmblookup broken over routed connection?

2016-11-22 Thread Jelmer Vernooij
On Tue, Nov 22, 2016 at 05:17:09PM +0100, herrmann wrote: > Package: samba-common-bin > Version: 2:4.2.10+dfsg-0+deb8u3 > Severity: important > Tags: upstream > > Today we had the (very!) rare chance to restart all our windows 2012 domain > controllers and to apply all outstanding windows updates

Bug#845532: [Pkg-samba-maint] Bug#845532: cifs-utils: missing idmap-plugin symlink

2016-11-24 Thread Jelmer Vernooij
tags 845532 +upstream thanks On Thu, Nov 24, 2016 at 11:46:49AM +0100, Alessandro Larcher wrote: > getcifsacl (and setcifsacl) can't map SID to users/groups due to a missing > symlink > > ~ cd ~/mnt/cifs > ~ getcifsacl . > WARNING: unable to initialize idmapping plugin: >

Bug#845532: [Pkg-samba-maint] Bug#845532: cifs-utils: missing idmap-plugin symlink

2016-11-24 Thread Jelmer Vernooij
On Thu, Nov 24, 2016 at 11:46:49AM +0100, Alessandro Larcher wrote: > Package: cifs-utils > Version: 2:6.6-1 > Severity: normal Can you actually reproduce this with version 6.6? The RedHat bug suggests this was fixed in 6.2.

Bug#840188: jessie-pu: package tevent/0.9.25-0+deb8u1

2016-10-11 Thread Jelmer Vernooij
On Tue, Oct 11, 2016 at 09:15:22PM +0100, Adam D. Barratt wrote: > Control: tags -1 + confirmed > > On Sun, 2016-10-09 at 12:15 +0000, Jelmer Vernooij wrote: > > I would like to update tevent in jessie to 0.9.28. This is necessary, > > because the proposed version of Samba de

Bug#845335: bzr issue

2016-12-07 Thread Jelmer Vernooij
On Wed, Dec 07, 2016 at 05:47:52PM +, Ben Dooks wrote: > The "bzr: ERROR: exceptions.TypeError: first argument must be string or > compiled pattern" is still there after updating. > > bzr is already the newest version (2.7.0+bzr6619-1). This has been fixed. The latest version of bzr

Bug#847634: irssi-plugin-quassel: libquassel_core.so not in expected location

2016-12-10 Thread Jelmer Vernooij
On Sat, Dec 10, 2016 at 05:08:00AM +0100, Diederik de Haas wrote: > Package: irssi-plugin-quassel > Version: 0~git20160612-1 > Severity: grave > Justification: renders package unusable > > I followed the instructions from the README.md on github, but when I got > to the '/load quassel' part I got

Bug#834654: 7.0.1

2016-12-10 Thread Jelmer Vernooij
A brief update on this: a RC release has happened upstream, which is versioned "7.0.1". A stable release (which will be "7.1") is in the works, but may not make it before stretch. signature.asc Description: PGP signature

Bug#834654: Test failures

2016-12-10 Thread Jelmer Vernooij
I've uploaded a new Debian version to unstable packaging RC1. Unfortunately there are a test failures on various architectures. :( Note that not all of these are release architectures, and that make bails out once tests in one directory fail. Builders are still running, but so far I've seen:

Bug#837728: New Heimdal RC

2016-12-03 Thread Jelmer Vernooij
Just a quick update to this bug: some awesome people upstream (thanks!) have taken on the effort of getting another Heimdal release out. A RC has been pushed out, and hopefully a final 7 release will follow before the end of the year. Unfortunately, with the release schedule for Debian being

Bug#837728: Heimdal has done a new release

2017-01-06 Thread Jelmer Vernooij
Heimdal has done a new release, which has been packaged and will hopefully make it into stretch, rendering this removal request unnecessary. The only thing that's preventing its migration to testing at the moment is a regression in binutils on MIPS

Bug#849328: Patch submitted upstream

2017-01-07 Thread Jelmer Vernooij
tags 849328 +patch thanks I have sent the attached patch upstream, which resolves this issue. commit 372f1be5a78c447f7a827e87c2bf12ccf27cf5f0 Author: Jelmer Vernooij <jel...@jelmer.uk> Date: Sat Jan 7 19:28:39 2017 + Encode relative path to working tree in code paths when po

Bug#849135: heimdal: [INTL:de] Initial German translation of heimdal_krb5

2016-12-22 Thread Jelmer Vernooij
On Thu, Dec 22, 2016 at 10:01:57PM +0100, Chris Leick wrote: > Package: heimdal > Version: 1.7 > Severity: wishlist > Tags: l10n patch > > > Hi, > > please find attached the german translation of heimdal_krb5. > I've marked some typos in the englisch version with FIXME. Can you please forward

Bug#857643: heimdal-clients: Field "Description" should remove reference to telnet and ftp

2017-03-13 Thread Jelmer Vernooij
tags 857643 +confirmed thanks Yep! We'll do this for the next upload.

Bug#856982: ITP: litmus -- WebDAV server test suite

2017-03-06 Thread Jelmer Vernooij
Package: wnpp Severity: wishlist Owner: =?utf-8?q?Jelmer_Vernoo=C4=B3?= * Package name: litmus Version : 0.13 Upstream Author : Jelmer Vernooij

Bug#856843: [Pkg-samba-maint] Bug#856843: smbclient: connection flood to port 445 on mounting cifs volume under kernel 4.9.0

2017-03-05 Thread Jelmer Vernooij
On Sun, Mar 05, 2017 at 12:30:33PM +0100, nils wrote: > Package: smbclient > Version: 2:4.2.14+dfsg-0+deb8u2 > Severity: important > > Hello, > after upgrading my kernel from 4.0.8 to 4.0.9 I am getting connection floods > to > my FreeNAS samba server from my debian machine. I never had this

Bug#856511: ITP: xandikos -- CalDAV/CardDAV server backed by Git

2017-03-01 Thread Jelmer Vernooij
Package: wnpp Severity: wishlist Owner: Jelmer Vernooij <jel...@debian.org> * Package name: xandikos Version : 0.0.2 Upstream Author : Jelmer Vernooij <jel...@jelmer.uk> * URL : https://jelmer.uk/code/xandikos/ * License : GPL Programming

Bug#815333: Errors

2017-07-24 Thread Jelmer Vernooij
The test failures here are actually: ERROR: test_simple (dulwich.tests.test_porcelain.PushTests) -- Traceback (most recent call last): File "dulwich/tests/test_porcelain.py", line 478, in test_simple

Bug#855887: python3-parsedate in unstable

2017-07-19 Thread Jelmer Vernooij
FYI python3-parsedate has now made it to unstable. https://packages.debian.org/sid/python3-parsedatetime signature.asc Description: PGP signature

Bug#861626: [Pkg-samba-maint] Bug#861626: libpam-smbpass: Please add manpage for pam_smbpass.so

2017-05-01 Thread Jelmer Vernooij
On Mon, May 01, 2017 at 10:21:44PM +0200, Patrik Schindler wrote: > Package: libpam-smbpass > Version: 2:4.2.14+dfsg-0+deb8u5 > Severity: wishlist > > Please add a manpage for pam_smbpass, like with any other pam_*-modules. Thanks for the bug report. Please note that this is unlikely to happen,

Bug#873732: breezy: FTBFS on hurd-i386: many tests fail

2017-08-30 Thread Jelmer Vernooij
block 873732 by 190367 thanks On Wed, Aug 30, 2017 at 10:53:17AM -0400, Aaron M. Ucko wrote: > Source: breezy > Version: 3.0.0~bzr6772-1 > Severity: important > Tags: upstream > Justification: fails to build from source > > Thanks for quickly taking care of #873676. Breezy now builds without >

Bug#873291: sievec: always fails with the same error message and might be broken at all

2017-08-26 Thread Jelmer Vernooij
Hi Daniel, On Sat, Aug 26, 2017 at 10:18:46AM +0200, Daniel Leidert wrote: > Package: dovecot-sieve > Version: 1:2.2.27-3+deb9u1 > Severity: normal > > Hello, > > I recently updated my system to the new Debian stable. > > When I try to check my user .sieve files (~/.dovecot.sieve) after

Bug#873848: ITP: breezy-debian -- Breezy plugin for Debian package management

2017-08-31 Thread Jelmer Vernooij
Package: wnpp Severity: wishlist Owner: Jelmer Vernooij <jel...@debian.org> * Package name: breezy-debian Version : 3.0.0 Upstream Author : Breezy Developers * URL : https://launchpad.net/brz-debian * License : GPL Programming Lang: Python Descr

Bug#855887: Any news

2017-11-19 Thread Jelmer Vernooij
this very soon. You can > then help in reviewing and uploading to sid. Just give me one or two days more > :-). > > On 2017-11-19 09:12+, Jelmer Vernooij wrote: > > Hi Félix, > > > > I'm quite keen to see todoman in Debian. Is there anything I can do > > to help get

Bug#855887: Any news

2017-11-19 Thread Jelmer Vernooij
Hi Félix, I'm quite keen to see todoman in Debian. Is there anything I can do to help get it into sid? What's missing from the git packaging repo? It seem pretty complete already. Jelmer -- Jelmer Vernooij <jel...@jelmer.uk> PGP Key: https://www.jelmer.uk/D729A457.asc signatu

Bug#855887: Any news

2017-11-19 Thread Jelmer Vernooij
; > > Forgot the link: > > https://mentors.debian.net/debian/pool/main/t/todoman/todoman_3.2.4-1.dsc > > I just updated a new version which fixes a typo. Thanks! I'll review and barring any issues upload this week. Cheers, Jelmer -- Jelmer Vernooij <jel...@jelmer.uk> PGP Key: https://ww

Bug#855887: Any news

2017-11-21 Thread Jelmer Vernooij
; > > Forgot the link: > > https://mentors.debian.net/debian/pool/main/t/todoman/todoman_3.2.4-1.dsc > > I just updated a new version which fixes a typo. You should be receiving an email soon saying the package is in the NEW queue. Cheers, Jelmer -- Jelmer Vernooij <jel...@

Bug#855887: Any news

2017-11-21 Thread Jelmer Vernooij
On Tue, 2017-11-21 at 23:42 +0100, Félix Sipma wrote: > On 2017-11-21 22:17+0000, Jelmer Vernooij wrote: > > On Sun, Nov 19, 2017 at 10:59:40PM +0100, Félix Sipma wrote: > > > On 2017-11-19 22:45+0100, Félix Sipma wrote: > > > > On 2017-11-19 22:45+0100, Félix Sip

Bug#883743: bzr: FTBFS on armel

2017-12-06 Thread Jelmer Vernooij
On Wed, Dec 06, 2017 at 05:45:11PM -0800, Vagrant Cascadian wrote: > The last armel bzr build failed to build from source, and I've tried to > reproduce the issue unsuccessfully. > > > https://buildd.debian.org/status/fetch.php?pkg=bzr=armel=2.7.0%2Bbzr6622-9=1510195017=0 > > I tried building

Bug#883743: bzr: FTBFS on armel

2017-12-06 Thread Jelmer Vernooij
On Wed, Dec 06, 2017 at 05:45:11PM -0800, Vagrant Cascadian wrote: > Package: bzr > Version: 2.7.0+bzr6622-9 > Severity: serious > Tags: patch > > The last armel bzr build failed to build from source, and I've tried to > reproduce the issue unsuccessfully. > > >

Bug#580450: (no subject)

2017-12-08 Thread Jelmer Vernooij
I missing something? -- Jelmer Vernooij <jel...@jelmer.uk> PGP Key: https://www.jelmer.uk/D729A457.asc signature.asc Description: PGP signature

Bug#898591: lptools: Intent to remove from Debian

2018-05-14 Thread Jelmer Vernooij
On Sun, May 13, 2018 at 08:25:39PM -0400, Jeremy Bicha wrote: > Source: lptools > Version: 0.2.0-2 > Severity: serious > User: pkg-gnome-maintain...@lists.alioth.debian.org > Usertags: oldlibs pygtk > Tags: sid buster > X-Debbugs-CC: x...@debian.org, jel...@debian.org > > lptools depends on the

Bug#907587: CONTENT_LENGTH can no longer be empty

2018-09-05 Thread Jelmer Vernooij
Git's http-backend has become slightly stricter about the content of the CONTENT_LENGTH variable. Previously, Dulwich would leave this variable empty but git now expects it to be set to 0 for GET requests without a body. I'm uploading a fixed version of dulwich. -- Jelmer Vernooij PGP Key

Bug#911016: ITP: lintian-brush -- automatically fix some lintian issues

2018-10-14 Thread Jelmer Vernooij
Package: wnpp Severity: wishlist Owner: Jelmer Vernooij * Package name: lintian-brush Version : 0.1 Upstream Author : Jelmer Vernooij * URL : https://salsa.debian.org/jelmer/lintian-brush * License : GPLv2 or later Programming Lang: Python Description

Bug#912219: lintian-brush: Missing dependency on python3-dulwich, and more

2018-10-29 Thread Jelmer Vernooij
On Mon, Oct 29, 2018 at 01:34:23PM +0100, gregor herrmann wrote: > Thanks for writing lintian-brush, this looks really helpful. But > currently it has its quirks: Thanks for the detailed bug report, much appreciated. I hope to fix most of these issues in the upcoming upload. Cheers, Jelmer

Bug#912219: lintian-brush: Missing dependency on python3-dulwich, and more

2018-10-30 Thread Jelmer Vernooij
On Tue, Oct 30, 2018 at 02:56:38PM +0100, gregor herrmann wrote: > On Tue, 30 Oct 2018 00:42:42 +0000, Jelmer Vernooij wrote: > > > On Mon, Oct 29, 2018 at 01:34:23PM +0100, gregor herrmann wrote: > > > Thanks for writing lintian-brush, this looks really helpful. But >

Bug#912705: ITP: wsgiproxy2 -- A WSGI Proxy with various http client backends

2018-11-02 Thread Jelmer Vernooij
Package: wnpp Severity: wishlist Owner: Jelmer Vernooij * Package name: wsgiproxy2 Version : 0.4.5 Upstream Author : Gael Pasgrimaud * URL : https://github.com/gawel/WSGIProxy2/ * License : MIT Programming Lang: Python Description : A WSGI Proxy

Bug#912708: ITP: aiowsgi -- minimalist WSGI server implementation using async

2018-11-02 Thread Jelmer Vernooij
Package: wnpp Severity: wishlist Owner: Jelmer Vernooij * Package name: aiowsgi Version : 0.0.7 Upstream Author : Gael Pasgrimaud * URL : https://github.com/gawel/aiowsgi * License : MIT Programming Lang: Python Description : minimalist WSGI server

Bug#912698: yowsup-cli: website link mentioned in manpage broken

2018-11-02 Thread Jelmer Vernooij
Package: yowsup-cli Version: 2.5.7-4 Severity: minor Dear Maintainer, The first website mentioned in the yowsup-cli manpage (the mcclist one) no longer contains a mcclist, but just spam for bitcoin. -- System Information: Debian Release: buster/sid APT prefers unstable-debug APT policy:

Bug#913771: syncthing-gtk: unsatisfiable dependency on non-existent gir-1.2-glib-2.0

2018-11-14 Thread Jelmer Vernooij
Hi Steve, On Wed, Nov 14, 2018 at 03:16:32PM -0800, Steve Langasek wrote: > The syncthing-gtk package is uninstallable, because it depends on > gir-1.2-glib-2.0, which does not exist. The correct spelling of this > package name is gir1.2-glib-2.0. Please find a patch attached. Argh, that was

Bug#914464: Any update?

2019-01-21 Thread Jelmer Vernooij
On Mon, Jan 21, 2019 at 05:08:15PM +0100, Filip Pytloun wrote: > any update with this package? > I would need it to build newer vdirsyncer. I've just uploaded to NEW. -- Jelmer Vernooij PGP Key: https://www.jelmer.uk/D729A457.asc signature.asc Description: PGP signature

Bug#915977: (no subject)

2018-12-10 Thread Jelmer Vernooij
cont...@bugs.debian.org Bcc: jel...@jelmer.uk Subject: Re: Bug#915977: lintian-brush: option to print modifications without applying them to files Reply-To: In-Reply-To: <9d70da4ecbe32df4fd4ea3b1bfa0cc56b593ced3.ca...@debian.org> tags 915977 +confirmed thanks On Sun, Dec 09, 2018 at 10:25:37AM

Bug#914488: git breaks xandikos autopkgtest

2018-11-23 Thread Jelmer Vernooij
very surprised if this is related to the Git update. Digging a little bit further, this appears to be due to the wonky way that signals are handled in python and so in some cases SIGTERM just appears to end up printing the SystemExit traceback rather than actually exiting. Fix coming up. -- Jelm

Bug#913037: (no subject)

2018-11-19 Thread Jelmer Vernooij
retitle 913037 "test dulwich.tests.test_porcelain.PushTests.test_simple contains race condition" thanks This is not a python3.7-specific issue, but a test that contains a race condition that means it occasionally fails. This is reproducible on other python versions as well (when running the test

Bug#918723: "ERROR: TypeError: a bytes-like object is required, not 'str'" on committing

2019-01-08 Thread Jelmer Vernooij
tags 918723 +confirmed tags 918723 +upstream thanks Hi Martin, On Tue, Jan 08, 2019 at 07:52:38PM +0100, Martin Steigerwald wrote: > File "/usr/lib/python3/dist-packages/breezy/bzr/pack_repo.py", line 883, in > autopack > return self._do_autopack() > File

Bug#921971: lintian-brush: fixer for out-of-date-standards-version

2019-02-11 Thread Jelmer Vernooij
Hi Dmitry, Thanks for the patch. On Sun, Feb 10, 2019 at 07:08:50PM +, Dmitry Bogatov wrote: > diff --git a/fixers/out-of-date-standards-version.sh > b/fixers/out-of-date-standards-version.sh > new file mode 100755 > index 000..d8cda66 > --- /dev/null > +++

Bug#921870: lintian-brush: generate QA upload string

2019-02-11 Thread Jelmer Vernooij
On Sat, Feb 09, 2019 at 04:36:56PM +, Dmitry Bogatov wrote: > > Package: lintian-brush > Version: 0.11 > Severity: wishlist > > Dear Maintainer, > > please consider making `lintian-brush' to add 'QA upload' entry into > changelog if package is QA maintained. Thanks for the bugreport. I

Bug#921972: lintian-brush: when d/compat is missing

2019-02-10 Thread Jelmer Vernooij
On Sun, Feb 10, 2019 at 07:08:52PM +, Dmitry Bogatov wrote: > please consider following patch to avoid warnings, when there is no > `debian/compat'. Thanks for the patch! Applied in master. > By the way, it is quite unfortunate, that fixer API disallow early > sys.exit(0). Agreed, that would

Bug#921972: lintian-brush: when d/compat is missing

2019-02-10 Thread Jelmer Vernooij
On Mon, Feb 11, 2019 at 12:14:41AM +, Jelmer Vernooij wrote: > On Sun, Feb 10, 2019 at 07:08:52PM +, Dmitry Bogatov wrote: > > By the way, it is quite unfortunate, that fixer API disallow early > > sys.exit(0). > Agreed, that would be good to fix. A workaround is t

Bug#921971: (no subject)

2019-02-15 Thread Jelmer Vernooij
control: tags -1 -wontfix I don't think this should be wontfix. This is not impossible to address, but not as simple as the current patch suggests. E.g. looking at the upgrade checklist in policy (https://www.debian.org/doc/debian-policy/upgrading-checklist.html), a quick glance shows that the

Bug#921241: uses wrong author and committer for git commits

2019-02-04 Thread Jelmer Vernooij
o that for git repositories the logic used is: * $GIT_NAME <$GIT_EMAIL> * .git/config * ~/.gitconfig * ~/.config/breezy/breezy.conf * gecos <$USER@$HOST> -- Jelmer Vernooij PGP Key: https://www.jelmer.uk/D729A457.asc signature.asc Description: PGP signature

Bug#927685: Downgrading to normal

2019-04-21 Thread Jelmer Vernooij
severity 927685 normal thanks Downgrading this to normal, since it only affects the 'contrib' scripts shipped with klaus. Klaus itself works well without distutils.