Bug#823140: RFS: caffe/1.0.0~rc3-1 -- a deep learning framework [ITP]

2016-06-03 Thread Mo Zhou
Hi, I've updated the caffe package in the git repo, one of the major changes is that `python-caffe-cpu` was changed to `python3-caffe-cpu`. On 2 June 2016 at 07:00, Ghislain Vaillant wrote: > > > The build time testsuite, autopkgtest and piuparts serve different > purposes.

Bug#826528: ITP: lua-torch-cwrap/0~20160222-gdbd0a62 -- CWrap package for Torch Framework

2016-06-05 Thread Mo Zhou
Package:wnpp Severity: wishlist Owner: lumin * Package name: lua-torch-cwrap Version : 0~20160222-gdbd0a62 Upstream Author : Torch Developers * URL : https://github.com/torch/cwrap * License : BSD-3-Clause

Bug#826529: ITP: lua-torch-paths/0~20160203-g68d579a -- Filename Manipulation Package for Torch Framework

2016-06-05 Thread Mo Zhou
Package:wnpp Severity: wishlist Owner: lumin * Package name: lua-torch-paths Version : ​ 0~20160203-g68d579a Upstream Author : Torch Developers * URL : https://github.com/torch/ ​paths​ * License : BSD-3-Clause

Bug#826532: ITP: lua-torch-torch7/0~20160604-g69d7a01 -- Torch Package for Torch Framework

2016-06-05 Thread Mo Zhou
Package:wnpp Severity: wishlist Owner: lumin * Package name: lua-torch-torch7 Version : 0~20160604-g69d7a01 Upstream Author : Torch Developers * URL : https://github.com/torch/ ​torch7 * License : BSD-3-Clause

Bug#906265: RFH: julia -- ppc64el port of Julia language and LLVM-6.0

2018-08-16 Thread Mo Zhou
Package: wnpp Severity: normal I request assistance with maintaining the julia package. Specifically I need a ppc64el porter (or anyone who has root access to a ppc64el box) to help me: 1. Apply patch[1] to Debian's llvm-toolchain-6.0 (= 1:6.0.1-4) and build it. 2. Install the resulting

Bug#907475: false-positive "source-is-missing" error

2018-08-28 Thread Mo Zhou
Package: lintian Version: 2.5.98 Severity: normal Justification: lintian requests a bug report I got the following lintian E while building the source package for tensorflow. The false-positive is requested by the lintian message. This lintian report can be reproduced from this git repo:

Bug#783307: ITP: fzf -- General-purpose command-line fuzzy finder

2018-08-27 Thread Mo Zhou
Hi Tom, Have you found any sponsor for the fzf package? And are you still interested in maintaining it? > https://github.com/tomfitzhenry/pkg-fzf Best,

Bug#907040: ITP: vim-julia -- vim support for julia language

2018-08-23 Thread Mo Zhou
Package: wnpp Severity: wishlist Owner: Mo Zhou * Package name: vim-julia Version : 0.0~git20180821.120a0b6 Upstream Author : Carlo Baldassi and other contributors * URL : https://github.com/JuliaEditorSupport/julia-vim * License : Expat Programming Lang

Bug#907389: ITP: pscircle -- visualizing Linux processes in a form of radial tree

2018-08-30 Thread Mo Zhou
control: retitle -1 RFP: pscircle -- visualizing Linux processes in a form of radial tree control: owner -1 wnpp.debian.org This software looks not quite mature at the time of ITP submission.

Bug#907192: pre-RFS: tensorflow/1.10.0+dfsg-A1 [ITP] -- debian archve += 1 million lines of code

2018-09-05 Thread Mo Zhou
> Currently I can build it manually on my daily Debian experimental > system (amd64) and another unclean chroot (amd64). However I'm > still not sure whether the other can build it successfully like I do. Preliminary lintian-clean binary packages are available on debomatic-amd64:

Bug#896970: RFS: odp/1.19.0.0-1 [ITP]

2018-09-05 Thread Mo Zhou
Hi Dmitry, Thanks for the update! On Fri, Aug 31, 2018 at 03:41:01PM +0300, Dmitry Eremin-Solenikov wrote: > Hello, > > I've uploaded new 1.19.0.2-1 version to mentors.d.o. > I've added manpages, fixed copyright info, fixed alternatives > and enabled auto-tests. Could you please review it?

Bug#907192: need help on the very last blocker (Re: RFS: tensorflow/1.10.0+dfsg-A1 [ITP]

2018-09-07 Thread Mo Zhou
Hi mentors, Does anyone have idea about the following very last blocker for libtensorflow? We are really ready to upload TF once the C API unit tests passed without fatal error. procedure to reproduce:: 1. download libtensorflow-cc1.10 and libtensorflow-dev from debomatic-amd64 and

Bug#874305: RFS: mitlm/0.4.2-1 -- MIT Language Modeling toolkit

2018-09-09 Thread Mo Zhou
On Sun, Sep 09, 2018 at 12:25:54PM +0200, Giulio Paci wrote: > Hi Mo, >    thank you for your offer and review. > Unfortunately I do not know when I will be able to handle these issues as I > have very limited time at the moment. > > And the latest standards version is 4.2.1 . > > As you can

Bug#874305: RFS: mitlm/0.4.2-1 -- MIT Language Modeling toolkit

2018-09-08 Thread Mo Zhou
control: owner -1 ! control: tags -1 +moreinfo Hi Giulio, I can sponsor this package. However this package looks old and needs updating before the upload. 1. please have a look and fix the following lintian warnings: - │ W: mitlm

Bug#907192: pre-RFS: tensorflow/1.10.0+dfsg-A1 [ITP] -- debian archve += 1 million lines of code

2018-09-04 Thread Mo Zhou
control: retitle -1 RFS: tensorflow/1.10.1+dfsg-A1 [ITP] control: tag -1 -moreinfo Hello science team and mentors, I did a right choice to write the python+ninja build system from scratch (I call this build system TF-Shogun in the source code). Now I started to sort out any possible FTBFS with

Bug#908106: dpkg ignores ASCII file named *.so when building source package

2018-09-06 Thread Mo Zhou
Package: dpkg Version: 1.19.0.5+b1 Severity: normal Justification: triggers confusing FTBFS under a certain condition Procedure to reproduce: 1. clone https://salsa.debian.org/science-team/tensorflow 2. checkout lumin/A1u30 or equivalently a2d2212c63bc23ada20bef0eeb6284e6f3a022ec 3. build

Bug#907192: [done] Re: RFS: tensorflow/1.10.0+dfsg-A1 [ITP]

2018-09-08 Thread Mo Zhou
control: close -1 I'll sponsor myself shortly as long as nothing goes wrong in the last build. This will be an ~300MB initial upload. On Fri, Sep 07, 2018 at 01:23:03PM +, Mo Zhou wrote: > Hi mentors, > > Does anyone have idea about the following very last blocker for libtensorf

Bug#890379: RFS: python-jsonrpc/1.10.8-1 [ITP]

2018-09-08 Thread Mo Zhou
control: owner -1 ! Hi Ghislain, I can sponsor this now. Should wait for you to update the package to the latest upstream verison, or check and upload it from git repo as is? I think the packaging repo is this one: https://salsa.debian.org/python-team/modules/python-jsonrpc BTW, why don't you

Bug#907791: lua-moses breaks lua-torch-nn autopkgtest

2018-09-11 Thread Mo Zhou
control: close -1 Justification: not a bug. I'm aware of the breakage before uploading lua-moses to unstable since the affected packages are maintained by me. This is not a regression in lua-moses but simply an API bump. I'll deal with lua-torch-nn soon, by updating it's function calls related

Bug#905826: libjulia depends on libblas.so.3 instead of openblas?

2018-10-12 Thread Mo Zhou
Control: tag -1 +pending -wontfix Hi Milan, Things have changed a bit since I submitted this bug. The 1.0.1-1 package waiting in NEW queue is linked against libblas.so.3 (which is a symlink pointing to openblas). The dependency of the resulting package can be satisfied by installing any package

Bug#910924: ILP64 interface of openblas?

2018-10-13 Thread Mo Zhou
Package: julia Version: 1.0.1-2 Hi Sebastien, do you have any plan to add ILP64 interface to OpenBLAS? I acknowledge that bumping BLAS interface from LP64 to ILP64 is really a hardwork under Debian's context, and will take a long time to transit. If there is not much necessity to provide ILP64

Bug#910837: RFS: mle/1.2-1 [ITP] -- flexible terminal-based text editor (C)

2018-10-14 Thread Mo Zhou
t; https://github.com/adsr/mle/tree/debian Oops. Thanks for the hint. Then you should put it to the Vcs-Git and Vcs-Browser fields in debian/control. > Thanks for the tip about the "Recommends" field. I will add optional > runtime deps there. > > Adam > > On

Bug#845585: only "m" (for manpage) works in "?" menu (ranger)

2018-10-14 Thread Mo Zhou
Control: tag -1 +moreinfo Hi Yaroslav, I think this bug has been fixed already. At least I cannot reproduce this issue with the latest 1.9.2-1 version (uploaded several hours ago) May I close this bug?

Bug#878121: ILP64 interface of openblas?

2018-10-21 Thread Mo Zhou
and ILP64 interface I will send a RFC proposal about the NEW ILP64 interface on science list. [1] you can find it on salsa under science-team's namespace On Fri, Oct 19, 2018 at 10:18:53AM +0200, Sébastien Villemot wrote: > Hi, > > Le samedi 13 octobre 2018 à 13:22 +, Mo Zho

Bug#911277: ITP: termbox -- Library for writing text-based user interfaces

2018-10-17 Thread Mo Zhou
Package: wnpp Severity: wishlist Owner: Mo Zhou * Package name: termbox Version : 1.1.2+dfsg Upstream Author : nsf * URL : https://github.com/nsf/termbox * License : Expat Programming Lang: C, Python Description : Library for writing text-based user

Bug#911282: [gmp/patch] Raise SIGFPE instead of SIGABRT as long as possible

2018-10-18 Thread Mo Zhou
Package: libgmp-dev Version: 2:6.1.2+dfsg-3 Severity: important Tag: patch Justification: affects Julia's functionality on non-x86 arches This patch is cherry-picked from upstream repo: https://gmplib.org/repo/gmp/rev/c59c3879f982 Related discussions:

Bug#910837: RFS: mle/1.2-1 [ITP] -- flexible terminal-based text editor (C)

2018-10-11 Thread Mo Zhou
Hi Adam, Thanks for this package, the copyright file looks good to me. However there are still a couple of problems: 1. Can we avoid shipping with embedded code copy[1] of lua, termbox and uthash? . lua 5.3 and uthash are already in the archive. termbox needs to be packaged. 2. I'd

Bug#911131: Raising OpenBLAS's priority to 100 in the alternatives system

2018-10-16 Thread Mo Zhou
Package: libopenblas-dev Version: 0.3.3+ds-1 Severity: wishlist Hi Sebastien, The range between priority numbers of OpenBLAS and Atlas is a bit narrow. I think it isn't enough for furture usage when BLIS landed onto the archive, especially when we wanted to provide libraries in different

Bug#910837: RFS: mle/1.2-1 [ITP] -- flexible terminal-based text editor (C)

2018-10-17 Thread Mo Zhou
On Sat, Oct 13, 2018 at 06:03:48PM -0400, a...@php.net wrote: > Yes, I can make Lua and uthash package deps instead of embedding them. > Is it ok to embed termbox for now, or should we consider that a > blocker? Try to build against this termbox package, it's almost finished:

Bug#911698: ITS: tbb

2018-10-23 Thread Mo Zhou
Package: libtbb-dev Version: 2017~U7-8 Severity: important X-Debbugs-CC: steven.cap...@gmail.com, debian-science-maintain...@lists.alioth.debian.org, debian-scie...@lists.debian.org tbb packaging repo is hosted under debian-science team's namespace on Salsa. However the maintainer is not set

Bug#911698: ITS: tbb

2018-10-24 Thread Mo Zhou
On Tue, Oct 23, 2018 at 08:42:31PM +0100, Steven Capper wrote: > Hi Mo, > I maintain the package and we had it hosted on Debian Science. I would > like to keep maintaining the package, but I am happy to co-maintain > the package with others. Thank you for the quick reply. I'm happy to co-maintain

Bug#911813: use ptrdiff_t as the type of size instead of int

2018-10-24 Thread Mo Zhou
Package: libdsfmt-dev Version: 2.2.3+dfsg-3 Severity: important https://salsa.debian.org/julia-team/julia/blob/master/deps/patches/dSFMT.c.patch https://salsa.debian.org/julia-team/julia/blob/master/deps/patches/dSFMT.h.patch This change is similar to changes about BLAS's 64-bit-index version.

Bug#911807: ITP: rover -- text-based light-weight frontend for update-alternatives

2018-10-24 Thread Mo Zhou
Package: wnpp Severity: wishlist * Package name: rover Version : 0.1 Upstream Author : myself * URL : https://salsa.debian.org/debian/rover * License : GPL-3+ Programming Lang: Python Description : text-based light-weight frontend for

Bug#911946: rc-status: double free or corruption (!prev)

2018-10-26 Thread Mo Zhou
Package: openrc Version: 0.38-2 Severity: serious On my amd64 virtual machine rc-status failes every time I run it. Some times it just reports double free or corruption (!prev) And sometimes it reports malloc(): smallbin double linked list corrupted I think this is 100% reproducible by

Bug#893189: llvm-defaults to llvm-7 ? [was: Re: Bug#893189: transition: llvm-defaults to llvm 6.0]

2018-10-28 Thread Mo Zhou
Hi Sylvestre, F.Y.I. > * llvm 6.0 upstream won't have a new upstream release * I have been > focusing my Debian effort on 7 for a while, so, packaging is a much > better shape Julia upstream backported many patches from llvm-7 to their vendored llvm-6 source. However it's llvm-7 support is

Bug#839921: zfs-linux: Please add Conflicts to support easier migration

2018-10-26 Thread Mo Zhou
control: tags -1 -patch +moreinfo Hi Antonio, I cannot find the patch anymore. Do we still need to fix the ZoL upstream deb -> Debian deb transition problem?

Bug#911813: use ptrdiff_t as the type of size instead of int

2018-10-25 Thread Mo Zhou
control: close -1 This is a fake bug. Patches are already applied by Peter 3 years ago.

Bug#862524: RFP: nvidia-cudnn/6.0 -- NVIDIA CUDA Deep Neural Network library

2018-10-25 Thread Mo Zhou
control: retitle -1 RFP: nvidia-cudnn -- NVIDIA CUDA Deep Neural Network library control: owner -1 w...@debian.org control: close 887728 I'm no longer interested in reading Nvidia's license. Packaging scripts are avaialble on Salsa.

Bug#911830: FTBFS on multiple architectures

2018-10-25 Thread Mo Zhou
Package: python3-sklearn Version: 0.20.0+dfsg-1 Severity: serious https://buildd.debian.org/status/package.php?p=scikit-learn

Bug#913618: ITP: zsh-autosuggestions -- Fish-like autosuggestions for zsh

2018-11-12 Thread Mo Zhou
Package: wnpp Severity: wishlist Owner: lu...@debian.org * Package name: zsh-autosuggestions Version : 0.4.3 Upstream Author : Thiago de Arruda, Eric Freese * URL : https://github.com/zsh-users/zsh-autosuggestions * License : Expat Programming Lang: zsh

Bug#909497: CUDA 10 available now

2018-11-15 Thread Mo Zhou
control: tags -1 +moreinfo Please hold on the CUDA version for a while. Some important applications are still not fully ready for CUDA 10. Since recently Nvidia started to produce buggy software and buggy hardware, I think we should slow down our pace and only update CUDA when necessary, or when

Bug#910181: RFA: fortune-zh

2018-10-03 Thread Mo Zhou
Package: wnpp Severity: normal I plan to drop this package after releasing

Bug#910172: RFA: lua-torch-paths

2018-10-03 Thread Mo Zhou
Package: wnpp Severity: normal LuaTorch has been deprecated by upstream and

Bug#910170: RFA: lua-torch-sys

2018-10-03 Thread Mo Zhou
Package: wnpp Severity: normal LuaTorch has been deprecated by upstream and

Bug#910174: RFA: lua-torch-nngraph

2018-10-03 Thread Mo Zhou
Package: wnpp Severity: normal LuaTorch has been deprecated by upstream and

Bug#910167: RFA: lua-torch-xlua

2018-10-03 Thread Mo Zhou
Package: wnpp Severity: normal LuaTorch has been deprecated by upstream and I'm moving to Pytorch. I cannot maintain more than 3 deep learning frameworks at the same time, so I wish someone to take over the maintenance.

Bug#910175: RFA: lua-torch-nn

2018-10-03 Thread Mo Zhou
Package: wnpp Severity: normal LuaTorch has been deprecated by upstream and

Bug#910173: RFA: lua-torch-optim

2018-10-03 Thread Mo Zhou
Package: wnpp Severity: normal LuaTorch has been deprecated by upstream and

Bug#910168: RFA: lua-torch-trepl

2018-10-03 Thread Mo Zhou
Package: wnpp Severity: normal LuaTorch has been deprecated by upstream and I'm moving to Pytorch. I cannot maintain more than 3 deep learning frameworks at the same time, so I wish someone to take over the maintenance.

Bug#910171: RFA: lua-torch-sundown

2018-10-03 Thread Mo Zhou
Package: wnpp Severity: normal LuaTorch has been deprecated by upstream and

Bug#910164: RFA: lua-torch-cutorch

2018-10-03 Thread Mo Zhou
Package: wnpp Severity: normal LuaTorch has been deprecated by upstream and I'm moving to Pytorch. I cannot maintain more than 3 deep learning frameworks at the same time, so I wish someone to take over the maintenance.

Bug#910166: RFA: meta-torch-core-free

2018-10-03 Thread Mo Zhou
Package: wnpp Severity: normal LuaTorch has been deprecated by upstream and I'm moving to Pytorch. I cannot maintain more than 3 deep learning frameworks at the same time, so I wish someone to take over the maintenance.

Bug#910169: RFA: lua-torch-torch7

2018-10-03 Thread Mo Zhou
Package: wnpp Severity: normal LuaTorch has been deprecated by upstream and I'm moving to Pytorch. I cannot maintain more than 3 deep learning frameworks at the same time, so I wish someone to take over the maintenance.

Bug#910177: RFA: lua-torch-graph

2018-10-03 Thread Mo Zhou
Package: wnpp Severity: normal LuaTorch has been deprecated by upstream and

Bug#910176: RFA: lua-torch-image

2018-10-03 Thread Mo Zhou
Package: wnpp Severity: normal LuaTorch has been deprecated by upstream and

Bug#910180: RFA: lua-moses

2018-10-03 Thread Mo Zhou
Package: wnpp Severity: normal LuaTorch has been deprecated by upstream and

Bug#910178: RFA: lua-torch-dok

2018-10-03 Thread Mo Zhou
Package: wnpp Severity: normal LuaTorch has been deprecated by upstream and

Bug#910179: RFA: lua-torch-cwrap

2018-10-03 Thread Mo Zhou
Package: wnpp Severity: normal LuaTorch has been deprecated by upstream and

Bug#892415: NVCC 9.1 + GCC-8 workaround

2018-09-29 Thread Mo Zhou
Hi anbe and nvidia team, During debconf Ximin and I have figured out a workaround to make NVCC work with GCC-8. Using this workaround I have successfully compiled src:caffe-contrib. CXXFLAGS += -std=c++03 -D__GNUC__=8 We need to make GCC-8 disguise to be GCC-6, and downgrade CXX standard to

Bug#909793: RFS: intel-mkl/2019.0.117-2~bpo9+1 [NEW,stable-backports]

2018-09-28 Thread Mo Zhou
requirement to (>= 3.5) + * Downgrade debhelper compat level to 10. + * Enable control.bpo.py script in rules. + * Backport to stretch. + + -- Mo Zhou Tue, 25 Sep 2018 08:19:29 + + intel-mkl (2019.0.117-2) unstable; urgency=medium * Export HOME=/tmp/ to fix FTBFS due to the failure that rpm

Bug#909457: ITP: blis -- BLAS-like Library Instantiation Software Framework

2018-09-24 Thread Mo Zhou
Package: wnpp Severity: wishlist X-Debbugs-CC: debian-scie...@lists.debian.org Owner: Mo Zhou * Package name: blis Version : 0.4.1 Upstream Author : The University of Texas at Austin, HP Enterprise, AMD Inc. * URL : https://github.com/flame/blis * License

Bug#909406: [regression] GCC-8 failed to compile Julia on armhf while GCC-7 worked.

2018-09-22 Thread Mo Zhou
Package: gcc-8 Version: 8.2.0-7 Severity: important This happend on our buildd and Ubuntu buildfarm, and I reproduced it in my qemu-armhf chroot: qemu: Unsupported syscall: 385 Invalid Thumb instruction at 0xff5ef780: 0xee4c, 0x000e signal (4): Illegal instruction in expression

Bug#909406: Acknowledgement ([regression] GCC-8 failed to compile Julia on armhf while GCC-7 worked.)

2018-09-22 Thread Mo Zhou
Update on the way to reproduce: Repo: https://salsa.debian.org/julia-team/julia tag: debian/1.0.0-3 Way to reproduce: 1. same as the last mail, revert https://salsa.debian.org/julia-team/julia/commit/b89c05c87f27d23513cb3f90cd534f775daea289 2. remove -marm from rules. On Sun, Sep 23, 2018

Bug#909500: nvBLAS as an alternative to libblas.so.3

2018-09-24 Thread Mo Zhou
Package: libnvblas9.2 Version: 9.2.148-1 Severity: wishlist X-Debbugs-CC: debian-scie...@lists.debian.org Nvidia says nvBLAS is a "drop-in" BLAS library however it merely provides several level-3 BLAS symbols. That being said, nvBLAS is indeed a valid candidate for libblas.so.3 if explicitly

Bug#909497: CUDA 10 available now

2018-09-24 Thread Mo Zhou
Package: nvidia-cuda-toolkit Version: 9.2.148-1 Severity: wishlist Justification: new upstream release https://docs.nvidia.com/cuda/cuda-toolkit-release-notes/index.html Some notable points from the release notes: 1. CUDA 10.0.130, requires nvidia >= 410.48 2. CUDA 10.0 adds support for the

Bug#909507: MKL 2019 is available

2018-09-24 Thread Mo Zhou
Package: intel-mkl Version: 2018.3.222-3 Severity: wishlist https://software.intel.com/en-us/articles/intel-math-kernel-library-release-notes-and-new-features I should also write a watch file monitoring this page: https://pypi.org/project/mkl/

Bug#909457: ITP: blis -- BLAS-like Library Instantiation Software Framework

2018-09-24 Thread Mo Zhou
simple benchmark result here: https://github.com/flame/blis/issues/255 On Mon, Sep 24, 2018 at 07:06:44AM +0000, Mo Zhou wrote: > Package: wnpp > Severity: wishlist > X-Debbugs-CC: debian-scie...@lists.debian.org > Owner: Mo Zhou > > * Package name: blis > Version

Bug#909544: Backport MKL 2019.0.117 to stretch

2018-09-24 Thread Mo Zhou
Package: intel-mkl Version: 2019.0.117-1 Severity: wishlist 2019.0.117-1~bpo9+1

Bug#911698: ITS: tbb

2018-11-18 Thread Mo Zhou
On Tue, Oct 23, 2018 at 08:42:31PM +0100, Steven Capper wrote: > I maintain the package and we had it hosted on Debian Science. I would > like to keep maintaining the package, but I am happy to co-maintain > the package with others. I added myself as a co-maint. > Out of interest, what would

Bug#915831: Fwd:Re: zfsutils-linux: Upgrading to 0.7.12 breaks during dpkg --configure]

2018-12-31 Thread Mo Zhou
- Forwarded message - Hi Rich, I investigated into this issue a bit and it looks like a result of messy system where systemd-sysv and insserv are co-installed. In insserv/sid, the postinst process will nolonger fail even if the same error occurs. The error will disappear if you remove

Bug#917520: Add patches from Julia upstream

2018-12-27 Thread Mo Zhou
Source: libunwind Version: 1.2.1-8 Severity: normal Hi Adrian, Julia upstream applied several patches[1] to their vendored libunwind, but it seems that none of these patches was applied to Debian's libunwind package. This is a list of patches: (1) libunwind-arm-dyn.patch (2)

Bug#914766: mkl: path of headers

2018-12-27 Thread Mo Zhou
control: severity -1 wishlist control: tag -1 wontfix Moving headers out of mkl/ subsirectory would mess up user's /usr/include

Bug#917520: Add patches from Julia upstream

2018-12-27 Thread Mo Zhou
Hi, In addition, upstream is likely to release libunwind 1.3 after some holidays in january[1]. The timing sounds bad for the Buster freeze, but I think a freeze exception is still feasible. [1] https://github.com/libunwind/libunwind/issues/97

Bug#917789: Wrong tarball id (pristine-tar) when import-orig with --components

2018-12-30 Thread Mo Zhou
Package: git-buildpackage Version: 0.9.13 Severity: important X-Debbugs-CC: Mattia Rizzolo Dear maintainer, I noticed that the pristine-tar tarball id for the source is incorrect if the set of orig-tarballs are imported with gbp-import-orig XXX.orig.tar.xz --components YYY For example,

Bug#918000: openmpi postinst failure due to missing space in script

2019-01-01 Thread Mo Zhou
Package: libopenmpi3 Version: 3.1.3-7 Severity: serious Dear maintainer, You missed a space in the script, which resulted in The following packages will be upgraded: libopenmpi3 openmpi-common 2 upgraded, 0 newly installed, 0 to remove and 4 not upgraded. 210 not fully installed or removed.

Bug#871019: sshfs: Please update to 3.x

2019-01-05 Thread Mo Zhou
I guess sshfs 3.X is hopeless for Buster. Because there is no any related transition on the tracker. And fuse3 breaks gnome-core. Anyone who cannot wait for the official package could try mine: https://salsa.debian.org/lumin/sshfs-fuse (3.5.1)

Bug#917789: Wrong tarball id (pristine-tar) when import-orig with --components

2019-01-02 Thread Mo Zhou
On Sun, Dec 30, 2018 at 12:53:18PM +0100, Guido Günther wrote: > > I noticed that the pristine-tar tarball id for the source is incorrect > > if the set of orig-tarballs are imported with > > > > gbp-import-orig XXX.orig.tar.xz --components YYY > > > > For example, after importing the opencv

Bug#915886: zfs-dkms: module FTBFS for 4.18.0-3-amd64: NR_FILE_PAGES in either node_stat_item or zone_stat_item: NOT FOUND

2019-01-05 Thread Mo Zhou
Hi anbe, Do you still have any idea about the way to reproduce this failure? I've added an autopkgtest script to zfs to test the dkms build against linux-headers-$(dpkg --print-architecture), and it seems that I cannot reproduce this issue in a clean and minimal chroot.

Bug#918476: ITS: fish

2019-01-06 Thread Mo Zhou
Package: fish Version: 2.7.1-3+b1 X-Debbugs-CC: Tristan Seligmann Hi Tristan, fish is my default login shell and I wish to use fish 3.0 and push fish 3.0.X into Buster. So following the ITS process I'm filing this bug.

Bug#915721: transition: opencv

2019-01-05 Thread Mo Zhou
not buildd. Builds for 3.4.5+dfsg-1~exp1 were successful so I don't expect any problem for 3.4.5+dfsg-1~exp1+b1 . On Mon, Dec 31, 2018 at 10:14:20AM +, Mo Zhou wrote: > I've uploaded opencv 3.4.5 to experimental which fixed some issues found > in the previous version. This time

Bug#871019: sshfs: Please update to 3.x

2019-01-06 Thread Mo Zhou
On Sun, Jan 06, 2019 at 07:56:11PM +0100, Fabio Pedretti wrote: > I don't think a transition is needed, now that fuse and fuse3 are > co-installable. The packages that can migrate to fuse3 could do, the others Source of "co-installable"??? I just installed fuse3, then apt removed gnome-core and

Bug#915721: transition: opencv

2019-01-14 Thread Mo Zhou
On Sun, Jan 13, 2019 at 08:06:57PM +0100, Emilio Pozuelo Monfort wrote: > > What is the status with the rdeps? I looked at two bugs and they worry me: I haven't had enough time to test rdeps for another round. But I guess the situation would be similar to the first round. > #915544 suggests the

Bug#909497: CUDA 10 available now

2018-12-12 Thread Mo Zhou
lua-torch-cutorch is deprecated by upstream and orphaned by me: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=916281 caffe-contrib FTBFS because libopencv-dev cannot be installed, libopencv-dev cannot be installed because there is a temporary FTBFS against hdf5 where libvtk6-dev is

Bug#916281: RM: lua-torch-cutorch -- ROM; deprecated upstream; NBS; NPOASR;

2018-12-12 Thread Mo Zhou
Package: ftp.debian.org Severity: normal rm src:lua-torch-cutorch It's deprecated by upstream, and has already been replaced by newer alternatives. Since I'm not going to maintain it anymore and I don't expect anyone to take it over, I'm requesting a removal.

Bug#916991: julia: cannot load /usr/bin/../lib/x86_64-linux-gnu/julia/libblas.so: undefined symbol: openblas_get_config

2018-12-20 Thread Mo Zhou
Hi Norbert, > It seems that the current Julia does not like the mkl blas libraries. Our prebuild Julia package cannot depend on MKL. It assumes that the user use openblas by default. For MKL users, there is a CUSTOM_MKL flag provided by julia's debian/rules file, with which one can easily

Bug#910837: RFS: mle/1.2-1 [ITP] -- flexible terminal-based text editor (C)

2018-12-22 Thread Mo Zhou
See comments I left in github issues. On Fri, Dec 21, 2018 at 03:34:40PM -0500, a...@php.net wrote: > On Wed, 17 Oct 2018 13:28:40 +0000 Mo Zhou wrote: > > ... > > Try to build against this termbox package, it's almost finished: > > https://salsa.debian.org/debian/ter

Bug#915721: transition: opencv

2018-12-23 Thread Mo Zhou
On Wed, Dec 19, 2018 at 11:32:36AM +0100, Emilio Pozuelo Monfort wrote: > I was going to ack this, but I noticed that opencv failed to build on some > architectures: > > https://buildd.debian.org/status/package.php?p=opencv=experimental > > Please look at that before we start this. opencv was

Bug#915721: transition: opencv

2018-12-27 Thread Mo Zhou
OpenCV 3.4.4 is green on all official architectures after uploading manually built mips{,64}el packages by using Yunqiang's machine. Shall we move on? On Mon, Dec 24, 2018 at 01:49:45AM +, Mo Zhou wrote: > On Wed, Dec 19, 2018 at 11:32:36AM +0100, Emilio Pozuelo Monfort wrote: &g

Bug#916514: ITP: gym -- A toolkit for developing and comparing reinforcement learning algorithms.

2018-12-15 Thread Mo Zhou
Package: wnpp Severity: wishlist Owner: Mo Zhou * Package name: gym Version : 0.10.9 Upstream Author : OpenAI * URL : https://gym.openai.com/ * License : MIT/Expat Programming Lang: Python Description : A toolkit for developing and comparing

Bug#915529: ros-opencv-apps FTBFS against opencv 3.4.4

2018-12-04 Thread Mo Zhou
Package: ros-opencv-apps Version: 1.12.0-1 Severity: important Tags: patch https://patch-diff.githubusercontent.com/raw/ros-perception/opencv_apps/pull/71.diff

Bug#915186: RFA: caffe -- Fast, open framework for Deep Learning

2018-12-01 Thread Mo Zhou
Package: wnpp Severity: normal X-Debbugs-CC: debian-scie...@lists.debian.org As time goes by, the DL framework is more and more likely an educational code base. It's architecture and design is old, compared to PyTorch or TensorFlow 2.0. The last time I use caffe for neural network training is

Bug#886675: opencv: CVE-2018-5269

2018-12-05 Thread Mo Zhou
control: tags -1 +fixed-in-experimental 3.4.4+dfsg-1~exp1

Bug#909497: CUDA 10 available now

2018-12-05 Thread Mo Zhou
Hi Anbe, Do you have any plan about Buster's CUDA version? My Recommendation is 9.2 since 9.1 is buggy. My most familiar use case of CUDA is PyTorch, which omitted CUDA 9.1: https://pytorch.org/

Bug#914748: ant: Fail when installed along with usrmerge and invoked via /bin/ant

2018-12-05 Thread Mo Zhou
I've fixed the opencv build failure in experimental due to the path change of ant. Fixed in version: 3.4.4+dfsg-1~exp1

Bug#886674: opencv: CVE-2018-5268

2018-12-05 Thread Mo Zhou
control: tags -1 +fixed-in-experimental 3.4.4+dfsg-1~exp1

Bug#915709: gst-plugins-bad1.0 FTBFS against opencv 3.4.4 in experimental

2018-12-06 Thread Mo Zhou
Source: gst-plugins-bad1.0 Version: 1.14.4-1 Severity: important builddlog attached. gst-plugins-bad1.0_1.14.4-1_amd64-2018-12-06T04:04:31Z.build.xz Description: application/xz

Bug#915710: libkf5kface FTBFS against opencv 3.4.4 in experimental

2018-12-06 Thread Mo Zhou
Source: libkf5kface Version: 17.08.1 Severity: important builddlog attached. libkf5kface_17.08.1-1_amd64-2018-12-06T04:21:30Z.build.xz Description: application/xz

Bug#915711: mldemos FTBFS against opencv 3.4.4 in experimental

2018-12-06 Thread Mo Zhou
Source: mldemos Version: 0.5.1+git.1.ee5d11f-4 Severity: important builddlog attached. mldemos_0.5.1+git.1.ee5d11f-4_amd64-2018-12-06T04:29:45Z.build.xz Description: application/xz

Bug#915712: php-facedetect FTBFS against opencv 3.4.4 in experimental

2018-12-06 Thread Mo Zhou
Source: php-facedetect Version: 1.1.0+git20170801-2 Severity: important buildlog attached. php-facedetect_1.1.0+git20170801-2_amd64-2018-12-06T06:23:12Z.build.xz Description: application/xz

Bug#915730: malformed searching pattern crashes rover

2018-12-06 Thread Mo Zhou
Package: rover Version: 0.3.1 Rover will crash if I search with * It's clear that we need to deal with malformed regex if there is any. Traceback (most recent call last): File "/usr/bin/rover", line 389, in rv.refresh_selections() File "/usr/bin/rover", line 204, in refresh_selections

  1   2   3   >