Bug#869074: closed by Tobias Frost <t...@debian.org> (Re: mame FTBFS on i386: virtual memory exhausted)

2018-04-15 Thread Adrian Bunk
> Date: Sun, 15 Apr 2018 10:50:19 +0200 > From: Tobias Frost > To: 869074-d...@bugs.debian.org > Subject: Re: mame FTBFS on i386: virtual memory exhausted > > On Thu, 20 Jul 2017 12:55:17 +0300 Adrian Bunk wrote: > > Source: mame > > Version: 0.187+dfsg.1-1 > >

Bug#895734: xboxdrv: Please update watch file

2018-04-15 Thread Tobias Frost
Package: xboxdrv Severity: minor The project moved to github, so uscan should start looking there: https://github.com/xboxdrv/xboxdrv/ Thanks! -- System Information: Debian Release: buster/sid APT prefers unstable APT policy: (500, 'unstable') Architecture: amd64 (x86_64) Kernel: Linux

Bug#743824: digikam: Digikam no longer displays any album thumbnails

2018-04-15 Thread MH
Package: digikam Version: 4:5.6.0-4+b2 Followup-For: Bug #743824 Dear Maintainer, Digikam v. 5.6.0 in Debian Buster (Build date: Dec 21 2017 (target: Debian)) no longer displays thumbnails under any of the albums in my collection. As far as I can tell, there has been no recent update of

Bug#892229: wireless-regdb: Missing support for kernel direct loading

2018-04-15 Thread gerardo diaz
Download wireless-regdb 2017.12.23, untar, and copy regulatory.db and regulatory.db.p7s to /lib/firmware; full ok.

Bug#895718: python-pyqt5: import PyQt5.QtCore fails

2018-04-15 Thread Dmitry Shachnev
Control: tags -1 unreproducible On Sun, Apr 15, 2018 at 12:59:12AM -0400, Scott Kitterman wrote: > Tried this on sid with both pyqt5 5.9.2 and 5.10.1: > > Unpacking python-pyqt5 (5.10.1+dfsg-1) over (5.9.2+dfsg-1+b1) ... > Setting up python-pyqt5 (5.10.1+dfsg-1) ... > # python > Python 2.7.14+

Bug#895712: ITP: misspell-fixer -- Tool for fixing common misspellings, typos in source code.

2018-04-15 Thread Lajos Veres
On Sun, 15 Apr 2018, Paul Wise wrote: > On Sun, 15 Apr 2018 00:49:05 +0100 Lajos Veres wrote: > > > I have not found any sourcecode typofixer tool in Debian. > > codespell -w > spellintian (doesn't autofix) > > Some more that are not yet in Debian: > > https://jwilk.net/software/mwic >

Bug#895676: gnome-session: Black screen only when choose "GNOME on Xorg" session [solved]

2018-04-15 Thread Kamen Naydenov
I was able to solve my problem removing "workrave" from auto started programs. Now I have normal gnome-shell session which can be crashed (going to black screen) when starting "workrave". best regards Kamen

Bug#895712: ITP: misspell-fixer -- Tool for fixing common misspellings, typos in source code.

2018-04-15 Thread Paul Wise
On Sun, 15 Apr 2018 11:35:11 +0100 (BST) Lajos Veres wrote: > (I am not very familiar with Debian packaging. So sorry if I missed any > rules/etc.) The first one you should be aware of is that bug submitters and random folks commenting on a bug are not subscribed to the bug by default. So you

Bug#830207: new VCS

2018-04-15 Thread Rolf Leggewie
the packaging is now being developed at https://github.com/leggewie-DM/audio-recorder

Bug#876386: Thank you for this report

2018-04-15 Thread Rolf Leggewie
Dear Shi, thank you for your report.  I will shortly upload an interim "fix" to depend on net-tools until this can be properly fixed.  Xie xie. Regards Rolf

Bug#890595: This is an easy fix.

2018-04-15 Thread Nye Liu
--- sql.lib.php.dist2018-04-15 01:55:18.675402718 -0700 +++ sql.lib.php 2018-04-15 01:53:46.787216745 -0700 @@ -610,7 +610,7 @@ || $analyzed_sql_results['is_analyse']) && $analyzed_sql_results['select_from'] && ((empty($analyzed_sql_results['select_expr'])) -

Bug#895737: python-asdf: please make the build reproducible

2018-04-15 Thread Chris Lamb
[Re-adding #895737 to CC] Hi Niels > The attachment to the bug appears to be an empty file. Not sure if it > is a bug in the BTS or you attached the wrong file. No, my fault. Now attached. Regards, -- ,''`. : :' : Chris Lamb `. `'` la...@debian.org /

Bug#895733: python-msgpack: please update to 0.5.6

2018-04-15 Thread Goirand Thomas (aka zigo)
It is ok to NMU if you send the debdiff to the BTS and upload to delayed queue. Bonus point if you send a pull request to the BTS. Note that we use a git based workflow, so you must: ./debian/rules fetch-upstream-remote ./debian/rules gen-orig-xz Sent from my Cyanogen phone On Apr 15,

Bug#872413: kpatch: Please package new upstream version

2018-04-15 Thread Simon Ruderich
On Thu, Apr 12, 2018 at 05:03:42PM +0200, Vincent Bernat wrote: > Hi! > > As the package is not currently usable with our kernel, or even the > one in stable, I am bumping the severity. Since you already worked a > lot on this, would you be interested to prepare an upload for 0.5.0? If > yes, we

Bug#866037: your report lacks information

2018-04-15 Thread Rolf Leggewie
Hello, there is basically no information whatsoever in your bug report what problem you experience with n2n.  What am I supposed to make of this?  Please provide steps to reproduce and what problems you experience.  You even quoted the section requesting that information, yet ignored it. Regards

Bug#895674: lintian: maybe-not-arch-all-binnmuable emitted for (= ${source:Version})

2018-04-15 Thread Chris Lamb
tags 895674 + pending thanks > I guess I'd want to know if the source format were not 3.0 (quilt) but > that's a rare enough issue that it's probably not worth the noise Indeed. Whilst we have things like: unknown-source-format unsupported-source-format missing-debian-source-format ... I

Bug#863072: cronutils: Non-determistically FTBFS due to unreliable timing in tests

2018-04-15 Thread Chris Lamb
Jamie Wilkinson wrote: > Yeah, it's pretty ugly. Do you have any ideas on how to improve it? Sorry, didn't see this until now. I don't have an idea on how to improve it per-se, but IMHO it is ipso facto not a real test as it is nondeterminstic. :( Regards, -- ,''`. : :' :

Bug#895043: libgtk-3-0: unexplained downstream patch disables VIQR input method in Vietnamese locales

2018-04-15 Thread Simon McVittie
On Sun, 15 Apr 2018 at 05:48:00 +, Khang Nguyen Trong wrote: > What I am trying to say is that [VIQR] not be the default, but it should not > be disabled either. That is my take on this matter. I believe the result of the Debian/Ubuntu patch is that VIQR is not the default for any locale, but

Bug#895725: librsvg: Test failures on s390x

2018-04-15 Thread Simon McVittie
On Sun, 15 Apr 2018 at 16:16:48 +1000, Tim Lunn wrote: > # Storing test result image at /tmp/91-nonzero-translation-diff.png > not ok 26 /rsvg-test/reftests/bugs/91-nonzero-translation.svg > FAIL: rsvg-test 26 /rsvg-test/reftests/bugs/91-nonzero-translation.svg It's helpful if you quote how many

Bug#895723: librsvg: FTBFS on powerpc arches

2018-04-15 Thread Tim Lunn
Source: librsvg Version: 2.42.3-1 Severity: important Tags: upstream Building 2.42.3 on Debian experimental ppc64el. powerpc and ppc64 seem to have the same issues. Possibly due to linking with --as-needed . However not sure why this only affects the powerpc arches. Full ppc64el logs:

Bug#895724: ITP: sphinxtesters -- Utilities for testing Sphinx extensions

2018-04-15 Thread Sandro Tosi
Package: wnpp Severity: wishlist Owner: Sandro Tosi * Package name: sphinxtesters Version : 0.1.1 Upstream Author : Matthew Brett * URL : http://github.com/matthew-brett/sphinxtesters * License : BSD Programming Lang: Python Description

Bug#895727: python-sphinx: missing dependency on python-typing

2018-04-15 Thread Adrian Bunk
Package: python-sphinx Version: 1.7.2-1 Severity: serious Control: affects -1 src:python-arrow src:tilecache src:lazr.config src:cpl-plugin-kmos src:python-django-debug-toolbar src:python-tinyrpc https://tests.reproducible-builds.org/debian/rb-pkg/unstable/arm64/python-arrow.html ...

Bug#895043: libgtk-3-0: unexplained downstream patch disables VIQR input method in Vietnamese locales

2018-04-15 Thread Rob Hurle
I agree with Khang Nguyen. I've written a lot using Vietnamese and spent a lot of time in Vietnam. Most people there use Telex, a few VNI, and VIQR is uncommon (may be used in some parts of the USA). VIQR is trouble and should not be the default, but should be available. Rob Hurle (Researcher

Bug#895728: tlslite-ng: CVE-2018-1000159: Improper Validation of Integrity Check Value vulnerability

2018-04-15 Thread Salvatore Bonaccorso
Source: tlslite-ng Version: 0.5.1-1 Severity: important Tags: patch security upstream Forwarded: https://github.com/tomato42/tlslite-ng/pull/235 Hi, The following vulnerability was published for tlslite-ng. CVE-2018-1000159[0]: Improper Validation of Integrity Check Value vulnerability If you

Bug#895300: cargo: Please disable incremental-by-default on sparc64

2018-04-15 Thread Vasudev Kamath
John Paul Adrian Glaubitz writes: > Hi! > > The attached patch disables incremental builds on sparc64 and resolves > the issue for me. It would be good if the patch could be applied for > the time being until we have investigated what causes the issues with >

Bug#895712: ITP: misspell-fixer -- Tool for fixing common misspellings, typos in source code.

2018-04-15 Thread KAction
[2018-04-15 00:49] Lajos Veres > [...] > > --- > > Reason: I have not found any sourcecode typofixer tool in Debian. > Some users also mentioned that their life would be a little easier > with a packaged version. Lintian supports some spell checking, including 'spelling error

Bug#856299: ITA: storebackup -- fancy compressing managing checksumming deduplicating hard-linking cp -ua

2018-04-15 Thread Oliver Meißner
Control: owner -1 ! Control: retitle -1 ITA: storebackup -- fancy compressing managing checksumming deduplicating hard-linking cp -ua

Bug#895729: RFS: mkl-dnn/0.13~20180406-ga5f6077-1 [ITP] -- math kernel lib for deep neural network

2018-04-15 Thread Lumin
Package: sponsorship-requests Severity: wishlist X-Debbugs-CC: debian-scie...@lists.debian.org Dear mentors, I am looking for a sponsor for my package "highwayhash" * Package name: mkl-dnn Version : 0.13~20180406-ga5f6077-1 Upstream Author : Intel * URL :

Bug#886036: Improve changelog version parsing

2018-04-15 Thread Chris Lamb
Chris Lamb wrote: > Can you update us on the status of this issue? Did we resolve it already > or do you have more patches ready to roll soon? :) Gentle ping on this? I do remember you had some patches queued up, I just hope we/I haven't neglected them somewhere... Regards, -- ,''`.

Bug#895732: cogl FTBFS: symbol differences

2018-04-15 Thread Adrian Bunk
Source: cogl Version: 1.22.2-3 Severity: serious Some recent change in unstable makes cogl FTBFS: https://tests.reproducible-builds.org/debian/history/cogl.html https://tests.reproducible-builds.org/debian/rb-pkg/unstable/amd64/cogl.html ... debian/rules override_dh_makeshlibs make[1]:

Bug#895733: python-msgpack: please update to 0.5.6

2018-04-15 Thread Gianfranco Costamagna
Source: python-msgpack Version: 0.5.1-3 Severity: important Dear maintainer, can you please update to 0.5.6, borgbackup has issues with previous versions, see [1] thanks! I can NMU if needed, just let me know! Gianfranco [1] [18:38:34] zigo, please update msgpack? rationale is there

Bug#551400: [Pkg-pascal-devel] Bug#551400: fpc on kfreebsd-i386

2018-04-15 Thread Abou Al Montacir
It seems that kfreebasd-* resisted to the vague of architectures drop in Debian and is still there. How shall we proceed with this ticket? --  Cheers, Abou Al Montacir signature.asc Description: This is a digitally signed message part

Bug#895725: librsvg: Test failures on s390x

2018-04-15 Thread Tim
On 15/04/18 20:20, Simon McVittie wrote: > > To be able to debug these, someone will need to build librsvg on a > porterbox and fetch the -diff.png images for inspection. I'll kick off > a build on zelenka later today if nobody gets there first. I already posted the test artifacts and  -diff.png

Bug#894298: python-gffutils new version 0.9 - relevant again?

2018-04-15 Thread Steffen Möller
Hello, I thought I should work a bit on the yellow (in git but not uploaded) packages and came across python-gffutils. There is a newer version 0.9 out, so, yeah, motivating. Just when about to upload I then found https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=894298 . So this is a

Bug#895722: trivial-gray-streams: autopkgtest fails in testing while succeeds in unstable => missing version?

2018-04-15 Thread Paul Gevers
Source: trivial-gray-streams Version: 20180311.git425aeca-2 Severity: normal User: ci-t...@tracker.debian.org Usertags: regression With the upload of trivial-gray-streams version 20180311.git425aeca-2 the autopkgtest doesn't depend on cl-asdf anymore (according to the changelog). However when the

Bug#861180: shc does not work, the executable sh.x it generates does not work correctly

2018-04-15 Thread raphael ciribelly
Package: shc Version: 3.8.9b-1+b1 Followup-For: Bug #861180 Dear Maintainer, *** Reporter, please consider answering these questions, where appropriate *** * What led up to the situation? * What exactly did you do (or not do) that was effective (or ineffective)? * What was the

Bug#895730: RFS: storebackup/3.5-2 [ITA] -- fancy compressing managing checksumming deduplicating hard-linking cp -ua

2018-04-15 Thread Oliver Meißner
Package: sponsorship-requests Severity: normal Dear mentors, I am looking for a sponsor for my package "storebackup" * Package name: storebackup Version : 3.5-2 Upstream Author : Heinz-Josef Claes * URL : http://savannah.nongnu.org/projects/storebackup * License

Bug#895731: RFS: pikopixel.app/1.0-b9b-1

2018-04-15 Thread Yavor Doganov
Package: sponsorship-requests Severity: normal Dear mentors, I'm looking for a sponsor for my package "pikopixel.app". * Package name: pikopixel.app Version : 1.0-b9b-1 Upstream Author : Josh Freeman * URL :

Bug#893561: libtablelayout-java: license does not seem to meet the DFSG

2018-04-15 Thread Francesco Poli
On Thu, 29 Mar 2018 00:09:47 +0200 Emmanuel Bourg wrote: > Le 28/03/2018 à 23:34, Francesco Poli a écrit : > > > In other words, can someone develop a fork of libtablelayout-java (with > > the namespace changed to a different one) which works as a drop-in > > replacement for the original

Bug#893561: libtablelayout-java: license does not seem to meet the DFSG

2018-04-15 Thread Francesco Poli
On Thu, 29 Mar 2018 00:38:42 +0200 Markus Koschany wrote: > Am 28.03.2018 um 23:34 schrieb Francesco Poli: > > On Sat, 24 Mar 2018 15:22:12 +0100 Markus Koschany wrote: [...] > > debian-legal is more like a sort of advisory board, where licensing > > issues are discussed and analyzed. The FTP

Bug#895712: ITP: misspell-fixer -- Tool for fixing common misspellings, typos in source code.

2018-04-15 Thread Lajos Veres
On Sun, 15 Apr 2018, kact...@gnu.org wrote: > [2018-04-15 00:49] Lajos Veres > > [...] > > > > --- > > > > Reason: I have not found any sourcecode typofixer tool in Debian. > > Some users also mentioned that their life would be a little easier > > with a packaged version. > >

Bug#873331: rm of llvm-toolchain-3.8

2018-04-15 Thread Sylvestre Ledru
tags 873331 - moreinfo thanks As said in https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=873408#23 Julia isn't in testing anymore. Therefor, llvm-toolchain-3.8 can be removed from Debian! thanks S

Bug#895737: python-asdf: please make the build reproducible

2018-04-15 Thread Chris Lamb
Source: python-asdf Version: 1.3.3-1 Severity: wishlist Tags: patch User: reproducible-bui...@lists.alioth.debian.org Usertags: timestamps randomness X-Debbugs-Cc: reproducible-b...@lists.alioth.debian.org Hi, Whilst working on the Reproducible Builds effort [0], we noticed that python-asdf

Bug#892988: autokey-gtk: does not start

2018-04-15 Thread Adrian Bunk
On Thu, Mar 15, 2018 at 10:01:01AM +0100, Francesco Marchesi wrote: >... > from Xlib import X, XK, display, error > File "/usr/lib/python2.7/dist-packages/Xlib/display.py", line 26, in > > from six import create_unbound_method > ImportError: cannot import name create_unbound_method

Bug#895725: librsvg: Test failures on s390x

2018-04-15 Thread Tim Lunn
Source: librsvg Version: 2.42.3-1 Severity: important Tags: upstream Building 2.42.3 test failures on Debian experimental s390x # Storing test result image at /tmp/91-nonzero-translation-diff.png not ok 26 /rsvg-test/reftests/bugs/91-nonzero-translation.svg FAIL: rsvg-test 26

Bug#888182: qemu-system-arm: qemu-system-arm crashes when run as part of the nbdkit testsuite

2018-04-15 Thread Michael Tokarev
Control: severity -1 normal Hmm.. I've no idea why this bug has severity Grave to start with. /mjt

Bug#895589: RFS: storebackup/3.5-2+nmu3 [ITA] -- fancy compressing managing checksumming deduplicating hard-linkin 'cp -ua'

2018-04-15 Thread Tobias Frost
On Sun, 15 Apr 2018 09:36:29 +0200 Oliver =?UTF-8?B?TWVpw59uZXI=?= wrote: > marked as done, because I uploaded a newer Version to mentors.debian.net > ämh, sounds like you going to open up a new bug for the newversion, but this is not the right way: If you upload a newer version, you recycle

Bug#886306: python-pyocr: FTBFS: "Unable to parse Tesseract version"

2018-04-15 Thread Chris Lamb
Chris Lamb wrote: > Patch is simple: Gentle ping on this? :) Regards, -- ,''`. : :' : Chris Lamb `. `'` la...@debian.org / chris-lamb.co.uk `-

Bug#808455: roboptim-core: FTBFS: dh_install: libroboptim-core2-plugin-base missing files (usr/lib/*/roboptim-core/*.so.2*), aborting

2018-04-15 Thread Chris Lamb
Hi, > roboptim-core: FTBFS: dh_install: [...] So: https://bugs.debian.org/cgi-bin/pkgreport.cgi?src=roboptim-core 5 RC bugs? Are we sure this should be in Debian? :-) Regards, -- ,''`. : :' : Chris Lamb `. `'` la...@debian.org / chris-lamb.co.uk `-

Bug#895736: Should Gnash be removed?

2018-04-15 Thread Moritz Muehlenhoff
Source: gnash Severity: important Should Gnash be removed? - Doesn't have any active uploaders any more - Upstream seems mostly dead, last commits over a year ago - Mozilla plugin broken as of Firefox 57 (so soon also for firefox-esr) (Konqeror plugin seems broken for longer even according to

Bug#895737: python-asdf: please make the build reproducible

2018-04-15 Thread Chris Lamb
forwarded 895737 https://github.com/spacetelescope/asdf/pull/490 thanks I've forwarded this upstream here: https://github.com/spacetelescope/asdf/pull/490 Regards, -- ,''`. : :' : Chris Lamb `. `'` la...@debian.org / chris-lamb.co.uk `-

Bug#895726: python3-gbulb: ModuleNotFoundError: No module named 'gi'

2018-04-15 Thread Helmut Grohne
Package: python3-gbulb Version: 0.5.3-2 Severity: serious Justification: missing dependency After installing python3-gbulb, I tried importing it into a python interpreter: | $ python3 | Python 3.6.5 (default, Apr 1 2018, 05:46:30) | [GCC 7.3.0] on linux | Type "help", "copyright", "credits" or

Bug#895705: missing ";" passed syntax checks

2018-04-15 Thread Niko Tyni
On Sun, Apr 15, 2018 at 05:57:01AM +0800, 積丹尼 Dan Jacobson wrote: > Package: perl > Version: 5.26.1-5 > Severity: wishlist > > This missing ";" passed syntax checks: > > use Data::Dumper; > use Time::Piece > $Data::Dumper::Indent = $Data::Dumper::Sortkeys = 1; > my $doc; That's because it is

Bug#895735: xsel fails to paste more than 4k of text into chrome

2018-04-15 Thread Chow Loong Jin
Package: xsel Version: 1.2.0-3 Severity: normal Tags: upstream fixed-upstream Dear Maintainer, 1. Copy a large block (>4k )of text using xsel 2. Open Chrome/Chromium 3. Try to paste it into a textarea 4. Chrome/Chromium hangs This is fixed upstream in this PR:

Bug#895712: ITP: misspell-fixer -- Tool for fixing common misspellings, typos in source code.

2018-04-15 Thread Peter Pentchev
On Sun, Apr 15, 2018 at 11:53:15AM +0100, Lajos Veres wrote: > On Sun, 15 Apr 2018, kact...@gnu.org wrote: > > > [2018-04-15 00:49] Lajos Veres > > > [...] > > > > > > --- > > > > > > Reason: I have not found any sourcecode typofixer tool in Debian. > > > Some users also

Bug#895466: debootstrap 1.0.96 fails due to missing apt-config

2018-04-15 Thread Olliver Schinagl
On 12-04-18 09:58, Raphael Hertzog wrote: Hi, On Wed, 11 Apr 2018, Olliver Schinagl wrote: While running debootstrap on a non-native debian system, debootstrap keeps failing with debootstrap: line 55: apt-config: command not found Duh... this change has even been discussed on the mailing

Bug#895466: debootstrap 1.0.96 fails due to missing apt-config

2018-04-15 Thread Olliver Schinagl
On 12-04-18 10:05, Simon McVittie wrote: On Wed, 11 Apr 2018 at 22:14:21 +0200, Olliver Schinagl wrote: Tags: newcomer The newcomer tag is for use by the package's maintainer. It indicates a bug that is particularly suitable for new contributors to work on as an introduction to contributing to

Bug#895703: Continuous LIBUSB_ERROR_NO_DEVICE in journal after removing a Yubikey 4 (USB-C)

2018-04-15 Thread Ludovic Rousseau
Hello, Le 06/04/2018 à 21:50, Luke W Faraone a écrit : Package: pcscd Version: 1.8.23-2 Severity: normal Dear maintainer, This appears to be similar symptoms to bug #459827, but reporting separately, as this has nothing to do with PCMCIA. After removing a Yubikey 4 (USB-C) from my XPS 13

Bug#895738: python3-sphinx: missing dependency on python3-setuptools

2018-04-15 Thread Roberto C. Sanchez
Package: python3-sphinx Version: 1.7.2-1 Severity: important This morning I upgraded python3-sphinx in a sid chroot: [UPGRADE] python3-sphinx:amd64 1.6.7-2 -> 1.7.2-1 Following that upgrade, it no longer works: Traceback (most recent call last): File "/usr/bin/sphinx-build", line 6, in

Bug#712841: A bit late, but still an issue...

2018-04-15 Thread Ian Campbell
On Sun, 2018-04-15 at 16:03 +0200, Martin Michlmayr wrote: > * Axel Sommerfeldt [2018-04-14 22:07]: > > Just a reminder that this bug is still a thing. And yes, the model > can be found in uLinux.conf: > > Ian, do you think it's worth asking the release team if they'd

Bug#893561: libtablelayout-java: license does not seem to meet the DFSG

2018-04-15 Thread tony mancill
On Sun, Apr 15, 2018 at 11:42:20AM +0200, Francesco Poli wrote: > On Thu, 29 Mar 2018 00:09:47 +0200 Emmanuel Bourg wrote: > > > Le 28/03/2018 à 23:34, Francesco Poli a écrit : > > > > > In other words, can someone develop a fork of libtablelayout-java (with > > > the namespace changed to a

Bug#895753: ITP: golang-github-k-sone-critbitgo -- crit-bit for golang and its applications (sorted map, IP routing table)

2018-04-15 Thread Eric Dorland
Package: wnpp Severity: wishlist Owner: Eric Dorland * Package name: golang-github-k-sone-critbitgo Version : 1.1.0+git20170112.327359a-1 Upstream Author : Keita Sone * URL : https://github.com/k-sone/critbitgo * License : MIT Programming

Bug#895754: ncurses-term: please add tmux-direct terminal type

2018-04-15 Thread brian m. carlson
Package: ncurses-term Version: 6.1+20180210-1 Severity: wishlist tmux has, since version 2.2, supported true color capabilities, but there is no terminal definition (either tmux* or screen*) that handles true color. This means that people who want to use true color-capable programs, like Vim, in

Bug#743824: digikam: Digikam no longer displays any album thumbnails

2018-04-15 Thread Steve Robbins
On Sunday, April 15, 2018 5:01:48 AM CDT MH wrote: > Package: digikam > Version: 4:5.6.0-4+b2 > Followup-For: Bug #743824 > > Dear Maintainer, > > Digikam v. 5.6.0 in Debian Buster (Build date: Dec 21 2017 (target: Debian)) > no longer displays thumbnails under any of the albums in my

Bug#895758: lintian -- when is a patch a patch (HG)

2018-04-15 Thread Chris Lamb
retitle 895758 Ignore files ending in ".patch_back" in patch-file-present-but-not-mentioned-in-series thanks Hi Thorsten, > W: libosmo-sccp source: patch-file-present-but-not-mentioned-in-series > 02_set_version_explicitly.patch_back This might be a language thing but I would not know

Bug#895758: lintian -- when is a patch a patch (HG)

2018-04-15 Thread Thorsten Alteholz
Hi Chris, On Sun, 15 Apr 2018, Chris Lamb wrote: This might be a language thing but I would not know what "patch back" would mean out of context. Indeed, even when I am pretty sure what you are trying to achieve (temporarily ignore a patch?) yes, thats what I wanted. I could have sworn that

Bug#894083: italc: diff for NMU version 1:3.0.3+dfsg1-2.1

2018-04-15 Thread Adrian Bunk
Control: tags 894083 + pending Dear maintainer, I've prepared an NMU for italc (versioned as 1:3.0.3+dfsg1-2.1) and uploaded it to DELAYED/14. Please feel free to tell me if I should cancel it. cu Adrian -- "Is there not promise of rain?" Ling Tan asked suddenly out of the

Bug#892399: kodi: diff for NMU version 2:17.6+dfsg1-1.1

2018-04-15 Thread Adrian Bunk
Control: tags 892399 + patch Control: tags 892399 + pending Dear maintainer, I've prepared an NMU for kodi (versioned as 2:17.6+dfsg1-1.1) and uploaded it to DELAYED/15. Please feel free to tell me if I should cancel it. cu Adrian -- "Is there not promise of rain?" Ling Tan asked

Bug#894214: python-debian: Build API documentation

2018-04-15 Thread Stuart Prescott
… And now merged, with API documentation now published automatically at https://python-debian-team.pages.debian.net/python-debian/ > > The autodoc API documentation needs to learn not > > to pick up some private members that are uninteresting while we need to > > keep others present

Bug#895713: FTBFS with googletest 1.8.0-7

2018-04-15 Thread Steve Robbins
severity 895713 normal tags 895713 + patch thanks On Saturday, April 14, 2018 7:10:33 PM CDT you wrote: > Debian's googletest package used to ship only sources, not a compiled > libgtest. The ros-catkin package has a build-dep on libgtest-dev. I was mistaken on the second point; ros-catkin

Bug#712841: A bit late, but still an issue...

2018-04-15 Thread Ian Campbell
On Sun, 2018-04-15 at 15:33 +0100, Ian Campbell wrote: > That said, if there are modifications which can be made to the existing > config file installed on this variant which would minimise the > modifications i.e. by adding a simple "has_a_fan = true" which affected > people can set to false then

Bug#895733: python-msgpack: please update to 0.5.6

2018-04-15 Thread Gianfranco Costamagna
Hello, >./debian/rules fetch-upstream-remote >./debian/rules gen-orig-xz I cloned, run the two commands, updated the changelog and uploaded in deferred/10, thanks! I don't know how to mix the upstream commits and the debian history, so for now I prefer to avoid sending a pr unless I find

Bug#893561: libtablelayout-java: license does not seem to meet the DFSG

2018-04-15 Thread Emmanuel Bourg
Le 15/04/2018 à 11:42, Francesco Poli a écrit : > So there's no way to create a modified version of libtablelayout-java > that can be used as a drop-in replacement for the original upstream > TableLayout. Fundamentally the libtablelayout-java package in Debian is a fork of the project named

Bug#895417: libseccomp: New upstream release 2.3.3

2018-04-15 Thread Xavier Guerrin
Package: libseccomp2 Version: 2.3.1-2.1 Followup-For: Bug #895417 Hello, I wholeheartedly concur with Simon: as of libseccomp 2.3.1 (and 2.3.2), trying to run Qt5 applications with seccomp-based syscall filtering (e.g. in a systemd-nspawn container) results in exit code 134 along with the

Bug#894469: crystalhd: diff for NMU version 1:0.0~git20110715.fdd2f19-12.1

2018-04-15 Thread Adrian Bunk
Control: tags 894469 + patch Control: tags 894469 + pending Dear maintainer, I've prepared an NMU for crystalhd (versioned as 1:0.0~git20110715.fdd2f19-12.1) and uploaded it to DELAYED/15. Please feel free to tell me if I should cancel it. cu Adrian -- "Is there not promise of rain?"

Bug#895739: psychtoolbox-3: FTBFS: Include deprecated xlocale.h

2018-04-15 Thread Rafael Laboissière
Source: psychtoolbox-3 Version: 3.0.14.20170103+git6-g605ff5c.dfsg1-1 Severity: serious Tags: patch upstream Justification: FTBFS Package psychtoolbox-3 is currently failing to build from source because file PsychSourceGL/Source/Common/Screen/SCREENDrawText.c includes xlocale.h, which has been

Bug#895741: plastimatch FTBFS with libdlib-dev 19.10-1

2018-04-15 Thread Adrian Bunk
Package: libdlib-dev Version: 19.10-2 Severity: serious Control: affects -1 src:plastimatch https://buildd.debian.org/status/package.php?p=plastimatch=sid ... -- Configuring done CMake Warning (dev) at cmake/PlmMacros.cmake:66 (add_library): Policy CMP0028 is not set: Double colon in target

Bug#712841: A bit late, but still an issue...

2018-04-15 Thread Martin Michlmayr
* Axel Sommerfeldt [2018-04-14 22:07]: > Just a reminder that this bug is still a thing. And yes, the model can be > found in uLinux.conf: Ian, do you think it's worth asking the release team if they'd allow an update for this in stable? Since stretch is likely to be

Bug#895703: Continuous LIBUSB_ERROR_NO_DEVICE in journal after removing a Yubikey 4 (USB-C)

2018-04-15 Thread Ludovic Rousseau
Le 15/04/2018 à 17:07, Luke W Faraone a écrit : On 15/04/18 12:05, Ludovic Rousseau wrote: - kill any already running pcscd process - run the newly compiler pcscd $ sudo src/pcscd --foreground --debug --color | tee log.txt - connect the Yubikey 4 (USB-C) - disconnect the device - stop pcscd by

Bug#890882: workaround for "Freecad fails to start with Assertion `!xcb_xlib_threads_sequence_lost' failed"

2018-04-15 Thread Jonathan
Hi, I've found a temporary workaround for this on the Arch User Repository page for freecad. LIBGL_DRI3_DISABLE=true FreeCAD Maybe I'll save someone the extra searching... Kind Regards gbf

Bug#892802: transition: efl

2018-04-15 Thread Andreas Metzler
On 2018-04-08 Andreas Metzler wrote: > On 2018-04-08 Emilio Pozuelo Monfort wrote: >> On 08/04/18 07:45, Andreas Metzler wrote: >[...] >>> it looks like the transition needs some brute force/hint. Both efl and >>> e17 are valid candidates, but do not

Bug#895761: jhove: FTBFS with java 9

2018-04-15 Thread Andreas Beckmann
Source: jhove Version: 1.6+dfsg-1 Severity: serious Tags: sid buster Justification: fails to build from source Hi, jhove FTBFS with openjdk-9 as the default jdk: debian/rules build QUILT_PATCHES=debian/patches \ quilt --quiltrc /dev/null push -a || test $? = 2 Applying patch

Bug#895766: stretch-pu: package tlslite-ng/0.6.0-1+deb9u1

2018-04-15 Thread Daniel Stender
Package: release.debian.org Severity: normal Tags: stretch User: release.debian@packages.debian.org Usertags: pu I hereby propose an update for stable/stretch of tlslite-ng. It contains a patch fixing CVE-2018-1000159 [1]. The security issue was marked as being no-dsa [2]. Please see the

Bug#895742: python-acidobasic should be named python3-acidobasic

2018-04-15 Thread Helmut Grohne
Package: python-acidobasic Version: 2.7-4 Severity: serious Justification: violates python policy 3.3 The package python-acidobasic is wrongly named. It contains a Python 3.x module. Python 2.x packages should carry a python- prefix while Python 3.x packages should carry a python3- prefix. Please

Bug#895746: RM: octave-pkg-dev -- ROM; deprecated, superseded by dh-octave

2018-04-15 Thread Rafael Laboissière
Package: ftp.debian.org Severity: normal X-Debbugs-Cc: debian-oct...@lists.debian.org Package octave-pkg-dev provided the infrastructure for building Octave add-on packages fo Debian. It has been replaced by dh-octave. All the packages that Build-Depend on octave-pkg-dev have already

Bug#895748: mpi-default-dev: add riscv64 to list of MPI arches

2018-04-15 Thread Drew Parsons
Package: mpi-default-dev Version: 1.10 Severity: normal Both openmpi and mpich now build on the new arch riscv64. So riscv64 should be added to the list of default arches. Whether default to openmpi or to mpich, your choice. We've been defaulting to openmpi for most arches, but that's mainly

Bug#894616: RFS: eqonomize/1.2.0-1 [QA upload]

2018-04-15 Thread Fabian Wolff
On Fri, Apr 13, 2018 at 09:19:41PM +0200, Tobias Frost wrote: > Hi Fabian, > > LGTM, Uploading! Great, thanks! > (The only thing you could do is to file those patches upstream to get > them included.) Done. I probably should have done this right away. Best regards, Fabian

Bug#862879: Port from libnm-util/libnm-glib to libnm (or GNetworkMonitor)

2018-04-15 Thread Ricardo Mones
Hi Michael, On Sat, Apr 14, 2018 at 01:04:33AM +0200, Michael Biebl wrote: > Control: severity -1 serious > > Hi, > > I intend to upload a new version of network-manager soonish which will > drop libnm-glib/libnm-util. I'm thus bumping this issue to RC in > preparation for that. OK, thanks for

Bug#894083: italc: diff for NMU version 1:3.0.3+dfsg1-2.1

2018-04-15 Thread Mike Gabriel
Hi Adrian, On Sunday, April 15, 2018, Adrian Bunk wrote: > Control: tags 894083 + pending > > Dear maintainer, > > I've prepared an NMU for italc (versioned as 1:3.0.3+dfsg1-2.1) and > uploaded it to DELAYED/14. Please feel free to tell me if I should > cancel it. > > cu > Adrian > > -- >

Bug#895765: igv: FTBFS with java 9

2018-04-15 Thread Andreas Beckmann
Source: igv Version: 2.4.6+dfsg-1 Severity: serious Justification: fails to build from source Hi, igv FTBFS with openjdk-9 as the default jdk: debian/rules build dh build --with javahelper dh_update_autotools_config dh_autoreconf dh_auto_configure jh_linkjars dh_auto_build

Bug#895764: RM: premail -- RoQA; partially broken email privacy package from the last millenium in contrib

2018-04-15 Thread Adrian Bunk
Package: ftp.debian.org Severity: normal Partially broken email privacy package from the last millenium in contrib.

Bug#895744: kmail --composer doesn't start

2018-04-15 Thread luca
Package: kmail Version: 4:17.12.3-1 Severity: normal Dear Maintainer, kmail --composer from konsole doesn't start. in dolphin with kmail_addattachmentservicemenu.desktop neither from konsole this is the output

Bug#895703: Continuous LIBUSB_ERROR_NO_DEVICE in journal after removing a Yubikey 4 (USB-C)

2018-04-15 Thread Luke W Faraone
On 15/04/18 12:05, Ludovic Rousseau wrote: > - kill any already running pcscd process > - run the newly compiler pcscd > $ sudo src/pcscd --foreground --debug --color | tee log.txt > > - connect the Yubikey 4 (USB-C) > - disconnect the device > - stop pcscd by Ctrl-C after the problem occurred >

Bug#886026: thank you for the translations

2018-04-15 Thread Rolf Leggewie
Thank you for the translations.  Pastebinit uses launchpad for many things, translations included. https://translations.launchpad.net/pastebinit/trunk I've made an attempt to upload it there.

Bug#895703: Continuous LIBUSB_ERROR_NO_DEVICE in journal after removing a Yubikey 4 (USB-C)

2018-04-15 Thread Luke Faraone
Enclosed. Doesn't appear to have changed the output. On Sun, Apr 15, 2018 at 3:49 PM, Ludovic Rousseau wrote: > Le 15/04/2018 à 17:07, Luke W Faraone a écrit : >> >> On 15/04/18 12:05, Ludovic Rousseau wrote: >>> >>> - kill any already running pcscd process >>> - run

Bug#895751: radare2: CVE-2018-8809

2018-04-15 Thread Salvatore Bonaccorso
Source: radare2 Version: 2.4.0+dfsg-1 Severity: normal Tags: patch security upstream Forwarded: https://github.com/radare/radare2/issues/9726 Hi, The following vulnerability was published for radare2. CVE-2018-8809[0]: | In radare2 2.4.0, there is a heap-based buffer over-read in the |

Bug#895752: radare2: CVE-2018-8808

2018-04-15 Thread Salvatore Bonaccorso
Source: radare2 Version: 2.4.0+dfsg-1 Severity: normal Tags: patch security upstream Forwarded: https://github.com/radare/radare2/issues/9725 Hi, The following vulnerability was published for radare2. CVE-2018-8808[0]: | In radare2 2.4.0, there is a heap-based buffer over-read in the |

Bug#895750: garbled display output on nouveau after suspend

2018-04-15 Thread ZevenOS
Package: linux-image-4.15 Version: 4.15.0-0.bpo.2-4kc-malta After installing kernel 4.15 from stretch-backports and testing on some of our testing machines with Nvidia GT218M [NVS 3100M] cards they don't successfully restore from suspend like they did before with kernel 4.14 (from backports)

Bug#895756: libinput bug: invalid tap event TAP_EVENT_PALM in state TAP_STATE_TAPPED related

2018-04-15 Thread Jeffrin Thalakkottoor
Package: libinput10 Version: 1.10.4-1 hello , I found the following in syslog Apr 15 19:41:54 debian org.gnome.Shell.desktop[1356]: libinput error: event1 - SynPS/2 Synaptics TouchPad: libinput bug: invalid tap event TAP_EVENT_PALM in state TAP_STATE_TAPPED -- software engineer rajagiri

Bug#474540: ext[23] should not be marked "essential"

2018-04-15 Thread Helmut Grohne
Control: tags -1 + patch On Mon, Aug 21, 2017 at 08:42:16AM -0400, Theodore Ts'o wrote: > On Mon, Aug 21, 2017 at 09:34:20AM +0200, Andreas Henriksson wrote: > > Step 1: Essential: yes -> Important: yes You know I've picked up the work to make this happen. To that end, I inspected the archive

  1   2   >