Bug#912099: gnumeric: FTBFS with itstool 2.0.4: 'ascii' codec can't decode byte 0xc2

2018-12-07 Thread Tanguy Ortolo
Hello, Niko Tyni, 2018-10-28 11:05+0200: gnumeric fails to build on current sid/amd64. It seems to have broken with itstool 2.0.4 in early October or so. From the build log: Warning: Could not merge cs translation for msgid: The chapters of this version of the Gnumeric manual are organized

Bug#915853: toppred: reproducible build (usrmerge): embeds path of tool found via PATH

2018-12-07 Thread Andreas Henriksson
Package: toppred Version: 1.10-6 Severity: normal Tags: unreproducible patch User: m...@linux.it Usertags: usrmerge Dear maintainer. The package toppred currently fails to build reproducibly on merged-usr vs non-merged systems. Please see attached patch fixing this issue. Regards, Andreas

Bug#915830: busybox: cp: failed to access '/var/tmp/mkinitramfs_h8da2B//usr/bin/busybox': Too many levels of symbolic links

2018-12-07 Thread Chris Boot
On 07/12/2018 08:43, Chris Lamb wrote: > If it helps: > > $ ls -l /usr/bin | grep busybox > -rwxr-xr-x 1 root root 654,048 2018-07-13 05:19 busybox > > $ ls -l /bin | grep busybox > lrwxrwxrwx 1 root root 16 2018-11-26 17:23 busybox ->

Bug#915847: rancid: reproducible build (usrmerge): embeds path of tool found via PATH

2018-12-07 Thread Andreas Henriksson
Package: rancid Version: 3.8-2 Severity: normal Tags: unreproducible patch User: m...@linux.it Usertags: usrmerge Dear maintainer. The package rancid currently fails to build reproducibly on merged-usr vs non-merged systems. Please see attached patch fixing this issue. Regards, Andreas

Bug#915846: porg: reproducible build (usrmerge): embeds path of tool found via PATH

2018-12-07 Thread Andreas Henriksson
Package: porg Version: 2:0.10-1.1 Severity: normal Tags: unreproducible patch User: m...@linux.it Usertags: usrmerge Dear maintainer. The package porg currently fails to build reproducibly on merged-usr vs non-merged systems. Please see attached patch fixing this issue. (Sorry I got the patch

Bug#915842: archmbox: reproducible build (usrmerge): embeds path of tool found via PATH

2018-12-07 Thread Andreas Henriksson
Package: archmbox Version: 4.10.0-2 Severity: normal Tags: unreproducible patch User: m...@linux.it Usertags: usrmerge Dear maintainer. The package archmbox currently fails to build reproducibly on merged-usr vs non-merged systems. Please see attached patch fixing this issue. Regards, Andreas

Bug#915844: p4vasp: reproducible build (usrmerge): embeds path of tool found via PATH

2018-12-07 Thread Andreas Henriksson
Package: p4vasp Version: 0.3.30+dfsg-4+b1 Severity: normal Tags: unreproducible patch User: m...@linux.it Usertags: usrmerge Dear maintainer. The package p4vasp currently fails to build reproducibly on merged-usr vs non-merged systems. Please see attached patch fixing this issue. Regards,

Bug#915849: rpm: reproducible build (usrmerge): embeds path of tool found via PATH

2018-12-07 Thread Andreas Henriksson
Package: rpm Version: 4.14.2+dfsg1-1 Severity: normal Tags: unreproducible patch User: m...@linux.it Usertags: usrmerge Dear maintainer. The package rpm currently fails to build reproducibly on merged-usr vs non-merged systems. Please see attached patch fixing this issue. Regards, Andreas

Bug#915841: newsbeuter FTBFS with json-c 0.13.1

2018-12-07 Thread Birger Schacht
Package: newsbeuter Version: 2.9-8 Severity: normal Tags: upstream Control: block 904418 by -1 Dear Maintainer, There exists a transition slot for json-c (see #904418). When trying to rebuild all reverse dependencies of json-c, newsbeuter fails to rebuild. I am attaching the build log here for

Bug#915848: resource-agents: reproducible build (usrmerge): embeds path of tool found via PATH

2018-12-07 Thread Andreas Henriksson
Package: resource-agents Version: 1:4.2.0-1 Severity: normal Tags: unreproducible patch User: m...@linux.it Usertags: usrmerge Dear maintainer. The package resource-agents currently fails to build reproducibly on merged-usr vs non-merged systems. Please see attached patch fixing this issue.

Bug#915843: ganeti-2.15: reproducible build (usrmerge): embeds path of tool found via PATH

2018-12-07 Thread Andreas Henriksson
Package: ganeti-2.15 Version: 2.15.2-12 Severity: normal Tags: unreproducible patch User: m...@linux.it Usertags: usrmerge Dear maintainer. The package ganeti-2.15 currently fails to build reproducibly on merged-usr vs non-merged systems. Please see attached patch fixing this issue. Regards,

Bug#915845: pekwm: reproducible build (usrmerge): embeds path of tool found via PATH

2018-12-07 Thread Andreas Henriksson
Package: pekwm Version: 0.1.17-3 Severity: normal Tags: unreproducible patch User: m...@linux.it Usertags: usrmerge Dear maintainer. The package pekwm currently fails to build reproducibly on merged-usr vs non-merged systems. Please see attached patch fixing this issue. Regards, Andreas

Bug#915850: rsnapshot: reproducible build (usrmerge): embeds path of tool found via PATH

2018-12-07 Thread Andreas Henriksson
Package: rsnapshot Version: 1.4.2-1 Severity: normal Tags: unreproducible patch User: m...@linux.it Usertags: usrmerge Dear maintainer. The package rsnapshot currently fails to build reproducibly on merged-usr vs non-merged systems. Please see attached patch fixing this issue. Regards, Andreas

Bug#915719: [Pkg-fonts-devel] Bug#915719: Glagolitic shrift dysplay problem for unicode fonts

2018-12-07 Thread Fabian Greffrath
control: tags -1 moreinfo Glagolica Info wrote: > When I use Glagolitic shrift, not correctly display several Unicode > characters in font family Cantarell: I am not exactly sure what you mean, but I am pretty sure that the Cantarell font itself does not include any glyphs in this unicode range.

Bug#915830: busybox: cp: failed to access '/var/tmp/mkinitramfs_h8da2B//usr/bin/busybox': Too many levels of symbolic links

2018-12-07 Thread Chris Boot
On 07/12/2018 12:27, Chris Lamb wrote: > tags 915830 + moreinfo > severity 915830 normal > thanks > > Chris Lamb wrote: > >> Well, I did attempt a usrmerge on this system; did it perhaps break >> halfway through? > > Purging and re-installing busybox fixed this for me; shall I close > this bug?

Bug#915867: yamagi-quake2: broken symlink: /usr/share/doc/yamagi-quake2/NEWS -> ../yamagi-quake2-core/NEWS

2018-12-07 Thread Andreas Beckmann
Package: yamagi-quake2 Version: 7.30+ctf1.05~dfsg-1 Severity: normal User: debian...@lists.debian.org Usertags: piuparts Hi, during a test with piuparts I noticed your package ships (or creates) a broken symlink. >From the attached log (scroll to the bottom...): 0m57.9s ERROR: FAIL: Broken

Bug#912004: r-cran-rlang: autopkgtest regression

2018-12-07 Thread Graham Inggs
Control: reopen -1 Now fails with the following: > test_check("rlang") ── 1. Error: env_binding_type_sum() detects types (@test-env-binding.R#210) ─── no applicable method for 'type_sum' applied to an object of class "character" 1: expect_identical(env_binding_type_sum(env), types) at

Bug#915861: ITP: libsearch-elasticsearch-client-2-0-perl -- module to support elasticsearch in its 2.x version

2018-12-07 Thread Laurent Baillet
Package: wnpp Severity: wishlist Owner: Laurent Baillet * Package name: libsearch-elasticsearch-client-2-0-perl Version : 5.02 Upstream Author : Clinton Gormley * URL : https://metacpan.org/pod/Search::Elasticsearch::Client::2_0 * License : Apache-2

Bug#915862: linux-image-4.18.0-3-686-pae: Doesn't boot/printk on Geode LX

2018-12-07 Thread Gert
Package: src:linux Version: 4.18.20-2 Severity: normal Dear Maintainer, I tried Buster with 4.18.20-2 kernel on an Alix 2C2, with Geode LX800, BIOS 0.99m. After grub unpacking initramfs, the (serial) console outputs nothing (despite earlyprintk/boot_delay), then it reboots by itself. (Same

Bug#915863: php-pimple: New upstream version 3.2.3

2018-12-07 Thread Sebastien Delafond
Package: php-pimple Version: 3.0.2-2 Severity: wishlist Control: block 913903 by -1 Could 3.2.3 be packaged and uploaded to sid ? https://salsa.debian.org/php-team/pear/php-pimple seems to have what's needed already, and it would help in packaging centreon. Cheers, -- Seb -- System

Bug#915830: busybox: cp: failed to access '/var/tmp/mkinitramfs_h8da2B//usr/bin/busybox': Too many levels of symbolic links

2018-12-07 Thread Chris Lamb
Hi Chris, > Well your symlink in /bin was dated 2018-11-26 17:23. Ah, good spot! > Your purge/reinstall could well fix it, just double-check you haven't > ended up with *both* /bin/busybox and /usr/bin/busybox. You should have > only the former and should be able to safely remove

Bug#915862: linux-image-4.18.0-3-686-pae: Doesn't boot/printk on Geode LX

2018-12-07 Thread Gert
This kernel, from the installer, does boot: http://ftp.de.debian.org/debian/dists/testing/main/installer-i386/20181206/images/hd-media/ It has the same version numbers as the "normal" deb that doesn't boot (on which I reported). See attachment for dmesg. [0.00] Linux version

Bug#850157: Please deprecate all ad-hoc patch systems

2018-12-07 Thread Stuart Prescott
Hi! Now that #850156 (deprecate vendor-specific series files) is resolved, we have a recommended pathway by which maintainers can stop using debian/vendor.series files. Amongst other alternatves, the technical committee resolution advised maintainers to use systems that apply patches at build

Bug#911705: [Pkg-fonts-devel] Bug#911705: #911705 [l10n|gu] debian-installer: fonts broken for Gujarati

2018-12-07 Thread Holger Wansing
Hi, Jonas Smedegaard wrote: > Quoting Holger Wansing (2018-12-07 08:46:37) > > Jonas Smedegaard wrote: > > > The UI variant is likely irrelevant: It is a font optimized for use > > > in UI elements like menus where uniform height has higher priority > > > than whatever is the normal spacing

Bug#914707: r-cran-rcmdcheck: autopkgtest regression

2018-12-07 Thread Graham Inggs
Control: reopen -1 Now fails with the following: > test_check("rcmdcheck") ── 1. Failure: print message displays informative output (@test-comparison.R#35) `{ ... }` has changed from known value recorded in 'comparison-newly-failing.txt'. 1/19 mismatches x[4]: "-- R CMD check comparison

Bug#915877: linux-perf-4.18 in Stretch bpo is not linked with libunwind

2018-12-07 Thread Szabolcs Fazekas
package: linux-perf-4.18 version: 4.18.6-1~bpo9+1 Package is not linked with libunwind, which makes perf report very slow when dwarf graph is used. How to reproduce: $ sudo perf_4.18 record -F 200 -p 38429 --call-graph dwarf sleep 120 $ time sudo perf report -G --no-inline > /dev/null real

Bug#915805: Should this package be removed?

2018-12-07 Thread Kevin Smith
Apologies, I’d forgotten that we’d prepared an update from upstream and not gotten it submitted. We’ll try to address this in the next week or so. /K > On 6 Dec 2018, at 21:55, Moritz Muehlenhoff wrote: > > Source: swift-im > Severity: serious > > Should swift-im be removed? > - No upload

Bug#915825: [G-I] installer completely broken for Gujarati, missing font

2018-12-07 Thread Jonas Smedegaard
[re-adding bugreport as cc] Quoting Holger Wansing (2018-12-07 14:26:52) > Jonas Smedegaard wrote: > > Quoting Holger Wansing (2018-12-07 08:39:23) > > > With commit > > > "Replace ttf-freefont-udeb by fonts-freefont-udeb as the former has been > > > removed from unstable (and thus testing)."

Bug#915825: [G-I] installer completely broken for Gujarati, missing font

2018-12-07 Thread Jonas Smedegaard
Quoting Holger Wansing (2018-12-07 08:39:23) > With commit > "Replace ttf-freefont-udeb by fonts-freefont-udeb as the former has been > removed from unstable (and thus testing)." under > https://salsa.debian.org/installer-team/debian-installer/commit/94507f32b36ce050a3f45777b75dce793db3e614 >

Bug#915865: [20181207] ftp.nluug.nl: out of date

2018-12-07 Thread Peter Palfrader
Package: mirrors User: mirr...@packages.debian.org Usertags: mirror-problem Hi! it seems http://ftp.nluug.nl/debian/ is out of date, not having successfully finished a mirrorrun since the 3rd: http://ftp.nluug.nl/debian/project/trace/

Bug#915859: [Pkg-privacy-maintainers] Bug#915859: uses a fixed filename in /tmp

2018-12-07 Thread Peter Palfrader
On Fri, 07 Dec 2018, intrigeri wrote: > Hi, > > Peter Palfrader: > > onionshare uses /tmp/onionshare_server.log as a logfile with --debug. > > Good catch! > > While that code obviously conflicts with basic secure programming best > practices, it seems to me that the default settings of the >

Bug#915859: [Pkg-privacy-maintainers] Bug#915859: uses a fixed filename in /tmp

2018-12-07 Thread intrigeri
Hi, Peter Palfrader: > onionshare uses /tmp/onionshare_server.log as a logfile with --debug. Good catch! While that code obviously conflicts with basic secure programming best practices, it seems to me that the default settings of the fs.protected_symlinks and fs.protected_hardlinks sysctls

Bug#915460: staden-io-lib FTBFS on armel: scramble: cram_codecs.c:1441: cram_huffman_encode_init: Assertion `hi->data.i > 0' failed.

2018-12-07 Thread Andreas Tille
Hi James, when I add this patch I get a failure of the test suite on amd64. Should I sent a full build log or are you able to reproduce the issue? Kind regards Andreas. On Fri, Dec 07, 2018 at 11:30:46AM +, James Bonfield wrote: > On Tue, Dec 04, 2018 at 07:55:14AM +0100, Andreas

Bug#915830: busybox: cp: failed to access '/var/tmp/mkinitramfs_h8da2B//usr/bin/busybox': Too many levels of symbolic links

2018-12-07 Thread Chris Lamb
tags 915830 + moreinfo severity 915830 normal thanks Chris Lamb wrote: > Well, I did attempt a usrmerge on this system; did it perhaps break > halfway through? Purging and re-installing busybox fixed this for me; shall I close this bug? (Downgrading and tagging for now...) Regards, --

Bug#915411: dovecot-core: doveadm crashes with segmentation fault ('batch -A : kick')

2018-12-07 Thread Bernhard Übelacker
Control: found -1 dovecot/1:2.3.4-2 Dear Maintainer, I could reproduce this crash in a minimal stretch amd64 VM with just dovecot-core installed and default configuration. That command crashes also in a similar VM with current buster/testing version. Kind regards, Bernhard (gdb) bt #0

Bug#915866: [python3-dnspython] crashes on parsing DNS zone file with NSEC3

2018-12-07 Thread Maximilian Engelhardt
Package: python3-dnspython Version: 1.15.0-1 Severity: normal Tags: patch Hi, python3-dnspython crashes while parsing my zone files with DNSSEC and NSEC3. The zone files are generated by the knot DNS server and I thus believe them to be correct and valid. Traceback (most recent call last):

Bug#914954: Fails to upgrade from 3.4.0 to 3.4.1: ERROR:root:After system restart, the values must be saved into db. Please, execute tuptime with a privileged user.

2018-12-07 Thread Axel Beckert
Hi Ricardo, Ricardo Fraile wrote: > I have the fix committed on the repo but before update it to Debian, > if possible, I would like that you test it before. Thanks! > git clone -b dev https://github.com/rfrail3/tuptime.git > > cd tuptime && dpkg-buildpackage -us -uc > > dpkg -i

Bug#915873: libsensors-config: removal of libsensors-config makes files disappear from libsensors4

2018-12-07 Thread Andreas Beckmann
Package: libsensors-config Version: 1:3.5.0-1 Severity: serious User: debian...@lists.debian.org Usertags: piuparts replaces-without-breaks Hi, during a test with piuparts and DOSE tools I noticed your package causes removal of files that also belong to another package. This is caused by using

Bug#914833: RFS: python-pyxs/0.4.1-1 [ITP] -- Pure Python XenStore client implementation

2018-12-07 Thread Nicolas Braud-Santoni
Control: tag -1 + pending Control: owner -1 ! Hi Benjamin, On Tue, Nov 27, 2018 at 08:49:53PM +0100, Benjamin Hof wrote: > I am looking for a sponsor for my package "python-pyxs" I will review your package later today. > The Vcs-Browser and Vcs-Git fields point to salsa.debian.org/debian, >

Bug#915148: [Pkg-cmake-team] Bug#915148: cmake: regression in ros-ros-comm build

2018-12-07 Thread Brad King
On 12/6/18 4:16 PM, Jochen Sprickerhof wrote: > after reading up on this, I think this needs fixing in cmake. > > So neither adding -lpthread, > nor adding /usr/lib/x86_64-linux-gnu/libpthread.so > seems correct to me. Both are valid ways to link to the pthread library, which is all the

Bug#915148: [Pkg-cmake-team] Bug#915148: cmake: regression in ros-ros-comm build

2018-12-07 Thread Jochen Sprickerhof
* Brad King [2018-12-07 07:29]: On 12/6/18 4:16 PM, Jochen Sprickerhof wrote: after reading up on this, I think this needs fixing in cmake. So neither adding -lpthread, nor adding /usr/lib/x86_64-linux-gnu/libpthread.so seems correct to me. Both are valid ways to link to the pthread

Bug#913910: atop crashed with "Malloc failed for 1826553824 deviated tasks"

2018-12-07 Thread Marc Haber
Control: tags #913910 confirmed -help Thanks for tracking this down. I have been following the work on the github ticket. Very nice work! Will upload the new fixed version as soon as it's released. Greetings Marc

Bug#915875: stretch-pu: package dnspython/1.15.0-1+deb9u1

2018-12-07 Thread Scott Kitterman
Package: release.debian.org Severity: normal Tags: stretch User: release.debian@packages.debian.org Usertags: pu Please see the attached patch. It's a simple enough fix from upstream for an issue that is causing crashes for a user. I've uploaded this change to unstable. I'll make sure I

Bug#915264: libfolia: Please upgrade to version 1.15

2018-12-07 Thread Maarten van Gompel
Hi Hugh, On 18-12-07 08:43, Hugh McMaster wrote: > Hi Maarten, > > On Sunday, 2 December 2018 10:40 PM, Maarten van Gompel wrote: > > Thanks, I'm aware of it and am currently working to update the debian > > packages. > > Many thanks for your work on libfolia, ucto and frog. > > I saw you had

Bug#915852: ITP: bagit -- Create and validate BagIt packages

2018-12-07 Thread Michael R. Crusoe
Package: wnpp Severity: wishlist Owner: Debian Med team * Package name: bagit Version : 1.7.0 Upstream Author : Ed Summers * URL : https://libraryofcongress.github.io/bagit-python/ * License : CC0 Programming Lang: Python Description : Create and

Bug#915854: transition: petsc

2018-12-07 Thread Drew Parsons
Package: release.debian.org Severity: normal User: release.debian@packages.debian.org Usertags: transition As soon as you're happy with the state of the hdf5 transition, I'd like to proceed with the petsc 3.10 transition. All rdependencies build fine, except deal.ii, which needs an upgrade

Bug#915856: sphinx: Failed cross building with Build-Depends on python3-sphinx

2018-12-07 Thread kaliko
Source: sphinx Version: 1.4.9-2 Severity: normal here is a follow up of a discussion started on irc:debian-devel with mitya57. I'm trying to cross build an "Architecture: any" package [0] (commit:52326679) using the following: sudo pbuilder create --host-arch armhf sudo pbuilder build

Bug#915876: libcpan-meta-perl: superseded by perl

2018-12-07 Thread Niko Tyni
Package: libcpan-meta-perl Version: 2.150010-2 Severity: serious This is a separately packaged version of a module that is also bundled with Perl core. The last upstream release of CPAN::Meta was over two years ago. I don't think there's any value in releasing buster with this as a separate

Bug#915694: [Pkg-clamav-devel] Bug#915694: RFS: clamav-unofficial-sigs/5.6.2

2018-12-07 Thread Scott Kitterman
Yes. You'll need to do that. Scott K On Friday, December 07, 2018 10:25:40 AM Brent Clark wrote: > Good day Scott and Paul > > Thanks so much for looking at my RFS. > > Sorry for not communicating that in the changelog. > Do you guys want that in the changelog? > > Regards > Brent > > On

Bug#915718: RFS: arno-iptables-firewall/2.0.3-1 [ITA]

2018-12-07 Thread Sven Geuer
Hi Adam and Marcos, thank you for your input. I will upload a package with re-integrated sysvinit support soon. @Marcos: I wonder why Lintian on mentors.debian.net complains about several issues while the lintian check included in debuild stays calm. Any clue about this? Cheers, Sven

Bug#915839: bti FTBFS with json-c 0.13.1

2018-12-07 Thread Birger Schacht
Package: bti Version: 034-3 Severity: normal Tags: upstream Control: block 904418 by -1 Dear Maintainer, There exists a transition slot for json-c (see #904418). When trying to rebuild all reverse dependencies of json-c, bti fails to rebuild. I am attaching the build log here for your

Bug#67321: Estimado usuario

2018-12-07 Thread Lorena Lanussy Silva
Estimado usuario Su buzón ha excedido el límite de almacenamiento de 20 GB establecido por el administrador, actualmente se ejecuta en 20.9 GB, no puede enviar ni recibir mensajes nuevos hasta que verifique su buzón. Vuelva a validar su cuenta por correo, complete la siguiente información a

Bug#915832: segmentation fault ghostscript -dSAFER -dBATCH -dNOPAUSE -dNOPROMPT -dMaxBitmap=500000000

2018-12-07 Thread Pierre-Alain Bandinelli
Dear Maintainer, I am seing the same behaviour... It works fine with ghostscript 9.20: 11:18 user@machine ~ % ghostscript -dSAFER -dBATCH -dNOPAUSE -dNOPROMPT -dMaxBitmap=5 -dAlignToPixels=0 -dGridFitTT=2 -sDEVICE=pngalpha -dTextAlphaBits=4 -dGraphicsAlphaBits=4 -r72x72 -dFirstPage=1

Bug#913363: RFS: desktopfolder/1.0.10-1 [ITP]

2018-12-07 Thread Herbert Fortes
On 07/12/2018 08:10, foss.freedom wrote: It has been about a month since the initial package was uploaded to mentors. Still hoping for some feedback please. Yesterday I've tweaked the package to remove an unnecessary build-dependency after discussing with upstream. I note one new

Bug#915855: apache2: systemd alias for httpd

2018-12-07 Thread Valentin Vidic
Package: apache2 Version: 2.4.37-1 Severity: wishlist Dear Maintainer, Since apache2 Provides httpd it would be nice to make a systemd Alias for httpd: # systemctl restart httpd Failed to restart httpd.service: Unit httpd.service not found. This would make apache2 a bit more compatible

Bug#915857: radare2: 3.1 fails to build on mipsel, ppc64el, s390x

2018-12-07 Thread Jeremy Bicha
Source: radare2 Version: 3.1.0+dfsg-1 Severity: serious Tags: ftbfs X-Debbugs-CC: s...@debian.org radare2 3.1.0 and 3.1.2 fails to build on the release architectures mipsel, mips64el, ppc64el, and s390x. https://buildd.debian.org/status/package.php?p=radare2 Build log excerpt

Bug#915859: uses a fixed filename in /tmp

2018-12-07 Thread Peter Palfrader
Package: onionshare Version: 1.3-1 Severity: grave Tags: security onionshare uses /tmp/onionshare_server.log as a logfile with --debug. in onionshare/web.py: | def debug_mode(): | temp_dir = tempfile.gettempdir() | log_handler = logging.FileHandler( | os.path.join(temp_dir,

Bug#915830: busybox: cp: failed to access '/var/tmp/mkinitramfs_h8da2B//usr/bin/busybox': Too many levels of symbolic links

2018-12-07 Thread Chris Lamb
Hi Chris, > This is odd. The busybox package ships only a /bin/busybox binary, so > I'm surprised to see your symlink to /usr/bin/busybox and the binary in > there. Do you have any idea where that came from? Well, I did attempt a usrmerge on this system; did it perhaps break halfway through?

Bug#915148: [Pkg-cmake-team] Bug#915148: cmake: regression in ros-ros-comm build

2018-12-07 Thread Brad King
On 12/7/18 7:44 AM, Jochen Sprickerhof wrote: >> Both are valid ways to link to the pthread library, which is all >> the `-pthread` flag does when used to drive linking. > > I don't agree. Quoting from my mail: > > "Define additional macros required" Macros are for compiling. It is not used

Bug#911705: [Pkg-fonts-devel] Bug#911705: #911705 [l10n|gu] debian-installer: fonts broken for Gujarati

2018-12-07 Thread Cyril Brulebois
Holger Wansing (2018-12-07): > Will see, maybe kibi can comment on this... Just to make it clear for everyone: broken support for Gujarati will have to get mentioned in errata for the upcoming release; I'll help track this down once D-I Buster Alpha 4 is out. Cheers, -- Cyril Brulebois

Bug#915870: gccgo-doc: broken symlinks: /usr/share/man/man1/gccgo.1.gz, /usr/share/info/gccgo.info.gz

2018-12-07 Thread Andreas Beckmann
Package: gccgo-doc Version: 5:7.2.0-2 Severity: normal User: debian...@lists.debian.org Usertags: piuparts Hi, during a test with piuparts I noticed your package ships (or creates) a broken symlink. >From the attached log (scroll to the bottom...): 0m46.5s ERROR: FAIL: Broken symlinks:

Bug#911705: [Pkg-fonts-devel] Bug#911705: #911705 [l10n|gu] debian-installer: fonts broken for Gujarati

2018-12-07 Thread Jonas Smedegaard
Quoting Holger Wansing (2018-12-07 08:46:37) > Jonas Smedegaard wrote: > > The UI variant is likely irrelevant: It is a font optimized for use > > in UI elements like menus where uniform height has higher priority > > than whatever is the normal spacing dynamic in regular texts. > > > > A

Bug#915858: update link to upstream BTS in manpage

2018-12-07 Thread Stéphane Blondon
Package: tortoisehg Severity: minor In the BUGS section in thg manpage, the link goes to a 404 error. The patch provides a new link to the tortoisehg bug tracker. -- Stéphane --- thg.1.xml.orig 2018-12-07 12:26:55.621754326 +0100 +++ thg.1.xml 2018-12-07 12:28:29.239571850 +0100 @@ -453,7

Bug#915460: staden-io-lib FTBFS on armel: scramble: cram_codecs.c:1441: cram_huffman_encode_init: Assertion `hi->data.i > 0' failed.

2018-12-07 Thread James Bonfield
On Tue, Dec 04, 2018 at 07:55:14AM +0100, Andreas Tille wrote: > > === testing ./data/xx#unsorted.sam === > > ./scram.test: 27: [: ./data/xx#unsorted.sam: unexpected operator > > ../progs/scramble -t4 ./data/xx#unsorted.sam test.out/xx#unsorted.sam > > ../progs/scramble -t4 -r ./data/xx.fa

Bug#915864: mirror.solnode.io: out of date

2018-12-07 Thread Peter Palfrader
Package: mirrors User: mirr...@packages.debian.org Usertags: mirror-problem - Forwarded message from Peter Palfrader - From: Peter Palfrader Subject: mirror.solnode.io out of date To: Ben Babich Cc: Debian Mirror Team Reply-To: Debian Mirror Team Date: Wed, 5 Dec 2018 14:21:18 +

Bug#915703: FTBFS: fails to correctly detect PETSc 3.10 version

2018-12-07 Thread Graham Inggs
Control: tags -1 + pending Hi Drew On 2018/12/06 11:30, Drew Parsons wrote: A build of deal.ii against PETSc 3.10 (currently in experimental) fails: This should be fixed in deal.ii 9.0.1-1 in NEW. Regards Graham

Bug#915869: sometimes get backtrace on shutdown

2018-12-07 Thread Peter Palfrader
Package: onionshare Version: 1.3-1 Severity: normal sometimes onionshare throws an exception on shutdown: | Onionshare 1.3 | https://onionshare.org/ | [Dec 07 2018 13:55:25] Settings.__init__ | [Dec 07 2018 13:55:25] Onion.__init__ | [Dec 07 2018 13:55:25] Onion.connect | [Dec 07 2018 13:55:25]

Bug#915868: perl: Consider updating stable to perl 5.24.4

2018-12-07 Thread Dominic Hargreaves
Source: perl Version: 5.24.1-3+deb9u5 Severity: wishlist In the jessie release cycle we decided to upload a maintenance release of 5.20.x, which was quite successful (though we noted a full archive rebuild would be needed in the future), due to one regression. Considering a similar process for

Bug#915629: git-buildpackage: Allow --ignore-branch for 'gbp pq'

2018-12-07 Thread Juan Navarro
On 7/12/18 9:16, Guido Günther wrote: Hi, On Fri, Dec 07, 2018 at 12:37:01AM +0100, Juan Navarro wrote: On 5/12/18 14:18, Guido Günther wrote: Hi, On Wed, Dec 05, 2018 at 01:45:59PM +0100, Juan Navarro wrote: Source: git-buildpackage Version: 0.9.10 Severity: wishlist When trying to import

Bug#911705: [Pkg-fonts-devel] Bug#911705: #911705 [l10n|gu] debian-installer: fonts broken for Gujarati

2018-12-07 Thread Jonas Smedegaard
Quoting Holger Wansing (2018-12-07 14:15:32) > Hi, > > Jonas Smedegaard wrote: > > Quoting Holger Wansing (2018-12-07 08:46:37) > > > Jonas Smedegaard wrote: > > > > A quick search for samples led me to > > > > https://fontinfo.opensuse.org/fonts/NotoSansGujaratiRegular.html > > > > and > >

Bug#915871: RM: aether -- ROM; No longer used, replaced by maven-resolver

2018-12-07 Thread Emmanuel Bourg
Package: ftp.debian.org Severity: normal Hi, Please remove the aether package, it's has been replaced by maven-resolver and is no longer used. Thank you, Emmanuel Bourg

Bug#915872: gcalcli: Cannot import ICS file

2018-12-07 Thread Sebastien Delafond
Package: gcalcli Version: 4.0.0~a4-1 Severity: normal Control: tag -1 + patch With (the default) python3, importing ICS files fail (this is a different problem than #870384) with the following error: Error: name 'file' is not defined!

Bug#915874: rename(1): incorrect note since glibc 2.28

2018-12-07 Thread Johannes 'josch' Schauer
Package: manpages Version: 4.16-1 Severity: normal Hi, currently, the manpage for rename(2) states: Note: There is no glibc wrapper for renameat2(); see NOTES. and further down under NOTES: Glibc does not provide a wrapper for the renameat2() system call; call it using

Bug#915878: pycode-browser: Typo in package description

2018-12-07 Thread Thomas Vincent
Package: pycode-browser Severity: minor Dear Maintainer, I noticed a typo in the description of pycode-browser. Indeed, "Phyiscs" should be spelled "Physics". Thanks a lot for maintaining pycode-browser! Cheers, Thomas -- System Information: Debian Release: 9.6 APT prefers proposed-updates

Bug#915879: RM: libghc-iw-doc -- NBS; no longer built by haskell-iwlib

2018-12-07 Thread Ilias Tsitsimpis
Package: ftp.debian.org Severity: normal Please remove the libghc-iw-doc package, which has been renamed to libghc-iwlib-doc. Thanks, -- Ilias

Bug#909581: proot: does not support renameat2

2018-12-07 Thread Johannes Schauer
Control: tag -1 + patch Hi, On Tue, 25 Sep 2018 17:27:49 +0200 Johannes 'josch' Schauer wrote: > proot currently doesn't support the renameat2 system call. This means > that the 'mv' from coreutils in current Debian unstable and testing will > not work. This in turn doesn't make proot very

Bug#905734: found #905734 hplip/3.17.10

2018-12-07 Thread Paul Elliott
But upon request, packages can be adapted to target specific suites; that's precisely what *-backports suites are. That's why I uploaded a _modified_ hplip 3.18.10+dfsg0-3 to the `stretch-backports` suite. That upload was accepted today and is in the process of being built for all architectures.

Bug#915886: zfs-dkms: module FTBFS for 4.18.0-3-amd64: NR_FILE_PAGES in either node_stat_item or zone_stat_item: NOT FOUND

2018-12-07 Thread Andreas Beckmann
Package: zfs-dkms Version: 0.7.12-1 Severity: serious Hi, # dkms build -k 4.18.0-3-amd64 zfs/0.7.12 Kernel preparation unnecessary for this kernel. Skipping... Running the pre_build script: checking for gawk... no checking for mawk... mawk checking metadata... META file checking build

Bug#915602: Please upgrade to a newer snapshot/version

2018-12-07 Thread Jonas Smedegaard
Control: tag -1 help Hi Laurent, Quoting Laurent Bigonville (2018-12-05 09:29:03) > Current version is quite old (2014) and some other packages seems to > require a newer version (see enchant bug #861141) > > Would it be possible to upgrade to a newer version? Yes, gnulib is too old for

Bug#915880: lvm2: Dependency on liblz4-1 causes /sbin binaries to depend on /usr/lib libraries

2018-12-07 Thread Per Lundberg
Package: lvm2 Version: 2.02.176-4.1 Severity: normal Dear Maintainer, We just noted on a fresh Ubuntu 18.04 installation after it failed to mount the /usr partition on boot, that its /sbin/lvm tool depends on libraries in /usr/lib. I assumed at first that this bug was local to Ubuntu, but for

Bug#915883: usrmerge: missing dependency on perl

2018-12-07 Thread Niko Tyni
Package: usrmerge Version: 19 The convert-usrmerge program uses modules outside perl-base (at least autodie), but this package doesn't declare a corresponding dependency on perl. The build system should invoke dh_perl to fill in the ${perl:Depends} substvar (already referenced in the source

Bug#838503: debian-installer: mdadm should not start syncing RAID1 arrays at full speed during installation

2018-12-07 Thread Lennart Sorensen
On Fri, Dec 07, 2018 at 12:22:38AM +, Steve McIntyre wrote: > I've no idea why he things this is a regression. But this is something > we should probably change anyway - installing on RAID is pointlessly > slow here unless you know how to work around it. And it's been that > way since

Bug#915890: umlet FTBFS: error: package org.apache.bcel.classfile does not exist

2018-12-07 Thread Adrian Bunk
Source: umlet Version: 13.3-1.1 Severity: serious Tags: ftbfs https://tests.reproducible-builds.org/debian/rb-pkg/unstable/amd64/umlet.html ... debian/rules build test -d eclipse-plugin-source || mkdir eclipse-plugin-source # move unused source code out of the way mv

Bug#915891: libjlatexmath-java: missing build depedency on junit4

2018-12-07 Thread Adrian Bunk
Source: libjlatexmath-java Version: 1.0.7-2 Severity: serious Tags: ftbfs https://tests.reproducible-builds.org/debian/rb-pkg/unstable/amd64/libjlatexmath-java.html ... [INFO] --< org.scilab.forge:jlatexmath-fop >--- [INFO] Building jlatexmath-fop 1.0.7

Bug#915892: png-sixlegs FTBFS without internet access

2018-12-07 Thread Adrian Bunk
Source: png-sixlegs Version: 2.0-1 Severity: serious Tags: ftbfs buster sid https://tests.reproducible-builds.org/debian/rb-pkg/unstable/amd64/png-sixlegs.html ... javadoc: [javadoc] Generating Javadoc [javadoc] Debian build on Java 9+ detected: Adding the --ignore-source-errors option

Bug#912201: RFS: manticore/2.7.3 [ITP]

2018-12-07 Thread Adrian Nuta
Hi, Switched to quilt, but I don't understand why mentor lintian says "No compatibility level set!" Thanks

Bug#915884: qemu: CVE-2018-16867: dev-mtp: path traversal in usb_mtp_write_data of the Media Transfer Protocol (MTP)

2018-12-07 Thread Salvatore Bonaccorso
Source: qemu Version: 1:2.12+dfsg-3 Severity: grave Tags: patch security upstream Justification: user security hole Forwarded: https://lists.gnu.org/archive/html/qemu-devel/2018-12/msg00390.html Hi, The following vulnerability was published for qemu. CVE-2018-16867[0]: |dev-mtp: path traversal

Bug#915888: pytest-pylint FTBFS with pytest 3.10.1-1

2018-12-07 Thread Adrian Bunk
Source: pytest-pylint Version: 0.12.3-1 Severity: serious Tags: ftbfs https://tests.reproducible-builds.org/debian/rb-pkg/unstable/amd64/pytest-pylint.html ... === FAILURES === __ test_basic

Bug#878409: postfix: fails to upgrade from 8/jessie to 9/stretch: "aborting postfix install"

2018-12-07 Thread Joost van Baal-Ilić
Hi, Yet another, slightly less ugly, workaround: echo "set postfix/compat_conversion_warning true" | debconf-communicate HTH, Bye, Joost signature.asc Description: Digital signature

Bug#915859: [Pkg-privacy-maintainers] Bug#915859: uses a fixed filename in /tmp

2018-12-07 Thread Salvatore Bonaccorso
Conrol: retitle -1 onionshare: CVE-2018-19960: uses a fixed filename in /tmp Hi, So it will additionally allow potentially denial of service on multi-user systems. Not sure if the grave severity is warranted, though, will leave this discussion to you both :) For tracking the issue, I have

Bug#913001: live-wrapper: Handle firmware list more robustly by using proper whitespace split

2018-12-07 Thread Steve McIntyre
Contro: tag -1 pending On Mon, Nov 05, 2018 at 07:50:37PM +, Witold Baryluk wrote: >Package: live-wrapper >Version: 0.7 >Severity: normal >Tags: patch > >Hi, > >Patch against current master branch in attachement. > >" >Fix splitting of firmare package names > >split(' ') literally

Bug#915862: linux-image-4.18.0-3-686-pae: Doesn't boot/printk on Geode LX

2018-12-07 Thread Gert
After testing several other kernels, I think I have found the root cause: Geode LX does not support PAE. How could I have missed that, sorry for the noise. I don't know how to close this bug properly myself.

Bug#905254: libphp-phpmailer: Please update to version 6.x

2018-12-07 Thread Salvatore Bonaccorso
Control: severity -1 serious As mentioned in https://github.com/PHPMailer/PHPMailer/releases/tag/v5.2.27 the 5.2 branch is deprecated and will not recieve security updates anymore after 31st December 2018. This is not an issue per se, as we usually need to backport fixes to older versions in

Bug#914954: Fails to upgrade from 3.4.0 to 3.4.1: ERROR:root:After system restart, the values must be saved into db. Please, execute tuptime with a privileged user.

2018-12-07 Thread Ricardo Fraile
Hi Axel, Great to reat that the issue has been solved. I just update it upstream with the "Architecture: all". As the documentation points [1], it takes more sense, you are right. Thanks, [1] - https://www.debian.org/doc/debian-policy/ch-controlfields.html#architecture

Bug#908549: gimp: segfault when using measuring tool

2018-12-07 Thread Frederic MASSOT
Package: gimp Version: 2.10.8-1 Followup-For: Bug #908549 Dear Maintainer, I have the same problem with version 2.10.8. Gimp crash at the first click of the measurement tool. Regards. -- System Information: Debian Release: buster/sid APT prefers stable-updates APT policy: (500,

Bug#913328: closed by Florian Schlichting (Re: [Pkg-mpd-maintainers] Bug#913328: both system and user service?)

2018-12-07 Thread Anthony DeRobertis
> > and tracked it down to mpd is installed as both a system service (which > > I've configured, and been using for a while) and a systemd user service, > > are you sure this is the systemd user service, rather than > /etc/xdg/autostart/mpd.desktop? Yes. Here is a fuller excerpt from the

Bug#838503: debian-installer: mdadm should not start syncing RAID1 arrays at full speed during installation

2018-12-07 Thread Steve McIntyre
On Fri, Dec 07, 2018 at 10:11:02AM -0500, Lennart Sorensen wrote: >On Fri, Dec 07, 2018 at 12:22:38AM +, Steve McIntyre wrote: >> I've no idea why he things this is a regression. But this is something >> we should probably change anyway - installing on RAID is pointlessly >> slow here unless

Bug#915885: py3status: Dear Meintainer. Please update py3status to 3.14. Thank You, for your efforts on py3status.

2018-12-07 Thread Mindaugas Celiesius
Package: py3status Version: 3.13-1 Severity: normal Dear Maintainer, the current py3status version in Debian Sid (3.13-1). Upstream version includes many bug fixes and new features I would appreciate having an update version in Debian. Cheers, Mindaugas -- System Information: Debian

Bug#787211: libopenblas-base: 100% CPU load on ARM

2018-12-07 Thread Sébastien Villemot
Control: tags -1 + moreinfo Dear user, On Fri, 29 May 2015 20:19:42 +0200 nfb wrote: > Package: libopenblas-base > Version: 0.2.14-1 > Severity: normal > i have experienced 100% CPU load on ARM with octave + libopenblas as > reported here [0]. I don't know if this is due to my hardware setup

Bug#915881: Ubuntu's custom build flags are overridden by Debian's

2018-12-07 Thread Iain Lane
Package: libdpkg-perl Version: 1.19.1 Severity: normal Tags: patch Heya, In Ubuntu we recently got a version of dpkg including d5374bc618310917557daa9c9ac2f4930515a0b2 for the first time, and I noticed that our ppc64el -O3 build flag wasn't being used - -O2 was being passed instead. See the

  1   2   3   >