Bug#927348: unblock: salt/2018.3.4+dfsg1-2

2019-05-14 Thread Paul Gevers
Hi Benjamin, On 14-05-2019 13:13, Benjamin Drung wrote: > Hi Paul, > > Am Freitag, den 10.05.2019, 20:40 +0200 schrieb Paul Gevers: >> Control: tags -1 moreinfo >> >> So, all in all, I don't want to unblock the new upstream with your >> packaging, we're too late in the cycle and the version

Bug#928992: priority-extra-is-replaced-by-priority-optional doesn't catch some packages

2019-05-14 Thread s3v
Package: lintian Severity: minor Dear maintainer,  after downloading Packages.xz file [1] and searching priority-extra files for amd64 architecture in sid:  $ sed -n "/Priority: extra/p" Packages | wc -l  272 I saw a little divergence. I compared the result with this page [2] that reports

Bug#928994: unblock: t50/5.8.3-2

2019-05-14 Thread Samuel Henrique
Package: release.debian.org Severity: normal User: release.debian@packages.debian.org Usertags: unblock Hello, I'm asking for the unblock of t50 because a critical bug was solved in the last upload. The change consists of an update to an already existing quilt patch, and it is removing

Bug#928991: t50 Makefile is failing to detect right architecture and using cpu specific flags

2019-05-14 Thread Samuel Henrique
Package: t50 Severity: serious Version: 5.8.3-1 Fixed: 5.8.3-2 We found out that version 5.8.3-1 of t50 is trying to detect the architecture its being build to on Makefile but it fails to do that on some cases, this was detected thanks to the reproducible builds project. It is known that t50's

Bug#928989: linux-image-4.19.0-4-amd64: CVE-2019-11815

2019-05-14 Thread Ben Hutchings
Control: fixed -1 4.19.37-1 Control: found -1 4.9.168-2 Control: found -1 3.16.64-2 Control: severity -1 important On Tue, 2019-05-14 at 14:37 -0400, Jeff Cliff wrote: > Package: src:linux > Version: 4.19.28-2 > Severity: grave > Tags: security > Justification: user security hole > > Dear

Bug#928993: sdaps: Please package the latest upstream version

2019-05-14 Thread Boyuan Yang
Package: sdaps Severity: important Dear sdaps maintainers, I noticed that Debian is providing sdaps 1.2.1-2 while upstream has released v1.9.6. The old version depends on python-zbar, which is a python2 binding of libzbar. We are working on zbar to provide python3 binding instead and eventually

Bug#928967: unblock: needrestart/3.4-4

2019-05-14 Thread Jonathan Wiltshire
Control: tag -1 moreinfo On Tue, May 14, 2019 at 11:25:57AM +0200, Patrick Matthäi wrote: > +needrestart (3.4-3~bpo9+1) stretch-backports; urgency=medium > + > + * Rebuild for stretch-backports. > + > + -- Patrick Matthäi Wed, 24 Apr 2019 10:04:02 +0200 > + This changelog entry should not be

Bug#928861: flash-kernel: Please add an entry for FriendlyArm NanoPi NEO 2

2019-05-14 Thread Vagrant Cascadian
On 2019-05-14, Domenico Andreoli wrote: > On Sun, May 12, 2019 at 10:13:50AM -0700, Vagrant Cascadian wrote: >> On 2019-05-12, Karsten Merker wrote: >> > On Sun, May 12, 2019 at 10:40:39AM +0200, Domenico Andreoli wrote: >> > > Please mind that the NanoPi NEO 2 target for u-boot has just been

Bug#928505: fixed in ruby-pygments.rb 1.2.0-4

2019-05-14 Thread Pirate Praveen
On Tue, May 14, 2019 at 8:51 AM, d...@debian.org wrote: Hi, On Sun, May 12, 2019 at 09:55:33PM +0530, Pirate Praveen wrote: We will have to file an unblock request for this to migrate to testing. Can you file it? sorry for my afk, but thanks to release team (maybe), it migrated to

Bug#928014: binNMU: rebuild wine-development against unicode-data 12.1.0~pre1-2

2019-05-14 Thread Paul Gevers
Hi Jens, On 12-05-2019 14:50, Jens Reyer wrote: > Reassigning to the release team then, please binNMU and unblock: > > nmu wine-development_4.2-4 . ANY . unstable . -m "rebuild against > unicode-data 12.1.0~pre1-2" Scheduled. I'll unblock it when all builds are fine. Paul signature.asc

Bug#914034: Bug#911938: libhttp-daemon-ssl-perl FTBFS: tests fail: Connection refused

2019-05-14 Thread gregor herrmann
On Mon, 13 May 2019 01:02:45 +0200, Guilhem Moulin wrote: > Thanks for your analysis, Steffen. Dropping the Debian-specific patch > is definitely the way to go for libwww/LWP. Thanks for the confirmation, Guilhem, and all your work on this issue, and thanks alot to Steffen for tracking down the

Bug#928995: debian-installer: gen-hd-image: Start default partition size at 4MB.

2019-05-14 Thread Vagrant Cascadian
Package: debian-installer Severity: normal Tags: patch X-Debbugs-Cc: debian-...@lists.debian.org Some boot firmware, such as u-boot am335x_evm, have grown large enough that it may overwrite the start of the first partition when configured to start at 1MB. We do not yet support targets affected

Bug#928863: debian-installer: Add support for NanoPi NEO2

2019-05-14 Thread Cyril Brulebois
Hi, Domenico Andreoli (2019-05-14): > > I suppose we could merge this and let you test and report what > > happens with daily builds. Would that be fine with you? > > Of course it's fine with me. Great! Just pushed an updated master; you should find updated images in a couple of hours here:

Bug#928987: compiz: make a compiz-boxmenu package

2019-05-14 Thread boffi
Source: compiz Severity: wishlist Dear Maintainer, I'd like to see compiz-boxmenu in Debian. Thank you for compiz, ciao · g -- System Information: Debian Release: 10.0 APT prefers unstable APT policy: (500, 'unstable'), (500, 'testing')

Bug#928965: unblock: lsb/10.2019051400

2019-05-14 Thread Jonathan Wiltshire
Control: tag -1 confirmed moreinfo On Tue, May 14, 2019 at 08:57:18AM +0200, Didier 'OdyX' Raboud wrote: > I hereby request an upload authorization towards an unblock for package lsb > 10.2019051400, which was not uploaded yet. > > lsb (10.2019051400) unstable; urgency=medium > > [ Harald

Bug#846645: Proposal

2019-05-14 Thread Lehmann Schulz
Please did you receive the project email I sent you?

Bug#928988: RM: openjdk-7/experimental -- ROM; obsolete, no longer builds

2019-05-14 Thread Emilio Pozuelo Monfort
Package: ftp.debian.org Severity: normal Hi, openjdk-7 was kept in experimental in order to prepare updates and see them build, and later backport them to the security suites that still had openjdk-7. However for a while now openjdk-7 hasn't built on experimental anymore, and it's only supported

Bug#905720: Bug#926681: unblock: acme-tiny/1:4.0.4-1

2019-05-14 Thread Samuel Henrique
Hi all, Uploaded to the DELAYED queue with 7 days delay. On Sun, 12 May 2019 at 14:58, Samuel Henrique wrote: > Hello Niels, > > Sorry for the delay on this. >> > > No worries, I know you've been doing lots of work during the freeze, and I > noticed that you also proactively unblocked some of

Bug#928465: stretch-pu: package linux/4.9.168-1

2019-05-14 Thread Salvatore Bonaccorso
Hi Adam, On Thu, May 09, 2019 at 10:04:10PM +0100, Adam D. Barratt wrote: > Control: tags -1 + confirmed > > Hi, > > Sorry for not picking this up sooner. > > On Sun, 2019-05-05 at 11:28 +0200, Salvatore Bonaccorso wrote: > > The last linux upload via the stretch point release unfortunately >

Bug#928996: hddemux FTCBFS: upstream Makefile hard codes build architecture build tools

2019-05-14 Thread Helmut Grohne
Source: hddemux Version: 0.4-7 Tags: patch upstream User: helm...@debian.org Usertags: rebootstrap hddemux fails to cross build from source, because it hard codes build architecture build tools. The attached patch makes the relevant tools substitutable and hddemux cross buildable. Please consider

Bug#928991:

2019-05-14 Thread Samuel Henrique
fixed -1 t50/5.8.3-2 thanks -- Samuel Henrique

Bug#928991:

2019-05-14 Thread Samuel Henrique
Control: fixed -1 t50/5.8.3-2 thanks Yeah our tooling is not that great :/ -- Samuel Henrique

Bug#928966: heimdal: CVE-2018-16860

2019-05-14 Thread Salvatore Bonaccorso
Source: heimdal Version: 7.5.0+dfsg-2.1 Severity: important Tags: security upstream Control: found -1 7.1.0+dfsg-13+deb9u2 Control: found -1 7.1.0+dfsg-13 Hi, The following vulnerability was published for heimdal, actually just what is affecting samba embedded copy of heimdal.

Bug#927142: Cyrus-Imapd expel from Buster?

2019-05-14 Thread Xavier
Le 09/05/2019 à 15:30, Xavier a écrit : > Le 09/05/2019 à 15:13, Anthony Prades a écrit : >> Hi, >> >> I'll add this patch. We use it in production and it works fine. >> >> For upgrade steps, what do you think about: >>

Bug#928204: check-support-status: cannot create /var/lib/debian-security-support/security-support.semaphore: Directory nonexistent

2019-05-14 Thread Holger Levsen
control: tags -1 - unreproducible moreinfo thanks Hi Santiago, On Mon, May 13, 2019 at 11:32:46PM +0200, Santiago Vila wrote: > Way to reproduce it: [...] > The postinst blindly assumes that if the user debian-security-support > exists, then /var/lib/debian-security-support should also exist:

Bug#927153: plymouth: upgrade fails: /usr/share/initramfs-tools/hooks/plymouth failed with return 134

2019-05-14 Thread Vincent Lefevre
On 2019-05-13 14:23:03 +0200, Tobias Eliasson wrote: > Perhaps this defect can be closed? I can't try with fontconfig from buster, but I suppose it can. (BTW, the bug did not appear to be fixed according to the fontconfig changelog, but the changelog does not actually seem to be up-to-date!) --

Bug#928965: unblock: lsb/10.2019051400

2019-05-14 Thread Didier 'OdyX' Raboud
Package: release.debian.org Severity: normal User: release.debian@packages.debian.org Usertags: unblock I hereby request an upload authorization towards an unblock for package lsb 10.2019051400, which was not uploaded yet. lsb (10.2019051400) unstable; urgency=medium [ Harald Dunkel ] *

Bug#927142: Cyrus-Imapd expel from Buster?

2019-05-14 Thread Anthony Prades
Already done... Thank you Xavier. Anthony On 5/14/19 10:53 AM, Xavier wrote: > Le 09/05/2019 à 15:30, Xavier a écrit : >> Le 09/05/2019 à 15:13, Anthony Prades a écrit : >>> Hi, >>> >>> I'll add this patch. We use it in production and it works fine. >>> >>> For upgrade steps, what do you think

Bug#928966: heimdal: CVE-2018-16860

2019-05-14 Thread Brian May
Salvatore Bonaccorso writes: > Source: heimdal > Version: 7.5.0+dfsg-2.1 > Severity: important > Tags: security upstream > Control: found -1 7.1.0+dfsg-13+deb9u2 > Control: found -1 7.1.0+dfsg-13 > > Hi, > > The following vulnerability was published for heimdal, actually just > what is affecting

Bug#928956: Document removal of ecryptfs-utils from Buster

2019-05-14 Thread Andrei POPESCU
Control: tags -1 + moreinfo On Lu, 13 mai 19, 23:16:40, Daniel Lange wrote: > Package: release-notes > Severity: important > > Due to #765854 ecryptfs-utils has been removed from Buster. > The kernel module (ecryptfs.ko) is still built but depending on the upgrade > path users will be unable to

Bug#928068: ruby2.5: FTBFS on ia64 due to segfault

2019-05-14 Thread John Paul Adrian Glaubitz
Hello Antonio! On 4/27/19 2:00 PM, James Clarke wrote: > Currently, ruby2.5 FTBFS, segfaulting when building documentation. > Please include the above patch applied[1] upstream (currently only to > trunk) to fix this. Would you mind including this patch in the next upload? It's just a one-liner

Bug#907327: #907327 -- status?

2019-05-14 Thread Noah Meyerhans
Control: tags -1 + upstream pending fixed-upstream On Tue, Nov 27, 2018 at 10:13:17AM +, David Buckley wrote: > Hi! Is this going to get acted on if I leave it here? I was rather > hoping the maintainers here would know better than I how to submit this > patch. > > I tried many years ago

Bug#927254: libjs-vue-router: ships node module instead of browser one

2019-05-14 Thread Oliver Giles
[2019-04-19 07:03] Xavier > Provided files are not node-* ones but recompiled using rollup. Could > you check if Laminar works well with > https://unpkg.com/vue-router@3.0.2/dist/vue-router.js file ? (same > version than in Buster) It looks like the .js/.min.js files are supposed to be UMD type

Bug#928956: Document removal of ecryptfs-utils from Buster

2019-05-14 Thread Daniel Lange
Am 14.05.19 um 08:54 schrieb Andrei POPESCU: * reason for removal not essential, but it helps to understand the issue #765854 ecryptfs cannot unmount encrypted home directories due to systemd keeping the pam session active even after logout. Upstream bug

Bug#927142: Cyrus-Imapd expel from Buster?

2019-05-14 Thread Anthony Prades
Hi, ok, i'll merge branch into master and update changelog before. Anthony On 5/14/19 10:53 AM, Xavier wrote: > Le 09/05/2019 à 15:30, Xavier a écrit : >> Le 09/05/2019 à 15:13, Anthony Prades a écrit : >>> Hi, >>> >>> I'll add this patch. We use it in production and it works fine. >>> >>> For

Bug#928924: user-mode-linux: xterm functionality broken due to wrong path to port-helper

2019-05-14 Thread Ritesh Raj Sarraf
Control: tag -1 +fixed-upstream CC: Adding Debian Kernel Maintainers Hello Paul, I submitted this fix upstream to the kernel some time ago. I don't recollect if the 4.19 kernel is what had it included.

Bug#864654: synaptic: Duplicate package entries in Origin

2019-05-14 Thread Avinash Sonawane
Hi! I can reproduce this bug on latest Debian stable. Please check the screenshots: 1. https://i.imgur.com/fPCScbm.png 2. https://i.imgur.com/9w0hsyY.png $ lsb_release -a No LSB modules are available. Distributor ID: Debian Description:Debian GNU/Linux 9.9 (stretch) Release:9.9

Bug#929004: yank FTCBFS: multiple reasons

2019-05-14 Thread Helmut Grohne
Source: yank Version: 1.1.0-1 Tags: patch User: helm...@debian.org Usertags: rebootstrap yank fails to cross build from source. During dh_auto_build, it correctly cross builds the "yank" executable. Then during make install, PROG is changed to yank-cli, so it needs to be rebuilt, but no cross

Bug#929005: superkb FTCBFS: upstream build system hard codes build architecture tools

2019-05-14 Thread Helmut Grohne
Source: superkb Version: 0.23-2 Tags: patch upstream User: helm...@debian.org Usertags: rebootstrap superkb fails to cross build from source, because the upstream build system hard codes build architecture build tools (gcc and pkg-config). The attached patch makes these tools substitutable, but

Bug#916375: [debian-mysql] Bug#916375: Update libaprutil1-dbd-mysql

2019-05-14 Thread Otto Kekäläinen
ti 23. huhtik. 2019 klo 10.21 Otto Kekäläinen (o...@debian.org) kirjoitti: > > It was reported in > https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=920619#20: > > Updating libaprutil1-dbd-mysql to 1.6.1-4 (from unstable as of now) > > fixed the problem > > Does this fix

Bug#927851: testing-updates...

2019-05-14 Thread andrew glaeser
-BEGIN PGP SIGNED MESSAGE- Hash: SHA1 > andrew@a68n:~$ ssh root@detst > Linux detst 4.19.0-4-amd64 #1 SMP Debian 4.19.28-2 (2019-03-15) x86_64 > > The programs included with the Debian GNU/Linux system are free software; > the exact distribution terms for each program are described in

Bug#928999: ITP: puppet-module-magnum -- Puppet module for OpenStack Magnum

2019-05-14 Thread Thomas Goirand
Package: wnpp Severity: wishlist Owner: Thomas Goirand * Package name: puppet-module-magnum Version : 14.4.0 Upstream Author : OpenStack Foundation * URL : https://github.com/openstack/puppet-magnum * License : Apache-2.0 Programming Lang: Puppet

Bug#929006: intel-microcode: Atom fails to boot when loading microcode

2019-05-14 Thread Richard Hector
Package: intel-microcode Version: 3.20180807a.2~deb9u1 Severity: normal Dear Maintainer, I don't know whether this is a problem with the intel-microcode package, the kernel, or the microcode itself. I installed intel-microcode and rebooted. The machine failed to boot - when using recovery

Bug#918988: [debian-mysql] Bug#918988: Maybe I can help with this issue

2019-05-14 Thread Otto Kekäläinen
Hello! > Downgrading the package is not working anymore - it was a dirty > workaround for about two months: > apt-get install libmariadbclient18=10.1.26-0+deb9u1 > apt-mark hold libmariadbclient18 Maybe because the problem is not in that package, but some other binary in the chain of what

Bug#929002: release-notes: Current buster release notes do not validate

2019-05-14 Thread Karl O. Pinc
Package: release-notes Severity: normal Hi, The buster release notes as of commit 29a765c0991f, Tue May 14 23:53:09 2019 +0200 do not validate. 'make validate' produces the following errors: nl/about.dbk:131: parser error : Entity 'url-svn-release-notes' not defined url="">web-interface

Bug#928975: (no subject)

2019-05-14 Thread Michael Lustfield
After looking at the provided samples, I would agree that the similarity between the two is too close to be a coincidence, especially considering the timeline described/observed. Without evidence to the contrary, I agree that this should be removed from Debian. You should probably also file

Bug#918988: [debian-mysql] Bug#918988: Maybe I can help with this issue

2019-05-14 Thread debian-mailinglist
Hey Otto, ok thats an interesting question. Querying the installed packages tells me the following: root@system: # apt list --installed [...] php-auth-sasl/stable,stable,now 1.0.6-3 all [installed,automatic] php-cli/stable,stable,now 1:7.0+49 all [installed,automatic]

Bug#929003: release-notes: Provide specific instructions to remove obsolete packages

2019-05-14 Thread Karl O. Pinc
Package: release-notes Severity: normal Tags: patch The buster release notes should provide more specifics when it comes to removing obsolete packages. The following patch makes 2 changes. It recommends removing packages that are obsolete in stretch before beginning the upgrade to buster. It

Bug#929000: sloccount: --autogen flag seems not to work

2019-05-14 Thread Reuben Thomas
Package: sloccount Version: 2.26-5.2 Severity: normal If I have files foo.py and foo.py.in, and run sloccount foo.py, I get no lines counted. The same happens for foo.py.in (perhaps because sloccount does not recognise “.in” as a language?). So I try sloccount --autogen foo.py, but that still

Bug#928942: Bug #928942: udd: cannot import database dump into PostgreSQL ("function release_name(text) does not exist")

2019-05-14 Thread Leandro Doctors
On Tue, 14 May 2019 at 06:20, Michael Banck wrote: > Am Montag, den 13.05.2019, 15:44 -0300 schrieb Leandro Doctors: Hi, Michael! Thanks for your detailed answer. > > Package: qa.debian.org > > Severity: grave > > Justification: causes non-serious data loss> > not sure whether that is

Bug#928997: RM: gpsshogi -- RoQA; RoQA, unmaintained, dead-upsteam. low popcon

2019-05-14 Thread Tobias Frost
Package: ftp.debian.org Severity: normal Dear ftp-masters, Daigo Moriwaki (the maintainer of this package) has asked me to help him with removal of this package: "The upstream, gpsshogi, has no update. It would surely be obsolete. I am ok to orphan or remove it from the Debian." tobi (for the

Bug#928982: Bug: 'systemctl is-enabled' return enabled/true when alias symlinks exist

2019-05-14 Thread Martin Olsson
Hi! I don't know why you need it, since the bug is in systemctl, but here it is: #cat /etc/systemd/system/myfoobar.target [Unit] Description=MyFooBar (with 2 workers) Wants=foo1of2.service foo2of2.service [Install] WantedBy=multi-user.target Since Puppet use the exit-status from 'systemctl

Bug#928942: Bug #928942: udd: cannot import database dump into PostgreSQL ("function release_name(text) does not exist")

2019-05-14 Thread Leandro Doctors
On Tue, 14 May 2019 at 19:01, Mattia Rizzolo wrote: > TTBOMK, the schema Is just handled pseudo-manually, so any change would need > to be applied directly. > > I'm not even sure if the schema dump in git is current anymore (being 7 > months old). Then, probably the best course of action would

Bug#928998: mirror submission for debian.blue3.com.br

2019-05-14 Thread Samir Hanna Verza
Package: mirrors Severity: wishlist User: mirr...@packages.debian.org Usertags: mirror-submission Submission-Type: new Site: debian.blue3.com.br Type: leaf Archive-architecture: ALL amd64 arm64 armel armhf hurd-i386 i386 kfreebsd-amd64 kfreebsd-i386 mips mips64el mipsel powerpc ppc64el s390x

Bug#928942: Bug #928942: udd: cannot import database dump into PostgreSQL ("function release_name(text) does not exist")

2019-05-14 Thread Mattia Rizzolo
On Tue, 14 May 2019, 11:42 pm Leandro Doctors, wrote: > I'll give it a try and open a MR on salsa.d.o to solve this. (I guess > that changing the schema itself should be trivial. I will only have to > think a little bit about the migration process of the current DB.) > TTBOMK, the schema Is

Bug#928968: debian-security-support: cleanup cruft in check-support-status.hook after the buster release

2019-05-14 Thread Holger Levsen
Package: debian-security-support Version: 2019.02.02 Severity: minor check-support-status.hook contains code (copied from postinst) to create the d-s-s user, which (I believe) is useless as the user is created in postinst anyway and this hook will only be run after postinst. we should clean this

Bug#928973: snapshot.debian.org: internal server error (Error 500)

2019-05-14 Thread Vincent Lefevre
Control: severity -1 grave Raising the severity since the packages are themselves affected by the internal errors, making the service impossible to use. -- Vincent Lefèvre - Web: 100% accessible validated (X)HTML - Blog: Work: CR INRIA -

Bug#928974: Vinagre crash with white screen after canceling the RDP session before signing in

2019-05-14 Thread Sauer Jochen
Package: Vinagre Version: 3.22.0 Debian Buster Testing (2019-05-06) When Vinagre starts an RDP connection and you quit before entering the user and password, the screen turns completely white. Now no keyboard shortcut works anymore. Neither Alt + F4 to exit, nor F11 to exit the Vinagre full

Bug#928975: seafile: copyright concerns

2019-05-14 Thread Jan-Henrik Haukeland
Source: seafile Version: 6.2.11-1 We ask Debian to consider removing and stop distributing Seafile packages [1] due to copyright concerns. Background: - Seafile is an open-source dropbox clone created by a team from China. Around 2013 they needed MySQL and PostgreSQL

Bug#928967: unblock: needrestart/3.4-4

2019-05-14 Thread Patrick Matthäi
Package: release.debian.org Severity: normal User: release.debian@packages.debian.org Usertags: unblock Please unblock package needrestart It fixes an upstream bug which leads to a false positive, see #928225 diff -Naur '--exclude=.svn' 3.4-3/debian/changelog 3.4-4/debian/changelog ---

Bug#390067: initscripts: SELinux and log saving in /etc/init.d/check*.sh

2019-05-14 Thread Dmitry Bogatov
control: severity -1 wishlist control: tags -1 +moreinfo [2006-09-29 02:52] Erich Schubert > For SELinux domain transition purposes, it would be good to have the > logsave invocations split out from the init scripts into separate > scripts (that may even boil down to something like this:) >

Bug#928970: RFP: jj - FIFO-based jabber client

2019-05-14 Thread Dmitry Bogatov
Package: wnpp Severity: wishlist Homepage: https://23.fi/jj jj is simple FIFO and filsystem-based Jabber client. It was inspired by "ii" IRC client. pgpYfW6PXCXHP.pgp Description: PGP signature

Bug#928827: libjs-jquery: Minified version of jquery.js (jquery.min.js) throws syntax error

2019-05-14 Thread Christoph Weber
Source: jquery Version: 1.7.2+dfsg-3.2+deb8u6 Followup-For: Bug #928827 Hello, I investigated this issue and believe the recent change "Fix problem calling uglify during build." (related patch is "fix_uglify_invocation.patch") leads to this issue. I guess it was introduced in the security fix

Bug#403369: initscripts: boot messages not displayed on serial console with bootlogd enabled

2019-05-14 Thread Paul Slootman
On Tue 14 May 2019, Dmitry Bogatov wrote: > > Seems things changed for 13 years. I just set up virtual machine with > following kernel options: > > console=tty0 console=ttyS0,9600n > > and runit with "kvm -serial file:serial". When it booted content of > /var/log/boot in VM and "serial"

Bug#927726: wlroots: Please upload new upstream version

2019-05-14 Thread iskrenx2
Hello, how can I help this gets into the experimental repo and unblock Sway 1.0 final? What needs to be done ? Thank you. - П.П. Разбра ли, че Яна щала да си прави сайт? Яна, от онази реклама. Виж сайт билдъра на СуперХостинг.БГ, за да си направиш

Bug#928942: Bug #928942: udd: cannot import database dump into PostgreSQL ("function release_name(text) does not exist")

2019-05-14 Thread Michael Banck
retitle 928942 udd: cannot import current dump due to matview referencing function without schema done Hi, Am Montag, den 13.05.2019, 15:44 -0300 schrieb Leandro Doctors: > Package: qa.debian.org > Severity: grave > Justification: causes non-serious data loss>  not sure whether that is

Bug#928924: user-mode-linux: xterm functionality broken due to wrong path to port-helper

2019-05-14 Thread Ben Hutchings
On Tue, 2019-05-14 at 14:36 +0530, Ritesh Raj Sarraf wrote: > Control: tag -1 +fixed-upstream > > CC: Adding Debian Kernel Maintainers > > > Hello Paul, > > I submitted this fix upstream to the kernel some time ago. I don't > recollect if the 4.19 kernel is what had it included. It went into

Bug#928971: ITS: libgit2

2019-05-14 Thread Jongmin Kim
Source: libgit2 Version: 0.27.7+dfsg.1-0.1 Severity: important Dear Russell (and relevant maintainer of libgit2 package in Debian), The package 'libgit2' appears to be unmaintained by listed Maintainer. The last upload by the listed Maintainer seems July 29, 2017 (2 years ago). After that it was

Bug#928972: unblock: debian-security-support/2019.05.14

2019-05-14 Thread Holger Levsen
+++ debian-security-support-2019.05.14/check-support-status.hook 2019-05-14 11:36:45.0 +0200 @@ -4,6 +4,8 @@ #%# License: GPL-2.0-only # This codes duplicates "postinst configure" +# 20190514: but why? and why all of it, eg the user creation? +# FIXME: we should drop

Bug#927153: plymouth: upgrade fails: /usr/share/initramfs-tools/hooks/plymouth failed with return 134

2019-05-14 Thread Tobias Eliasson
Den tis 14 maj 2019 kl 11:14 skrev Vincent Lefevre : > > (BTW, the bug did not appear to be fixed according to the fontconfig > changelog, but the changelog does not actually seem to be up-to-date!) > > I narrowed it down to commit 34b5c949d51fcc8eafe2301ca8f539f735e31522 upstream at fontconfig

Bug#914034: Bug#911938: libhttp-daemon-ssl-perl FTBFS: tests fail: Connection refused

2019-05-14 Thread Guilhem Moulin
On Tue, 14 May 2019 at 03:57:46 +0200, Steffen Ullrich wrote: >> Ah I see, thanks for the clarification. I thought you meant it could >> yield a deadlock. Aren't temporary failures also possible on plain >> sockets (though of course the extra SSL layer make it strictly more >> likely to happen)?

Bug#928969: stterm: incorrect rendering of cyrillic letters with Terminus

2019-05-14 Thread Dmitry Bogatov
Package: stterm Version: 0.8.2-1 Severity: normal Dear Maintainer, cyrillic letters in stterm with Terminus font are rendered as more wide and overlapping than latin letters. On both "xterm" and under tty cyrillic letters are rendered properly. This issue is only with Terminus font: no other

Bug#624289: sysvinit-utils: bootlogd fails to start: ioctl TIOCGDEV: invalid argument

2019-05-14 Thread Dmitry Bogatov
control: tags -1 +moreinfo [2011-04-27 09:24] arno renevier > Package: sysvinit-utils > Version: 2.88dsf-13.2 > Severity: normal > > Hi, > bootlogd fails to start. I investigated with printf-debug, and found that > ioctl(0, TIOCGDEV, ) fails and strerror(errno) is: "Invalid argument". > Also,

Bug#440709: patch: mount securityfs when it is available (Closes: #440709)

2019-05-14 Thread Dmitry Bogatov
control: tags 440709 +patch +pending Here I refreshed patch: From efedf38621a2a63fd193f1fa740c3a97ae8bee26 Mon Sep 17 00:00:00 2001 From: Dmitry Bogatov Date: Mon, 13 May 2019 15:18:41 + Subject: [PATCH] Mount securityfs when it is available (Closes: #440709) Thanks: Ritesh Raj Sarraf

Bug#627797: patch: ensure mdadm starts before checkfs (Closes: #627797)

2019-05-14 Thread Dmitry Bogatov
control: tags 627797 +patch +pending From 5de0dc682fc11e9bd10691638610955eec979571 Mon Sep 17 00:00:00 2001 From: Dmitry Bogatov Date: Mon, 13 May 2019 17:53:47 + Subject: [PATCH] Ensure mdadm starts before checkfs (Closes: #627797) --- debian/src/initscripts/etc/init.d/checkfs.sh | 2 +-

Bug#403369: initscripts: boot messages not displayed on serial console with bootlogd enabled

2019-05-14 Thread Dmitry Bogatov
control: tags -1 +unreproducible +moreinfo [2006-12-16 18:01] Paul Slootman > part text/plain1776 > Package: initscripts > Version: 2.86.ds1-14.1 > Severity: normal > > While configuring a Sun Netra T1 (which only has a serial console, no > graphics at all), I noticed

Bug#927254: [Pkg-javascript-devel] Bug#927254: libjs-vue-router: ships node module instead of browser one

2019-05-14 Thread Dmitry Bogatov
[2019-04-22 09:56] Dmitry Bogatov > > Provided files are not node-* ones but recompiled using rollup. Could > > you check if Laminar works well with > > https://unpkg.com/vue-router@3.0.2/dist/vue-router.js file ? (same > > version than in Buster) > > Yes, file from this URL is OK. Is it

Bug#669406: patch: remove overly aggressive optimization from /etc/init.d/rc

2019-05-14 Thread Dmitry Bogatov
control: tags 669406 +patch +pending From 59a9444af50c2b922db6b28cf7bb4476acaba19d Mon Sep 17 00:00:00 2001 From: Dmitry Bogatov Date: Tue, 14 May 2019 08:07:02 + Subject: [PATCH] Remove overly aggressive optimization from /etc/init.d/rc The optimization: A start script is not run

Bug#926471: lintian/patch: check that daemons have init.d script

2019-05-14 Thread Dmitry Bogatov
[2019-04-18 10:24] Dmitry Bogatov > Here is prelimitary patch, that implement the check. It seems to affect > t/tags/checks/init.d/init.d-lsb-depends-nonrel/ check, and, maybe, > something else -- I did not run whole test suite. Just a ping, to make sure that issue did not got lost. --

Bug#928808: tracker.debian.org: automatic filing bugs

2019-05-14 Thread Dmitry Bogatov
[2019-05-12 21:26] Raphael Hertzog > On Sat, 11 May 2019, Dmitry Bogatov wrote: > > would it be possible to automatically file bugs with issues, already > > detected by tracker? > > Right now, there's no email notification and I certainly agree > that there should be some email notification

Bug#928966: heimdal: CVE-2018-16860

2019-05-14 Thread Salvatore Bonaccorso
Hi Brian, On Tue, May 14, 2019 at 06:11:05PM +1000, Brian May wrote: > Salvatore Bonaccorso writes: > > > Source: heimdal > > Version: 7.5.0+dfsg-2.1 > > Severity: important > > Tags: security upstream > > Control: found -1 7.1.0+dfsg-13+deb9u2 > > Control: found -1 7.1.0+dfsg-13 > > > > Hi, >

Bug#928973: snapshot.debian.org: internal server error (Error 500)

2019-05-14 Thread Vincent Lefevre
Package: snapshot.debian.org Severity: important I sometimes get internal server errors (Error 500) on various snapshot.debian.org URLs, e.g. https://snapshot.debian.org/package/fontconfig/ -- System Information: Debian Release: 10.0 APT prefers unstable-debug APT policy: (500,

Bug#927348: unblock: salt/2018.3.4+dfsg1-2

2019-05-14 Thread Benjamin Drung
Hi Paul, Am Freitag, den 10.05.2019, 20:40 +0200 schrieb Paul Gevers: > Control: tags -1 moreinfo > > So, all in all, I don't want to unblock the new upstream with your > packaging, we're too late in the cycle and the version really doesn't > match the freeze policy. However, I am offering you

Bug#924787: I would really like to see yubikey-personalization in buster

2019-05-14 Thread Petter Reinholdtsen
Note, the clock is ticking now, as yubikey-personalization is scheduled for removal 2019-06-12 because of this RC bug. -- Happy hacking Petter Reinholdtsen

Bug#928968: debian-security-support: cleanup cruft in check-support-status.hook after the buster release

2019-05-14 Thread Guillem Jover
Hi! On Tue, 2019-05-14 at 11:29:04 +0200, Holger Levsen wrote: > Package: debian-security-support > Version: 2019.02.02 > Severity: minor > check-support-status.hook contains code (copied from postinst) to create > the d-s-s user, which (I believe) is useless as the user is created in >

Bug#928986: CloudCompare: error while loading shared libraries: libQCC_IO_LIB.so:

2019-05-14 Thread Johannes 'josch' Schauer
Package: cloudcompare Version: 2.10.1-1 Severity: grave Justification: renders package unusable Hi, after installing the package, when attempting to start CloudCompare I get the following error message: CloudCompare: error while loading shared libraries: libQCC_IO_LIB.so: cannot open shared

Bug#928989: linux-image-4.19.0-4-amd64: CVE-2019-11815

2019-05-14 Thread Jeff Cliff
Package: src:linux Version: 4.19.28-2 Severity: grave Tags: security Justification: user security hole Dear Maintainer, An issue was discovered in rds_tcp_kill_sock in net/rds/tcp.c in the Linux kernel before 5.0.8. There is a race condition leading to a use-after-free, related to net

Bug#928990: dmarc-cat: attempts internet communication during build

2019-05-14 Thread Gianfranco Costamagna
Package: dmarc-cat Version: 0.9.2-1 Severity: serious Hello, as said, the package attempts to do internet communication during build... this is forbidden by policy. this is an example of what happens in Ubuntu, where internet is more strictly disabled:

Bug#928972: unblock: debian-security-support/2019.05.14

2019-05-14 Thread Holger Levsen
On Tue, May 14, 2019 at 12:11:41PM +0200, Holger Levsen wrote: > + * postinst and check-support-status.hook: add code to create the d-s-s > +user's home directory if it doesn't exist, as schroot copies /etc/passwd > +from the host without creating the user home directories. Closes: >

Bug#748207: It's not going to be fixed

2019-05-14 Thread Changwoo Ryu
Control: tags -1 + wontfix "Fixing" this bug in Debian doesn't really make any sense. This function just exists in the source code and is not even called.

Bug#928977: e2fsprogs: e2scrub_all cron job complains about lack of lvm2

2019-05-14 Thread Jon
Package: e2fsprogs Version: 1.45.1-1 Severity: normal After the latest upgrade of e2fsprogs I started getting email from cron about lvm2 not being installed: Subject: Cron test -e /run/systemd/system || /sbin/e2scrub_all -A -r e2scrub_all: can't find lvcreate --- is lvm2 installed?

Bug#928980: icecc: Icecream writing logs to location with no permission

2019-05-14 Thread Matthew Exon
Source: icecc Version: 1.2-1 Severity: normal Tags: patch Icecream is writing its log files directly to /var/log, even though it is running as the icecc user which has no permission to write to /var/log. This problem has already been reported in Ubuntu here:

Bug#928924: user-mode-linux: xterm functionality broken due to wrong path to port-helper

2019-05-14 Thread Paul Wise
Control: notforwarded -1 On Tue, 2019-05-14 at 14:36 +0530, Ritesh Raj Sarraf wrote: > I submitted this fix upstream to the kernel some time ago. I don't > recollect if the 4.19 kernel is what had it included. > >

Bug#928924: user-mode-linux: xterm functionality broken due to wrong path to port-helper

2019-05-14 Thread Ben Hutchings
On Tue, 2019-05-14 at 18:13 +0530, Ritesh Raj Sarraf wrote: > On Tue, 2019-05-14 at 10:45 +0100, Ben Hutchings wrote: > > > Irrespective, I think it is a fair candidate to be backported if > > 4.19 > > > missed that window. For User-Mode-Linux, The sources are the same > > that > > > the Debian

Bug#923053: python3-stem: Version in stretch-backport isn't installable

2019-05-14 Thread user
Package: python3-stem Followup-For: Bug #923053 python3-distutils is not needed since version 1.7.0

Bug#928924: user-mode-linux: xterm functionality broken due to wrong path to port-helper

2019-05-14 Thread Paul Wise
On Tue, 2019-05-14 at 13:57 +0100, Ben Hutchings wrote: > Does user-mode-linux need to be a separate source package at all? I guess it is separate to not require building yet another variant. Looks like merging it was discussed in 2016: https://bugs.debian.org/837920 -- bye, pabs

Bug#927153: plymouth: upgrade fails: /usr/share/initramfs-tools/hooks/plymouth failed with return 134

2019-05-14 Thread Vincent Lefevre
On 2019-05-14 12:37:57 +0200, Tobias Eliasson wrote: > Den tis 14 maj 2019 kl 11:14 skrev Vincent Lefevre : > > (BTW, the bug did not appear to be fixed according to the fontconfig > > changelog, but the changelog does not actually seem to be up-to-date!) > > > > I narrowed it down to commit

Bug#928068: ruby2.5: FTBFS on ia64 due to segfault

2019-05-14 Thread John Paul Adrian Glaubitz
On 5/14/19 2:39 PM, Antonio Terceiro wrote: > It would be nice if you could build from git master and confirm that all > goes well; I would have done it myself but there is no ia64 porterbox > listed in the Debian LDAP. I just verified that the patch fixes the build on ia64 for me. Adrian --

Bug#928973: Processed: Re: snapshot.debian.org: internal server error (Error 500)

2019-05-14 Thread Peter Palfrader
severity 928973 normal close 928973 thanks On Tue, 14 May 2019, Debian Bug Tracking System wrote: > > severity -1 grave > Bug #928973 [snapshot.debian.org] snapshot.debian.org: internal server error > (Error 500) > Severity set to 'grave' from 'important' This is snapshot being overloaded by

Bug#927153: plymouth: upgrade fails: /usr/share/initramfs-tools/hooks/plymouth failed with return 134

2019-05-14 Thread Tobias Eliasson
Den tis 14 maj 2019 kl 15:05 skrev Vincent Lefevre : > > This patch alone (slightly modified to avoid a conflict) does not > solve the issue. I even suspect that the "double free" error and > that the patch issue had different causes. The "double free" error > might be this one: > > >

  1   2   >