Bug#928185: unblock: openjdk-11/11.0.3+7-4

2019-06-10 Thread tony mancill
On Tue, Jun 11, 2019 at 01:20:30AM +0200, Emmanuel Bourg wrote: > Le 10/06/2019 à 21:12, Sam Hartman a écrit : > > > My position is that the openjdk maintainers should make this decision > > based on what is best for our users based on the quality of the > > software. > > There is little doubt

Bug#930346: Documentation missing

2019-06-10 Thread 積丹尼 Dan Jacobson
Package: viking Version: 1.7-1 Severity: wishlist Add an offline documentation package perhaps, and in a README mention where the online documentation is.

Bug#930340: tiger: [init001e] Don't have required command DIFF (Linux 5)

2019-06-10 Thread Francois Marier
Package: tiger Version: 1:3.2.4~rc1-1 Severity: normal Every hour cron spits out: --ERROR-- [init001e] Don't have required command DIFF. This is the same bug as https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=785589 but for Linux 5 instead of Linux 4. The fix is the same: cd

Bug#930344: radare2: CVE-2019-12790

2019-06-10 Thread Salvatore Bonaccorso
Source: radare2 Version: 3.2.1+dfsg-5 Severity: important Tags: security upstream Forwarded: https://github.com/radare/radare2/issues/14211 Hi, The following vulnerability was published for radare2. CVE-2019-12790[0]: | In radare2 through 3.5.1, there is a heap-based buffer over-read in | the

Bug#911844: okular: Prints to the wrong printer

2019-06-10 Thread Lisandro Damián Nicanor Pérez Meyer
Hi Brian! El lun., 10 jun. 2019 16:54, Brian Potkin escribió: > Severity: critical > thanks > > > > On Thu 25 Oct 2018 at 12:50:25 +0100, Brian Potkin wrote: > > > Package: okular > > Version: 4:17.12.2-2 > > Severity: critical > > Tags: upstream security > > > > > > > > "critical" because a

Bug#930311: lintian: Possible exception to package-contains-documentation-outside-usr-share-doc

2019-06-10 Thread Niels Thykier
Chris Lamb: > Hi Niels, > >> My question is: Should we move this exception to lintian itself and >> stop having people automate overrides > > Oh, without any doubt here — the idea of automatically-generated > overrides simply makes me squirm. > > (Shall we begin by cloning this bug "against"

Bug#930313: unblock: monit/1:5.25.3-1

2019-06-10 Thread Paul Gevers
Control: tags -1 moreinfo Hi Sergey, On 10-06-2019 12:57, Sergey B Kirpichev wrote: > Package: release.debian.org > Severity: normal > User: release.debian@packages.debian.org > Usertags: unblock > > Please unblock package monit. The new upstream > bugfix release fix two CVEs:

Bug#864320: multiple critical problems booting

2019-06-10 Thread Samuel Thibault
gofloss gofloss, le mar. 06 juin 2017 13:52:05 -0700, a ecrit: > apparently debian wants to make its fonts unreadable because [...] Nope. I understand that you got a big pile of frustration like hell, but unfortunately what followed this sentence can't get anything positive done. Debian clearly

Bug#930337: linux-image-4.19.0-5-amd64: mount fails when deprecated 'nobarrier' option is used in fstab

2019-06-10 Thread Ingo Juergensmann
Package: src:linux Version: 4.19.37-3 Severity: critical Justification: breaks the whole system Hi! Just upgraded from stretch to buster to test the whole upgrade thing. In stretch I was using "nobarrier" option to mount my XFS filesystems. As described in

Bug#928770: closed by Laszlo Boszormenyi (GCS) (Bug#928770: fixed in sqlite3 3.27.2-3)

2019-06-10 Thread Salvatore Bonaccorso
Hi Laszlo, On Mon, Jun 10, 2019 at 05:06:07PM +, Debian Bug Tracking System wrote: > sqlite3 (3.27.2-3) unstable; urgency=high > . >* Backport security related patches: [...] > - prevent aliases of window functions expressions from being used as >arguments to aggregate or

Bug#930345: lstp: [INTL:fr] French program translation update

2019-06-10 Thread Quentin Lejard
Package: lstp Version: 5.1.99 Severity: wishlist Tags: patch l10n Dear Maintainer, Please find attached the French translation, proofread by the debian-l10n-french mailing list contributors. This file should be put as fr.po in the appropriate place in your package build tree. Best regards,

Bug#928770: closed by Laszlo Boszormenyi (GCS) (Bug#928770: fixed in sqlite3 3.27.2-3)

2019-06-10 Thread GCS
Hi Salvatore, On Tue, Jun 11, 2019 at 6:18 AM Salvatore Bonaccorso wrote: > On Mon, Jun 10, 2019 at 05:06:07PM +, Debian Bug Tracking System wrote: > > sqlite3 (3.27.2-3) unstable; urgency=high > > . > >* Backport security related patches: > [...] > > - prevent aliases of window

Bug#908868: RFH: docker.io // Would like to maintain Docker.io package

2019-06-10 Thread Dmitry Smirnov
On Monday, 10 June 2019 3:03:23 PM AEST Arnaud Rebillout wrote: > I also want to try to unbundle > containerd from the docker package, This may be very risky to do so one have to have a good justification what those risks are taken for. It has been attempted in the past with disastrous results.

Bug#930342: eblook FTCBFS: does not pass --host to ./configure

2019-06-10 Thread Helmut Grohne
Source: eblook Version: 1:1.6.1-15 Tags: patch User: debian-cr...@lists.debian.org Usertags: ftcbfs eblook fails to cross build from source, because it does not pass --host to ./configure. The easiest way of doing so - using dh_auto_configure - makes eblook cross buildable. Please consider

Bug#930343: libgcr410 FTCBFS: uses the wrong compiler

2019-06-10 Thread Helmut Grohne
Source: libgcr410 Version: 2.4.0-9.2 Tags: patch User: debian-cr...@lists.debian.org Usertags: ftcbfs libgcr410 fails to cross build from source, because it does not pass cross tools to make. The easiest way of doing so - using dh_auto_build - makes libgcr410 cross buildable. Please consider

Bug#930341: rotix FTCBFS: does not use cross tools

2019-06-10 Thread Helmut Grohne
Source: rotix Version: 0.83-5 Tags: patch User: debian-cr...@lists.debian.org Usertags: ftcbfs rotix fails to cross build from source, because it uses build architecture build tools. The presence of a ./configure makes debhelper use the autoconf build system. Thus debhelper assumes that

Bug#930347: showrgb man page FILES wrong

2019-06-10 Thread 積丹尼 Dan Jacobson
Package: x11-xserver-utils Version: 7.7+8 Severity: minor File: /usr/share/man/man1/showrgb.1.gz FILES /usr/share/X11/rgb default database. should actually be .../rgb.txt, (and even that is just a symlink.)

Bug#930338: CVE-2019-10155 IKEv1 Informational exchange integrity check failure

2019-06-10 Thread Daniel Kahn Gillmor
Package: libreswan Version: 3.27-5 Severity critical Control: found -1 3.28-1 Control: forwarded -1 https://libreswan.org/security/CVE-2019-10155/ See the attached message from libreswan upstream about this CVE. I'll fix it in unstable shortly. --dkg --- Begin Message --- -BEGIN PGP

Bug#928185: unblock: openjdk-11/11.0.3+7-4

2019-06-10 Thread Sam Hartman
> "Emmanuel" == Emmanuel Bourg writes: Emmanuel> Le 10/06/2019 à 18:22, Sam Hartman a écrit : >> we release with pre-releases for other packages all the time when >> maintainers believe that's the right call to make. This is an >> area where we trust maintainers to decide

Bug#929521: Conflicts in upgrade to 418.74-1 with optimus setup

2019-06-10 Thread Andreas Beckmann
On 07/06/2019 18.12, Luca Boccassi wrote: > Hi, this should be the list: > > bbswitch bumblebee bumblebee-nvidia primus primus-libs primus-libs-ia32 > nvidia-driver-libs-nonglvnd nvidia-driver-libs-nonglvnd-i386 Is this documented somewhere? This can be minimized to apt-get install

Bug#871321: tenshi: CVE-2017-11746: should create its PID file before dropping privileges

2019-06-10 Thread Andreas Beckmann
Followup-For: Bug #871321 Hi, I'm rising the severity to serious because tenshi violates version ordering constraints since this bug was fixed in wheezy-security: tenshi | 0.13-2| wheezy | source, all tenshi | 0.13-2| stretch | source, all tenshi | 0.13-2

Bug#930292: texlive-luatex: lualatex uses huge memory for Noto CJK fonts

2019-06-10 Thread Hilmar Preuße
Am 10.06.2019 um 06:13 teilte Ryutaroh Matsumoto mit: This report contains UTF-8 encoded text in the latex example. lualatex uses 6 GB of real memory with a small input (see below) when the Noto CJK fonts used in the first time. First Link:

Bug#864320: [RFC] Changing the default cursor on the Linux console?

2019-06-10 Thread Samuel Thibault
Hello, I'm here looking for opinions from debian-accessibility from people with low vision. Samuel Thibault, le lun. 10 juin 2019 22:02:05 +0200, a ecrit: > > whenever i have to use the linux console, i have significant > > neurological issues, due to the blinking cursor. > > Oh, I did not know

Bug#930256: Ignoring Provides line with non-equal DepCompareOp for package firefox-l10n-bn-bd

2019-06-10 Thread shirish शिरीष
at bottom :- On 10/06/2019, Ansgar wrote: > Hi, > >> I'm rising the severity since this causes errors in dose-debcheck, which >> might affect QA or other infrastructure: > > I removed the problematic package from experimental earlier; that should > make it a bit less urgent to upload a new

Bug#930050: miniupnpd: CVE-2019-12107 CVE-2019-12108 CVE-2019-12109 CVE-2019-12110 CVE-2019-12111

2019-06-10 Thread Salvatore Bonaccorso
hi Thomas, On Fri, Jun 07, 2019 at 09:31:41AM +0200, Thomas Goirand wrote: > Hi Salvatore and the rest of the security team, > > I have prepared the Stretch update for the new Stretch update: > miniupnpd/1.8.20140523-4.1+deb9u2 > > The debdiff is attached to this mail. The resulting package is

Bug#930339: RFP: wsdd2 -- WSD/LLMNR Discovery/Name Service Daemon

2019-06-10 Thread Dean Hamstead
Package: wnpp Severity: wishlist * Package name: wsdd2 Version : 1.8 Upstream Author : Netgear * URL :https://github.com/kochinc/wsdd2 * License : GPL Programming Lang: C Description : WSD/LLMNR Discovery/Name Service Daemon With Microsoft turning off

Bug#928750: - Bug in grubx64.efi triggered by shim?

2019-06-10 Thread Michael Kesper
Hi Steve, On 10.06.19 18:57, Steve McIntyre wrote: > In fact, I'm looking at a different fix: using a specific build of the > Grub netboot image with the d-i prefix configured. Watch this space! Thanks for investigating and keeping me informed! :) Bye Michael signature.asc Description:

Bug#595696: Bug#864320: multiple critical problems booting

2019-06-10 Thread Samuel Thibault
Control: block 864320 by 816111 595696 Hello, gofloss gofloss, le mar. 06 juin 2017 13:52:05 -0700, a ecrit: > below i describe multiple bugs in booting in jessie, which > might be relevant to stretch. [...] > rebooted, and discovered that the font was unreadably small, > unlike wheezy. > >

Bug#929882: buildd.debian.org: possible conflict between the "dhelp" package and the KDE packages on debian buster

2019-06-10 Thread Paul Gevers
Hi khelpcenter maintainers, On Sat, 01 Jun 2019 21:30:41 +0200 pnd23 wrote: > KDE packages install their documentation files in /usr/share/doc/HTML on > buster > (in debian 8 this was: /usr/share/doc/kde/HTML). The "dhelp" package erases > this folder when it rebuilds its index. The KHelpcenter

Bug#928758: [debian-mysql] Bug#928758: mariadb-server: mysql_install_db fails if basedir option isn't set, expecting resolveip to be present in /usr/sbin/

2019-06-10 Thread Faustin Lammler
Hi Michael, I can confirm this bug and I am not able to reproduce it with the upstream 10.1 version (from the official MariaDB repo). I will check what's the diff and if we can expect a fix in the next release based on the upstream version or if we have to submit a specific patch directly on

Bug#911844: okular: Prints to the wrong printer

2019-06-10 Thread Brian Potkin
Severity: critical thanks On Thu 25 Oct 2018 at 12:50:25 +0100, Brian Potkin wrote: > Package: okular > Version: 4:17.12.2-2 > Severity: critical > Tags: upstream security > > > > "critical" because a document should always go to where it is sent. > Please reduce the severity if I have

Bug#930311: lintian: Possible exception to package-contains-documentation-outside-usr-share-doc

2019-06-10 Thread Chris Lamb
Hi Niels, > My question is: Should we move this exception to lintian itself and > stop having people automate overrides Oh, without any doubt here — the idea of automatically-generated overrides simply makes me squirm. (Shall we begin by cloning this bug "against" dh-r?) Regards, --

Bug#928185: unblock: openjdk-11/11.0.3+7-4

2019-06-10 Thread Emmanuel Bourg
Le 10/06/2019 à 21:12, Sam Hartman a écrit : > My position is that the openjdk maintainers should make this decision > based on what is best for our users based on the quality of the > software. There is little doubt the OpenJDK users want the latest stable release for their stable systems, and

Bug#930134: Please package new upstream version

2019-06-10 Thread Jonas Meurer
Hi Thomas, Thomas Goirand: >> do you have plans to update the python-falcon packages to a newer >> upstream version (2.0.0 being the most recent one at the moment) >> anytime soon? >> >> python3-falcon is a dependency for mailman3 and starting with mailman3 >> version 3.2.2, falcon > 1.0.0 is

Bug#930029: Some extra output with earlyprintk set

2019-06-10 Thread Leon Gehling
oading Linux 4.19.0-5-amd64 ...Loading Linux 4.19.0-5-amd64 .. . Loading initial ramdisk ...Loading initial ramdisk .. . [    0.00] Linux version 4.19.0-5-amd64 (debian-ker...@lists.debian.org) (g) [    0.00] Command line: BOOT_IMAGE=/boot/vmlinuz-4.19.0-5-amd64 root=UUID=0 [    0.00]

Bug#927996: RFS: diskfit/2.0.2.3 [ITP] -- Simple disk fit calculator

2019-06-10 Thread Adam Borowski
Hi! On Wed, May 29, 2019 at 08:30:50AM +0200, Heiko Schäfer wrote: > an updated package is available at > > https://launchpad.net/~velnias/+archive/ubuntu/sandbox/+sourcefiles/diskfit/2.0.2.6-1~eoan~ppa1/diskfit_2.0.2.6-1~eoan~ppa1.dsc > > Please ignore the '~eoan~ppa1' for the moment, because I

Bug#902174: #902174: RFP: mes

2019-06-10 Thread Vagrant Cascadian
On 2019-06-10, Vagrant Cascadian wrote: > On 2019-06-10, Jan Nieuwenhuizen wrote: >> Vagrant Cascadian writes: >>> Mes itself still fails to build I updated to b3fa6273210200cf2694491b07ed5a328e9a4e62 from upstream, added a few packaging updates, and... The current branch builds a package!

Bug#930091: bison is wrongly marked Multi-Arch: foreign

2019-06-10 Thread Matthias Klose
On 06.06.19 20:08, Helmut Grohne wrote: > Package: bison > Version: 2:3.3.2.dfsg-1 > Severity: important > > bison is marked Multi-Arch: foreign and Depends on libbison-dev. > Packages Build-Depend on bison and expect a libbison-dev (for the host > architecture). This is broken. > > We had this

Bug#929451: linking shaders twice fails, fixed by rebuilding the package

2019-06-10 Thread Steinar H. Gunderson
On Thu, May 23, 2019 at 10:09:21PM +0200, Steinar H. Gunderson wrote: > Unfortunately, even after clearing the shader cache, I can provoke these > issues with a bit of work. So something is corrupting the shader cache. I tracked this to https://bugs.freedesktop.org/show_bug.cgi?id=110872

Bug#930195: avr-libc: Upstream avr-libc maintainers appear to be MIA; can another source be found?

2019-06-10 Thread Paul "LeoNerd" Evans
On Mon, 10 Jun 2019 11:07:29 +0200 Hakan Ardo wrote: > There have been a sugestion to use Microchip Packs Repository: > > http://packs.download.atmel.com/ > > But as far as I can tell, these are binary distributions and thus not > suitable for mainstream debian (I suppose placing them i

Bug#812609: tracker.debian.org: wrong versioned links for security versions

2019-06-10 Thread zaza
On Fri, 26 Apr 2019 16:17:15 +0200 Salman Mohammadi wrote: > On Mon, 25 Jan 2016 16:43:38 +0100 Ricardo Mones wrote: > > > > The links to .dsc file wich appear on versioned links panel for security > > versions are using httpredir.d.o, which always gives 40x errors for those > > package

Bug#812609: tracker.debian.org: wrong versioned links for security versions

2019-06-10 Thread zaza
On Mon, 10 Jun 2019 08:09:23 -0300 zaza wrote: > On Fri, 26 Apr 2019 16:17:15 +0200 Salman Mohammadi wrote: > > On Mon, 25 Jan 2016 16:43:38 +0100 Ricardo Mones wrote: > > > > > > The links to .dsc file wich appear on versioned links panel for security > > > versions are using httpredir.d.o,

Bug#930314: mariadb-10.3 FTCBFS: multiple reasons

2019-06-10 Thread Helmut Grohne
Source: mariadb-10.3 Version: 1:10.3.15-2 Tags: patch User: debian-cr...@lists.debian.org Usertags: ftcbfs mariadb-10.3 fails to cross build from source. The immediate reason is that its perl dependency is not satisfiable. I'm not quite sure what it needs perl for, so I'm uneasy about annotating

Bug#930195: avr-libc: Upstream avr-libc maintainers appear to be MIA; can another source be found?

2019-06-10 Thread Hakan Ardo
Hi, Apache 2.0 licence is fine, but for the main distribution we need the source as well. On Mon, Jun 10, 2019 at 12:28 PM Paul "LeoNerd" Evans < leon...@leonerd.org.uk> wrote: > On Mon, 10 Jun 2019 11:07:29 +0200 > Hakan Ardo wrote: > > > There have been a sugestion to use Microchip Packs

Bug#927775: monit: CVE-2019-11454 CVE-2019-11455

2019-06-10 Thread Sergey B Kirpichev
On Sun, Jun 09, 2019 at 01:44:18PM +0200, Salvatore Bonaccorso wrote: > I gave a reason though now in my previous mail I was expecting such explanation before changing in severity... > > > Could you please work out with the Release team via an unblock request > > > if they would wave through the

Bug#930302: installing and starting docker changes iptables FORWARD policy, breaking unrelated things

2019-06-10 Thread Shengjing Zhu
Control: forcemerge 865975 -1 I looked at the bug list of docker.io, found it's already reported at #865975 docker did this intentionally, and also metioned this behaviour in its chanelog(in src engine/CHANGELOG.md, not in /usr/share/doc) * Change the default `FORWARD` policy to `DROP`

Bug#888025: how to integrate ca-certificates with gpgsm (for email s/mime signature verification)

2019-06-10 Thread Daniel Kahn Gillmor
Hi Gregor, everyone-- On Wed 2019-06-05 19:10:57 +0200, Gregor Zattler wrote: > I use notmuch-emacs to read my email and sometimes do use GnuPG, > therefore notmuch-emacs is configured to verify signatures but > does so also for S/MIME signatures. When displaying such emails > I'm asked if I

Bug#812609: tracker.debian.org: wrong versioned links for security versions

2019-06-10 Thread Ricardo Mones
On Mon, Jun 10, 2019 at 08:09:23AM -0300, zaza wrote: > On Fri, 26 Apr 2019 16:17:15 +0200 Salman Mohammadi wrote: > > On Mon, 25 Jan 2016 16:43:38 +0100 Ricardo Mones wrote: > > > > > > The links to .dsc file wich appear on versioned links panel for security > > > versions are using

Bug#930315: Please drop obsolete uniutils package

2019-06-10 Thread Egmont Koblinger
Package: uniutils Version: 2.27-2+b1 Please remove this obsolete package from Debian. Upstream hasn't seen a new release for more than 10 years. The package provides useful character information based on version 5.1 of the Unicode standard. Unicode is continuously evolving, currently at version

Bug#927267: nitroshare: Nitroshare on pc is undiscoverable by nitroshare on mobile, and vice versa, due to old version

2019-06-10 Thread jim_p
Package: nitroshare Version: 0.3.3-1.1 Followup-For: Bug #927267 I think its severity should be raised to grave, since it does make the package unsusable. There is also a issue report on the project's github page by a kubuntu user who has exactly the same issue. -- System Information: Debian

Bug#930297: unblock: fastforward/1:0.51-6

2019-06-10 Thread Andreas Beckmann
Package: release.debian.org Severity: normal User: release.debian@packages.debian.org Usertags: unblock Please unblock package fastforward diff -Nru fastforward-0.51/debian/changelog fastforward-0.51/debian/changelog --- fastforward-0.51/debian/changelog 2019-01-13 00:29:15.0 +0100

Bug#930298: unblock: dot-forward/1:0.71-5

2019-06-10 Thread Andreas Beckmann
Package: release.debian.org Severity: normal User: release.debian@packages.debian.org Usertags: unblock Please unblock package dot-forward diff -Nru dot-forward-0.71/debian/changelog dot-forward-0.71/debian/changelog --- dot-forward-0.71/debian/changelog 2019-01-11 21:46:13.0 +0100

Bug#930005: regina-rexx: rexxutil error

2019-06-10 Thread Ben Longbons
Package: libregina3 Version: 3.6-2.1 Followup-For: Bug #930005 Dear Maintainer, I took a look at this since I thought it would be a simple `-ltinfo` fix, but it's more complicated than that. As it is, the package can't possibly run on 64-bit platforms. There are a *lot* of dangerous warnings;

Bug#930301: RM: liguidsoap [all] -- RoQA; NBS; obsolete arch:all package

2019-06-10 Thread Andreas Beckmann
Package: ftp.debian.org Severity: normal liguidsoap is arch:all cruft liguidsoap | 1.1.1-7.2 | unstable | all liquidsoap | 1.1.1-7.2 | unstable | source liquidsoap | 1.3.4-1 | unstable | source, amd64, arm64, armel, armhf, i386, mips, mips64el, mipsel,

Bug#907135: [Box Backup] Debian now requires 2048bit RSA keys

2019-06-10 Thread Chris Wilson
Hi Reinhard, I don't blame you. I think that for Debian to upgrade a package, changing a global setting, break some of its dependencies, and then kick out the resulting broken packages a month later (nearly a year before the expected release date) seems pretty harsh. In this case it took me 4.5

Bug#902174: #902174: RFP: mes

2019-06-10 Thread Jan Nieuwenhuizen
Vagrant Cascadian writes: Hi! > Mes itself still fails to build, but I updated to 0.19, and made a > branch based off of janneke's wip branch as well > (debian/master-wip). configure fails to detect nyacc. It may be an issue > with multi-arch paths (e.g. /usr/lib/guile/2.2 > vs.

Bug#930300: libghc-argon2-dev: switch dependency to libargon2-dev

2019-06-10 Thread Andreas Beckmann
Package: libghc-argon2-dev Version: 1.3.0.1-4 Severity: serious User: debian...@lists.debian.org Usertags: piuparts Control: affects -1 + libghc-argon2-prof Hi, during a test with piuparts I noticed your package causes problems during the upgrade from stretch to buster. >From the attached log

Bug#930322: network-manager-gnome: French Translation : at least one text string is not translated

2019-06-10 Thread Gilles CHARABOT
Package: network-manager-gnome Version: 1.8.20-1.1 Severity: normal Dear all, * What led up to the situation? The buster profile being French, in "Settings" -> "Network" -> "Wired" -> "Identity" the system should have called its first connection "Connexion filaire 1" rather than

Bug#929248: apt: E: Repository # changed its 'Suite' value from 'buster' to 'testing'; but how to accept?

2019-06-10 Thread Thorsten Glaser
David Kalnischkies dixit: >While I might agree the behaviour of apt-get could be more revealing, >I don't think this would belong in apt-secure. I guess we could add >another N: for apt-get, but I haven't looked at where to add that it is That sounds agreeable as well. >On a sidenote: The

Bug#930320: with attachements it is better

2019-06-10 Thread Bardot Jérôme
join the missing 2 screenshots 0x053A41EF03878A98.asc Description: application/pgp-keys signature.asc Description: OpenPGP digital signature

Bug#930089: unblock: mediawiki/1:1.31.2-1

2019-06-10 Thread Kunal Mehta
My original mail didn't make it to the debian-release mailing list due to the size of the debdiff, so here it is, without the attachment. -- Kunal On Thu, 06 Jun 2019 13:40:46 -0400 Kunal Mehta wrote: > Package: release.debian.org > Severity: normal > User:

Bug#930330: unblock: cryptsetup/2.1.0-5

2019-06-10 Thread Guilhem Moulin
Package: release.debian.org Severity: normal User: release.debian@packages.debian.org Usertags: unblock Tags: d-i Hi there, During a chat last at MiniDebConf Hamburg last week-end we (cryptsetup package maintainers + KiBi + ivodd) discussed a path forward for #927165 (debian-installer:

Bug#930323: parallel: Perl warning printed when running

2019-06-10 Thread Philipp Marek
Package: parallel Version: 20161222-1.1 Severity: normal Running parallel gives me sysread() is deprecated on :utf8 handles. This will be a fatal error in Perl 5.30 at /usr/bin/parallel line 8413. when using perl=5.28.1-6. -- System Information: Debian Release: 10.0 APT prefers testing

Bug#930324: unblock: nageru/1.8.4-2

2019-06-10 Thread Steinar H. Gunderson
Package: release.debian.org Severity: normal User: release.debian@packages.debian.org Usertags: unblock Please unblock package nageru It contains a fix for an RC bug that is only seen with recent versions of Mesa (but buster's Mesa is new enough). The fix is a trivial backport from upstream

Bug#930134: Please package new upstream version

2019-06-10 Thread Thomas Goirand
On 6/7/19 7:25 PM, Jonas Meurer wrote: > Package: src:python-falcon > Version: 1.0.0-2 > Severity: normal > > Hello, > > do you have plans to update the python-falcon packages to a newer > upstream version (2.0.0 being the most recent one at the moment) > anytime soon? > > python3-falcon is a

Bug#930325: ITP: python-consonance -- WhatsApp's handshake implementation using Noise Protocol

2019-06-10 Thread Josue Ortega
Package: wnpp Severity: wishlist Owner: Josue Ortega *Package name: python-consonance Version: 0.1.3 Upstream Author: Tarek Galal *URL: https://github.com/tgalal/consonance/ *Licence: GPL-3.0 Programming Language: Python Description: WhatsApp's handshake implementation using Noise Protocol

Bug#927165: debian-installer: improve support for LUKS

2019-06-10 Thread Guilhem Moulin
Hi there, On Mon, 15 Apr 2019 at 23:24:19 +0200, Cyril Brulebois wrote: >>> One could argue that cryptodisk support has never been supported by >>> d-i anyway, >> >> Yup, and I suppose that's why I overlooked this in my mail to >> debian-boot :-P Jonathan Carter had a similar report last week >>

Bug#930326: ITP: python-dissonance -- A python implementation for Noise Protocol Framework

2019-06-10 Thread Josue Ortega
Package: wnpp Severity: wishlist Owner: Josue Ortega *Package name: python-dissonance Version: 0.34.3 Upstream Author: Tarek Galal *URL: https://github.com/tgalal/dissonance *Licence: MIT Programming Language: Python Description: A python implementation for Noise Protocol Framework

Bug#930327: approx: cron.weekly: Don't mail deleted files

2019-06-10 Thread Baurzhan Ismagulov
Package: approx Version: 5.7-3 Severity: wishlist Hello, if cron.weekly deletes files, the list is mailed to root. Other programs send nothing on success. It would be nice to have the verbosity configurable in /etc/default/approx, or disable printing by default. With kind regards, Baurzhan.

Bug#930328: approx: Use $cache from approx.conf in cron.weekly

2019-06-10 Thread Baurzhan Ismagulov
Package: approx Version: 5.7-3 Severity: wishlist Hello, the cache path is duplicated in approx.conf and cron.weekly. If one changes $cache in the former, one has to to the same in the latter. It would be better if the path would be read from /etc/default/approx or approx.conf. With kind

Bug#930329: ITP: libmoox-shorthas-perl -- Shortcuts for common Moo has attribute configurations

2019-06-10 Thread Utkarsh Gupta
Package: wnpp Severity: wishlist Owner: Utkarsh Gupta * Package name : libmoox-shorthas-perl Version : 1.190320-1 Upstream Author : Christian Walde * URL : https://github.com/wchristian/MooX-ShortHas * License : CC0-1.0 Programming Lang : Perl

Bug#812609: tracker.debian.org: wrong versioned links for security versions

2019-06-10 Thread Herbert Fortes
On 6/10/19 9:10 AM, Ricardo Mones wrote: > On Mon, Jun 10, 2019 at 08:09:23AM -0300, zaza wrote: >> On Fri, 26 Apr 2019 16:17:15 +0200 Salman Mohammadi wrote: >>> On Mon, 25 Jan 2016 16:43:38 +0100 Ricardo Mones wrote: The links to .dsc file wich appear on versioned links panel for

Bug#928185: unblock: openjdk-11/11.0.3+7-4

2019-06-10 Thread Emmanuel Bourg
Le 10/06/2019 à 16:18, tony mancill a écrit : > Emmanuel, I recognize that I am reversing position turn on this. I know > that you had expressed reservations about shipping with an EA version as > well. I took a look at the diffs between 11.0.3+7 and 11.0.4+4, and > all though there are a lot

Bug#930296: RM: git-core [all] -- RoQA; NBS; obsolete arch:all package; provided by git

2019-06-10 Thread Andreas Beckmann
Package: ftp.debian.org Severity: normal Please clean up the obsolete transitional git-core package. All rdepends are satisfied by the Provides in git. Thanks. Andreas

Bug#930299: apt: A warning "Ignoring Provides line with non-equal DepCompareOp for package" for two packages

2019-06-10 Thread jim_p
Package: apt Version: 1.8.2 Severity: normal Dear Maintainer, After yesterday's apt-get update, I get this message everytime I run it W: Ignoring Provides line with non-equal DepCompareOp for package firefox-l10n-bn-bd W: Ignoring Provides line with non-equal DepCompareOp for package

Bug#930316: konsole: Segmentation fault arisen when obtining new konsole themes

2019-06-10 Thread Saverio Brancaccio
Package: konsole Version: 4:18.04.0-1 Severity: important Dear Maintainer, I opened the Konsole (KDE) app, next I edited profile settings, next I selected "aspect..." tab, next I clicked on button "Obtain new theme", next a setting panel opened, next I inserted some text to search new theme in

Bug#919181: fixes to WIP package

2019-06-10 Thread Paolo Greppi
Hi, thanks for working on this ! I set out to try and reproduce 927254, using the laminar debs built from the WIP package here: https://salsa.debian.org/debian/laminar But after apt install laminar the service would not start at first: Jun 10 12:39:22 laminar systemd[1]: Started Laminar

Bug#930317: dpkg: refuse to create packages with invalid versioned Provides: foo (<< 42)

2019-06-10 Thread Andreas Beckmann
Package: dpkg Version: 1.19.7 Severity: important Hi Guillem, dpkg should refuse to create packages with invalid versioned Provides (unless --nocheck is given) to prevent bugs like #930256 where apt emits # apt-get update W: Ignoring Provides line with non-equal DepCompareOp for package

Bug#929248: apt: E: Repository # changed its 'Suite' value from 'buster' to 'testing'; but how to accept?

2019-06-10 Thread David Kalnischkies
Hi, On Sun, May 19, 2019 at 11:37:57PM +0200, Thorsten Glaser wrote: > Sure, but the apt-secure(8) manpage is 8 screen pages, and while > I eventually (took me some time) found the right section, it does > not document *how* one would accept this change: Well, apt-secure manpage is supposed to

Bug#930316: konsole: Segmentation fault arisen when obtining new konsole themes

2019-06-10 Thread Lisandro Damián Nicanor Pérez Meyer
Control: tag -1 important Hi Aurelien and Saverio! El lun., 10 jun. 2019 10:42, Aurélien COUDERC escribió: > control: tags -1 + confirmed > > Hi Saverio, > > thank you for your bug report. > I confirm I reproduce the bug. > > This is due to the Konsole package not shipping

Bug#930319: spectre-meltdown-checker: wish it would notify the user if the CPU has unfixable bugs

2019-06-10 Thread Russell Coker
Package: spectre-meltdown-checker Version: 0.42-1 Severity: wishlist Tags: upstream model name : Intel(R) Core(TM)2 Quad CPUQ9505 @ 2.83GHz Above is the CPU specification from /proc/cpuinfo on this system.

Bug#923500: snapd: non-classic snap not confined

2019-06-10 Thread Zygmunt Krynicki
Thank you for reporting this bug. This problem is something we’ve been investigating for a while internally. We need to improve the user experience around installing snaps when we know the sandbox confinement is not what we designed it for. Right now the consequence of that is that large chunk

Bug#930256: Ignoring Provides line with non-equal DepCompareOp for package firefox-l10n-bn-bd

2019-06-10 Thread Andreas Beckmann
Followup-For: Bug #930256 Control: severity -1 serious Hi, I'm rising the severity since this causes errors in dose-debcheck, which might affect QA or other infrastructure: Fatal error in module deb/debcudf.ml: This should never happen : a provide can be either = or unversioned I also filed

Bug#930316: konsole: Segmentation fault arisen when obtining new konsole themes

2019-06-10 Thread Saverio Brancaccio
Hello guys, I tried to create the file /etc/xdg/konsole.knsrc with thi content (taken from upstream): [KNewStuff3] ProvidersUrl=https://download.kde.org/ocs/providers.xml Categories=Konsole Color Schemes TargetDir=konsole AcceptHtmlDownloads=false Uncompress=archive and the bug disappears,

Bug#930299: apt: A warning "Ignoring Provides line with non-equal DepCompareOp for package" for two packages

2019-06-10 Thread David Kalnischkies
Control: reassign -1 firefox-l10n-bn Control: forcemerge 930256 -1 Control: affects -1 apt Hi, On Mon, Jun 10, 2019 at 09:50:15AM +0300, jim_p wrote: > W: Ignoring Provides line with non-equal DepCompareOp for package > firefox-l10n-bn-bd > W: Ignoring Provides line with non-equal DepCompareOp

Bug#929833: marked as done (apt: Differences in the reported value of the Provides field in apt-cache)

2019-06-10 Thread David Kalnischkies
just for the record: > > $ sudo apt-cache show python3 > > Package: python3 > > > > Provides: python3-profiler > > > > $ sudo apt-cache showpkg python3 > > ... > > Provides: > > 3.5.3-1 - python3-profiler:i386 (= ) python3:any (= 3.5.3-1) > > python3-profiler > > (= ) python3-profiler:any

Bug#927254: reproducible, but ...

2019-06-10 Thread Paolo Greppi
Hi, nice one ! It is reproducible when I use the laminar debs built from the WIP package here: https://salsa.debian.org/debian/laminar after these fixes: https://bugs.debian.org/919181#27 Once started, the laminar service dashboard should be reachable from localhost:8080 but it fails to load.

Bug#930316: konsole: Segmentation fault arisen when obtining new konsole themes

2019-06-10 Thread Aurélien COUDERC
control: tags -1 + confirmed Hi Saverio, thank you for your bug report. I confirm I reproduce the bug. This is due to the Konsole package not shipping /etc/xdg/konsole.knsrc which is required for the new stuff functionality to work. @qt-kde team, the patch is a one-liner in konsole.install but

Bug#930316: konsole: Segmentation fault arisen when obtining new konsole themes

2019-06-10 Thread Lisandro Damián Nicanor Pérez Meyer
Actually it would be good to know first why we are not shipping that file. El lun., 10 jun. 2019 10:45, Lisandro Damián Nicanor Pérez Meyer < perezme...@gmail.com> escribió: > Control: tag -1 important > > Hi Aurelien and Saverio! > > > El lun., 10 jun. 2019 10:42, Aurélien COUDERC > escribió:

Bug#928052: CVE-2019-11502 CVE-2019-11503

2019-06-10 Thread Kentaro Hayashi
Hi, Thank you for feedback. On Sun, 9 Jun 2019 19:03:19 +0200 Salvatore Bonaccorso wrote: > Hi, > snip > This should not close the bug yet as it only adresses CVE-2019-11502. > #928052 both tracks CVE-2019-11502 CVE-2019-11503. So onless I miss > smoething the changes to fix CVE-2019-11503

Bug#930319: spectre-meltdown-checker: wish it would notify the user if the CPU has unfixable bugs

2019-06-10 Thread Sylvestre Ledru
Le 10/06/2019 à 15:55, Russell Coker a écrit : Package: spectre-meltdown-checker Version: 0.42-1 Severity: wishlist Tags: upstream model name : Intel(R) Core(TM)2 Quad CPUQ9505 @ 2.83GHz Above is the CPU specification from /proc/cpuinfo on this system.

Bug#930316: konsole: Segmentation fault arisen when obtining new konsole themes

2019-06-10 Thread Aurélien COUDERC
Le 10/06/2019 à 15:46, Lisandro Damián Nicanor Pérez Meyer a écrit : > Actually it would be good to know first why we are not shipping that file. Simply because it was added by upstream between 17.12.3 and 18.04.0 and the .install file was not updated accordingly. $ tar tvfa

Bug#930320: inkscape: crash on rotate

2019-06-10 Thread Bardot Jerome
Package: inkscape Version: 0.92.4-3 Severity: important Dear Maintainer, I try to repeat a shape configuration. But when i try to rotate my group of shape inkscape crash. This is the error. - $ inkscape terminate called after throwing an instance of 'Geom::LogicalError' what():

Bug#928185: unblock: openjdk-11/11.0.3+7-4

2019-06-10 Thread tony mancill
On Sun, Jun 09, 2019 at 04:19:53PM -0700, tony mancill wrote: > On Sun, Jun 09, 2019 at 09:54:50PM +0200, Paul Gevers wrote: > > Hi, > > > > On 05-06-2019 22:28, Paul Gevers wrote: > > > I really want bug 900912 and 925071 fixed. It seems that is missing from > > > your second approach. Let me

Bug#930256: Ignoring Provides line with non-equal DepCompareOp for package firefox-l10n-bn-bd

2019-06-10 Thread Ansgar
Hi, > I'm rising the severity since this causes errors in dose-debcheck, which > might affect QA or other infrastructure: I removed the problematic package from experimental earlier; that should make it a bit less urgent to upload a new version of firefox (it will only miss firefox-l10n-bn).

Bug#927913: Second chromium kills the first one, and we see "Restore pages?"

2019-06-10 Thread Stephen Kitt
On 10 June 2019 06:59:43 CEST, "Jürgen Göricke" wrote: >why don't you create binary packages of chromium and publish them in >the unstable branch? >Did I miss something important? The packages are still being built, see https://buildd.debian.org/status/package.php?p=chromium Regards,

Bug#930321: php-horde-form: CVE-2019-9858

2019-06-10 Thread Salvatore Bonaccorso
Source: php-horde-form Version: 2.0.18-3 Severity: grave Tags: security upstream Justification: user security hole Hi, The following vulnerability was published for php-horde-form. CVE-2019-9858[0]: | Remote code execution was discovered in Horde Groupware Webmail 5.2.22 | and 5.2.17.

Bug#924787: Motivation for blocking 842194

2019-06-10 Thread Diane Trout
Hi, I discovered the need for the new udev rules via trying to use the yubikey-personalization-gui. Someone had reported 842194 and as far as I can tell its caused by the same permission denied problem this bug is covering. I suppose one could argue the gui should have reported the permission

Bug#917491: debian-installer-9-netboot-amd64: Did this bug crop up again in 20170615+deb9u6 (released Apr 2019)?

2019-06-10 Thread Jared P Bostic
Package: debian-installer-9-netboot-amd64 Version: 20170615+deb9u6 Followup-For: Bug #917491 Dear Maintainer, Some weeks ago, my Debian stretch netboot installer told me that I needed to update, so I proceeded to download the new files:

Bug#930237: gnome-control-center: Under Details -> Graphics shown as "Unknown"

2019-06-10 Thread Carlos Donizete Froes
Hi, By default, GNOME is in "wayland" and to my surprise when I signed in to "GNOME with Xorg". Now in Details -> Graphics is showing as "Unknown". The problem is only occurring using the "wayland". Thanks! -- ⢀⣴⠾⠻⢶⣦⠀ Carlos Donizete Froes [a.k.a coringao] ⣾⠁⢠⠒⠀⣿⡁ Debian Wiki:

  1   2   >