Bug#931253: Bug#903392: want support for packaging-only maintainer views

2019-06-30 Thread Ian Jackson
Sean Whitton writes ("Bug#931253: Bug#903392: want support for packaging-only maintainer views"): > On Sat 29 Jun 2019 at 02:55pm +0100, Ian Jackson wrote: > > I could make baredebian+git an alias for it. Or, rename it. It's not > > released yet... > > I think it should be renamed. Otherwise,

Bug#931277: release-notes: document Wayland as default display server for GNOME in what's new

2019-06-30 Thread Justin B Rye
Paul Gevers wrote: > I thinks we should document the switch of GNOME to Wayland as the > default display server in the What's New section. Proposal attached. > I've added d-a11y@l.d.o in X-D-CC, please keep them in the loop, because > I think it is worth mentioning a recommendation to not use

Bug#931277: release-notes: document Wayland as default display server for GNOME in what's new

2019-06-30 Thread Justin B Rye
Justin B Rye wrote: > A bit repetitive, and we should probably say "modern", not "recent" > (for a start because that hints at the downside: its assumptions are > *too* modern for my video hardware). > >Following upstream, GNOME in buster defaults to using the Wayland >display

Bug#931052: release-notes text proposal for bug 931052: webkit2gtk not supported on non-sse2 i386 hardware

2019-06-30 Thread Paul Gevers
Hi Justin, On 30-06-2019 13:17, Justin B Rye wrote: > + It is also intended that the buster-backports archive will receive an > + updated package once that archive opens up for uploads, so an > alternative > + could be to install webkit2gtk > + from there once it's available.

Bug#931277: release-notes: document Wayland as default display server for GNOME in what's new

2019-06-30 Thread Paul Gevers
Hi Justin, On 30-06-2019 13:53, Justin B Rye wrote: >> Does this subject (a11y on Wayland) warrant a note in "Issues to be >> aware of for buster" chapter? > > Probably the "apps-in-gnome-on-wayland" issues section should link > back to this whats-new section. That's a good solution. I'll do

Bug#910764: openjfx: segmentation fault in GtkNativeMainLoopThread with GTK 3

2019-06-30 Thread Markus Koschany
Am 30.06.19 um 12:42 schrieb Thomas Uhle: > Hello Markus, > > it seems that the bugfix has been backported upstream to OpenJFX 11.0.2 > as well. Please see https://bugs.openjdk.java.net/browse/JDK-8216292 for > further reference. Thanks for the information. I will remove the workaround in PDFsam

Bug#931285: jami: Black, empty screen shared from wayland desktop session

2019-06-30 Thread Bruno Kleinert
Package: jami Version: 20190215.1.f152c98~ds1-1 Severity: normal Hi, just a black screen is transmitted when Jami is instructed to share the screen or a part of it from GNOME 3 wayland sessions. From GNOME 3 Xorg sessions it works as expected, though. Cheers - Bruno -- System Information:

Bug#931280: gnome-shell: Keyboard layout randomly alternates

2019-06-30 Thread Michael Biebl
On Sun, 30 Jun 2019 14:35:47 +0200 Paul Menzel wrote: > Package: gnome-shell > Version: 3.30.2-9 > Severity: serious That feels vastly exaggerated. That aside... > Dear Debian folks, > > > With Debian Sid/unstable with the default GNOME session, that means > Wayland is used, and with two

Bug#930594: Another controller result

2019-06-30 Thread Karsten
I aditionally buyed a new "USB 3.0 SATA Cables Converter to 2.5/3.5 inch HDD SSD" like this https://www.aliexpress.com/item/USB-3-0-SATA-Cables-Converter-Male-to-2-5-3-5-inch-HDD-SSD-Drive/33010303964.html It is visible at USB as Bus 001 Device 010: ID 152d:0578 JMicron Technology Corp. /

Bug#931276: release-notes: document merged usr/ for new installs

2019-06-30 Thread Paul Gevers
Package: release-notes Control: tags -1 patch pending Hi all, I think it is worth it to mention merged usr/. I have prepared the attached text, which I am requesting review for. Paul diff --git a/en/whats-new.dbk b/en/whats-new.dbk index 943fa148..4865e7ae 100644 --- a/en/whats-new.dbk +++

Bug#868087: light-locker: Locking screen with light-locker crashes system to blinking cursor

2019-06-30 Thread Yves-Alexis Perez
-BEGIN PGP SIGNED MESSAGE- Hash: SHA256 On Fri, 2019-06-28 at 17:06 +, nodiscc wrote: > Original, working, no xorg.conf, glx alternative = /usr/lib/mesa-diverted: > > (II) LoadModule: "nouveau" > (II) Loading /usr/lib/xorg/modules/drivers/nouveau_drv.so > > glx alternative =

Bug#931052: release-notes text proposal for bug 931052: webkit2gtk not supported on non-sse2 i386 hardware

2019-06-30 Thread Alberto Garcia
On Sat, Jun 29, 2019 at 08:36:34PM +0100, Justin B Rye wrote: > >> And how are we deciding when it's "WebKitGTK" and when it's > >> "webkit2gtk"? Bear in mind that users have no easy way of > >> mapping from the name of a source package to the name of the > >> specific library they might or might

Bug#931277: release-notes: document Wayland as default display server for GNOME in what's new

2019-06-30 Thread Paul Gevers
Package: release-notes X-Debbugs-CC: debian-accessibil...@lists.debian.org Control: tags -1 patch pending Hi all, I thinks we should document the switch of GNOME to Wayland as the default display server in the What's New section. Proposal attached. I've added d-a11y@l.d.o in X-D-CC, please keep

Bug#910764: openjfx: segmentation fault in GtkNativeMainLoopThread with GTK 3

2019-06-30 Thread Thomas Uhle
Hello Markus, it seems that the bugfix has been backported upstream to OpenJFX 11.0.2 as well. Please see https://bugs.openjdk.java.net/browse/JDK-8216292 for further reference. Regards, Thomas

Bug#879024: util-linux: FTBFS on alpha: setarch-uname26-version FAILED

2019-06-30 Thread Andreas Henriksson
On Wed, Oct 18, 2017 at 11:01:16AM -0400, Aaron M. Ucko wrote: > Source: util-linux > Version: 2.30.2-0.1 > Severity: important > Justification: fails to build from source (but built successfully in the past) > User: debian-al...@lists.debian.org > > Builds of util-linux for alpha (admittedly not

Bug#931052: release-notes text proposal for bug 931052: webkit2gtk not supported on non-sse2 i386 hardware

2019-06-30 Thread Justin B Rye
Alberto Garcia wrote: > Justin B Rye wrote: >> The trouble with talking about WebKitGTK is that besides >> libwebkit2gtk-* there are also a couple of packages like >> libwebkitgtk3.0-cil that look as if they'd be relevant to this but >> aren't. > > Packages named *webkitgtk* (without the '2')

Bug#931243: libvirt0: does not work under cgroup v2 (and rtkit)

2019-06-30 Thread Ryutaroh Matsumoto
I found a much better workaround. rtkit works fine after the CGroup V2 CPU controller is enabled. So, if the V2 CPU controller is enabled before a user process gets the realtime priority, libvirt-daemon works also fine. I made the following lines to

Bug#931279: thunderbird: Info message says that daily version is used, but 60.7.2 is ESR version

2019-06-30 Thread Paul Menzel
Package: thunderbird Version: 1:60.7.2-1 Severity: minor Dear Debian folks, Using Debian Sid/unstable with Thunderbird 60.7.2, having no message selected, for example after starting Thunderbird,, the information below is shown in the message window. You are using the daily version of

Bug#928642: release-notes: please mention improved support in buster for Rockchip RK3328 and RK3399 devices

2019-06-30 Thread Paul Gevers
Hi Andrei, On 08-05-2019 08:58, Andrei POPESCU wrote: > According to http://opensource.rock-chips.com/wiki_Status_Matrix > mainline should have reasonable support for RK3328 and RK3399 as of > 4.14. > > Considering RK3399 is already used in some interesting devices > (ROCKPro64,

Bug#930922: [PATCH] dgit(1): In --include-dirty caveat, say "especially --clean=git"

2019-06-30 Thread Ian Jackson
Closes: #930922 Signed-off-by: Ian Jackson --- dgit.1 | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/dgit.1 b/dgit.1 index cf7b8c52..cb1cbe21 100644 --- a/dgit.1 +++ b/dgit.1 @@ -647,7 +647,7 @@ Note that this does .BR not prevent dgit from cleaning your tree, so if the

Bug#931284: python3-cryptominisat: package description has wrong module name

2019-06-30 Thread Beatrice Torracca
Package: python3-cryptominisat Severity: minor Hi, the package description now reads "This package provides the pycroptosat module...", but I think the module name is pycryptosat, not pycrOptosat. Thanks, beatrice

Bug#931286: Synapse fails to start without jinja2

2019-06-30 Thread Jörg Sommer
Package: matrix-synapse Version: 1.0.0-2 Severity: normal Hi, after installing the new version, I've got this error message: ``` Traceback (most recent call last): File "/usr/lib/python3.7/runpy.py", line 193, in _run_module_as_main "__main__", mod_spec) File

Bug#931278: bzip2: Fix for CVE-2019-12900 breaks uncompressing some lbzip2 files

2019-06-30 Thread Salvatore Bonaccorso
Source: bzip2 Version: 1.0.6-9.1 Severity: normal Tags: upstream Forwarded: https://gitlab.com/federicomenaquintero/bzip2/issues/24 The fix for CVE-2019-12900 causes that some lbzip2 compressed files cannot be uncompressed anymore. There ws a bug in libzip2 which got fixed, but files produced

Bug#929905: autoremoval of fdroidserver

2019-06-30 Thread Phil Morrell
Hi, I realise fdroidserver is scheduled for removal from testing after the buster release date, but I'm writing in case Paul above is right. Please include fdroidserver in buster unless there's some other RC bug. Testing contributions to the default central repository is not the only use case

Bug#931280: gnome-shell: Keyboard layout randomly alternates

2019-06-30 Thread Paul Menzel
Package: gnome-shell Version: 3.30.2-9 Severity: serious Dear Debian folks, With Debian Sid/unstable with the default GNOME session, that means Wayland is used, and with two keyboard layouts configured (Neo (default), and German) sometimes the keyboard layout changes from Neo to normal

Bug#931281: gnome-shell: Session cannot be unlocked when audio dialog for plugged in speaker is active

2019-06-30 Thread Paul Menzel
Package: gnome-shell Version: 3.30.2-9 Severity: serious Dear Debian folks, With Debian Sid/unstable with the default GNOME session, that means Wayland is used, logging in and plugging in speakers/headphone a dialog pops up if this is a headphone, a headset or a microphone. If ignore that

Bug#725884: hdparm: Standby (spindown) timeout option (-S) has no effect

2019-06-30 Thread Alex Mestiashvili
On 3/10/19 10:41 PM, Stijn Segers wrote: > Hi, > > I recently experienced the same issue here. Until Debian Stretch everything > was fine, but I recently upgraded to Debian Buster (pre-release). I > previously just set the spindown time and this used to work fine. Hdparm -Y > on the devices

Bug#931277: release-notes: document Wayland as default display server for GNOME in what's new

2019-06-30 Thread Paul Gevers
Hi Justin, On 30-06-2019 13:54, Justin B Rye wrote: > Justin B Rye wrote: >> A bit repetitive, and we should probably say "modern", not "recent" >> (for a start because that hints at the downside: its assumptions are >> *too* modern for my video hardware). >> >>Following upstream, GNOME

Bug#931282: unblock: s-nail/14.9.11-3

2019-06-30 Thread Paride Legovini
Package: release.debian.org Severity: normal User: release.debian@packages.debian.org Usertags: unblock Please unblock package s-nail. Version 14.9.11-3 contains a targeted fix for #930691 I've got from upstream. The debdiff between -2 and -3 is attached. Thank you, Paride Legovini unblock

Bug#929667: debian-installer doesn't install Recommends of linux-image-*

2019-06-30 Thread Ben Hutchings
On Tue, 2019-05-28 at 17:08 +0100, Ben Hutchings wrote: > Control: tag -1 serious > > On Tue, 2019-05-28 at 10:16 +0200, Patrick wrote: > > Package: debian-installer > > Version: 20190410 > > > > debian-installer doesn't install the Recommends of "linux-image-*". > > Apparently, this is by

Bug#931277: release-notes: document Wayland as default display server for GNOME in what's new

2019-06-30 Thread Justin B Rye
Paul Gevers wrote: >> Justin B Rye wrote: >>> A bit repetitive, and we should probably say "modern", not "recent" >>> (for a start because that hints at the downside: its assumptions are >>> *too* modern for my video hardware). >>> >>>Following upstream, GNOME in buster defaults to using

Bug#874781: Remove script altogether

2019-06-30 Thread Jeremy Sowden
My inclination would be to drop this script entirely. For one thing, I don't think it serves any useful purpose, but, furthermore. it relies on FTP to download the Packages file from security.debian.org, which means that it hasn't worked for more than eighteen months without any com- plaints. J.

Bug#931269: python-debian: command-line tools to print debian.changelog & debian.copyright warnings

2019-06-30 Thread Paul Wise
Source: python-debian Severity: wishlist User: check-all-the-thi...@packages.debian.org Usertags: new-check Control: affects -1 check-all-the-things The debian.changelog & debian.copyright modules have a number of checks for Debian changelog/copyright files. It would be nice to have access to

Bug#931270: amule-utils-gui: works perfectly — should not be labelled ‘experimental’

2019-06-30 Thread Axel Stammler
Package: amule-utils-gui Version: 1:2.3.2-5 Severity: wishlist Dear Maintainer, I have been using this Amule daemon GUI client for many years (i.e. in different Debian versions) without any problems. I suggest removing the ‘experimental’ label in the package description (cf. apt show). --

Bug#931271: More info

2019-06-30 Thread Sylvestre Ledru
To be clear, we don't need dh-cargo if we can have encoding-rs without dh-cargo, this is perfectly fine :) S

Bug#930856: autopkgtest-build-qemu: captures something from host

2019-06-30 Thread Bastian Blank
On Sat, Jun 29, 2019 at 04:44:32PM +0200, Bastian Blank wrote: > On Sat, Jun 29, 2019 at 02:25:55PM +, Dmitry Bogatov wrote: > > Note that APT tries to use Devuan keyring to validate Debian release and > > fail. How does `debootstrap' decides, which keyring to use? > "dpkg -s debootstrap"?

Bug#931272: openssh-server: incoming connections fail if openssl's afalg engine is enabled

2019-06-30 Thread Emilio López
Package: openssh-server Version: 1:8.0p1-2 Severity: important Dear Maintainer, After enabling afalg engine on OpenSSL and configuring OpenSSH server to use the following ciphers, incoming ssh connections stop working. When a client tries to connect, you can observe the following message on

Bug#915851: psensor FTBFS with json-c 0.13.1

2019-06-30 Thread Gianfranco Costamagna
control: forwarded -1 https://gitlab.com/jeanfi/psensor/merge_requests/9 On Sun, 30 Jun 2019 10:34:41 +0200 Gianfranco Costamagna wrote: > control: tags -1 patch > > > trivial patch attached. > > On Fri, 07 Dec 2018 11:50:56 +0100 Birger Schacht > wrote: > > Source: psensor > > Version:

Bug#921952: Time to close this ?

2019-06-30 Thread Xavier
Hi all, libsass has been updated in testing. I think it is time to close (or at least decrease) this RC bug. Cheers, Xavier

Bug#931243: libvirt0: does not work under cgroup v2 (and rtkit)

2019-06-30 Thread Ryutaroh Matsumoto
Package: libvirt0 Version: 5.2.0-2 Followup-For: Bug #931243 Control: found 931243 5.2.0-2 Dear Maintainer, I installed version 5.2.0-2 from the experimental and confirmed that this issue still exists in 5.2.0-2. Ryutaroh -- System Information: Debian Release: 10.0 APT prefers testing APT

Bug#931273: gdebi: French templates translation

2019-06-30 Thread Jean-Philippe MENGUAL
Package: gdebi Version: N/A Severity: wishlist Tags: patch l10n Dear Maintainer, *** Reporter, please consider answering these questions, where appropriate *** * What led up to the situation? * What exactly did you do (or not do) that was effective (or ineffective)? * What was the

Bug#915851: psensor FTBFS with json-c 0.13.1

2019-06-30 Thread Gianfranco Costamagna
control: tags -1 patch trivial patch attached. On Fri, 07 Dec 2018 11:50:56 +0100 Birger Schacht wrote: > Source: psensor > Version: 1.1.5-1 > Severity: normal > Tags: upstream > Control: block 904418 by -1 > > Dear Maintainer, > > There exists a transition slot for json-c (see #904418).

Bug#931274: acl: French templates translation

2019-06-30 Thread Jean-Philippe MENGUAL
Package: acl Version: N/A Severity: wishlist Tags: patch l10n Dear Maintainer, *** Reporter, please consider answering these questions, where appropriate *** * What led up to the situation? * What exactly did you do (or not do) that was effective (or ineffective)? * What was the

Bug#931275: RM: jasperreports -- RoQA; many security issues

2019-06-30 Thread Salvatore Bonaccorso
Package: ftp.debian.org Severity: normal Hi FTP masters, As discussed around https://bugs.debian.org/880467#10 jasperreports is not really supportable in Debian. It has several (undetermined) security issues where upstream does not share detailed information and just advises to update to newest

Bug#929398: jasperreports: Should jasperreports be removed from unstable?

2019-06-30 Thread Salvatore Bonaccorso
Hi, On Wed, May 22, 2019 at 10:04:18PM +0200, Salvatore Bonaccorso wrote: > Source: jasperreports > Version: 6.3.1-2 > Severity: serious > Justification: unfit for a Debian release > > Hi > > Given the discussion around https://bugs.debian.org/880467#10 and the > fact that removing

Bug#931179: [Pkg-javascript-devel] Bug#931179: acorn 6.1.1 please bundle additional plugins needed by nodejs source

2019-06-30 Thread Bastien ROUCARIES
On Thu, Jun 27, 2019 at 5:12 PM Jérémy Lal wrote: > > Source: acorn > Severity: wishlist > > https://github.com/nodejs/node/tree/master/deps/acorn-plugins > shows which ones. > > Thanks for considering - i wonder if some of them would rather be > packaged independently or not. Will do but I need

Bug#931271: unblock: dh-cargo/18

2019-06-30 Thread Sylvestre Ledru
Package: release.debian.org Severity: normal User: release.debian@packages.debian.org Usertags: unblock Please unblock package dh-cargo Hello We don't need dh-cargo per say but it is blocking rust-encoding-rs migration. Version 18 has been in unstable since march without regression and it

Bug#931276: release-notes: document merged usr/ for new installs

2019-06-30 Thread Paul Gevers
Hi, On 30-06-2019 11:46, Paul Gevers wrote: > I think it is worth it to mention merged usr/. I have prepared the > attached text, which I am requesting review for. I had another look at my proposal and updated it a bit. See attached renewed proposal. Paul diff --git a/en/whats-new.dbk

Bug#931294: openjpeg2: CVE-2018-20847

2019-06-30 Thread Salvatore Bonaccorso
Source: openjpeg2 Version: 2.3.0-2 Severity: important Tags: security upstream Hi, The following vulnerability was published for openjpeg2. CVE-2018-20847[0]: | An improper computation of p_tx0, p_tx1, p_ty0 and p_ty1 in the | function opj_get_encoding_parameters in openjp2/pi.c in OpenJPEG |

Bug#922431: Upstream is confused about Tracing consisting on non-source JS

2019-06-30 Thread Tomas Pospisek
Hello Michael et al, you wrote in https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=922431#10: On Fri, Feb 15, 2019 at 2:54 PM Sebastien Helleu wrote: With chromium version 72.0.3626.81, the URL chrome://tracing does not work any more. Tracing is disabled in debian starting with

Bug#930922: dgit: combination of -wgf and --include-dirty nukes untracked files

2019-06-30 Thread Sean Whitton
Hello, On Sat 29 Jun 2019 at 03:36PM +01, Ian Jackson wrote: > Sean Whitton writes ("Re: Bug#930922: dgit: combination of -wgf and > --include-dirty nukes untracked files"): >> On Mon 24 Jun 2019 at 12:02pm +0100, Ian Jackson wrote: >> >> A possible alternative would be to actually add

Bug#877125: dtc: build errors with swig for python lib

2019-06-30 Thread Sjoerd Simons
Package: device-tree-compiler Version: 1.4.7-3 Followup-For: Bug #877125 This seems a bug of debians own making; debian/rulies copes the upstream Makefiles warnigns && Werror and then explicitly sets those as CFLAGS for the build. However this means that they'll get applied *both* to libfdt and

Bug#931118: unblock: debian-keyring/2019.06.25

2019-06-30 Thread Mattia Rizzolo
On Sun, Jun 30, 2019 at 08:38:52PM +0200, Paul Gevers wrote: > On 26-06-2019 16:10, Mattia Rizzolo wrote: > > The last upload of debian-keyring done yesterday updates the security > > team key. See #928222 for more context. > > > > I think it would be good if this change could find its way into

Bug#903392: want support for packaging-only maintainer views

2019-06-30 Thread Sean Whitton
Hello, On Sat 29 Jun 2019 at 03:43PM +01, Ian Jackson wrote: > Sean Whitton writes ("Re: Bug#903392: want support for packaging-only > maintainer views"): >> On Sat 29 Jun 2019 at 02:55pm +0100, Ian Jackson wrote: >> > Sean Whitton writes ("Re: Bug#903392: want support for packaging-only >> >

Bug#903392: Bug#931253: Bug#903392: want support for packaging-only maintainer views

2019-06-30 Thread Sean Whitton
Hello, On Sun 30 Jun 2019 at 12:44PM +01, Ian Jackson wrote: > Please take a look at wip.baredebian in my chiark repo and see what > you think of the way the docs read now. > > If after reading that you still think it ought to be renamed, I will > do so. While writing the e-mail I sent a few

Bug#930869: Asked to try and mediate this bug.

2019-06-30 Thread Sam Hartman
Michael, I've been asked to try and mediate this bug. Unfortunately, to do that, I'm going to need to ask at least one question that Adam is already asked. I can assure you that I'm not as smart as you believe he is, so I really am going to need some help to understand the situation:-) What

Bug#931052: release-notes text proposal for bug 931052: webkit2gtk not supported on non-sse2 i386 hardware

2019-06-30 Thread Justin B Rye
Paul Gevers wrote: > Justin B Rye wrote: >> + It is also intended that the buster-backports archive will receive an >> + updated package once that archive opens up for uploads, so an >> alternative >> + could be to install webkit2gtk >> + from there once it's available. > >

Bug#931278: bzip2: Fix for CVE-2019-12900 breaks uncompressing some lbzip2 files

2019-06-30 Thread Salvatore Bonaccorso
Hi Mark, On Sun, Jun 30, 2019 at 06:01:35PM +0200, Mark Wielaard wrote: > See the upstream discussion on the bzip2-devel mailinglist: > https://sourceware.org/ml/bzip2-devel/2019-q2/msg00024.html > > In particular this workaround patch for some (buggy lbzip2 compressed) > files that bzip2 1.0.6

Bug#931290: general: Asrock A300 Deskmini AMD Athlon 200GE ends in black screen Monitor has no Signal

2019-06-30 Thread joe
Package: general Severity: important Dear Maintainer, *** Reporter, please consider answering these questions, where appropriate *** * What led up to the situation? * What exactly did you do (or not do) that was effective (or ineffective)? * What was the outcome of this action?

Bug#931198: unblock: warzone2100/3.2.1-4

2019-06-30 Thread Paul Gevers
retitle 931198 buster-pu: package warzone2100/3.2.1-3+deb10u1 user release.debian@packages.debian.org usertags 931198 - unblock usertags 931198 pu tags 931198 buster thanks Hi Marcus, On 28-06-2019 01:37, Markus Koschany wrote: > A segmentation fault was discovered in warzone2100 when

Bug#930438: libgd2 2.2.4-2+deb9u5 flagged for acceptance

2019-06-30 Thread Adam D Barratt
Control: tags -1 + pending Hi, The upload referenced by this bug report has been flagged for acceptance into the proposed-updates queue for Debian stretch. Thanks for your contribution! Upload details == Package: libgd2 Version: 2.2.4-2+deb9u5 Explanation: fix uninitialized read

Bug#931293: alsa-utils: unnecessary dependency

2019-06-30 Thread astian
Package: alsa-utils Version: 1.1.8-2 Severity: normal Dear Maintainer, The package depends on whiptail|dialog, but the only user of whiptail (alsaconf) is not part of the package. The only (optional) user of dialog (alsa-info.sh) explicitly calls "dialog" and does not check for whiptail.

Bug#931267: times out and drops into useless emergency shell with fsck still ongoing

2019-06-30 Thread Michael Biebl
Am 30.06.2019 um 07:12 schrieb Michael Biebl: > As you can see, after 30s the eye-of-cylon animation kicks in and after > 300s the boot proceeds and successfully completes. sorry for the typo, meant 200s here > This is even a more elaborate setup with LVM and stuff. To be sure, I also tested

Bug#931252: lximage-qt: should have a manpage

2019-06-30 Thread Alf Gaida
If you want a manpage - just write one. We will be happy to merge it upstream. There will not be a manpage stub for debian. Re: Mandatory - of course i could use a tool to convert the help into a manpage, but: Really, no! Never ever. Never. Really. It will be more likely that the hell will

Bug#929968: Add missing C_CAN module

2019-06-30 Thread Bastian Germann
Package: linux Tags: patch I have merge requested a fix for this issu. https://salsa.debian.org/kernel-team/linux/merge_requests/153

Bug#931278: bzip2: Fix for CVE-2019-12900 breaks uncompressing some lbzip2 files

2019-06-30 Thread Mark Wielaard
See the upstream discussion on the bzip2-devel mailinglist: https://sourceware.org/ml/bzip2-devel/2019-q2/msg00024.html In particular this workaround patch for some (buggy lbzip2 compressed) files that bzip2 1.0.6 could decompress, but 1.0.7 (with the CVE-2019- 12900 hardening patch) cannot:

Bug#931288: www.debian.org: Broken link to WML website

2019-06-30 Thread Alban Vidal
Package: www.debian.org Severity: normal -BEGIN PGP SIGNED MESSAGE- Hash: SHA256 Dear Webmaster team, On the Debian Website, in "Translating Debian web pages"[1] we have a broken link to the WML website [2]. The source file is english/devel/website/translating.wml in the webwml

Bug#931289: ITP: croaring -- Portable Roaring bitmaps in C (and C++)

2019-06-30 Thread Alexander GQ Gerasiov
Package: wnpp Severity: wishlist Owner: Alexander GQ Gerasiov * Package name: croaring Version : 0.2.63 Upstream Author : Daniel Lemire and others * URL : https://github.com/RoaringBitmap/CRoaring * License : Apache 2.0 Programming Lang: C, C++

Bug#929410: [Pkg-tigervnc-devel] Bug#929410: Bug#929410: RANDR extension not present

2019-06-30 Thread Ola Lundqvist
Hi It is too late for buster. Deadline has passed more than a week ago. If I had been faster maybe it had been possible. Maybe we can get it to a point release. Do you know how much changes there are between 1.9.0+dfsg-3 and the one you mentioned? It seems to fall in the criteria to fix

Bug#926943: closed by Thomas Goirand (Bug#926943: fixed in python-rtslib-fb 2.1.66-3)

2019-06-30 Thread George Diamantopoulos
Hello, Are there any plans to push this fix to buster before its release? Thank you. BR, George On Tue, 16 Apr 2019 at 23:42, Debian Bug Tracking System < ow...@bugs.debian.org> wrote: > This is an automatic notification regarding your Bug report > which was filed against the python3-rtslib-fb

Bug#928543: Acknowledgement (ucarp should depend on ifupdown|ifupdown2 instead of versioned ifupdown only)

2019-06-30 Thread George Diamantopoulos
Hello, Any chance this will get looked into before buster is released? Thanks! BR, George On Mon, 6 May 2019 at 22:57, Debian Bug Tracking System < ow...@bugs.debian.org> wrote: > Thank you for filing a new Bug report with Debian. > > You can follow progress on this Bug here: 928543: >

Bug#928984: Acknowledgement (ifupdown: networking lost when installing ifupdown2)

2019-06-30 Thread George Diamantopoulos
Hello, Any chance this will get looked into before buster is released? Thanks! BR, George On Tue, 14 May 2019 at 18:45, Debian Bug Tracking System < ow...@bugs.debian.org> wrote: > Thank you for filing a new Bug report with Debian. > > You can follow progress on this Bug here: 928984: >

Bug#931282: unblock: s-nail/14.9.11-3

2019-06-30 Thread Paul Gevers
retitle 931282 buster-pu: package s-nail/14.9.11-2+deb10u1 user release.debian@packages.debian.org usertags 931282 - unblock usertags 931282 pu tags 931282 buster thanks Hi Paride, On 30-06-2019 14:55, Paride Legovini wrote: > Please unblock package s-nail. Version 14.9.11-3 contains a

Bug#930274: RFS: junitparser/1.3.2-1 [ITP]

2019-06-30 Thread Herbert Fortes
On 6/29/19 10:28 AM, Bastian Germann wrote: > Hi Herbert, > > Thanks for coming back to me. I uploaded a new version with the > suggested changes. > >> # lintian-info -t 'tag' >> >> - upstream-metadata-file-is-missing >> >>It is pedantic. There are info here to fix that: >>Refer to

Bug#928300: secure boot via removable media path unavailable

2019-06-30 Thread Steve McIntyre
Hi Chris! On Sat, Jun 29, 2019 at 06:44:06AM +0200, Chris Nospam wrote: > >I know that this bug is not closed yet, but maybe the following is of >interest for you. > >I noticed your report of bug #930531 which was recently fixed in >grub2 version 2.02+dfsg1-19. Thus, I decided to give secure boot

Bug#931287: apt-install --with-recommends does not work during base install

2019-06-30 Thread Ben Hutchings
Package: debian-installer-utils Version: 1.131 Severity: important apt-install only passes the APT::Install-Recommends option to apt-get if it will differ from the value of base-installer/install-recommends. If that is set to true (the default) then --with-recommends doesn't affect the apt-get

Bug#931002: [Pkg-rust-maintainers] Updating crates for Debian stable release

2019-06-30 Thread Sylvestre Ledru
Le 27/06/2019 à 17:43, Ivo De Decker a écrit : Hi, On Mon, Jun 24, 2019 at 06:03:00PM +, Ximin Luo wrote: I am on vacation for the next two weeks, please can someone else deal with the following: Due to Firefox we updated/unblocked rustc 1.34.2 for Debian Testing (and the next Debian

Bug#931126: unblock: enigmail/2:2.0.11+ds1-2

2019-06-30 Thread Paul Gevers
Control: tags -1 moreinfo Hi Daniel, On 26-06-2019 19:13, Daniel Kahn Gillmor wrote: > Please unblock package enigmail > > enigmail 2:2.0.11+ds1-2 includes several usability and security fixes > from upstream, including a fix for CVE-2019-12269 (debian bug #929363). > > The debdiff is

Bug#931291: ITP: pdqsort -- pdqsort is a drop-in replacement for std::sort

2019-06-30 Thread Alexander GQ Gerasiov
Package: wnpp Severity: wishlist Owner: Alexander GQ Gerasiov * Package name: pdqsort Version : git snapshot Upstream Author : Orson Peters * URL : https://github.com/orlp/pdqsort * License : zlib Programming Lang: C++ Description : pattern-defeating

Bug#931118: unblock: debian-keyring/2019.06.25

2019-06-30 Thread Paul Gevers
retitle 931118 buster-pu: package debian-keyring/2019.06.25~deb10u1 user release.debian@packages.debian.org usertags 931118 - unblock usertags 931118 pu tags 931118 buster thanks Hi Mattia, On 26-06-2019 16:10, Mattia Rizzolo wrote: > The last upload of debian-keyring done yesterday updates

Bug#931243: libvirt0: does not work under cgroup v2 (and rtkit)

2019-06-30 Thread Ryutaroh Matsumoto
Control: tags 931243 + fixed-upstream This issue has been recognized and fixed by the upstream developers at https://libvirt.org/git/?p=libvirt.git;a=commit;h=1d49cdcd116186e079db5668893da17f56141652 The below is the upstream commit log: util: vircgroupv2: don't error out if enabling controller

Bug#931292: openjpeg2: CVE-2019-12973

2019-06-30 Thread Salvatore Bonaccorso
Source: openjpeg2 Version: 2.3.0-2 Severity: important Tags: security upstream Forwarded: https://github.com/uclouvain/openjpeg/pull/1185 Hi, The following vulnerability was published for openjpeg2. CVE-2019-12973[0]: | In OpenJPEG 2.3.1, there is excessive iteration in the |

Bug#903392: Bug#931253: Bug#903392: want support for packaging-only maintainer views

2019-06-30 Thread Ian Jackson
Sean Whitton writes ("Bug#903392: Bug#931253: Bug#903392: want support for packaging-only maintainer views"): > While writing the e-mail I sent a few minutes ago, I lost track of the > actual concrete suggestion, which was calling baredebian+git just > baredebian. Sorry about that. Heh. > I no

Bug#929905: autoremoval of fdroidserver

2019-06-30 Thread Hans-Christoph Steiner
Control: severity 929905 important Please keep it in buster, I would like to go the point release route.

Bug#931215: many well known Android devices not supported

2019-06-30 Thread Hans-Christoph Steiner
Control: severity 931215 important Please keep this in buster. I am working on an update for the buster package for the point fix release.

Bug#903392: Bug#931253: Bug#903392: want support for packaging-only maintainer views

2019-06-30 Thread Sean Whitton
Hello, On Sun 30 Jun 2019 at 10:01PM +01, Ian Jackson wrote: >> I no longer think that renaming is needed. I'd like to suggest adding >> baredebian+git as an alias for baredebian, and writing it immediately >> after in the docs, i.e. >> >> --quilt=baredebian (or its alias

Bug#931118: unblock: debian-keyring/2019.06.25

2019-06-30 Thread Jonathan McDowell
On Sun, Jun 30, 2019 at 10:12:32PM +0200, Mattia Rizzolo wrote: > On Sun, Jun 30, 2019 at 08:38:52PM +0200, Paul Gevers wrote: > > On 26-06-2019 16:10, Mattia Rizzolo wrote: > > > The last upload of debian-keyring done yesterday updates the > > > security team key. See #928222 for more context. >

Bug#931228: policyd-weight: dead upstream

2019-06-30 Thread Werner Detter
this is nothing new: Upstream is discontinued since I took over the package years ago, I took care to fix bugs and implemented things where needed. policyd-weight is still used but usage decreases. I'd suggest to leave the package meanwhile and remove it after usage has significantly dropped (and

Bug#730315: latexmk: emacs .fdb_latexmk

2019-06-30 Thread Hilmar Preuße
tags 730315 + pending stop On 23.11.13 22:27, Kevin Ryde wrote: Hi, > As an idea for a feature, latexmk could setup for emacs completion to > ignore foo.fdb_latexmk files, since you usually don't want to visit > them. The debian/emacsen-startup and debian/rules.diff setup a line in >

Bug#673273: texlive-pstricks: auto-pst-pdf.sty unusable without ifplatform

2019-06-30 Thread Hilmar Preuße
tags 673273 + pending stop On 17.05.12 14:50, Patrice Duroux wrote: Hi, > But I have found that ifplatform is currently in texlive-latex-extra. > In one of the next TL snapshots ifplatform will be in texlive-latex-base. Tag bug as pending. H. -- sigfault #206401 http://counter.li.org

Bug#673273: (fwd) Re: Bug#673273: texlive-pstricks: auto-pst-pdf.sty unusable without ifplatform

2019-06-30 Thread Karl Berry
It looks like a good idea to move ifplatform to collection-base ??? Agreed, moved, thanks. -k

Bug#931267: times out and drops into useless emergency shell with fsck still ongoing

2019-06-30 Thread Steve McIntyre
Control: retitle -1 starts up emergency shell with fsck running on the same console Hi Michael, and thanks for the very quick responses! I've analyzed my own logs some more and realised I've made a mistake here when trying to work out the problem. There's a local filesystem service (a

Bug#931278: bzip2: Fix for CVE-2019-12900 breaks uncompressing some lbzip2 files

2019-06-30 Thread Mark Wielaard
Hi Salvatore, On Sun, 2019-06-30 at 19:28 +0200, Salvatore Bonaccorso wrote: > Testing and feedback appreciated. > > it is not very helpfull I think, because I do not have a good testing > corpus. What I did is to apply the patch on top of our current > 1.0.6-9.1 (which has the issue after

Bug#931295: u-boot-sunxi: cannot stop autoboot with usb keyboard on cubietruck

2019-06-30 Thread Phil Morrell
Source: u-boot Version: 2019.01+dfsg-7 Severity: important Hi, I currently have a Stretch install on cubietruck sata SSD, with just u-boot on the SD. Today I tried a first step of installing Buster, but the new SD image does not allow me to stop the autoboot into Stretch. This prevents me

Bug#740534: ITA: python-tempita

2019-06-30 Thread Ondřej Kobližek
retitle 740534 ITA: python-tempita -- small text templating language owner 740534 Ondřej Kobližek thanks Hi, I'll maintain this package. Ondřej Kobližek

Bug#931296: general: Camera flash drive mount does not show up on desktop

2019-06-30 Thread Roger
Package: general Severity: important Tags: a11y Dear Maintainer, * What led up to the situation? Plugging in camera in Buster does not show flash storage on desktop as it did in previous versions with Xfce DE. * What exactly did you do (or not do) that was effective (or

Bug#931297: Please support /usr/lib64/sane

2019-06-30 Thread Gunnar Hjalmarsson
Package: src:sane-backends Version: 1.0.27-3.2 Tags: patch The patch 0125-multiarch_dll_search_path.patch makes /usr/lib/sane be recognized as a directory for SANE backends. However, some .deb files with scanner drivers, typically provided by Brother, install files in /usr/lib64/sane. It

Bug#931298: gmailieer may stop working 15 July 2019 due to "Gmail API lockdown"

2019-06-30 Thread Nicholas D Steeves
Package: gmailieer Version: 0.10-1 Severity: important Forwarded: https://github.com/gauteh/lieer/issues/110 Hi, I've tagged this as severity important, but I suspect it will become RC later next month; although, I could be wrong... Please see the forwarded bug, the links in that report, and

Bug#928736: System won't boot

2019-06-30 Thread Christopher Patrick
I have this same problem, but no matter how long I wait it won't boot. The gnome live weekly ISO won't even boot. Will they be an update to fix it?

Bug#927165: debian-installer: improve support for LUKS

2019-06-30 Thread Cyril Brulebois
Hi Roger, Roger Shimizu (2019-06-30): > On Tue, Jun 11, 2019 at 12:06 AM Guilhem Moulin wrote: > > > > Hi there, > > > > On Mon, 15 Apr 2019 at 23:24:19 +0200, Cyril Brulebois wrote: > > >>> One could argue that cryptodisk support has never been supported by > > >>> d-i anyway, > > >> > > >>

  1   2   >