Bug#942089: linux-signed-amd64: version number not handled correctly by dpkg-genchanges

2019-10-10 Thread Ansgar
Source: linux Source-Version: 5.2.17-1 Severity: important Please do not use "+b1" in versions for the generated source template for linux-signed-* as this confuses dpkg (#942087). I suggest to mangle the version to ".b1" or so instead (debian-installer-netboot-images already uses this scheme).

Bug#942086: xpdf: Memory leak on large document (even w/ continuousView turned off)

2019-10-10 Thread J.P. Larocque
Package: xpdf Version: 3.04-13 Severity: important I have a PDF document which seems to cause xpdf to leak memory as I advance through its pages. The severity of the leak seems to scale with the window size of xpdf, at least to some extent. I don't think this is the same bug as #926501, because

Bug#942087: dpkg-source and dpkg-genchanges disagree how .dsc should be named if version ends with +b1

2019-10-10 Thread Ansgar
Package: dpkg Version: 1.18.25 Severity: normal For the Secure Boot support in Debian we automatically generate source packages that include the signatures (linux-signed-*) from files shipped in linux-image-amd64-signed-template below

Bug#942085: RFS: hijra/0.5.1-1 [UPDATE, adds new binary packages]

2019-10-10 Thread أحمد المحمودي
Package: sponsorship-requests Severity: normal Please sponsor the upload of the updated package hijra, the reason it needs sponsoring is that it adds 2 new binary packages: python3-hijra, and gnome-shell-extension-hijra This package fixes the following bugs: #936703 hijra: Python2 removal in

Bug#942095: nmu: rebuild packages for binutils 2.33

2019-10-10 Thread Matthias Klose
Package: release.debian.org Severity: normal User: release.debian@packages.debian.org Usertags: binnmu Please binNMU these packages for the binutils 2.33 upload to unstable: naev 0.7.0-2 wcc 0.0.2+dfsg-3 (amd64 only) looking-glass 0+b1-1 kcov 36+dfsg-1 also, binutils-mingw64 might need a

Bug#942045: [Pkg-javascript-devel] Bug#942045: rollup 0.68.2 transition: build fails with TypeError: magic_string_1.SourceMap is not a constructor

2019-10-10 Thread Pirate Praveen
Control: forwarded -1 Send the patch upstream as well.

Bug#942021: README.Debian refers to an inexistent architecture.html file

2019-10-10 Thread Tomas Pospisek
Thanks a lot Christoph! *t On Thu, 10 Oct 2019, Christoph Berg wrote: Re: Tomas Pospisek 2019-10-09 <157060474499.25811.562085763250996306.reportbug@hier> Looks like the architecture documentation is missing from the package Hi Tomas, thanks for spotting that. I rewrote architecture.html

Bug#942098: Acknowledgement (Wish for "mmdebstrap unstable unstable-chroot.squashfs")

2019-10-10 Thread Trent W. Buck
I had a brief go at this myself, but I quickly got stuck. * mmdebstrap always has tar write to stdout, rather than adding "-f $filename" to @taropts. mksquashfs doesn't allow this. mksquashfs *has to* write to a regular file (AFAIK). * mmdebstrap adds compression to the pipeline

Bug#941836: blhc: false positive for libtool relink mode?

2019-10-10 Thread Simon Ruderich
On Sun, Oct 06, 2019 at 12:40:22PM +0200, Yves-Alexis Perez wrote: > On Sun, 2019-10-06 at 11:47 +0200, Simon Ruderich wrote: >> Now I'm somewhat confused. I think the issue in this case is not >> "libtool: relink:" because I get no errors for those lines when >> running blhc on the buildd log. >>

Bug#942087: dpkg-source and dpkg-genchanges disagree how .dsc should be named if version ends with +b1

2019-10-10 Thread Guillem Jover
Control: reassign -1 dpkg-dev/1.18.25 On Thu, 2019-10-10 at 08:15:07 +0200, Ansgar wrote: > Package: dpkg > Version: 1.18.25 > Severity: normal > For the Secure Boot support in Debian we automatically generate source > packages that include the signatures (linux-signed-*) from files > shipped in

Bug#794799: libwxgtk3.0-0: assertion failure with gnuplot5

2019-10-10 Thread Vincent Lefevre
On 2019-10-10 07:51:51 +1300, Olly Betts wrote: > Control: tag -1 + unreproducible > > Tagging based on "This is not reproducible" in the initial report. If > you've since found a way to reproduce, please remove the tag and provide > details. IIRC, I haven't managed to reproduce it since a long

Bug#908273: Mouse cursor stops on visual effects

2019-10-10 Thread Uwe Kleine-König
Control: retitle -1 Mouse cursor stops on visual effects On Thu, Sep 13, 2018 at 06:01:06PM +0200, Stefan Frings wrote: > Can somebody please fix the typo in the title? Yes, anyone (who knows how) can ... :-) Best regards Uwe signature.asc Description: PGP signature

Bug#288822: marked as done (developers-reference: "Bugs" control field not documented)

2019-10-10 Thread Holger Levsen
On Wed, Oct 09, 2019 at 08:30:03PM +0200, Guillem Jover wrote: > > thanks for that information! do you agree there's nothing to be added to > > dev-ref? > Yeah, looks like it. & thanks for confirming this too! :) -- cheers, Holger

Bug#942021: README.Debian refers to an inexistent architecture.html file

2019-10-10 Thread Christoph Berg
Re: Tomas Pospisek 2019-10-09 <157060474499.25811.562085763250996306.reportbug@hier> > Looks like the architecture documentation is missing from the package Hi Tomas, thanks for spotting that. I rewrote architecture.html as README.md(.gz), and neglected to update the reference to it in

Bug#941836: blhc: false positive for libtool relink mode?

2019-10-10 Thread Yves-Alexis Perez
On Thu, 2019-10-10 at 09:31 +0200, Simon Ruderich wrote: > Thanks for verifying. I've pushed c4814aa ("Fix false positive in > libtool detection with quoted path", 2019-10-06) [1] with the > fix. > > I've also released blhc 0.10 with the recent fixes. [2] Thanks for the work. I'll wait for it to

Bug#940614: gdm3: GDM doesn't start (I see flickering on the console a few times until it decides it has failed)

2019-10-10 Thread philippe batailler
Package: gdm3 Version: 3.34.0-2 Followup-For: Bug #940614 Dear Maintainer, * What led up to the situation? An upgrade from testing * What exactly did you do (or not do) that was effective (or ineffective)? apt upgrade * What was the outcome of this action? a black screen on

Bug#942059: gcc-9-cross: uses “long” as “time_t” leading to failure on most new 32-bit architectures

2019-10-10 Thread Matthias Klose
Control: severity -1 important Control: reassign -1 src:gcc-9-cross-ports As always, I appreciate your detailed analysis, level of detail (including the gcc-9-source version number), and thoroughly written bug report. No, most 32bit archs build fine, it's just x32 having that issue. On

Bug#942092: attr: [INTL:fr] French templates translation

2019-10-10 Thread Jean-Pierre Giraud
Package: attr Severity: wishlist Tags: patch l10n Hi! Please find attached the french translation updated, proofread by the debian-l10n-french mailing list contributors. I had moved the charset from iso-8859-15 to UTF-8, but I can revert this change if you prefer. This file should be put as

Bug#940571: dpkg-buildflags should support an optimization area for things like lto and pgo

2019-10-10 Thread Matthias Klose
On 09.10.19 20:28, Guillem Jover wrote: Control: tag -1 - patch + moreinfo Control: retitle -1 dpkg-buildflags: Add support for an optimize area for things like LTO On Tue, 2019-09-17 at 14:36:44 +0200, Matthias Klose wrote: Package: src:dpkg Version: 1.19.7 Tags: patch Please add an

Bug#942097: openvpn does not re-read CRLs on client connect in "capath" mode

2019-10-10 Thread Bartos-Elekes Zsolt
Package: openvpn Version: 2.4.7-1 Severity: normal Dear Maintainer, openvpn does not re-read CRLs on client connect in "capath" mode (that is, a directory containing trusted CA certificates and CRLs). I have a two-level CA setup (one root CA and one intermediate CA that emits both server and

Bug#942096: /usr/share/doc/jq/README is a broken symlink

2019-10-10 Thread Jakub Wilk
Package: jq Version: 1.6-1 Severity: minor $ dpkg -L jq | xargs -n1 file 2>&1 | grep -w broken /usr/share/doc/jq/README: broken symbolic link to README.md -- System Information: Architecture: i386 Versions of packages jq depends on: ii libjq1 1.6-1 ii libc6 2.29-2 -- Jakub Wilk

Bug#942098: Wish for "mmdebstrap unstable unstable-chroot.squashfs"

2019-10-10 Thread Trent W. Buck
Package: mmdebstrap Version: 0.5.0-1 Severity: wishlist File: /usr/bin/mmdebstrap It would cool if I could do an unprivileged mmdebstrap and get a .squashfs instead of a tarball. Sales pitch: squashfs is a file format that can act both like an archive (replaces .tar.xz):

Bug#932246: Re : Bug#932246: Re : Bug#932246: printer-driver-hpcups: no more printing to a HP LaserJet 1320: stack smashing detected and hpcups crashed on signal 6

2019-10-10 Thread Brian Potkin
On Wed 09 Oct 2019 at 17:26:02 -0400, Stefan Monnier wrote: > > That'll be 3.19.8+dfsg0-4, uploaded later tonight. It will also ship > > autopkgtests, to also test hplip printing on fake printers. > > FWIW, I have 3.19.8+dfsg0-7 installed and am still seeing this problem. Knowing the printer

Bug#942090: Description isn't descriptive

2019-10-10 Thread Christoph Berg
Package: node-xtend Version: 4.0.1-2 Severity: normal node-xtend short description 's is just a joke, not a description. Please put something in the 1-line description that makes sense. Description-en: extend like a boss xtend is a basic utility library which allows you to extend an object by

Bug#942093: libdbd-mysql-perl: flaky autopkgtest: Out of memory!

2019-10-10 Thread Paul Gevers
Source: libdbd-mysql-perl Version: 4.050-2 Severity: serious Tags: sid bullseye X-Debbugs-CC: debian...@lists.debian.org User: debian...@lists.debian.org Usertags: flaky Dear Perl team, With a recent upload of perl the autopkgtest of libdbd-mysql-perl failed in testing when that autopkgtest was

Bug#908273: Problen does not occur anymore

2019-10-10 Thread Uwe Kleine-König
Control: fixed -1 1.16.0-1 On Sun, Nov 04, 2018 at 01:29:18PM +0100, Stefan Frings wrote: > The problen does not occur anymore with release 1.16.0-1 ^ This typo --' however cannot be fixed :-) I'm not sure if not occuring on 1.16.0-1 is good enough to close this bug, so for now I

Bug#942045: rollup 0.68.2 transition: build fails with TypeError: magic_string_1.SourceMap is not a constructor

2019-10-10 Thread Pirate Praveen
Control: reassign -1 node-magic-string I think this comes from the inconsistent exports in es.js and cjs.js es.js has this line at the end, export { Bundle, SourceMap }; but cjs.js or umd.js does not export these.

Bug#939898: fixed in nftables 0.9.2-2

2019-10-10 Thread Arturo Borrero Gonzalez
Control: notfixed -1 nftables/0.9.2-2 On Wed, 09 Oct 2019 18:04:35 + Arturo Borrero Gonzalez wrote: > Date: Wed, 09 Oct 2019 19:40:31 +0200 > Source: nftables > Architecture: source > Version: 0.9.2-2 > Distribution: unstable > Urgency: medium > Maintainer: Debian Netfilter Packaging Team >

Bug#942045: rollup 0.68.2 transition: build fails with TypeError: magic_string_1.SourceMap is not a constructor

2019-10-10 Thread Pirate Praveen
Control: affects -1 rollup On Thu, 10 Oct 2019 14:16:44 +0530 Pirate Praveen wrote: > Control: reassign -1 node-magic-string > > I think this comes from the inconsistent exports in es.js and cjs.js > > es.js has this line at the end, > > export { Bundle, SourceMap }; > > but cjs.js or umd.js

Bug#942059: gcc-9-cross: uses “long” as “time_t” leading to failure on most new 32-bit architectures

2019-10-10 Thread Gaius Mulley
Matthias Klose writes: > Control: severity -1 important > Control: reassign -1 src:gcc-9-cross-ports > > As always, I appreciate your detailed analysis, level of detail > (including the gcc-9-source version number), and thoroughly written > bug report. No, most 32bit archs build fine, it's just

Bug#915721: transition: opencv

2019-10-10 Thread Paul Gevers
Control: block -1 by 922566 Control: block -1 by 922569 Control: block -1 by 922570 Control: block -1 by 922573 Control: block -1 by 922574 Control: block -1 by 922578 Control: block -1 by 922579 Control: block -1 by 922582 Control: block -1 by 922583 Control: block -1 by 922584 Control: block -1

Bug#942057: claws-mail: shows wrong sha256 certificate fingerprint

2019-10-10 Thread Ricardo Mones
control: tags -1 confirmed pending fixed-upstream Hi, On Wed, Oct 09, 2019 at 06:44:28PM +0200, koniu wrote: > Package: claws-mail > Version: 3.17.3-2 > Severity: normal > > Hi, > > Just a headsup- current claws in stable/testing (3.17.3-2) shows wrong sha256 > certificate fingerprints. > >

Bug#942059: gcc-9-cross: uses “long” as “time_t” leading to failure on most new 32-bit architectures

2019-10-10 Thread Gaius Mulley
Matthias Klose writes: > Control: severity -1 important > Control: reassign -1 src:gcc-9-cross-ports > > As always, I appreciate your detailed analysis, level of detail > (including the gcc-9-source version number), and thoroughly written > bug report. No, most 32bit archs build fine, it's just

Bug#942068: openvpn-systemd-resolved: missing script for update-systemd-resolved

2019-10-10 Thread Eugene Zhukov
Thank you for the bug report, Johan. Could there be something with the configuration on your side? update-systemd-resolved is installed under /etc/openvpn not /etc/openvpn/scripts Thanks, Eugene

Bug#941912: libsoup2.4: CVE-2019-17266

2019-10-10 Thread Claudio Saavedra
On Wed, 2019-10-09 at 20:48 +0200, Salvatore Bonaccorso wrote: > > Thanks for this information, so I'm updating the tracker information. Thank you. > While at it, I'm pretty sure > https://gitlab.gnome.org/GNOME/libsoup/issues/173 was previously > accessible, but now it is not anymore (I was

Bug#942087: dpkg-source and dpkg-genchanges disagree how .dsc should be named if version ends with +b1

2019-10-10 Thread Ansgar
Guillem Jover writes: > On Thu, 2019-10-10 at 08:15:07 +0200, Ansgar wrote: >> With the first binNMU the changelog used 5.2.17+1+b1 as the version >> and this caused disagreement between different parts of dpkg. >> dpkg-source generates linux-signed-amd64_5.2.17+1+b1.dsc, but >> dpkg-genchanges

Bug#942091: ITP: tpm2-pkcs11 -- PKCS#11 interface for TPM2 hardware

2019-10-10 Thread 林上智
Package: wnpp Severity: wishlist Owner: SZ Lin (林上智) X-Debbugs-CC: debian-de...@lists.debian.org * Package name: tpm2-pkcs11 Version : 0~git20190905.0b7ceff Upstream Author : tpm2-software * URL : https://github.com/tpm2-software/tpm2-pkcs11 * License :

Bug#942099: gnome-shell: Screensaver doesn't power down monitor ("Server does not have the DPMS Extension")

2019-10-10 Thread Conrad J.C. Hughes (for Debian package stuff)
Package: gnome-shell Version: 3.30.2-9 Severity: normal Dear Maintainer, Not entirely sure where this report should go, but the gnome-screensaver package says that gnome-shell does screensaving these days.. Before I upgraded to buster and Wayland, Debian would send my monitor to sleep when the

Bug#941267: ukwm can't start, dmesg has segfault error info libukwm-cogl-1.so [b5b4c000+68000]

2019-10-10 Thread Faris Xiao
Thanks for you feedback! 在 2019/10/10 上午3:38, Andreas Beckmann 写道: > testing and sid now have 1.1.11-1+b2 - does the crash still happen with > these versions that were rebuilt against newer libraries? (Don't forget > to upgrade the libukwm-1-0 package, too.) After I upgrade to the newer

Bug#935653: 100% CPU usage for a long time

2019-10-10 Thread Bálint Réczey
Control -1 moreinfo Hi Pascal, I tried to reproduce the issue in an lxc container, but did not observe a lot of stat calls: root@sid-uu:~# dpkg -i hello_2.10-1+deb9u1_amd64.deb dpkg: warning: downgrading hello from 2.10-2 to 2.10-1+deb9u1 (Reading database ... 15204 files and directories

Bug#942104: release.debian.org: Will fail if "Suite" field is missing

2019-10-10 Thread Raphaël Hertzog
Package: release.debian.org Severity: normal User: release.debian@packages.debian.org Usertags: britney britney assumes that if you have a Release file, it will contain a "Suite" field. That's not true, the "Codename" entry is required but the "Suite" one is optional. Please handle properly

Bug#932246: Re : Bug#932246: Re : Bug#932246: printer-driver-hpcups: no more printing to a HP LaserJet 1320: stack smashing detected and hpcups crashed on signal 6

2019-10-10 Thread Stefan Monnier
>> FWIW, I have 3.19.8+dfsg0-7 installed and am still seeing this problem. > Knowing the printer model is always useful. HP-Deskjet-5150 > The file /usr/lib/os-release has bullseye/sid in PRETTY_NAME. Edit > bullseye/sid to reduce the number of characters to less than 12. > Does this have any

Bug#942105: Can not active fcitx after Debian testing upgraded today

2019-10-10 Thread gulfstream
Package: fcitx Version: 1:4.2.9.6-6 Severity: grave I upgrade my Debian testing just now, and I found that the fcitx can not be used. When I press ctrl+Space, the Chinese input UI can not be actived. Hope this problem can be resolve soon. Best regards, Gulfstream -- System Information:

Bug#940973: libarchive-zip-perl breaks strip-nondeterminism autopkgtest: error: becoming Archive::Zip::DirectoryMember

2019-10-10 Thread tony mancill
On Tue, Oct 08, 2019 at 11:15:38PM +0200, gregor herrmann wrote: > Control: tag -1 - fixed-upstream > COntrol: notforwarded -1 > > On Tue, 08 Oct 2019 14:10:19 -0700, Chris Lamb wrote: > > > This has apparently been fixed (again) upstream in version 1.67: > > > > > >

Bug#942109: [choqok] Please support version 1.7

2019-10-10 Thread Lisandro Damián Nicanor Pérez Meyer
Hi Uwe! On Thu, 10 Oct 2019 at 10:42, Uwe Kerstan wrote: > > Package: choqok > Severity: wishlist > > Dear Maintainer, > > http://choqok.gnufolks.org/ is no longer available. > > The new version has many improvements. > > https://cgit.kde.org/choqok.git/tree/changelog > > Thank you very much and

Bug#942109: [choqok] Please support version 1.7

2019-10-10 Thread Uwe Kerstan
Package: choqok Severity: wishlist Dear Maintainer, http://choqok.gnufolks.org/ is no longer available. The new version has many improvements. https://cgit.kde.org/choqok.git/tree/changelog Thank you very much and good luck.

Bug#942100: openssh-server: /etc/ssh/sshd_config unconditionally overwritten by update

2019-10-10 Thread Stefan Tauner
Package: openssh-server Version: 1:7.9p1-10+deb10u1 Severity: important Hi, this just bit me on current stable (Buster) while updating from the security repo: The following packages will be upgraded: openssh-client (1:7.9p1-10 => 1:7.9p1-10+deb10u1) openssh-server (1:7.9p1-10 =>

Bug#942079: [Pkg-utopia-maintainers] Bug#942079: Bug#942079: network-manager: sometimes forgets my wifi password

2019-10-10 Thread Michael Biebl
Am 10.10.2019 um 06:22 schrieb Russell Coker: > KDE. Passwords stored per user. When I resume the desktop is locked but the > keyring isn't. I've read about kwallet related problems in that regard. To rule that out, could you, for testing purposes, store the password(s) system-wide. -- Why

Bug#942056: openvswitch: Incomplete debian/copyright?

2019-10-10 Thread Thomas Goirand
On 10/9/19 6:32 PM, Chris Lamb wrote: > Source: openvswitch > Version: 2.11.0+2019.06.25+git.9ebe795035+ds1-1 > Severity: serious > Justication: Policy §12.5 > X-Debbugs-CC: Thomas Goirand , ftpmas...@debian.org > > Hi, > > I just ACCEPTed openvswitch from NEW but noticed it was missing >

Bug#941836: blhc: false positive for libtool relink mode?

2019-10-10 Thread Eriberto
Em qui, 10 de out de 2019 às 05:45, Yves-Alexis Perez escreveu: > > On Thu, 2019-10-10 at 09:31 +0200, Simon Ruderich wrote: > > Thanks for verifying. I've pushed c4814aa ("Fix false positive in > > libtool detection with quoted path", 2019-10-06) [1] with the > > fix. > > > > I've also released

Bug#942110: stretch-pu: package gnustep-base/1.24.9-3.1+deb9u1

2019-10-10 Thread Yavor Doganov
Package: release.debian.org Severity: normal Tags: stretch User: release.debian@packages.debian.org Usertags: pu I'd like to fix a vulnerability in the gdomap daemon (no DSA). It is fixed in testing/unstable and already approved/uploaded for buster (release.d.o #940943). The patch is the

Bug#942111: dpkg,debhelper: please set HOME, XDG_* to a temporary location during the build

2019-10-10 Thread Simon McVittie
Package: dpkg,debhelper Severity: wishlist I'm reporting this feature request against both dpkg and debhelper because I don't yet know whether it's feasible to implement in debhelper, and if it's feasible in both places, I don't know which location is where it *should* be implemented. Problem

Bug#942101: python-msrest build accesses the network during the build

2019-10-10 Thread Matthias Klose
Package: src:python-msrest Version: 0.6.1-1 Severity: serious Tags: sid bullseye according to https://launchpadlibrarian.net/441507516/buildlog_ubuntu-eoan-amd64.python-msrest_0.6.1-1_BUILDING.txt.gz the tests access some infrastructure. The build must not rely on the network, the autopkg

Bug#941122: e1000e is slow for I219-LM (rev 11)

2019-10-10 Thread Markus Lindberg
Interestingly linux-image-4.19.0-6-amd64 is working perfectly while linux-image-5.2.0-0.bpo.3-amd64 does not. -- Markus

Bug#942103: tasksel: Move fonts-arphic-* to Suggests for task-chinese-{s,t}-desktop

2019-10-10 Thread Aron Xu
Package: tasksel Severity: normal Tags: patch Since fonts-arphic-{ukai,uming} have quite unfriendly fontconfig configurations due to historical reasons, it makes default user experience confusing, thus lowering them from Recommends to Suggests, avoiding them from being automatically installed.

Bug#812421: apt: "apt upgrade" exits with "E: Broken packages" instead of upgrading

2019-10-10 Thread James McCoy
On Thu, Oct 10, 2019 at 08:13:51AM -0400, James McCoy wrote: > Control: found -1 1.8.4 > > On Sat, Jan 23, 2016 at 11:06:54AM -0500, James McCoy wrote: > > "apt upgrade" is erroring out instead of letting me upgrade packages > > uninvolved with the qt packages. > > I'm running into this problem

Bug#937009: [gregory.sz...@gmail.com: Python 3 Transition Plan / Calendar Versioning]

2019-10-10 Thread Julien Cristau
- Forwarded message from Gregory Szorc - Date: Tue, 8 Oct 2019 18:26:46 -0700 From: Gregory Szorc To: mercurial-packag...@mercurial-scm.org, mercurial-devel Subject: Python 3 Transition Plan / Calendar Versioning At the Mercurial 5.2 Sprint last weekend, we made a number of decisions

Bug#931944: vtk7: FTBFS with PROJ 6

2019-10-10 Thread peter green
Disabling the PROJ support was not an option as it was for vtk6. You may want to reinstate the embedded copy and use that instead. It looks like a commit doing this was made on salsa on august 6th https://salsa.debian.org/science-team/vtk7/commit/19d6e5e2e02cbd10404dd96e750370546feaa82b Is

Bug#940571: LTO/PGO and reproducible builds

2019-10-10 Thread Bernhard M. Wiedemann
LTO: ensure you have that gcc patch https://gcc.gnu.org/bugzilla/show_bug.cgi?id=91307 There might be few other related patches that our (SUSE's) Martin Liska probably knows, but if you already have the -flto=auto, you probably got the others, too. PGO: > The only thing it would do is to

Bug#942077: /usr/bin/budgie-desktop: Update to GNOME 3.34 breaks Budgie

2019-10-10 Thread Willem Mulder
On Wed, 9 Oct 2019 23:41:37 +0100 David Mohammed wrote: > many thanks for the suggested changes. > > Please can you let me know a bit more about your setup to clarify why > the patch is required. > > Have you got both gnome-shell and budgie-desktop as sessions? I do, and I suspect that's the

Bug#812421: apt: "apt upgrade" exits with "E: Broken packages" instead of upgrading

2019-10-10 Thread James McCoy
Control: found -1 1.8.4 On Sat, Jan 23, 2016 at 11:06:54AM -0500, James McCoy wrote: > "apt upgrade" is erroring out instead of letting me upgrade packages > uninvolved with the qt packages. I'm running into this problem again. I have the old (now removed from the archive) git-remote-bzr

Bug#936330: construct: diff for NMU version 2.8.16-0.3

2019-10-10 Thread Sandro Tosi
Control: tags 936330 + patch Control: tags 936330 + pending Dear maintainer, I've prepared an NMU for construct (versioned as 2.8.16-0.3) and uploaded it to DELAYED/7. Please feel free to tell me if I should delay it longer. Regards. diff -Nru construct-2.8.16/debian/changelog

Bug#942107: grub flickers with ultrawide monitors

2019-10-10 Thread Laurent Bigonville
Package: grub-pc Version: 2.04-3 Severity: normal Hi, With an ultrawide monitor (21:9 1440p) grub has trouble to draw the screen, flickers when pressing a key and has a really high imput lag. When booting, the grub menu at first badly drawn (with parts that looks no initialized) and then the

Bug#942106: (some kind of) transition: add python3.8 as a supported python3 version

2019-10-10 Thread Matthias Klose
Package: release.debian.org Severity: normal User: release.debian@packages.debian.org Usertags: transition Please setup a tracker to add python3.8 as a supported python3 version. This is non-blocking, as packages can migrate on their own once built. I'm not yet starting this, just want to

Bug#936112: aiodns: diff for NMU version 1.1.1-1.1

2019-10-10 Thread Sandro Tosi
Control: tags 936112 + patch Control: tags 936112 + pending Dear maintainer, I've prepared an NMU for aiodns (versioned as 1.1.1-1.1) and uploaded it to DELAYED/7. Please feel free to tell me if I should delay it longer. Regards. diff -Nru aiodns-1.1.1/debian/changelog

Bug#942104: release.debian.org: Will fail if "Suite" field is missing

2019-10-10 Thread Ansgar
> britney assumes that if you have a Release file, it will contain a "Suite" > field. That's not true, the "Codename" entry is required but the "Suite" > one is optional. https://wiki.debian.org/DebianRepository/Format#A.22Release.22_files says one of Suite and Codename is required. Codename

Bug#942111: dpkg,debhelper: please set HOME, XDG_* to a temporary location during the build

2019-10-10 Thread Simon McVittie
On Thu, 10 Oct 2019 at 14:58:11 +0100, Simon McVittie wrote: > These general-purpose tools, > or the libraries they use, frequently read and write locations such as > $HOME and the freedesktop.org (XDG) base directories[1]. Oops, I forgot the footnote: [1]

Bug#942051: debian-policy: [4.9] requirement to write only to /tmp, /var/tmp, ${TMPDIR} is too strict

2019-10-10 Thread Simon McVittie
On Wed, 09 Oct 2019 at 17:51:53 +0200, Ansgar Burchardt wrote: > +--- > | 4.9 > |Required targets must not write outside of the unpacked source > |package tree, except for TMPDIR, /tmp and /var/tmp. > +--- If you are interested in this sort of thing, is

Bug#942104: release.debian.org: Will fail if "Suite" field is missing

2019-10-10 Thread Raphael Hertzog
Control: tag -1 + patch On Thu, 10 Oct 2019, Ansgar wrote: > https://wiki.debian.org/DebianRepository/Format#A.22Release.22_files > says one of Suite and Codename is required. Codename itself is not required. Ok. > I wouldn't be surprised if many tools just use one and assume it always >

Bug#939751:

2019-10-10 Thread Roel van Meer
Hi, This patch fixes the problem (at least for me, on the one server where it manifested itself). It might not be the best solution though. I've sent it to Kopano to ask for feedback. Cheers, Roel Decrease ICS processing batch size This fixes the following Z-push error:

Bug#942108: ufw: enabling ufw is breaking the INPUT chain

2019-10-10 Thread Jonathan Dowland
Package: ufw Version: 0.36-1 Severity: important Dear Maintainer, Post-buster upgrade, and ufw is no longer functioning correctly. I'm using ip(6)tables-legacy, rather than the newer xtables stuff, for interoperability with docker. My ufw ruleset has several ALLOWs, e.g. # ufw status | grep

Bug#914698: rdepends

2019-10-10 Thread Gordon Ball
Looking at the rdepends of python{,3}-prompt-toolkit: rubber -- Suggests both python- and python3-prompt-toolkit, apparently as a transitive dependency only if you intend to use pythontex from texlive-extra-utils. mycli - Current unstable (1.16) requires ptk 1; upgrading to 1.19 or

Bug#942112: Use Python3 instead of Python2

2019-10-10 Thread Matthias Klose
Package: src:konversation Version: 1.7.5-1 Severity: normal Tags: sid bullseye patch User: debian-pyt...@lists.debian.org Usertags: py2removal Use Python3 instead of Python2. The scripts are compatible with Python2 and Python3. * Use python3 for the scripts (no changes necessary), use

Bug#675432: xterm scrolling is very slow

2019-10-10 Thread Sven Joachim
Control: tags -1 + moreinfo On 2012-05-31 23:48 -0700, David Griffith wrote: > Package: xterm > Version: 278-1 > Severity: normal > > Compared to Xterm in Squeeze, Xterm in Wheezy is very slow to scroll and > update. This leads to distracting flashes and empty blocks when > scrolling or

Bug#942113: 3depict: FTBFS on PPC64EL - POWERPC macro not always defined

2019-10-10 Thread Thierry fa...@linux.ibm.com
Package: 3depict Version 0.0.22-1 Severity: normal The error when compiling on ppc64el: g++ -DHAVE_CONFIG_H -I. -I.. -Wdate-time -D_FORTIFY_SOURCE=2 -I/usr/include/freetype2 -I/usr/include/libpng16 -g -O2 -fdebug-prefix-map=/<>=. -fstack-protector-strong -Wformat -Werror=format-security

Bug#942051: debian-policy: [4.9] requirement to write only to /tmp, /var/tmp, ${TMPDIR} is too strict

2019-10-10 Thread Bill Allombert
On Wed, Oct 09, 2019 at 05:30:51PM +0100, Simon McVittie wrote: > On Wed, 09 Oct 2019 at 18:08:09 +0200, Bill Allombert wrote: > > On Wed, Oct 09, 2019 at 05:51:53PM +0200, Ansgar Burchardt wrote: > > > There are > > > other paths that should be fine to be written to during the build > > >

Bug#942114: cache fails to store capabilities correctly

2019-10-10 Thread Antoine Beaupré
Control: tags -1 +patch Here's a patch to fix this, also available in: https://salsa.debian.org/ganeti-team/ganeti-instance-debootstrap/merge_requests/1 -- You are absolutely deluded, if not stupid, if you think that a worldwide collection of software engineers who can't write operating

Bug#935945: Add patch

2019-10-10 Thread Niv Sardi
tags 935945 + patch thanks I've finally managed to get the time to do the mok dance and test this patch, I can confirm it fixes this bug. I have updated the patch to close this bug in the debian/changelog and created a Merge Request here:

Bug#942117: ndppd: Can't stop ndppd with systemd

2019-10-10 Thread Fabrice Meyer
Package: ndppd Version: 0.2.5-4 Severity: important Tags: patch Dear Maintainer, When I migrated from stretch to buster I add some issues using systemctl to manage ndppd. I enabled the service using systemctl, start running properly but I had the following log line trying to stop it

Bug#940112: buster-pu: package quota/4.04-2+deb10u1

2019-10-10 Thread Adam D. Barratt
Control: tags -1 + confirmed On Thu, 2019-09-12 at 14:50 +0100, Mark Hymers wrote: > quota in buster has a bug (#931855) where rpc.rquotad permanently > spins > at 100% CPU. This bug is fixed in 4.05-1 (unstable) and there is a > targeted fix available for 4.04. I have spoken to the maintainer

Bug#940973: libarchive-zip-perl breaks strip-nondeterminism autopkgtest: error: becoming Archive::Zip::DirectoryMember

2019-10-10 Thread gregor herrmann
On Thu, 10 Oct 2019 06:30:52 -0700, tony mancill wrote: > I have recently started observing build failures for packages that use > jh_manifest (which is part of Debian's javahelper). All of the failures > I have seen so far have the same symptom, namely that the manifest > cannot be extracted

Bug#942118: smartmontools: fails to restart during upgrade, breaks dpkg

2019-10-10 Thread Thorsten Glaser
Package: smartmontools Version: 7.0-1 Severity: grave Justification: renders package unusable […] (Reading database ... 302786 files and directories currently installed.) Preparing to unpack .../00-smartmontools_7.0-1_amd64.deb ... Unpacking smartmontools (7.0-1) over (6.6-1+b1) ... […] Setting

Bug#920118: sponge: preverses permissions but not ownership

2019-10-10 Thread Nicolas Schier
Control: retitle -1 sponge: preserves permissions but not ownership Control: severity -1 normal Control: tag -1 - wontfix On Tue, Oct 01, 2019 at 07:27:57PM +, Andy Smith wrote: > Hi, > > On Thu, Apr 18, 2019 at 10:42:54PM +0200, Nicolas Schier wrote: > > Why do you think that sponge ought

Bug#675433: xterm: terminal bell randomly stops and requires a reboot to get back

2019-10-10 Thread David Griffith
My reply is at the bottom. Please put your reply there too. On Thu, 10 Oct 2019, Sven Joachim wrote: Control: tags -1 + moreinfo On 2012-08-19 19:22 +0700, Ivan Shmakov wrote: Thomas Dickey writes: On Thu, May 31, 2012 at 11:53:05PM -0700, David Griffith wrote: >> Package: xterm >>

Bug#925540: qhull: add libqhullcpp to installed libraries

2019-10-10 Thread David Bremner
D Haley writes: > > The Qhull package does not install the libqhullcpp shared libraries. The > headers are installed, but the library is built statically, and does > not get installed. > > I have attached a patch against ea54d22bba5fb2cedf106a58bd11904370bfeb4f, > which changes the library to

Bug#940815: zathura: Mouse wheel zoom inconsistent with girara >= 0.3.3

2019-10-10 Thread Yuri D'Elia
Package: zathura Version: 0.4.4-1 Followup-For: Bug #940815 I also find the zoom direction to be inverted. I tried to remap Button4/Button5, but no maps involving Button4/5 have effect: map Button4 zoom in map zoom in It seems that the mouse wheel behavior cannot be overridden.

Bug#942120: python3-zmq: pypy3 -m ipykernel install ... fails with No module named zmq.backend.cffi

2019-10-10 Thread r.ductor
Package: python3-zmq Version: 17.1.2-3 Severity: normal Dear Maintainer, Maybe I'm missing some important point and maybe this does not concern python3-zmq, I report my issue anyway. Just after successfull "aptitude install pypy3" I tried to (system-wise) install ipython kernel for pypy3 and

Bug#942121: f2fs-tools: Please do not force to FSCK when changing kernel.

2019-10-10 Thread Kyuma Ohta
Package: f2fs-tools Version: 1.11.0-1.1 Severity: wishlist Dear Maintainer, When boot with changing kernel version, force starting FSCK for F2FS partitions. So, spend a lot of time (some minutes or longer) at boot time. This is upstream's feature issue still not fixed. See

Bug#927757: Drop 0001-Disable-installation-of-tests.patch

2019-10-10 Thread Sandro Tosi
On Mon, 22 Apr 2019 18:44:26 -0300 Emmanuel Arias wrote: > > Thanks! But may be wait a bit ;-) upstream apparently moved tests from the > > package into top directory on the last > release. See my question > https://github.com/PyGithub/PyGithub/issues/1098 >

Bug#942122: does not fallback to ipv4 when ipv6 fails

2019-10-10 Thread Antoine Beaupre
Package: apt-cacher-ng Version: 3.2-2 Severity: normal Tags: ipv6 apt-cacher-ng does not deal well with dual-stack failures. At home I regularly have trouble with my IPv6 connexions, which just hang. Most applications are able to recover from this and fallback to IPv4, which just works. This is

Bug#930796: spindown_time and force_spindown_time are broken in hdparm 9.58+ds-1

2019-10-10 Thread Sébastien Béhuret
Hi Alex, Apologies for the late reply, I found what prevented the HDDs to enter standby mode: udisksd. I leave the workarounds here for reference. Intro: The smartd and udisksd [1] daemons poll S.M.A.R.T. data from drives regularly, and HDDs with a longer standby (or spindown) timeout than the

Bug#942119: libproxy: depends on mono for build-arch; mono not universally present

2019-10-10 Thread Jeremy Bicha
On Thu, Oct 10, 2019 at 12:09 PM Thorsten Glaser wrote: > src:libproxy recently gained a B-D-Arch on dh-sequence-cli which > depends on mono-utils, which isn’t available for the architectures > mips64el (release), alpha, hppa, hurd-i386, ia64, kfreebsd-amd64, > kfreebsd-i386, m68k, riscv64, sh4,

Bug#942123: transmission-remote-cli: should this package be removed?

2019-10-10 Thread Sandro Tosi
Package: transmission-remote-cli Severity: serious Hello, upstream declared, at https://github.com/fagga/transmission-remote-cli that transmission-remote-cli is no longer maintained. Alternative Transmission TUI clients are tremc (a fork of this project) and stig. so, should we remove

Bug#942119: libproxy: depends on mono for build-arch; mono not universally present

2019-10-10 Thread Thorsten Glaser
Hi Jeremy, > Maybe you'd be interested in helping me by digging deeper into this issue? I can try, but I don’t have experience with Mono either. > dh-sequence-cli doesn't work in B-D-Indep as I found when I built 0.4.15-6 : Ouch. Looking at it… >

Bug#942119: libproxy: depends on mono for build-arch; mono not universally present

2019-10-10 Thread Simon McVittie
On Thu, 10 Oct 2019 at 12:46:22 -0400, Jeremy Bicha wrote: > On Thu, Oct 10, 2019 at 12:09 PM Thorsten Glaser wrote: > > src:libproxy recently gained a B-D-Arch on dh-sequence-cli ... > > Please use mono only in B-D-Indep. > > dh-sequence-cli doesn't work in B-D-Indep as I found when I built

Bug#942056: openvswitch: Incomplete debian/copyright?

2019-10-10 Thread Chris Lamb
Hi Thomas, > My last upload, which fixes it, goes again through NEW, as we (re-)added > the support for ipsec. This was just ACCEPTED. Regards, -- ,''`. : :' : Chris Lamb `. `'` la...@debian.org  chris-lamb.co.uk `-

Bug#935653: [unattended-upgrades] /usr/bin/unattended-upgrade hogging cpu

2019-10-10 Thread Thibaut Girka
I have the same issue Running `/usr/bin/unattended-upgrade -v -d --download-only` manually shows that it is trying to solve dependencies somehow and keeps failing at finding something it is satisfied with. Here is an extract: […] Checking: evolution-common ([, , ]) pkg libebook-1.2-19 now

Bug#942116: mocha: missing documented file /usr/share/doc/mocha/Readme.md.gz

2019-10-10 Thread Jonas Smedegaard
Package: mocha Version: 4.1.0+ds3-5 Severity: minor -BEGIN PGP SIGNED MESSAGE- Hash: SHA512 Man page references /usr/share/doc/mocha/Readme.md.gz for more information, but that file does not exist. - Jonas -BEGIN PGP SIGNATURE-

Bug#942124: gdk-pixbuf: intermittent FTBFS on i386: pixbuf-randomly-modified: failed to allocate 1048576 bytes

2019-10-10 Thread Simon McVittie
Source: gdk-pixbuf Version: 2.38.2+dfsg-1 Severity: important https://buildd.debian.org/status/fetch.php?pkg=gdk-pixbuf=i386=2.40.0%2Bdfsg-1=1570725571=0 > The output from the failed tests: > > 6/23 gdk-pixbuf:slow / pixbuf-randomly-modified FAIL 0.37 s (killed by > signal 5 SIGTRAP) > >

Bug#938132: python-repoze.sphinx.autointerface: diff for NMU version 0.8-0.2

2019-10-10 Thread Sandro Tosi
Control: tags 938132 + patch Control: tags 938132 + pending Dear maintainer, I've prepared an NMU for python-repoze.sphinx.autointerface (versioned as 0.8-0.2) and uploaded it to DELAYED/7. Please feel free to tell me if I should delay it longer. Regards. diff -Nru

  1   2   3   >