Bug#753837: crawl-tiles: Crawl-tiles fails to start unless package ttf-dejavu-core is installed

2014-07-06 Thread Esa Peuha
The reason for this is that the absolute paths to the font files are searched for and hardcoded into the binary at compile time, and if both fonts-dejavu-core and ttf-dejavu-core are installed, the latter is used. Since ttf-dejavu should be avoided if possible, the right fix is to change crawl to

Bug#776143: Avoid appending timestamps to generated manpages

2015-06-21 Thread Esa Peuha
Since this package is now orphaned [1], it is possible to just do a QA upload [2] to fix this issue instead of waiting for someone to adopt the package (which might take a long time). [1] http://bugs.debian.org/782433 [2]

Bug#785509: RM: appdata-tools -- ROM; deprecated, unused

2015-06-25 Thread Esa Peuha
The transitional appdata-tools from src:appstream-glib is in both unstable and testing now, so it should be safe to go ahead with this. -- To UNSUBSCRIBE, email to debian-bugs-dist-requ...@lists.debian.org with a subject of unsubscribe. Trouble? Contact listmas...@lists.debian.org

Bug#785556: RM: php-math-biginteger -- ROM; Duplicate from php-seclib

2015-06-25 Thread Esa Peuha
I think that careful reading of https://www.debian.org/doc/debian-policy/ch-relationships.html#s-virtual will be the best way to understand the situation here, but the most important thing is that virtual packages can't have version numbers. Therefore the line Provides: php-math-biginteger (=

Bug#789793: broken PTS links on pending removals page

2015-06-24 Thread Esa Peuha
Package: ftp.debian.org It seems that all links on http://ftp-master.debian.org/removals.html that should point to packages' PTS pages are broken. -- To UNSUBSCRIBE, email to debian-bugs-dist-requ...@lists.debian.org with a subject of unsubscribe. Trouble? Contact listmas...@lists.debian.org

Bug#786535: RM: openvas-libraries/experimental -- RoQA; unmaintained, outdated, uninstallable, ftbfs

2015-06-26 Thread Esa Peuha
I think greenbone-security-assistant should be removed for the same reasons as openvas-*: it's based on openvas-scanner, already missing build dependency libxslt-dev and therefore FTBFS, looks like buildd could never build it on any architecture (binary package gsad on i386 was probably uploaded

Bug#785079: RM: wxwidgets2.8 -- ROM; Unmaintained upstream; newer release packaged

2015-06-30 Thread Esa Peuha
block -1 by 751241 759044 thanks Looks like codeblocks, gspiceui and sitplus have fixed versions available, so that leaves just amule and tribler; marking their bugs as blockers for this bug. -- To UNSUBSCRIBE, email to debian-bugs-dist-requ...@lists.debian.org with a subject of unsubscribe.

Bug#790358: please don't depend on clang-3.4

2015-06-28 Thread Esa Peuha
Package: kfreebsd-11 Control: block 783516 by -1 kfreebsd-11 currently depends on clang-3.4 which is going to be removed (see bug #783516), so please update the dependency to a newer version. Also, if possible, please do the same for kfreebsd-10. -- To UNSUBSCRIBE, email to

Bug#469791: O: libmimedir -- A library to parse RFC 2425 Directory Information blocks

2015-07-06 Thread Esa Peuha
libmimedir was removed (see https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=789203) so closing this bug. -- To UNSUBSCRIBE, email to debian-bugs-dist-requ...@lists.debian.org with a subject of unsubscribe. Trouble? Contact listmas...@lists.debian.org

Bug#790618: FTBFS due to missing dependencies

2015-06-30 Thread Esa Peuha
Package: libdbd-oracle-perl Version: 1.66-1 Severity: serious The source package libdbd-oracle-perl build-depends on packages oracle-instantclient12.1-basic and oracle-instantclient12.1-devel which are not available, and therefore can no longer be built from source. -- To UNSUBSCRIBE, email to

Bug#787923: RM: apache2 -- NBS; ROM; Remove obsolete transitional packages

2015-06-26 Thread Esa Peuha
mod-auth-mysql has been removed, so there should be nothing blocking removal of apache2. -- To UNSUBSCRIBE, email to debian-bugs-dist-requ...@lists.debian.org with a subject of unsubscribe. Trouble? Contact listmas...@lists.debian.org

Bug#793314: handlersocket: update to mysql-5.6

2015-07-24 Thread Esa Peuha
The current source repository is at https://github.com/DeNA/HandlerSocket-Plugin-for-MySQL and it seems to have fixes for mysql 5.6 (though I didn't try to compile it). -- To UNSUBSCRIBE, email to debian-bugs-dist-requ...@lists.debian.org with a subject of unsubscribe. Trouble? Contact

Bug#803061: calendarserver: please make the build reproducible

2015-10-26 Thread Esa Peuha
Source: calendarserver Version: 5.2.2+dfsg-2 Severity: wishlist Tags: patch User: reproducible-bui...@lists.alioth.debian.org X-Debbugs-Cc: reproducible-bui...@lists.alioth.debian.org Hi! While working on the “reproducible builds” effort [1], we have noticed that calendarserver could not be

Bug#803482: ncurses: please make the build reproducible, take two

2015-10-30 Thread Esa Peuha
Source: ncurses Version: 6.0+20151024-1 Severity: wishlist User: reproducible-bui...@lists.alioth.debian.org X-Debbugs-Cc: reproducible-bui...@lists.alioth.debian.org Hi! While ncurses 6.0+20151017-1 fixed the earlier reproducibility bug #801864, it also introduced a reproducibility regression;

Bug#803482: ncurses: please make the build reproducible, take two

2015-10-31 Thread Esa Peuha
On Fri, Oct 30, 2015 at 10:44 PM, Sven Joachim wrote: > Certainly aclocal.m4 is _not_ a generated file in ncurses, Not in the Debian package, but upstream must be generating it from configure.in by running aclocal. > Possible > solutions are to run dh_strip_nondeterminism on

Bug#804140: Problem viewing list of usertagged bugs without specifying a tag

2015-11-05 Thread Esa Peuha
Package: bugs.debian.org URLs such as https://bugs.debian.org/cgi-bin/pkgreport.cgi?users=release.debian@packages.debian.org;tag=transition that include a "tag" parameter work fine, but https://bugs.debian.org/cgi-bin/pkgreport.cgi?users=release.debian@packages.debian.org without that

Bug#801864: ncurses: please make the build reproducible

2015-10-15 Thread Esa Peuha
Source: ncurses Version: 6.0+20150810-1 Severity: wishlist Tags: patch User: reproducible-bui...@lists.alioth.debian.org Usertags: locale X-Debbugs-Cc: reproducible-bui...@lists.alioth.debian.org Hi! While working on the “reproducible builds” effort [1], we have noticed that ncurses could not be

Bug#802481: apertium-en-ca: please make the build reproducible

2015-10-20 Thread Esa Peuha
Source: apertium-en-ca Version: 0.9.3~r61232-1 Severity: wishlist Tags: patch User: reproducible-bui...@lists.alioth.debian.org X-Debbugs-Cc: reproducible-bui...@lists.alioth.debian.org Hi! While working on the “reproducible builds” effort [1], we have noticed that apertium-en-ca (as well as

Bug#801212: unicode-data: please make the build reproducible

2015-10-07 Thread Esa Peuha
Source: unicode-data Version: 8.0-1 Severity: wishlist Tags: patch User: reproducible-bui...@lists.alioth.debian.org X-Debbugs-Cc: reproducible-bui...@lists.alioth.debian.org Hi! While working on the “reproducible builds” effort [1], we have noticed that unicode-data could not be built

Bug#791716: libiconv-dev -- library to convert character encoding

2015-07-08 Thread Esa Peuha
Control: severity -1 wishlist Control: retitle -1 RFP: libiconv-dev -- library to convert character encoding Why do you think libiconv should be included in Debian? All of its functionality is already provided by glibc (and AFAIK has been for several Debian releases). -- To UNSUBSCRIBE, email

Bug#781326: please link to reproducible.d.n/$suite/$arch/$srcpkg

2015-09-28 Thread Esa Peuha
On Mon, Sep 28, 2015 at 10:21 AM, Paul Wise wrote: > Hmm, the template links to .html: No, it actually doesn't, it just looks like it does :-) Notice how the double quote is before the .html instead of after it.

Bug#808121: [Reproducible-builds] Bug#808121: diffoscope: HTML output is bloated

2015-12-17 Thread Esa Peuha
While we are at it, let's convert HTML character entity references (which each use 6-8 characters and as many bytes in the HTML file) to actual characters (which UTF-8 encodes as 2-3 bytes). Since all diffoscope output files are peppered with abundant amounts of these things, this could reduce the

Bug#793314: Let's just drop handlersocket

2016-01-01 Thread Esa Peuha
On Wed, 30 Dec 2015, Clint Byrum wrote: > I orphaned it a long time ago, and nobody has stepped up to maintain, so > I suggest just dropping it rather than chasing this RC. The people who have the power to completely remove packages from Debian are unlikely to notice this here, so please file a

Bug#808347: emacs24: FTBFS on ppc64el, ppc64: "Program segment above .bss"

2015-12-18 Thread Esa Peuha
Source: emacs24 Version: 24.5+1-5 Severity: serious According to https://buildd.debian.org/status/package.php?p=emacs24=sid dumping emacs on ppc64el and ppc64 fails with emacs: Program segment above .bss in /«BUILDDIR»/emacs24-24.5+1/debian/build-x/src/temacs which seems like it might be

Bug#808340: ace-of-penguins: please update to current upstream version

2015-12-18 Thread Esa Peuha
Package: ace-of-penguins Version: 1.3-13 I have write access to the upstream Ace of Penguins CVS repository at cvs.delorie.com/cvs/ace . After the 1.4 release (which never made it into Debian, although it's in Ubuntu) I have fixed a number of bugs in that release, many of them related to the

Bug#808347: emacs24: FTBFS on ppc64el, ppc64: "Program segment above .bss"

2015-12-19 Thread Esa Peuha
On Fri, Dec 18, 2015 at 11:15 PM, Rob Browning wrote: > Actually, I think I may know the cause, but when I had time to poke at > it last week(?), both of the porterboxes were down, and I haven't had a > chance to get back to it yet. > > (I don't have a pointer handy, but

Bug#811274: nmu: mmpong smc

2016-01-18 Thread Esa Peuha
On Mon, Jan 18, 2016 at 4:21 PM, Jonathan Wiltshire wrote: > Is this going to happen often? I'm not excited by the idea of having to get > involved every time the version number for cegui-mk2 gets incremented... I'm afraid I don't know; the only reason I even noticed this is

Bug#810848: ace-of-penguins: 4 doesn't call the four suits game

2016-01-18 Thread Esa Peuha
On Mon, Jan 18, 2016 at 1:34 AM, Markus Koschany wrote: > The affected game is Penguin Spider. According to the help menu it > should be possible to choose a four suits or two suits game by pressing > the buttons 4 or 2. But pressing 4 or 2 in version 1.5~rc1 reshuffles > the

Bug#811182: RM: apertium-en-es/experimental -- RoQA; newer version in unstable/testing

2016-01-16 Thread Esa Peuha
Package: ftp.debian.org The version of apertium-en-es in experimental (0.8.0+svn~57502-1) is older than the version in unstable and testing (0.8.0~r57502-1) although the version strings unfortunately don't really reflect that. I guess the actual contents of the packages are identical, since they

Bug#811274: nmu: mmpong smc

2016-01-17 Thread Esa Peuha
Package: release.debian.org User: release.debian@packages.debian.org Usertags: binnmu Recent update of the cegui-mk2 source package changed the name of the binary package from libcegui-mk2-0.7.6 to libcegui-mk2-0.8.4 with the result that the dependent packages need a binNMU. Apparently there

Bug#814357: RM: fatrat -- RoQA; uninstallable, unbuildable, unmaintained

2016-02-10 Thread Esa Peuha
Package: ftp.debian.org fatrat is uninstallable and unbuildable, and the last upload was in 2012.

Bug#691374: remuco: stop building remuco-exaile

2016-02-06 Thread Esa Peuha
Control: reassign -1 src:remuco Control: retitle -1 remuco: stop building remuco-exaile Bug #813255 requests the removal of exaile. Since remuco-exaile depends on exaile and has not worked for over three years, please stop building remuco-exaile from source.

Bug#813926: RM: remuco-exaile -- RoQA; unusable, depends on to-be-removed package

2016-02-06 Thread Esa Peuha
Package: ftp.debian.org According to bug #691374 remuco-exaile is incompatible with the current exaile API (and has been for over three years) which makes it unusable, and so it has very low popcon. Since it also blocks the removals of exaile and moodbar, I think it would be best to remove

Bug#753800: tracker.debian.org: please give the details link some content

2016-02-07 Thread Esa Peuha
Here is a patch that hopefully fixes this issue. It adds two new template tags, "octicon" which renders any octicon with alternate text (which should appear as both mouseover text and text-mode-only text), and "toggle_chevron" which gives a downward chevron to toggle the display of details (this

Bug#814256: RM: sshmenu -- RoQA; uninstallable, unmaintained, dead upstream

2016-02-09 Thread Esa Peuha
Package: ftp.debian.org sshmenu has been uninstallable for one and a half years (#752821) and already needed user tweaking to work for two years before that (#677595). Upstream looks dead too, last release was six years ago.

Bug#814155: RM: vdkbuilder2 -- RoQA; uninstallable, unmaintained

2016-02-08 Thread Esa Peuha
Package: ftp.debian.org Bug #743295 requested the removals of both vdkxdb2 and vdkbuilder2, but only vdkxdb2 was removed, making vdkbuilder2 uninstallable. Let's fix that omission.

Bug#814147: RM: ghdl -- RoQA; uninstallable, orphaned

2016-02-08 Thread Esa Peuha
Package: ftp.debian.org ghdl is uninstallable (#695303) and orphaned (#696548), and has been both for over three years. It is pointless to keep it in unstable in its current state.

Bug#813727: kfreebsd-10: update clang version

2016-02-04 Thread Esa Peuha
Source: kfreebsd-10 Control: block 812778 by -1 Currently freebsd-10 build-depends on clang-3.5 which is going to be removed (see bug #812778), so please update to a newer version.

Bug#814612: RM: pyke -- RoQA; uninstallable, no rdeps, maintainer agrees

2016-02-13 Thread Esa Peuha
Package: ftp.debian.org python-pyke depends on binary packages that are no longer built from python-ply. There are no rdeps, just a reverse-recommends which shouldn't block the removal. The maintainer of pyke also wants it removed (see #799577 message #15).

Bug#814615: RM: openwalnut -- RoQA; uninstallable, unbuildable, unmaintained

2016-02-13 Thread Esa Peuha
Package: ftp.debian.org openwalnut is uninstallable and unbuildable, and has been for at least a year (see #778050).

Bug#812744: RM: xchat-xsys -- RoQA; depends on to-be-removed package

2016-01-26 Thread Esa Peuha
Package: ftp.debian.org Bug #811007 requests the removal of xchat since its upstream is dead and the actively maintained fork hexchat is already in Debian. As hexchat already has a plugin that does the same thing as xchat-xsys for xchat, there is no reason to keep xchat-xsys.

Bug#785054: Please remove dependency on dpsyco

2016-01-26 Thread Esa Peuha
On Mon, May 11, 2015 Ola Lundqvist wrote: > I would like you to kindly remove the dependency on dpsyco-devel. I have > attached a patch for that. The reason is that I have requested the removal > of psyco source and this reverse dependency prevents that from happening. > See bug

Bug#813501: RM: libcegui-mk2-dev [kfreebsd-amd64 kfreebsd-i386] -- RoQA; NBS, uninstallable

2016-02-02 Thread Esa Peuha
Package: ftp.debian.org As a follow-up to bug #813317, libcegui-mk2-dev on kfreebsd-* is also uninstallable and no longer built from source, so please remove that as well.

Bug#813317: RM: libcegui-mk2-0.7.6 -- RoQA; NBS, uninstallable

2016-01-31 Thread Esa Peuha
Package: ftp.debian.org After the recent removal of ogre-1.8 (bug #797423) libcegui-mk2-0.7.6 is uninstallable, as well as anything that still depends on it, so nothing can get more broken by removing libcegui-mk2-0.7.6 and libcegui-mk2-0.7.6-dbg which are no longer built from source.

Bug#813315: RM: kgamma/experimental -- RoQA; replaced by kgamma5

2016-01-31 Thread Esa Peuha
Package: ftp.debian.org As a follow-up to #813196, please also remove kgamma from experimental.

Bug#816178: RM: python-ldap-doc -- RoQA; obsolete, unmaintained, depends on to-be-removed package

2016-02-28 Thread Esa Peuha
Package: ftp.debian.org In 2006 src:python-ldap-doc was split off from src:python-ldap and moved to contrib because it build-depends on latex2html which at the time was in non-free. However in 2009 latex2html changed its license to GPLv2 and was moved to main, so there is no reason to keep

Bug#815926: RM: albatross -- RoQA; abandoned, dead upstream, depends on to-be-removed package, low popcon

2016-02-25 Thread Esa Peuha
Package: ftp.debian.org The last maintainer upload of albatross was in 2008, and even the last NMU was in 2013. Upstream looks dead too, last release was in 2011. The source package build-depends on python-old-doctools which is going to be removed. The popcon is very low, and there are

Bug#816319: Bugs missing from https://ftp-master.debian.org/removals.html

2016-02-29 Thread Esa Peuha
Package: ftp.debian.org There are currently two bugs missing from the page of Pending Debian Package removals, and have been for some time: 812554 and 814109. Since there doesn't seem to be any other reason why these are still open, I'm assuming it's because they are missing from the page.

Bug#810848: ace-of-penguins: 4 doesn't call the four suits game

2016-01-19 Thread Esa Peuha
This is now fixed in CVS, so I suppose that's 1.5~rc2 then.

Bug#811007: information about build-deps on xchat

2016-01-27 Thread Esa Peuha
tag 811007 - moreinfo thanks Both cwirc and xchat-xsys have been removed, so now xchat can go too.

Bug#812341: RM: libconstantine-java/experimental -- RoQA; replaced by jnr-constants

2016-01-22 Thread Esa Peuha
Package: ftp.debian.org As a follow-up to bug #811487, please also remove libconstantine-java from experimental.

Bug#811158: No rdeps left

2016-03-09 Thread Esa Peuha
Control: tag -1 - moreinfo ISTM there are no rdeps of mysql-5.5 left, so please remove it.

Bug#817571: RM: ruby-hdfeos5-dbg -- RoQA; NBS, manual decrufting needed

2016-03-09 Thread Esa Peuha
Package: ftp.debian.org Version 1.2-6 of src:ruby-hdfeos5 no longer builds a number of packages that were built by 1.2-5; four of these (libhdfeos5-ruby, libhdfeos5-ruby-doc, libhdfeos5-ruby1.9.1, and libhdfeos5-ruby1.9.1-dbg) are arch:all while ruby-hdfeos5-dbg is arch:any (and the only one I

Bug#817938: RM: feel++ -- RoQA; abandoned, FTBFS, uninstallable, depends on to-be-removed package

2016-03-11 Thread Esa Peuha
Package: ftp.debian.org The last upload of feel++ was in September 2014. It has two RC bugs (#777848 and #811714) due to FTBFS, and now it is impossible to even try to build it, since it build-depends on libopenmpi1.10 and libslepc3.4.2-dev which can't be installed at the same time. Four out of

Bug#817939: RM: fw4spl -- RoQA; RC buggy, NPOASR, depends on to-be-removed package

2016-03-11 Thread Esa Peuha
Package: ftp.debian.org fw4spl has had only three upload to Debian: the first two a few days apart in March 2015, the third in July. It has never been in a stable release, and not likely to be because it has two RC bugs (#797475 and #797481) and at least one bug that is going to become RC

Bug#817148: RM: pinba-engine-mysql-5.5 -- RoQA; NBS, blocks mysql-5.5 removal

2016-03-08 Thread Esa Peuha
Package: ftp.debian.org The current version of src:pinba-engine-mysql no longer builds the binary package pinba-engine-mysql-5.5 which AFAICT is the only blocker to mysql-5.5 removal, so please remove this obsolete binary.

Bug#800414: src:minc should be removable now

2016-03-08 Thread Esa Peuha
Control: tag -1 - moreinfo Unless I missed something, there is nothing blocking the removal of src:minc now that caret is gone.

Bug#816716: RM: ginkgocadx [!amd64 !i386] -- RoQA; dependency not available

2016-03-04 Thread Esa Peuha
Package: ftp.debian.org The current version of ginkgocadx both build-depends and runtime depends on insighttoolkit4 which is only available on amd64 and i386. Please remove the obsolete binary packages on other architectures.

Bug#816918: RM: caret -- RoQA; unmaintained, RC buggy, depends on to-be-removed package

2016-03-06 Thread Esa Peuha
Package: ftp.debian.org Last upload of caret was in 2012, it has one serious bug and two important ones (both of which will almost certainly become serious before the release of stretch), and it is the only blocker to the removal of minc.

Bug#817043: RM: ruby-dev [all] -- RoQA; NBS, changed to arch:any

2016-03-07 Thread Esa Peuha
Package: ftp.debian.org Version 1:2.3.0 changed ruby-dev from arch:all to arch:any. Ideally, the automatic decrufter should remove the obsolete arch:all ruby-dev 1:2.3~1, but instead it gets confused and thinks that it would break every package that (build-)depends on ruby-dev. So this one needs

Bug#817047: nmu: cyphesis-cpp_0.6.0-3

2016-03-07 Thread Esa Peuha
Package: release.debian.org User: release.debian@packages.debian.org Usertags: binnmu It seems that cyphesis-cpp has had problems building on several architectures, with the result that it depends on various old library packages on these arches. However the Reproducible Builds project has

Bug#816823: nmu: freqtweak_0.7.2-4.1 rapidsvn_0.12.1dfsg-3

2016-03-05 Thread Esa Peuha
On Sat, Mar 5, 2016 at 4:34 PM, Emilio Pozuelo Monfort <po...@debian.org> wrote: > On 05/03/16 15:08, Esa Peuha wrote: >> Package: release.debian.org >> User: release.debian@packages.debian.org >> Usertags: binnmu >> >> Last year wxwidgets3.0 renamed i

Bug#785770: RM: xserver-xorg-video-siliconmotion [arm64] -- RoP; FTBFS; out-of-date; uninstallable; quite possiblly never worked, little if any utility

2016-03-05 Thread Esa Peuha
On Wed, May 20 2015 Julien Christau wrote: > Please don't do that quite yet. I'm still undecided whether to keep the > package in the archive at all. Pinging you since you added the moreinfo tag to this bug; what should be done with this package?

Bug#816823: nmu: freqtweak_0.7.2-4.1 rapidsvn_0.12.1dfsg-3

2016-03-05 Thread Esa Peuha
Package: release.debian.org User: release.debian@packages.debian.org Usertags: binnmu Last year wxwidgets3.0 renamed its libraries from wx*3.0-0 to wx*3.0-0v5 as part of the libstdc++6 transition, but there are still packages using the old libraries. Out of these, freqtweak and rapidsvn look

Bug#816319: Bugs missing from https://ftp-master.debian.org/removals.html

2016-05-23 Thread Esa Peuha
On Mon, Feb 29, 2016 at 11:26 PM, Mattia Rizzolo wrote: > actually, I think it's because those packages are already removed: Well, at least one of them is (see below). > * #812554: googlecl, already removed after #812553 Not really. Bug #812553 was a request to ftp-masters

Bug#832135: gcc-5: building liburcu on alpha crashes gcc

2016-07-22 Thread Esa Peuha
Package: gcc-5 Version: 5.4.0-6 According to this buildd log https://buildd.debian.org/status/fetch.php?pkg=liburcu=alpha=0.9.2-3=1467933496 attempting to build liburcu 0.9.2-3 on alpha makes gcc 5.4.0-6 crash with an internal compiler error (could not split insn). I don't have access to an

Bug#833674: apt: Use ptsname_r if available

2016-08-07 Thread Esa Peuha
Source: apt Commit 0a81c22 removed the test for ptsname_r from configure.ac but there is a code block in apt-pkg/deb/dpkgpm.cc that is trying to use ptsname_r if it exists. Although that code block is conditional inside "#ifdef HAVE_PTS_NAME_R" while the configure test was trying to define

Bug#828000: emacs24: Missing toolbar icons

2016-07-29 Thread Esa Peuha
I can confirm that the proposed patch fixes the toolbar with LXDE.

Bug#873057: ntp: ntpd not started at boot

2017-08-24 Thread Esa Peuha
Source: ntp Version: 1:4.2.8p10+dfsg-5 I have an installation of Debian testing with ntp installed on it. With ntp version 1:4.2.8p10+dfsg-3 and earlier, ntpd was started during boot, but with 1:4.2.8p10+dfsg-4 and -5, ntpd isn't started (which BTW is far from obvious; I became aware of the issue

Bug#873057: ntp: ntpd not started at boot

2017-08-25 Thread Esa Peuha
On Thu, Aug 24, 2017 at 11:31 AM, Bernhard Schmidt wrote: > Can you show both > > systemctl status ntp.service ● ntp.service - Network Time Service Loaded: loaded (/lib/systemd/system/ntp.service; enabled; vendor preset: enabled) Active: inactive (dead) Docs:

Bug#873591: emacs doesn't un-maximize properly with openbox 3.6.1-5

2017-08-29 Thread Esa Peuha
Package: emacs25 Version: 25.2+1-5 I have an installation of Debian testing that uses openbox as its window manager. Recently openbox was upgraded from version 3.6.1-4.1 to 3.6.1-5 which apparently broke emacs: if I open an emacs window and maximize it, then un-maximizing the window doesn't

Bug#883707: ace-freecell crashes on KDE desktops

2018-02-12 Thread Esa Peuha
That's very odd. Presumably a program can only cause that error message by calling XGetImage, and freecell (like every other of these games except taipei) can only do so from line 819 of xwin.c in build_image. However, the only non-constant arguments to XGetImage are display and window, and if one

Bug#883707: ace-freecell crashes on KDE desktops

2018-02-27 Thread Esa Peuha
I think I've found out what is causing this bug and why it only affects freecell. When any of these games start up, the kde window manager sends an expose event for one pixel at the top left corner, then an expose event for the rest of the top row of pixels, then an expose event for the remaining

Bug#933623: transition: petsc

2019-08-12 Thread Esa Peuha
This transition isn't quite complete yet; src:freefem++ still build-depends on libpetsc-{real,complex}3.10-dev.

Bug#934750: python-pbr: autopkgtest regression

2019-08-14 Thread Esa Peuha
Source: python-pbr Version: 5.1.3-3 As Debian CI logs [1] show, python-pbr 5.1.3-3 is consistently failing its autopkgtest. This regression is blocking its migration to testing. It looks like the test infrastructure is trying to run Python 2 tests, even though Python 2 support was removed from

Bug#934924: python-oslo.middleware: unbuildable in testing

2019-08-16 Thread Esa Peuha
Source: python-oslo.middleware Version: 3.37.1-2 Currently python-oslo.middleware is unbuildable in testing because three of its build-dependencies (python-hacking, python-oslotest, python-stestr) have been removed. Please remove these and other python 2 build-dependencies.

Bug#935041: mh-e: unbuildable in testing due to missing B-D

2019-08-18 Thread Esa Peuha
Source: mh-e Version: 8.5-2.1 Severity: serious Currently mh-e build-depends on emacs25-nox | emacs25 | emacs24 but none of these packages exist in testing. This makes mh-e unbuildable. Please build-depend on emacs-nox | emacs-gtk instead.

Bug#934825: python-yappi: migration blocked by binary upload

2019-08-15 Thread Esa Peuha
Source: python-yappi Version: 1.0-1 python-yappi isn't migrating to testing due to a maintainer-uploaded amd64 binary package. This blocks migration of python-oslo.service which is currently unbuildable in testing. Please make a source-only upload of python-yappi.

Bug#934382: cvxopt: FTBFS on non-amd64 architectures

2019-08-10 Thread Esa Peuha
Source: cvxopt Version: 1.2.3+dfsg-1 Severity: serious As shown by buildd logs [1], compiling src/C/umfpack.c fails on all architectures except amd64 because umfpack.h is not found. This is because line 61 of setup.py tests whether any files matching /usr/lib/x86_64-linux-gnu/libsuitesparse*

Bug#934496: node-regexpu-core: unbuildable in testing due to missing B-D

2019-08-11 Thread Esa Peuha
Source: node-regexpu-core Version: 4.5.4+ds+1 Severity: serious Binary package node-unicode-12.0.0 is no longer built from source and was removed from testing. As a result node-regexpu-core is unbuildable in testing. Please build-depend on node-unicode-12.1.0 instead.

Bug#935079: gnome-photos: unbuildable in testing due to missing B-D

2019-08-19 Thread Esa Peuha
Source: gnome-photos Version: 3.30.1-2 Severity: serious Currently gnome-photos build-depends on python-dogtail but it doesn't exist in testing. This makes gnome-photos unbuildable in testing. Please remove this build-depency.

Bug#935161: RM: chemfp -- RoQA; Python 2 only, B-D on cruft package, dead upstream

2019-08-20 Thread Esa Peuha
Package: ftp.debian.org X-Debbugs-CC: che...@packages.debian.org Please remove chemfp from unstable. It's Python 2 only, it build-depends on python-rdkit which is no longer built by src:rdkit, and last upstream activity was in 2013, so conversion to Python 3 is unlikely to happen.

Bug#934977: verilog-mode: unbuildable in testing due to missing B-D emacs25

2019-08-17 Thread Esa Peuha
Source: verilog-mode Version: 20161124.fd230e6-2 Severity: serious Currently verilog-mode build-depends on emacs25 which doesn't exist in testing. This makes verilog-mode unbuildable. Please build-depend on emacs-gtk instead.

Bug#932320: cross-toolchain-base-mipsen FTBFS in unstable

2019-07-17 Thread Esa Peuha
Source: cross-toolchain-base-mipsen Version: 4 Severity: serious Current version of cross-toolchain-base-mipsen FTBFS with binutils from unstable (version 2.32.51.20190707-1). This is blocking binutils from migrating from unstable to testing (which transitively blocks migration of a bunch of

Bug#932320: [Cross-toolchain-base-devs] Bug#932320: cross-toolchain-base-mipsen FTBFS in unstable

2019-07-18 Thread Esa Peuha
On Wed, Jul 17, 2019 at 8:40 PM Matthias Klose wrote: > > please see > https://lists.debian.org/debian-mips/2019/07/msg1.html Well, if you don't want to fix c-t-b-mipsen, would you agree to have it removed from testing? That should allow binutils and gcc to migrate.

Bug#933061: piuparts.debian.org: missing bullseye

2019-07-26 Thread Esa Peuha
Package: piuparts.debian.org On the left sidebar at https://piuparts.debian.org/ under "all tested suites" there isn't a single line that mentions bullseye. Also, trying to visit https://piuparts.debian.org/bullseye results in a 404 error.

Bug#934251: coinor-dylp: unbuildable in testing due to B-D on texlive-omega

2019-08-08 Thread Esa Peuha
Source: coinor-dylp Version: 1.6.0-1.1 Severity: serious src:texlive-base no longer builds binary package texlive-omega, which has been removed from testing (and will be removed from unstable at some point in the future, even if other packages still depend on it). As a result, coinor-dylp is

Bug#934313: gertty: unbuildable in testing due to B-D on python-alembic

2019-08-09 Thread Esa Peuha
Source: gertty Version: 1.5.0-3 Severity: serious Binary package python-alembic is no longer built from source and has been removed from testing. As a result, gertty is currently unbuildable in testing. Please make gertty build-depend on python3-alembic instead.

Bug#939663: freefem++: B-D on cruft packages

2019-09-07 Thread Esa Peuha
Source: freefem++ Version: 3.61.1+dfsg1-4 Severity: serious Currently freefem++ build-depends on libpetsc-real3.10-dev and libpetsc-complex3.10-dev which are no longer built from source. Please update these build-dependencies.

Bug#939745: python-nameparser: needs a source-only upload

2019-09-08 Thread Esa Peuha
Source: python-nameparser Version: 1.0.4-1 Severity: serious According to the Release Team, maintainer-uploaded binary packages are no longer allowed to enter testing. Since it's not possible to binNMU arch:all packages, a source-only upload is needed to get python3-nameparser built on a buildd.

Bug#939949: sleepyhead: B-D on cruft package

2019-09-10 Thread Esa Peuha
Source: sleepyhead Version: 1.0.0-beta-2+dfsg-6 Severity: serious Currently sleepyhead build-depends on libquazip5-headers, which is no longer built from source as its contents have been merged into libquazip5-dev, thus making sleepyhead unbuildable since these two packages are not coinstallable.