Bug#388006: nfs-common: init script does not write rpc.idmapd.pid

2006-09-17 Thread Matthew Gabeler-Lee
Package: nfs-common Version: 1:1.0.10-1 Severity: normal The mount program looks for /var/run/rpc.idmapd.pid to detect if idmapd is running. The init script for nfs-common will start idmapd, but does not invoke it in a way that creates that pid file. Thus all nfs4 mount attempts cause mount to

Bug#261352: joe: Perl highliting fixed upstream

2006-09-20 Thread Matthew Gabeler-Lee
Package: joe Version: 3.3-5 Followup-For: Bug #261352 While the $` issue seems to be fixed somewhere between 3.1 and 3.3, a very similar bug regarding using variables named $q still exists in 3.3. The changelog for upstream indicates that this (along with several other bugs) was fixed either in

Bug#496151: emdebian-tools: emchain handles multiple available gcc source versions poorly

2008-08-22 Thread Matthew Gabeler-Lee
Package: emdebian-tools Version: 1.4.1 Severity: normal I'm trying to build an i386/i486 cross compiler chain using emchain on the amd64 arch. emchain gives me the Error. Mismatch in source versions error when trying to do so, complaining that 4.3.1-9 is what's built on i386, but I'm trying to

Bug#447172: lirc-modules-source: More information

2007-11-14 Thread Matthew Gabeler-Lee
Package: lirc-modules-source Version: 0.8.2-1 Followup-For: Bug #447172 I saw this problem too. It looks like it is including the automake-generated makefile for drivers/Makefile, with no include to get the kernel build rules. Items in debian/rules and elsewhere indicate that there were in the

Bug#434028: xserver-xorg-video-intel: Ignores Screen/Display/Modes configuration

2007-08-05 Thread Matthew Gabeler-Lee
On Sat, 21 Jul 2007, Brice Goglin wrote: Does it help if you: * get a ModeLine for your desired resolution/refresh rate with something like gtf 1024 768 78 and add it to your xorg.conf Monitor section * add a PreferredMode line to your Monitor section Option PreferredMode

Bug#437724: mime-support: Flash Video mime type

2007-08-13 Thread Matthew Gabeler-Lee
Package: mime-support Version: 3.39-1 Severity: wishlist Would be helpful (mostly for apache) to have the .flv (Flash Video) format in /etc/mime.types. For magic detection, it appears to start with ASCII FLV. -- System Information: Debian Release: lenny/sid APT prefers testing APT policy:

Bug#410035: kernel-package: Confirmed, also breaks unpatching

2007-08-17 Thread Matthew Gabeler-Lee
Package: kernel-package Version: 11.001 Followup-For: Bug #410035 I can confirm this behavior. I was seeing it before with patch_the_kernel=YES and no patches. Now I've noticed another related problem that this bug introduced. I added a patch to my kernel, and noticed that it wasn't getting

Bug#410152: pilot-link: udev rules need updating

2007-02-07 Thread Matthew Gabeler-Lee
Package: pilot-link Version: 0.12.1-5 Severity: minor pilot-link comes with some handy dandy udev rules (/usr/share/pilot-link/udev/60-libpisock.rules) to help get permissions right when plugging in a device. However, these rules no longer work with the current version of udev in Debian. The

Bug#392472: gpar2: Which Package?

2007-02-20 Thread Matthew Gabeler-Lee
Package: gpar2 Version: 0.3-2 Followup-For: Bug #392472 AFAICT, all packages gpar2 depends on directly are up to date in testing, and I'm seeing the same error as the original reporter. Which package specifically needs to be update to work properly with gpar2? If it depends on a particular

Bug#434028: xserver-xorg-video-intel: Ignores Screen/Display/Modes configuration

2007-07-20 Thread Matthew Gabeler-Lee
Package: xserver-xorg-video-intel Version: 2:2.1.0-2 Severity: normal Because of limitations in my hardware, I have a Modes section that is meant to explicitly limit which video modes the i810/intel driver uses. The driver detects, and would normally try to use, several video modes that my

Bug#481300: netfilter-extensions-source: Fails to build against 2.6.25.3

2008-05-15 Thread Matthew Gabeler-Lee
Package: netfilter-extensions-source Version: 20080326+debian-1 Severity: normal When trying to build against stock linux 2.6.25.3 kernel (haven't tried any other kernel versions), I get the following errors: CC [M] /usr/src/modules/netfilter-extensions/net/ipv4/netfilter/ipt_TARPIT.o

Bug#481382: ipset: segfault on --unbind :all: :all:

2008-05-15 Thread Matthew Gabeler-Lee
Package: ipset Version: 2.3.0-1 Severity: normal Tags: upstream patch Trying to run ipset --unbind :all: :all: causes a segfault. Reported upstream at https://bugzilla.netfilter.org/cgi-bin/bugzilla/show_bug.cgi?id=539 Trivial patch to fix it: --- ipset.c.orig2008-05-15

Bug#360084: swish-e: Perl XS improperly built

2006-03-30 Thread Matthew Gabeler-Lee
Package: swish-e Version: 2.4.3-3 Severity: important The XS part of the swish-e perl library is not built correctly on amd64, though it does appear to be correct on i386. The problem is that /usr/lib/perl5/auto/SWISH/API/API.so is not linked against libswish-e or libxml2, thus producing

Bug#355153: pwgen: -B option interferes with combo of -n and -c options

2006-03-03 Thread Matthew Gabeler-Lee
Package: pwgen Version: 2.05-1 Severity: normal When pwgen is given the -c, -n, and -B options together (include at least one capital letter, include at least one number, avoid ambiguous characters), it does not always obey the -n + -c combination. Example: $ pwgen -c -n -B 8 5 ieChei9s

Bug#378312: gmailfs: Same behavior

2006-07-27 Thread Matthew Gabeler-Lee
Package: gmailfs Version: 0.7.1-6 Followup-For: Bug #378312 I'm seeing the exact same behavior as the original reporter. $ mount.gmailfs none /home/cheetah/gmailfs -o username=fastcat -p Gmail password: $ cd gmailfs $ ls Traceback (most recent call last): File /usr/share/gmailfs/gmailfs.py,

Bug#377891: gidentd: Does not start without ipv6

2006-07-11 Thread Matthew Gabeler-Lee
Package: gidentd Version: 0.4.5-7.2 Severity: important gidentd does not work on a kernel without ipv6 support. In gidentd.c, in open_proc_files, it unconditionally attempts to open /proc/net/tcp6, and fails if it cannot. It does not check if the -4 option was given (instructing it to do ipv4

Bug#597563: grub-common: grub-probe segfaults scanning lvm devices

2011-01-08 Thread Matthew Gabeler-Lee
On Sat, 8 Jan 2011, Vladimir 'φ-coder/phcoder' Serbinenko wrote: There may be a problem in RAID assembling. Are any of the devices marked as faulty or spare? No (see below). it's ls -- -l / for now, will be fixed later. $ sudo ./grub-fstest -c 4 /dev/sda3 /dev/sdb3 /dev/sdc3 /dev/sdd3 ls

Bug#597563: grub-common: grub-probe segfaults scanning lvm devices

2011-01-08 Thread Matthew Gabeler-Lee
On Sat, 8 Jan 2011, Vladimir 'φ-coder/phcoder' Serbinenko wrote: As was recommended I forward the remaining part to linux-raid mailing list. In short: on his system mdraid, raid5, 4 devices, metadata (presumably) 0.90, two devices have index 0. If such situation is valid please advice me on how

Bug#597563: grub-common: grub-probe segfaults scanning lvm devices

2011-01-08 Thread Matthew Gabeler-Lee
On 1/8/2011 18:34, Vladimir 'φ-coder/phcoder' Serbinenko wrote: Sorry, I've noticed that I've looked into the wrong place all the long. md2 is fine. I suppose it's a problem with md0 (all mdraid are assembled at the beginning). Since md0 is raid1, its misassembly wouldn't have any influence (we

Bug#597563: grub-common: grub-probe segfaults scanning lvm devices

2011-01-08 Thread Matthew Gabeler-Lee
On 1/8/2011 18:55, Vladimir 'φ-coder/phcoder' Serbinenko wrote: I have a hypothesis. Does last partition on any device span, s.t. it leaves less than 64K after it until the end of device? If so then GRUB sees the same metadata sector as the one at the end of device and as at the end of

Bug#597563: grub-common: grub-probe segfaults scanning lvm devices

2011-01-09 Thread Matthew Gabeler-Lee
On 1/9/2011 16:57, NeilBrown wrote: Simply running mdadm --zero-superblock /dev/sdb should fix it. Well, that doesn't work very well: mdadm: Couldn't open /dev/sdb for write - not zeroing ... strace reveals that mdadm is trying to open it O_EXCL, which I presume is why it's not working

Bug#543367: debconf: Dialog frontend can't start subshell

2009-08-24 Thread Matthew Gabeler-Lee
Package: debconf Version: 1.5.27 Severity: normal When attempting to resolve issues with a new config file in a package upgrade, the dialog (whiptail) frontend for some reason cannot start a subshell to examine the situation. The screen flashses and instantly returns to the menu of choices.

Bug#529891: watchdog: default max config line length too short

2009-05-22 Thread Matthew Gabeler-Lee
Package: watchdog Version: 5.6-1 Severity: normal I was configuring watchdog for my system, and was getting strange complaints about invalid lines in the config file. After a little investigation, I discovered that the config parser has a default maximum line length of 80. Two observations:

Bug#523763: grub-common: Segfault scanning devices

2009-07-19 Thread Matthew Gabeler-Lee
Package: grub-common Version: 1.96+20090709-1 Severity: normal I'm seeing what I think is a new manifestation of the same bug. On an earlier version of grub2, I saw the same FPE, then I upgraded and it was working (sorry, not sure what version that was), and then I (think) I upgraded again, and

Bug#536546: daemontools-run: Should stop services at shutdown

2009-07-10 Thread Matthew Gabeler-Lee
Package: daemontools-run Version: 1:0.76-3 Severity: important daemontools-run nicely starts all the services going at init, but it fails to stop them cleanly at shutdown. Because svscan is designed to keep things going, init's attempt to kill everything at shutdown fails to stop some

Bug#575298: Upstream Response

2010-05-17 Thread Matthew Gabeler-Lee
Forwarded: bug-...@gnu.org Tags: patch Since nobody looked at this, I forwarded this upstream. They responded with this simple patch which fixed the issue for me. From e21d54e8cd3d8026ad56f90cc6bde831106c2cb9 Mon Sep 17 00:00:00 2001 From: Sergey Poznyakoff g...@gnu.org.ua Date: Mon, 17 May

Bug#582534: dkms: Kernel postinst script does not report errors

2010-05-21 Thread Matthew Gabeler-Lee
Package: dkms Version: 2.1.1.2-2 Severity: important When invoking dkms after installing a new kernel, the kernel postinst script hides all errors. It pipes the output of /usr/lib/dkms/dkms_autoinstaller to /dev/null, and does not check its return code. If any of the modules dkms is attempting

Bug#439734: does not support the dynamic option in /etc/ntp.conf

2010-03-22 Thread Matthew Gabeler-Lee
Package: ntp Version: 1:4.2.6+dfsg-1 Severity: normal I noticed I was getting syntax errors in syslog related to this option, and upon further investigation, I found that the option is really and truly gone according to the ChangeLog in the source, and looking at ntp_parser.y, it really really is

Bug#575298: tar: Segfault with --listed-incremental when archive includes root directory

2010-03-24 Thread Matthew Gabeler-Lee
Package: tar Version: 1.23-1 Severity: important When doing an incremental backup using --listed-incremental that includes the root directory, tar segfaults. Example: ## create the full backup tar --create --one-file-system --file /tmp/tartest.tar \ --listed-incremental /tmp/tartest.list

Bug#562573: More info

2010-04-15 Thread Matthew Gabeler-Lee
One more thing I noticed ... For a while the ability for dh-make-drupal to identify packages and versions from the website was broken, and I'd assumed that hadn't been fixed so I'd been building modules by manually downloading tarballs and then running dh-make-drupal project -t tar.gz -V

Bug#562573: dh-make-drupal: Doesn't identify drupal version correctly from .info files

2010-04-15 Thread Matthew Gabeler-Lee
On 14:59, Gunnar Wolf wrote: Hi, I'm sorry it took me so long to look at this bug. The bug report seems invalid to me, as dh-make-drupal does not take that information from the *.info file (only the dependencies are taken from there). The versions list is retreived from the Web site. If you

Bug#562573: dh-make-drupal: Doesn't identify drupal version correctly from .info files

2009-12-25 Thread Matthew Gabeler-Lee
Package: dh-make-drupal Version: 0.4-2 Severity: important dh-make-drupal expects the core version in the .info file to be either 6 or 5 it seems, but with all the modules I'm downloading from the drupal site, the core version is listed as 6.x. For modules that have dependencies on core drupal

Bug#597563: grub-common: grub-probe segfaults scanning lvm devices

2010-09-20 Thread Matthew Gabeler-Lee
Package: grub-common Version: 1.98+20100804-4 Severity: important Any invocation of grub-probe that I try on my system, except --help, segfaults. From past experience, I know better than to try to reboot, because this has almost certainly rendered my system unbootable ... I built a debug

Bug#599376: sudo: Always asks for password if no tty present

2010-10-06 Thread Matthew Gabeler-Lee
Package: sudo Version: 1.7.4p4-3 Severity: normal If sudo is run without a TTY, it always tries to prompt for a password, even if it would not need one with a TTY. Example: $ sudo true prompts, ticket is now live, OK $ sudo true does not prompt, OK $ sudo true /dev/null /dev/null prompts, why? $

Bug#600739: dh-make-drupal: More Info

2010-10-21 Thread Matthew Gabeler-Lee
Package: dh-make-drupal Version: 0.7-1 Severity: normal I'm seeing this too. I did a little deeper looking, and I believe the problem is ocurring around line 828 of dh-make-drupal: # Get the project description. Fetch only the first paragraph - # This is usually enough for the

Bug#599376: (no subject)

2010-10-07 Thread Matthew Gabeler-Lee
tag 599376 upstream forwarded 599376 http://www.gratisoft.us/bugzilla/show_bug.cgi?id=445 thanks Issue is in upstream, upstream has a patch for it. Patch applies to Debian source cleanly and fixes the issue for me. -- To UNSUBSCRIBE, email to debian-bugs-dist-requ...@lists.debian.org with

Bug#507731: libc6: AC_FUNC_MKTIME failing

2008-12-03 Thread Matthew Gabeler-Lee
Package: libc6 Version: 2.7-16 Severity: normal Ancient bug #177940 seems to have cropped up again, or something similar to it. I'm building owfs, which uses the AC_FUNC_MKTIME, and it's deciding that mktime doesn't work, after a timeout (a note in the test source says This test makes some

Bug#511979: nvclock: New Upstream 0.8b4

2009-01-15 Thread Matthew Gabeler-Lee
Package: nvclock Version: 0.8b3-1 Severity: wishlist Upstream has anew version 0.8 beta 4. http://www.linuxhardware.org/nvclock/ http://www.linuxhardware.org/nvclock/nvclock0.8b4.tar.gz -- System Information: Debian Release: 5.0 APT prefers testing APT policy: (990, 'testing'), (500,

Bug#550682: closed by Colin Watson

2010-05-27 Thread Matthew Gabeler-Lee
I can't say for sure if that is the exact version that fixed it, but I have since upgraded grub, and I can confirm that at least the current version in testing (1.98-1) is working properly for me. Thanks, -Matt -- To UNSUBSCRIBE, email to debian-bugs-dist-requ...@lists.debian.org

Bug#550682: grub-common: grub-probe segfaults scanning lvm devices

2009-10-12 Thread Matthew Gabeler-Lee
Package: grub-common Version: 1.97~beta4-1 Severity: important grub-setup is segfaulting in its lvm scanning code. This made my system unbootable. Since even grub-legacy uses grub-probe from grub-common, getting my system to boot again was quite the ordeal :( A stack trace of the crash, from a

Bug#521165: mounted directory are never dismounted

2011-06-02 Thread Matthew Gabeler-Lee
Package: autofs5 Version: 5.0.4-3.2+b1 Followup-For: Bug #521165 Searching around, I believe this may have been fixed upstream, though it's not 100% clear. http://www.mail-archive.com/autofs@linux.kernel.org/msg08622.html Given the code base for the debian package is approaching 2 years old, it

Bug#625917: drupal7

2011-06-10 Thread Matthew Gabeler-Lee
-- To UNSUBSCRIBE, email to debian-bugs-dist-requ...@lists.debian.org with a subject of unsubscribe. Trouble? Contact listmas...@lists.debian.org

Bug#639964: apt: regression from 0.8.15.5: sources with no component give error processing Release file

2011-08-31 Thread Matthew Gabeler-Lee
Package: apt Version: 0.8.15.6 Severity: important As of apt 0.8.15.6, sources.list entries that use the deb http://... path/ format instead of the deb http://... release component format fail (for me). For example, I have the following entries in my sources.list: deb-src

Bug#675299: bash-completion: sudo -u tab should complete usernames

2012-05-30 Thread Matthew Gabeler-Lee
Package: bash-completion Version: 1:1.99-3 Severity: normal Completion for sudo should understand some of sudo's options, most importantly (for me), the -u option. sudo -u tab completes commands as if the -u was not there. Following on from that, sudo -u user tab doesn't complete commands, and

Bug#684738: dh-make-drupal: drupal version specifier broken

2012-08-13 Thread Matthew Gabeler-Lee
-buildpackage: source changed by Matthew Gabeler-Lee dpkg-buildpackage: host architecture amd64 dpkg-source --before-build drupaltrue-mod-ctools-1.9 fakeroot debian/rules clean dh clean dh_testdir dh_auto_clean dh_clean dpkg-source -b drupaltrue-mod-ctools-1.9 dpkg-source: error: can't build

Bug#685024: deborphan: orphaner fails with multiarch

2012-08-15 Thread Matthew Gabeler-Lee
Package: deborphan Version: 1.7.28.8 Severity: normal After enabling multi-arch in dpkg (mostly to get wine stuff working), deborphan / orphaner is not working properly. Instead of displaying just the package name as it would before, it now displays packagename:arch. When orphaner goes to try

Bug#717778: checkinstall: mkdir -p fails (fstrans broken again?)

2013-07-24 Thread Matthew Gabeler-Lee
Package: checkinstall Version: 1.6.2-4 Severity: important If a make install step does a mkdir -p that needs to create multiple directories, it fails, every time. This breaks using checkinstall with quite a lot of packages. Demonstrating this needs only a 2 line Makefile as a package: install:

Bug#718428: completion: diff -c tab should trigger labels

2013-07-31 Thread Matthew Gabeler-Lee
Package: mercurial Version: 2.6.2-1 Severity: minor Invoking completion after the -c argument to diff should invoke the labels (branches, tags, bookmarks, ...) completion, not file completion as it does now. Not sure if other mercurial commands have an equivalent -c argument, diff is the only

Bug#720051: unrar-nonfree: Please bring back libunrar, possibly add sfx

2013-08-17 Thread Matthew Gabeler-Lee
Source: unrar-nonfree Version: 1:5.0.10-1 Severity: normal With the update to unrar 5.0, the libunrar package appears to be gone. Please bring it back :) Packaging the output of the sfx target might be useful too. NB: to build the lib for 5.0, I had to add -fPIC to the compile flags. --

Bug#707212: logrotate script error

2013-05-17 Thread Matthew Gabeler-Lee
Package: tt-rss Version: 1.7.8+dfsg-2 Followup-For: Bug #707212 Also, the logrotate script doesn't send output to /dev/null, so it will spam the administrator every day. -- System Information: Debian Release: jessie/sid APT prefers testing APT policy: (990, 'testing'), (500, 'unstable'), (1,

Bug#710275: postgresql-9.1: Needs restart on libc upgrade

2013-05-29 Thread Matthew Gabeler-Lee
Package: postgresql-9.1 Version: 9.1.9-1 Severity: important When upgrading libc6, it appears that postgresql is one of the services that needs to be restarted for authentication to work properly. After updating libc6 from 2.13 to 2.17 (testing), I was unable to authenticate to my databases

Bug#702715: tortoisehg: broken pyqt4 version check

2013-05-29 Thread Matthew Gabeler-Lee
Package: tortoisehg Version: 2.4-2 Severity: grave Followup-For: Bug #702715 This bug has now landed. As the packages in testing / unstable now stand, you cannot use tortoisehg. Even worse, for reasons I cannot quite understand, it does not print any error message about this situation, nor does

Bug#714216: zenity: Manpage gives incorrect list of available window icons

2013-06-26 Thread Matthew Gabeler-Lee
Package: zenity Version: 3.8.0-1 Severity: minor Tags: upstream From the manpage: --window-icon=ICONPATH Set the window icon with the path to an image. Alternatively, one of the four stock icons can be used: 'error', 'info', 'ques‐ tion' or

Bug#680663: apt-show-versions: bash-completion _comp_dpkg_installed_packages error

2013-01-03 Thread Matthew Gabeler-Lee
Package: apt-show-versions Version: 0.20 Followup-For: Bug #680663 The original report is correct that this is the same problem as 658773, and it has the same solution. Trivial patch attached. -- System Information: Debian Release: wheezy/sid APT prefers testing APT policy: (990,

Bug#697415: RFP: hdhomerun-config-gui -- GUI Configuration utility for Silicon Dust HD HomeRun

2013-01-04 Thread Matthew Gabeler-Lee
Package: wnpp Severity: wishlist * Package name: hdhomerun-config-gui Version : 20120405 Upstream Author : Sillicon Dust * URL : http://www.silicondust.com/support/hdhomerun/downloads/linux/ * License : GPLv3 Programming Lang: C++ Description : GUI

Bug#697696: diffstat: Doesn't fetch terminal width correctly

2013-01-08 Thread Matthew Gabeler-Lee
Package: diffstat Version: 1.55-3 Severity: normal Diffstat tries to get the terminal width to auto-scale the histogram, but the method it uses simply doesn't work, at least with bash. The method it uses is getenv(COLUMNS). Unfortunately, at least with bash, the COLUMNS variable is normally a

Bug#704689: gzip: Overwrite prompt always overwrites

2013-04-04 Thread Matthew Gabeler-Lee
Package: gzip Version: 1.5-1.1 Severity: important When run from a terminal, gzip will prompt the user whether they want to ovewrite the output file if it already exists. For some reason, which I have not yet been able to identify, the debian build always overwrites, no matter what the user

Bug#697696: closed by Sandro Tosi mo...@debian.org (Re: Bug#697696: diffstat: Doesn't fetch terminal width correctly)

2013-01-14 Thread Matthew Gabeler-Lee
reopen 697696 thanks On Sun, 13 Jan 2013, Debian Bug Tracking System wrote: Delivery to the following recipient failed permanently: chee...@fastcat.org Technical details of permanent failure: Google tried to deliver your message, but it was rejected by the recipient domain. We recommend

Bug#697696: closed by Sandro Tosi mo...@debian.org (Re: Bug#697696: diffstat: Doesn't fetch terminal width correctly)

2013-01-25 Thread Matthew Gabeler-Lee
Sandro Tosi mo...@debian.org wrote: On Mon, Jan 14, 2013 at 5:20 PM, Matthew Gabeler-Lee chee...@fastcat.org wrote: Anyways, my point in the bug report is that fetching the COLUMNS environment variable is a no-op, it is completely non-functional. have you tried it? Yes ... hence the bug

Bug#703998: debsecan: Don't report on already installed fixes

2013-03-26 Thread Matthew Gabeler-Lee
Package: debsecan Version: 0.4.16+nmu1 Severity: wishlist Today debsecan alerted me about CVE-2013-1824 (a php5 issue). Based on the PTS page for php5 and my system update schedule, I can say with near certainty that I installed the fixed version of php5 more than two weeks before it sent the

Bug#703998: debsecan: Don't report on already installed fixes

2013-03-26 Thread Matthew Gabeler-Lee
On 2013-03-26 14:27, Florian Weimer wrote: * Matthew Gabeler-Lee: Today debsecan alerted me about CVE-2013-1824 (a php5 issue). Based on the PTS page for php5 and my system update schedule, I can say with near certainty that I installed the fixed version of php5 more than two weeks before

Bug#702977: tt-rss: Missing Depends: libphp-simplepie

2013-03-13 Thread Matthew Gabeler-Lee
Package: tt-rss Version: 1.7.2+dfsg-1 Severity: grave Justification: renders package unusable tt-rss needs simplepie to do anything with RSS feeds, AFAICT. But the package does not have a Depends, or even a Recommends or Suggests on libphp-simplepie. Without that package, I cannot subscribe to

Bug#701140: dh-make-perl: Patch to understand packages named -vX.Y.Z

2013-02-21 Thread Matthew Gabeler-Lee
Package: dh-make-perl Version: 0.75-1 Severity: important Tags: patch dh-make-perl doesn't seem to understand packages that have a name like Foo-Bar-v1.0.0, only ones named Foo-Bar-1.0.0. Attached tiny patch fixes this. -- System Information: Debian Release: 7.0 APT prefers testing APT

Bug#701140: dh-make-perl: Patch to understand packages named -vX.Y.Z

2013-02-22 Thread Matthew Gabeler-Lee
On 2013-02-22 08:41, gregor herrmann wrote: On Thu, 21 Feb 2013 20:31:39 -0500, Matthew Gabeler-Lee wrote: dh-make-perl doesn't seem to understand packages that have a name like Foo-Bar-v1.0.0, only ones named Foo-Bar-1.0.0. Attached tiny patch fixes this. Thanks for your bug report

Bug#701140: dh-make-perl: Patch to understand packages named -vX.Y.Z

2013-02-22 Thread Matthew Gabeler-Lee
On 2013-02-22 10:58, gregor herrmann wrote: Summary: 1) I'm confused :) 2) The errors come from git, and we really seem to have a version problem somewhere. Not sure if this is the problem you are facing. 3) Could you please provide the dh-make-perl invocation and output on your system,

Bug#701717: getmail4: New upstream release (4.39.0)

2013-02-26 Thread Matthew Gabeler-Lee
Package: getmail4 Version: 4.32.0-2 Severity: wishlist There is a new upstream release which addresses several (to me) important issues. Most notably, it makes getmail behave rationally when interrupted via Ctrl-C. Also, it looks like it should contain a fix for #513116 (see the release notes

Bug#694547: gmpc: Doesn't show in Gnome applications list

2012-11-27 Thread Matthew Gabeler-Lee
Package: gmpc Version: 11.8.16-5 Severity: important The gmpc application no longer appears in the gnome applications menu. In the gnome menu editor, gmpc does appear in the (disabled) Debian menu hierarchy. Investigating a bit, it appears that /usr/share/applications/gmpc.desktop is slightly

Bug#694829: libtiff4 is not Multi-Arch compatible

2012-11-30 Thread Matthew Gabeler-Lee
Package: libtiff4 Version: 3.9.6-9 Severity: normal Installing libtiff4 in a multiarch environment (e.g. i386 on an amd64 native for me) fails: Unpacking libtiff4:i386 (from .../libtiff4_3.9.6-9_i386.deb) ... dpkg: error processing /var/cache/apt/archives/libtiff4_3.9.6-9_i386.deb (--unpack):

Bug#259864: debget -a arch pkg

2012-12-03 Thread Matthew Gabeler-Lee
Package: debian-goodies Version: 0.61 Followup-For: Bug #259864 I was trying to use the other apt syntax for specifying an architecture (apt-get install packagename:arch), and it looks like debget gets most of the way there, it just needs some slightly smarter regex fu. $ debget libtiff4:amd64

Bug#694829: libtiff4 is not Multi-Arch compatible

2012-12-03 Thread Matthew Gabeler-Lee
On Mon, 3 Dec 2012, Jay Berkenbilt wrote: Can you double check to make sure that you are installing the same version for amd64 and i386? It looks like the version you have for amd64 might be different from the version you are trying to install on i386. $ sudo apt-get remove libtiff4:i386 ...

Bug#714279: fontconfig-config: Not correct view anti-aliasing fonts and incorrect visualization.

2013-07-08 Thread Matthew Gabeler-Lee
Package: fontconfig-config Version: 2.10.2-2 Followup-For: Bug #714279 I encountered the same problems. By fiddling some configuration bits, I was able to restore the previous good font rendering: 1. Fix the symlink for /etc/fonts/conf.d/11-lcdfilter-default.conf (it was pointing to

Bug#716664: Grive needs updating to 0.3.0

2013-07-12 Thread Matthew Gabeler-Lee
Package: grive Version: 0.2.0-1 Followup-For: Bug #716664 If you check GitHub and the main grive website carefully, you'll notice that 0.3.0 is not a finalized release yet. That said, it would be nice to have a pre-release snapshot from github available, at least in /experimental, since the new

Bug#725755: php-wikidiff2: Incomplete / incorrect php.ini installation

2013-10-07 Thread Matthew Gabeler-Lee
Package: php-wikidiff2 Version: 0.0.1+svn109581-1+b1 Severity: important php-wikidiff2 installs its php.ini snippet into /etc/php5/conf.d, but the common usage of it with mediawiki and apache does not read this directory. It should be putting the ini snippet in /etc/php5/mods-available and then

Bug#725980: geoip-database-contrib: Cron job should be quieter

2013-10-10 Thread Matthew Gabeler-Lee
Package: geoip-database-contrib Version: 1.13 Severity: wishlist The cron job installed by geoip-database-contrib mails the full wget output, including the (long) download progress. This seems a bit excessive. I see two options: 1) The cron entry sends stdout to /dev/null, but not stderr. It

Bug#730656: nautilus-dropbox: Colorized output broken

2013-11-27 Thread Matthew Gabeler-Lee
Package: nautilus-dropbox Version: 1.6.0-2 Severity: normal The output of dropbox ls or dropbox filestatus --list is supposed to be colorized when running on a terminal. However, the colorized output is never used because in /usr/bin/dropbox, ~ line 832, there is this:

Bug#606165: Support python3

2013-12-11 Thread Matthew Gabeler-Lee
Package: pylint Version: 0.27.0-1 Followup-For: Bug #606165 3 years on... I see that a 1.0.0 upstream update package is pending, but looking in the subversion repo for the debian packaging, it still doesn't have python 3.x support. -- System Information: Debian Release: jessie/sid APT prefers

Bug#706097: coreutils: chmod --recursive --changes fails to stat items in subdirectories

2013-04-24 Thread Matthew Gabeler-Lee
Package: coreutils Version: 8.20-3 Severity: normal Tags: upstream Under some circumstances, combining the --recursive and --changes arguments to chmod can cause it to report errors checking the new permissions of subdirectories. Test case: $ cd /tmp $ mkdir -p a/b $ chmod -R g+s a $ chmod -Rc

Bug#715482: gnome-calculator: (Wrong calculation results!) `Malformed expression' after changing number bases.

2013-08-28 Thread Matthew Gabeler-Lee
Package: gnome-calculator Version: 3.8.2-1 Followup-For: Bug #715482 The first bug (which is driving me batsh*t crazy) appears to have been fixed upstream between 3.9.4 and 3.9.90, based on some quick testing of building upstream source from git. The only functional change between those two

Bug#721752: isc-dhcp-server: Always listens on all interfaces

2013-09-03 Thread Matthew Gabeler-Lee
Package: isc-dhcp-server Version: 4.2.4-7 Severity: normal It seems that the isc-dhcp-server daemon always listens for dhcp requests on all interfaces, even when given a specific interface to bind to. The dnsmasq program appears to have the same bug. The result is that having a dhcp server for

Bug#721751: dnsmasq-base: Always listens on all interfaces

2013-09-03 Thread Matthew Gabeler-Lee
Package: dnsmasq-base Version: 2.66-4 Severity: normal It seems that the dnsmasq daemon always listens for dhcp requests on all interfaces, even when given a specific interface to bind to. The isc-dhcp-server program appears to have the same bug. The result is that having a dhcp server for a

Bug#722534: vnstat: Provide /etc/network/if-*.d script(s) to avoid counter problems

2013-09-11 Thread Matthew Gabeler-Lee
Package: vnstat Version: 1.11-2 Severity: wishlist vnstat has some documented issues around what happens when an interface is brought down and then back up, and it has some options (I think mostly the --reset option) to help deal with this. It would be nice if there were /etc/network/if-*.d (not

Bug#723620: mediawiki: Default installation does not work (Apache 2.4 problem)

2013-09-17 Thread Matthew Gabeler-Lee
Package: mediawiki Version: 1:1.19.8+dfsg-1 Severity: important Dear Maintainer, * What led up to the situation? Installed clean new Debian wheezy system. Installed Apache 2.4 with default options. Installed mediawiki with default options. Enabled mediawiki apache configuration, including

Bug#723622: php-wikidiff2: Configuration sent as output instead of executing

2013-09-17 Thread Matthew Gabeler-Lee
Package: php-wikidiff2 Version: 0.0.1+svn109581-1+b1 Severity: important Using a default installation of Debian testing, with Apache 2.4, the contents of /etc/mediawiki-extensions/extensions-available/wikidiff2.php are being sent as output instead of executing. AFAICT, this is because the file

Bug#723669: gptsync: Doesn't understand linux filesystem gpt partition type

2013-09-18 Thread Matthew Gabeler-Lee
Package: gptsync Version: 0.14-2 Severity: normal gptsync doesn't understand gpt partitions with code 8300 / guid 0FC63DAF-8483-4772-8E79-3D69D8477DE4, the linux filesystem type. -- System Information: Debian Release: jessie/sid APT prefers testing APT policy: (990, 'testing'), (500,

Bug#723620: [Pkg-mediawiki-devel] Bug#723620: mediawiki: Default installation does not work (Apache 2.4 problem)

2013-09-18 Thread Matthew Gabeler-Lee
Thorsten Glaser t.gla...@tarent.de wrote: On Tue, 17 Sep 2013, Matthew Gabeler-Lee wrote: The problem seems to do with the change in syntax for Apache 2.4 allow/deny rules. Prior bug#669832 mentions a fix that worked for me (change in the allow/deny syntax in /etc/mediawiki/apache.conf

Bug#723620: [Pkg-mediawiki-devel] Bug#723620: mediawiki: Default installation does not work (Apache 2.4 problem)

2013-09-18 Thread Matthew Gabeler-Lee
Thorsten Glaser t.gla...@tarent.de wrote: On Tue, 17 Sep 2013, Matthew Gabeler-Lee wrote: The problem seems to do with the change in syntax for Apache 2.4 allow/deny rules. Prior bug#669832 mentions a fix that worked for me (change in the allow/deny syntax in /etc/mediawiki/apache.conf

Bug#723620: [Pkg-mediawiki-devel] Bug#723620: mediawiki: Default installation does not work (Apache 2.4 problem)

2013-09-19 Thread Matthew Gabeler-Lee
On 2013-09-19 05:30, Thorsten Glaser wrote: On Thu, 19 Sep 2013, Thorsten Glaser wrote: Since the bug occurs for you but not for me, can you try … or actually, try the attached file, jmw already committed something. Yup, that works, which is no surprise since it's exactly what I did to

Bug#737898: i8kmon: no UI visible

2014-02-06 Thread Matthew Gabeler-Lee
Package: i8kutils Version: 1.40 Severity: normal With the gnome 3 desktop, the i8kmon UI does not appear. I suspect this may be related to gnome changing the rules on docked tray apps, but I'm not sure how to verify this. -- System Information: Debian Release: jessie/sid APT prefers testing

Bug#737896: i8kutils: Missing Depends: acpitool (or: bug handling not-installed optional program)

2014-02-06 Thread Matthew Gabeler-Lee
Package: i8kutils Version: 1.40 Severity: normal If acpitool is not installed, i8kmon fails to run: couldn't execute acpitool: no such file or directory while executing exec acpitool -a (eval body line 1) invoked from within eval exec $cmd2 (procedure read_ac_status line 13)

Bug#713612: vdpau-video: FTBFS: utils_glx.h:163:5: error: unknown type name 'PFNGLMULTITEXCOORD2FPROC'

2013-12-30 Thread Matthew Gabeler-Lee
Package: vdpau-video Version: 0.7.3-2 Followup-For: Bug #713612 I know debian-multimedia.org is persona non grata in some portions of the debian circle, but they do have patches for this (and other FTBFS problems) in vdpau-video-dmo 0.7.4-dmo1. The dmo patches for 0.7.4 apply cleanly to the

Bug#703472: iceweasel freezes in _MD_WaitUnixProcess after mailcap test command terminates

2014-01-06 Thread Matthew Gabeler-Lee
Package: iceweasel Version: 26.0-1 Followup-For: Bug #703472 I've found a workaround for this issue, for both iceweasel and icedove. Launch the app from a terminal (xterm, etc.), backgrounded, and then dismiss the terminal. I.e. open a terminal and run iceweasel or icedove , and then exit.

Bug#734930: libswt-webkit-gtk-3-jni: Prefers to load libwebkitgtk-1.0 over libwebkitgtk-3.0, and then crashes

2014-01-10 Thread Matthew Gabeler-Lee
Package: libswt-webkit-gtk-3-jni Version: 3.8.2-3 Severity: important It seems that this package prefers to load libwebkitgtk-1.0 over libwebkigtk-3.0, even though it only seems to work with 3.0. The upshot of this (for me), is that if libwebkitgtk-1.0-0 is installed (e.g. because I want to use

Bug#735524: samba: Unbounded per-client logging

2014-01-15 Thread Matthew Gabeler-Lee
Package: samba Version: 2:4.1.3+dfsg-2 Severity: minor Debian's default smb.conf has the directive log file = /var/log/samba/log.%m which is all well and good. But, other than log.smbd and log.nmbd, none of these are rotated or pruned. In the old days, this never seemed to be a problem, but in

Bug#702201: samba: logrotate script for nmbd.log does not wait long enough.

2014-01-15 Thread Matthew Gabeler-Lee
Package: samba Version: 2:4.1.3+dfsg-2 Followup-For: Bug #702201 The easiest workaround is to add delaycompress to the logrotate config so that logrotate renames the log file on the first rotate, and compresses it on the second rotate. -- Configuration Files: /etc/logrotate.d/samba changed:

Bug#735620: yafc: bash_completion helper broken and in wrong directory

2014-01-16 Thread Matthew Gabeler-Lee
Package: yafc Version: 1.3.1-1 Severity: minor The completion helper script is installed as: /usr/share/bash-completions/completions/yafc it should be: /usr/share/bash-completion/completions/yafc After relocating the file, unfortunately it still didn't work. I was able to fix it easily enough,

Bug#606165: Support python3

2014-01-25 Thread Matthew Gabeler-Lee
-maintainer upload. + * Add python3 support experimentally + + -- Matthew Gabeler-Lee (Cheetah) chee...@fastcat.org Sat, 25 Jan 2014 17:49:57 -0500 + pylint (1.1.0-1) unstable; urgency=low * New upstream release diff -urN pylint-1.1.0/debian/control pylint-1.1.0-py3/debian/control --- pylint

Bug#710275: postgresql-9.1: Needs restart on libc upgrade

2013-12-18 Thread Matthew Gabeler-Lee
On 2013-12-18 04:49, Christoph Berg wrote: a late followup here: which kind of authentication do you have configured there? I'd assume the problem only affects pam. Actually I'm only using md5 and ident with a username map. (I'm downgrading the bug to normal because pam is not the default

Bug#703472: iceweasel freezes in _MD_WaitUnixProcess after mailcap test command terminates

2013-12-18 Thread Matthew Gabeler-Lee
Package: iceweasel Version: 26.0-1 Followup-For: Bug #703472 I'm not sure how to represent this to the debian BTS (clone this bug?), but it appears that this also affects icedove, at least version 24.1.1-1. -- Package-specific info: -- Extensions information Name: Adblock Plus Location:

Bug#732753: xserver-xorg-video-intel: Backlight changes very slow in gnome, server picks wrong interface

2013-12-21 Thread Matthew Gabeler-Lee
On 2013-12-21 09:38, Julien Cristau wrote: Please report this upstream at bugs.freedesktop.org following the instructions at https://01.org/linuxgraphics/documentation/how-report-bugs and let us know the bug number for tracking. I've submitted https://bugs.freedesktop.org/show_bug.cgi?id=72959

Bug#733133: xwiimote: xwiikeymap often fails to connect to new wiimotes

2013-12-25 Thread Matthew Gabeler-Lee
Package: xwiimote Version: 0.3+20120630-5+b1 Severity: normal The xwiikeymap tool attempts to configure new wiimotes as they connect, but it has a glitch. tools/xwiikeymap.c line 218 has a short sleep after a new device appears, but this sleep is too short. Extending it from 10ms to 100ms works

  1   2   3   4   >