Bug#575367: newvserver: undocumented restriction on hostname

2010-03-31 Thread ydirson
Selon Ola Lundqvist o...@debian.org: merge 575367 409862 thanks Hi Yann On Thu, Mar 25, 2010 at 10:06:20AM +0100, Yann Dirson wrote: Package: vserver-debiantools Version: 0.6.4 # newvserver --hostname a [...] newvserver error: --hostname must be a hostname for the vserver

Bug#582610: memtest86: memtest reboots after running briefly

2010-05-25 Thread ydirson
I tried running memtest86 on an ASUS M3A78 Pro motherboard (dual-core AMD64 with 4GiB non-ECC RAM) and had a reboot after it ran for less than a minute. I hame myself a brand new M4A88TD-V with a 4x CPU and 4GB non-ECC. I got a reboot at ~50% of test1, but test0 can run as much as I want.

Bug#742873: Patch for #742873

2014-11-15 Thread ydirson
tags 742873 + patch thanks Too bad it's too late for jessie... From 18bbc237763955c150da72daf9be2b9702fefb0a Mon Sep 17 00:00:00 2001 From: Yann Dirson ydir...@free.fr Date: Sat, 15 Nov 2014 16:45:50 + Subject: [PATCH] Fix CVE-2013-1953 --- debian/changelog | 8

Bug#788849: accerciser: unhandled exception in QuickSelect inspect accessible under mouse for some widgets

2015-06-16 Thread ydirson
Please use reportbug to report bugs, as that gives us some useful information. I do when possible, it was just not an option from here :) Do you have python3-gi-cairo installed? If not, does it help if you install it? It was not installed, and installing it does fix the problem, thanks!

Bug#788849: accerciser: unhandled exception in QuickSelect inspect accessible under mouse for some widgets

2015-06-15 Thread ydirson
Package: accerciser Version: 3.14.0-1 If eg. I'm inspecting a yelp window, Ctrl-alt-? over a button in the title bar does bring me to the correct item , but over a next button inside a help window, I get and exception: Traceback (most recent call last): File

Bug#788525: git-remote-https segfault involving libgnutls

2015-06-12 Thread ydirson
Package: libgnutls-deb0-28 Version: 3.3.15-5 Severity: grave Justification: breaks other package In my setup, a simple git ls-remote https://github.com/irmen/Pyro4.git; (or any https repo I had) would silently die, with only strace revealing git-remote-https segfaulting. gdb shows: Reading

Bug#788527: pyro4: new upstream available

2015-06-12 Thread ydirson
Source: pyro4 Version: 4.23-2 Severity: normal Dear Maintainer, The version in sid is quite old now, and the online docs describe very useful features... that are simply not available in that old version. -- To UNSUBSCRIBE, email to debian-bugs-dist-requ...@lists.debian.org with a subject of

Bug#787658: aptitude ignores available updates for a while after downgrades

2015-06-12 Thread ydirson
Same here, it looks like only updating the package list again will bring those packages back into the Upgradable set. -- To UNSUBSCRIBE, email to debian-bugs-dist-requ...@lists.debian.org with a subject of unsubscribe. Trouble? Contact listmas...@lists.debian.org

Bug#804662: libsdl2: lacks origtarball filtering instructions

2015-11-10 Thread ydirson
Package: libsdl2 Version: 2.0.2+dfsg1-7 The exact way of turning an upstream tarball into a -dfsg tree is not documented. Having this info would help, eg. when one wants to package a new upstream snapshot.

Bug#803923: razorqt: can read whole text from kerneloops-applet

2015-11-03 Thread ydirson
Package: razorqt, kerneloops-applet Version: 0.5.2-4, 0.12+git20140509-1 Severity: important Under razorqt, various notifications with a long text are truncated, and we can't see the end of the question we're asked. This is seen with eg the question asked after a diag information has been

Bug#803920: firmware-iwlwifi: please include ucode 3160-15

2015-11-03 Thread ydirson
Package: firmware-iwlwifi Version: 20151018-2 This version is advertised as be necessary for kernels 4.2+ (whereas http://www.intel.com/support/fr/wireless/wlan/sb/cs-034398.htm lists already-included 3160-14 to be targeted to 4.2+) It is necessary for and does work for me with 4.3-rc7.

Bug#804024: lesspipe: please add support for OpenEmbedded .ipk files

2015-11-04 Thread ydirson
Package: less Version: 458-3 Tags: patch .ipk files are restricted .deb archives for use by opkg, the dpkg-apt-like tool from OpenEmbedded. They just need to be listed in the known .deb suffixes: *.deb|*.udeb|*.ddeb|*.ipk) echo "$1:"; dpkg

Bug#804025: less: new upstream release

2015-11-04 Thread ydirson
Package: less Version: 458-3 Version 481 has recently been released, as ready for general use.

Bug#802575: ikiwiki: missing dependency

2015-10-21 Thread ydirson
Package: ikiwiki Version: 3.20141016.2 ikiwiki --setup /etc/ikiwiki/auto.setup * [new branch] master -> master Directory /home/wiki/O-Computersinternal is now a clone of git repository /home/wiki/O-Computersinternal.git Can't locate Date/Parse.pm in @INC (you may need to install the

Bug#802576: ikiwiki: history confuses admin name for wiki name

2015-10-21 Thread ydirson
Package: ikiwiki Version: 3.20141016.2 When re-running "ikiwiki --setup /etc/ikiwiki/auto.setup", it attemtps to provide as default values those from a a previous run. However, the default value on second run for the wiki name seems to be taken from the admin name instead.

Bug#802575: Acknowledgement (ikiwiki: missing dependency)

2015-10-21 Thread ydirson
In fact, even more packages seem to be necessary just to create a wiki: gcc, python, libc6-dev (ikiwiki.cgi.c needs stdio.h)

Bug#643997: aptitude: user-requested downgrade should not cause (so much of a) downgrade penalty for conflict resolution

2015-12-07 Thread ydirson
Hi Manuel, - Mail original - > >The "downgrade" use-case surely needs some love those days thanks to > >the moz foundation: I rapidly had a test of iceweasel 7 in unstable > >(eager to get better ram usage ;), just to conclude that so many > >extensions are not compatible. > > > >So let's

Bug#643997: aptitude: user-requested downgrade should not cause (so much of a) downgrade penalty for conflict resolution

2015-12-07 Thread ydirson
- Mail original - > De: "Manuel A. Fernandez Montecelo" > À: "Yann Dirson" > Cc: 643...@bugs.debian.org > Envoyé: Lundi 7 Décembre 2015 17:30:46 > Objet: Re: aptitude: user-requested downgrade should not cause (so much of a) > downgrade

Bug#807444: stormbaancoureur: doc mentions non-shipped example keybinding file

2015-12-08 Thread ydirson
Package: stormbaancoureur Version: 2.1.6-1.1 Quoting README: >For keyboard controls, you can customize the key mapping by copying the file >.stormbaancoureur.keys.example to $HOME/.stormbaancoureur.keys and then >editting >it. Having this file in the package would be a must!

Bug#807447: 0ad: version 0.0.19 is out

2015-12-08 Thread ydirson
Package: 0ad Version: 0.0.18-2 Severity: wishlist 0.0.19 was recently released, it would be great to have it :)

Bug#643997: aptitude: user-requested downgrade should not cause (so much of a) downgrade penalty for conflict resolution

2015-12-07 Thread ydirson
> 2011-10-01 15:59 Yann Dirson: > >Package: aptitude > >Version: 0.6.3-4 > >Severity: normal > > > >The "downgrade" use-case surely needs some love those days thanks to > >the moz foundation: I rapidly had a test of iceweasel 7 in unstable > >(eager to get better ram usage ;), just to conclude

Bug#809767: videoob: failure to download from arte+7

2016-01-03 Thread ydirson
Package: weboob Version: 1.0-3 (at least some of) the arte+7 videos do not download - the relevant wget commandline is unfortunately not reported even in debug mode: videoob> backends only arte videoob> search requin 1 — Dans le sillage des requins (4/4) : Au-delà des apparences (arte)

Bug#810320: pitivi: manpage is wrong

2016-01-08 Thread ydirson
Package: pitivi Version: 0.95-1 Manpage mentions interesting options such as --import, but those seem not to exist in this version.

Bug#808586: weboob: network connection setting up bash completion

2015-12-21 Thread ydirson
Package: weboob Version: 1.0-3 While starting up a (root) shell while on public wifi (wlan0 up but not logged into the captive portal), I get the following when starting up a root shell. Looks somewhat like if much too much things were being attempted in the context of initializing shell

Bug#808221: okular: crashes with no clue when launched from a reconnected screen session

2015-12-17 Thread ydirson
Package: okular Version: 4:15.08.3-1 When running from a screen(1) session that was created before logging out and logging in again, so various envvars are wrong, okular crashes and presents the bug-reporting dialog instead of presenting to the user the more informative "Session bus not found"

Bug#806168: gst-plugins-bad1.0: please ship gst-element-maker

2015-11-24 Thread ydirson
Package: gst-plugins-bad1.0 Version: 1.6.1-1 http://gstreamer.freedesktop.org/data/doc/gstreamer/head/pwg/html/section-boiler-project-stamp.html states that "for creating elements the tool gst-element-maker from gst-plugins-bad is recommended these days". Today it seems it only appears in the

Bug#806546: repo: no doc nor link to doc

2015-11-28 Thread ydirson
Package: repo Version: 1.12.22-1 Severity: wishlist Since there is apparently no doc shipped aside from "repo help", a link to upstream doc ought to be provided, in a README.Debian or in a manpage.

Bug#648443: recommend libx11-doc

2015-11-24 Thread ydirson
> libx11-dev is not installed by > default. As far as I'm concerned this is a non-bug. Policy says: `Recommends' This declares a strong, but not absolute, dependency. The `Recommends' field should list packages that would be found together with this one in

Bug#806792: gst-rtsp-server1.0: please ship examples directory

2015-12-01 Thread ydirson
Package: gst-rtsp-server1.0 Version: 1.6.1-1 Severity: wishlist Starting with this package without an example is not easy, and there are examples in the source tree - please consider shipping them.

Bug#796222: bug fixed in experimental

2016-06-05 Thread ydirson
fixed 796222 1.0.5~20140831-1 thanks Just checked that this bug is not present any more in experimental, would be worth to upload it to unstable ?

Bug#826434: xul-ext-automatic-save-folder: new upstream beta

2016-06-05 Thread ydirson
Package: xul-ext-automatic-save-folder Version: 1.0.5~20140831-1 A new beta was published in February 2016, and there is an official github repo now.

Bug#826321: uscan: typo in manpage

2016-06-04 Thread ydirson
Package: devscripts Version: 2.16.4 Tags: patch "passive" option for FTP is typoed as "passsive", evading search

Bug#826334: dget: removes existing dir by default without asking

2016-06-04 Thread ydirson
Package: devscripts Version: 2.16.4 Severity: grave dget unpacks the downloaded source by default, even if the target directory was pre-existing. Moreover, it does not just unpack it above the pre-existing dir, but removes it first, together with all the other files it may contain !

Bug#826311: closed by Alf Gaida <aga...@siduction.org> (Bug#826311: fixed in pcmanfm-qt 0.11.0-4)

2016-06-04 Thread ydirson
Well, the problem of the selection of the theme is not that easy. I have themes adwaita, tango, oxygen installed. * when I open the prefs, adwaita is highlighted, but apparently not active, as I can get file icons after switching to another theme and then back. I originally thought the

Bug#826311: pcmanfm-qt: lacks icons

2016-06-04 Thread ydirson
Package: pcmanfm-qt Version: 0.11.0-3 With all depends and recommends installed, I don't get any toolbar icons, nor any file icon in contents pane. Looks like a missing dependency. Eg, "strace -efile |& grep icon" shows it's trying to find lots of icons in /usr/share/icons/hicolor/, which

Bug#813051: flashgot: should better advertize audio streaming capabilities

2016-01-28 Thread ydirson
Package: xul-ext-flashgot Version: 1.5.6.12+dfsg-1 Severity: wishlist As described on [1] flashgot is able to expose audio-only streams for eg. youtube videos, and to feed them to media players for streaming. The package description would gain from getting the feature mentioned (I knew about

Bug#816451: icedtea-netx: requires jre8 but still alternatively depends on jre7

2016-03-01 Thread ydirson
Package: icedtea-netx Version: 1.6.2-2 Severity: serious On upgrade, jre8 is not pulled, as existing jre7 fulfills the "openjdk-8-jre | openjdk-7-jre" dependency

Bug#567576: patch

2016-03-18 Thread ydirson
tags 567576 + patch thanks Puzzled to hit this bug (in the GUI version), while there seems to be a patch around since 2012

Bug#817255: cleancss: depends on material in /usr/share/doc

2016-03-09 Thread ydirson
Package: cleancss Version: 1.0.12-1 Severity: serious Removing /usr/share/doc should be allowed, as per policy 12.3. but: var packageConfig = fs.readFileSync('/usr/share/doc/node-clean-css/package.json');

Bug#817907: libcrcutil-doc: advertises non-existant header as main entry point

2016-03-11 Thread ydirson
Package: libcrcutil-doc Version: 1.0-3 README.gz says: use "interface.h" which hides all the details of the implementation. ... but there is no such header in -dev Additionally, the README also says: Please see "usage.cc" which provides an example how to use crcutil_interface::CRC class.

Bug#629121: winpdb and python3

2016-04-12 Thread ydirson
retitle 629121 winpdb: python3 support not packaged severity 629121 important thanks Winpdb has upstream python3 support, but the package has not. Python2 is nearing EOL and writing new programs in python2 is highly discouraged, we must ensure the tools are ready for it :)

Bug#820583: flashplugin-nonfree: should notify when an update is not yet available, not just reinstall current version

2016-04-10 Thread ydirson
Package: flashplugin-nonfree Version: 1:3.6.1+b1 Severity: important After noticing announcement of a CVE, it's rather normal to very where one machine stands: # update-flashplugin-nonfree --status Flash Player version installed on this system : 11.2.202.577 Flash Player version available on

Bug#791761: flashplugin-nonfree: please provide a cronjob to run update-flashplugin-nonfree regularly

2016-04-10 Thread ydirson
It would be more friendly to let the admin choose what to do. Running --install in a cron job without asking and without an opt-out is clearly not that friendly. I'd say we need 3 options in the spirit of: * --install automatically * just check --status, and output weekly reminders [should

Bug#818232: Acknowledgement (qgo: Unable to type via VNC, keys not matching)

2016-03-22 Thread ydirson
reassign -1 libqt5gui5 thanks Sounds like a good idea, thanks for your investigation :) - Mail original - > De: "Linus Lüssing" > À: 818...@bugs.debian.org > Envoyé: Mardi 22 Mars 2016 10:53:56 > Objet: Bug#818232: Acknowledgement (qgo: Unable to type via VNC,

Bug#822458: libjgraphx-java: new version and new upstream URL

2016-04-24 Thread ydirson
Package: libjgraphx-java Version: 2.1.0.7-1 Homepage from control file and copyright file redirects to jgraphx github repo, which is at v3.5.1.2.

Bug#822457: libjgraph-java: upstream URLs are broken

2016-04-24 Thread ydirson
Package: libjgraph-java Version: 5.12.4.2+dfsg-2 Homepage from control file http://www.jgraph.com/ points to a site only providing commercial software. URL from copyright file redirects to jgraphx github repo, which is apparently something different.

Bug#821952: firefox-esr: undistinguishable from firefox in apps menu

2016-04-20 Thread ydirson
Package: firefox-esr, firefox Version: 45.0.2esr-1, 45.0.2-1 Both firefox and firefox-esr can be installed at the same time, and when they are, we get 2 "Firefox" entries in the "Internet" apps menu, and even the tooltips are strictly identical. There should be a way to distinguish them. It

Bug#822172: pjproject: please package examples

2016-04-21 Thread ydirson
Package: pjproject Version: 2.4.5~dfsg-4 Severity: wishlist pjsip-apps/src contains a couple of example apps (vidui, pygui, ...). It would be great to have them available as examples in the relevant dev package.

Bug#822172: Acknowledgement (pjproject: please package examples)

2016-04-21 Thread ydirson
pygui does not seem uptodate (importing pjsua2 while the package builds pjsua). I was able to build vidgui (which is referenced from official wiki at http://trac.pjsip.org/repos/wiki/Video_Users_Guide) by: * building the package from source first (else qmake complains not to find toplevel

Bug#822665: bumblebee: reports wrong error message from Xorg log

2016-04-26 Thread ydirson
No I just reported it to the bts as I saw it - Mail original - > De: "Luca Boccassi" > À: ydir...@free.fr, 822...@bugs.debian.org > Envoyé: Mardi 26 Avril 2016 11:28:29 > Objet: Re: Bug#822665: bumblebee: reports wrong error message from Xorg log > > Control:

Bug#822665: bumblebee: reports wrong error message from Xorg log

2016-04-26 Thread ydirson
Package: bumblebee Version: 3.2.1-10 When trying to use bumblebee those days, the reported failure is: $ optirun xterm [42519.843834] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) /dev/dri/card0: failed to set DRM interface version 1.4: Permission denied [42519.843864]

Bug#822264: plantuml: pdf generation requires batik

2016-04-22 Thread ydirson
Package: plantuml Version: 8024-2 "plantuml -tpdf" fails with: java.lang.ClassNotFoundException: org.apache.batik.apps.rasterizer.SVGConverter I've tried to install libbatik-java, but it did not help.

Bug#824958: QtQuick1 removal from the archive

2016-05-22 Thread ydirson
tags 824958 + pending thanks Fixed in git - Mail original - > De: "Lisandro Damián Nicanor Pérez Meyer" > À: 824...@bugs.debian.org > Cc: ydir...@free.fr > Envoyé: Dimanche 22 Mai 2016 16:22:51 > Objet: Bug#824958: QtQuick1 removal from the archive > > On Sunday

Bug#821333: snapshot.debian.org: should advertise source-specific [check-valid-until=false] in preference to system-wide flag

2016-04-17 Thread ydirson
Package: snapshot.debian.org Severity: important Advertised "-o Acquire::Check-Valid-Until=false" will impact all sources, and using it just suspends the protection, potentially leaving the user susceptible to attacks. Using "deb [check-valid-until=false]

Bug#570933: dh-buildinfo: should provide a addon file for dh command (debhelper 7 mode)

2016-04-14 Thread ydirson
OK, please do! thx, -- Yann - Mail original - > De: "Daniel Stender" > À: 570...@bugs.debian.org, "Yann Dirson" > Envoyé: Jeudi 14 Avril 2016 13:01:31 > Objet: Re: dh-buildinfo: should provide a addon file for dh command > (debhelper 7 mode) >

Bug#820428: lxc2 still broken

2016-04-21 Thread ydirson
Just hit the same problem. The only solution/workaround mentionned here seems removing from the host two packages that are recommended by lxc, without a pointer to an external bugreport it the problem is not in Debian. I must say I'm quite puzzled. Can someone please give some more info, so

Bug#816501: plantuml failure on deployment diag

2016-04-21 Thread ydirson
Ah, I used plantuml-8038.tar.gz here, tha may explain the difference :) - Mail original - > De: "PlantUML PlantUML" > À: "Andrew Shadura" > Cc: ydir...@free.fr, 816...@bugs.debian.org > Envoyé: Jeudi 21 Avril 2016 11:52:03 > Objet: Re:

Bug#816501: plantuml failure on deployment diag

2016-04-21 Thread ydirson
severity 816501 important thanks Hi Arnaud, Thanks for this quick answer - Mail original - > Your examples work fine with last version of PlantUML: >

Bug#822094: Acknowledgement (plantuml: please add watch file)

2016-04-21 Thread ydirson
In fact my first version matches an unwanted source, this one should be used instead: version=4 http://sf.net/plantuml/ plantuml-([\d.]+)\.tar\.gz debian

Bug#822092: plantuml: debian/copyright lacks source info

2016-04-21 Thread ydirson
Source: plantuml Version: 8024-2 Adding the source URL to the copyright file would help navigation in the PTS. BTW, Upstream-name is redundant when it is the same as the debian package name.

Bug#822092: Acknowledgement (plantuml: debian/copyright lacks source info)

2016-04-21 Thread ydirson
Also, upstream email and other fields could be filled - Mail original - > De: "Debian Bug Tracking System" > À: ydir...@free.fr > Envoyé: Jeudi 21 Avril 2016 10:15:05 > Objet: Bug#822092: Acknowledgement (plantuml: debian/copyright lacks source > info) > > Thank

Bug#822094: plantuml: please add watch file

2016-04-21 Thread ydirson
Package: plantuml Version: 8024-2 Tags: patch Here is a debian/watch so the PTS will be able to warn when a new version is out: version=4 http://sf.net/plantuml/ plantuml-(.+)\.tar\.gz debian

Bug#816501: plantuml failure on deployment diag

2016-04-21 Thread ydirson
I confirm that version 8038 works. Packaging a new version was just trivial :) Andrew, if you don't object, I can NMU the new version together with fixes for the other problems, and setup a collab-maint git repo for easier collaboration. Best regards, Yann - Mail original - > De:

Bug#823748: tar: illegal hardware instruction breaks apt-get upgrade

2016-05-08 Thread ydirson
Would it be related to gcc taking advantage of the drop of i565 support ? https://lists.debian.org/debian-devel-announce/2016/05/msg1.html

Bug#823755: pinpoint: segfaults on example

2016-05-08 Thread ydirson
Package: pinpoint Version: 1:0.1.8-2 Severity: important X-debbugs-CC: pkg-gnome-maintain...@lists.alioth.debian.org Just running "pinpoint /usr/share/doc/pinpoint/examples/introduction.pin" shows the first slide, and if I just wait or hit a key, I get a segfault. The problem may be in the

Bug#832797: sgt-puzzles: missing menu entries

2016-07-28 Thread ydirson
Package: sgt-puzzles Version: 20160429.b31155b-1 At least sgt-undead is not in the /usr/share/menu/ declaration - and since for some reason (too many entries?) lxqt does not list all games from desktop files, the only way to launch it from lxqt seems to be from cmdline.

Bug#825833: libkms

2016-07-15 Thread ydirson
Well, the fact that it's enabled by default upstream, and that at least one very recent piece of software requires it could weight a bit :) - Mail original - > De: "Julien Cristau" > À: ydir...@free.fr, 825...@bugs.debian.org > Cc: 825833-submit...@bugs.debian.org >

Bug#830985: tulip: error while loading shared libraries: libbfd-2.26-system.so

2016-07-16 Thread ydirson
Well, I have never really felt libbfd.so-linking rejection from the project before, as tulip has undergone numerous binNMU's to keep pace with libbfd. Furthermore, the fact that the .so link is installed whenever bfd.h is installed rather calls for linking against the shared lib. If we want to

Bug#830985: tulip: error while loading shared libraries: libbfd-2.26-system.so

2016-07-16 Thread ydirson
- Mail original - > De: "Yuri D'Elia" > À: "Debian Bug Tracking System" > Envoyé: Mercredi 13 Juillet 2016 16:49:40 > Objet: Bug#830985: tulip: error while loading shared libraries: > libbfd-2.26-system.so > > Package: tulip > Version:

Bug#815091: ceph 10.2.x

2016-07-05 Thread ydirson
Looks like 10.2 is the current LTS now :) Best regards, Yann

Bug#525813: apt-file package versions

2016-07-06 Thread ydirson
This feature would really be useful, so we can see at once that a file eg. existed in stable but is not here in testing any more. For this, indication of the source would be quite useful in addition to the version.

Bug#825833: libkms

2016-07-06 Thread ydirson
In fact, it looks like libkms was built in the past, but is explicitely disabled now. There is probably a reason for this, but there is no more information than that in the changelog, and no README.Debian. Could we please have more insight about why this decision was made ? best regards, --

Bug#825833: libkms

2016-07-06 Thread ydirson
- Mail original - > De: "Sven Joachim" > À: ydir...@free.fr > Cc: 825...@bugs.debian.org, 825833-submit...@bugs.debian.org > Envoyé: Mercredi 6 Juillet 2016 19:14:41 > Objet: Re: Bug#825833: libkms > > On 2016-07-06 18:46 +0200, ydir...@free.fr wrote: > > > In fact,

Bug#833630: scalpel: performance decreases with running time

2016-08-07 Thread ydirson
Package: scalpel Version: 1.60-1 Severity: important Running scalpel on a 1TB drive with 100 patterns of 1024 bytes each: * ETA some time after starting stabilized around 11h (as I recall it, but this number is superfluous, the next ones talk loud enough) * after 11h run it has done 63% and the

Bug#632689: scalpel: upstream changed

2016-08-07 Thread ydirson
Looking for 2.0 source, one rapidly notices that the upstream Homepage is not valid any more. Digging a bit: * Fedora seems to have an upstream tarball at http://pkgs.fedoraproject.org/lookaside/pkgs/scalpel/scalpel-2.0.tar.gz/b0da813bf34941e79209d7fafe86a6e6/ *

Bug#833638: foremost: does not completely honor build opts

2016-08-07 Thread ydirson
Package: foremost Version: 1.5.7-5 Tags: patch Only adding flags to the default -O2 will not allow build option "noopt" to work. From faa2c13f600818fc2aac0c293ff55a2935265041 Mon Sep 17 00:00:00 2001 From: Yann Dirson Date: Sun, 7 Aug 2016 13:46:04 +0200 Subject: [PATCH]

Bug#833639: foremost: cryptic/suspicious error message about config parsing and corrupts memory when lines are longer than 1024 bytes

2016-08-07 Thread ydirson
Package: foremost Version: 1.5.7-5 Severity: important When forging a config file with 100 big (1024-bytes) patterns, I get the message "ERROR: In line 2 of the configuration file." That: * does not tell what the problem is * is suspect because there is no reason why line 1 would have worked and

Bug#833642: foremost: hardcoded limit of 50 patterns is not enforced, segfault

2016-08-07 Thread ydirson
Package: foremost Version: 1.5.7-5 Severity: important main.h: s_spec search_spec[50]; /*ARRAY OF BUILTIN SEARCH TYPES*/ Feeding a config with a large number of entries causes a buffer overflow. It segfaults for my large config, but someone with 51 entries could have funny surprises...

Bug#632689: scalpel: upstream changed

2016-08-07 Thread ydirson
Taking a look at the 2.0 source code from the sleuthkit repo, we can see a small issue with that version: It looks like it uses PASCAL-style prefix-length strings to store patterns, which prevents to use patterns larger than 256 bytes. Why on earth not using a struct to keep the size in an

Bug#833649: scalpel: no check for overflow while reading patterns

2016-08-07 Thread ydirson
Package: scalpel Version: 1.60-1 Severity: important Although the buffer used to hold a line is larger than in the original foremost code, it still does not check that the buffer really holds a complete line, and strtok will happily corrupt data outside of the buffer when a line is large enough.

Bug#833630: scalpel: performance decreases with running time

2016-08-08 Thread ydirson
Another test, more closely monitored, with the same set of 100 1024-bytes patterns, carving a 1TB SATA drive, with defines updated to avoid buffer overflows: +--- scalpel-1.60.orig/scalpel.h scalpel-1.60/scalpel.h +@@ -143,11 +143,10 @@ void setProgramName(char *s); + + + #define

Bug#776941: dh-kpatches: please help make builds reproducible

2017-02-19 Thread ydirson
Well, the package is orphaned (although I never did an upload removing my name from the maintainer field, it has a proper WNPP bug). For some reason some people seem to be still using it :) - Mail original - > De: "Chris Lamb" > À: 776...@bugs.debian.org > Envoyé:

Bug#835046: apt-listchanges: complains about InfoFD after upgrade

2016-08-21 Thread ydirson
Package: apt-listchanges Version: 3.3 After an upgrade in aptitude, which notified me of changes in the config file, and for which the config file was properly replaced by the new version, I get the following when I request installation of a new package from the same aptitude session:

Bug#831825: clarification request

2016-08-21 Thread ydirson
severity 831825 important tags 831825 + unreproducible moreinfo reassign 831825 gcompris-qt thanks Let's lower the severity as it seems not to impact all users. Trying to reproduce, I'm puzzled by the description, as gcompris does not have a bottom-left menu, although gompris-qt has one. I'm

Bug#836777: perceptualdiff: does not catch disk-full condition, creates 0-size diffs

2016-09-05 Thread ydirson
Package: perceptualdiff Version: 1.2-2 -output will always create a file, but when the disk is full its size is 0 and we don't get an error message.

Bug#836265: [Aptitude-devel] Bug#836265: aptitude: keeps reselecting sysvinit

2016-09-01 Thread ydirson
- Mail original - > I don't see sysvinit being Essential anymore in unstable: > > → apt-cache show sysvinit | fgrep -i Essential > This package depends on init, which is an essential package that > → > > Any chance that you have stable/jessie in your sources.list, too? Yes: wheezy,

Bug#836265: aptitude: keeps reselecting sysvinit

2016-09-01 Thread ydirson
- Mail original - > De: "Sven Joachim" > À: ydir...@free.fr > Cc: "Axel Beckert" , 836...@bugs.debian.org > Envoyé: Jeudi 1 Septembre 2016 12:24:59 > Objet: Re: Bug#836265: aptitude: keeps reselecting sysvinit > > On 2016-09-01 11:58 +0200,

Bug#836265: [Aptitude-devel] Bug#836265: aptitude: keeps reselecting sysvinit

2016-09-01 Thread ydirson
- Mail original - > De: "David Kalnischkies" > À: ydir...@free.fr, 836...@bugs.debian.org > Envoyé: Jeudi 1 Septembre 2016 16:20:55 > Objet: Re: [Aptitude-devel] Bug#836265: aptitude: keeps reselecting sysvinit > > On Thu, Sep 01, 2016 at 02:10:14PM +0200,

Bug#836068: tightvnc: version 1.3.10

2016-08-30 Thread ydirson
Package: tightvnc Version: 1.3.9-8 Severity: wishlist Although develelopment seems to have stopped in this software, the latest version on http://www.tightvnc.com/download-old.php is more recent than ours.

Bug#841765: enet: new version available

2016-10-23 Thread ydirson
Package: enet Version: 1.3.12+ds-2 1.3.13 was apparently released some time ago. http://enet.bespin.org/download/

Bug#844296: libstdc++6-7-dbg: undeclared common file with libstdc++6-6-dbg

2016-11-14 Thread ydirson
Package: libstdc++6-7-dbg Version: 7-20161112-1 Unpacking libstdc++6-7-dbg:amd64 (7-20161112-1) ... dpkg: error processing archive /tmp/apt-dpkg-install-K00oDb/18-libstdc++6-7-dbg_7-20161112-1_amd64.deb (--unpack): trying to overwrite '/usr/lib/x86_64-linux-gnu/debug/libstdc++.a', which is

Bug#834790: aptitude hangs at "Loading cache" when unable to download package list

2016-11-04 Thread ydirson
Just hit the same problem after adding a valid sources.list entry without having imported the repo signing key, and I can confirm it'the behaviour is really awkward - and reading suggestions that letting the user lose time until he figures out he has to restarti aptitude would be a valid way out

Bug#833741: patch/nmu ?

2016-11-04 Thread ydirson
tags 833741 + patch thanks Is there any reason not to apply that patch ?

Bug#847996: edid-decode: wrongly interprets 13-byte strings as non-conforming

2016-12-12 Thread ydirson
Package: edid-decode Version: 0.1~git20140128.afcf2a2e-1 The spec states that only when the "Alphanumeric Data String Descriptor Definition" is less than 13 bytes, should it be followed by 0x0A and further padded with 0x20. Thus, a 13-byte string without a 0x0A is valid, but edid-decode rejects

Bug#833741: Patch updated for 1.8.3

2017-01-14 Thread ydirson
Updated Bob's patch, which was against 1.8.1, to 1.8.3. This fixes both RC bugs, uploading a NMU hoping it's not too late... diff --git a/debian/changelog b/debian/changelog index e94d50a..965efd3 100644 --- a/debian/changelog +++ b/debian/changelog @@ -1,3 +1,17 @@ +pepperflashplugin-nonfree

Bug#849856: input-utils: outdated upstream URL, new upstream release

2017-01-01 Thread ydirson
Package: input-utils Version: 1.0-1.1 Contents behind upstream URL in copyright in watch files is apparently a set of CVS snapshot not updated any more. There is a 1.2 release at https://www.kraxel.org/releases/input/ Homepage at https://www.kraxel.org/blog/linux/input/

Bug#848668: emacs25: please include .desktop file for emacsclient

2016-12-19 Thread ydirson
Package: emacs25 Severity: wishlist Tags: patch Today eg. firefox proposes to open a text file in emacs, but since it only finds apps through desktop files, it won't propose emacsclient. Attached the one I'm using now, quickly modified from emacs25.desktop emacsclient25.desktop Description:

Bug#849072: lightdm: add-seat badly documented, apparently deprecated

2016-12-22 Thread ydirson
Package: lightdm Version: 1.18.2-2 While "dm-tool add-nested-seat" does work, it is not suitable for all uses, and "dm-tool add-seat" looks like the way to launch a real new X session. However: * manpage mentions the syntax is "dm-tool add-seat TYPE" without giving any clue as to what TYPE

Bug#859147: network-manager: restart failure on upgrade

2017-03-30 Thread ydirson
Package: network-manager Version: 1.6.2-3 When upgrading from 1.6.2-2: Setting up network-manager (1.6.2-3) ... Job for NetworkManager.service failed because a timeout was exceeded. See "systemctl status NetworkManager.service" and "journalctl -xe" for details. invoke-rc.d: initscript

Bug#859147: [Pkg-utopia-maintainers] Bug#859147: network-manager: restart failure on upgrade

2017-03-31 Thread ydirson
Here is the relevant journalctl -alb excerpt, sending more details in private mail Mar 30 20:22:06 yantop systemd[1]: Stopping Network Manager Wait Online... Mar 30 20:22:06 yantop systemd[1]: Stopping Network Manager... Mar 30 20:22:06 yantop NetworkManager[4948]: [1490898126.5839] caught

  1   2   >