Bug#712841: A bit late, but still an issue...

2018-04-23 Thread Martin Michlmayr
* Axel Sommerfeldt [2018-04-22 12:01]: > And after setting "has_fan" to "false": Ok, thanks for testing! I hope Ian can apply this upstream and release a new Debian package. It probably makes sense to update debian/NEWS (see proposed patch in the attachment).

Bug#712841: A bit late, but still an issue...

2018-04-22 Thread Axel Sommerfeldt
On Thu, Apr 19, 2018, at 12:47, Martin Michlmayr wrote: > * Axel Sommerfeldt [2018-04-16 21:25]: > Based on Ian's comments, I added a has_fan to the configuration file. > I believe the attached patch should do the trick. > > Axel, can you test this (after restoring the

Bug#712841: A bit late, but still an issue...

2018-04-19 Thread Martin Michlmayr
* Axel Sommerfeldt [2018-04-16 21:25]: > 1) Done > 2) "qcontrol fanspeed stop" makes the beeping stop Thanks for confirming this! > Creating /etc/qcontrol.d/90-no-fan.conf with the content above makes the > beeping stop, too. Great! Based on Ian's comments, I added a

Bug#712841: A bit late, but still an issue...

2018-04-16 Thread Axel Sommerfeldt
On Mon, Apr 16, 2018, at 20:12, Martin Michlmayr wrote: > Axel, can you restore the original config and 1) see if you get the beeps > and 2) whether running > > qcontrol fanspeed stop > > makes them stop. (change setfan in the config to do nothing, otherwise > the fan will be turned on

Bug#712841: A bit late, but still an issue...

2018-04-16 Thread Martin Michlmayr
* Ian Campbell [2018-04-15 15:33]: > > Ian, do you think it's worth asking the release team if they'd allow > > an update for this in stable? > > I think it is premature to consider that question without a specific > fix in unstable to be backported in order to make the

Bug#712841: A bit late, but still an issue...

2018-04-16 Thread Ian Campbell
On Mon, 2018-04-16 at 20:12 +0200, Martin Michlmayr wrote: > Do you know if /etc/default is Debian-specific or generic? I'm just > wondering if the qcontrol configs should read from /etc/default/qcontrol > (Google suggests Red Hat and SUSE have it too, so I guess that should > be ok.) They have

Bug#712841: A bit late, but still an issue...

2018-04-16 Thread Martin Michlmayr
* Martin Michlmayr [2018-04-16 20:12]: > As a workaround, until this is fixed, users can create a file > /etc/qcontrol.d/90_no_fan with: It needs a .conf extension, so e.g. /etc/qcontrol.d/90-no-fan.conf -- Martin Michlmayr http://www.cyrius.com/

Bug#712841: A bit late, but still an issue...

2018-04-15 Thread Ian Campbell
On Sun, 2018-04-15 at 15:33 +0100, Ian Campbell wrote: > That said, if there are modifications which can be made to the existing > config file installed on this variant which would minimise the > modifications i.e. by adding a simple "has_a_fan = true" which affected > people can set to false then

Bug#712841: A bit late, but still an issue...

2018-04-15 Thread Martin Michlmayr
* Axel Sommerfeldt [2018-04-14 22:07]: > Just a reminder that this bug is still a thing. And yes, the model can be > found in uLinux.conf: Ian, do you think it's worth asking the release team if they'd allow an update for this in stable? Since stretch is likely to be

Bug#712841: A bit late, but still an issue...

2018-04-15 Thread Ian Campbell
On Sun, 2018-04-15 at 16:03 +0200, Martin Michlmayr wrote: > * Axel Sommerfeldt [2018-04-14 22:07]: > > Just a reminder that this bug is still a thing. And yes, the model > can be found in uLinux.conf: > > Ian, do you think it's worth asking the release team if they'd

Bug#712841: A bit late, but still an issue...

2018-04-14 Thread Axel Sommerfeldt
Just a reminder that this bug is still a thing. And yes, the model can be found in uLinux.conf: root@qnap119:~# mount -o ro -t ext2 /dev/mtdblock5 /mnt root@qnap119:~# more /mnt/uLinux.conf [System] Model = TS-119 Internal Model = TS-119 ... BTW: Martin, thanks a lot for all the work. Having

Bug#712841: A bit late, but still an issue...

2016-05-10 Thread Martin Michlmayr
* Christian Mueller [2016-05-10 18:57]: > That would be great. You mean customise.conf, correct? Anything I can do to > help? No, I meant uLinux.conf. There should be a [System] stanza with information such as Model = TS-219 Internal Model = TS-219 -- Martin Michlmayr

Bug#712841: A bit late, but still an issue...

2016-05-10 Thread Christian Mueller
That would be great. You mean customise.conf, correct? Anything I can do to help? Thanks, --Christian P.S.: Thanks for all the effort you put into this - I'm using Debian on ARM devices for my mail/DNS/VPN/... server(s) since the old NSLU2 days and it all started on on cyrius.com :) On

Bug#712841: A bit late, but still an issue...

2016-05-05 Thread Martin Michlmayr
* Christian Mueller [2016-04-29 22:20]: > Long story cut short: if there is a way to identify TS-119 vs. TS-219 > hardware, a fix would be very welcome. There's a configuration file on /dev/mtdblock5 which contains the device type. I'm starting to think the easiest solution

Bug#712841: A bit late, but still an issue...

2016-04-29 Thread Christian Mueller
Hi all, I've just upgraded my trusty and apparently indestructable TS-119 to Jessie and stumbled over this bug. I've simply commented-out the line that increases the fan error count and the beeping has stopped but I see log entries which show qcontrol trying to set fan speeds due to