Bug#782336: okular: Cannot print from okular

2024-05-24 Thread Leo L. Schwab
Package: okular
Version: 4:23.08.1-2+b1
Followup-For: Bug #782336

Dear Maintainer,

I'm observing the same behavior.  In my specific case, I was
trying to print a range of pages from a PDF.  Instead, an `lpr` usage
message appeared on the terminal:

```
usage: lpr [-cdfghlmnpqrstv] [-#num] [-1234 font] [-C class] [-i [numcols]]
[-J job] [-Pprinter] [-T title] [-U user] [-wnum] [name ...]
```

`okular` itself reports no error or any other indication that
the print operation failed.

It's not listed in the dependencies below, but I also have
installed:
* cups v2.4.7-1.1+b1
* lpr 1:2008.05.17.3+nmu2

Schwab

-- System Information:
Debian Release: trixie/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'testing'), (500, 'stable')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 6.7.12-amd64 (SMP w/4 CPU threads; PREEMPT)
Kernel taint flags: TAINT_WARN, TAINT_FIRMWARE_WORKAROUND
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8), LANGUAGE not set
Shell: /bin/sh linked to /usr/bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Versions of packages okular depends on:
ii  kinit   5.115.0-2
ii  kio 5.115.0-6
ii  libc6   2.38-11
ii  libfreetype62.13.2+dfsg-1+b4
ii  libjpeg62-turbo 1:2.1.5-3
ii  libkf5activities5   5.115.0-3
ii  libkf5archive5  5.115.0-2
ii  libkf5bookmarks55.115.0-2
ii  libkf5codecs5   5.115.0-2
ii  libkf5completion5   5.115.0-2
ii  libkf5configcore5   5.115.0-2
ii  libkf5configgui55.115.0-2
ii  libkf5configwidgets55.115.0-2
ii  libkf5coreaddons5   5.115.0-2
ii  libkf5crash55.115.0-2
ii  libkf5i18n5 5.115.1-2
ii  libkf5itemviews55.115.0-2
ii  libkf5jobwidgets5   5.115.0-2
ii  libkf5kexiv2-15.0.0 23.04.2-2+b1
ii  libkf5kiocore5  5.115.0-6
ii  libkf5kiogui5   5.115.0-6
ii  libkf5kiowidgets5   5.115.0-6
ii  libkf5parts55.115.0-2
ii  libkf5pty5  5.115.0-2
ii  libkf5purpose-bin   5.115.0-2
ii  libkf5purpose5  5.115.0-2
ii  libkf5textwidgets5  5.115.0-2
ii  libkf5wallet-bin5.115.0-2
ii  libkf5wallet5   5.115.0-2
ii  libkf5widgetsaddons55.115.0-2
ii  libkf5windowsystem5 5.115.0-2
ii  libkf5xmlgui5   5.115.0-2
ii  libokular5core114:23.08.1-2+b1
ii  libphonon4qt5-4t64  4:4.12.0-3.1+b1
ii  libpoppler-qt5-1t64 24.02.0-5
ii  libqmobipocket2 4:22.12.3-1+b2
ii  libqt5core5t64  5.15.10+dfsg-7.2+b1
ii  libqt5dbus5t64  5.15.10+dfsg-7.2+b1
ii  libqt5gui5t64   5.15.10+dfsg-7.2+b1
ii  libqt5printsupport5t64  5.15.10+dfsg-7.2+b1
ii  libqt5texttospeech5 5.15.10-2+b2
ii  libqt5widgets5t64   5.15.10+dfsg-7.2+b1
ii  libqt5x11extras55.15.10-2+b2
ii  libqt5xml5t64   5.15.10+dfsg-7.2+b1
ii  libspectre1 0.2.12-1+b1
ii  libstdc++6  14.1.0-1
ii  phonon4qt5  4:4.12.0-3.1+b1
ii  zlib1g  1:1.3.dfsg+really1.3.1-1

Versions of packages okular recommends:
pn  cups-bsd  

Versions of packages okular suggests:
ii  ghostscript10.03.1~dfsg~git20240518-1
pn  okular-extra-backends  
ii  poppler-data   0.4.12-1
ii  texlive-binaries   2023.20230311.66589-9+b2
ii  unrar  1:7.0.9-1

-- no debconf information



Bug#782336: okular: Cannot print from okular

2016-12-26 Thread Maximiliano Curia

¬°Hola Moritz!

El 2016-12-22 a las 18:20 +0100, Moritz Strohm escribió:
Package: okular 
Version: 4:4.14.2-2 
Followup-For: Bug #782336


I have the same issue. When I start Okular from the shell, opened a PDF 
and selected print. On the shell I got the following output:



okular(4712)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
okular(4712)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
okular(4712)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
okular(4712)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
okular(4712)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
Object::connect: No such signal org::freedesktop::UPower::DeviceAdded(QString) 
Object::connect: No such signal 
org::freedesktop::UPower::DeviceRemoved(QString) 
okular(4712) BackendLoader::init: "/usr/lib/x86_64-linux-gnu/kde4/plugins" 
This backend is only for XRandR 1.1, your version is:  1 . 4 
usage: lpr [-cdfghlmnpqrstv] [-#num] [-1234 font] [-C class] [-i [numcols]]

   [-J job] [-Pprinter] [-T title] [-U user] [-wnum] [name ...]



It seems that Okular doesn't call lpr correctly.


This is a known issue, okular expects the cups' lpr command, later versions add 
a recommends cups-bsd. Given the other printing issues in okular I would 
suggest the use of qpdfviewer for printing.


Happy hacking,
--
A computer scientist is someone who, when told to "Go to Hell,"
sees the "go to," rather than the destination, as harmful.
Saludos /\/\ /\ >< `/


signature.asc
Description: PGP signature


Bug#782336: okular: Cannot print from okular

2016-12-22 Thread Moritz Strohm
Package: okular
Version: 4:4.14.2-2
Followup-For: Bug #782336

I have the same issue. When I start Okular from the shell, opened a PDF
and selected print. On the shell I got the following output:

okular(4712)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
okular(4712)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
okular(4712)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
okular(4712)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
okular(4712)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
Object::connect: No such signal org::freedesktop::UPower::DeviceAdded(QString)
Object::connect: No such signal
org::freedesktop::UPower::DeviceRemoved(QString)
okular(4712) BackendLoader::init: "/usr/lib/x86_64-linux-gnu/kde4/plugins"
This backend is only for XRandR 1.1, your version is:  1 . 4
usage: lpr [-cdfghlmnpqrstv] [-#num] [-1234 font] [-C class] [-i [numcols]]
[-J job] [-Pprinter] [-T title] [-U user] [-wnum] [name ...]


It seems that Okular doesn't call lpr correctly.



-- System Information:
Debian Release: 8.6
  APT prefers stable
  APT policy: (500, 'stable'), (500, 'oldstable')
Architecture: amd64 (x86_64)

Kernel: Linux 3.16.0-4-amd64 (SMP w/2 CPU cores)
Locale: LANG=de_DE.utf8, LC_CTYPE=de_DE.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages okular depends on:
ii  kde-runtime 4:4.14.2-2
ii  libc6   2.19-18+deb8u6
ii  libfreetype62.5.2-3+deb8u1
ii  libjpeg62-turbo 1:1.3.1-12
ii  libkactivities6 4:4.13.3-1
ii  libkdecore5 4:4.14.2-5+deb8u1
ii  libkdeui5   4:4.14.2-5+deb8u1
ii  libkexiv2-114:4.14.2-1
ii  libkio5 4:4.14.2-5+deb8u1
ii  libkparts4  4:4.14.2-5+deb8u1
ii  libkprintutils4 4:4.14.2-5+deb8u1
ii  libkpty44:4.14.2-5+deb8u1
ii  libokularcore5  4:4.14.2-2
ii  libphonon4  4:4.8.0-4
ii  libpoppler-qt4-40.26.5-2+deb8u1
ii  libqca2 2.0.3-6
ii  libqimageblitz4 1:0.0.6-4
ii  libqmobipocket1 4:4.14.2-1
ii  libqt4-dbus 4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1
ii  libqt4-declarative  4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1
ii  libqt4-svg  4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1
ii  libqt4-xml  4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1
ii  libqtcore4  4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1
ii  libqtgui4   4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1
ii  libsolid4   4:4.14.2-5+deb8u1
ii  libspectre1 0.2.7-3
ii  libstdc++6  4.9.2-10
ii  phonon  4:4.8.0-4
ii  zlib1g  1:1.2.8.dfsg-2+b1

okular recommends no packages.

Versions of packages okular suggests:
ii  ghostscript9.06~dfsg-2+deb8u4
pn  jovie  
pn  okular-extra-backends  
ii  poppler-data   0.4.7-1
pn  texlive-binaries   
pn  unrar  

-- no debconf information