Bug#944912: libgit-raw-perl: FBTFS: ./xs/Indexer.xs:14:8: error: too many arguments to function ‘git_indexer_new’

2019-11-17 Thread Aurelien Jarno
Source: libgit-raw-perl Version: 0.79-6+b2 Severity: serious Tags: ftbfs Justification: fails to build from source (but built successfully in the past) libgit-raw-perl fails to build from source: | x86_64-linux-gnu-gcc -c -I. -D_REENTRANT -D_GNU_SOURCE -DDEBIAN -fwrapv -fno-strict-aliasing

Bug#944911: libfiu: FBTFS: Found too many matching python3 bindings

2019-11-17 Thread Aurelien Jarno
Source: libfiu Version: 1.00-3+b1 Severity: serious Tags: ftbfs Justification: fails to build from source (but built successfully in the past) libfiu fails to build from source: | ./wrap-python 3 ./test-manyfps.py | Found too many matching python3 bindingsmake[3]: *** [Makefile:96:

Bug#942634: apt-cacher-ng: fails to work on debian/sid suite (too small BUFSIZEMAX)

2019-10-19 Thread Aurelien Jarno
Package: apt-cacher-ng Version: 3.2-2 Severity: grave Justification: renders package unusable Dear maintainer, apt-cacher-ng stopped working recently when used to cache the debian/sid suite. It reports the following error: | An error occurred while reading this file, some contents may have been

Bug#942565: cross-toolchain-base-mipsen_8_all.changes REJECTED

2019-10-18 Thread Aurelien Jarno
gt; === > > Please feel free to respond to this email if you don't understand why > your files were rejected, or if you upload new files which address our > concerns. > The Built-Using is wrongly using the binary version, the source version (in that case 5.2.17-1) shou

Bug#941845: postgresql-11_11.5-2+b2_s390x.changes REJECTED

2019-10-06 Thread Aurelien Jarno
oads to unstable must have a higher version than present in unstable. > > Mapping sid to unstable. > > === > > Please feel free to respond to this email if you don't understand why > your files were rejected, or if you upload new files which address ou

Bug#940703: [Debian-med-packaging] Bug#940703: augustus_3.3.3+dfsg-1_mips64el.changes REJECTED

2019-09-20 Thread Aurelien Jarno
On 2019-09-19 22:56, Sascha Steinbiss wrote: > > > > On 19. Sep 2019, at 11:29, Aurelien Jarno wrote: > > > > Package: augustus > > Version: 3.3.3+dfsg-1 > > Severity: serious > > > > On 2019-09-18 23:34, Debian FTP Masters wrote: > >&g

Bug#940703: augustus_3.3.3+dfsg-1_mips64el.changes REJECTED

2019-09-19 Thread Aurelien Jarno
Package: augustus Version: 3.3.3+dfsg-1 Severity: serious On 2019-09-18 23:34, Debian FTP Masters wrote: > augustus_3.3.3+dfsg-1_mips64el.deb: Built-Using refers to non-existing source > package libbam-dev (= 0.1.19-4) > > > Mapping sid to unstable. > > === > > Please feel free to respond to

Bug#940228: binutils-mipsen: FTBFS following the upload of binutils 2.32.51.20190909-1

2019-09-14 Thread Aurelien Jarno
l cross from binutils 2.32.51.20190909-1. + + -- Aurelien Jarno Sat, 14 Sep 2019 10:42:48 +0200 + binutils-mipsen (4~c3) unstable; urgency=medium * Build using binutils 2.32.51.20190821-2. diff -Nru binutils-mipsen-4~c3/debian/control binutils-mipsen-4~c3.1/debian/control --- binutils-mipsen

Bug#939899: [ftpmas...@ftp-master.debian.org: apitrace_8.0+repack-1_amd64.changes REJECTED]

2019-09-12 Thread Aurelien Jarno
snappy (= 1.1.7-1+b1) Mapping sid to unstable. === Please feel free to respond to this email if you don't understand why your files were rejected, or if you upload new files which address our concerns. - End forwarded message - -- Aurelien Jarno GPG: 4096R

Bug#940031: gnucash-docs_3.7-1_all.changes REJECTED

2019-09-11 Thread Aurelien Jarno
t; Please feel free to respond to this email if you don't understand why > your files were rejected, or if you upload new files which address our > concerns. > Built-Using should use the source package name (i.e. fonts-freefont) and not the binary package name. -- Aurelien Jarno

Bug#939899: apitrace_7.1+git20170623.d38a69d6+repack-3+b4_mipsel.changes REJECTED

2019-09-09 Thread Aurelien Jarno
gt; Mapping sid to unstable. > > === > > Please feel free to respond to this email if you don't understand why > your files were rejected, or if you upload new files which address our > concerns. > The Built-Using field should use the source version, not

Bug#939308: gkrellm2-cpufreq_0.6.4-5_mips64el.changes REJECTED

2019-09-03 Thread Aurelien Jarno
On 2019-09-03 09:25, John Paul Adrian Glaubitz wrote: > Hello Aurelien! > > On 9/3/19 9:19 AM, Aurelien Jarno wrote: > > Package: gkrellm2-cpufreq > > Version: 0.6.4-5 > > Severity: serious > > > > On 2019-09-02 23:19, Debian FTP Masters wrote: > >&g

Bug#939308: gkrellm2-cpufreq_0.6.4-5_mips64el.changes REJECTED

2019-09-03 Thread Aurelien Jarno
Package: gkrellm2-cpufreq Version: 0.6.4-5 Severity: serious On 2019-09-02 23:19, Debian FTP Masters wrote: > gkrellm-cpufreq_0.6.4-5_mips64el.deb: Missing mandatory field > gkrellm-cpufreq_0.6.4-5_mips64el.deb. > > > > === > > Please feel free to respond to this email if you don't

Bug#939016: rust-debcargo_2.4.0-1_mipsel.changes REJECTED

2019-08-31 Thread Aurelien Jarno
Please feel free to respond to this email if you don't understand why > your files were rejected, or if you upload new files which address our > concerns. > > The Built-Using field is not correct, it should point to the version of the source package, not the bina

Bug#935938: android-sdk-meta_25.0.0+11~deb10u1_all.changes REJECTED

2019-08-28 Thread Aurelien Jarno
hat are built are in version 25.0.0+11, hence the reject. See the build log: https://buildd.debian.org/status/fetch.php?pkg=android-sdk-meta=all=25.0.0%2B11%7Edeb10u1=1566961497=0 -- Aurelien Jarno GPG: 4096R/1DDD8C9B aurel...@aurel32.net http://www.aurel32.net

Bug#926699: libc6-{i386,x32}: installing, removing, reinstalling in a --merged-usr system results in unmerged /lib{32,x32}

2019-08-19 Thread Aurelien Jarno
4,o32,x32} directories, at least until the state stays as "weak". I would be happy if you could also work on your side to provide alternative solutions. Regards, Aurelien -- Aurelien Jarno GPG: 4096R/1DDD8C9B aurel...@aurel32.net http:/

Bug#926699: libc6-{i386,x32}: installing, removing, reinstalling in a --merged-usr system results in unmerged /lib{32,x32}

2019-08-17 Thread Aurelien Jarno
On 2019-08-17 23:00, Marco d'Itri wrote: > On Aug 17, Aurelien Jarno wrote: > > > One package should be responsible for providing those links so that > > glibc is not the last package using them. The same way that base-files > > ensure that some directories are present. &

Bug#926699: libc6-{i386,x32}: installing, removing, reinstalling in a --merged-usr system results in unmerged /lib{32,x32}

2019-08-17 Thread Aurelien Jarno
On 2019-08-17 22:20, Marco d'Itri wrote: > On Aug 17, Aurelien Jarno wrote: > > > > > The preinst scripts could check whether the package is being installed > > > > in a --merged-usr environment and create (dangling) symlinks if > > > > /usr/lib{3

Bug#926699: libc6-{i386,x32}: installing, removing, reinstalling in a --merged-usr system results in unmerged /lib{32,x32}

2019-08-17 Thread Aurelien Jarno
reassign -1 debootstrap,usrmerge thanks On 2019-04-09 16:53, Aurelien Jarno wrote: > On 2019-04-09 12:27, Andreas Beckmann wrote: > > Package: libc6-x32,libc6-i386 > > Version: 2.28-8 > > Severity: serious > > User: debian...@lists.debian.org > > Usertags: piup

Bug#934316: FTBFS: source-af-packet.c:646:28: error: ‘SIOCGSTAMP’ undeclared

2019-08-09 Thread Aurelien Jarno
Source: suricata Version: 1:4.1.4-4 Severity: serious Tags: patch upstream ftbfs Justification: fails to build from source (but built successfully in the past) suricata fails to build with recent kernel versions: | gcc -DHAVE_CONFIG_H -I. -I.. -Wdate-time -D_FORTIFY_SOURCE=2

Bug#934307: rust-regex_1.2.1-1_s390x.changes REJECTED

2019-08-09 Thread Aurelien Jarno
Package: rust-regex Version: 1.2.1-1 Severity: serious On 2019-08-09 12:10, Debian FTP Masters wrote: > > > librust-regex-dev_1.2.1-1_s390x.deb: has 1 file(s) with a timestamp too far > in the past: > usr/share/cargo/registry/regex-1.2.1/Cargo.lock (Thu Jan 1 00:00:00 1970) > > > > === >

Bug#932678: glib2.0: tests timeout on i386 and mips

2019-07-27 Thread Aurelien Jarno
ore blacklisted glib2.0 from the slowest buildds. Aurelien -- Aurelien Jarno GPG: 4096R/1DDD8C9B aurel...@aurel32.net http://www.aurel32.net

Bug#933205: haskell-patience_0.2.1.1-1_all.changes REJECTED

2019-07-27 Thread Aurelien Jarno
Source: haskell-patience Version: 0.2.1.1-1 Severity: serious On 2019-07-27 14:42, Debian FTP Masters wrote: > libghc-patience-doc_0.2.1.1-1_all.deb: has 1 file(s) with a timestamp too far > in the past: > usr/share/doc/libghc-patience-doc/changelog.gz (Thu Jan 1 00:00:00 1970) > > > > ===

Bug#933204: haskell-cgi_3001.3.0.3-1_s390x.changes REJECTED

2019-07-27 Thread Aurelien Jarno
Source: haskell-cgi Version: 3001.3.0.3-1 Severity: serious On 2019-07-27 14:40, Debian FTP Masters wrote: > > > libghc-cgi-dev_3001.3.0.3-1_s390x.deb: has 1 file(s) with a timestamp too far > in the past: > usr/share/doc/libghc-cgi-dev/changelog.gz (Thu Jan 1 00:00:00 1970) > > > > ===

Bug#933166: haskell-base64-bytestring_1.0.0.2-1_mipsel.changes REJECTED

2019-07-27 Thread Aurelien Jarno
Source: haskell-base64-bytestring Version: 1.0.0.2-1 Severity: serious On 2019-07-27 06:07, Debian FTP Masters wrote: > libghc-base64-bytestring-prof_1.0.0.2-1_mipsel.deb: has 1 file(s) with a > timestamp too far in the past: > usr/share/doc/libghc-base64-bytestring-prof/changelog.gz (Thu Jan

Bug#933164: haskell-aeson_1.4.2.0-1_mipsel.changes REJECTED

2019-07-27 Thread Aurelien Jarno
0:00 1970) > > > > === > > Please feel free to respond to this email if you don't understand why > your files were rejected, or if you upload new files which address our > concerns. > > > -- Aurelien Jarno GPG: 4096R/1DDD8C9B aurel...@aurel32.net http://www.aurel32.net

Bug#933165: haskell-brick_0.46-1_s390x.changes REJECTED

2019-07-27 Thread Aurelien Jarno
Source: haskell-brick Version: 0.46-1 Severity: serious On 2019-07-27 05:07, Debian FTP Masters wrote: > > > libghc-brick-dev_0.46-1_s390x.deb: has 1 file(s) with a timestamp too far in > the past: > usr/share/doc/libghc-brick-dev/changelog.gz (Thu Jan 1 00:00:00 1970) > > > > === > >

Bug#933010: haskell-quickcheck_2.12.6.1-1_s390x.changes REJECTED

2019-07-25 Thread Aurelien Jarno
Source: haskell-quickcheck Version: 2.12.6.1-1 Severity: serious On 2019-07-25 17:34, Debian FTP Masters wrote: > > > libghc-quickcheck2-prof_2.12.6.1-1_s390x.deb: has 2 file(s) with a timestamp > too far in the past: > usr/share/doc/libghc-quickcheck2-prof/changelog.gz (Thu Jan 1 00:00:00

Bug#932917: libleveldb1d: does not contain any library, only a dead symlink

2019-07-24 Thread Aurelien Jarno
Package: libleveldb1d Version: 1.22-1 Severity: grave Justification: renders package unusable libleveldb1d version 1.22-1 does not contain any library, only a dead symlink as it can be seen by looking at the content of the package: | $ dpkg -c libleveldb1d_1.22-1_amd64.deb | drwxr-xr-x root/root

Bug#927825: arm: mvneta driver used on Armada XP GP boards does not receive packets (regression from 4.9)

2019-05-01 Thread Aurelien Jarno
Hi, On 2019-05-01 00:04, Aurelien Jarno wrote: > On 2019-04-30 10:12, Uwe Kleine-König wrote: > > > > More precisely the board is a "Marvell Armada XP Development Board > > > > DB-MV784MP-GP" > > > > > > > > > anymore. Using tcp

Bug#927825: arm: mvneta driver used on Armada XP GP boards does not receive packets (regression from 4.9)

2019-04-30 Thread Aurelien Jarno
On 2019-04-30 10:12, Uwe Kleine-König wrote: > [Adding the mvebu guys and netdev to Cc] > > Hello, > > On Thu, Apr 25, 2019 at 09:17:32PM +0200, Aurelien Jarno wrote: > > On 2019-04-25 14:50, Aurelien Jarno wrote: > > > On 2019-04-23 22:16, Aurelien Jarn

Bug#927825: arm: mvneta driver used on Armada XP GP boards does not receive packets (regression from 4.9)

2019-04-25 Thread Aurelien Jarno
On 2019-04-25 14:50, Aurelien Jarno wrote: > On 2019-04-23 22:16, Aurelien Jarno wrote: > > Source: linux > > Version: 4.19.28-2 > > Severity: important > > > > After upgrading hartmann.debian.org (an armhf buildd using an Armada XP > > GP board) from

Bug#927825: arm: mvneta driver used on Armada XP GP boards does not receive packets (regression from 4.9)

2019-04-25 Thread Aurelien Jarno
On 2019-04-23 22:16, Aurelien Jarno wrote: > Source: linux > Version: 4.19.28-2 > Severity: important > > After upgrading hartmann.debian.org (an armhf buildd using an Armada XP > GP board) from buster to stretch, the ethernet device is not working More precisely the board is

Bug#926699: libc6-{i386,x32}: installing, removing, reinstalling in a --merged-usr system results in unmerged /lib{32,x32}

2019-04-09 Thread Aurelien Jarno
symlinks to be removed, so I wonder if we need a usrmerge version of it. -- Aurelien Jarno GPG: 4096R/1DDD8C9B aurel...@aurel32.net http://www.aurel32.net signature.asc Description: PGP signature

Bug#903514: Deadlock in _dl_close join-ing threads accessing TLS (was Re: gimp won't launch)

2019-03-31 Thread Aurelien Jarno
that can be forwarded upstream. It's not an easy task though. -- Aurelien Jarno GPG: 4096R/1DDD8C9B aurel...@aurel32.net http://www.aurel32.net signature.asc Description: PGP signature

Bug#924891: glibc: FTBFS: /<>/build-tree/amd64-libc/conform/UNIX98/ndbm.h/scratch/ndbm.h-test.c:1:10: fatal error: ndbm.h: No such file or directory

2019-03-28 Thread Aurelien Jarno
between the following debian packages: - linux-image-4.10.0-rc6-amd64-unsigned version 4.10~rc6-1~exp1 - linux-image-4.10.0-trunk-amd64-unsigned version 4.10-1~exp1 I gave a quick look at the commit logs, and I haven't identified a commit. I'll look again and try to identify the commit fixing the issue so that it can be backported in the stretch kernel. I'll then reassign the bug there. Regards, Aurelien -- Aurelien Jarno GPG: 4096R/1DDD8C9B aurel...@aurel32.net http://www.aurel32.net

Bug#924891: glibc: FTBFS: /<>/build-tree/amd64-libc/conform/UNIX98/ndbm.h/scratch/ndbm.h-test.c:1:10: fatal error: ndbm.h: No such file or directory

2019-03-26 Thread Aurelien Jarno
you have some more details about the issue? Is it a glibc or a kernel problem? If we can't fix the issue easily on the libc side, I guess the way to fix that is to XFAIL that test on 32-bit x86. -- Aurelien Jarno GPG: 4096R/1DDD8C9B aurel...@aurel32.net http://www.aurel32.net

Bug#918823: Update on your bug report

2019-02-16 Thread Aurelien Jarno
tell it here. Aurelien -- Aurelien Jarno GPG: 4096R/1DDD8C9B aurel...@aurel32.net http://www.aurel32.net

Bug#921296: ccfits: FTBFS with upcoming doxygen 1.8.15

2019-02-10 Thread Aurelien Jarno
On 2019-02-04 10:53, Aurelien Jarno wrote: > On 2019-02-04 01:04, Paolo Greppi wrote: > > Source: ccfits > > Severity: serious > > > > Dear Maintainer, > > > > I tested your package against a draft package for doxygen 1.8.15: > > https:/

Bug#921296: ccfits: FTBFS with upcoming doxygen 1.8.15

2019-02-04 Thread Aurelien Jarno
s for all LaTeX packages required | to build documents using the default stylesheet. ccfits doesn't do anything fancy, it just generates the latex file using doxygen and then run pdflatex on it. If a dependency is missing for that, it should be added to doxygen-latex. Aurelien -- Aurelien J

Bug#919049: posix-cpu-timers: Unbreak timer rearming (regression)

2019-01-12 Thread Aurelien Jarno
ttps://bugzilla.redhat.com/show_bug.cgi?id=1662602 > https://bugzilla.kernel.org/show_bug.cgi?id=202123 > > https://lore.kernel.org/lkml/2019033500.840117...@linutronix.de/ I confirm the patch above fixes the glibc issues. Aurelien -- Aurelien Jarno GPG: 409

Bug#918823: libc6: [24945.428485] libvirtd[12553]: segfault at 8 ip 00007fb0f515ba63 sp 00007fff86e08370 error 4 in ld-2.24.so[7fb0f514b000+23000]

2019-01-09 Thread Aurelien Jarno
nd resolving the dependencies. It's not impossible that some files are corrupted. Which version of libvirt are you using, the one from Debian Stretch? In order to better understand the problem, would it be possible to send us the output of the following commands: - ldd /usr/bin/virsh - LD_DEBUG

Bug#918583: Bug #918583 in glibc marked as pending

2019-01-07 Thread Aurelien Jarno
Control: tag -1 pending Hello, Bug #918583 in glibc reported by you has been fixed in the Git repository and is awaiting an upload. You can see the commit message below and you can check the diff of the fix at:

Bug#914999: [libc6] Locking problems into libc6

2018-12-30 Thread Aurelien Jarno
On 2018-12-12 17:11, Roman Savochenko wrote: > Hello, Aurelien > > On 12/4/18 1:24 PM, Roman Savochenko wrote: > > On 11/29/18 9:13 PM, Aurelien Jarno wrote: > > > > 1. For my program, I was needed to create extra locking about > > > > the function &

Bug#917801: pacemaker is linked to both libcfg6 and libcfg7 causing it to fail to start

2018-12-30 Thread Aurelien Jarno
Source: pacemaker Version: 1.1.18-2 Severity: grave Tags: buster Justification: renders package unusable pacemaker in buster hasn't been rebuilt against corosync 3.0.0, so it ends up to be dynamically linked to both libcfg6 and libcfg7. In turns this causes it to fail to start with a

Bug#916415: nocache broken with glibc 2.28: several programs just hang in call to futex(..., FUTEX_WAIT_PRIVATE, 2, NULL)

2018-12-29 Thread Aurelien Jarno
On 2018-12-23 01:14, Aurelien Jarno wrote: > control: reassign -1 nocache > control: tag -1 + patch > > On 2018-12-14 07:44, Aurelien Jarno wrote: > > control: forwarded -1 https://github.com/Feh/nocache/issues/34 > > > > On 2018-12-14 13:33, Paul Wise wrote: >

Bug#915738: python-scipy should use the default gfortran on s390x

2018-12-29 Thread Aurelien Jarno
emoving -funroll-loops is enough to get the leastsq testcase to pass. Now I am not used to fortran code, so I don't know how to move that forward. -- Aurelien Jarno GPG: 4096R/1DDD8C9B aurel...@aurel32.net http://www.aurel32.net signature.asc Description: PGP signature

Bug#916054: procmeter3 FTBFS with glibc 2.28

2018-12-25 Thread Aurelien Jarno
me to cancel it. Regards, Aurelien -- Aurelien Jarno GPG: 4096R/1DDD8C9B aurel...@aurel32.net http://www.aurel32.net diff -Nru procmeter3-3.6/debian/changelog procmeter3-3.6/debian/changelog --- procmeter3-3.6/debian/changelog 2014-03-22 16:38:22.00

Bug#916415: nocache broken with glibc 2.28: several programs just hang in call to futex(..., FUTEX_WAIT_PRIVATE, 2, NULL)

2018-12-22 Thread Aurelien Jarno
control: reassign -1 nocache control: tag -1 + patch On 2018-12-14 07:44, Aurelien Jarno wrote: > control: forwarded -1 https://github.com/Feh/nocache/issues/34 > > On 2018-12-14 13:33, Paul Wise wrote: > > Package: nocache/1.0-1,libc6/2.28-2 > > Severity: critical >

Bug#916054: procmeter3 FTBFS with glibc 2.28

2018-12-21 Thread Aurelien Jarno
glibc. +If _XOPEN_SOURCE is defined _DEFAULT_SOURCE needs to be defined explicit +to have the definition of loff_t. +Author: Aurelien Jarno +Bug-Debian: https://bugs.debian.org/916054 +Last-Update: 2018-12-21 + +--- procmeter3-3.6.orig/modules/longrun.c procmeter3-3

Bug#882255: libc6-dev: #define _SC_PAGESIZE _SC_PAGESIZE in /usr/include/x86_64-linux-gnu/bits/confname.h

2018-12-20 Thread Aurelien Jarno
num value and a defined value that can be tested with #ifdef. -- Aurelien Jarno GPG: 4096R/1DDD8C9B aurel...@aurel32.net http://www.aurel32.net

Bug#915171: Upstream ticket

2018-12-19 Thread Aurelien Jarno
ommit/?id=4af4a4a71827c0bc5e0ec67af23edef4f15cee8e -- Aurelien Jarno GPG: 4096R/1DDD8C9B aurel...@aurel32.net http://www.aurel32.net

Bug#915151: gzip FTBFS: ../../lib/fseeko.c:110:4: error: #error "Please port gnulib fseeko.c to your platform! Look at the code in fseeko.c, then report this to bug-gnulib."

2018-12-19 Thread Aurelien Jarno
. > > Would the here attached patch help ? > On most files in lib we can use the == 6 construct. Only for fflush.c this > can’t be done because it uses removed libio.h references. I think you should use the patch that has been committed to the upstream gnulib: http://git.s

Bug#915150: gzip: FTBFS with glibc 2.28

2018-12-19 Thread Aurelien Jarno
in the upstream gnulib repository, so it's definitely the right way to fix the bug: http://git.savannah.gnu.org/cgit/gnulib.git/commit/?id=4af4a4a71827c0bc5e0ec67af23edef4f15cee8e Aurelien -- Aurelien Jarno GPG: 4096R/1DDD8C9B aurel...@aurel32.net http://www.aurel32.net

Bug#916415: nocache broken with glibc 2.28: several programs just hang in call to futex(..., FUTEX_WAIT_PRIVATE, 2, NULL)

2018-12-13 Thread Aurelien Jarno
che; some programs, > when run under it (but not all of them), hang in a call to read/futex: I haven't looked at it in details, but at least accorded to the upstream bug, it seems to be an issue on the nocache side: https://github.com/Feh/nocache/issues/34 -- Aurelien Jarno

Bug#915339: Bug #915339 in glibc marked as pending

2018-12-04 Thread Aurelien Jarno
Control: tag -1 pending Hello, Bug #915339 in glibc reported by you has been fixed in the Git repository and is awaiting an upload. You can see the commit message below and you can check the diff of the fix at:

Bug#915321: Mutex creation failed

2018-12-02 Thread Aurelien Jarno
ug in r-cran-later, I'm reassigning this bug there > and leave another bug here for adding a Conflicts with the unfixed > r-cran-later afterwards. While the pointer to the bug is correct, I am not sure we need to reassign the bug there. Nothing has to be changed in r-cran-later, it just has to be binNMued against glibc 2.28. OTOH, we need to add a Break on the glibc side. -- Aurelien Jarno GPG: 4096R/1DDD8C9B aurel...@aurel32.net http://www.aurel32.net

Bug#915321: Mutex creation failed

2018-12-02 Thread Aurelien Jarno
d, but end-up using the glibc one, leading to the above crash. Rebuilding r-cran-later against glibc 2.28 to enable C11 threads support from glibc is enough to fix the issue. I believe we should binNMU it and add Breaks: on the glibc side. -- Aurelien Jarno GPG: 4096R/1DDD8C9B aurel...@aurel32.net http://www.aurel32.net

Bug#914999: [libc6] Locking problems into libc6

2018-11-29 Thread Aurelien Jarno
is related with glibc, please try to install glibc packages (libc*, possibly locales* and nscd if needed) from Debian 9 onto a working Debian 8 installation and see if the problem appears. Without more information, there is no way for us to fix the bug, so we'll just have to close it. Thanks, Aurelien

Bug#906307: clsync: pre-depends on multiarch-support in buster

2018-09-13 Thread Aurelien Jarno
tag: reopen -1 On 2018-09-13 15:35, Adrian Bunk wrote: > Version: 0.4.2-1 > > On Thu, Aug 16, 2018 at 10:50:17PM +0200, Aurelien Jarno wrote: > > Source: clsync > > Version: 0.4.1-1 > > Severity: serious > > Tags: buster > > > > The multiarch-suppo

Bug#906307: clsync: pre-depends on multiarch-support in buster

2018-08-16 Thread Aurelien Jarno
Source: clsync Version: 0.4.1-1 Severity: serious Tags: buster The multiarch-support package is scheduled for removal in buster. clsync is one of the last package in buster that still depends on it. The dependency is added by old versions of debhelper, so in theory the package would just need to

Bug#905615: healpy: FTBFS with python 3.7

2018-08-07 Thread Aurelien Jarno
Source: healpy Version: 1.11.0-1 Severity: serious Justification: fails to build from source (but built successfully in the past) healpy fails to build in the python 3.7 build. From the build log: ... | x86_64-linux-gnu-gcc -pthread -DNDEBUG -g -fwrapv -O2 -Wall -g -O2 -fstack-protector-strong

Bug#902800: Bug #902800 in glibc marked as pending

2018-07-05 Thread Aurelien Jarno
Control: tag -1 pending Hello, Bug #902800 in glibc reported by you has been fixed in the Git repository and is awaiting an upload. You can see the commit message below, and you can check the diff of the fix at:

Bug#902990: FTBFS: bus error, alignment problems

2018-07-04 Thread Aurelien Jarno
uild' failed > make: *** [build] Error 25 > dpkg-buildpackage: error: debian/rules build subprocess returned exit status 2 This is upstream issue #86. Marking the bug as forwarded. -- Aurelien Jarno GPG: 4096R/1DDD8C9B aurel...@aurel32.net http://www.aurel32.net

Bug#895642: sqlite: snprintf wrongly used, path truncated

2018-04-13 Thread Aurelien Jarno
Source: sqlite Version: 2.8.17-14 Severity: serious Compiling lemon.c with -Wall, leads to the following warning (among many others): | cc -g -O2 -fdebug-prefix-map=/tmp/sqlite-2.8.17=. -fstack-protector-strong -Wformat -Werror=format-security -DTHREADSAFE=1 -Wall -o lemon ./tool/lemon.c |

Bug#872535: sqlite FTBFS on arm* with gcc 7

2018-04-13 Thread Aurelien Jarno
Maximum length of any ".datatype" field. */ char *stddt; /* Standardized name for a datatype */ int i,j; /* Loop counters */ - int hash; /* For hashing the name of a type */ + unsigned int hash; /* For hash

Bug#892458: Security: please consider upgrade to 3.43(0)

2018-03-09 Thread Aurelien Jarno
s announce from NASA, and it's not track as a CVE. Looking at the diff there are many sprintf changed into snprintf, but I am not 100% sure it's the issue or the sole issue. Aurelien -- Aurelien Jarno GPG: 4096R/1DDD8C9B aurel...@aurel32.net http://www.aurel32.net

Bug#892096: libc6:i386 yields invalid writes, triggered by GCC's AddressSanitizer

2018-03-05 Thread Aurelien Jarno
PRIVATE This has been discussed for example there: https://www.sourceware.org/ml/libc-alpha/2018-02/msg00611.html The AddressSanitizer people should discuss for a public API so that it doesn't happen again. Otherwise it might break at every new glibc version. I am therefore reassigning the bug to gcc-snapshot. -- Aurelien Jarno GPG: 4096R/1DDD8C9B aurel...@aurel32.net http://www.aurel32.net

Bug#891911: bogofilter: not binNMU safe

2018-03-02 Thread Aurelien Jarno
Source: bogofilter Version: 1.2.4+dfsg1-10 Severity: serious bogofilter has been binNMUed on mips64el. The depends on bogofilter-common is too strict and makes bogofilter uinstallable: | # apt-get install bogofilter | Reading package lists... Done | Building dependency tree | Reading

Bug#889859: chemps2: FTBFS on mipsel: test5 segfaults

2018-02-27 Thread Aurelien Jarno
on other buildds. I have blacklisted it on the Loongson 3 buildds so that it doesn't happen again. I am therefore closing the bug. Aurelien -- Aurelien Jarno GPG: 4096R/1DDD8C9B aurel...@aurel32.net http://www.aurel32.net

Bug#891547: cairo: test runs into buildd timeout without fpu

2018-02-27 Thread Aurelien Jarno
e that, so the mips part of this bug is fixed. I am retitling the bug accordingly. -- Aurelien Jarno GPG: 4096R/1DDD8C9B aurel...@aurel32.net http://www.aurel32.net

Bug#891249: linux: unstable kernel/data corruption on ppc64el

2018-02-26 Thread Aurelien Jarno
tag 891249 + fixed-upstream thanks On 2018-02-26 11:01, Breno Leitao wrote: > Hi, > > On 02/23/2018 03:52 PM, Aurelien Jarno wrote: > > > DSA has installed the latest security kernel (4.9.82-1+deb9u2) on the > > Debian POWER8 machines running ppc64el. W

Bug#891249: linux: unstable kernel/data corruption on ppc64el

2018-02-23 Thread Aurelien Jarno
Source: linux Version: 4.9.82-1+deb9u2 Severity: critical Justification: causes serious data corruption DSA has installed the latest security kernel (4.9.82-1+deb9u2) on the Debian POWER8 machines running ppc64el. While they boot correctly, then programs segfault randomly (apt, sbuild, systemd,

Bug#889521: libmsv FTBFS on mips64el: shared library not built

2018-02-04 Thread Aurelien Jarno
in the attached patch. > For some reason it Works for me on eller. The default chroots on porterboxes have file installed. Aurelien -- Aurelien Jarno GPG: 4096R/1DDD8C9B aurel...@aurel32.net http://www.aurel32.net diff -Nru libmsv-1.1.1/debian/control

Bug#887886: marked as pending

2018-01-27 Thread Aurelien Jarno
59207df282a6557177ad1b9d69689eaf6bc5c21c Author: Aurelien Jarno <aurel...@aurel32.net> Date: Sat Jan 27 14:18:47 2018 +0100 New upstream snapshot from 20180127: * New upstream snapshot from 20180127: - Fix stack corruption by __pthread_register_cancel. Closes: #887078, #887886. - debian/p

Bug#887078: marked as pending

2018-01-27 Thread Aurelien Jarno
59207df282a6557177ad1b9d69689eaf6bc5c21c Author: Aurelien Jarno <aurel...@aurel32.net> Date: Sat Jan 27 14:18:47 2018 +0100 New upstream snapshot from 20180127: * New upstream snapshot from 20180127: - Fix stack corruption by __pthread_register_cancel. Closes: #887078, #887886. - debian/p

Bug#888477: marked as pending

2018-01-26 Thread Aurelien Jarno
741cbe1479259e28e5641a749be0a02e5b50435c Author: Aurelien Jarno <aurel...@aurel32.net> Date: Fri Jan 26 12:14:33 2018 +0100 debian/patches/git-updates.diff: update from upstream stable branch: * debian/patches/git-updates.diff: update from upstream stable branch: - Fix build with binutils 2.30 on arm64.

Bug#888477: glibc FTBFS on arm64: dangerous relocation: unsupported relocation

2018-01-26 Thread Aurelien Jarno
porting it to the 2.26 branch. See: https://sourceware.org/ml/libc-stable/2018-01/msg00053.html Aurelien -- Aurelien Jarno GPG: 4096R/1DDD8C9B aurel...@aurel32.net http://www.aurel32.net

Bug#887886: libc6 from experimental makes vlc crash (even after rebuilding from source)

2018-01-21 Thread Aurelien Jarno
version 2.27 [2], so it will be either fixed or reverted for the final release. Aurelien [1] https://sourceware.org/ml/libc-alpha/2018-01/msg00178.html [2] https://sourceware.org/glibc/wiki/Release/2.27 -- Aurelien Jarno GPG: 4096R/1DDD8C9B aurel...@aurel32.net

Bug#848220: g++-4.9/g++-5 show floating point diff to g++-6/g++-7

2018-01-21 Thread Aurelien Jarno
boinc-app-eah-brp to track that. On your side please open a bug describing the issue you encountered with newer g++ versions so that it can eventually be fixed. -- Aurelien Jarno GPG: 4096R/1DDD8C9B aurel...@aurel32.net http://www.aurel32.net

Bug#887880: boinc-app-eah-brp: non-standard gcc/g++ used for build (gcc-5)

2018-01-21 Thread Aurelien Jarno
Package: boinc-app-eah-brp Version: 0.20170426+dfsg-7 Severity: serious Tags: sid User: debian-...@lists.debian.org Usertags: non-standard-compiler, gcc-5, gcc-5-legacy This package builds with a non standard compiler version; please check if this package can be built with the default version of

Bug#848220: gcc-5 should not ship in stretch

2018-01-21 Thread Aurelien Jarno
epends on them anymore¹. Do you think it can be > > removed from unstable too now, or does it have a particular purpose? > > The cuda maintainers asked to keep it still in unstable. Also I'd like to see > the next upstream release 5.5.0 in the snapshot archive. Note that

Bug#886506: busybox sh broken on i386 with glibc 2.26, leads to kernel panic

2018-01-21 Thread Aurelien Jarno
On 2018-01-21 00:47, Ben Hutchings wrote: > On Wed, 17 Jan 2018 12:31:06 +0100 Aurelien Jarno <aure...@debian.org> wrote: > [...] > > busybox is compiled with -mpreferred-stack-boundary=2 on i386 which has > > the same effect of reducing the default stack alignment from

Bug#887629: libc6: bad upgrade path: libexpat1 unpacked and python3 called before libc6 unpacked

2018-01-18 Thread Aurelien Jarno
On 2018-01-18 20:38, Julian Andres Klode wrote: > On Thu, Jan 18, 2018 at 06:41:52PM +0100, Aurelien Jarno wrote: > > control: reassign -1 apt,dpkg > > control: affects -1 libc6 > > control: affects -1 libexpat1 > > > > On 2018-01-18 15:53, Andreas Bec

Bug#887629: libc6: bad upgrade path: libexpat1 unpacked and python3 called before libc6 unpacked

2018-01-18 Thread Aurelien Jarno
d correctly depends on it. Therefore it's not a bug of libc6 nor libexpat1. It looks to me like a bug in apt or dpkg. I am therefore reassigning the bug to these packages, so the maintainers can have a look at the issue. Aurelien -- Aurelien Jarno GPG: 4096R/1DDD8C9B aurel...@aurel32.net http://www.aurel32.net

Bug#886506: busybox sh broken on i386 with glibc 2.26, leads to kernel panic

2018-01-17 Thread Aurelien Jarno
cc 4.2.x | # from aligning stack to 16 bytes. (Which is gcc's way of supporting SSE). | CFLAGS += $(call cc-option,-march=i386 -mpreferred-stack-boundary=2,) I don't really get why it is essential to prevent gcc from aligning stack to 16 bytes, anyway this is a bad idea. Removing this option just

Bug#887001: marked as pending

2018-01-13 Thread Aurelien Jarno
82a888594125b1d05bed4092b23af44fc23907a2 Author: Aurelien Jarno <aurel...@aurel32.net> Date: Sat Jan 13 16:14:06 2018 +0100 debian/patches/git-updates.diff: update from upstream stable branch: * debian/patches/git-updates.diff: update from upstream stable branch: - Fix a buffer underflow in getcwd() (CV

Bug#886133: ndpi: FTBFS on mips, s390x, powerpc, and ppc64: tests time out

2018-01-03 Thread Aurelien Jarno
are inactivity timeouts, so any > output to stdout or stderr resets them.) s390x and ppc64 are definitely not slow architectures. The common between all these architectures is that there are big endian. -- Aurelien Jarno GPG: 4096R/1DDD8C9B aurel...@aurel32.net http://www.aurel32.net

Bug#883615: Acknowledgement ([CRITICAL] Stretch p-u 9.3 breaks NVidia driver and X.org)

2017-12-17 Thread Aurelien Jarno
ernel, one in /lib and the other in /lib/tls. Debian dropped the 2.4 kernel support in Lenny, and thus only the glibc with the "new" TLS mechanism was provided. As a consequence all the packages stopped using the tls directory as the new mechanism was guaranteed to be support

Bug#884524: marked as pending

2017-12-16 Thread Aurelien Jarno
6c6484d2c22b1a60d3dec8af8fae2236530f18b0 Author: Aurelien Jarno <aurel...@aurel32.net> Date: Sat Dec 16 12:20:29 2017 +0100 debian/rules.d/debhelper.mk: strip all *crt*.o files, unless DEB_BUILD_OPTIONS contains nostrip. Closes: #884524. diff --git a/debian/changelog b/debian/changelog index 1a30046..f23313e

Bug#884524: libc6-dev: *crt*.o files are not stripped anymore

2017-12-16 Thread Aurelien Jarno
Package: libc6-dev Version: 2.25-4 Severity: serious glibc version 2.25-4 reorganized the way the files are put in the libc6-dbg or the -dbgsym packages. Unfortunately this caused the *crt*.o from libc6-dev to not be stripped anymore. This causes in turns at least the lintian testsuite to fail.

Bug#883615: Acknowledgement ([CRITICAL] Stretch p-u 9.3 breaks NVidia driver and X.org)

2017-12-07 Thread Aurelien Jarno
bly due > to ASLR. It's normal that the addresses are not the same, that said, I was expecting the path to be different. The only thing that /etc/ld.so.nohwcap is supposed to change the libraries that are loaded. That said, there is are path for optimized libraries on amd64, so I am not really surprised. I still don't understand the bug... Aurelien -- Aurelien Jarno GPG: 4096R/1DDD8C9B aurel...@aurel32.net http://www.aurel32.net

Bug#883615: Acknowledgement ([CRITICAL] Stretch p-u 9.3 breaks NVidia driver and X.org)

2017-12-07 Thread Aurelien Jarno
control: reopen -1 control: tag -1 - unreproducible control: retitle -1 nvidia-driver: crashes with /etc/ld.so.nohwcap On 2017-12-07 05:43, Julien Aubin wrote: > 2017-12-06 21:50 GMT+01:00 Aurelien Jarno <aurel...@aurel32.net>: > > > On 2017-12-06 19:39, Julien Aubin

Bug#883705: Bug#883615: Acknowledgement ([CRITICAL] Stretch p-u 9.3 breaks NVidia driver and X.org)

2017-12-07 Thread Aurelien Jarno
control: reopen 883705 control: forcemerge 883705 883394 control: retitle 883705 libc6: keep /etc/ld.so.nohwcap after upgrade, breaking Nvidia GLX On 2017-12-07 05:43, Julien Aubin wrote: > 2017-12-06 21:50 GMT+01:00 Aurelien Jarno <aurel...@aurel32.net>: > > > On 2017-12-06 1

Bug#883615: Acknowledgement ([CRITICAL] Stretch p-u 9.3 breaks NVidia driver and X.org)

2017-12-06 Thread Aurelien Jarno
est is done you can then remove it. Thanks, Aurelien -- Aurelien Jarno GPG: 4096R/1DDD8C9B aurel...@aurel32.net http://www.aurel32.net

Bug#882255: marked as pending

2017-12-02 Thread Aurelien Jarno
6549f5118127642e53e61045b9dd2d8a3fb35296 Author: Aurelien Jarno <aurel...@aurel32.net> Date: Sat Dec 2 10:37:07 2017 +0100 debian/sysdeps/x32.mk: set the minimum kernel version to 2.6.32 for the libc6-amd64:x32 and libc6-i386:x32 flavours, to match libc6:amd64 and libc6:i386. Closes: #882255. diff --git a/debian/cha

Bug#882255: libc6-amd64: Multilib causes catastrophic system failure during upgrade to libc 2.25

2017-12-02 Thread Aurelien Jarno
control: tag -1 - pending On 2017-12-02 03:34, Mikulas Patocka wrote: > > > On Sun, 26 Nov 2017, Aurelien Jarno wrote: > > > > > You mean that even now running 'ldconfig' followed by 'ldd /bin/true' > > > > will give you > > > >

Bug#882255: marked as pending

2017-12-01 Thread Aurelien Jarno
514c3f235e480ed7aaf80025b7e026170d704774 Author: Aurelien Jarno <aurel...@aurel32.net> Date: Fri Dec 1 19:59:41 2017 +0100 debian/patches/submitted-ldconfig-c-collation.diff: New patch to process include directives in ldconfig using the C/POSIX collation. Closes: #882255. diff --git a/debian/changelog b/debian/cha

Bug#882263: libc6-dev-mips64el-cross breaks linking executables

2017-11-30 Thread Aurelien Jarno
| $ echo 'int main(){return 0;}' | s390x-linux-gnu-gcc -x c - -o /dev/null | /usr/lib/gcc-cross/s390x-linux-gnu/7/../../../../s390x-linux-gnu/bin/ld: cannot find /usr/s390x-linux-gnu/lib/ld64.so.1 | collect2: error: ld returned 1 exit status It therefore looks like to me that this hunk has to be

Bug#883186: marked as pending

2017-11-30 Thread Aurelien Jarno
72c8c592e031dafa2aa91deeb9b45382abd49acf Author: Aurelien Jarno <aurel...@aurel32.net> Date: Thu Nov 30 14:08:45 2017 +0100 Fix missing posix_fadvise64 from static mips64el build. Closes: #883186. diff --git a/debian/changelog b/debian/changelog index 3f530fd..bbe817a 100644 --- a/debian/changelog +++ b/debian/cha

  1   2   3   4   5   6   7   8   9   10   >