Bug#944831: thonny (build-)depends on cruft package.

2019-11-15 Thread peter green
Package: thonny Version: 0.14.1-1 Severity: serious Tags: bullseye, sid, patch thonny depends and build-depends on the pylint3 binary package which is no longer built by the pylint source package. The python 3 pylint functionality is now in the pylint binary package. These

Bug#944828: salt-pylint (build-)depends on cruft package.

2019-11-15 Thread peter green
Package: salt-pylint Version: 0.14.1-1 Severity: serious Tags: bullseye, sid, patch python3-saltpylint depends on and the salt-pylint source package build-depends on the pylint3 binary package which is no longer built by the pylint source package. The python 3 pylint functionality is now in

Bug#944825: pylint-common (build-)depends on cruft package.

2019-11-15 Thread peter green
Package: pylint-common Version: 0.2.5-2 Severity: serious Tags: bullseye, sid, patch python3-plint-common depends on and the pylint-common source package build-depends on the pylint3 binary package which is no longer built by the pylint source package. The python 3 pylint functionlity is now

Bug#944824: pylint-celery (build-)depends on cruft package.

2019-11-15 Thread peter green
Package: pylint-celery Version: 0.3-4 Severity: serious Tags: bullseye, sid, patch python3-plint-celery depends on and the pylint-celery source package build-depends on the pylint3 binary package which is no longer built by the pylint source package. The python 3 pylint functionlity is now in

Bug#943924: reducing matplotlib2 build-depends.

2019-11-12 Thread peter green
matplotlib2 seems to be an important node in the python2 removal/reduction problem (and the qt4 removal problem). I have noticed there are a substantial number of python module packages that it build-depends on but does not depend on. python-backports.functools-lru-cache python-cairocffi

Bug#922582: FTBFS against opencv 4.0.1 (exp)

2019-11-12 Thread peter green
tags 922582 +patch thanks > gmic's cmake file needs to be updated for Opencv4 A bit more than just the cmake file needs to be updated. I was able to get the package to build with the attached debdiff, I have upload the changes to raspbian, no intent to NMU in Debian. diff -Nru

Bug#943867: stressant: non-buildd binaries

2019-11-09 Thread peter green
tags 943867 +patch thanks Since there was no maintainer response to this bug report, I decided to go ahead and prepare a NMU. While testing for said NMU I found that the package's clean target did not clean up properly. So I fixed it. I have uploaded a NMU to delayed/5 with the attached

Bug#944341: libopencv-imgcodecs-dev depends on cruft package.

2019-11-08 Thread peter green
package: libopencv-imgcodecs-dev version: 4.1.2+dfsg-4 severity: serious The libopencv-imgcodecs-dev binary package depends on and the opencv source package build-depends on libgdcm2-dev which is no longer built by the gdcm source package.

Bug#944193: node-react needs a source-only upload.

2019-11-05 Thread peter green
Package: node-react Version: 16.2.0-3 Severity: serious node-react is currently blocked from migrating to testing because the release team have decreed that only buildd-built binaries can migrate. Please make sure your next upload is source-only. Ideally one would deal with bug 933123 at the

Bug#936207: biosig4c++: Python2 removal in sid/bullseye

2019-10-31 Thread peter green
Severity 936207 serious thanks biosig4c++ build-depends on the python-pkgconfig binary package which is no longer built by the python-pkgconfig source package.

Bug#943912: python-easydev: needs a source-only upload

2019-10-31 Thread peter green
Package: python-easydev Version: 0.9.38-1 Severity: serious The release team have decreed that non-buildd binaries can no longer migrate to testing. Please Make a source-only upload so your package can migrate.

Bug#943911: squid: needs a source-only upload.

2019-10-31 Thread peter green
Package: squid Version: 4.8-1 Severity: serious The release team have decreed that non-buildd binaries can no longer migrate to testing. Please make a source-only upload so your package can migrate.

Bug#941101: rdup: Uses functions deprecated in Nettle 3.5

2019-10-31 Thread peter green
I notice that in addition to the complaints about nettle deprecation there is also a complaint about the use of memmove, unfortunately the compiler doesn't say what exactly it doesn't like about the use of memmove. In raspbian I decided to go ahead and remove -Werror, a debdiff doing that

Bug#943566: FTBFS with nettle 3.5.1

2019-10-31 Thread peter green
tags 943566 +patch thanks Currently the nettle 3.5.1 transition is going on. I tried to binNMU your package but it fails to build from source on all architectures. I had a fiddle around with the order of includes and this led me to some different error messages which led me to the real

Bug#943867: stressant: non-buildd binaries

2019-10-30 Thread peter green
Package: stressant Version: 0.5.0 Severity: serious The release team have decreed that non-buildd binaries can no longer migrate to testing. Please make a source-only upload so your package can migrate.

Bug#943542: google-cloud-print-connector: hardcoded dependency on libsnmp30

2019-10-25 Thread Peter Green
Package: google-cloud-print-connector Version: 1.12.1 Severity: serious Tags: bullseye, sid After uploading my fix for 942331 to Raspbian bullseye I discovered another problem. The dependency on libsnmp30 is hardcoded. In raspbian I have just gone ahead and changed the dependency. a debdiff

Bug#942331: google-cloud-print-connector FTBFS with current cups (was: google-cloud-print-connector: FTBFS during rebuild with libsnmp35)

2019-10-25 Thread peter green
tags 942331 +patch thanks Your package is part of the libsnmp transition. During a rebuild your package FTBFS on all architectures. Reading the log more thoroughly it seems the actual failure is cups related. cgo-gcc-prolog:95:2: warning: ‘cupsGetPPD3’ is deprecated: Use cupsCopyDestInfo

Bug#942887: python-fabio: autopkgtest failure.

2019-10-22 Thread peter green
Package: python-fabio Version: 0.9.0+dfsg-2 Severity: serious Python-fabio's autopkgtest is failing, == ERROR: testFullFormatName (fabio.test.testfabioconvert.TestFabioConvert)

Bug#913424: Should python-trio be allowed into testing? (Was: state of python-msrest.)

2019-10-20 Thread peter green
On 20/10/2019 00:15, Robie Basak wrote: On Sat, Oct 19, 2019 at 11:59:45PM +0200, Nicolas Dandrimont wrote: 2. while python3-trio has passed new, it's maintainer (Robie Basak) has filed a RC bug saying he does not belive it is currently suitable for a stable release. In part I just followed

Bug#942607: gtk-d FTBFS on armhf, multiple definition errors.

2019-10-18 Thread peter green
Package: gtk-d Version: 3.9.0-2 Severity: serious The issue with gtk-d trying to build with the wrong compiler on gdc architectures (most notablly armhf, which until recently was an ldc architecture) has now been fixed, unfortunately it is still failling to build, this time with a bunch of

Bug#942533: sardana: needs a source-only upload.

2019-10-17 Thread peter green
On 17/10/2019 22:23, PICCA Frederic-Emmanuel wrote: ok, but this packages comes from NEW. So it would be nice if the process NEW -> unstable could be a source upload. Ir is not possible to upload without the binary in New. This processus necessitate two uploads if I understand correctly.

Bug#942536: repmgr needs a source-only upload

2019-10-17 Thread peter green
Package: repmgr Version: 5.0.0-1 Severity: serious The release team have decreed that non-buildd binaries can no longer migrate to testing, please make a source-only upload so your package can migrate.

Bug#942533: sardana: needs a source-only upload.

2019-10-17 Thread peter green
Package: sardana Version: 3.0.0a+3.f4f89e+dfsg-1 Severity: serious The release team have decreed that non-buildd binaries cannot migrate to testing. Please make a source-only upload so your package can migrate.

Bug#937162: nototools: Python2 removal in sid/bullseye

2019-10-16 Thread peter green
Hi. As I posted earlier nototools build-depends on python-fonttools which is no longer built by the fonttools source package. Since this package turned out not to be eligable for autoremoval I decided to take a slightly deeper look. nototools builds a single binary package, python-nototools

Bug#942350: repmgr: autopkgtest fails with postgresql 12 libraries

2019-10-14 Thread peter green
Package: repmgr Version: 4.2.0-2 Severity: serious postgresql-12 recently took over a bunch of library packages from postgresql-11. This seems to have caused repmgr's autopkgtest to fail with a bunch of undefined symbol errors. This can be seen with both testings version (tested as part of

Bug#931944: vtk7: FTBFS with PROJ 6

2019-10-10 Thread peter green
Disabling the PROJ support was not an option as it was for vtk6. You may want to reinstate the embedded copy and use that instead. It looks like a commit doing this was made on salsa on august 6th https://salsa.debian.org/science-team/vtk7/commit/19d6e5e2e02cbd10404dd96e750370546feaa82b Is

Bug#941957: check-manifest: needs a source-only upload

2019-10-07 Thread peter green
Package: check-manifest Version: 0.39-1 Severity: serious The release team have decreed that non-buildd binaries can no longer migrate to testing, please make a source-only upload so your package can migrate.

Bug#941558: check-manifest: autopkgtest failure with transitional bzr package.

2019-10-01 Thread peter green
Package: check-manifest Version: 0.37-1 Tags: bullseye, sid Severity: serious x-debbugs-cc: b...@packages.debian.org bzr recently became a transitional package to breezy (a fork of bzr), unfortunately this is causing the autopkgtest of check-manifest to fail.

Bug#941226: python-pyramid-zcml needs a source-only upload

2019-09-26 Thread peter green
Package: python-pyramid-zcml Version: 1.0.0-1.1 Severity: serious x-debbugs-cc: w...@debian.org The release-team have decreed that non-buildd binaries cannot migrate to testing, please make a source-only upload to the package can migrate.

Bug#941225: python-pyramid-tm: needs a source-only upload

2019-09-26 Thread peter green
Package: python-pyramid-tm Version: 0.5-1.1 Severity: serious x-debbugs-cc: w...@debian.org The release team have decreed that non-buildd binaries cannot migrate to testing, please make a source-only upload so the package can migrate.

Bug#941223: ufolib2: needs a source-only upload

2019-09-26 Thread peter green
Package: ufolib2 Version: 0.4.0+dfsg1-2 Severity: serious The release-team have decreed that non-buildd binaries can no longer migrate to testing, please make a source-only upload so your package can migrate.

Bug#940983: [Pkg-rust-maintainers] Bug#940983: rust-sha-1: rebuilding results in broken dependencies.

2019-09-26 Thread peter green
On 24/09/2019 03:55, kpcyrd wrote: On Sun, Sep 22, 2019 at 11:07:57PM +0100, peter green wrote: Package: rust-sha-1 Version: 0.8.1-2 Severity: serious If rust-sha-1 is re-built, the version mentioned in virtual package names in the provides changes from "0.4" to "0.8&qu

Bug#940717: gtk-d FTBFS on armhf, tries to build with ldc but it's not installed.

2019-09-26 Thread peter green
found 940717 3.8.5-1 tags 940717 +bullseye tags 940717 +sid Since the version of default-d-compiler which uses gdc on armhf migrated to testing, gtk-d also fails to build on armhf in testing.

Bug#941008: loggerhead, multiple dependency issues.

2019-09-23 Thread peter green
Package: loggerhead Version: 1.19~bzr479+dfsg-3 Severity: serious Loggerhead has multiple dependency issues. The loggerhead source package build-depends on python-subunit which is no longer built by the subunit source package. The loggerhead source package build-depends on python-bzrlib.tests

Bug#940983: rust-sha-1: rebuilding results in broken dependencies.

2019-09-22 Thread peter green
Package: rust-sha-1 Version: 0.8.1-2 Severity: serious If rust-sha-1 is re-built, the version mentioned in virtual package names in the provides changes from "0.4" to "0.8", but the version mentioned in the virtual package names in the depends stays at "0.4", thus breaking dependencies between

Bug#940717: gtk-d FTBFS on armhf, tries to build with ldc but it's not installed.

2019-09-19 Thread peter green
Package: gtk-d Version: 3.9.0-1 Severity: serious the new gtk-d upload failed to build on armhf, the dependencies install gdc but the package tries to build with ldc. I presume this was triggered by the change in default d compiler on armhf from ldc to gdc. The changelog mentions building

Bug#940684: breezy: build-depends on obsolete package.

2019-09-18 Thread peter green
Package: breezy Severity: serious Version: 3.0.1-2 Breezy (both versions 3.0.1-2 and 3.0.1-4) build-depends on python-subunit which is no longer built by the subunit source package.

Bug#940682: lava-server: depends on cruft package.

2019-09-18 Thread peter green
Package: lava-server Version: 2019.01-5 Severity: serious Tags: bullseye, sid lava depends on gunicorn3 which is no longer built by the gunicorn source package. I belive you need to change your dependency to gunicorn, possiblly with a version constraint of >= 19.9.0-4

Bug#940604: dhcpig depends on cruft package.

2019-09-17 Thread peter green
Package: dhcpig Version: 1.5-2 Severity: serious Tags: bullseye, sid dhcpig depends on python-scapy which is no longer built by the scapy source package. If you want your package to remain around you probably need to migrate to python 3.

Bug#940320: matplotlib2 build-depends on package that is cruft in unstable and gone in testing.

2019-09-15 Thread peter green
Package: matplotlib2 Version: 2.2.4-1 Severity: serious matplotlib2 build-depends on python-cxx-dev, this package is no longer built by the pycxx source package. It is still present in unstable as a cruft package, but is completely gone from testing.

Bug#940316: zope.testing autopkgtest failure.

2019-09-15 Thread peter green
Package: zope.testing Version: 4.6.2-2 Severity: serious https://ci.debian.net/data/autopkgtest/testing/amd64/z/zope.testing/2966135/log.gz autopkgtest [06:13:32]: test all: [--- Traceback (most recent call last): File "/usr/bin/zope-testrunner", line 9, in

Bug#940315: zope.testrunner autopkgtest failure.

2019-09-15 Thread peter green
Package: zope.testrunner Version: 4.4.9-3 Severity: serious autopkgtest [06:13:47]: test all-2: [--- bash: /tmp/autopkgtest-lxc.v65a_j_9/downtmp/build.cMu/src/debian/tests/all-2: /usr/bin/python: bad interpreter: No such file or directory autopkgtest [06:13:47]: test all-2:

Bug#940314: neo, needs a source-only upload to migrate to testing.

2019-09-15 Thread peter green
Package: neo Version: 0.7.2-1 Severity: serious The release team have decreed that non-buildd binaries can no longer migrate to testing. Please make a source-only upload so your package can migrate.

Bug#940313: python3-osprofiler fails to install

2019-09-15 Thread peter green
Package: python3-osprofiler Version: 2.6.0-1 Severity: grave python3-osprofiler fails to install, I first noticed this in an autopkgtest, but I was able to reproduce it in a local sid chroot too. Setting up python3-osprofiler (2.6.0-1) ... update-alternatives: error: alternative path

Bug#940178: distro-info autopkgtest failure with new pylint.

2019-09-13 Thread peter green
Package: distro-info Version: 0.21 Severity: serious Tags: bullseye, sid pylint has been migrated from python 2 to python 3. This seems to be causing an autopkgtest failure in your package. Can you fix it so that pylint can migrate to testing?

Bug#940131: srslte FTBFS with libbladerf2 and uhd 3.14

2019-09-12 Thread peter green
Package: srslte Version: 3.14.1.0-2 Severity: serious srslte FTBFS in bullseye and sid due to the new versions of bladerf and uhd changing some data types. I patched the errors and was able to get a successful build in raspbian bullseye which I uploaded to the raspbian archive, I have not

Bug#939620: zope.testrunner: Python2 removal in sid/bullseye

2019-09-12 Thread peter green
severity 938919 serious thanks python-zope.testrunner in testing depends on python-zope.exceptions which has already been dropped by the zope.exceptions source package. This has been addressed in unstable by dropping the python-zope.testrunner binary package, however that fix cannot currently

Bug#939561: soapybladerf ftbfs in unstable

2019-09-12 Thread peter green
tags 939561 +fixed-upstream tags 939561 +patch thanks Some googling revealed that upstream had fixed this issue https://github.com/pothosware/SoapyBladeRF/pull/19 . I was able to take the upstream pull request, turn it into a patch series and apply it to the Debian package. I have uploaded

Bug#940119: sdaps build-depends on package that is cruft in unstable and gone in testing.

2019-09-12 Thread peter green
Package: sdaps Version: 1.9.7-0.1 Severity: serious sdaps build-depends on texlive-generic-recommended which is no longer built by texlive-base. The old texlive-generic-recommended is still present in unstable as a cruft package, but is completely gone from testing. Please update your

Bug#940071: gr-radar FTBFS in unstable.

2019-09-11 Thread peter green
Package: gr-radar Version: 0.0.0.20180308-1 Severity: serious Tags: bullseye, sid gr-radar failed to build with the following errors when an attempt was made to binnmu it for the new gnuradio. CMake Error at CMakeLists.txt:120 (find_package): Could not find a configuration file for package

Bug#940069: gr-limsdr FTBFS in unstable.

2019-09-11 Thread peter green
Package: gr-limesdr Version: 0.9~beta-1+b2 Severity: serious Tags: bullseye, sid gr-limesdr failed to build with the following errors when an attempt was made to binnmu it for the new gnuradio. -- Could NOT find MPIR (missing: MPIRXX_LIBRARY MPIR_LIBRARY MPIR_INCLUDE_DIR) CMake Error at

Bug#940068: gr-gsm FTBFS in unstable

2019-09-11 Thread peter green
Package: gr-gsm Version: 0.42.2-1 Severity: serious Tags: bullseye, sid gr-gsm failed to build with the following errors when an attempt was made to binnmu it for the new gnuradio. CMake Warning at CMakeLists.txt:135 (find_package): Found package configuration file:

Bug#940063: gnss-sdr FTBFS, is gr-iio broken? did gnuradio break ABI?

2019-09-11 Thread peter green
Package: gnss-sdr Version: 0.0.11-1 Severity: serious gnss-sdr seems to have recently started failing to build with the following error. cd /build/1st/gnss-sdr-0.0.11/obj-x86_64-linux-gnu/src/utils/front-end-cal && /usr/bin/c++ -DBOOST_GREATER_1_65 -DGNSSSDR_INSTALL_DIR=\"/usr\"

Bug#939984: metview, FTBFS on 32-bit, narrowing conversions.

2019-09-10 Thread peter green
Package: metview Version: 5.6.1-3 Severity: serious It seems metview has recently started to fail to build on 32-bit, /<>/atlas/src/tests/mesh/test_halo.cc: In function 'void atlas::test::traced_test_105(std::string&, int&, int)': /<>/atlas/src/tests/mesh/test_halo.cc:142:40: error: narrowing

Bug#939807: sbcl build-depends on package that is cruft in unstable and gone in testing.

2019-09-08 Thread peter green
Package: sbcl Version: 2:1.5.6-1 Severity: serious sbcl build-depends on texlive-generic-recommended which is no longer built by texlive-base. The old texlive-generic-recommended is still present in unstable as a cruft package, but is completely gone from testing. Please update your

Bug#939670: gdcm-doc: depends on cruft package.

2019-09-07 Thread peter green
Package: gdcm-doc Version: 2.8.8-9 Severity: serious Tags: bullseye, sid gdcm-doc depends on vtk6-doc which is no longer built by the vtk6 source package.

Bug#933822: closed by Jan Dittberner (Bug#933822: fixed in virtualenvwrapper 4.8.4-1)

2019-08-29 Thread Peter Green
On 28/08/2019 09:12, Debian Bug Tracking System wrote: This is an automatic notification regarding your Bug report which was filed against the virtualenvwrapper package: #933822: virtualenvwrapper depends on cruft package python-stevedore Is there a reason that the fix was only uploaded to

Bug#936079: python-ceilometerclient (build-)depends on cruft packages.

2019-08-29 Thread peter green
Package: python-ceilometerclient Version: 2.9.0-2 Severity: serious Tags: bullseye, sid The python-ceilometerclient binary package depends on and the python-ceilometerclient binary package build-depends on a number of python 2 binary packages that are no longer built by their corresponding

Bug#935015: datalad: please drop python-datalad (python 2 removal effort)

2019-08-29 Thread peter green
Found 935015 0.11.2-2 Thanks This bug also affects the version in testing.

Bug#936010: rust-pangocairo build-dependencies unsatisfiable

2019-08-28 Thread peter green
Package: rust-pangocairo Version: 0.6.0-1 Severity: serious Tags: sid According to wanna-build rust-pangocairo's build-dependencies are unsatisfiable. It looks like librust-cairo-rs-0.5+default-dev has been replaced with librust-cairo-rs-0.7+default-dev .

Bug#935794: xfce4-sntray-plugin FTBFS

2019-08-28 Thread peter green
It looks like that class was dropped from vala-panel in https://gitlab.com/vala-panel-project/vala-panel/commit/87493a6dfab9868f77b7b19b57fca40a06fe80af Unfortunately the commit message doesn't give any clues to what if-anything it should be replaced with. If a proper fix cannot be found then

Bug#935998: haskell-blaze-html: unsatisfiable build-depends due to version constraint.

2019-08-28 Thread peter green
Package: haskell-blaze-html Version: 0.9.1.1-3 Severity: serious Tags: sid haskell-blaze-html build-depends on libghc-quickcheck2-dev (< 2.12) but unstable now has version 2.12.6.1-2

Bug#935952: fmcs (build-)depends on cruft package.

2019-08-28 Thread peter green
Package: fmcs Version: 1.0-1 Severity: serious Tags: bullseye, sid python-fmcs depends on and the fmcs source package build-depends on python-rdkit which is no longer built by the rdkit source package. If you want to keep this package around then you need to migrate to python 3

Bug#935584: octave-octclip FTBFS in bullseye, "fgeneral.c:270:8: error: 'nDatos' is predetermined 'shared' for 'shared'"

2019-08-24 Thread peter green
Package: octave-octclip Version: 1.0.8-6 Severity: serious It seems that the new octave-octclip FTBFS in bullseye. I initially noticed this in Raspbian, but it's also appearing on the reproducible builds site so it doesn't seem to be raspbian specific. fgeneral.c: In function 'Minimo':

Bug#935432: kazoo (build-)depends on cruft package.

2019-08-22 Thread peter green
Package: kazoo Version: 2.6.1-1 Severity: serious python-kazoo depends on and the kazoo source package build-depends on the python-eventlet binary package which is no longer built by the python-eventlet source package. It's probably time to drop python 2 support from this package.

Bug#935154: goopg depends on cruft package

2019-08-20 Thread peter green
Package: goopg Version: 0.3.1-9 Severity: serious goopg depends on the python-oauth2client binary package which is no longer built by the python-oauth2client source package. If you want your package to be in bullseye you need to migrate to python 3 (and fix the other rc bug)

Bug#934931: planet-venus: depends on cruft package

2019-08-16 Thread peter green
Package: planet-venus Version: 0~git9de2109-4.2 Severity: serious Tags: bullseye, sid planet-venus depends on python-portalocker which is no longer built by the portalocker source package. If you want your package to stay around you probably need to migrate to python 3.

Bug#934932: presentty (build-)depends on cruft package.

2019-08-16 Thread peter green
Package: presentty Version: 0.2.0-1 Severity: serious Tags: bullseye, sid Presentty (build-)depends on the python-pbr binary package which is no longer built by the corresponding source package. There is a bug report questioning whether said dependency is really necessary (

Bug#934930: python-novnc: depends on cruft package.

2019-08-16 Thread peter green
Package: python-novnc Version: 1:1.0.0-1 Severity: serious Tags: bullseye, sid The python-novnc package depends on the python-oslo.config binary package which is no longer built by the corresponding source package. As far as I can tell if you want to keep novnc around you will need to migrate

Bug#934914: m2crypto: non-buildd binaries

2019-08-16 Thread peter green
Package: m2crypto Version: 0.31.0-5 Severity: serious The release team have decreed that binaries not built on a buildd can no longer migrate to testing. Please make a source-only upload so your package can migrate.

Bug#934912: printrun: depends on cruft package.

2019-08-16 Thread peter green
Package: printrun Version: 1.6.0-2 Severity: serious Tags: bullseye, sid printrun depends on python-cairosvg which is no longer built by the cairosvg source package. If you want your package to stay around you probably need to migrate to python 3.

Bug#934911: design-desktop-graphics: depends on cruft package.

2019-08-16 Thread peter green
Package: design-desktop-graphics Version: 3.0.13 Severity: serious design-desktop-graphics depends on python-cairosvg which is no longer built by the cairosvg source package. Looking at the stated intent of this package and the content of the packages built by the cairosvg source package I

Bug#934844: python-trezor: depends on cruft package.

2019-08-15 Thread peter green
Package: python-trezor Severity: serious Version: 0.9.0-1 Tags: bullseye, sid python-trezor (build-)depends on the python-ecdsa binary package which is no longer built by the corresponding source package. It's probablly time to drop python 2 support.

Bug#934841: sshpubkeys: (build-)depends on cruft package.

2019-08-15 Thread peter green
Package: sshpubkeys Severity: serious Version: 3.1.0-1 Tags: bullseye, sid The python-sshpubkeys package depends on and the sshpubkeys source package build-depends on the python-ecdsa binary package which is no longer built by the corresponding source package. It's probablly time to drop

Bug#934839: python-keepkey: depends on cruft package.

2019-08-15 Thread peter green
Package: python-keepkey Severity: serious Version: 0.7.3-1 Tags: bullseye, sid python-keepkey depends on the python-ecdsa binary package which is no longer built by the corresponding source package. If you want your package to stay around you need to migrate to python 3.

Bug#933757: Firefox-esr FTBFS "failed to open: /sbuild-nonexistent/.cargo/.package-cache"

2019-08-14 Thread peter green
So the libvpx transition prompted me to take a look at this, I added some code to debian/rules to create a fake homedir, use it for the build and remove it in the clean target. Unfortunately I then ran into another failure.

Bug#934788: gst-plugins-good1.0 non-buildd binaries

2019-08-14 Thread peter green
Package: gst-plugins-good1.0 Version: 1.16.0-2 Severity: serious The release team have decreed that non-buildd binaries can no longer migrate to testing, please make a source-only upload so your package can migrate.

Bug#934691: rekall: maintainer address bounces

2019-08-13 Thread peter green
Package: rekall Severity: serious x-debbugs-cc: sa...@debian.org x-debbugs-cc: ben...@debian.org While sending https://lists.debian.org/debian-python/2019/08/msg00072.html I got forensics-de...@lists.alioth.debian.org (generated fromrek...@packages.debian.org) host

Bug#934687: heudiconv, indirectly build-depends on cruft package, needs to migrate to python 3

2019-08-13 Thread peter green
Package: heudiconv Severity: serious Version: 0.5.3-1 heudiconv build-depends on the python-datalad binary package which in turn depends on the python-fasteners binary package, which in turn depends on the python-monotonic binary package which is no longer built by the python-monotonic source

Bug#934674: python-os-win: (build-)depends on cruft package.

2019-08-13 Thread peter green
Package: python-os-win Version: 4.0.0-3 Severity: serious Tags: bullseye Python-os-win in testing (build-)depends on a number of python2 packages that are no longer built by the corresponding source packages. This is already fixed in unstable, by dropping python 2 support, but the unstable

Bug#928129: python-os-win: FTBFS on i386: ClusterPropertyListParsingError: Parsing a cluster property list failed.

2019-08-12 Thread peter green
Severity: serious i'm not entirely convinced on the severity, IIRC established practice in Debian is that arch all packages need to be buildable on at least one release architecture, not all release architectures. python-os-win/experimental FTBFS on i386 while building the (arch:all) package

Bug#934644: openstack-deploy: depends on cruft package.

2019-08-12 Thread peter green
Package: openstack-deploy Version: 0.25 Severity: serious Tags: bullseye, sid openstack-deploy depends on the python-keystoneclient binary package which is no longer built by the corresponding source package. Should this dependency be changed to python3-keystoneclient ?

Bug#934476: django-oauth-toolkit non-buildd binary

2019-08-11 Thread peter green
Package: django-oauth-toolkit Version: 1.2.0-1 Severity: serious The release team have decreed that non-buildd binaries can no longer migrate to testing. Please make a source-only upload so this package can migrate.

Bug#934443: getdp build-depends on cruft package.

2019-08-10 Thread peter green
Package: getdp Version:3.0.4+dfsg1-1 Severity: serious Tags: patch, bullseye, sid getdp build-depends on texlive-generic-recommended which is no longer built by texlive-base. Please update your build-dependency to texlive-plain-generic.

Bug#934442: python-gabbi (build-)depends on cruft package.

2019-08-10 Thread peter green
Package: python-gabbi Version: 1.40.0-4 Severity: serious Tags: bullseye, sid python-gabbi (build-)depends on the python-jsonpath-rw-ext binary package which is no longer built by the corresponding source package. It's probably time to drop python 2 support from this package.

Bug#934441: python-etcd3gw (build-)depends on cruft package.

2019-08-10 Thread peter green
Package: python-etcd3gw Version: 0.2.1-1 Severity: serious Tags: patch, bullseye, sid python-etcd3gw (build-)depends on the python-futurist binary package which is no longer built by the corresponding source package. It's probably time to drop python 2 support from this package. I notice that

Bug#934336: python-shade: (build-)depends on cruft packages.

2019-08-09 Thread peter green
Package: python-shade Version: 1.30.0-2 Severity: serious Tags: bullseye, sid python-shade (build-)depends on the python-os-client-config and python-openstacksdk binary packages which are no longer built by the corresponding source packages. It looks like it's time to drop python2 support

Bug#934232: python-cutadapt: non-buildd binaries.

2019-08-08 Thread peter green
Package: python-cutadapt Severity: serious Version: 2.4-1 The release team have decreed that non-buildd binaries can no longer migrate to testing. Please make a source-only upload so your package can migrate.

Bug#934233: python-dnaio: non-buildd binaries.

2019-08-08 Thread peter green
Package: python-dnaio Severity: serious Version: 0.3-1 The release team have decreed that non-buildd binaries can no longer migrate to testing. Please make a source-only upload so your package can migrate.

Bug#934095: python-os-testr (build-)depends on cruft package.

2019-08-06 Thread peter green
Package: python-os-testr Version: 1.0.0-4 Severity: serious Tags: bullseye, sid The python-os-testr source package build-depends on the python-stestr binary package and the python-os-testdir binary package depends on it. The python-stestr binary package is no longer built by the python-stestr

Bug#914151: dlz-ldap-enum FTBFS with bind9 9.11.5

2019-07-25 Thread peter green
Tags 914151 +patch Thanks This turned out to be a simple case of a missing include, a debdiff can be found at https://debdiffs.raspbian.org/main/d/dlz-ldap-enum/dlz-ldap-enum_1.1.0-1%2Brpi1.debdiff . No intent to NMU in Debian.

Bug#932976: quagga build-depends on cruft package.

2019-07-25 Thread peter green
Package: quagga Version: 1.2.4-3 Tags: bullseye, sid, patch Severity: serious quagga build-depends on texlive-generic-reccomended which is no longer built by the texlive-base source package. Please build-depend on texlive-plain-generic instead.

Bug#932975: octave build-depends on cruft package.

2019-07-25 Thread peter green
Package: octave Version: 3.5.2-1 Tags: bullseye, sid, patch Severity: serious octave build-depends on texlive-generic-reccomended which is no longer built by the texlive-base source package. Please build-depend on texlive-plain-generic instead.

Bug#932972: r-base build-depends on cruft package.

2019-07-25 Thread peter green
Package: r-base Version: 3.5.2-1 Tags: bullseye, sid, patch Severity: serious r-base build-depends on texlive-generic-reccomended which is no longer built by the texlive-base source package. Please build-depend on texlive-plain-generic instead.

Bug#932951: pspp build-depends on cruft package.

2019-07-24 Thread peter green
Package: pspp Version: 3.5.2-1 Tags: bullseye, sid, patch Severity: serious pspp build-depends on texlive-generic-reccomended which is no longer built by the texlive-base source package. Please build-depend on texlive-plain-generic instead.

Bug#932949: gri build-depends on cruft package.

2019-07-24 Thread peter green
Package: gri Version: 3.5.2-1 Tags: bullseye, sid, patch Severity: serious gri build-depends on texlive-generic-reccomended which is no longer built by the texlive-base source package. Please build-depend on texlive-plain-generic instead.

Bug#932942: vistrails depends on cruft package.

2019-07-24 Thread peter green
Package: vistrails Severity: serious Version: 2.2.4-1 Tags: bullseye, sid vistrails depends on python-usagestats which is no longer built by the usagestats source package. If you want your Package to remain in Debian you probablly need to migrate to python3.

Bug#932938: librust-docopt-dev (build-)depends on obsolete virtual package.

2019-07-24 Thread peter green
Package: librust-docopt-dev Version: 1.0.2-1 Severity: serious Tags: buster, sid librust-docopt-dev depends on the virtual package librust-strsim-0.7+default-dev which is no longer provider by librust-strsim-dev. The virtual package seems to have been renamed to 

Bug#932650: swift-bench: (build-)depends on cruft package.

2019-07-21 Thread peter green
Package: swift-bench Severity: serious Tags: bullseye, sid swift-bench (build-)depends on the python-swiftclient binary package which is no longer built by the python-swiftclient source package. You probably need to migrate to python3

Bug#932649: swauth: (build-)depends on cruft package.

2019-07-21 Thread peter green
Package: swauth Severity: serious Tags: bullseye, sid swauth (build-)depends on the python-swiftclient binary package which is no longer built by the python-swiftclient source package. You probably need to migrate to python3

  1   2   3   4   5   6   7   8   9   10   >