Bug#883938: RFT: Candidate fix for boot failure of Debian 8.10 on various x86 systems

2017-12-14 Thread Chris Hofstaedtler
Hi, * Ben Hutchings [171214 11:37]: > Apologies for this regression. Salvatore Bonaccorso has tracked down > which change in 3.16-stable triggers the crash, and I identified some > related upstream changes which appear to fix it. An updated package is > available at: > >

Bug#904870: autopkgtest: calls su with an empty username, thus fails

2018-07-28 Thread Chris Hofstaedtler
Package: autopkgtest Version: 5.4.1 Severity: grave Justification: renders package unusable Dear autopkgtest Maintainers, In various situations autopkgtest calls /bin/su with an empty string for the username. The old su (from login) ignored this, but newer su versions (from util-linux 2.32-0.2)

Bug#896085: tk8.5: Time to remove from Debian

2018-08-09 Thread Chris Hofstaedtler
Control: clone 896085 -2 Control: reassign -2 ftp.debian.org Control: retitle -2 RM: tk8.5 -- ROQA; obsolete Control: affects -2 src:tk8.5 * Sergei Golovan [180809 20:47]: > Source: tk8.5 > > Tcl/Tk 8.5 has reached its end-of-life, so it's time to remove it from Debian. > Applications which use

Bug#889556: monotone: (Build-)Depends on obsolete libbotan1.10-dev

2018-08-09 Thread Chris Hofstaedtler
Hi Markus, * Markus Wanner [180809 20:52]: > On 03/09/2018 10:32 AM, Jack Lloyd wrote: > > 2.4.0 was just (in last week or so) packaged for buster - > > https://packages.debian.org/buster/libbotan-2-4 > > oh, very nice. Looks like I searched only "stable". Thank you for the hint. Is there any

Bug#889557: ovito: (Build-)Depends on obsolete libbotan1.10-dev

2018-08-09 Thread Chris Hofstaedtler
Dear ovito Maintainers, is there any update on progress of porting to botan2, or at least moving off botan1.10? Cheers, Chris

Bug#905409: upgrade of util-linux and login break the xhost command for other users

2018-08-08 Thread Chris Hofstaedtler
* Helge Kreutzmann [180808 18:57]: > On Tue, Aug 07, 2018 at 08:20:23PM +0100, Simon McVittie wrote: > > Andreas already asked for a merge request, so it seems that proposing a > > patch would indeed be welcome. > > I'll do, incorporating your excellent explaination. I'll do so until > the end

Bug#866110: multipath-tools: mpathpersist segfaults. Newer version is available and fixed!

2018-07-22 Thread Chris Hofstaedtler
Upstream commit is: https://git.opensvc.com/gitweb.cgi?p=multipath-tools/.git;a=commit;h=fef089a6610f94a847541069f3008a5708044015

Bug#903285: Bug #903285 in bundler marked as pending

2018-07-23 Thread Chris Hofstaedtler
Control: tag -1 pending Hello, Bug #903285 in bundler reported by you has been fixed in the Git repository and is awaiting an upload. You can see the commit message below, and you can check the diff of the fix at:

Bug#904340: netgen: Depends on obsolete tk8.5

2018-07-23 Thread Chris Hofstaedtler
Package: netgen Version: 4.9.13.dfsg-11 Severity: serious In #896085 it has been suggested that tk8.5 should go away before stretch. This bug informs you of this ;-) C.

Bug#908136: src:h2o: FTBFS on amd64

2018-09-06 Thread Chris Hofstaedtler
Package: src:h2o Version: 2.2.5+dfsg1-6 Severity: serious Dear Maintainer, when trying to build h2o from source on amd64, inside sbuild, it fails: h2o server (pid:14780) is ready to serve requests fetch-ocsp-response (using OpenSSL 1.1.1-pre9 (beta) 21 Aug 2018) failed to extract

Bug#907322: [DRE-maint] Bug#907322: jekyll: NMU in deferred/4

2018-09-11 Thread Chris Hofstaedtler
* Gianfranco Costamagna [180911 06:48]: > control: tags -1 patch pending > the following diff is now in deferred/4, please let me know if you want me to > cancel or reschedule it. Please commit your changes on salsa; feel free to do a team upload (with no delay) then. Cheers, Chris

Bug#913163: (Security) bugs in pdns in stretch

2018-11-10 Thread Chris Hofstaedtler
Hi everyone, thanks for reporting bugs against pdns in stretch. I intend to upload a new version to stretch to fix those bugs, but I cannot test all involved components personally. Please give this version a shot: https://people.debian.org/~zeha/pdns/source/ For your convenience, amd64 binaries

Bug#913163: (Security) bugs in pdns in stretch

2018-11-23 Thread Chris Hofstaedtler
* Moritz Mühlenhoff [181123 14:09]: > On Sat, Nov 10, 2018 at 04:34:48PM +0100, Chris Hofstaedtler wrote: > > Hi everyone, > > > > thanks for reporting bugs against pdns in stretch. > > I intend to upload a new version to stretch to fix those bugs, but I > > ca

Bug#816640: Bug #816640 in ruby-eventmachine marked as pending

2019-01-03 Thread Chris Hofstaedtler
* Hideki Yamane [190103 03:40]: > On Fri, 16 Feb 2018 13:48:16 + z...@debian.org wrote: > > Bug #816640 in ruby-eventmachine reported by you has been fixed in the > > Git repository and is awaiting an upload. You can see the commit > > message below, and you can check the diff of the fix at:

Bug#919486: osinfo-db: diff for NMU version 0.20181120-1.1

2019-04-05 Thread Chris Hofstaedtler
Control: tags 919486 - pending Hi, * Guido Günther [190405 22:04]: > If we had stable links for CD images (3813797) this would be different > but I did not get around to look into this yet so help there would be > appreciated and would make this fixable for real. > > For now it would be cool

Bug#924634: libuima-as-java depends on the removed libspring-jms-java

2019-04-06 Thread Chris Hofstaedtler
Control: severity 924634 wishlist * Matthias Klose [190406 12:53]: > libuima-as-java depends on the removed libspring-jms-java in unstable. Lowering severity as libspring-jms-java is still built by libspring-java (4.3.22-3). If newer developments show up, please re-raise the severity. Cheers,

Bug#925498: Subject: Re: Bug#925498: afterstep: v2.2.12-12 FTBFS due to patch#57 generates libAfterImage/Makefile incorrectly.

2019-04-06 Thread Chris Hofstaedtler
Control: tags -1 + moreinfo Control: severity -1 normal * Jim Turner [190406 15:00]: > > The configure script is regenerated > > during the build process, so there > > is no need to change it via a patch. > > I was wondering a/b that, but it DOESN'T rebuild configure for me???!!!, > after

Bug#909750: applications tries to write to /usr/* directories via libfontconfig1

2019-04-06 Thread Chris Hofstaedtler
* Thierry fa...@linux.ibm.com [190406 14:35]: > > >The only occurrence I'm seeing on my system is: > > > > > >openat(AT_FDCWD, "/usr/lib/firefox/fonts/.uuid.TMP-EWjEq0", > > >O_RDWR|O_CREAT|O_EXCL|O_CLOEXEC, 0600) = -1 EACCES (Permission denied) > > > > Now it's the only occurrence for me, too.

Bug#924762: a bug in xfce4? / triage

2019-04-06 Thread Chris Hofstaedtler
Control: reassign -1 xfce4 Control: severity -1 normal * zieg...@uni-freiburg.de [190406 15:06]: > > "xterm -T ä" crashes the X-server too. > > So it seems rather to be a bug in xfce4. Given the bug history, this would look more like an isolated problem, certainly not a bug in emacs (which is

Bug#916145: closure-compiler: Not working with recent JS code

2019-04-06 Thread Chris Hofstaedtler
* Roland Gruber [190406 16:07]: > the current version is so old that it got incompatible with recent JS code. > E.g. jQuery 3.3.1 cannot be minified as the tool reports parsing errors. > > Please either update the tool or remove it from the archive. This is now > 5 years in unmaintained state.

Bug#924966: pdns: diff for NMU version 4.1.6-1.1

2019-03-31 Thread Chris Hofstaedtler
* Salvatore Bonaccorso [190329 17:39]: > Control: tags 924966 + patch > Control: tags 924966 + pending > > > Dear maintainer, > > I've prepared an NMU for pdns (versioned as 4.1.6-1.1) and > uploaded it to DELAYED/5. Please feel free to tell me if I > should delay it longer. > > There is a

Bug#919486: osinfo-db: diff for NMU version 0.20181120-1.1

2019-04-06 Thread Chris Hofstaedtler
Hi Guido, * Guido [190406 19:37]: > On Fri, Apr 05, 2019 at 11:50:54PM +0200, Chris Hofstaedtler wrote: > > * Guido Günther [190405 22:04]: > > > If we had stable links for CD images (3813797) this would be different > > > but I did not get around to look into t

Bug#924151: grub2-common: wrong grub.cfg for efi boot and fully encrypted disk

2019-04-06 Thread Chris Hofstaedtler
* Colin Watson [190406 19:50]: > Hmm. I tried doing that in a virt-manager VM as follows: > > * started with a buster alpha-5 netinst ISO rather than the full DVD >image, since my bandwidth is very limited > * configured VM to use UEFI > * guided partitioning; selected full-disk

Bug#917847: ipsec-tools is unsuitable for inclusion in Debian

2019-07-11 Thread Chris Hofstaedtler
Hey Noah, * Noah Meyerhans [190711 14:17]: > If you disagree that ipsec-tools should be removed from future Debian > releases, please say so now. As we haven't really heard from anyone, should I go ahead and ask for final removal via ftpmaster? Cheers, Chris

Bug#927946: python-audit: SWIG-related type errors render module unusable

2019-04-25 Thread Chris Hofstaedtler
Dear Maintainer, the following patch fixes the problem for me, tested locally. Please consider applying it. Cheers, Chris --- audit-2.8.4.orig/bindings/swig/src/auditswig.i +++ audit-2.8.4/bindings/swig/src/auditswig.i @@ -41,6 +41,6 @@ typedef unsigned __u32; typedef unsigned uid_t; %include

Bug#909750: applications tries to write to /usr/* directories via libfontconfig1

2019-04-17 Thread Chris Hofstaedtler
* Niels Thykier [190413 18:28]: > Vincas Dargis: > > On 2019-04-13 12:50, Niels Thykier wrote: > >> What is the status of this bug? AFAICT, we have *some* fixes from > >> upstream but Chris's mail implies that the bug is not completely fixed. > > > > This bug disappeared from my logs long time

Bug#927180: firefox-esr: does not launch (Power Mac G5)

2019-04-24 Thread Chris Hofstaedtler
Control: severity -1 normal * Noah Wolfe [190424 11:16]: > I installed firefox-esr via ftp.ports.debian.org, as I'm running the ppc64 > (BE) > port, and when launched from terminal, it puts out "Segmentation fault" > instead > of opening the application. Thank you for your report, but I'm

Bug#959402: yaml-cpp: FTBFS on mipsel

2020-05-04 Thread Chris Hofstaedtler
Hi Boyuan Yang, * Boyuan Yang [200504 09:03]: > Unfortunately yaml-cpp currently FTBFS on mipsel architecture. Build logs > indicate that it might be caused by the exhaustion of memory: [..] > as: out of memory allocating 7161456 bytes after a total of 573444096 bytes [..] > I'm not sure what's

Bug#959783: util-linux: 2.35.1-1 FTBFS in pbuilder chroot: testsuite fails in misc/fallocate and misc/mountpoint

2020-05-05 Thread Chris Hofstaedtler
Control: severity -1 important Control: tags -1 + upstream Hi Mark Hindley, thanks for your report. See below. * Mark Hindley [200505 13:27]: > Unfortunately the testsuite fails when building in a pbuilder/cowbuilder > chroot. In particular misc/fallocate and misc/mountpoint. > > The issues

Bug#961889: src:gnutls28: Fails building chains with expired intermediate regardless of trust store

2020-05-30 Thread Chris Hofstaedtler
Package: src:gnutls28 Version: 3.6.7-4+deb10u3 Severity: grave Justification: renders package unusable Hi, gnutls appears to fail building a certificate chain, if: - the server sends an alternate chain with an expired intermediate - a matching root is in the local trust store. This was found

Bug#963704: libmount-dev: missing libcryptsetup-dev dependency breaks mount.pc

2020-06-25 Thread Chris Hofstaedtler
Hi, * Pino Toscano [200625 17:45]: > util-linux 2.35.2-5 added support for dm-verify (#951048); apparently > this results in libmount requiring it as private dependency: > .. > > Easily fixed by adding libcryptsetup-dev dependency to libmount-dev; > patch attached for this. Thanks for pushing

Bug#963287: notmuch: FTBFS: grotty: ():1662: fatal error: output error

2020-06-22 Thread Chris Hofstaedtler
* Michael Meskes [200622 15:42]: > > 'm adding the maintainers of util-linux (bsdextrautils) and > > bsdmainutils > > to Cc. Which path forward do you see for this issue? A similar issue > > seems to affect many packages, such as: > > ... > > It seems to me there are two options here, either we

Bug#963177: calendar: trying to overwrite '/etc/calendar/default', which is also in package bsdmainutils 12.1.1

2020-06-20 Thread Chris Hofstaedtler
Hi Josh, I figured you might be interested in this, too, as IIRC the original patch was from you: * Thorsten Glaser [200621 02:04]: > Selecting previously unselected package calendar. > (Reading database ... 406194 files and directories currently installed.) > Preparing to unpack

Bug#963721: [pkg-cryptsetup-devel] Bug#963721: libcryptsetup12 v2:2.3.3-1 seems to be breaking libssl somehow

2020-06-28 Thread Chris Hofstaedtler
Control: retitle -1 libmount1 memory corruption affecting libjansson users Hi everyone, * Michael Biebl [200627 21:18]: > Control: affects -1 firewalld > > On Sat, 27 Jun 2020 19:46:57 +0200 Guilhem Moulin > wrote: > > On Sat, 27 Jun 2020 at 01:08:49 -0400, Christian Weeks wrote: > > >>

Bug#963721: [pkg-cryptsetup-devel] Bug#963721: libcryptsetup12 v2:2.3.3-1 seems to be breaking libssl somehow

2020-06-28 Thread Chris Hofstaedtler
Hi Michael, * Michael Biebl [200628 03:30]: > Am 27.06.20 um 21:14 schrieb Michael Biebl: > > [16014.637459] traps: firewalld[35622] general protection fault > > ip:7f981342d7b2 sp:7ffe6abe4ed0 error:0 in > > libjansson.so.4.11.1[7f981342c000+8000] > > Attached is a back trace. It appears you

Bug#963721: [pkg-cryptsetup-devel] Bug#963721: libcryptsetup12 v2:2.3.3-1 seems to be breaking libssl somehow

2020-06-28 Thread Chris Hofstaedtler
Control: clone -1 -2 Control: retitle -1 libmount1: pulls in libssl, breaking statically-linked-to-libssl software Control: severity -1 wishlist Control: tags -1 wontfix Control: retitle -2 libjson-c and libjansson both export json_object_iter_next Hi Christian, Guilhem, For Steam issues,

Bug#963933: glib2.0: autopkgtext: ld: cannot find -lcryptsetup

2020-06-28 Thread Chris Hofstaedtler
Source: glib2.0 Severity: serious Version: 2.64.3-1 Dear glib2.0 Maintainers, the autopkgtest suite offers quite interesting behaviour: With an installed libcryptsetup-dev, ld fails with "cannot find -lcryptsetup". Log:

Bug#963932: Duplicate symbol json_object_iter_next in json-c, jansson

2020-06-28 Thread Chris Hofstaedtler
the case in Debian for firewalld, which loads libmount1 and libnftables1, which use json-c and jansson respectively. firewalld then crashes because of this. Some detail: * Michael Biebl [200628 21:27]: > Am 28.06.20 um 21:16 schrieb Chris Hofstaedtler: > > > $ ldd /usr/lib/x86_

Bug#963932: Duplicate symbol json_object_iter_next in json-c, jansson

2020-06-28 Thread Chris Hofstaedtler
* Chris Hofstaedtler [200628 20:10]: > your libraries BOTH export a symbol named json_object_iter_next, > causing crashes for binaries that end up loading both (possibly > transitively). [..] Upstream bugs: https://github.com/json-c/json-c/issues/621 https://github.com/akheron/janss

Bug#963933: glib2.0: autopkgtext: ld: cannot find -lcryptsetup

2020-06-30 Thread Chris Hofstaedtler
* Simon McVittie [200629 01:16]: > On Sun, 28 Jun 2020 at 22:00:58 +0200, Chris Hofstaedtler wrote: > > the autopkgtest suite offers quite interesting behaviour: > > With an installed libcryptsetup-dev, ld fails with "cannot find > > -lcryptsetup". > ...

Bug#963933: glib2.0: autopkgtext: ld: cannot find -lcryptsetup

2020-06-30 Thread Chris Hofstaedtler
* Simon McVittie [200630 11:23]: > On Tue, 30 Jun 2020 at 10:51:39 +0200, Chris Hofstaedtler wrote: > > I'm not sure it was a good idea before. Is static linking something > > you actively want to support for glib? > > It has worked in the past, Policy says the stati

Bug#963933: glib2.0: autopkgtext: ld: cannot find -lcryptsetup

2020-07-06 Thread Chris Hofstaedtler
Hi Simon, src:util-linux will drop most static libraries in the 2.35.2-8 upload. Please change the glib2.0 autopkgtest (by dropping the static test) to allow this. Many thanks, Chris

Bug#966114: src:cyrus-imapd: Mail::JMAPTalk version 0.15 required--this is only version 0.13 at ./Cassandane/Cyrus/JMAPCore.pm

2020-07-23 Thread Chris Hofstaedtler
Package: src:cyrus-imapd Version: 3.2.2-1 Severity: serious Justification: unrelated change autopkgtest failure Dear Maintainers, the autopkgtest suite of cyrus-imapd in testing now fails with this error: ... Cloning into 'Mail-JMAPTalk.git'... Checking if your kit is complete... ... make[1]:

Bug#966597: multipath-tools: patch for newer json-c

2020-07-31 Thread Chris Hofstaedtler
Hi Gianfranco, * Gianfranco Costamagna [200731 10:30]: > Source: multipath-tools > Version: 0.8.4-2 > Severity: serious > tags: patch > > hello, attached a patch that makes it build with newer json-c Thanks! I'm considering going with a somewhat different patch given TRUE is used only once

Bug#963932: Unversioned symbol json_object_iter_next is in all of json-c, jansson, json-glib

2020-07-29 Thread Chris Hofstaedtler
Control: severity -1 important * Simon McVittie [200728 00:21]: > On Sun, 28 Jun 2020 at 22:06:13 +0200, Chris Hofstaedtler wrote: > > your libraries BOTH export a symbol named json_object_iter_next, > > causing crashes for binaries that end up loading both (possibly &