Bug#718982: docbook2x cannot be installed anymore

2013-08-08 Thread Gianfranco Costamagna
Hi Daniel thanks for the fast and prompt answer. Unfortunately I deleted the package because I wanted to upload a NMU version, and for some reason the package didn't get published anymore on mentors. I also tried to dcut the old package but also dcut file is still there. Tomorrow morning I'll

Bug#718982: docbook2x cannot be installed anymore

2013-08-09 Thread Gianfranco Costamagna
/bd2579ba06e759ae594a9f510e26abf427152726 many thanks Gianfranco Da: Daniel Leidert daniel.leid...@wgdd.de A: Gianfranco Costamagna costamagnagianfra...@yahoo.it; 718...@bugs.debian.org Inviato: Giovedì 8 Agosto 2013 20:10 Oggetto: Re: Bug#718982: docbook2x

Bug#718982: docbook2x cannot be installed anymore

2013-08-09 Thread Gianfranco Costamagna
Ok for some other obscure reasons now mentors works again https://mentors.debian.net/package/docbook2x - Messaggio originale - Da: Daniel Leidert daniel.leid...@wgdd.de A: Gianfranco Costamagna costamagnagianfra...@yahoo.it; 718...@bugs.debian.org Cc: Inviato: Venerdì 9 Agosto

Bug#718982: docbook2x cannot be installed anymore

2013-08-07 Thread Gianfranco Costamagna
Package: docbook2x Version: 0.8.8-8 Severity: serious Dear Maintainer, please consider upload of my package available on mentors [1], because now docbook2x cannot be installed on sid anymore. I cannot build/rebuild anymore packages I maintain in debian. I can adopt the package. Gianfranco

Bug#718982: (no subject)

2013-08-07 Thread Gianfranco Costamagna
From the log [snip] Setting up libxml-parser-perl (2.41-1+b1) ... Setting up libxml-sax-expat-perl (0.40-2) ... update-perl-sax-parsers: Registering Perl SAX parser XML::SAX::Expat with priority 50... update-perl-sax-parsers: Updating overall Perl SAX parser modules info file... Replacing config

Bug#684828: (no subject)

2013-10-30 Thread Gianfranco Costamagna
Sorry why this bug is still open? uglifyjs reached testing months ago, I think this bug can be closed, in order to allow backbone reach testing bests, Gianfranco -- To UNSUBSCRIBE, email to debian-bugs-rc-requ...@lists.debian.org with a subject of unsubscribe. Trouble? Contact

Bug#746863: FTBFS src:insighttoolkit4

2014-07-12 Thread Gianfranco Costamagna
Hi, Il Mercoledì 2 Luglio 2014 13:15, Gert Wollny gw.foss...@gmail.com ha scritto: My bad, I got irritated by the parallel build. The failing command seems to be /usr/bin/gccxml -fxml-start=_cable_ -fxml=/«PKGBUILDDIR»/BUILD/Wrapping/Modules/ITKCommon/vcl_complex.xml

Bug#746863: FTBFS src:insighttoolkit4

2014-07-15 Thread Gianfranco Costamagna
Hi Matt and all! Il Lunedì 14 Luglio 2014 22:09, Matt McCormick matt.mccorm...@kitware.com ha scritto: Hi, First, please note I made an error regarding the GCCXML bug tracker -- it is still in the old location. However, Steve's patch has now been merged upstream. I was able to

Bug#754884: milkyway shouldn't be in jessie

2014-07-15 Thread Gianfranco Costamagna
Source: boinc-app-milkyway Severity: serious Version: 0.18d-4 The package is slightly outdated, and not working anymore. If the new git snapshots will continue to give computation error this package I'm afraid won't be ready for jessie. thanks Gianfranco -- To UNSUBSCRIBE, email to

Bug#746863: FTBFS src:insighttoolkit4

2014-07-15 Thread Gianfranco Costamagna
Hi again to all, Il Martedì 15 Luglio 2014 13:03, Gianfranco Costamagna costamagnagianfra...@yahoo.it ha scritto: Hi Matt and all!   Il Lunedì 14 Luglio 2014 22:09, Matt McCormick matt.mccorm...@kitware.com ha scritto:   Hi,   First, please note I made an error regarding

Bug#746863: [Debian-med-packaging] Bug#746863: FTBFS src:insighttoolkit4

2014-07-16 Thread Gianfranco Costamagna
@@ -1,3 +1,11 @@ +insighttoolkit4 (4.5.2-4) unstable; urgency=medium + +  * Team upload. +  * control.in: bump gccxml dep to 0.9.0+git20140716-1 to ensure +    up-to-date support for GCC 4.9. + + -- Gianfranco Costamagna costamagnagianfra...@yahoo.it  Wed, 16 Jul 2014 12:07:29 +0200

Bug#749128: (no subject)

2014-07-23 Thread Gianfranco Costamagna
:23:50.0 +0200 @@ -1,3 +1,12 @@ +filezilla (3.9.0.1-0.1) unstable; urgency=medium + +  * Non-maintainer upload. +  * New upstream release (Closes: #749128) +  * Switch to gnutls28-dev, required by configure script. +  * Drop 02_wx3.0-compat.patch. + + -- Gianfranco Costamagna costamagnagianfra

Bug#754220: Re: virtualbox: FTBFS with GCC 4.9 as default

2014-07-25 Thread Gianfranco Costamagna
Hi to all, unfortunately I'm just a DM, not a DD and I cannot upload anything :( The major showstopper is that somebody should give a test try to the new package, to be sure it works with xorg-server 1.16 and the mesa showliness (with 3D acceleration) has been fixed Also the guest-additions

Bug#755327: Upstream commit

2014-07-31 Thread Gianfranco Costamagna
-2.0.4/debian/changelog 2014-07-31 11:11:23.0 +0200 @@ -1,3 +1,11 @@ +gridsite (2.0.4-3.1) unstable; urgency=medium + +  * Non-maintainer upload. +  * Cherry-pick upstream commit 2124d471f9fc +    to fix a FTBFS with curl = 7.37.1 (Closes: #755327) + + -- Gianfranco Costamagna

Bug#755327: gridsite: FTBFS: htcp.c:65:27: error: 'CURLOPT_FILE' undeclared (first use in this function)

2014-08-03 Thread Gianfranco Costamagna
Il Domenica 3 Agosto 2014 2:33, Vincent Cheng vch...@debian.org ha scritto: Hi Gianfranco, Hi dear Vincent and Colin since the upload is already in deferred I don't think there is much here rather than finding what breaked your patch. Your proposed debdiff doesn't seem to apply

Bug#752544: Fixed also in experimental

2014-09-21 Thread Gianfranco Costamagna
Hi, according to #50, this bug is fixed from upstream for versions greater than 2.41.3. Since the bug wasn't automatically been marked as fixed for the experimental branch (now uploaded in unstable), I'm marking it as such, letting the package (hopefully) reach testing. thanks, Gianfranco

Bug#763078: confirmed llvm change broke ghc

2014-09-29 Thread Gianfranco Costamagna
Hi Joey, llvm maintainer (Sylvestre) says that llvm-3.4 is going to disappear (not before jessie, but somewhen after), and llvm-3.5 is built correctly on arm{el,hf}. Isn't it better to just upload with llvm-3.5 and do some binNMUs instead of using the old one and be hit (or be a blocker) for

Bug#763238: gambas3: FTBFS: dh_install: gambas3-gb-jit missing files (usr/lib/gambas3/gb.jit.*), aborting

2014-09-29 Thread Gianfranco Costamagna
Hi José, I prepared a patch for this RC and submitted upstream. It has been accepted (with a little modification) and committed also on debian git http://anonscm.debian.org/cgit/pkg-gambas/gambas3.git/tree/debian/patches/fix-llvm-3.5.patch Feel free to test and upload at your wish :) thanks,

Bug#762403: (no subject)

2014-10-04 Thread Gianfranco Costamagna
Hi, the failing architectures mentioned above seems to have been built correctly the latest version 3.14.1-1. However now it has failed for hurd and sparc (I noticed after sending the control command, sorry), but since they aren't release architectures I guess this bug can be closed :)

Bug#713040: Patch available

2014-10-05 Thread Gianfranco Costamagna
Hi Jonas, I'm willing to help in fixing this bug, however the patch is really trivial, so I'm wondering if there is something behind the scenes that is preventing this bug to be fixed (do you want to ship the package in jessie?), so I'm giving you my help in fixing/testing it if necessary.

Bug#713040: Patch available

2014-10-06 Thread Gianfranco Costamagna
Hi Jonas, As requested, I took over the package maintenance and put the package on mentors. Notable changes: * Acknowledge previous NMU. * Set myself and Jonas as Uploaders. * Set Debian Fonts Task Force as Maintainer. * Bump std-version to 3.9.6, no changes required. * Bump

Bug#713040: Bug#659734: Bug#713040: Patch available

2014-10-06 Thread Gianfranco Costamagna
As you wish Jonas ;) dropped and reuploaded on mentors :) cheers, Gianfranco -- To UNSUBSCRIBE, email to debian-bugs-rc-requ...@lists.debian.org with a subject of unsubscribe. Trouble? Contact listmas...@lists.debian.org

Bug#741580: poedit: Please update to use wxwidgets3.0

2014-06-06 Thread Gianfranco Costamagna
Hi all, I did a quick check of the poedit trac system. Seems that ftl is needed to build poedit with wx-3.0 http://trac.poedit.net/ticket/568 Do you plan to enable ftl in wx? Attaching a log file with the debdiff of the trivial patch diff -Nru wxwidgets3.0-3.0.0/debian/rules

Bug#746863: Cannot reproduce

2014-06-06 Thread Gianfranco Costamagna
tags 746863 moreinfo + unreproducible severity 746863 normal thanks Hi Mattias, since this bug report a lot of changes have appeared in gcc-4.9 headers, and now following a discussion on debian-med mail list seems that nobody has been able to reproduce this problem. Feel free to reopen if

Bug#746863: FTBFS src:insighttoolkit4

2014-07-02 Thread Gianfranco Costamagna
Il Mercoledì 2 Luglio 2014 12:50, Gert Wollny gw.foss...@gmail.com ha scritto: T here must be something wrong with your setup because what is failing is a plain CC compile command /usr/bin/cc that should never include the files from /usr/share/gccxml-0.9/GCC/4.9/ as it does

Bug#751432: (no subject)

2014-07-03 Thread Gianfranco Costamagna
Hi, what is the status of this bug? the severity now is RC, so I grab the patch and uploaded on mentors [1] Can anybody from the maintainer team please give a feedback/upload? [1] https://mentors.debian.net/package/gdcm thanks Gianfranco -- To UNSUBSCRIBE, email to

Bug#736814: boinc-client recommends the removed ia32-libs

2014-01-26 Thread Gianfranco Costamagna
Hi Adrian, thanks for your bug report. Unfortunately this bug has already been fixed in the latest git on alioth. Will be fixed in the next upload, but I cannot do it, since I'm a DM and for the introduction of the server packages this upload will need an action from a DD and go in the new

Bug#738849: Please enable webview support for wx3.0

2014-02-13 Thread Gianfranco Costamagna
Package: libwxgtk3.0-0 Severity: serious The wx3.0 package *should* depend from libwebkitgtk-3.0-dev. The last boinc release needs webwview support, and I finally spotted why I didn't succeed in building it on a clean debian environment. Your build log clearly says that you are enabling webview

Bug#738849: Acknowledgement (Please enable webview support for wx3.0)

2014-02-13 Thread Gianfranco Costamagna
Attaching the debdiff (I didn't bump the std-version) After further looking at the configure log I found some problems: - you use the embedded libnotify because you don't add the debian one - you don't enable sdl support - you don't enable libmspack support I attached two debdiff, one fixing

Bug#745228: flex: Flex 2.5.39-3 has a typo in installman

2014-04-19 Thread Gianfranco Costamagna
Package: flex Version: 2.5.39-3 Severity: serious Dear Manoj, (opening this bug just to prevet flex reach testing) This commit [1] introduced a bug in rules files (probably a typo) -override_dh_installman: +verride_dh_installman: this prevents the override_dh_installman to be executed. Also

Bug#744896: upstream fixed this bug

2014-04-23 Thread Gianfranco Costamagna
tags 744896 fixed-upstream Hi, I would like to inform you that the bug has been fixed upstream https://gist.github.com/FROGGS/11191811 thanks, Gianfranco -- To UNSUBSCRIBE, email to debian-bugs-rc-requ...@lists.debian.org with a subject of unsubscribe. Trouble? Contact

Bug#731823: Fixed in mentors, can anybody please sponsor?

2014-05-09 Thread Gianfranco Costamagna
Hi * file vtkXYPlotActor.class vtkXYPlotActor.class: compiled Java class data, version 49.0 (Java 1.5) file vtkTypeInt16Array.class vtkTypeInt16Array.class: compiled Java class data, version 49.0 (Java 1.5) the trick was this patch +--- a/CMake/vtkWrapJava.cmake b/CMake/vtkWrapJava.cmake

Bug#747108: I: Fixed in mentors, can anybody please sponsor?

2014-05-09 Thread Gianfranco Costamagna
Hi * Like for the other bug 731823 I did the same trick for this RC bug. However I'm not sure if the TCL patches from Jordi should be applied here too or not. the trick was this patch --- vtk6-6.0.0.orig/Wrapping/Java/CMakeLists.txt +++ vtk6-6.0.0/Wrapping/Java/CMakeLists.txt @@ -237,7

Bug#747108: I: Fixed in mentors, can anybody please sponsor?

2014-05-09 Thread Gianfranco Costamagna
...@debian.org ha scritto: Hi Gianfranco, thanks for the help! I integrated your fix into the next upload. Regards Anton 2014-05-09 19:03 GMT+02:00 Gianfranco Costamagna costamagnagianfra...@yahoo.it: Hi * Like for the other bug 731823 I did the same trick for this RC bug. However I'm

Bug#731823: Bug#747108: I: Fixed in mentors, can anybody please sponsor?

2014-05-10 Thread Gianfranco Costamagna
-maint/vtk.git;a=commitdiff;h=5e721d4f2721b41c528ccd5960e6196ff4a77318 Anton 2014-05-10 0:09 GMT+02:00 Gianfranco Costamagna costamagnagianfra...@yahoo.it: Hi Anton, Thanks to you for the upload! Since you are in the debian science team, can you please also upload vtk? http://bugs.debian.org

Bug#731823: Not fixed.

2014-05-10 Thread Gianfranco Costamagna
Hi all, I grabbed the deb from debian incoming and this bug is NOT fixed. Can you please upload again with the real fix from mentors? There is also a build failure on kfreebsd-amd64, don't know if related to this fix

Bug#749292: (no subject)

2014-05-26 Thread Gianfranco Costamagna
Can you please git add debian/patches/wx-config-conditionalise-webview-in-std.patch and commit? I think you forgot to add the patch (I saw it in incoming) :) The patch is really nice for the debian problem, however I was thinking as you said in the other bug about a more general problem,

Bug#749843: (no subject)

2014-05-30 Thread Gianfranco Costamagna
Thanks Olly for this, it is really good to have a tracker for this issue! We are discussing the transition here https://lists.alioth.debian.org/pipermail/pkg-boinc-devel/2014-May/thread.html https://lists.alioth.debian.org/pipermail/pkg-boinc-devel/2014-May/005523.html

Bug#749843: Tagging the bug severity as important, to let current boinc version reach testing

2014-05-31 Thread Gianfranco Costamagna
tag 749843 important thanks -- To UNSUBSCRIBE, email to debian-bugs-rc-requ...@lists.debian.org with a subject of unsubscribe. Trouble? Contact listmas...@lists.debian.org

Bug#729158: ia64 not keeping up

2014-01-07 Thread Gianfranco Costamagna
Since ia64 isn't keeping up in debian I think this bug is the only blocker left for the testing migration Ivo, how do you think about closing it? thanks, Gianfranco

Bug#739663: Processed: libboinc7: fails to upgrade from 'wheezy' - trying to overwrite /usr/lib/libboinc_zip.so.7

2014-02-21 Thread Gianfranco Costamagna
Hi Andreas, I tried to add a Break+Replaces, but it didn't work, I think because now boinc-dev is not a real package anymore, just a transition virtual package. For this reason I only added a breaks on libboinc7, and I tested on a virtual machine. It seems to be working, but this is the first

Bug#739663: Processed: libboinc7: fails to upgrade from 'wheezy' - trying to overwrite /usr/lib/libboinc_zip.so.7

2014-02-21 Thread Gianfranco Costamagna
Il Venerdì 21 Febbraio 2014 14:54, Andreas Beckmann a...@debian.org ha scritto: On 2014-02-21 14:37, Gianfranco Costamagna wrote: Hi Andreas, I tried to add a Break+Replaces, but it didn't work, How did this look like? And how did it fail? I dont't honestly remember, it failed

Bug#739999: (no subject)

2014-02-26 Thread Gianfranco Costamagna
Oh... this has been reproduce on trusty machine, I asked for a sync request of tomcat7, and the buildd failed to build from source https://launchpadlibrarian.net/167631874/buildlog_ubuntu-trusty-i386.tomcat7_7.0.52-1_FAILEDTOBUILD.txt.gz I don't know the rationale of this problem, because I

Bug#735502: (no subject)

2014-03-13 Thread Gianfranco Costamagna
Since nobody fixed this bug so far I took the patch from Octavio (with a great thanks), tweaked it a little bit (I cannot sign with your key, so I changed the signature but gave your name in changelog and added this bug reference that you forgot), and uploaded on mentors  

Bug#754982: Another RC bug needs fixing

2014-08-05 Thread Gianfranco Costamagna
Hi Thomas, would you mind to cherry-pick the patch in #718624 to fix the other RC bug in the package?  Would be nice to fix all the RC bugs in a row! have many thanks, Gianfranco -- To UNSUBSCRIBE, email to debian-bugs-rc-requ...@lists.debian.org with a subject of unsubscribe. Trouble?

Bug#757120: The package doesn't build the debian file

2014-08-05 Thread Gianfranco Costamagna
Package: googleearth-package Version: 1.1.0 Severity: serious Justification: makes the program almost useless tags:patch the fix is fairly trivial, taken from the ubuntu bug report https://bugs.launchpad.net/ubuntu/+source/googleearth-package/+bug/1335021 === modified file 'debian/changelog'

Bug#756782: (no subject)

2014-08-05 Thread Gianfranco Costamagna
fixed 756782 4.6.0-1 thanks Seems that the new 4.6.0 has been built successfully, hence I'm closing this bug report now. Gianfranco -- To UNSUBSCRIBE, email to debian-bugs-rc-requ...@lists.debian.org with a subject of unsubscribe. Trouble? Contact listmas...@lists.debian.org

Bug#758184: boinc: FTBFS due to dependency errors in Makefile

2014-08-15 Thread Gianfranco Costamagna
Hi Sebastian, Source: boinc Version: 7.4.14+dfsg-1 Severity: serious Justification: fails to build from source (but built successfully in the past) boinc failed to build on the buildds with the following error: | /bin/bash ../libtool  --tag=CXX   --mode=link /usr/bin/g++ -Wall -Wextra

Bug#757120: #757120: The package doesn't build the debian file

2014-08-20 Thread Gianfranco Costamagna
Hi Vincent Il Martedì 19 Agosto 2014 10:20, Vincent Cheng vch...@debian.org ha scritto: On Tue, 5 Aug 2014 14:45:13 +0100 Gianfranco Costamagna costamagnagianfra...@yahoo.it wrote:   Package: googleearth-package   Version: 1.1.0   Severity: serious   Justification: makes the program almost

Bug#758184: boinc: FTBFS due to dependency errors in Makefile

2014-08-26 Thread Gianfranco Costamagna
(please excuse my top posting) Hi Guo and Steffen, sorry if it is taking too long, but you don't know the kind of problems I spotted in this deep code review! the makefiles are now consistent, or at least they should be. The problem was that we (I, because the gcc-4.9 patch was from me)

Bug#756104: binary removal mrpt

2014-10-17 Thread Gianfranco Costamagna
Hi Jose, In order to get them removed you have to open a bug against ftp.debian.org Feel free to copy the significant bit from this bug report https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=764859 cheers, Gianfranco -- To UNSUBSCRIBE, email to debian-bugs-rc-requ...@lists.debian.org

Bug#768831: ettercap-common, ettercap-graphical: shipping the same file: usr/share/ettercap/ettercap.png

2014-11-10 Thread Gianfranco Costamagna
| byacc-j | btyacc, not compatible after +the cmake switch. + * Add flex-old as b-d, used with bison++. + * Fix conflicting files in both common and graphical package +(Closes: #768831). + * Remove the gksu dependency, not needed anymore. + + -- Gianfranco Costamagna costamagnagianfra

Bug#769967: virtualbox-guest-utils: Starting VirtualBox Additions No suitable module for running kernel found ... failed!

2014-11-17 Thread Gianfranco Costamagna
Hi Tomas, did you upgrade your virtualbox extension pack? did virtualbox run the vboxdrv setup? did you change your kernel? I see in your log a no suitable kernel module found cheers, Gianfanco Sent from Yahoo Mail on Android, please escuse brevity, typos and top-posting.

Bug#773416: fixed in ettercap 1:0.8.1-3

2014-12-22 Thread Gianfranco Costamagna
Hi dear Raphael, fortunately oldstable is almost unaffected by this kind of CVEs, because almost all of them refers to code written after the squeeze release, anyway here we go, this should be the only patch useful for squeeze folks --- ettercap-0.7.3.orig/src/dissectors/ec_cvs.c +++

Bug#773416: fixed in ettercap 1:0.8.1-3

2014-12-22 Thread Gianfranco Costamagna
Hi Raphael, Thanks for the info! So the only remaining CVE would be https://security-tracker.debian.org/tracker/CVE-2014-9380 and https://security-tracker.debian.org/tracker/CVE-2014-9381 for the CVS dissector. yes, I think yes. BTW, https://security-tracker.debian.org/tracker/CVE-2014-9376

Bug#773416: fixed in ettercap 1:0.8.1-3

2014-12-23 Thread Gianfranco Costamagna
Hi Barak and Raphael, the patch is already above, I didn't tweak the changelog because I don't even know the best target series, and I don't know where to patch/prepare the upload. Is that debdiff sufficient or not? I can create a squeeze chroot and prepare a build, if it is enough the above

Bug#773416: fixed in ettercap 1:0.8.1-3

2014-12-23 Thread Gianfranco Costamagna
Hi Raphael, The target serie is squeeze-lts. You can upload the .dsc to mentors if you want (or just send the debdiff as attachment here). It was copy/pasted in email and lost spaces so it's best if you can resend it as proper attachment. Don't worry about this, if you have source package ready

Bug#773416: fixed in ettercap 1:0.8.1-3

2014-12-23 Thread Gianfranco Costamagna
Mentor rejected it Hello, Unfortunately your package ettercap was rejected because of the following reason: You are not uploading to one of those Debian distributions: experimental jessie jessie-backports jessie-backports-sloppy jessie-security jessie-updates oldstable oldstable-backports

Bug#773416: [DEBIAN-LTS] ettercap package

2014-12-25 Thread Gianfranco Costamagna
Hi *, nope, you seems to be modifying other patches rather than the strict necessary to fix this bug. Moreover the patch is lacking of a CVE description (actually the patch is fixing two CVEs, and the description mentions only one) (there is also no need to mention me, I'm not the author of

Bug#773416: [DEBIAN-LTS] ettercap package

2014-12-25 Thread Gianfranco Costamagna
the other looks good to me :) cheers, G. (sorry for top posting) Il Giovedì 25 Dicembre 2014 11:26, Nguyen Cong cong.nguyen...@toshiba-tsdv.com ha scritto: Hello Gianfranco Costamagna and Raphael Hertzog, Many thanks for your comments, especially Raphael :). I propose something like

Bug#773416: [DEBIAN-LTS] ettercap package

2014-12-27 Thread Gianfranco Costamagna
Hi dear Nguyen, for me if it applies to ettercap/squeeze cleanly it is fine :) Let's wait for Raphael, I don't have any more issues! Cheers, G. Il Sabato 27 Dicembre 2014 5:04, Nguyen Cong cong.nguyen...@toshiba-tsdv.com ha scritto: Dear Gianfranco Costamagna, Many thanks for your

Bug#775888: [vbox-dev] Fwd: Re: Bug#775888: virtualbox: CVE-2014-6588 CVE-2014-6589 CVE-2014-6590 CVE-2014-6595 CVE-2015-0418 CVE-2015-0427

2015-01-22 Thread Gianfranco Costamagna
Hi all, so to sum everything up: experimental: NOT AFFECTED. jessie: fixed all of them by disabling the code (attached jessie-debdiff) wheezy: fixed CVE-2015-0377, CVE-2015-0418 wheezy-bpo: I propose to backport the new 4.3.18 into bpo when it reaches testing. squeeze: no virtualbox there

Bug#775888: Re: [vbox-dev] Fwd: Re: Bug#775888: virtualbox: CVE-2014-6588 CVE-2014-6589 CVE-2014-6590 CVE-2014-6595 CVE-2015-0418 CVE-2015-0427

2015-01-21 Thread Gianfranco Costamagna
Hi Frank, that code does only exist in VBox 4.3.x, older branches are not affected. wonderful Attached. wonderful These patches are against the latest code in the respective branches but I hope they apply to these old versions. Sorry but it's not possible to support such old versions, we

Bug#775888: [vbox-dev] Fwd: Re: Bug#775888: virtualbox: CVE-2014-6588 CVE-2014-6589 CVE-2014-6590 CVE-2014-6595 CVE-2015-0418 CVE-2015-0427

2015-01-21 Thread Gianfranco Costamagna
Hi Frank the most CVEs from that CPU are related to the experimental VMSVGA implementation. This code is not documented and not announced and regular users will not use it. Therefore I suggest you to just disable that code by setting VBOX_WITH_VMSVGA= VBOX_WITH_VMSVGA3D= This will

Bug#775888: virtualbox: CVE-2014-6588 CVE-2014-6589 CVE-2014-6590 CVE-2014-6595 CVE-2015-0418 CVE-2015-0427

2015-01-27 Thread Gianfranco Costamagna
Hi Aron, can you please also followup on squeeze-bpo? (might need a kbuild backport to make it build) cheers, (thanks) G. Il Martedì 27 Gennaio 2015 13:57, Aron Xu happyaron...@gmail.com ha scritto: I'll follow-up in wheezy-backports this weekend, at that time it should land in jessie

Bug#775888: virtualbox: CVE-2014-6588 CVE-2014-6589 CVE-2014-6590 CVE-2014-6595 CVE-2015-0418 CVE-2015-0427

2015-01-27 Thread Gianfranco Costamagna
Hi Moritz, please read carefully this thread :) Could you please check back with upstream on CVE-2015-0377 and CVE-2015-0418? jessie is not affected, and wheezy has already the patch on this thread the two CVEs are for VirtualBox prior to 3.2.26, 4.0.28, 4.1.36, 4.2.28 so 4.3 not affected.

Bug#768476: openssl: Removes symbol without SONAME bump

2015-05-04 Thread Gianfranco Costamagna
What is the rationale for this? I see in the changelog: * Temporary enable SSLv3 methods again, but they will go away. so if the changelog is correct, sid is *not* affected. cheers, G Il Lunedì 4 Maggio 2015 0:48, Christoph Anton Mitterer cales...@scientia.net ha scritto: Control: tags

Bug#784245:

2015-05-04 Thread Gianfranco Costamagna
Hi All, As Joachim said in a mail where I requested the same thing: [1] (if correct) lists the compatibility matrix of ghc and llvm so 7.10 llvm 3.5 7.11 llvm 3.6 [1] http://smart-cactus.org/~ben/posts/2014-11-28-state-of-llvm-backend.html cheers, Gianfranco -- To UNSUBSCRIBE, email to

Bug#783686:

2015-05-06 Thread Gianfranco Costamagna
Attached a debdiff to fix this bug. You can also grab directly the build on DebOMatic if you want. http://debomatic-i386.debian.net/distribution#unstable/llvm-toolchain-3.4/3.4.2-14/buildlog or here http://debomatic-amd64.debian.net/distribution#unstable/llvm-toolchain-3.4/3.4.2-14 cheers,

Bug#784443: Cmake FindSSL module doesn't work anymore

2015-05-06 Thread Gianfranco Costamagna
Package: cmake Version: 3.0.2-1 Severity: Serious I Cmake maintainers, I honestly don't know where the bug belongs to, but I'm reporting against cmake. In my opinion this bug is becoming serious, since something in unstable changed and broke the builds the problem seems to be actually in the

Bug#784655: can't rebuild casablanca with newer libstdc++6 (sid)

2015-05-07 Thread Gianfranco Costamagna
Package: gcc-5 Version: 5.1.1-4 Severity: Serious Justification: Package rebuild trigger a test failure. As said, casablanca doesn't pass the testsuite anymore with libstdc++6 library. I triggered a successful build from Stretch, and upgraded packages until I upgraded libstdc++6 Preparing to

Bug#784655: can't rebuild casablanca with newer libstdc++6 (sid)

2015-05-07 Thread Gianfranco Costamagna
Hi Matthias, thanks for the quick reply are you running sid, or stretch? in plain sid the package doesn't build at all, in order to trim down the differences I started from a Stretch clean pbuilder environment, and upgraded stuff until I got the problem. is the testsuite rebuilt after the

Bug#784655: closed by Matthias Klose d...@debian.org (Bug#784655: fixed in gcc-5 5.1.1-5)

2015-05-11 Thread Gianfranco Costamagna
Hi Doko, does this mean that I need to b-d on g++-5 and export CXX=g++-5? It seems to be failing to build when mixing g++-4.9 and new libstdc++... thanks a lot for the fix! Now with gcc-5 I can build it correctly! cheers, Gianfranco Il Sabato 9 Maggio 2015 18:45, Debian Bug Tracking

Bug#784655: closed by Matthias Klose d...@debian.org (Bug#784655: fixed in gcc-5 5.1.1-5)

2015-05-11 Thread Gianfranco Costamagna
-5) On 05/11/2015 10:36 AM, Gianfranco Costamagna wrote: does this mean that I need to b-d on g++-5 and export CXX=g++-5? It seems to be failing to build when mixing g++-4.9 and new libstdc++... thanks a lot for the fix! Now with gcc-5 I can build it correctly! no, please continue to build

Bug#784655: closed by Matthias Klose d...@debian.org (Bug#784655: fixed in gcc-5 5.1.1-5)

2015-05-14 Thread Gianfranco Costamagna
Hi again Doko, is it acceptable to use g++-5 or should I reopen this RC? I don't know if there is another hidden bug here or not thanks Gianfranco Il Lunedì 11 Maggio 2015 23:28, Gianfranco Costamagna costamagnagianfra...@yahoo.it ha scritto: Hi Doko, yes, I had to force g++5 to make

Bug#785424: virtualbox: CVE-2015-3456: floppy driver host code execution

2015-05-18 Thread Gianfranco Costamagna
Hi sid/testing: - 4.3.28 is not affected (upload pending) -jessie: 4.3.18-dfsg-3+deb8u2 is fixed in git branch jessie, with the upstream patch http://anonscm.debian.org/cgit/pkg-virtualbox/virtualbox.git/commit/?h=jessieid=990f846aec31871952b839ed93f7963f16bceb0c -wheezy: 4.1.18-dfsg-2+deb7u5

Bug#785689: I: Bug#785424: [Pkg-virtualbox-devel] Bug#785424: virtualbox: CVE-2015-3456: floppy driver host code execution

2015-05-19 Thread Gianfranco Costamagna
Package: virtualbox Severity: Serious Version: 4.3.18-dfsg-3 Tags: patch Virtualbox crashes after 10 minutes of run Il Lunedì 18 Maggio 2015 20:36, Frank Mehnert frank.mehn...@oracle.com ha scritto: Hi Gianfranco, could you also have a look here?

Bug#785424: [Pkg-virtualbox-devel] Bug#785424: virtualbox: CVE-2015-3456: floppy driver host code execution

2015-05-19 Thread Gianfranco Costamagna
, Frank On Monday 18 May 2015 16:48:13 Gianfranco Costamagna wrote: Hi sid/testing: - 4.3.28 is not affected (upload pending) -jessie: 4.3.18-dfsg-3+deb8u2 is fixed in git branch jessie, with the upstream patch http://anonscm.debian.org/cgit/pkg-virtualbox/virtualbox.git/commit/?h

Bug#785424: [vbox-dev] CVE-2015-3456 aka VENOM

2015-05-19 Thread Gianfranco Costamagna
Hi Frank, are you sure the bug is really fixed? the qemu patch seems to be different from the virtualbox one, and seems that the affected code is not fixed

Bug#785424: Re: Bug#785424: [Pkg-virtualbox-devel] Bug#785424: virtualbox: CVE-2015-3456: floppy driver host code execution

2015-05-19 Thread Gianfranco Costamagna
Jessie package. Thanks, Frank On Monday 18 May 2015 16:48:13 Gianfranco Costamagna wrote: Hi sid/testing: - 4.3.28 is not affected (upload pending) -jessie: 4.3.18-dfsg-3+deb8u2 is fixed in git branch jessie, with the upstream patch http://anonscm.debian.org/cgit

Bug#785424: Re: [vbox-dev] CVE-2015-3456 aka VENOM

2015-05-19 Thread Gianfranco Costamagna
Hi Debian security team, can we please followup with the two uploads then? I'm attaching the two debdiffs, chers, Gianfranco Il Martedì 19 Maggio 2015 11:27, Frank Mehnert frank.mehn...@oracle.com ha scritto: Hi Gianfranco, On Tuesday 19 May 2015 09:17:13 Gianfranco Costamagna wrote: Hi

Bug#783032: fixed in mentors?

2015-05-20 Thread Gianfranco Costamagna
Hi, the bug above should be fixed in mentors. I did some additional work, packaging the new release, bumping std-version, removing cdbs, wrap-and-sort, move watch file to github, export QT_SELECT, and something more. The package can be found here http://mentors.debian.net/package/minitube

Bug#787761: missing licenses in debian/copyright

2015-06-05 Thread Gianfranco Costamagna
Control: tags 787761 pending Hi Thorsten, first thanks for the review! I committed the changes on git [1] branch experimental. I hope we can followup with an upload of 3.7.1 and this fix on unstable soon. this bug seems affetting each gambas release since oldstable [1]

Bug#787921: gambas3-gb-desktop-x11: fails to upgrade from 'sid' - trying to overwrite /usr/lib/gambas3/gb.desktop.gambas

2015-06-06 Thread Gianfranco Costamagna
control: tags -1 pending Hi Andreas, I pushed the changes on git branch experimental, and on DebOMatic http://debomatic-amd64.debian.net/distribution#unstable/gambas3/3.7.1-1/buildlog http://anonscm.debian.org/cgit/pkg-gambas/gambas3.git/commit/?h=experimental Unfortunately piuparts there

Bug#781767:

2015-06-18 Thread Gianfranco Costamagna
Control: severity -1 important thanks Based on the last few comments I'm setting the severity back to important. cheers, G. -- To UNSUBSCRIBE, email to debian-bugs-rc-requ...@lists.debian.org with a subject of unsubscribe. Trouble? Contact listmas...@lists.debian.org

Bug#788945: libjsoncpp.so.0: cannot open shared object file: No such file or directory

2015-06-17 Thread Gianfranco Costamagna
On Wed, 17 Jun 2015 10:31:49 +0200 Peter Spiess-Knafl d...@spiessknafl.at wrote: Hi! I just did an upload including a fix for this bug. Please remember that all packages built against the broken version need a binNMU to get the new dependency right. However I cannot do binNMUs

Bug#783543: Fixed in 3.6.1

2015-06-17 Thread Gianfranco Costamagna
Control: fixed -1 1:3.6.1-1 thanks Hi, looking at the sources and the llvm branch commits mail list [1] seems that this bug is fixed in 3.6.1 [1] https://www.mail-archive.com/llvm-branch-commits@cs.uiuc.edu/msg01056.html cheers, Gianfranco -- To UNSUBSCRIBE, email to

Bug#781767: Makes it unusable for my buckets too

2015-06-13 Thread Gianfranco Costamagna
Hi all, I opened a jessie-p-u request here [1] I tried to explain (sum this conversation) in the best way I could, please read and correct if I wrote anything wrong there. Maybe something about this can be fixed with a python upload? (just wondering how bad might be reverting the check in a

Bug#786819: Can anybody please followup with this?

2015-05-28 Thread Gianfranco Costamagna
Hi Vince and Sebastian, unfortunately a package I comaintain (Virtualbox) is stuck in testing migration due to the libvnc transition, and the transition is blocked by netsurf (AFAIK). Is it possible to ack or NMU the package in the near future? I wouldn't bother, but Virtualbox/unstable is

Bug#777912: patch

2015-07-04 Thread Gianfranco Costamagna
Hi Steve, I saw you fixed insighttoolkit4, do you plan to fix also this one? the patch is really the same... However I'm wondering if we should let it disappear from testing, and try to focus on enabling itk4 on all architectures... cheers, G. -- To UNSUBSCRIBE, email to

Bug#777912: patch

2015-07-04 Thread Gianfranco Costamagna
Hi Steve, yes, I remember I tried it and I succeeded. I can retry if needed, but I'm mostly sure it was obviously due to the changes in cxx11 ABI. IIRC I tried with both the old and new gcc api (unstable and experimental) let me know if I have to try again, it was one month ago, I forget

Bug#777868:

2015-07-05 Thread Gianfranco Costamagna
reassign 777868 gccxml thanks actually the problem on this bug is on gccxml, so I guess reassigning is the right thing to do. I did some tweak to the gdcm build (by copying gccxml missing files to the gcc build directory) and I succeeded in the build. I guess switching to gccxml successor

Bug#777868: your mail

2015-07-05 Thread Gianfranco Costamagna
Hi Steve, So I reassign back. Create a new issue for gccxml and block this by it. yes, I did just this... I forgot about that! sorry G. -- To UNSUBSCRIBE, email to debian-bugs-rc-requ...@lists.debian.org with a subject of unsubscribe. Trouble? Contact listmas...@lists.debian.org

Bug#785689: patch

2015-05-26 Thread Gianfranco Costamagna
: #785689) from upstream changeset 53083 +thanks Frank for the hint! + + -- Gianfranco Costamagna costamagnagianfra...@yahoo.it Tue, 19 May 2015 10:22:10 +0200 + virtualbox (4.3.18-dfsg-3+deb8u2) jessie-security; urgency=high * d/p/CVE-2015-3456.patch fix for CVE-2015-3456 a.k.a. VENOM diff --git

Bug#779620: closed by Gianfranco Costamagna costamagnagianfra...@yahoo.it (Fixed in last unstable release)

2015-08-13 Thread Gianfranco Costamagna
Can you please open a new issue for this? thanks, Gianfranco Il Giovedì 13 Agosto 2015 15:13, Philipp Marek philipp.ma...@linbit.com ha scritto: Hi, according to the source code this seems to be fixed already in the last two Debian uploads. Please confirm the code is working. Sorry,

Bug#795531: FTBFS on i386

2015-08-15 Thread Gianfranco Costamagna
Hi dear Daniel, Thanks for the feedback, however this is not needed, because I already get the FTBFS mail from buildds, and even before the bug report I had discussed the build failure with upstream, a failure that will be discussed on monday too with vbox-dev folks, to see if we can narrow

Bug#779620: closed (Fixed in last unstable release)

2015-08-19 Thread Gianfranco Costamagna
Hi Philipp, can you please try the latest llvm-toolchain-snapshots 3.8 on unstable? the libstdc++ rebuilds should make it installable with not so many troubles hopefully (at least in a pbuilder-environment) cheers, G. Il Venerdì 14 Agosto 2015 7:18, Philipp Marek philipp.ma...@linbit.com

Bug#791310: Fixed in unstable and experimental

2015-08-20 Thread Gianfranco Costamagna
Hi, since nobody took care of this issue, I took the liberty to fix this bug and upload directly on unstable, due to policy allowing to put on 0 day queue packages with more than 7 days old RC bugs and no intention to fix. I did upload as NMU, even if I'm in the Debian Science team, because I

Bug#790655: python3-pygithub, remove the package?

2015-08-05 Thread Gianfranco Costamagna
Control: forwarded -1 https://github.com/PyGithub/PyGithub/issues/331 Hi Dmitry, I guess the package is really not python3 ready, in my opinion we should at least let the python2 version migrate to testing, because I need it as dependency of the new w3af. How do you feel about doing that? I

Bug#794466: Virtualbox might not be suitable for Stretch

2015-08-03 Thread Gianfranco Costamagna
Source: virtualbox Version: 4.3.30-dfsg-1 Severity: critical X-Debbugs-CC: j...@inutil.org X-Debbugs-CC: r...@debian.org X-Debbugs-CC: frank.mehn...@oracle.com X-Debbugs-CC: klaus.espenl...@oracle.com (please cc people if needed As Said in many different threads [1 bottom of the mail], Upstream

  1   2   3   4   5   6   7   >