Bug#321621: gcc biarch builds fails on i386

2005-08-06 Thread Matthias Klose
Package: amd64-libs-dev Severity: serious after upgrading to glibc-2.3.5, the gcc-4.0 biarch build fails: if [ x-fpic != x ]; then \ /org/packages/gcc/4.0/gcc-4.0-4.0.1/build/gcc/xgcc -B/org/packages/gcc/4.0/gcc-4.0-4.0.1/build/gcc/ -B/usr/i486-linux-gnu/bin/ -B/usr/i486-linux-gnu/lib/

Bug#321883: FTBFS: Unsatisfiable Build-Depends on libcairo0.5.1-dev

2005-08-07 Thread Matthias Klose
Michael Banck writes: Package: gcc-4.0 Version: 4.0.1-3 Severity: serious Hello, there was a problem autobuilding your package: would you mind checking the BTS before submitting duplicates? -- To UNSUBSCRIBE, email to [EMAIL PROTECTED] with a subject of unsubscribe. Trouble? Contact

Bug#321785: fakeroot: segfaults on [hppa]

2005-08-08 Thread Matthias Klose
fakeroot-tcp shows the same behaviour. reverting back to glibc-2.3.2 is a workaround. Matthias -- To UNSUBSCRIBE, email to [EMAIL PROTECTED] with a subject of unsubscribe. Trouble? Contact [EMAIL PROTECTED]

Bug#318808: How did you build the package?

2005-08-08 Thread Matthias Klose
Hi, the reason that the package is not yet upload is a FTBFS. I'm wondering how you did succeed building the package. Did you build on a current unstable system? Please attach the build log to the bug report. Thanks, Matthias PS: Please don't upload packages built on another environment than

Bug#322143: build dependency gcj-3.3 will be removed

2005-08-09 Thread Matthias Klose
Package: classpath Severity: serious The gcj-3.3 package will vanish soon from the archives. Please use gcj. -- To UNSUBSCRIBE, email to [EMAIL PROTECTED] with a subject of unsubscribe. Trouble? Contact [EMAIL PROTECTED]

Bug#321785: fakeroot: segfaults on [hppa]

2005-08-09 Thread Matthias Klose
Clint Adams writes: fakeroot-tcp shows the same behaviour. reverting back to glibc-2.3.2 is a workaround. Does building fakeroot against glibc 2.3.5 change anything? no, it's not fakeroot, it's make segfaulting ... # gdb /usr/bin/make GNU gdb 6.3-debian Copyright 2004 Free Software

Bug#322525: umfpack depends on packages, beeing removed from unstable

2005-08-11 Thread Matthias Klose
Package: umfpack Severity: serious depends on blas atlas2-base, see #317245 -- To UNSUBSCRIBE, email to [EMAIL PROTECTED] with a subject of unsubscribe. Trouble? Contact [EMAIL PROTECTED]

Bug#322884: cgilib FTBFS (at least with glibc-2.3.5)

2005-08-13 Thread Matthias Klose
Package: cgilib Version: 0.5-4 Severity: serious Package needs a recompilation, I'm preparing a NMU. char cgiInit (); int main () { cgiInit (); ; return 0; } configure:25719: gcc -o conftest -O2 -I/usr/include/tcl8.4 -fPIC -DPIC -I/usr/include/libart-2.0 -I/usr/include/freetype2

Bug#303326: file conflicts in libcgi-dev cgilib

2005-08-13 Thread Matthias Klose
I'm adding a Conflicts: line, both packages are development packages. -- To UNSUBSCRIBE, email to [EMAIL PROTECTED] with a subject of unsubscribe. Trouble? Contact [EMAIL PROTECTED]

Bug#322691: Please force libgmp3c2 to be installed on upgrade from

2005-08-13 Thread Matthias Klose
yes, this can be removed now. this thing was a temporary thing to allow packages depending on the C only library to migrate to testing without having the libgmpcxx in testing. -- To UNSUBSCRIBE, email to [EMAIL PROTECTED] with a subject of unsubscribe. Trouble? Contact [EMAIL PROTECTED]

Bug#323133: gcc: submitted Debian report #323133 to gcc-gnats as PR 21123

2005-08-14 Thread Matthias Klose
# submitted Debian report #323133 to gcc-gnats as PR 21123 # http://gcc.gnu.org/PR21123 forwarded 323133 http://gcc.gnu.org/PR21123 retitle 323133 [PR 21123, 4.0 regression, fixed in 4.1] ICE on arm m68k when compiling arts (in cp_expr_size, at cp/cp-objcp-common.c:101) tags 323133 + upstream

Bug#323194: dpkg-checkbuilddeps doesn't parse valid build depends

2005-08-15 Thread Matthias Klose
Package: dpkg-dev, lapack3 Version: 1.13.10 Severity: grave Build-Depends: debhelper ( = 4 ) , g77, refblas3-dev g77 isn't recognized as a build dependency. Removing the whitespace is a workaround. -- To UNSUBSCRIBE, email to [EMAIL PROTECTED] with a subject of unsubscribe. Trouble? Contact

Bug#323343: missing tightened build-dependencies on -dev packages with C++ ABI 2

2005-08-16 Thread Matthias Klose
Package: obby Version: 0.2.0-1 Severity: serious needs libsigc++-2.0-dev (= 2.0.10-2), libgmp3-dev (= 4.1.4-7) -- To UNSUBSCRIBE, email to [EMAIL PROTECTED] with a subject of unsubscribe. Trouble? Contact [EMAIL PROTECTED]

Bug#323550: needs a rebuild for libcapi20-3

2005-08-17 Thread Matthias Klose
Package: capisuite Version: 0.4.5-3 Severity: serious please rebuild, with tightened build dependency on libcapi20-dev. -- To UNSUBSCRIBE, email to [EMAIL PROTECTED] with a subject of unsubscribe. Trouble? Contact [EMAIL PROTECTED]

Bug#323548: needs a rebuild for libcapi20-3

2005-08-17 Thread Matthias Klose
Package: asterisk-chan-capi Version: 0.3.5-11 Severity: serious please rebuild, with tightened build dependency on libcapi20-dev. -- To UNSUBSCRIBE, email to [EMAIL PROTECTED] with a subject of unsubscribe. Trouble? Contact [EMAIL PROTECTED]

Bug#323549: needs a rebuild for libcapi20-3

2005-08-17 Thread Matthias Klose
Package: capi4hylafax Version: 1:01.02.03-13 Severity: serious please rebuild, with tightened build dependency on libcapi20-dev. -- To UNSUBSCRIBE, email to [EMAIL PROTECTED] with a subject of unsubscribe. Trouble? Contact [EMAIL PROTECTED]

Bug#323619: typo in python-egenix-stack dependency

2005-08-17 Thread Matthias Klose
Package: python-egenix-stack Version: 2.0.6-1 Severity: serious missing comma. maybe you can drop the 2.1 and 2.2 packages? -- To UNSUBSCRIBE, email to [EMAIL PROTECTED] with a subject of unsubscribe. Trouble? Contact [EMAIL PROTECTED]

Bug#318510: jni.h

2005-08-18 Thread Matthias Klose
forgot: just disabling the check in the configure script should be enough to fix it. -- To UNSUBSCRIBE, email to [EMAIL PROTECTED] with a subject of unsubscribe. Trouble? Contact [EMAIL PROTECTED]

Bug#318510: jni.h

2005-08-18 Thread Matthias Klose
to get the include directory and the include file, use: $ gcc --print-file-name=include/jni.h /usr/lib/gcc/i486-linux-gnu/4.0.2/include/jni.h $ gcc --print-file-name=include /usr/lib/gcc/i486-linux-gnu/4.0.2/include however, that directory is in the standard include path. -- To UNSUBSCRIBE,

Bug#316815: not a bug, at least not in lam4-dev

2005-08-18 Thread Matthias Klose
severity 316815 normal thanks run strings on the binary, it does have i486-linux-gnu-g++ -- To UNSUBSCRIBE, email to [EMAIL PROTECTED] with a subject of unsubscribe. Trouble? Contact [EMAIL PROTECTED]

Bug#350662: [Pkg-zope-developers] Bug#350662: zope3: unmet dependencies

2006-01-31 Thread Matthias Klose
tags 350662 + pending thanks sitting in NEW for a week now. Seo Sanghyeon writes: Package: zope3 Version: 3.2.0-1 Severity: serious Justification: Policy 2.2.1 The following packages have unmet dependencies: zope3: Depends: python2.4-mechanize (= 0.0.10a) but it is not installable

Bug#350688: gcc-2.95: FTBFS with new make

2006-01-31 Thread Matthias Klose
Daniel Schepler writes: Package: gcc-2.95 Version: 2.95.4ds15-24 Severity: serious From my pbuilder build log: ... stage1/xgcc -Bstage1/ -B/usr/i486-linux-gnu/bin/ -DIN_GCC -g -O2 -DHAVE_CONFIG_H `case stage1/xgcc -Bstage1/ -B/usr/i486-linux-gnu/bin/ in *gcc*) echo -Wall

Bug#290619: xvfb-run doesn't correctly quote arguments

2005-01-15 Thread Matthias Klose
Package: xvfb Version: 4.3.0.dfsg.1-10 Severity: serious Tags: patch xvfb-run calls XAUTHORITY=$AUTHFILE Xvfb :$SERVERNUM $XVFBARGS $LISTENTCP $ERRORFILE leading to: Unrecognized option: -screen 0 640x480x8 The $XVFBARGS $LISTENTCP variables must not be quoted. Causes build failures for all

Bug#290805: eric puts an own sitecustomize.py in sys.path

2005-01-16 Thread Matthias Klose
Package: eric Version: 3.5.0 Severity: grave Tags: patch eric includes /usr/lib/python2.3/site-packages/sitecustomize.py into it's package, changing the behaviour of site.py for all packages installed. Please install this file into a directory not in sys.path, i.e. /usr/share/eric. A

Bug#291060: gcc: submitted Debian report #291060 as PR http://bugzilla.gnome.org/show_bug.cgi?id=165271

2005-01-25 Thread Matthias Klose
# submitted Debian report #291060 as PR http://bugzilla.gnome.org/show_bug.cgi?id=165271 # http://gcc.gnu.org/PRhttp://bugzilla.gnome.org/show_bug.cgi?id=165271 forwarded 291060 http://bugzilla.gnome.org/show_bug.cgi?id=165271 tags 291060 + upstream thanks -- To UNSUBSCRIBE, email to [EMAIL

Bug#291060: libstdc++6-4.0-doc: cannot install

2005-01-27 Thread Matthias Klose
Laurent Bonnaud writes: Package: libstdc++6-4.0-doc Version: 4.0-0pre4 Severity: grave Justification: renders package unusable Hi, here is the problem: # apt-get install libstdc++6-4.0-doc [...] Unpacking libstdc++6-4.0-doc (from .../libstdc++6-4.0-doc_4.0-0pre4_all.deb) ...

Bug#293338: python2.3: raises an AttributeError during a deep copy

2005-02-02 Thread Matthias Klose
Roman Joost writes: Package: python2.3 Version: 2.3.4-19 Severity: grave Justification: renders package unusable I'm using the python2.3 to run my Zope 2.7.3 with CMF/Plone. After an update in debian unstable, it doesn't work anymore, because it raises an AttributeError during a deep

Bug#293932: license issues with profiler.py and md5.h/md5c.c

2005-02-07 Thread Matthias Klose
A Debian user pointed out (http://bugs.debian.org/293932), that the current license for the Python profiler is not conforming to the DFSG (Debian free software guidelines). http://www.python.org/doc/current/lib/node829.html states This permission is explicitly restricted to the copying and

Bug#294015: php4-sqlrelay: phpapi revision requires a new upload in sid

2005-02-07 Thread Matthias Klose
please go for it! Adam Conrad writes: Package: php4-sqlrelay Severity: grave Tags: sid Due to recent changes in the php4 packages, your package has become uninstallable in sid (as of today's dinstall run, installing php4_4:4.3.10-3). We are now building php4 with Zend Thread Safety

Bug#294522: patch available

2005-02-10 Thread Matthias Klose
tags 294522 + patch thanks https://bugzilla.ubuntu.com/show_bug.cgi?id=6401 -- To UNSUBSCRIBE, email to [EMAIL PROTECTED] with a subject of unsubscribe. Trouble? Contact [EMAIL PROTECTED]

Bug#293932: [Python-Dev] license issues with profiler.py and md5.h/md5c.c

2005-02-11 Thread Matthias Klose
Donovan Baarda writes: On Tue, 2005-02-08 at 11:52 -0800, Gregory P. Smith wrote: The md5.h/md5c.c files allow copy and use, but no modification of the files. There are some alternative implementations, i.e. in glibc, openssl, so a replacement should be sage. Any other requirements when

Bug#335199: cupsys: FTBFS: Not using -fPIC to make shared lib.

2005-10-23 Thread Matthias Klose
Kenshi Muto writes: Hi, At Sat, 22 Oct 2005 16:42:03 +0200, Kurt Roeckx wrote: Package: cupsys Version: 1.1.99.b1.r4748-1 Severity: serious Tags: experimental Hi, Your package is failing to build on amd64 with the following error: Linking libcups.so.2... /usr/bin/ld:

Bug#335438: libsvncpp-dev and libapr0-dev cannot be installed together

2005-10-23 Thread Matthias Klose
Package: libsvncpp-dev,libapr0-dev Severity: serious that means, that pysvn's build-deps cannot be installed anymore. Please coordinate, if these these packages should depend on libdb4.2-dev or libdb4.3-dev. -- To UNSUBSCRIBE, email to [EMAIL PROTECTED] with a subject of unsubscribe. Trouble?

Bug#335438: libsvncpp-dev and libapr0-dev cannot be installed together

2005-10-25 Thread Matthias Klose
Steve Langasek writes: -BEGIN PGP SIGNED MESSAGE- Hash: SHA1 reassign 335438 libsvn0-dev severity 335438 important thanks On Mon, Oct 24, 2005 at 09:45:49PM +1000, Adam Conrad wrote: Matthias Klose wrote: Package: libsvncpp-dev,libapr0-dev Severity: serious

Bug#336012: eclipse never built on s390, lowering severity of report

2005-10-29 Thread Matthias Klose
severity 336012 important thanks -- To UNSUBSCRIBE, email to [EMAIL PROTECTED] with a subject of unsubscribe. Trouble? Contact [EMAIL PROTECTED]

Bug#336463: Floating point exception ICE on mips and mipsel

2005-10-30 Thread Matthias Klose
reassign 336463 scummvm thanks well, check it before uploading, if you think it's critical. please ask the debian admins to install what's needed on the developer machines. please reassign after providing the complete information. Matthias Tore Anderson writes: Package: g++-4.0 Severity:

Bug#336114: Forwarded upstream

2005-11-08 Thread Matthias Klose
Nathanael Nerode writes: tags 336114 +upstream forwarded 336114 http://gcc.gnu.org/bugzilla/show_bug.cgi?id=24712 thanks Forwarded upstream as GCC bug number 24712. I think, that's not upstream. both changes were made between the 4.0.1 and the 4.0.2 release. Matthias -- To

Bug#338513: gjdoc: FTBFS: gcc: internal compiler error

2005-11-10 Thread Matthias Klose
tags 338513 + upstream forwarded 338513 http://gcc.gnu.org/PR24572 retitle 338513 [PR 24572] [4.0 regression] ICE in gimplify_expr, at gimplify.c:3983 thanks forwarded two weeks ago without a Debian report. Roland Stigge writes: Package: gcc-4.0 Version: 4.0.2-3 Severity: serious Hi,

Bug#316573: move of files in /var/lib/misc to /var/lib/db silently breaks scripts depending on libnss-db

2005-07-01 Thread Matthias Klose
Package: libnss-db Version: 2.2-6.3 Severity: grave The last NMU moved /var/lib/misc/Makefile to /var/lib/db/Makefile. It's not mentioned in the changelog, it breaks existing scripts. sorry, that's just bad style for a NMU. -- To UNSUBSCRIBE, email to [EMAIL PROTECTED] with a subject of

Bug#316578: FTBFS: No rule to make target current_symbols.txt

2005-07-02 Thread Matthias Klose
severity 316578 important tags 316578 + unreproducible thanks works for the buildd's and me. Matt Kraai writes: Package: gcc-4.0 Version: 4.0.0ds1-11 Severity: serious When I tried to rebuild gcc-4.0, it failed as follows: baseline_name=`basename

Bug#317501: amd64-libs-dev conflicts with linux-kernel-headers

2005-07-09 Thread Matthias Klose
Package: amd64-libs-dev Version: 1.1 Severity: grave Conflicts against linux-kernel-headers_2.6.12.0-1, the biarch build for gcc-3.4 and gcc-4.0 on i386 have to be disabled, therefore severity grave. -- To UNSUBSCRIBE, email to [EMAIL PROTECTED] with a subject of unsubscribe. Trouble? Contact

Bug#317541: missing build dependency imagemagick

2005-07-09 Thread Matthias Klose
Package: openoffice.org2 Version: 1.9.114-1 Tags: experimental Severity: serious convert is used without having the build dependency on imagemagick -- To UNSUBSCRIBE, email to [EMAIL PROTECTED] with a subject of unsubscribe. Trouble? Contact [EMAIL PROTECTED]

Bug#317501: amd64-libs-dev conflicts with linux-kernel-headers

2005-07-09 Thread Matthias Klose
Daniel Jacobowitz writes: On Sat, Jul 09, 2005 at 09:29:33AM +0200, Matthias Klose wrote: Package: amd64-libs-dev Version: 1.1 Severity: grave Conflicts against linux-kernel-headers_2.6.12.0-1, the biarch build for gcc-3.4 and gcc-4.0 on i386 have to be disabled, therefore severity

Bug#317082: libc6-s390x: missing depends on lib64gcc1

2005-07-12 Thread Matthias Klose
GOTO Masanori writes: At Tue, 05 Jul 2005 20:09:59 -0700, Ryan Murray wrote: libc6-s390x is missing a depends on lib64gcc1 that causes gcc to fail to link when -m64 is used on an s390 system. I'm filling the bug here rather than on the gcc-VERSION packages because the sparc64

Bug#318926: gettext-base package not renamed for C++ ABI change

2005-07-18 Thread Matthias Klose
Package: gettext-base Version: 0.14.5-2 Severity: serious the libasprintf library contained in gettext-base is built for the new C++ ABI. IMO you cannot use the same package name. Maybe a correct solution is to split the library into a separate libasprintf0c2 package and keep the -dev files in

Bug#318926: gettext-base package not renamed for C++ ABI change

2005-07-18 Thread Matthias Klose
Santiago Vila writes: On Mon, 18 Jul 2005, Matthias Klose wrote: Package: gettext-base Version: 0.14.5-2 Severity: serious the libasprintf library contained in gettext-base is built for the new C++ ABI. IMO you cannot use the same package name. Yes, I can, because packages

Bug#318959: gcc-4.0: compiles broken code

2005-07-19 Thread Matthias Klose
reassign 318959 libc6 thanks looks like this only happens, when lround from libm is used. Thorsten Jordan writes: Package: gcc-4.0 Version: 4.0.1-2 Severity: grave Justification: renders package unusable gcc-4.0 generates code that gives false results for this tiny program: #include

Bug#319168: gjdoc unconditionally depends on kaffe, currently uninstallable

2005-07-20 Thread Matthias Klose
Package: gjdoc Version: 0.7.5-1 Severity: serious gjdoc currently is not installable in unstable. It should definitely depend on the java1-runtime or java2-runtime alternative. At least java-gcj-compat is a working alternative. -- To UNSUBSCRIBE, email to [EMAIL PROTECTED] with a subject of

Bug#318785: do not wait on libgmp3

2005-07-20 Thread Matthias Klose
we will wait for a new upstream release before uploading. Currently gmp is not yet build on m68k, so we have to wait anyway. no, you don't need to wait, if you would use libgmp3c2's shlibs file. Is there _any_ reason to ship a shlibs.local file with packages, which are available in the

Bug#319168: gjdoc unconditionally depends on kaffe, currently uninstallable

2005-07-20 Thread Matthias Klose
Arnaud Vandyck writes: Wolfgang Baer wrote: Matthias Klose wrote: gjdoc currently is not installable in unstable. It should definitely depend on the java1-runtime or java2-runtime alternative. At least java-gcj-compat is a working alternative. gjdoc dependED on kaffe because

Bug#319205: build gmp using gcc-3.4/g++-3.4 on m68k as a workaorund

2005-07-20 Thread Matthias Klose
Package: gmp Version: 4.1.4-8 Severity: serious As a workaround, please build gmp using gcc-3.4/g++-3.4 on m68k and/or lower the optimization level to -O2 (according to the Debian policy). -- To UNSUBSCRIBE, email to [EMAIL PROTECTED] with a subject of unsubscribe. Trouble? Contact [EMAIL

Bug#319205: build gmp using gcc-3.4/g++-3.4 on m68k as a workaorund

2005-07-20 Thread Matthias Klose
Steve M. Robbins writes: On Wed, Jul 20, 2005 at 03:40:23PM +0200, Matthias Klose wrote: Package: gmp Version: 4.1.4-8 Severity: serious As a workaround, please build gmp using gcc-3.4/g++-3.4 on m68k and/or lower the optimization level to -O2 (according to the Debian policy

Bug#319410: imake assumes availability of selinux

2005-07-21 Thread Matthias Klose
Package: xutils Version: 6.8.2.dfsg.1-3 Severity: serious the xisdnutils imake run in isdnutils/xmonisdn generates: SELINUX_LDFLAGS = SELINUX_INCLUDES = -I/usr/include/selinux SELINUX_CFLAGS = -DHAVE_SELINUX SELINUX_LIBS = -lselinux Is this intended? There's nothing why

Bug#319205: build gmp using gcc-3.4/g++-3.4 on m68k as a workaorund

2005-07-22 Thread Matthias Klose
Roger Leigh writes: -BEGIN PGP SIGNED MESSAGE- Hash: SHA1 Now that gcc-4.0 is the default compiler, will a simple rebuild fix this bug? no, the bug is about FTBFS with gcc-4.0. -- To UNSUBSCRIBE, email to [EMAIL PROTECTED] with a subject of unsubscribe. Trouble? Contact [EMAIL

Bug#320043: additional .pc files

2005-07-26 Thread Matthias Klose
Package: mozilla-firefox-dev Version: 1.0.6 Severity: serious usr/lib/pkgconfig/firefox-nspr.pc usr/lib/pkgconfig/firefox-nss.pc these files break other packages to build from source, pointing to header files which are not included in the package. please remove. -- To UNSUBSCRIBE, email to

Bug#320046: FTBFS due to dpkg-architecture changes

2005-07-26 Thread Matthias Klose
Package: curl Version: 7.14 Severity: serious ifneq (${DEB_BUILD_GNU_SYSTEM},m68k-linux) ... and maybe others. Don't rely on the GNU variables -- To UNSUBSCRIBE, email to [EMAIL PROTECTED] with a subject of unsubscribe. Trouble? Contact [EMAIL PROTECTED]

Bug#320046: FTBFS due to dpkg-architecture changes

2005-07-27 Thread Matthias Klose
Domenico Andreoli writes: On Tue, Jul 26, 2005 at 07:07:05PM +0200, Matthias Klose wrote: Package: curl Version: 7.14 Severity: serious ifneq (${DEB_BUILD_GNU_SYSTEM},m68k-linux) ... and maybe others. Don't rely on the GNU variables please elaborate. why they are wrong? any

Bug#320439: blas-dev and lapack-dev beeing removed from unstable, rebuild using atlas3 needed

2005-07-29 Thread Matthias Klose
Package: blitz++ Severity: serious According to 317245, the following packages are removed from unstable, please build-depend on the appropriate atlas3 libraries. atlas blas lapack lapack99 ** blitz++ has an unsatisfied build-dependency: blas-dev ** ghemical has an unsatisfied

Bug#320440: blas-dev and lapack-dev beeing removed from unstable, rebuild using atlas3 needed

2005-07-29 Thread Matthias Klose
Package: ghemical Severity: serious According to 317245, the following packages are removed from unstable, please build-depend on the appropriate atlas3 libraries. atlas blas lapack lapack99 ** blitz++ has an unsatisfied build-dependency: blas-dev ** ghemical has an unsatisfied

Bug#320720: package built in old build-env, needs better build-deps

2005-07-31 Thread Matthias Klose
Package: htmlgen Version: 1.8.24-1 Severity: serious please build in a current unstable build environment, tighten the build dependency on the libfltk1.1 development package. -- To UNSUBSCRIBE, email to [EMAIL PROTECTED] with a subject of unsubscribe. Trouble? Contact [EMAIL PROTECTED]

Bug#320747: xsidplay FTBFS with g++-4.0

2005-08-01 Thread Matthias Klose
Package: xsidplay Version: 1.6.5.2 Severity: serious libsidplay needs to be transitioned first https://bugzilla.ubuntu.com/show_bug.cgi?id=12689 -- To UNSUBSCRIBE, email to [EMAIL PROTECTED] with a subject of unsubscribe. Trouble? Contact [EMAIL PROTECTED]

Bug#321083: needs tightened build dependency on libmyspell-dev

2005-08-03 Thread Matthias Klose
Package: enchant Version: 1.1.6-1 Severity: serious The build dependency (and the dependencies in the -dev package on the -dev package) need to reference the first version of the depending C++ libraries built for the new C++ ABI. -- To UNSUBSCRIBE, email to [EMAIL PROTECTED] with a subject of

Bug#321084: jade FTBFS on hppa

2005-08-03 Thread Matthias Klose
Package: jade Version: 1.2.1-44 Severity: serious see the buildd logs. looks like it builds ok with g++-3.4 on hppa. -- To UNSUBSCRIBE, email to [EMAIL PROTECTED] with a subject of unsubscribe. Trouble? Contact [EMAIL PROTECTED]

Bug#321090: missing tightened (build-) dependency on libpt-dbg

2005-08-03 Thread Matthias Klose
Package: openh323 Version: 1.15.3-3 Severity: serious needs to (build)-depend on the first version of libpt-dbg built for the new C++ ABI. g++ build dependency is not necessary. -- To UNSUBSCRIBE, email to [EMAIL PROTECTED] with a subject of unsubscribe. Trouble? Contact [EMAIL PROTECTED]

Bug#328789: wml: segmentation fault in pass 3

2005-09-21 Thread Matthias Klose
Recompiling perl and eperl did fix the segfault problem for me on powerpc (I think the perl version in unstable doesn't need the recompilation really). Matthias -- To UNSUBSCRIBE, email to [EMAIL PROTECTED] with a subject of unsubscribe. Trouble? Contact [EMAIL PROTECTED]

Bug#329499: unsatisfied build dependency: librrd0-dev

2005-09-21 Thread Matthias Klose
Package: ganglia-monitor-core Severity: serious Version: 2.5.7-2 needs to be changed to librrd2-dev. -- To UNSUBSCRIBE, email to [EMAIL PROTECTED] with a subject of unsubscribe. Trouble? Contact [EMAIL PROTECTED]

Bug#329108: gcc-4.0 FTBFS on, uh, i386

2005-09-23 Thread Matthias Klose
GOTO Masanori writes: At Mon, 19 Sep 2005 19:27:15 +0200, Matthias Klose wrote: On the latest i386 Sid, gcc-4.0 does not build from source, on my machine, and on a buildd (see the logs). With dash as sh, I get: this is known, we're waiting on proper 64bit support from glibc. I'd

Bug#329715: gcc-4.0_4.0.1-9(powerpc/unstable): fails to build without deprecated BSD ptys

2005-09-23 Thread Matthias Klose
Ryan Murray writes: A full build log can be found at: http://buildd.debian.org/build.php?arch=powerpcpkg=gcc-4.0ver=4.0.1-9 /dev/pty* are only used with BSD style ptys. Linux 2.6 has named them as CONFIG_LEGACY_PTYS, to be removed at some point. Instead of looking for the old /dev/pty*,

Bug#327849: gcc: submitted Debian report #327849 to gcc-gnats as PR 24111

2005-09-28 Thread Matthias Klose
# submitted Debian report #327849 to gcc-gnats as PR 24111 # http://gcc.gnu.org/PR24111 forwarded 327849 http://gcc.gnu.org/PR24111 retitle 327849 [PR 24111] [3.4 4.0 4.1 regression] [arm] cannot handle identifiers with '$' character tags 327849 + upstream thanks -- To UNSUBSCRIBE, email to

Bug#330595: Miscompilation with -fomit-frame-pointer -O3 -funroll-all-loops

2005-09-28 Thread Matthias Klose
tags 330595 + unreproducible thanks Camm Maguire writes: Package: gcc-4.0 Version: 4.0.1-5 Severity: serious The following preprocessed file is miscompiled when compiled as follows: + /usr/bin/gcc -o ATL_F77wrap_ctrsv.o -c -DL2SIZE=4194304

Bug#327849: cannot handle identifiers with '$' character

2005-09-28 Thread Matthias Klose
severity 327849 important thanks -fdollars-in-identifiers work can be used as a workaround. see http://gcc.gnu.org/PR24111 for the upstream report. -- To UNSUBSCRIBE, email to [EMAIL PROTECTED] with a subject of unsubscribe. Trouble? Contact [EMAIL PROTECTED]

Bug#331661: extensions/*.jar ship without source code, shipped jar files are installed

2005-10-04 Thread Matthias Klose
Package: docbook-xsl Version: 1.68.1 Severity: serious The extensions contains many jar files, without having the sources in the source package, the problematic files seem to be: saxon644.jar saxon65.jar saxon651.jar saxon652.jar saxon653.jar It looks like the source for saxon643.jar

Bug#330595: Miscompilation with -fomit-frame-pointer -O3 -funroll-all-loops

2005-10-05 Thread Matthias Klose
severity 330595 normal thanks Camm Maguire writes: Package: gcc-4.0 Version: 4.0.1-5 Severity: serious The following preprocessed file is miscompiled when compiled as follows: + /usr/bin/gcc -o ATL_F77wrap_ctrsv.o -c -DL2SIZE=4194304 -I/fix/t1/camm/debian/atlas/atlas3-3.6.0/include

Bug#293667: bugs fixed in bash-3.0-17

2005-10-15 Thread Matthias Klose
close 293667 3.0-17 close 330889 3.0-17 close 293979 3.0-17 close 325045 3.0-17 close 327413 3.0-17 close 322481 3.0-17 thanks -- To UNSUBSCRIBE, email to [EMAIL PROTECTED] with a subject of unsubscribe. Trouble? Contact [EMAIL PROTECTED]

Bug#334346: please remove zlib packages from ia32-libs for amd64

2005-10-17 Thread Matthias Klose
Package: ia32-libs Version: 1.4 Severity: serious Unpacking lib32z1 (from .../lib32z1_1%3a1.2.3-4_amd64.deb) ... dpkg: error processing /var/cache/apt/archives/lib32z1_1%3a1.2.3-4_amd64.deb (--unpack): trying to overwrite `/emul/ia32-linux/usr/lib/libz.so.1', which is also in package ia32-libs

Bug#317882: ia32-libs: package fails to install

2005-10-17 Thread Matthias Klose
tags 317882 - moreinfo tags 317882 - unreproducible thanks install xorg-driver-fglrx (but I cannot find this package in Ubuntu), then ia32-libs to reproduce the installation failure. -- To UNSUBSCRIBE, email to [EMAIL PROTECTED] with a subject of unsubscribe. Trouble? Contact [EMAIL

Bug#298004: lowering severity of report

2005-03-04 Thread Matthias Klose
severity 298004 normal thanks please install the capiutils package. isdnactivecards should recommend capiutils, but not depend on it. upload pending -- To UNSUBSCRIBE, email to [EMAIL PROTECTED] with a subject of unsubscribe. Trouble? Contact [EMAIL PROTECTED]

Bug#298568: debian/copyright doesn't include the complete license text / installation overwrites dhelp index file

2005-03-08 Thread Matthias Klose
Package: python-gtk2-doc Severity: serious Tags: patch Please find a patch for both problems at http://patches.ubuntu.com/patches/python-gtk2-doc.diff -- To UNSUBSCRIBE, email to [EMAIL PROTECTED] with a subject of unsubscribe. Trouble? Contact [EMAIL PROTECTED]

Bug#298615: kdelibs/mipsel built with a broken g++ (3.3_3.3.5-9) compiler

2005-03-08 Thread Matthias Klose
Package: kdelibs Version: 4:3.3.2-3 Severity: grave Tags: sid kdelibs/mipsel built with a broken g++ (3.3_3.3.5-9) compiler. It has to rebuilt with an older or a newer (-10) version. -- To UNSUBSCRIBE, email to [EMAIL PROTECTED] with a subject of unsubscribe. Trouble? Contact [EMAIL

Bug#298617: glibmm2.4/mipsel built with a broken g++ (3.3_3.3.5-9) compiler

2005-03-08 Thread Matthias Klose
Package: glibmm2.4 Version: 2.6.1-1 Severity: grave Tags: sid glibmm2.4/mipsel built with a broken g++ (3.3_3.3.5-9) compiler. It has to rebuilt with an older or a newer (-10) version. -- To UNSUBSCRIBE, email to [EMAIL PROTECTED] with a subject of unsubscribe. Trouble? Contact [EMAIL

Bug#299922: mailscanner: lock/pid file location violates fhs

2005-03-23 Thread Matthias Klose
Wolfgang Kohnen writes: Package: mailscanner Version: 4.38.10-1 Severity: serious Justification: fhs Hello, with the default configuration, mailscanner uses /tmp as the directory holding pid and lock files. Since these dirs are world writeable, this is a security concern. It should

Bug#299922: mailscanner: lock/pid file location violates fhs

2005-03-23 Thread Matthias Klose
Justin Pryzby writes: On Wed, Mar 23, 2005 at 09:23:09PM +0100, Matthias Klose wrote: Wolfgang Kohnen writes: Package: mailscanner Version: 4.38.10-1 Severity: serious Justification: fhs Hello, with the default configuration, mailscanner uses /tmp as the directory

Bug#301489: kernel is unable to mount file system on raid0 device

2005-03-26 Thread Matthias Klose
Package: kernel-image-2.6.8-2-64-smp Version: 2.6.8-6 Severity: grave Seen on an A500 SMP system, it works fine with an A500 kernel found at ftp.parisc-linux.org. http://cvs.parisc-linux.org/download/linux-2.6/autobuild/a500_defconfig/palinux-a500-defconfig-2.6.8.1-pa11_0-2_all.deb Just

Bug#301489: kernel is unable to mount file system on raid0 device

2005-03-26 Thread Matthias Klose
severity 301489 normal thanks Kyle McMartin writes: On Sat, Mar 26, 2005 at 11:20:11AM +0100, Matthias Klose wrote: mdadm: /dev/md0 has been started with 2 drives. I'm not really sure what to say. None of that code has been modified in any of the hppa patches

Bug#339409: typo in lib64z1-dev dependency

2005-11-15 Thread Matthias Klose
Package: lib64z1-dev Severity: serious Version: 1:1.2.3-6 s/lib64c-dev/lib64c6-dev/ -- To UNSUBSCRIBE, email to [EMAIL PROTECTED] with a subject of unsubscribe. Trouble? Contact [EMAIL PROTECTED]

Bug#339509: FTBFS on hppa using expect

2005-11-16 Thread Matthias Klose
Package: binutils Version: 2.16.1cvs20051109-1 Severity: serious Tags: patch Using expect-tcl8.3 lets the build succeed. -- To UNSUBSCRIBE, email to [EMAIL PROTECTED] with a subject of unsubscribe. Trouble? Contact [EMAIL PROTECTED]

Bug#339234: library package needs to be renamed (libstdc++ allocator change)

2005-11-17 Thread Matthias Klose
Philipp Kern writes: On Nov 17, 2005, at 03:22, Matthias Klose wrote: Compiler versions g++-4.0_4.0.2-4 and g++-3.4_3.4.4-10 are now in the archive. The renaming of the library packages can now start. Apart of waiting for the dependencies... Do I need to tighten the build-dependency

Bug#339271: library package needs to be renamed (libstdc++ allocator change)

2005-11-18 Thread Matthias Klose
Hamish Moffatt writes: On Tue, Nov 15, 2005 at 07:57:24AM +0100, Matthias Klose wrote: Package: tqsllib Severity: important Please do not take any action before reading http://lists.debian.org/debian-devel-announce/2005/11/msg00010.html This bug report is filed against the source

Bug#339409: acknowledged by developer (Re: Bug#339409: typo in lib64z1-dev dependency)

2005-11-19 Thread Matthias Klose
Debian Bug Tracking System writes: As far as I can tell there is no actual bug here: the lib64c-dev provides exists in unstable and the dependency appears to do what I was expecting it to do. yes, but you are required to depend on a real package as well, not just only on a virtual package.

Bug#339229: library package needs to be renamed (libstdc++ allocator change)

2005-11-23 Thread Matthias Klose
tag 339229 wontfix tag 339257 wontfix any reason for these? please add a short rationale to the bug reports, why this is wontfix. -- To UNSUBSCRIBE, email to [EMAIL PROTECTED] with a subject of unsubscribe. Trouble? Contact [EMAIL PROTECTED]

Bug#339219: libstdc++ allocator change

2005-11-23 Thread Matthias Klose
tags 339219 + patch thanks http://people.ubuntu.com/patches/c2a-libsigc++-2.0.diff -- To UNSUBSCRIBE, email to [EMAIL PROTECTED] with a subject of unsubscribe. Trouble? Contact [EMAIL PROTECTED]

Bug#339158: libstdc++ allocator change

2005-11-23 Thread Matthias Klose
tags 339159 + patch thanks http://people.ubuntu.com/patches/c2a-cppunit.diff -- To UNSUBSCRIBE, email to [EMAIL PROTECTED] with a subject of unsubscribe. Trouble? Contact [EMAIL PROTECTED]

Bug#339144: libstdc++ allocator change

2005-11-23 Thread Matthias Klose
tags 339144 + patch thanks http://people.ubuntu.com/patches/c2a-aiksaurus.diff please remove the build dependency on libstdc++2.10-dev, it's not needed for anything. -- To UNSUBSCRIBE, email to [EMAIL PROTECTED] with a subject of unsubscribe. Trouble? Contact [EMAIL PROTECTED]

Bug#339161: libstdc++ allocator change

2005-11-23 Thread Matthias Klose
tags 339161 + patch thanks http://people.ubuntu.com/patches/c2a-enchant.diff -- To UNSUBSCRIBE, email to [EMAIL PROTECTED] with a subject of unsubscribe. Trouble? Contact [EMAIL PROTECTED]

Bug#339241: libstdc++ allocator change

2005-11-23 Thread Matthias Klose
tags 339241 + patch thanks http://people.ubuntu.com/patches/c2a-openexr.diff -- To UNSUBSCRIBE, email to [EMAIL PROTECTED] with a subject of unsubscribe. Trouble? Contact [EMAIL PROTECTED]

Bug#339211: libstdc++ allocator change

2005-11-23 Thread Matthias Klose
tags 339211 + patch thanks http://people.ubuntu.com/patches/c2a-libmusicbrainz-2.0.diff Note, that this patch drops python2.1 and python2.2 support, and add python2.4 support as well. -- To UNSUBSCRIBE, email to [EMAIL PROTECTED] with a subject of unsubscribe. Trouble? Contact [EMAIL

Bug#339155: cal3d didn't change the library package name for the GCC 4.0 C++ ABI change

2005-11-23 Thread Matthias Klose
well, too late, but please add conflicts/replaces to libcal3d10c2 as well, when you update the package. -- To UNSUBSCRIBE, email to [EMAIL PROTECTED] with a subject of unsubscribe. Trouble? Contact [EMAIL PROTECTED]

Bug#339212: libstdc++ allocator change

2005-11-23 Thread Matthias Klose
tags 339212 + patch thanks patch at http://people.ubuntu.com/patches/c2a-libmusicbrainz-2.1.diff -- To UNSUBSCRIBE, email to [EMAIL PROTECTED] with a subject of unsubscribe. Trouble? Contact [EMAIL PROTECTED]

Bug#339250: libstdc++ allocator change

2005-11-23 Thread Matthias Klose
tags 339250 + patch thanks please find a patch at http://people.ubuntu.com/patches/c2a-pcre3.diff as a side note: the package doesn't clean: dpkg-source -b pcre3-6.4 dpkg-source: building pcre3 using existing pcre3_6.4.orig.tar.gz dpkg-source: building pcre3 in pcre3_6.4-1ubuntu1.diff.gz

Bug#339223: libstdc++ allocator change

2005-11-23 Thread Matthias Klose
tags 339223 + patch thanks please find a patch at http://people.ubuntu.com/patches/c2a-libtunepimp.diff -- To UNSUBSCRIBE, email to [EMAIL PROTECTED] with a subject of unsubscribe. Trouble? Contact [EMAIL PROTECTED]

  1   2   3   4   5   6   7   8   9   10   >