Bug#351516: fvwm95: Depends on unavailable libreadline4

2006-02-05 Thread Sven Joachim
Package: fvwm95 Version: 2.0.43ba-23 Severity: grave From /usr/share/doc/fvwm95/changelog.Debian.gz: fvwm95 (2.0.43ba-23) unstable; urgency=low * [...] * Rebuild against libreadline5 (closes: Bug#326361) It seems that you did not actually do this, since on i386 fvwm95 still depends on

Bug#338333: emacs-goodies-el: Some Lisp packages are useless without non-free software

2005-11-09 Thread Sven Joachim
Package: emacs-goodies-el Version: 26.3-1 Severity: serious It seems to me that some Emacs Lisp packages in emacs-goodies-el are only of any use if non-free software is installed on the system, namely: maplev.el needs Maple, matlab.el needs Matlab and tcl.el needs the Target Language Compiler

Bug#338334: tetex-doc: Debian changelog is missing

2005-11-09 Thread Sven Joachim
Package: tetex-doc Version: 3.0-10 Severity: serious The Debian changelog is missing in the /usr/share/doc/tetex-doc directory. Please add it there as mandated by section 12.7 of the Policy Manual. -- System Information excluded -- To UNSUBSCRIBE, email to [EMAIL PROTECTED] with a subject

Bug#338333: emacs-goodies-el: Some Lisp packages are useless without non-free software

2005-11-10 Thread Sven Joachim
. While I would still prefer a different package for these files, I am sufficiently convinced that it is no policy violation to leave them in the main section. So I've downgraded the severity to wishlist. Kind Regards, -- Sven Joachim -- To UNSUBSCRIBE, email to [EMAIL PROTECTED

Bug#332753: xlibmesa-gl-dev: cannot link OpenGL app: /usr/bin/ld: cannot find, -lGL

2005-10-09 Thread Sven Joachim
Do you have nvidia-glx installed? That package diverts some files in the xlibmesa-gl package, which leads to the dangling symlink /usr/lib/libGL.so. Here's what dpkg -L xlibmesa-gl prints for me: /. /usr /usr/X11R6 /usr/X11R6/lib /usr/X11R6/lib/libGL.so.1.2 diverted by nvidia-glx to:

Bug#332753: xlibmesa-gl-dev: cannot link OpenGL app: /usr/bin/ld: cannot find, -lGL

2005-10-09 Thread Sven Joachim
severity 332753 important thanks Andre Heynatz wrote: I have read bug report #208198 and am somewhat confused. It has become a combinatorical problem, and my head smokes. But there seems to be an easy way out: libGL.so.1 is linked to different files whether Mesa or nVidia libs are used:

Bug#208198: Symlink /usr/lib/libGL.so dangling again

2005-10-10 Thread Sven Joachim
reopen 208198 tags 208198 - fixed-in-experimental thanks As of version 1.0.7676-1 of nvidia-glx, the symlink /usr/lib/libGL.so - libGL.so.1.2 in the xlibmesa-gl-dev package is dangling again after installing nvidia-glx. See http://bugs.debian.org/332753 . Will this mess ever be cleaned up?

Bug#341888: fails to read stage1 file on cciss raid

2005-12-04 Thread Sven Joachim
, look in /tmp, grub-install should have left a log there. Best regards, -- Sven Joachim -- To UNSUBSCRIBE, email to [EMAIL PROTECTED] with a subject of unsubscribe. Trouble? Contact [EMAIL PROTECTED]

Bug#323741: Please don't allow 'emacsen' as build-dependency

2006-11-17 Thread Sven Joachim
I think it is not correct to use emacs21 | emacsen in the Build-Depends-Indep field, since, AFIK, the xemacs packages provide emacsen but not the /usr/bin/emacs alternative. It would be better to use emacs21 | emacs22 | emacs-snapshot instead (the latter works, I just verified it). The package

Bug#396875: tagging 396875

2006-12-03 Thread Sven Joachim
On Tue, 28 Nov 2006, Rob Browning wrote: I should have a new version uploaded later this week, probably by tomorrow night. Ping? -- To UNSUBSCRIBE, email to [EMAIL PROTECTED] with a subject of unsubscribe. Trouble? Contact [EMAIL PROTECTED]

Bug#359048: w3-doc-e21: documentation is completely unmodifiable

2006-03-26 Thread Sven Joachim
Package: w3-doc-e21 Version: 4.0pre.2001.10.27-18 Severity: serious From /usr/share/info/emacs-21/w3.info.gz: , |Permission is granted to make and distribute verbatim copies of this | manual provided the copyright notice and this permission notice are | preserved on all copies. `

Bug#360610: wine: Recommends package from contrib section

2006-04-03 Thread Sven Joachim
Package: wine Version: 0.9.10-1 Severity: serious It is nice that your packages now recommend several other ones, rather than just suggesting them. However, there is one package which wine must _not_ recommend, namely msttcorefonts. This package is in contrib, and recommending it violates

Bug#361592: scilab-bin: linking against libreadline violates the GPL

2006-04-09 Thread Sven Joachim
Package: scilab-bin Version: 3.0-14.1 Severity: serious Your package depends on libreadline5, indicating that some binary depends on it (AFICS, it's /usr/lib/scilab/scilex). Since the readline library is distributed under the GPL rather than the LGPL, you may not link software with a

Bug#368846: emacs-snapshot: FTBFS with new coreutils

2006-05-25 Thread Sven Joachim
Package: emacs-snapshot Version: 1:20060524-1 Severity: serious Tags: patch There was a problem building this week's snapshot. From the end of the `debuild' log (sorry for the German, but the problem should be clear anyway): # save binary from deletion mv src/emacs src/nox-emacs touch

Bug#351516: Recommends: xcontrib should be removed

2006-02-06 Thread Sven Joachim
reopen 351516 severity 351516 minor retitle 351516 fvwm95: Recommends unavailable xcontrib package thanks Steve Langasek wrote: While you're at it, you also should remove the Recommends: of xcontrib in debian/control, since that package is gone for several years now. Hmm, please reopen

Bug#355439: gcc-4.0-base: Debian changelog and copyright lost after upgrade

2006-03-05 Thread Sven Joachim
Package: gcc-4.0-base Version: 4.0.2-10 Severity: serious It looks as if bug #346171 has raised its ugly head again, since somehow the files /usr/share/doc/gcc-4.0-base{copyright, changelog.Debian.gz} disappeared after the upgrade from 4.0.2-9 to 4.0.2-10: $ ls /usr/share/doc/gcc-4.0-base Ada

Bug#355439: gcc-4.0-base: Debian changelog and copyright lost after upgrade

2006-03-06 Thread Sven Joachim
Matthias Klose wrote: Sven Joachim writes: Package: gcc-4.0-base Version: 4.0.2-10 Severity: serious It looks as if bug #346171 has raised its ugly head again, since somehow the files /usr/share/doc/gcc-4.0-base{copyright, changelog.Debian.gz} disappeared after the upgrade from 4.0.2-9

Bug#355439: gcc-4.0-base: Debian changelog and copyright lost after upgrade

2006-03-06 Thread Sven Joachim
reassign 355439 libgcc1 thanks Reassigning this to libgcc1, since I found out this package (and lib64gcc1) at fault (see my previous message). -- To UNSUBSCRIBE, email to [EMAIL PROTECTED] with a subject of unsubscribe. Trouble? Contact [EMAIL PROTECTED]

Bug#355439: gcc-4.0-base: Debian changelog and copyright lost after upgrade

2006-03-07 Thread Sven Joachim
Matthias Klose wrote: reassign 355439 gcc-4.0-base thanks Sven Joachim writes: reassign 355439 libgcc1 thanks Reassigning this to libgcc1, since I found out this package (and lib64gcc1) at fault (see my previous message). no, the file is missing in gcc-4.0-base. Huh? The gcc-4.0-base

Bug#356055: loadlin: loadlin.exe cannot be built from source

2006-03-09 Thread Sven Joachim
Package: loadlin Version: 1.6c.really1.6c-1 Severity: serious The DOS executable loadlin.exe is not rebuilt in the maintainer scripts, and it appears it even cannot be built with programs in Debian since the makefile in the src directory starts as follows: # Makefile for LOADLIN-1.6 (C)

Bug#355439: gcc-4.0-base: Debian changelog and copyright lost after upgrade

2006-03-10 Thread Sven Joachim
Matthias Klose wrote: But maybe some magic in the preinst scripts can avoid that. Please check the packages at deb http://people.debian.org/~doko/gcc-4.0 ./ Inside a chroot, I upgraded the packages: 4.0.2-6 - 4.0.2-9 - 4.0.2-11, but, alas, the copyright and changelog were still lost

Bug#355439: gcc-4.0-base: Debian changelog and copyright lost after upgrade

2006-03-13 Thread Sven Joachim
Matthias Klose wrote: please recheck (after downgrading to 4.0.2-9), I had two copies of the packages at different places. Sorry. I now looked into the new 4.0.3-1 versions, they hopefully fix this for good. Some people may wonder why the files in /usr/share/doc/gcc-4.0-base have two names,

Bug#207932: Consequences of moving Emacs Manuals to non-free

2006-03-14 Thread Sven Joachim
[ CC'ing debian-emacsen, as this should be of interest for Emacs users and developers. Also, I would like to read other people's opinion about this.] Jérôme Marant wrote: Since the FDL documents contain invariant sections, they will have to be moved to non-free very soon. When you do this,

Bug#207932: Consequences of moving Emacs Manuals to non-free

2006-03-14 Thread Sven Joachim
of it either, but I have the choice of either do what the Project decided or resign from the Project. I've chosen the former. Thank you very much for this decision. Regards, Sven Joachim

Bug#357257: gawk: GFDL documentation with unmodifiable sections

2006-03-16 Thread Sven Joachim
Package: gawk Version: 1:3.1.5-2 Severity: serious From the gawk info manual: Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation; with the

Bug#357259: tar: GFDL documentation with unmodifiable sections

2006-03-16 Thread Sven Joachim
Package: tar Version: 1.15.1-4 Severity: serious From the tar info manual: Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.1 or any later version published by the Free Software Foundation;

Bug#357260: bash-doc: GFDL documentation with cover texts

2006-03-16 Thread Sven Joachim
Package: bash-doc Version: 3.1-3 Severity: serious From bashref.info: Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.1 or any later version published by the Free Software Foundation; with

Bug#315582: backup-manager: insecure handling of temporary files

2005-06-23 Thread Sven Joachim
Package: backup-manager Version: 0.5.7-1 Severity: critical Justification: root security hole Tags: patch The optional CD-burning feature of backup-manager uses a hardcoded filename (/tmp/bm-cdrecord.log) for logging the output of cdrecord. If a malicious (or just unlucky) user makes

Bug#385732: gcc-defaults: Non-free files in source package

2006-09-02 Thread Sven Joachim
Package: gcc-defaults Version: 1.42 Severity: serious The source package still contains the non-free files fsf-funding.7, gfdl.7 and gpl.7, apparently for no good reason since they aren't installed. Please remove them. -- System Information: Debian Release: testing/unstable APT prefers

Bug#385732: gcc-defaults: Non-free files in source package

2006-09-03 Thread Sven Joachim
Matthias Klose wrote: The source package still contains the non-free files fsf-funding.7, ok. gfdl.7 and gpl.7, apparently for no good reason since they aren't installed. Please remove them. no, license texts can be included. there's no reason to remove them. But the GFDL is not the

Bug#387427: Please loosen the firefox version dependency in install.rdf

2006-09-14 Thread Sven Joachim
A new version of mozilla-firefox-locale-all is in incoming, but it will become useless in just a few days, when the freshly-announced firefox 1.5.0.7 enters the Debian archives. :-( Can't this be fixed by upgrading maxVersion in /usr/lib/firefox/extensions/[EMAIL PROTECTED]/install.rdf to

Bug#388264: New upstream releases

2006-09-24 Thread Sven Joachim
severity 388264 wishlist thanks Daniel Baumann wrote: Since the current locales do not work with the thunderbird version in unstable, I'm raising the severity to grave. Huh?! What makes you think they don't work? The German locale package works perfectly fine for me. Note that its

Bug#390093: gcc-4.1-doc: Overwrites copyright and Debian changelog of gcc-4.1-base

2006-09-29 Thread Sven Joachim
Package: gcc-4.1-doc-non-dfsg Version: 4.1.1-nf1 Severity: serious In previous versions of gcc-4.1-doc (up to 4.1.1-10), /usr/share/doc/gcc-4.1-doc was a symlink to gcc-4.1-base. Because dpkg follows the symlink when upgrading the package, your files end up in /usr/share/doc/gcc-4.1-base,

Bug#374851: html-helper-mode: Mismatched parentheses in 50html-helper-mode.el

2006-06-21 Thread Sven Joachim
Package: html-helper-mode Version: 3.0.4kilo-1 Severity: grave Tags: patch Something went wrong when you applied my patch for #374587, since there is a closing parenthesis missing in line 17 of /etc/emacs/site-start.d/50html-helper-mode.el. The result is an error message during Emacs' start

Bug#366196: This bug should be closed

2006-07-07 Thread Sven Joachim
This bug, which was cloned from #365900, should have been closed together with that bug, seems this was forgotten. Would somebody close it now? I don't dare doing that myself, considering such an action as politically not quite correct. ;-) Cheers, Sven -- To UNSUBSCRIBE, email to [EMAIL

Bug#361592: Ping

2006-07-21 Thread Sven Joachim
#include hello.h Is there any progress on this bug? If not, I'll reassign it to ftp.debian.org and request removal of your package, to avoid legal risks for Debian. Cheers, Sven -- To UNSUBSCRIBE, email to [EMAIL PROTECTED] with a subject of unsubscribe. Trouble? Contact [EMAIL PROTECTED]

Bug#383437: thunderbird-locale-de: incomplete copyright file

2006-08-17 Thread Sven Joachim
Package: thunderbird-locale-de Version: 1:1.5.0.5-1 Severity: serious Quoting from section 12.5 of the Policy Manual: Every package must be accompanied by a verbatim copy of its copyright and distribution license in the file `/usr/share/doc/package/copyright'. Your copyright

Bug#207932: yow.c has license issues, it's deleted upstream

2006-10-27 Thread Sven Joachim
#include hello.h I think you have to remove lib-src/yow.c from the .orig.tar.gz as well. That file was deleted upstream due to license issues. Kind regards, Sven -- To UNSUBSCRIBE, email to [EMAIL PROTECTED] with a subject of unsubscribe. Trouble? Contact [EMAIL PROTECTED]

Bug#396875: emacs21-common: Must include a copy of the GFDL

2006-11-03 Thread Sven Joachim
Package: emacs21-common Version: 21.4a+1-1 Severity: serious The manpages for Emacs and Etags have the following license: Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.1 or any later version published by

Bug#341888: Problem is gone in version 0.97-2

2005-12-27 Thread Sven Joachim
In the new grub package 0.97-2, I no longer see the dreadful message Error 21: Selected disk does not exist when running grub unter a 2.4 kernel. AFICT, the only change that can be responsible for this welcome change is the removal of the odirect.diff patch, which was supposed to close

Bug#373711: libxv1: missing copyright file

2006-06-15 Thread Sven Joachim
Package: libxv1 Version: 1:1.0.1-3 Severity: serious The copyright file is missing in /usr/share/doc/libxv1. Please add it as mandated by section 12.5 of the Debian Policy Manual. -- System Information: Debian Release: testing/unstable APT prefers unstable APT policy: (500, 'unstable')

Bug#502686: ncurses-base: Overwrites files from libncurses5

2008-10-19 Thread Sven Joachim
Package: ncurses-base Version: 5.6+20081012-1 Severity: serious , | % ls -ld /usr/share/doc/*ncurses* | drwxr-xr-x 2 root root 4096 19. Okt 08:31 /usr/share/doc/libncurses5 | drwxr-xr-x 4 root root 4096 19. Okt 08:31 /usr/share/doc/libncurses5-dev | drwxr-xr-x 2 root root 4096 19. Okt 08:31

Bug#502762: Bug#429059: Bug#502762: Simple Fix - more cause and better fix

2008-10-23 Thread Sven Joachim
On 2008-10-23 12:02 +0200, Agustin Martin wrote: On Wed, Oct 22, 2008 at 06:39:20PM +0200, Agustin Martin wrote: Just noticed that this problem has already been reported against emacs22-el, and seems not strictly related to mailcrypt. #429059: emacs22-el: error message in sendmail.el stops

Bug#503340: emacs-goodies-el: etch to lenny upgrade fails

2008-10-25 Thread Sven Joachim
On 2008-10-25 07:58 +0200, Kumar Appaiah wrote: On Sat, Oct 25, 2008 at 12:20:00AM +0200, Bill Allombert wrote: Package: emacs-goodies-el Version: 29.3-2 Severity: serious Hello Peter, Upgrading from etch to lenny fails with Hi! I tried to reproduce this bug in a pristine chroot,

Bug#503340: emacs-goodies-el: etch to lenny upgrade fails

2008-10-25 Thread Sven Joachim
On 2008-10-25 00:20 +0200, Bill Allombert wrote: Package: emacs-goodies-el Version: 29.3-2 Severity: serious Hello Peter, Upgrading from etch to lenny fails with Setting up emacs22 (22.2+2-4) ... emacs-install emacs22 install/cedet-common: Handling install for emacsen flavor

Bug#503367: plink: file conflict with putty-tools

2008-10-25 Thread Sven Joachim
Package: plink Version: 1.03p1-1 Severity: serious The /usr/bin/plink name is already taken: , | # aptitude install plink | [...] | Selecting previously deselected package plink. | (Reading database ... 134796 files and directories currently installed.) | Unpacking plink (from

Bug#503340: emacs-goodies-el: etch to lenny upgrade fails

2008-10-25 Thread Sven Joachim
On 2008-10-25 08:46 +0200, Kumar Appaiah wrote: On Sat, Oct 25, 2008 at 08:15:48AM +0200, Sven Joachim wrote: - apt-get dist-upgrade then does the upgrade from emacs21 in Etch to the one in Lenny. Nowhere does it pull in emacs22. Install the `emacs' metapackage in etch, this will pull

Bug#503340: emacs-goodies-el: etch to lenny upgrade fails

2008-10-25 Thread Sven Joachim
found 503340 26.12-1 notfound 503340 29.3-2 close 503340 27.1-1 thanks On 2008-10-25 08:25 +0200, Sven Joachim wrote: On 2008-10-25 00:20 +0200, Bill Allombert wrote: Package: emacs-goodies-el Version: 29.3-2 Severity: serious Hello Peter, Upgrading from etch to lenny fails

Bug#504200: segmentation violation when running recite

2008-11-04 Thread Sven Joachim
On 2008-11-01 17:32 +0100, [EMAIL PROTECTED] wrote: Package: recite Version: 1.0-8 Severity: grave Tags: security Justification: renders package unusable When running recite ok, me and two other fairly random lenny users get a segmentation violation. Also a fairly random sid user

Bug#490893: still reproducible?

2008-11-05 Thread Sven Joachim
On 2008-11-05 11:01 +0100, Yves-Alexis Perez wrote: Is this still reproducible with the fix for #448470 which should make portmap initscript more reliable? At least one user (CC'ed) reported that the initscript did not run at all, see http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=490893#25.

Bug#506044: semi does not depend on /usr/bin/mail

2008-11-18 Thread Sven Joachim
severity 506044 serious retitle 506044 semi: installation succeeds despite byte-compilation errors thanks On 2008-11-17 23:55 +0100, Junichi Uekawa wrote: Package: semi Version: 1.14.6+0.20070618-1 Severity: grave semi fails if /usr/bin/mail is not executable but does not declare such

Bug#506498: dpkg fails with parse error in /var/lib/dpkg/status

2008-11-22 Thread Sven Joachim
On 2008-11-22 18:22 +0100, Raphael Hertzog wrote: The weird thing is that it looks like that only dpkg 1.14.23 causes you trouble and not 1.14.22. But the code that deals with lonely Triggers-Awaited dates back to Mon Aug 11 (commit 587b8d8696cb92a4a18901085db033d44bfe6f32) and dpkg 1.14.21.

Bug#495193: predictable filename if too short template used

2008-08-15 Thread Sven Joachim
On 2008-08-15 11:21 +0200, Riku Voipio wrote: mktemp /tmp/$0.$$.X The problem here is that you are using too short template. Try: mktemp /tmp/$0.$$.XXX using only 5 * X as in your version makes your app quite possibly brute-forceable. Not really, to make mktemp

Bug#495193: Etch's and Lenny's mktemp seriously broken

2008-08-15 Thread Sven Joachim
I raised the severity to critical as a lot of shell scripts in Debian rely on this data being random. Why is that important? The purpose of mktemp is to return a unique filename and to actually create the file. Can you describe an attack based on the non-randomness of the filename? Sven

Bug#495193: Etch's and Lenny's mktemp seriously broken

2008-08-15 Thread Sven Joachim
On 2008-08-15 14:42 +0200, Andreas Metzler wrote: is there actually a reason for using the PID and for limiting the non-pid part to [[A-Za-z]? Why not bugs included- --- mktemp-1.5.orig/priv_mktemp.c +++ mktemp-1.5/priv_mktemp.c @@ -81,25 +81,20 @@ register char *start,

Bug#495184: wodim: Fails, then asks me to use the option I've already given

2008-08-16 Thread Sven Joachim
On 2008-08-15 10:00 +0200, Nigel Horne wrote: Package: wodim Version: 9:1.1.8-1 Severity: grave Justification: renders package unusable wodim --devices says: wodim: No such file or directory. Cannot open SCSI driver! For possible targets try 'wodim --devices' or 'wodim -scanbus'. For

Bug#495565: emacs22-nox: Missing Files :: Installation Fails on ARM

2008-08-18 Thread Sven Joachim
severity 495565 normal tags 495565 + moreinfo thanks On 2008-08-18 20:44 +0200, Esben Stien wrote: Package: emacs22-nox Version: 22.2+2-3 Severity: grave Justification: renders package unusable Hardly. You're the first to report this, and this package has been installed successfully on

Bug#495184: wodim: Fails, then asks me to use the option I've already given

2008-08-20 Thread Sven Joachim
On 2008-08-18 10:28 +0200, Nigel Horne wrote: I was running as root, on a default system. Does Debian include root in the cdrom group by default? No, but root doesn't have to be in the cdrom group. Can you please post the output of `ls -l /dev/s[cgr]*' and `strace wodim -scanbus'? Sven

Bug#495184: wodim: Fails, then asks me to use the option I've already given

2008-08-20 Thread Sven Joachim
On 2008-08-20 12:37 +0200, Nigel Horne wrote: packard:/home/njh# ls -l /dev/s[cgr]* ls: cannot access /dev/s[cgr]*: No such file or directory Okay, so you're using the old IDE cdrom driver instead of libata/sr_mod. Should not be a problem, though. Sven -- To UNSUBSCRIBE, email to [EMAIL

Bug#495184: wodim: Fails, then asks me to use the option I've already given

2008-08-20 Thread Sven Joachim
On 2008-08-20 12:38 +0200, Nigel Horne wrote: Strace output attached. Thanks, it seems that your burner is called /dev/hdc. Is that correct? write(1, \t1000,2,0 12) 'Optiarc ' 'DVD..., 72 1000,2,0 12) 'Optiarc ' 'DVD RW AD-5170A ' '1.52' Removable CD-ROM ) = 72 Here you go, that

Bug#495954: [Pkg-openldap-devel] Bug#495954: slapd: Upgrade to Lenny failed: libldap_r-2.3.so.0 missing

2008-08-23 Thread Sven Joachim
On 2008-08-21 23:38 +0200, Steve Langasek wrote: reassign 495954 aptitude thanks On Thu, Aug 21, 2008 at 11:24:01PM +0200, Ferenc Wagner wrote: Steve Langasek [EMAIL PROTECTED] writes: On Thu, Aug 21, 2008 at 05:18:50PM +0200, Ferenc Wagner wrote: I upgraded a machine from Etch to

Bug#497837: gq: GPL license is not compatible with OpenSSL License

2008-09-04 Thread Sven Joachim
On 2008-09-04 20:11 +0200, Miriam Ruiz wrote: libssl0.9.8 [2]. which is released under OpenSSL License and the original SSLeay license, which are not compatible with the GPL [4] [5]. Thus, the resulting binary is not redsitributable at all. [snip] [1]

Bug#465748: vm: no autoloads are set up

2008-02-14 Thread Sven Joachim
Package: vm Version: 8.0.7-1 Severity: grave VM is unusable, since no autoloads are set up for it. Here are the relevant (AFAICT) startup files, all empty: , | (zsh)% ls -l /etc/emacs*/site-start.d/50vm-init.el | -rw-r--r-- 1 root root 0 Feb 9 11:50

Bug#465748: vm: no autoloads are set up

2008-02-22 Thread Sven Joachim
found 465748 8.0.9-1 thanks On 2008-02-21 23:13 +0100, Manoj Srivastava wrote: , | (zsh)% ls -l /etc/emacs*/site-start.d/50vm-init.el | -rw-r--r-- 1 root root 0 Feb 9 11:50 /etc/emacs-snapshot/site-start.d/50vm-init.el | -rw-r--r-- 1 root root 0 Feb 9 11:50

Bug#465748: vm: no autoloads are set up

2008-02-22 Thread Sven Joachim
On 2008-02-22 15:56 +0100, Manoj Srivastava wrote: Hi, On Fri, 22 Feb 2008 11:07:19 +0100, Sven Joachim [EMAIL PROTECTED] said: Thanks, vm-autoloads contains the autoloads in 8.0.9-1. However, the files /etc/emacs*/site-start.d/50vm-init.el are still empty, so the autoloads

Bug#465748: vm: no autoloads are set up

2008-03-04 Thread Sven Joachim
reopen 465748 thanks This is not really a package bug. The package does not contain any file called /etc/emacs*/site-start.d/50vm-init.el; instead, it ships /usr/share/emacs/site-lisp/vm/vm-init.el, which is shipped not empty. During installation, ucf is called to

Bug#465748: vm: no autoloads are set up

2008-03-04 Thread Sven Joachim
tags 465748 + patch thanks On 2008-03-04 10:28 +0100, Sven Joachim wrote: I now have it after closely looking at your /usr/lib/emacsen-common/packages/install/vm script. Here are the relevant actions in that script with line numbers: 43: ELDIR=/usr/share/emacs/site-lisp/$PACKAGE 44

Bug#479220: Additional information

2008-05-03 Thread Sven Joachim
Am 03.05.2008 um 20:05 schrieb Adrian Bunk: What fails is the update-alternatives invocation in irssi's prerm. That's because liblocale-gettext-perl was still the old version linked against perlapi-5.8.*, this causes the symbol lookup error. The new version had not been unpacked yet. Probably

Bug#50859: xfs Bug #50859: use start-stop-daemon --chuid ?

2008-05-16 Thread Sven Joachim
On 2008-05-12 08:15 +0200, Petter Reinholdtsen wrote: Ah, right. This work better. Now the xfs process is running as user nobody. This is the patch. diff -ur xfs-1.0.6/debian/xfs.init xfs-1.0.6.pere/debian/xfs.init --- xfs-1.0.6/debian/xfs.init 2008-05-12 08:13:32.0 +0200 +++

Bug#481186: CVE-2008-2149: buffer overflows

2008-05-16 Thread Sven Joachim
Am 16.05.2008 um 15:47 schrieb Andreas Tille: On Fri, 16 May 2008, Nico Golde wrote: - sprintf(tmpbuf, wn: invalid search option: %s\n, av[j]); + /* Fix CVE-2008-2149: buffer overflows Andreas Tille [EMAIL PROTECTED] */ + sprintf(tmpbuf, wn: invalid search

Bug#474559: Excessive Recommendations (was: Bug#474559: devscripts: *must* depend on libparse-debcontrol-perl)

2008-04-07 Thread Sven Joachim
On 2008-04-06 17:37 +0200, James Vega wrote: On Sun, Apr 06, 2008 at 04:32:40PM +0200, Christian Perrier wrote: I *did* read the warning about not reporting bug for dependencies in devscripts but I really fail to see why there should be an exception in that package. If I do the same in one of

Bug#474559: Excessive Recommendations

2008-04-07 Thread Sven Joachim
On 2008-04-07 10:26 +0200, Patrick Schoenfeld wrote: The reason for this is, that some of the useless cruft, as you call it, is used by very important scripts in the devscripts collection. Is this really true for _all_ the recommendations? The long package description does not mention why

Bug#474680: aptitude: Gets stuck resolving dependencies

2008-04-07 Thread Sven Joachim
On 2008-04-07 16:12 +0200, Daniel Burrows wrote: On Mon, Apr 07, 2008 at 09:24:03AM +0200, Sven Joachim [EMAIL PROTECTED] was heard to say: Today's aptitude safe-upgrade failed, apparently aptitude gets into an endless loop resolving the dependencies: I was wondering if this would bite

Bug#475519: emacs22-common-non-dfsg: File conflict with emacs22-common

2008-04-11 Thread Sven Joachim
Package: emacs22-common-non-dfsg Version: 22.2+1-1 Severity: serious The dired-x info file has moved from emacs22-common to emacs22-common-non-dfsg, but your package does not declare a Conflicts: or Replaces: on that package, so unpacking it fails if emacs22-common is not upgraded yet: , |

Bug#473950: How about closing this bug?

2008-04-19 Thread Sven Joachim
Now that python is at version 2.5 in sid, this bug seems to have resolved itself. Should it be closed? Sven -- To UNSUBSCRIBE, email to [EMAIL PROTECTED] with a subject of unsubscribe. Trouble? Contact [EMAIL PROTECTED]

Bug#486475: breaks xdm logins

2008-06-16 Thread Sven Joachim
On 2008-06-16 13:01 +0200, martin f krafft wrote: If I have use-session-dbus in /etc/X11/Xsession.options, xdm fails to start sessions: + exec /usr/bin/dbus-launch --exit-with-session x-window-manager XDM authorization key matches an existing client!Error: Couldn't connect to XServer I

Bug#487658: rt73-source: rt73-modules*.deb cannot be built

2008-06-23 Thread Sven Joachim
Package: rt73-source Version: 1:1.0.3.6-cvs20080623-dfsg1-1 Severity: serious Tags: patch Your package fails to build an rt73-modules*.deb: , | % LC_ALL=C m-a -t build rt73 | [...] | dh_installchangelogs CHANGELOG | install: cannot stat `CHANGELOG': No such file or directory |

Bug#488015: linux-libertine: Mozilla browsers crash

2008-06-25 Thread Sven Joachim
Package: linux-libertine Version: 2.8.14-1 Severity: serious As I discovered in #487979, iceweasel and iceape crash when they try to load the linux-libertine font. While this is probably a bug in pango, I'm filing this bug as well to prevent linux-libertine from transitioning to testing until

Bug#484270: iceweasel 3.0~b5-4 seg fault - fixed

2008-06-26 Thread Sven Joachim
On 2008-06-26 12:37 +0200, Marco Delaurenti wrote: I'm also running amd64, but unfortunately iceweasel (3.0~rc2-2) keeps crashing. I can confirm that it seems to crash inside pango. BTW, epiphany-gecko has the same problem. For another pango crash, see #487979. Maybe this is related to

Bug#489690: safe-rm: unsafe handling of dpkg-divert may leave the system without /bin/rm

2008-07-07 Thread Sven Joachim
Package: safe-rm Version: 0.2-3 Severity: critical Your usage of dpkg-divert in the maintainer scripts is very dangerous, because there are several situations where the system may be left without a functional /bin/rm: ,[ safe-rm.preinst ] | if [ install = $1 ]; then | dpkg-divert

Bug#489883: Maintainer address is not deliverable.

2008-07-08 Thread Sven Joachim
On 2008-07-08 16:14 +0200, Daniel Burrows wrote: Package: tetex-ucs Severity: serious When I reassigned a bug report to tetex-ucs, I got the attached bounce. The Maintainer address of a package ought to be deliverable IMO, even if it only exists in stable. Even if the package does not

Bug#489883: Maintainer address is not deliverable.

2008-07-08 Thread Sven Joachim
On 2008-07-08 16:30 +0200, Daniel Burrows wrote: On Tue, Jul 08, 2008 at 04:17:48PM +0200, Sven Joachim [EMAIL PROTECTED] was heard to say: Even if the package does not exist at all? ;-) You're looking for latex-ucs, not tetex-ucs. d'oh, sorry about that. latex, tetex, texlive

Bug#489690: closed by Francois Marier [EMAIL PROTECTED] (Bug#489690: fixed in safe-rm 0.2-4)

2008-07-08 Thread Sven Joachim
On 2008-07-08 09:48 +0200, Debian Bug Tracking System wrote: Changes: safe-rm (0.2-4) unstable; urgency=high . * Move the binary to /usr/bin which removes the need for a diversion (closes: #489690). Urgency high because of this critical bug. Thanks for the fast reaction.

Bug#50859: xfs Bug #50859: use start-stop-daemon --chuid ?

2008-05-16 Thread Sven Joachim
On 2008-05-16 13:07 +0200, Julien Cristau wrote: On Fri, May 16, 2008 at 08:16:20 +0200, Sven Joachim wrote: Just FYI, I've been running xfs with this patch for the last few days and don't have any problems. Could this be uploaded to unstable to get xfs back into testing? One question

Bug#50859: xfs Bug #50859: use start-stop-daemon --chuid ?

2008-05-17 Thread Sven Joachim
On 2008-05-16 23:43 +0200, Petter Reinholdtsen wrote: [Sven Joachim] Not at all, good catch. I just didn't know it even has a log file. How about compiling with -DUSE_SYSLOG? I must admit, I would prefer xfs logging to syslog. When debugging the segfault in #148650, the first place I

Bug#482551: xfs: segfaults at startup

2008-05-23 Thread Sven Joachim
Package: xfs Version: 1:1.0.7-1 Severity: grave xfs segfaults at startup, citing /var/log/messages after /etc/init.d/xfs start: , | xfs[5728]: segfault at eip b7df5be3 esp bfa7a95c error 4 ` -- System Information: Debian Release: lenny/sid APT prefers unstable APT policy:

Bug#483172: sysv-rc: does not run all shutdown scripts

2008-05-29 Thread Sven Joachim
On 2008-05-29 12:39 +0200, Petter Reinholdtsen wrote: Actually, sysv-rc is behaving as intended, designed and documented. When switching from one runlevel to another, only new start scripts are executed. So, if portmap want to stop in runlevel 0 and 6 while starting in runlevels 2-5, it

Bug#483172: sysv-rc: does not run all shutdown scripts

2008-05-29 Thread Sven Joachim
On 2008-05-29 12:49 +0200, Petter Reinholdtsen wrote: Can you test this patch? It convert the start optimization to a stop optimization for runlevels 0 and 6. Index: debian/sysv-rc/etc/init.d/rc === ---

Bug#485074: emacs21: FTBFS on amd64: Segmentation fault

2008-06-09 Thread Sven Joachim
retitle 485074 emacs21: FTBFS: Segmentation fault on dumping bootstrap-emacs under Linux 2.6.25 thanks On 2008-06-08 04:42 +0200, Daniel Schepler wrote: Package: emacs21 Version: 21.4a+1-5.4 Severity: serious From my pbuilder build log (on amd64): ... Finding pointers to doc strings...

Bug#485074: emacs21: FTBFS on amd64: Segmentation fault

2008-06-09 Thread Sven Joachim
On 2008-06-09 18:02 +0200, Sven Joachim wrote: A patch is available from [2], I will try to adopt it to the Debian package later this evening. [2] http://bugs.gentoo.org/attachment.cgi?id=152791action=view Imported it as debian/patches/fix-dumping.diff with `quilt import' and edited debian

Bug#485074: emacs21: FTBFS on amd64: Segmentation fault

2008-06-10 Thread Sven Joachim
tags 485074 + patch thanks On 2008-06-09 19:13 +0200, Sven Joachim wrote: On 2008-06-09 18:02 +0200, Sven Joachim wrote: A patch is available from [2], I will try to adopt it to the Debian package later this evening. [2] http://bugs.gentoo.org/attachment.cgi?id=152791action=view Imported

Bug#485603: libpopt0: Conflicts with libpopt-dev from the same source

2008-06-10 Thread Sven Joachim
Package: libpopt0 Version: 1.14-1 Severity: serious libpopt0 1.14-11 Conflicts: libpopt-dev (= 1.14-1), making the latter one uninstallable. Please change the '=' to ''. -- System Information: Debian Release: lenny/sid APT prefers unstable APT policy: (500, 'unstable') Architecture: i386

Bug#483102: portmap: /var is busy on shutdown

2008-06-11 Thread Sven Joachim
On 2008-06-11 18:22 +0200, Petter Reinholdtsen wrote: [Sven Joachim] I couldn't really believe it, so I removed /etc/rc4.d/S18portmap, switched to runlevel 4 with init 4 and rebooted. And voila, S32portmap ran successfully. This was an old bug in sysv-rc, now fixed in unstable and testing

Bug#498115: emms: fails 'emacs-package-install', leaving package half-configured

2008-09-08 Thread Sven Joachim
On 2008-09-08 13:48 +0200, Arnaud Fontaine wrote: Actually url.el is not provided only by emacs21 but it is in w3-url-e21, so I will add a Depends against w3-url-e21. Thanks for the report. This is not a very fortunate solution, since it forces emms users to install an obsolete Emacs version.

Bug#494468: lower the severity?

2008-09-09 Thread Sven Joachim
On 2008-09-09 10:27 +0200, Neil Williams wrote: The package supports a method of adding unsupported locales but that this method does not appear to have been used. Unless the submitter can demonstrate that the existing support is broken, I think this bug should be downgraded to normal. It

Bug#494468: lower the severity?

2008-09-09 Thread Sven Joachim
On 2008-09-09 11:09 +0200, Neil Williams wrote: On Tue, 2008-09-09 at 11:03 +0200, Sven Joachim wrote: For the record, the path is /usr/local/share/i18n/SUPPORTED (not /usr/locale/...), and that seems perfectly reasonable, since you don't want to edit files under /usr locally. In that case

Bug#498829: dict-devil does not contain any entries

2008-09-13 Thread Sven Joachim
/debian/changelog --- dict-devil-1.0/debian/changelog +++ dict-devil-1.0/debian/changelog @@ -1,3 +1,11 @@ +dict-devil (1.0-10) unstable; urgency=medium + + * QA Upload. + * Make debian/devil2dict executable to get some content into +the binary package (Closes: #498829). + + -- Sven Joachim

Bug#498829: dict-devil does not contain any entries

2008-09-13 Thread Sven Joachim
On 2008-09-13 23:03 +0200, Frank Lichtenheld wrote: I can do an upload tomorrow, seeing that I did the last upload. (I suspect it was broken before that, though) The previous maintainer apparently had built the package with debian/devil2dict being executable, so the bug did only show up after

Bug#499173: dpkg - depends against optional package

2008-09-16 Thread Sven Joachim
reassign 499173 ftp.debian.org retitle 499173 ftp.debian.org: lzma must be of priority required severity 499173 serious thanks On 2008-09-16 21:04 +0200, Bastian Blank wrote: dpkg pre-depends on lzma which is still optional. See §2.5 Policy. Which means that the priority of lzma needs to be

Bug#499555: aptitude safe-upgrade (and pretty much everything else) segfaults.

2008-09-19 Thread Sven Joachim
reassign 499555 apt 0.7.15~exp1 merge 499322 499555 thanks On 2008-09-19 20:30 +0200, Jason Riedy wrote: Package: aptitude Version: 0.4.11.10-1 Severity: grave Justification: renders package unusable Ka-boom. Makes installing debug libraries a pain, and I'm on a *slow* network right

  1   2   3   4   5   6   7   8   9   >