Bug#961990: libgcc1 : Depends: gcc-10-base (= 10.1.0-1) but 10.1.0-2 is to be installed

2020-06-02 Thread Luis Alejandro Martínez Faneyth
Nope, doesn't work. Tried installing libgcc-s1 first and then apt is still
asking for libgcc1 when I try to install Node.js.

I guess that is because there's still a physical libgcc1 on the sid
archive, right? Shouldn't that be removed?

https://packages.debian.org/search?keywords=libgcc1

El mar., 2 de jun. de 2020 a la(s) 10:00, Luis Alejandro Martínez Faneyth (
l...@luisalejandro.org) escribió:

> Oh wait, I get it, libgcc-s1 *Provides* libgcc1. I'll try it, thanks.
>
> El mar., 2 de jun. de 2020 a la(s) 09:13, Luis Alejandro Martínez Faneyth (
> l...@luisalejandro.org) escribió:
>
>> I wish I could, but there are several third party apps that depend on
>> libgcc1, for example:
>>
>> Node.js
>>
>> https://deb.nodesource.com/node_13.x/dists/buster/main/binary-amd64/Packages
>>
>> MongoDB
>>
>> http://repo.mongodb.org/apt/debian/dists/buster/mongodb-org/4.2/main/binary-amd64/Packages
>>
>> I suppose there are more, but I haven't tested them.
>>
>>
>>
>> El mar., 2 de jun. de 2020 a la(s) 03:50, Matthias Klose (d...@debian.org)
>> escribió:
>>
>>> On 6/1/20 5:34 PM, Luis Alejandro Martínez Faneyth wrote:
>>> > Package: libgcc1
>>> > Version: 10.1.0-1
>>> > X-Debbugs-CC: debian-gcc@lists.debian.org
>>> >
>>> > Hello everyone. I have been getting this installation error with GCC
>>> 10 on
>>> > Debian Sid, here's the full log:
>>> >
>>> >
>>> > + apt-get install -d ca-certificates libc6 libgcc1 libnode64 libstdc++6
>>> > python-minimal
>>> >
>>> > Reading package lists...
>>> > Building dependency tree...
>>> > Reading state information...
>>> > ca-certificates is already the newest version (20190110).
>>> > libstdc++6 is already the newest version (10.1.0-2).
>>> > libc6 is already the newest version (2.30-8).
>>> > Some packages could not be installed. This may mean that you have
>>> > requested an impossible situation or if you are using the unstable
>>> > distribution that some required packages have not yet been created
>>> > or been moved out of Incoming.
>>> > The following information may help to resolve the situation:
>>> >
>>> > The following packages have unmet dependencies:
>>> >  libgcc1 : Depends: gcc-10-base (= 10.1.0-1) but 10.1.0-2 is to be
>>> installed
>>> >
>>> >
>>> > This has something to do with the auto-libgc transition? what possible
>>> > workarounds do I have? Because of this I can't install a number of apps
>>> > depending on libgcc (mongo, node, etc).
>>>
>>> just remove libgcc1, it's provided by libgcc-s1.
>>>
>>
>>
>> --
>> Luis Alejandro Martínez Faneyth
>> Blog: https://luisalejandro.org
>> Github: https://github.com/LuisAlejandro
>> <http://github.com/LuisAlejandro>
>> Twitter: https://twitter.com/LuisAlejandro
>> <http://twitter.com/LuisAlejandro>
>>
>> CODE IS POETRY
>>
>
>
> --
> Luis Alejandro Martínez Faneyth
> Blog: https://luisalejandro.org
> Github: https://github.com/LuisAlejandro <http://github.com/LuisAlejandro>
> Twitter: https://twitter.com/LuisAlejandro
> <http://twitter.com/LuisAlejandro>
>
> CODE IS POETRY
>


-- 
Luis Alejandro Martínez Faneyth
Blog: https://luisalejandro.org
Github: https://github.com/LuisAlejandro <http://github.com/LuisAlejandro>
Twitter: https://twitter.com/LuisAlejandro
<http://twitter.com/LuisAlejandro>

CODE IS POETRY


Bug#961990: libgcc1 : Depends: gcc-10-base (= 10.1.0-1) but 10.1.0-2 is to be installed

2020-06-02 Thread Luis Alejandro Martínez Faneyth
Oh wait, I get it, libgcc-s1 *Provides* libgcc1. I'll try it, thanks.

El mar., 2 de jun. de 2020 a la(s) 09:13, Luis Alejandro Martínez Faneyth (
l...@luisalejandro.org) escribió:

> I wish I could, but there are several third party apps that depend on
> libgcc1, for example:
>
> Node.js
>
> https://deb.nodesource.com/node_13.x/dists/buster/main/binary-amd64/Packages
>
> MongoDB
>
> http://repo.mongodb.org/apt/debian/dists/buster/mongodb-org/4.2/main/binary-amd64/Packages
>
> I suppose there are more, but I haven't tested them.
>
>
>
> El mar., 2 de jun. de 2020 a la(s) 03:50, Matthias Klose (d...@debian.org)
> escribió:
>
>> On 6/1/20 5:34 PM, Luis Alejandro Martínez Faneyth wrote:
>> > Package: libgcc1
>> > Version: 10.1.0-1
>> > X-Debbugs-CC: debian-gcc@lists.debian.org
>> >
>> > Hello everyone. I have been getting this installation error with GCC 10
>> on
>> > Debian Sid, here's the full log:
>> >
>> >
>> > + apt-get install -d ca-certificates libc6 libgcc1 libnode64 libstdc++6
>> > python-minimal
>> >
>> > Reading package lists...
>> > Building dependency tree...
>> > Reading state information...
>> > ca-certificates is already the newest version (20190110).
>> > libstdc++6 is already the newest version (10.1.0-2).
>> > libc6 is already the newest version (2.30-8).
>> > Some packages could not be installed. This may mean that you have
>> > requested an impossible situation or if you are using the unstable
>> > distribution that some required packages have not yet been created
>> > or been moved out of Incoming.
>> > The following information may help to resolve the situation:
>> >
>> > The following packages have unmet dependencies:
>> >  libgcc1 : Depends: gcc-10-base (= 10.1.0-1) but 10.1.0-2 is to be
>> installed
>> >
>> >
>> > This has something to do with the auto-libgc transition? what possible
>> > workarounds do I have? Because of this I can't install a number of apps
>> > depending on libgcc (mongo, node, etc).
>>
>> just remove libgcc1, it's provided by libgcc-s1.
>>
>
>
> --
> Luis Alejandro Martínez Faneyth
> Blog: https://luisalejandro.org
> Github: https://github.com/LuisAlejandro <http://github.com/LuisAlejandro>
> Twitter: https://twitter.com/LuisAlejandro
> <http://twitter.com/LuisAlejandro>
>
> CODE IS POETRY
>


-- 
Luis Alejandro Martínez Faneyth
Blog: https://luisalejandro.org
Github: https://github.com/LuisAlejandro <http://github.com/LuisAlejandro>
Twitter: https://twitter.com/LuisAlejandro
<http://twitter.com/LuisAlejandro>

CODE IS POETRY


Bug#961990: libgcc1 : Depends: gcc-10-base (= 10.1.0-1) but 10.1.0-2 is to be installed

2020-06-02 Thread Luis Alejandro Martínez Faneyth
I wish I could, but there are several third party apps that depend on
libgcc1, for example:

Node.js
https://deb.nodesource.com/node_13.x/dists/buster/main/binary-amd64/Packages

MongoDB
http://repo.mongodb.org/apt/debian/dists/buster/mongodb-org/4.2/main/binary-amd64/Packages

I suppose there are more, but I haven't tested them.



El mar., 2 de jun. de 2020 a la(s) 03:50, Matthias Klose (d...@debian.org)
escribió:

> On 6/1/20 5:34 PM, Luis Alejandro Martínez Faneyth wrote:
> > Package: libgcc1
> > Version: 10.1.0-1
> > X-Debbugs-CC: debian-gcc@lists.debian.org
> >
> > Hello everyone. I have been getting this installation error with GCC 10
> on
> > Debian Sid, here's the full log:
> >
> >
> > + apt-get install -d ca-certificates libc6 libgcc1 libnode64 libstdc++6
> > python-minimal
> >
> > Reading package lists...
> > Building dependency tree...
> > Reading state information...
> > ca-certificates is already the newest version (20190110).
> > libstdc++6 is already the newest version (10.1.0-2).
> > libc6 is already the newest version (2.30-8).
> > Some packages could not be installed. This may mean that you have
> > requested an impossible situation or if you are using the unstable
> > distribution that some required packages have not yet been created
> > or been moved out of Incoming.
> > The following information may help to resolve the situation:
> >
> > The following packages have unmet dependencies:
> >  libgcc1 : Depends: gcc-10-base (= 10.1.0-1) but 10.1.0-2 is to be
> installed
> >
> >
> > This has something to do with the auto-libgc transition? what possible
> > workarounds do I have? Because of this I can't install a number of apps
> > depending on libgcc (mongo, node, etc).
>
> just remove libgcc1, it's provided by libgcc-s1.
>


-- 
Luis Alejandro Martínez Faneyth
Blog: https://luisalejandro.org
Github: https://github.com/LuisAlejandro <http://github.com/LuisAlejandro>
Twitter: https://twitter.com/LuisAlejandro
<http://twitter.com/LuisAlejandro>

CODE IS POETRY


Bug#961990: libgcc1 : Depends: gcc-10-base (= 10.1.0-1) but 10.1.0-2 is to be installed

2020-06-01 Thread Luis Alejandro Martínez Faneyth
Package: libgcc1
Version: 10.1.0-1
X-Debbugs-CC: debian-gcc@lists.debian.org

Hello everyone. I have been getting this installation error with GCC 10 on
Debian Sid, here's the full log:


+ apt-get install -d ca-certificates libc6 libgcc1 libnode64 libstdc++6
python-minimal

Reading package lists...
Building dependency tree...
Reading state information...
ca-certificates is already the newest version (20190110).
libstdc++6 is already the newest version (10.1.0-2).
libc6 is already the newest version (2.30-8).
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libgcc1 : Depends: gcc-10-base (= 10.1.0-1) but 10.1.0-2 is to be installed


This has something to do with the auto-libgc transition? what possible
workarounds do I have? Because of this I can't install a number of apps
depending on libgcc (mongo, node, etc).

Greetings,


-- 
Luis Alejandro Martínez Faneyth
Blog: https://luisalejandro.org
Github: https://github.com/LuisAlejandro
Twitter: https://twitter.com/LuisAlejandro

CODE IS POETRY