Bug#595495: lib32gcc1: preinst may do rm -rf /usr/lib32

2010-09-04 Thread Andreas Beckmann
Package: lib32gcc1 Version: 1:4.4.4-11 Severity: grave Tags: sid Justification: causes non-serious data loss Hi, some recent packaging changes have resurrected an ancient preinst script that handles^Wmesses with some things related to /usr/lib32 and /emul/ia32-linux/usr/lib. As a result

Bug#595495: fix affected versions

2010-09-04 Thread Andreas Beckmann
found 595495 1:4.4.4-12 notfound 595495 1:4.4.4-11 found 595495 1:4.5.1-4 thanks Since I couldn't report the bug from the pbuilder environment, I messed up the affected versions. It is now also reproducible with the latest version in experimental. The problem seems to be

Bug#595495: #595495 affects gcc-4.4 and gcc-4.5

2010-09-04 Thread Andreas Beckmann
reassign 595495 src:gcc-4.5 4.5.1-4 clone 595495 -1 reassign -1 src:gcc-4.4 4.4.4-12 tags 595495 - sid + experimental thanks Reassigning to the source package (both gcc-4.4 and gcc-4.5 build lib32gcc1) and cloning to notify gcc-4.4 of this RC bug. Andreas -- To UNSUBSCRIBE, email to

Bug#420189: g++-4.1: fails to compile correct template code - 4.1.[01] regression

2007-04-20 Thread Andreas Beckmann
Package: g++-4.1 Version: 4.1.1-21 Severity: normal Hi, I have problems with some heavy templated code, which can't be compiled by g++ 4.1.1. It's not an ICE! The following compilers (Debian packages) do compile it: g++-3.3, g++-3.4, g++-4.0, g++-4.1.2 (Debian experimental) I have no 4.1.0

Bug#460736: gcc-4.2: openmp support went lost: omp.h, ... missing

2008-01-14 Thread Andreas Beckmann
Package: gcc-4.2 Version: 4.2.2-6 Severity: important Hi, in the last upload of gcc-4.2 (4.2.2-6) openmp support went lost. The following files are missing (compared to 4.2.2-4, thx to debdiff): -rw-r--r-- root/root /usr/lib/gcc/i486-linux-gnu/4.2/SYSCALLS.c.X -rw-r--r-- root/root

Bug#455555: libstdc++5 is available in lenny's ia32-libs

2008-01-15 Thread Andreas Beckmann
Hi, today I ran into this problem, too. But since I'm running testing, I could use the ia32-libs package available there. This version (2.2) includes libstdc++.so.5. Andreas -- To UNSUBSCRIBE, email to [EMAIL PROTECTED] with a subject of unsubscribe. Trouble? Contact [EMAIL PROTECTED]

Bug#221621: gcc-3.3: fails to compile the linux kernel

2003-11-19 Thread Andreas Beckmann
Package: gcc-3.3 Version: 1:3.3.2-4 Severity: normal While compiling the kernel on a sparc system I get the following errors in kernel-source-2.4.22/arch/sparc/kernel/check_asm.c: gcc -o check_asm check_asm.c check_asm.c:309: error: field name not in record or union initializer check_asm.c:309:

Bug#677582: gcc-4.4-base: upgrade problems since removal of gcj-4.4

2012-06-14 Thread Andreas Beckmann
Package: gcc-4.4-base Version: 4.4.7-1 Severity: important User: debian...@lists.debian.org Usertags: piuparts Hi, during piuparts dist-upgrade tests I noticed problems upgrading from squeeze if gcj-4.4 is installed. gcj-4.4 was recently removed from sid and testing and there is no clean

Bug#677582: gcc-4.4-base: upgrade problems since removal of gcj-4.4

2012-06-22 Thread Andreas Beckmann
severity serious thanks Raising the severity to serious as I see now about 60 packages (e.g. libjboss-*-java) failing the squeeze=wheezy dist-upgrade test because of this, I'm not sure about the correct package to assign this to. On 2012-06-15 03:10, Andreas Beckmann wrote: during piuparts

Bug#677582: gcc-4.4-base: upgrade problems since removal of gcj-4.4

2012-08-04 Thread Andreas Beckmann
On 2012-08-04 11:42, Julien Cristau wrote: On Sat, Aug 4, 2012 at 11:14:15 +0200, Andreas Beckmann wrote: OK, that's not what we want. There shouln't be packages kept back. FWIW that result doesn't seem all that bad to me. In squeeze2wheezy/main piuparts test I currently see 172 passed logs

Bug#677582: gcc-4.4-base: NMU gcc-4.4 4.4.7-2.1 prepared to fix upgrade paths

2012-09-15 Thread Andreas Beckmann
) +Fixes some squeeze-wheezy upgrade paths where apt chooses to hold back +gcc-4.4-base and keep gcj-4.4-base installed instead of upgrading +gcc-4.4-base and removing the obsolete gcj-4.4-base. + + -- Andreas Beckmann deb...@abeckmann.de Sat, 15 Sep 2012 12:57:31 +0200 + gcc-4.4 (4.4.7

Bug#677582: fixed in gcc-4.4 4.4.7-3

2012-09-21 Thread Andreas Beckmann
Version: 4.4.7-3 Unfortunately my patch (that was working well at the time I wrote and tested it) is no longer fixing the situation. Probably something has changed in the dependency tree and apt now goes for a different solution and continues to hold back gcc-4.4-base instead of removing gcj-4.4

Bug#677582: needs to be fixed in gcc-4.7-base (gcc-4.4-base: upgrade problems since removal of gcj-4.4)

2012-09-22 Thread Andreas Beckmann
reassign 677582 gcc-4.7-base 4.7.2-2 reopen 677582 thanks On 2012-09-21 14:22, Andreas Beckmann wrote: [...] I'm now trying to add these Breaks to gcc-4.7-base, that can't be held back, hopefully. Attached is a diff that finally fixes this upgrade issue, hopefully. gcc-4.7-base isn't

Bug#677582: needs to be fixed in gcc-4.7-base (gcc-4.4-base: upgrade problems since removal of gcj-4.4)

2012-09-22 Thread Andreas Beckmann
On 2012-09-22 12:08, Matthias Klose wrote: I don't want this in gcc-4.7. Please provide a patch for gcc-defaults. This should work as well. That won't work, just tried it. The only package from gcc-defaults that could be involved in the problematic upgrade paths is gcj-jre-headless and that

Bug#677582: needs to be fixed in gcc-4.7-base (gcc-4.4-base: upgrade problems since removal of gcj-4.4)

2012-09-23 Thread Andreas Beckmann
On 2012-09-23 14:32, Matthias Klose wrote: On 22.09.2012 15:04, Andreas Beckmann wrote: On 2012-09-22 12:08, Matthias Klose wrote: I don't want this in gcc-4.7. Please provide a patch for gcc-defaults. This should work as well. That won't work, just tried it. The only package from gcc

Bug#690172: gcc-4.7-base: adding Breaks: gcc-4.4-base ( 4.4.7) ?

2012-10-10 Thread Andreas Beckmann
Package: gcc-4.7-base Version: 4.7.2-4 Severity: whishlist Hi Matthias, breaking the old versions of gcj-4.4-base seems to work fine in sid (#677582). Thanks again for adding these. Now I have discovered some more upgrade issues involving some old libgnustep*, libobjc2 and gcc-4.4-base. apt

Bug#692119: {cpp, gfortran, gnat}-4.4-doc: copyright file missing after upgrade (policy 12.5)

2012-11-02 Thread Andreas Beckmann
Package: cpp-4.4-doc,gfortran-4.4-doc,gnat-4.4-doc Version: 4.4.7-1 Severity: serious User: debian...@lists.debian.org Usertags: piuparts Hi, a test with piuparts revealed that your package misses the copyright file after an upgrade from squeeze to sid, which is a violation of Policy 12.5:

Bug#533009: lib32ffi5: missing Conflicts: libc6-i386 (= 2.9-18)

2012-11-10 Thread Andreas Beckmann
Control: found -1 3.0.9-3 Hi, I just noticed the Conflicts: libc6-i386 (= 2.9-18) that was supposedly added in 3.0.7-2 has disappeared later on again, causing incorrect updates from lenny to squeeze by installing the library over the /usr/lib32 - /emul/... symlink before that gets replaced

Bug#690172: gcc-4.7-base: adding Breaks: gcc-4.4-base ( 4.4.7) ?

2013-01-17 Thread Andreas Beckmann
Hi, how are the chances of getting this fix in sid and wheezy? I just verified that this really fixes the upgrade paths involving gnustep-back0.18 and friends. Andreas -- To UNSUBSCRIBE, email to debian-gcc-requ...@lists.debian.org with a subject of unsubscribe. Trouble? Contact

Bug#690172: gcc-4.7-base: adding Breaks: gcc-4.4-base ( 4.4.7) ?

2013-02-16 Thread Andreas Beckmann
Control: severity -1 serious On 2013-01-17 16:10, Andreas Beckmann wrote: Hi, how are the chances of getting this fix in sid and wheezy? I just verified that this really fixes the upgrade paths involving gnustep-back0.18 and friends. Raising the severity as this causes several incomplete

Bug#690172: updating gcc via sid currently blocked by mpfr4 update

2013-02-25 Thread Andreas Beckmann
Hi, due to the upload of a new upstream of mpfr4 to sid gcc built in sid will pick up a bumped libmpfr4 dependency not satisfiable in testing. Andreas -- To UNSUBSCRIBE, email to debian-gcc-requ...@lists.debian.org with a subject of unsubscribe. Trouble? Contact listmas...@lists.debian.org

Bug#708521: pu: package gcc-4.7/4.7.2-5+deb7u1

2013-05-16 Thread Andreas Beckmann
Breaks: gcc-4.4-base ( 4.4.7) (Closes: #690172) + + -- Andreas Beckmann deb...@abeckmann.de Thu, 17 Jan 2013 14:10:12 +0100 + gcc-4.7 (4.7.2-5) unstable; urgency=low * Add __gnu_* symbols to the libgcc1 symbols file for armel and armhf.

Bug#734913: gcc-4.9: file conflicts with packages built from src:gcc-4.8

2014-01-10 Thread Andreas Beckmann
Source: gcc-4.9 Version: 4.9-20140109-1 Severity: serious on amd64: lib32stdc++6-4.8-dbg 4.8.2-12 and lib32stdc++6-4.9-dbg 4.9-20140109-1 usr/lib32/debug/libstdc++.a usr/lib32/debug/libstdc++.so usr/lib32/debug/libstdc++.so.6 libstdc++-4.8-doc 4.8.2-12 and libstdc++-4.9-doc 4.9-20140109-1

Bug#734913: gcc-4.9: file conflicts with packages built from src:gcc-4.8

2014-01-18 Thread Andreas Beckmann
Followup-For: Bug #734913 Hi, the recent fix did not cover all cases: * libstdc++-4.9-doc needs to Conflicts: libstdc++-4.8-doc (not libstdc++6-4.8-doc) * libx32stdc++6-4.9-dbg needs to Conflicts: libx32stdc++6-4.8-dbg To avoid having the list of conflicts growing infinitely in the future,

Bug#736607: gcc-4.8-base: please Break gcc-4.7-base from wheezy

2014-01-25 Thread Andreas Beckmann
Package: gcc-4.8-base Version: 4.8.2-14 Severity: normal Tags: patch Hi, please add a Breaks: gcc-4.7-base ( 4.7.3) to gcc-4.8-base. This should simplify wheezy-jessie upgrades where apt prefers to keep the wheezy version (4.7.2-5) installed instead of removing some old packages and upgrading to

Bug#770025: gcc-4.9-base: please add Breaks: gcc-4.7-base ( 4.7.3) as in gcc-4.8-base

2014-11-18 Thread Andreas Beckmann
Package: gcc-4.9-base Version: 4.9.1-19 Severity: important User: debian...@lists.debian.org Usertags: piuparts Hi, please sync the Breaks between gcc-4.8-base and gcc-4.9-base s.t. both include Breaks: gcc-4.7-base ( 4.7.3). This will ensure more consistent upgrade behavior from wheezy to

Bug#770025: gcc-4.9-base: please add Breaks: gcc-4.7-base ( 4.7.3) as in gcc-4.8-base

2014-11-26 Thread Andreas Beckmann
On 2014-11-26 07:47, Julien Cristau wrote: On Tue, Nov 18, 2014 at 13:13:35 +0100, Andreas Beckmann wrote: I currently face upgrade problrms in piuparts where a minimal chroot keeps gcc-4.7-base installed after a distupgrade (this is taken as a reference), but a chroot with some packages

Bug#779876: gcc-4.9-base: please add Breaks: gnat-4.6-base ( 4.6.4)

2015-03-05 Thread Andreas Beckmann
Package: gcc-4.9-base Version: 4.9.1-19 Severity: important User: debian...@lists.debian.org Usertags: piuparts Hi, during my piuparts wheezy-jessie upgrade tests I noticed some cases where gnat-4.6 was kept installed and gnat-4.9 was not being installed, holding back some more old packages on

Bug#788455: libppl-dev: unhandled symlink to directory conversion: /usr/share/doc/PACKAGE

2015-06-11 Thread Andreas Beckmann
Package: libppl-dev Version: 1:1.1-4 Severity: serious User: debian...@lists.debian.org Usertags: piuparts Hi, an upgrade test with piuparts revealed that your package installs files over existing symlinks and possibly overwrites files owned by other packages. This usually means an old version

Bug#794329: gdc-multilib: uninstallable in sid: Depends: gdc (= 4:5.2.1-2), but sid has gdc (5.2.1-2)

2015-08-01 Thread Andreas Beckmann
Package: gdc-multilib Version: 4:5.2.1-2 Severity: serious User: debian...@lists.debian.org Usertags: piuparts Hi, during a test with piuparts I noticed your package is not installable in sid: gdc-multilib/amd64 unsatisfiable Depends: gdc (= 4:5.2.1-2) gdc-multilib/i386 unsatisfiable Depends:

Bug#793873: gcc-4.6: should not be released with stretch

2015-07-28 Thread Andreas Beckmann
Source: gcc-4.6 Version: 4.6.4-7 Severity: serious gcc-4.6 was not released with jessie, so it probably should not return in stretch. If you are filing a RM bug for gcc-4.6, please have gcc-4.6-doc removed from non-free, too. Andreas who has just started the AUTORM timer :-) -- To

Bug#787486: ppl: FTBFS with swi-prolog 7.x

2015-07-20 Thread Andreas Beckmann
Control: retitle -1 ppl: FTBFS with swi-prolog 7.x Since it built in 'stretch/testing' successfully I looked at the difference in installed packages after satisfying the build dependencies ... the only interesting package with a newer upstream version in sid seemed to be swi-prolog ... and then

Bug#788455: libppl-dev: unhandled symlink to directory conversion: /usr/share/doc/PACKAGE

2015-07-20 Thread Andreas Beckmann
to the package in lenny +as the libppl-dev package did not exist in squeeze or wheezy. +(Closes: #788455) + * libppl-dev: Update Breaks+Conflicts to match Replaces+Provides. + + -- Andreas Beckmann a...@debian.org Mon, 20 Jul 2015 03:28:48 +0200 + ppl (1:1.1-4) unstable; urgency=medium

Bug#799953: gcc-4.9: incorrect double to integer conversion on i386

2015-11-16 Thread Andreas Beckmann
Control: forwarded -1 https://gcc.gnu.org/bugzilla/show_bug.cgi?id=323 On Thu, 24 Sep 2015 18:42:14 +0200 Miroslav Urbanek wrote: > I believe I've found a bug in GCC that affects plymouth and maybe > other packages on i386. The following minimal code produces an >

Bug#807885: libstdc++6-6-dbg: fails to upgrade from 'sid' - trying to overwrite /usr/lib/x86_64-linux-gnu/debug/libstdc++.a

2015-12-13 Thread Andreas Beckmann
Package: libstdc++6-6-dbg Version: 6-20151211-1 Severity: serious User: debian...@lists.debian.org Usertags: piuparts Hi, during a test with piuparts I noticed your package fails to upgrade from 'sid' to 'experimental'. It installed fine in 'sid', then the upgrade to 'experimental' fails because

Bug#810514: libgcj17{,-awt}: missing Breaks+Replaces on libgcj16{,-awt}

2016-01-09 Thread Andreas Beckmann
Package: libgcj17,libgcj17-awt Version: 6-20160103-1 Severity: serious User: debian...@lists.debian.org Usertags: piuparts Hi, during a test with piuparts I noticed your package failed to install because it tries to overwrite other packages files without declaring a Breaks+Replaces relation.

Bug#810514: lib32stdc++6-6-dbg, libx32stdc++6-6-dbg, libgccjit-6-doc: missing Breaks+Replaces on their *-5-* counterparts

2016-01-09 Thread Andreas Beckmann
Severity: serious Followup-For: Bug #810514 User: debian...@lists.debian.org Usertags: piuparts Hi, during a test with piuparts I noticed your package fails to upgrade from 'sid' to 'experimental'. It installed fine in 'sid', then the upgrade to 'experimental' fails because it tries to overwrite

Bug#805616: gcc-4.9: GCC++ 4.9 compiler had ICE (internal compiler error)

2015-11-21 Thread Andreas Beckmann
verified in g++-4.9 built from svn: $ g++-4.9.x -v -std=gnu++11 -fno-strict-aliasing -O2 -c 805616..ii Using built-in specs. COLLECT_GCC=/opt/software/x86_64/gcc-4.9.x/bin/g++-4.9.x Target: x86_64-unknown-linux-gnu Configured with: ../gcc-4_9-branch/configure

Bug#810514: closed by Matthias Klose <d...@debian.org> (Re: Bug#810514: libgcj17{,-awt}: missing Breaks+Replaces on libgcj16{,-awt})

2016-01-12 Thread Andreas Beckmann
Control: found -1 6-20160109-1 On 2016-01-09 20:51, Debian Bug Tracking System wrote: > Version: 6-20160109-1 I can still reproduce these overwrite conflicts with the 20160109 snapshot. Andreas

Bug#810809: gnat-6-, libgnat{prj, vsn}6-dev--cross: fails to upgrade from 'sid' - trying to overwrite /usr/bin/-gnatxref, /usr//lib/libgnat{vsn, prj}.a

2016-01-12 Thread Andreas Beckmann
Source: gcc-6-cross Version: 6-20160109-1cross1 Severity: serious User: debian...@lists.debian.org Usertags: piuparts Hi, During a test with piuparts I noticed your package fails to upgrade from 'sid' to 'experimental'. It installed fine in 'sid', then the upgrade to 'experimental' fails because

Bug#826583: gdc-5: fails to upgrade from 'testing' - trying to overwrite /usr/lib/gcc/x86_64-linux-gnu/5/include/d/__entrypoint.di

2016-06-06 Thread Andreas Beckmann
Package: gdc-5 Version: 5.4.0-3 Severity: serious User: debian...@lists.debian.org Usertags: piuparts Hi, during a test with piuparts I noticed your package fails to upgrade from 'testing'. It installed fine in 'testing', then the upgrade to 'sid' fails because it tries to overwrite other

Bug#825320: gcc-doc-defaults: FTBFS in sid: error in 'Version' field string '5:': nothing after colon in version number

2016-05-25 Thread Andreas Beckmann
Source: gcc-doc-defaults Version: 5:14 Severity: serious Justification: fails to build from source (but built successfully in the past) Hi, gcc-doc-defaults FTBFS in curent sid: dh_builddeb dpkg-deb: building package 'gcc-doc' in '../gcc-doc_5.1.0-1_amd64.deb'. dpkg-deb: building package

Bug#825361: libgcj-bc: shlibs file generates unsatisfiable dependency

2016-05-26 Thread Andreas Beckmann
Package: libgcj-bc Version: 5.3.1-2 Severity: serious Hi, the libgcj-bc.shlibs file contains libgcj_bc 1 libgcj-bc (>= 5.3.1-17~) which is unsatisfiable and causes e.g. uninstallable ant packages: https://packages.qa.debian.org/a/ant.html Should this have been libgcj_bc 1 libgcj16

Bug#810717: libstdc++-6-doc: package corrupted?

2016-01-11 Thread Andreas Beckmann
Package: libstdc++-6-doc Version: 6-20160109-1 Severity: serious User: debian...@lists.debian.org Usertags: piuparts Hi, during a test with piuparts I noticed your package failed to install. As per definition of the release team this makes the package too buggy for a release, thus the severity.

Bug#810809: gnat-6-, libgnat{prj, vsn}6-dev--cross: fails to upgrade from 'sid' - trying to overwrite /usr/bin/-gnatxref, /usr//lib/libgnat{vsn, prj}.a

2016-02-12 Thread Andreas Beckmann
Followup-For: Bug #810809 Control: reassign -1 src:gcc-6 6-20160205-1 Control: reopen -1 Control: affects -1 + src:gcc-6-cross src:gcc-6-cross-ports Hi, the *gnat*-cross package relationships seem not to work correctly, yet: Selecting previously unselected package gnat-6-aarch64-linux-gnu.

Bug#814527: libgccjit-6-doc: should Conflicts: libgccjit-5-doc, not itself

2016-02-12 Thread Andreas Beckmann
Package: libgccjit-6-doc Version: 6-20160205-1 Severity: serious User: debian...@lists.debian.org Usertags: piuparts Hi, during a test with piuparts I noticed your package fails to upgrade from 'sid' to 'experimental'. It installed fine in 'sid', then the upgrade to 'experimental' fails because

Bug#813081: lib{, x}32stdc++6-6-dbg, libgccjit-6-doc: fails to upgrade from 'sid' - trying to overwrite /usr/lib{, x}32/debug/libstdc++fs.a, /usr/share/info/libgccjit.info.gz

2016-01-29 Thread Andreas Beckmann
Package: libx32stdc++6-6-dbg,lib32stdc++6-6-dbg,libgccjit-6-doc Version: 6-20160122-1 Severity: serious User: debian...@lists.debian.org Usertags: piuparts Hi, during a test with piuparts I noticed your package fails to upgrade from 'sid' to 'experimental'. It installed fine in 'sid', then the

Bug#818873: gcc-5-cross: FTBFS when built with dpkg-buildpackage -A (No such file or directory)

2016-05-09 Thread Andreas Beckmann
Followup-For: Bug #818873 Hi, in https://buildd.debian.org/status/fetch.php?pkg=gcc-5-cross=all=21=1462410260 the failing command is DEB_HOST_ARCH=s390x ARCH=s390x MAKEFLAGS="CC=something" dh_shlibdeps -plibgnat-5-s390x-cross \

Bug#818873: gcc-5-cross: FTBFS when built with dpkg-buildpackage -A (No such file or directory)

2016-05-09 Thread Andreas Beckmann
Control: tag -1 - help + pending On 2016-05-09 11:54, Matthias Klose wrote: > On 09.05.2016 10:17, Andreas Beckmann wrote: >> Followup-For: Bug #818873 > > that's already fixed in the VCS. Good, so let's fix the tags :-) Andreas

Bug#855640: gcc-6-cross: gcj-6- ship broken symlink /usr/lib/gcc-cross//6/ecj1 -> ../../ecj1

2017-02-20 Thread Andreas Beckmann
Source: gcc-6-cross Version: 16 Severity: normal User: debian...@lists.debian.org Usertags: piuparts Hi, during a test with piuparts I noticed that the gcj-6- packages built from src:gcc-6-cross ship a broken symlink: /usr/lib/gcc-cross//6/ecj1 -> ../../ecj1 I couldn't find the target

Bug#851886: gcc: broken manpage symlinks

2017-01-20 Thread Andreas Beckmann
Control: reassign -1 gcc-6 6.3.0-3 On 2017-01-19 17:14, Matthias Klose wrote: > That was fixed in today's gcc-6 6.3.0-3 upload. The man pages should be there. looks better, but not perfect, since there is now a new issue: 0m28.5s ERROR: FAIL: Broken symlinks: /usr/share/man/man1/gcov-6.1 ->

Bug#851886: gcc: broken manpage symlinks

2017-01-19 Thread Andreas Beckmann
Package: gcc Version: 4:6.3.0-1 Severity: normal User: debian...@lists.debian.org Usertags: piuparts Hi, the gcc metapackage installs a few broken manpage symlinks: /usr/share/man/man1/x86_64-linux-gnu-gcc-ranlib.1.gz -> gcc-ranlib-6.1.gz /usr/share/man/man1/x86_64-linux-gnu-gcc-nm.1.gz ->

Bug#833829: libgcc-6-dev: Missing crtfastmath.o on kfreebsd-*

2016-09-06 Thread Andreas Beckmann
Control: retitle -1 libgcc-6-dev: Missing crtfastmath.o on kfreebsd-* Control: affects -1 + src:vlc On Tue, 9 Aug 2016 11:39:54 +0200 Matthias Klose wrote: > > I'm unable to build a package because crtfastmath.o is missing from this > > package. Architecture is kfreebsd-i386. I

Bug#858112: gcc-defaults: broken symlinks: gcc-: /usr/share/doc/cpp-/README.Bugs -> ../gcc-6/README.Bugs

2017-03-18 Thread Andreas Beckmann
Source: gcc-defaults Version: 1.165 Severity: normal User: debian...@lists.debian.org Usertags: piuparts Hi, during a test with piuparts I noticed your package ships (or creates) a broken symlink. >From the attached log (scroll to the bottom...): 0m35.0s ERROR: FAIL: Broken symlinks:

Bug#858112: gcc-defaults: broken symlinks: gcc-: /usr/share/doc/cpp-/README.Bugs -> ../gcc-6/README.Bugs

2017-03-18 Thread Andreas Beckmann
Followup-For: Bug #858112 and another one in gdc- /usr/share/doc/gdc-/cpp- -> cpp- Andreas

Bug#859914: libstdc++6: please add Breaks: libopencv-core2.4

2017-04-09 Thread Andreas Beckmann
Package: libstdc++6 Version: 6.3.0-11 Severity: important User: debian...@lists.debian.org Usertags: piuparts Control: affects -1 + libsikuli-script-jni Hi doko, please add another Breaks to libstdc++: against libopencv-core2.4 In piuparts I found that the jessie->stretch upgrade of

Bug#860117: gcc-defaults: gdc: unhandled directory to symlink conversion: /usr/share/doc/PACKAGE

2017-04-11 Thread Andreas Beckmann
Source: gcc-defaults Version: 1.168 Severity: serious User: debian...@lists.debian.org Usertags: piuparts Hi, a test with piuparts revealed that your package misses the copyright file after an upgrade, which is a violation of Policy 12.5:

Bug#860120: gcc-{hppa, sh4}-linux-gnu: broken symlink: /usr/share/doc/cpp-/README.Bugs -> ../gcc-6-base/README.Bugs

2017-04-11 Thread Andreas Beckmann
Package: gcc-hppa-linux-gnu,gcc-sh4-linux-gnu Version: 4:6.3.0-4 Severity: normal User: debian...@lists.debian.org Usertags: piuparts Hi, during a test with piuparts I noticed your package ships (or creates) a broken symlink. >From the attached log (scroll to the bottom...): 0m39.9s ERROR:

Bug#858112: gcc-defaults: broken symlinks: gcc-: /usr/share/doc/cpp-/README.Bugs -> ../gcc-6/README.Bugs

2017-04-05 Thread Andreas Beckmann
Control: severity -1 serious On Sat, 18 Mar 2017 15:07:06 +0100 Andreas Beckmann <a...@debian.org> wrote: > and another one in gdc- > > /usr/share/doc/gdc-/cpp- -> > cpp- and resulting in packages without copyright file after upgrade e.g. gdc-mips64-linux-gnuabi64 4

Bug#857583: Acknowledgement (gcc-6-hppa64-linux-gnu: broken symlinks: /usr/share/man/man1/hppa64-linux-gnu-(cpp|gcc-.*)-6.1.gz -> (cpp|gcc-.*)-6.1.gz)

2017-03-12 Thread Andreas Beckmann
same problem in gcc-5-hppa64-linux-gnu: 0m30.3s ERROR: FAIL: Broken symlinks: /usr/share/man/man1/hppa64-linux-gnu-gcc-ranlib-5.1.gz -> gcc-ranlib-5.1.gz /usr/share/man/man1/hppa64-linux-gnu-gcc-nm-5.1.gz -> gcc-nm-5.1.gz /usr/share/man/man1/hppa64-linux-gnu-gcc-ar-5.1.gz -> gcc-ar-5.1.gz

Bug#857583: gcc-6-hppa64-linux-gnu: broken symlinks: /usr/share/man/man1/hppa64-linux-gnu-(cpp|gcc-.*)-6.1.gz -> (cpp|gcc-.*)-6.1.gz

2017-03-12 Thread Andreas Beckmann
Package: gcc-6-hppa64-linux-gnu Version: 6.3.0-8 Severity: normal User: debian...@lists.debian.org Usertags: piuparts Hi, during a test with piuparts I noticed your package ships (or creates) a broken symlink. >From the attached log (scroll to the bottom...): 0m39.4s ERROR: FAIL: Broken

Bug#857384: gnat-6: broken symlinks: /usr/share/man/man1/{, x86_64-linux-gnu-}gnatgcc.1.gz -> x86_64-linux-gnu-gcc-6.1.gz

2017-03-12 Thread Andreas Beckmann
Followup-For: Bug #857384 Hi, there is a similar problem in the -cross packages: 0m28.6s ERROR: FAIL: Broken symlinks: /usr/share/man/man1/alpha-linux-gnu-gnatgcc.1.gz -> alpha-linux-gnu-gcc-6.1.gz as well as in gnat-5: 0m52.1s ERROR: FAIL: Broken symlinks:

Bug#855640: gcc-6-cross: gcj-6- ship broken symlink /usr/lib/gcc-cross//6/ecj1 -> ../../ecj1

2017-03-12 Thread Andreas Beckmann
Followup-For: Bug #855640 Hi, this problem also exists in the gcc-5-cross packages, should I clone this bug? Andreas

Bug#857384: gnat-6: broken symlinks: /usr/share/man/man1/{, x86_64-linux-gnu-}gnatgcc.1.gz -> x86_64-linux-gnu-gcc-6.1.gz

2017-03-10 Thread Andreas Beckmann
Package: gnat-6 Version: 6.3.0-8 Severity: normal User: debian...@lists.debian.org Usertags: piuparts Hi, during a test with piuparts I noticed your package ships (or creates) a broken symlink. >From the attached log (scroll to the bottom...): 0m40.5s ERROR: FAIL: Broken symlinks:

Bug#856875: gcc-6-cross: gcc-6- ship broken symlink: /usr/lib/gcc-cross//6/libcc1.so -> ../../../..//lib/libcc1.so.0

2017-03-05 Thread Andreas Beckmann
Source: gcc-6-cross Version: 18 Severity: normal User: debian...@lists.debian.org Usertags: piuparts Hi, during a test with piuparts I noticed the gcc-6- cross compilers ship a broken symlink. >From the attached log (scroll to the bottom...): 0m32.5s ERROR: FAIL: Broken symlinks:

Bug#858112: gcc-defaults: broken symlinks: gcc-: /usr/share/doc/cpp-/README.Bugs -> ../gcc-6/README.Bugs

2017-04-18 Thread Andreas Beckmann
Followup-For: Bug #858112 Control: reopen -1 Control: found -1 1.168 Hi, the broken README.Bugs symlink is still there ... /usr/share/doc/cpp-mips-linux-gnu/README.Bugs -> ../gcc-6-base/README.Bugs /usr/share/doc/cpp-s390x-linux-gnu/README.Bugs -> ../gcc-6-base/README.Bugs

Bug#858112: gcc-defaults: broken symlinks: gcc-: /usr/share/doc/cpp-/README.Bugs -> ../gcc-6/README.Bugs

2017-04-18 Thread Andreas Beckmann
Control: severity -1 important On Wed, 5 Apr 2017 21:21:06 +0200 Andreas Beckmann <a...@debian.org> wrote: > Control: severity -1 serious > and resulting in packages without copyright file after upgrade > e.g. gdc-mips64-linux-gnuabi64 4:6.3.0-1 -> 4:6.3.0-2 This is

Bug#872301: gcc-6: broken symlink: /usr/lib/gcc-cross//6/libobjc_gc.so -> ../../../..//lib/libobjc_gc.so.4

2017-08-15 Thread Andreas Beckmann
Source: gcc-6 Version: 6.4.0-3 Severity: important User: debian...@lists.debian.org Usertags: piuparts Hi, during a test with piuparts I noticed your package ships (or creates) a broken symlink. >From the attached log (scroll to the bottom...): 0m42.6s ERROR: FAIL: Broken symlinks:

Bug#872233: lib{, x}32objc-5-dev: broken symlink: /usr/lib/gcc/x86_64-linux-gnu/5/{, x}32/libobjc_gc.so -> ../../../../../lib32/libobjc_gc.so.4

2017-08-15 Thread Andreas Beckmann
Package: lib32objc-5-dev,libx32objc-5-dev Version: 5.4.1-11 Severity: serious User: debian...@lists.debian.org Usertags: piuparts Hi, during a test with piuparts I noticed your package ships (or creates) a broken symlink. >From the attached log (scroll to the bottom...): 0m26.7s ERROR: FAIL:

Bug#866150: lib64objc-6-dev: broken symlink: /usr/lib/gcc/i686-linux-gnu/6/64/libobjc_gc.so -> ../../../../../lib64/libobjc_gc.so.4

2017-06-27 Thread Andreas Beckmann
Package: lib64objc-6-dev Version: 6.3.0-19 Severity: serious User: debian...@lists.debian.org Usertags: piuparts Hi, during a test with piuparts I noticed your package ships (or creates) a broken symlink. >From the attached log (scroll to the bottom...): 0m27.1s ERROR: FAIL: Broken symlinks:

Bug#866150: lib64objc-6-dev: broken symlink: /usr/lib/gcc/i686-linux-gnu/6/64/libobjc_gc.so -> ../../../../../lib64/libobjc_gc.so.4

2017-06-27 Thread Andreas Beckmann
Followup-For: Bug #866150 Control: affects -1 + libx32objc-6-dev lib64objc-7-dev libx32objc-7-dev Similar problems in libx32objc-6-dev, lib64objc-7-dev, libx32objc-7-dev: 0m26.6s ERROR: FAIL: Broken symlinks: /usr/lib/gcc/i686-linux-gnu/6/x32/libobjc_gc.so ->

Bug#861060: libstdc++6: please add Breaks: libsigc++-2.0-0c2a (<= 2.4.1-1+b1)

2017-04-24 Thread Andreas Beckmann
Package: libstdc++6 Version: 6.3.0-14 Severity: important User: debian...@lists.debian.org Usertags: piuparts Control: affects -1 + gir1.2-ganv-1.0 Hi, I just found an upgrade path on i386 that doesn't work as expected: Starting 2 pkgProblemResolver with broken count: 2 Investigating (0)

Bug#870895: gcc-7: libobjc-7-dev--cross: broken symlink: /usr/lib/gcc-cross//7/libobjc_gc.so -> ../../../..//lib/libobjc_gc.so.4

2017-08-06 Thread Andreas Beckmann
Source: gcc-7 Version: 7.1.0-11 Severity: serious User: debian...@lists.debian.org Usertags: piuparts Hi, new version, new broken symlinks ;-) During a test with piuparts I noticed your package ships (or creates) a broken symlink. >From the attached log (scroll to the bottom...): 0m22.6s

Bug#871220: gcc-doc-defaults: FTBFS with GCC-7

2017-08-06 Thread Andreas Beckmann
Package: gcc-doc-defaults Version: 5:16 Severity: serious Tags: sid buster User: debian-gcc@lists.debian.org Usertags: ftbfs-gcc-7 gcc-doc-defaults FTBFS since GCC-7 was made the default compiler: [...] debian/rules override_dh_gencontrol-arch make[1]: Entering directory

Bug#863845: libstdc++6: adding more Breaks to smoothen upgrades from jessie to stretch

2017-06-01 Thread Andreas Beckmann
On 2017-05-31 22:55, Andreas Beckmann wrote: > libktoblzcheck1c2a (replaced by libktoblzcheck1v5) > libterralib (replaced by libterralib3) > libmagickcore-6.q16-2 (replaced by > libmagick

Bug#863845: libstdc++6: adding more Breaks to smoothen upgrades from jessie to stretch

2017-05-31 Thread Andreas Beckmann
Package: libstdc++6 Version: 6.3.0-18 Severity: important Hi, during my piuparts upgrade tests I identified a few upgrade paths that could likely be smoothened by adding a few Breaks to libstdc++6: libktoblzcheck1c2a(replaced by libktoblzcheck1v5) libterralib

Bug#863820: gcc-6-base: adding Breaks: tzdata-java to smoothen the openjdk 7 -> 8 upgrade path from jessie to stretch

2017-05-31 Thread Andreas Beckmann
On 2017-05-31 16:01, Andreas Beckmann wrote: > I'll now build a gcc-6 with that Breaks added ... ... and can confirm that it fixes the upgrade path of libreoffice-subsequentcheckbase (where I previously observed a kept back tzdata (and openjdk-7) from jessie). Andreas

Bug#863820: gcc-6-base: adding Breaks: tzdata-java to smoothen the openjdk 7 -> 8 upgrade path from jessie to stretch

2017-05-31 Thread Andreas Beckmann
Package: gcc-6-base Version: 6.3.0-18 Severity: important Hi Doko, would it be possible to use gcc-6-base as the bigger hammer to smoothen the openjdk 7 -> 8 upgrade from jessie to stretch? The Breaks: tzdata-java added in openjdk-8-jre-headless (#857992) improved the situation a lot, but I

Bug#872233: lib{, x}32objc-5-dev: broken symlink: /usr/lib/gcc/x86_64-linux-gnu/5/{, x}32/libobjc_gc.so -> ../../../../../lib32/libobjc_gc.so.4

2017-09-09 Thread Andreas Beckmann
Followup-For: Bug #872233 Control: found -1 5.4.1-12 Hi, the broken symlinks are still here: 0m46.5s ERROR: FAIL: Broken symlinks: /usr/lib/gcc/x86_64-linux-gnu/5/32/libobjc_gc.so -> ../../../../../lib32/libobjc_gc.so.4 0m57.3s ERROR: FAIL: Broken symlinks:

Bug#877441: gcc-8: missing Breaks+Replaces against several gcc-7 packages

2017-10-01 Thread Andreas Beckmann
Source: gcc-8 Version: 8-20170923-1 Severity: serious User: debian...@lists.debian.org Usertags: piuparts Control: affects -1 + lib32stdc++6-8-dbg libgccjit-8-doc libstdc++-8-doc libstdc++6-8-dbg libx32stdc++6-8-dbg Hi, during a test with piuparts I noticed your package fails to upgrade from

Bug#872233: lib{, x}32objc-5-dev: broken symlink: /usr/lib/gcc/x86_64-linux-gnu/5/{, x}32/libobjc_gc.so -> ../../../../../lib32/libobjc_gc.so.4

2017-10-01 Thread Andreas Beckmann
Followup-For: Bug #872233 Control: affects -1 + lib64objc-5-dev There is also a similar broken symlink in lib64objc-5-dev 0m40.2s ERROR: FAIL: Broken symlinks: /usr/lib/gcc/i686-linux-gnu/5/64/libobjc_gc.so -> ../../../../../lib64/libobjc_gc.so.4 Andreas

Bug#881775: gcc-7-base: please add Breaks: gnat (<< 7)

2017-11-14 Thread Andreas Beckmann
Package: gcc-7-base Version: 7.2.0-14 Severity: normal Hi, please add a Breaks: gnat (<< 7) to gcc-7-base (and merge this to gcc-8-base ...) to fix some stretch -> buster upgrade paths involving old ada libraries where apt may prefer to keep gnat-6 installed instead of switching to gnat-7 ...

Bug#881272: gcc-5-: broken symlink /usr/lib/gcc-cross//5/libcc1.so -> ../../../..//lib/libcc1.so.0

2017-11-11 Thread Andreas Beckmann
On 11/09/2017 04:43 PM, Matthias Klose wrote: > is this with the gcc-5-cross* packages which are currently built but not > uploaded? I waited a bit, but no new binaries appeared. The tested packages are versioned 5.5.0-3cross1. There is another broken link in some gcj-5- packages, that does

Bug#881272: gcc-5-: broken symlink /usr/lib/gcc-cross//5/libcc1.so -> ../../../..//lib/libcc1.so.0

2017-11-09 Thread Andreas Beckmann
Source: gcc-5 Version: 5.5.0-3 Severity: important User: debian...@lists.debian.org Usertags: piuparts Hi, during a test with piuparts I noticed your package ships (or creates) a broken symlink. >From the attached log (scroll to the bottom...): 0m25.1s ERROR: FAIL: Broken symlinks:

Bug#898374: gcc-8-cross: file conflicts with {gcc,g++,...}-8 on /usr/bin/-*-8

2018-05-10 Thread Andreas Beckmann
Source: gcc-8-cross Version: 12 Severity: serious User: debian...@lists.debian.org Usertags: piuparts Hi, during a test with piuparts I noticed your package failed to install because it tries to overwrite other packages files. >From the attached log (scroll to the bottom...): Selecting

Bug#901048: gnat-*-x86-64-linux-gnu: missing Conflicts: gnat-5, gnat-6

2018-06-08 Thread Andreas Beckmann
Package: gnat-7-x86-64-linux-gnu,gnat-8-x86-64-linux-gnu Severity: serious User: debian...@lists.debian.org Usertags: piuparts Hi, during a test with piuparts I noticed your package fails to upgrade from 'stretch'. It installed fine in 'stretch', then the upgrade to 'buster' fails because it

Bug#901048: gnat-*-x86-64-linux-gnu: missing Conflicts: gnat-5, gnat-6

2018-06-10 Thread Andreas Beckmann
On 2018-06-08 17:51, Matthias Klose wrote: > you should not run piuparts against outdated binaries. These tests take everything available in the Packages files ... >  I filed #899045 > to remove these packages, but that didn't get yet processed.  Closing > this issue now. Interestingly these

Bug#879883: libx32stdc++6-8-dbg: missing Conflicts: libx32stdc++6-7-dbg

2017-10-26 Thread Andreas Beckmann
Package: libx32stdc++6-8-dbg Version: 8-20171023-1 Severity: serious User: debian...@lists.debian.org Usertags: piuparts Hi doko, the last round of adding Conflicts seems to have missed this one: Selecting previously unselected package libx32stdc++6-8-dbg. Preparing to unpack

Bug#905022: gcc-doc-defaults: FTBFS, needs update for gcc-8 being default

2018-07-30 Thread Andreas Beckmann
Source: gcc-doc-defaults Version: 5:17.1 Severity: serious Justification: fails to build from source (but built successfully in the past) Hi, gcc-doc-defaults FTBFS in sid. It probably needs some updates now that gcc-8 has become the default gcc. [...] debian/rules

Bug#904509: gcc-x86-64-linux-gnux32: broken symlink: /usr/share/doc/cpp-x86_64-linux-gnux32/README.Bugs -> ../gcc-8-x86_64-linux-gnux32-base/README.Bugs

2018-07-24 Thread Andreas Beckmann
Package: gcc-x86-64-linux-gnux32 Version: 4:8.1.0-1 Severity: normal User: debian...@lists.debian.org Usertags: piuparts Hi, during a test with piuparts I noticed your package ships (or creates) a broken symlink. >From the attached log (scroll to the bottom...): 0m33.0s ERROR: FAIL: Broken

Re: Bug#911090: libapt-pkg5.0: incompatible with apt/stretch

2018-10-22 Thread Andreas Beckmann
Control: clone -1 -2 Control: reassign -2 g++-8 Control: retitle -2 g++-8: removal of old abi mangling breaks compatibility with stretch On 2018-10-15 18:18, Julian Andres Klode wrote: > So, I think this affects more than just apt. gcc 7 broke the ABI > by adding a new mangling > >

Bug#911599: Bug#911090: libapt-pkg5.0: incompatible with apt/stretch

2018-10-22 Thread Andreas Beckmann
On 2018-10-22 15:13, Matthias Klose wrote: > The compat symbol was in GCC 7, and then removed in GCC 8. Sure, that doesn't > help with the distro upgrade. There is nothing in GCC to change, so if you > want > to fix that, you need a rename of the affected library packages. That sounds like

Bug#911633: gcc-8-base: please add Breaks: gnat (<< 7)

2018-10-22 Thread Andreas Beckmann
Package: gcc-8-base Version: 8.2.0-8 Severity: important Hi doko, the Breaks: gnat (<< 7) is present in gcc-7-base, but missing in gcc-8-base. Adding this should fix some upgrade issues from stretch to buster where old gnat-6 built packages are kept installed instead of being removed.

Bug#913016: cpp-6-x86-64-linux-gnu:amd64: ships /usr/bin/x86_64-linux-gnu-cpp-6, already in cpp-6:amd64

2018-11-05 Thread Andreas Beckmann
Package: cpp-6-x86-64-linux-gnu Version: 6.5.0-2cross1 Severity: serious User: debian...@lists.debian.org Usertags: piuparts Hi, during a test with piuparts I noticed your package failed to install because it tries to overwrite other packages files. >From the attached log (scroll to the

Bug#909614: cpp-x86-64-linux-gnu: broken symlink: /usr/share/doc/cpp-x86_64-linux-gnu/README.Bugs -> ../gcc-8-x86_64-linux-gnu-base/README.Bugs

2018-09-25 Thread Andreas Beckmann
Package: cpp-x86-64-linux-gnu Version: 4:8.2.0-1 Severity: normal User: debian...@lists.debian.org Usertags: piuparts Control: affects -1 + gcc-x86-64-linux-gnu Hi, during a test with piuparts I noticed your package ships (or creates) a broken symlink. >From the attached log (scroll to the

Bug#918445: libgccjit-9-doc: missing Conflicts: libgccjit-8-doc

2019-01-05 Thread Andreas Beckmann
Package: libgccjit-9-doc Version: 9-20190103-1 Severity: serious User: debian...@lists.debian.org Usertags: piuparts libgccjit-9-doc needs to conflict with libgccjit-8-doc like it does with the older ones. Andreas libgccjit-8-doc=8.2.0-13_libgccjit-9-doc=9-20190103-1.log.gz Description:

Bug#915870: gccgo-doc: broken symlinks: /usr/share/man/man1/gccgo.1.gz, /usr/share/info/gccgo.info.gz

2018-12-07 Thread Andreas Beckmann
Package: gccgo-doc Version: 5:7.2.0-2 Severity: normal User: debian...@lists.debian.org Usertags: piuparts Hi, during a test with piuparts I noticed your package ships (or creates) a broken symlink. >From the attached log (scroll to the bottom...): 0m46.5s ERROR: FAIL: Broken symlinks:

Bug#915678: gcc-x86-64-linux-gnux32: broken symlink: /usr/share/doc/gcc-x86_64-linux-gnux32 -> cpp-x86_64-linux-gnux32 (gcc-x86-64-linux-gnux32)

2018-12-05 Thread Andreas Beckmann
Package: gcc-x86-64-linux-gnux32 Version: 4:8.2.0-2 Severity: normal User: debian...@lists.debian.org Usertags: piuparts Hi, during a test with piuparts I noticed your package ships (or creates) a broken symlink. >From the attached log (scroll to the bottom...): 0m26.3s ERROR: FAIL: Broken

Bug#918903: dwz: fails during pocl i386 build

2019-01-10 Thread Andreas Beckmann
Package: dwz Version: 0.12-3 Severity: important Hi, I tried updating pocl to debhelper-compat (= 12), but it failed on i386 (while amd64 built fine): [...] dh_install -O--buildsystem=cmake dh_installdocs -O--buildsystem=cmake dh_installdocs: Cannot auto-detect main package for pocl-doc.

Bug#924911: closed by Matthias Klose (Bug#924911: fixed in gcc-8 8.3.0-4)

2019-04-03 Thread Andreas Beckmann
On 2019-03-26 13:21, Debian Bug Tracking System wrote: > #924911: gcc-8-base: please add Breaks: gnat-6 (<< 6.4) That worked as expected :-) Thanks! Andreas

  1   2   >