Bug#966265: marked as done ([libc6] Breaks is too broad for openssh on 64-bit)

2020-07-25 Thread Debian Bug Tracking System
Your message dated Sat, 25 Jul 2020 17:30:19 +0200
with message-id <20200725153019.ga10...@qmqm.qmqm.pl>
and subject line Re: [libc6] Breaks is too broad for openssh on 64-bit
has caused the Debian Bug report #966265,
regarding [libc6] Breaks is too broad for openssh on 64-bit
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
966265: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=966265
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Package: libc6
Version: 2.31-2
Severity: normal

--- Please enter the report below this line. ---

A fix for bug #965932 added a Breaks: for openssh-server and -client,
but the restriction covers all arches instead of 32-bit only, and so
prevents upgrading only libc to testing from stable on amd64.

--- System information. ---
(irrelevant)

--- Package information. ---
Package's Depends field is empty.

Package's Recommends field is empty.

Package's Suggests field is empty.
--- End Message ---
--- Begin Message ---
On Sat, Jul 25, 2020 at 05:07:36PM +0200, Michał Mirosław wrote:
> Package: libc6
> Version: 2.31-2
> Severity: normal
> 
> --- Please enter the report below this line. ---
> 
> A fix for bug #965932 added a Breaks: for openssh-server and -client,
> but the restriction covers all arches instead of 32-bit only, and so
> prevents upgrading only libc to testing from stable on amd64.

Oh, it is intentional, but was not there in 2.31-1.
Please close the bug as invalid.

Best Regards,
Michał Mirosław--- End Message ---


Re: Processed: Re: Bug#964477: libc6-dev: Fails to cleanly upgrade from Stable

2020-07-25 Thread Helge Kreutzmann
Hello all,
I resolved the breakage by "apt-get remove libgcc-8-dev". 

This removed noting central to me and allowed the subsequent
"dist-ugprade" to complete.

In the dist-ugprade I noticed two things:
a) All Debconf questions were asked in english, although they should
   be available in my default locale, i.e. de

b) The "dist-upgrade" initially failed:
…
Vormals nicht ausgewähltes Paket python3-sugar3 wird gewählt.
Vorbereitung zum Entpacken von .../30-python3-sugar3_0.117-1_all.deb ...
Entpacken von python3-sugar3 (0.117-1) ...
dpkg: Fehler beim Bearbeiten des Archivs 
/tmp/apt-dpkg-install-q4FnQb/30-python3-sugar3_0.117-1_all.deb (--unpack):
 Versuch, »/usr/bin/sugar-activity-web« zu überschreiben, welches auch in Paket 
python-sugar3 0.112-3 ist
dpkg-deb: Fehler: »einfügen«-Unterprozess wurde durch Signal (Datenübergabe 
unterbrochen (broken pipe)) getötet
Vorbereitung zum Entpacken von .../31-libxapian30_1.4.15-1_amd64.deb ...
Entpacken von libxapian30:amd64 (1.4.15-1) über (1.4.11-1) ...
Vormals nicht ausgewähltes Paket python3-xapian wird gewählt.
Vorbereitung zum Entpacken von .../32-python3-xapian_1.4.15-1+b1_amd64.deb ...
Entpacken von python3-xapian (1.4.15-1+b1) ...
Vormals nicht ausgewähltes Paket python3-carquinyol wird gewählt.
Vorbereitung zum Entpacken von .../33-python3-carquinyol_0.117-1_amd64.deb ...
Entpacken von python3-carquinyol (0.117-1) ...
dpkg: Fehler beim Bearbeiten des Archivs 
/tmp/apt-dpkg-install-q4FnQb/33-python3-carquinyol_0.117-1_amd64.deb (--unpack):
 Versuch, »/usr/bin/copy-from-journal« zu überschreiben, welches auch in Paket 
python-carquinyol 0.112-1 ist
Vorbereitung zum Entpacken von .../34-sucrose_0.117-3_all.deb ...
Entpacken von sucrose (0.117-3) über (0.112-6) ...
Fehler traten auf beim Bearbeiten von:
 /tmp/apt-dpkg-install-q4FnQb/30-python3-sugar3_0.117-1_all.deb
 /tmp/apt-dpkg-install-q4FnQb/33-python3-carquinyol_0.117-1_amd64.deb

A subsequent "apt-get -f install" fixed this, however.

If you would like to get futher information from me so that other 
users can avoid these problems (especially the first one) please let
me know. Please note, however, that I'm no tracking testing, i.e. the
state is now evolving again.

Greetings

   Helge


signature.asc
Description: PGP signature


Bug#966265: [libc6] Breaks is too broad for openssh on 64-bit

2020-07-25 Thread Michał Mirosław
Package: libc6
Version: 2.31-2
Severity: normal

--- Please enter the report below this line. ---

A fix for bug #965932 added a Breaks: for openssh-server and -client,
but the restriction covers all arches instead of 32-bit only, and so
prevents upgrading only libc to testing from stable on amd64.

--- System information. ---
(irrelevant)

--- Package information. ---
Package's Depends field is empty.

Package's Recommends field is empty.

Package's Suggests field is empty.