Re: [RFC PATCH v4 1/2] configure: Remove --enable-obsolete-nsl

2020-06-30 Thread Petr Vorel
Hi Florian, thank you for your review. I'll have time to send next version in second half of July. > * Petr Vorel: > > diff --git a/NEWS b/NEWS > > index a660fc59a8..cfaf50c816 100644 > > --- a/NEWS > > +++ b/NEWS > > @@ -33,6 +33,14 @@ Major new features: >

[RFC PATCH v5 1/2] Remove --enable-obsolete-nsl

2020-06-30 Thread Petr Vorel
C, e.g. on --enable-obsolete-rpc (installed libnsl headers use installed Sun RPC headers), which will be removed in the following commit. Signed-off-by: Petr Vorel --- changes v4->v5: * update manual/nsswitch.texi and nss/nsswitch.conf * mention that libnss_compat does not depended on libnsl s

[RFC PATCH v5 0/2] Remove --enable-obsolete-nsl --enable-obsolete-rpc

2020-06-30 Thread Petr Vorel
Hi, changes v4->v5: * update manual/nsswitch.texi and nss/nsswitch.conf * mention that libnss_compat does not depended on libnsl since 2.27 and thus can be used without NIS * wrap NEWS with column 72 Kind regards, Petr Petr Vorel (2): Remove --enable-obsolete-nsl Remove --enable-obsol

Re: [RFC PATCH v4 1/2] configure: Remove --enable-obsolete-nsl

2020-06-30 Thread Petr Vorel
Hi Florian, > * Petr Vorel: > > thank you for your review. I'll have time to send next version in second > > half of July. > If we merge new ports for glibc 2.32, it would be nice not include > sunrpc in them. We'll figure something out. +1. I'll try to send v

Re: [RFC PATCH v4 1/2] configure: Remove --enable-obsolete-nsl

2020-06-30 Thread Petr Vorel
Hi Florian, > * Petr Vorel: > >> nss_compat no longer depends on libnsl in current glibc. It can be used > >> without NIS, and some users do that. I don't think your patch changes > >> this. > > Interesting. I guess adding this would be worth then:

Re: [RFC PATCH v2 0/2] Remove --enable-obsolete-nsl --enable-obsolete-rpc

2020-06-05 Thread Petr Vorel
> Hi, > I'm still having issues with elf/tst-ldconfig-ld_so_conf-update when > running with both commits (it's ok when running only first commit). OK, I noticed core dump (can be reproduced): systemd-coredump[26018]: Process 26016 (ld-linux-x86-64) of user 1000 dumped core. PID:

[RFC PATCH v2 1/2] configure: Remove --enable-obsolete-nsl

2020-06-05 Thread Petr Vorel
in or before version 2.28. Replacement implementations based on TIRPC, which additionally support IPv6, are available from <https://github.com/thkukuk/>. Signed-off-by: Petr Vorel --- INSTALL | 9 --- NEWS | 8 ++ confi

[RFC PATCH v2 0/2] Remove --enable-obsolete-nsl --enable-obsolete-rpc

2020-06-05 Thread Petr Vorel
Simple creating etc directory and copying ld.so.conf does not help (I'm not surprised). Und yes, I have cross-compiling = no as Szabolcs noted. What can be wrong? Do I run testing in a wrong way? Or did I really introduced bug in second commit? Kind regards, Petr Petr Vorel (2): configure: Remove

Re: [RFC PATCH v2 0/2] Remove --enable-obsolete-nsl --enable-obsolete-rpc

2020-06-06 Thread Petr Vorel
Hi Szabolcs, Joseph, > On Fri, 5 Jun 2020, Szabolcs Nagy wrote: > > i would try to see why /etc is not created in the testroot. > Maybe it was only previously created as part of installing /etc/rpc there > and the patch is causing that file no longer to be installed? Thanks for your tips!

Re: [RFC PATCH v2 0/2] Remove --enable-obsolete-nsl --enable-obsolete-rpc

2020-06-06 Thread Petr Vorel
Hi, > On Fri, 5 Jun 2020, Szabolcs Nagy wrote: > > i would try to see why /etc is not created in the testroot. > Maybe it was only previously created as part of installing /etc/rpc there > and the patch is causing that file no longer to be installed? Found that. That was the missing piece.

[RFC PATCH v3 0/2] Remove --enable-obsolete-nsl --enable-obsolete-rpc

2020-06-06 Thread Petr Vorel
h_unix.c -> svc_authux.c # xdr_reference.c -> xdr_ref.c -headers = rpc/netdb.h +install-others = $(inst_sysconfdir)/rpc ifeq ($(build-shared),yes) need-export-routines := auth_des auth_unix clnt_gen clnt_perr clnt_tcp \ Petr Vorel (2): configure: Remove --enable-obsolete-nsl Rem

[RFC PATCH v3 1/2] configure: Remove --enable-obsolete-nsl

2020-06-06 Thread Petr Vorel
in or before version 2.28. Replacement implementations based on TIRPC, which additionally support IPv6, are available from <https://github.com/thkukuk/>. Signed-off-by: Petr Vorel --- INSTALL | 9 --- NEWS | 8 ++ confi

[RFC PATCH v4 1/2] configure: Remove --enable-obsolete-nsl

2020-06-06 Thread Petr Vorel
emoved in following commit. Signed-off-by: Petr Vorel --- INSTALL | 9 --- NEWS | 8 ++ config.h.in | 4 --- config.make.in | 1 - configure| 20 +- configure.ac

[RFC PATCH v4 0/2] Remove --enable-obsolete-nsl --enable-obsolete-rpc

2020-06-06 Thread Petr Vorel
ted only default compilation on x86_64: Summary of test results: 4166 PASS 24 UNSUPPORTED 12 XFAIL 6 XPASS I'll try to test it on other archs, but testing from others (especially cross-compilation would be great). Kind regards, Petr Petr Vorel (2): configure: Remove --enable-obsol

Re: [RFC PATCH v3 0/2] Remove --enable-obsolete-nsl --enable-obsolete-rpc

2020-06-06 Thread Petr Vorel
Hi, Maybe the naming isn't quite right: I guess libc_hidden_nolink should be libc_hidden_nolink_sunrpc (thus files in sunrpc/ will not have to be renamed) => v4. I kept libnsl_hidden_nolink_def. I could rename it to libnsl_hidden_nolink if desired. Kind regards, Petr

Re: [RFC PATCH v4 1/2] configure: Remove --enable-obsolete-nsl

2020-06-09 Thread Petr Vorel
Hi Szabolcs, ... > > +* Remove configure option --enable-obsolete-nsl. libnsl is only built as > > shared > > + library for backward compatibility and the NSS modules libnss_compat, > > + libnss_nis and libnss_nisplus are not built at all, libnsl's headers > > aren't > > + installed. This

Re: [RFC PATCH] Remove --enable-obsolete-rpc flag

2020-06-04 Thread Petr Vorel
Hi, [ Cc: Debian glibc maintainers and Buildroot maintainer (the only distros I'm aware of they use it, although there will be others) ] > The 06/04/2020 12:35, Petr Vorel wrote: > > The Sun RPC headers are not built, rpcgen program, librpcsvc and > > test for bug #20790 are com