Re: Arch qualification for buster: call for DSA, Security, toolchain concerns

2020-07-09 Thread Matthias Klose
On 7/8/20 9:21 PM, Paul Gevers wrote: > Hi, > > [Note, this e-mail may look familiar as it is mostly copied over from > the buster call, not much has changed, AFAICT]. > > As part of the interim architecture qualification for bullseye, we > request that DSA, the security team, Wanna build, and

Bug#962457: installation of finclude/math-vector-fortran.h

2020-06-08 Thread Matthias Klose
Package: src:glibc Version: 2.30-8 Severity: important Tags: sid bullseye 2.30-2 removed the installation of finclude/math-vector-fortran.h, which leads to build errors like reported in https://launchpad.net/bugs/1879092 glibc (2.30-2) unstable; urgency=medium * debian/rules.d/build.mk: do

Bug#953083: __glibc_has_include macro needs to be restored until GCC is rebuilt

2020-03-13 Thread Matthias Klose
On 3/4/20 9:48 AM, Florian Weimer wrote: > * Matthias Klose: > >> On 3/4/20 9:33 AM, Florian Weimer wrote: >>> * Matthias Klose: >>> >>>> The __glibc_has_include macro needs to be restored until GCC is rebuilt. At >>>> least on s390x,

Bug#953657: generate dependencies on libgcc-sN instead of libgccN

2020-03-11 Thread Matthias Klose
Package: src:glibc Version: 2.29-10 Tags: patch Please generate dependencies on libgcc-sN instead of libgccN. * libc6: Depend on libgcc-sN instead of libgccN. diff -Nru glibc-2.31/debian/rules.d/debhelper.mk glibc-2.31/debian/rules.d/debhelper.mk --- glibc-2.31/debian/rules.d/debhelper.mk

Bug#953083: __glibc_has_include macro needs to be restored until GCC is rebuilt

2020-03-05 Thread Matthias Klose
On 3/4/20 10:04 PM, Aurelien Jarno wrote: > On 2020-03-04 09:33, Matthias Klose wrote: >> Package: src:glibc >> Version: 2.30-0experimental2 >> Severity: important >> Tags: sid bullseye patch >> >> The __glibc_has_include macro needs to be restored until GCC

Bug#953083: __glibc_has_include macro needs to be restored until GCC is rebuilt

2020-03-04 Thread Matthias Klose
On 3/4/20 9:33 AM, Florian Weimer wrote: > * Matthias Klose: > >> The __glibc_has_include macro needs to be restored until GCC is rebuilt. At >> least on s390x, you get a non-wrorking compiler, which at least cannot glibc >> anymore. The macro is still referenced in the

Bug#953083: __glibc_has_include macro needs to be restored until GCC is rebuilt

2020-03-04 Thread Matthias Klose
Package: src:glibc Version: 2.30-0experimental2 Severity: important Tags: sid bullseye patch The __glibc_has_include macro needs to be restored until GCC is rebuilt. At least on s390x, you get a non-wrorking compiler, which at least cannot glibc anymore. The macro is still referenced in the

Bug#934823: glibc needs an update for linux-5.2 kernel headers (alpha)

2019-08-15 Thread Matthias Klose
Package: src:glibc Version: 2.28-10 Severity: sersious Tags: sid bullseye patch currently c-t-b-p ftbfs on alpha. A patch needs to be backported. https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1836064 the c-t-b-ports package ftbfs: /bin/bash ../scripts/move-if-change

Re: cross-toolchain-base: FTBFS: applying patches fails

2019-07-17 Thread Matthias Klose
On 08.01.19 21:08, Paul Gevers wrote: > user debian...@lists.debian.org > usertags needs-update > thanks > > Hi all, > > On Sat, 29 Dec 2018 23:46:40 +0100 Lucas Nussbaum wrote: >> During a rebuild of all packages in sid, your package failed to build >> on amd64. >> >> Relevant part

Re: Buster / GCC 7.4 Problem

2018-12-18 Thread Matthias Klose
On 18.12.18 16:39, Hagen Paul Pfeifer wrote: > Hallo, > > since December 7.3 to 7.4 switch I am not able to compile Yocto anymore: > >> | make[3]: Entering directory > '/home/pfeifer/git/p/p-core/build/tmp/work/x86_64-linux/m4-native/1.4.18-r0/build/lib' > > > | gcc -I.

Re: Arch qualification for buster: call for DSA, Security, toolchain concerns

2018-12-09 Thread Matthias Klose
On 07.07.18 17:24, YunQiang Su wrote: > Niels Thykier 于2018年6月28日周四 上午4:06写道: >> List of concerns for architectures >> == >> >> The following is a summary from the current architecture qualification >> table. >> >> * Concern for ppc64el and s390x: we are dependent

Bug#881646: don't build multilib library packages in stage1

2017-11-13 Thread Matthias Klose
Package: src:glibc Version: 2.24-17 Severity: important Tags: patch The recent debhelper changes expose a bug building stage1, because glibc build the multilib library packages in stage1, which shouldn't be built (only all dev packages should be built). --- glibc-2.24/debian/rules~ 2017-08-26

Bug#881455: glibc: don't build hardware enhancement library packages when stage1

2017-11-13 Thread Matthias Klose
we shouldn't build these for stage2 either.

Bug#881636: fix stage1/stage2 builds with updated debhelper

2017-11-13 Thread Matthias Klose
Package: src:glibc Version: 2.24-17 Tags: patch debhelper got a bit more strict, and now fails to build libc6.1-alphaev67 during stage1 and stage2. The solution is not to build this optimized package during stage1 and stage2. --- glibc-2.24/debian/sysdeps/alpha.mk~ 2017-06-19 17:36:06.0

Bug#874491: [patch] fix glibc-2.25 /26 stage1 build

2017-09-06 Thread Matthias Klose
Package: src:glibc Tags: patch fix glibc-2.25 /26 stage1 build. The python hooks are not installed for the stage1 build. --- a/debian/rules.d/debhelper.mk +++ b/debian/rules.d/debhelper.mk @@ -220,6 +220,7 @@ -e "s#RTLDDIR#$$rtlddir#g" \ -e "s#SLIBDIR#$$slibdir#g" \ -e

Bug#870257: Add conflicts for multilib development packages

2017-07-31 Thread Matthias Klose
Package: src:glibc Version: 2.24-12 Tags: patch Please add conflicts for the multilib development packages. There are bug reports with foreign architectures that try to install both libc6-dev-i386 and libc6-dev-amd64 packages, and then failing because of conflicts in /usr/include. This patch

Bug#845544: allow to inject linux-libc-dev dependency for cross-toolchain-base builds

2016-11-24 Thread Matthias Klose
-6.1) UNRELEASED; urgency=medium + + * Allow to inject the libc-dev dependency on linux-libc-dev by the build +environment. + + -- Matthias Klose <d...@debian.org> Thu, 24 Nov 2016 12:19:24 +0100 + glibc (2.24-6) unstable; urgency=medium [ Samuel Thibault ] diff -Nru glibc-2.24/

Bug#835946: glibc: non-standard gcc/g++ used for build (gcc-5)

2016-08-29 Thread Matthias Klose
Package: glibc Version: 2.23-5 Severity: important Tags: sid stretch User: debian-...@lists.debian.org Usertags: non-standard-compiler, gcc-5, gcc-5-legacy This package builds with a non standard compiler version; please check if this package can be built with the default version of gcc/g++, or

Bug#834138: build stage1 glibc without a C++ compiler

2016-08-12 Thread Matthias Klose
Package: src:glibc Version: 2.24-0experimental0 Tags: patch build stage1 glibc without a C++ compiler. As long as this is not required, we shouldn't be forced to a C++ compiler for stage1. --- glibc-2.24/debian/rules.d/build.mk~ 2016-08-12 10:49:51.119631719 +0200 +++

Bug#806912: Don't build optimized variants in stage1 or stage2 builds

2015-12-02 Thread Matthias Klose
/changelog 2015-12-02 20:06:12.0 + @@ -1,3 +1,9 @@ +glibc (2.21-1.1) UNRELEASED; urgency=medium + + * Don't build optimized variants in stage1 or stage2 builds. + + -- Matthias Klose <d...@debian.org> Wed, 02 Dec 2015 21:05:26 +0100 + glibc (2.21-1) unstable; urgency=

Bug#766877: pasted wrong bug number

2015-04-29 Thread Matthias Klose
Control: reopen -1 sorry, pasted the bug number from a wrong browser tab. -- To UNSUBSCRIBE, email to debian-glibc-requ...@lists.debian.org with a subject of unsubscribe. Trouble? Contact listmas...@lists.debian.org Archive: https://lists.debian.org/5541318b.5050...@debian.org

Bug#779294: /usr/bin/python: /lib/i386-linux-gnu/libc.so.6: version `GLIBC_2.15' not found (required by /usr/bin/python)

2015-02-26 Thread Matthias Klose
On 02/26/2015 06:01 PM, Andreas Beckmann wrote: during a test with piuparts I noticed a failure to upgrade from 'wheezy'. I'm not exactly sure which package to blame. This happened on i386, I cannot reproduce it on amd64. The package being tested was lsb-desktop, but it can probably show up

Bug#766877: Fix multilib enabled stage1 cross builds

2014-10-26 Thread Matthias Klose
Package: src:glibc Version: Tags: patch The patch fixes building multilib enabled stage1 cross, by doing the call xx dance for stage1 as well, as well as generating the debhelper files for multilib stage1 packages. --- glibc-2.19/debian/rules.d/debhelper.mk.orig 2014-10-22 21:10:46.131349002

Bug#747979: eglibc: non-standard gcc/g++ used for build (gcc-4.6)

2014-05-13 Thread Matthias Klose
Package: eglibc Version: 2.18-5 Severity: important Tags: sid jessie User: debian-...@lists.debian.org Usertags: non-standard-compiler, gcc-4.6, gcc-4.6-legacy This package builds with a non standard compiler version; please check if this package can be built with the default version of gcc/g++,

Bug#747996: eglibc: non-standard gcc/g++ used for build (gcc-4.7)

2014-05-13 Thread Matthias Klose
Package: eglibc Version: 2.18-5 Severity: important Tags: sid jessie User: debian-...@lists.debian.org Usertags: non-standard-compiler, gcc-4.7, gcc-4.7-legacy This package builds with a non standard compiler version; please check if this package can be built with the default version of gcc/g++,

Re: Bug#717557: gcc-4.8: can't compile working 64bit kernel with 32bit userspace gcc-4.8

2013-10-20 Thread Matthias Klose
Am 20.10.2013 22:58, schrieb Ben Hutchings: On Sun, 2013-10-20 at 22:21 +0200, Matthias Klose wrote: Am 20.10.2013 00:25, schrieb Ben Hutchings: On Sat, 2013-10-19 at 23:38 +0200, Matthias Klose wrote: Control: severity -1 important Control: tags -1 + moreinfo In file included from command

Bug#708265: gnu-stubs multilib headers not shipped at least on mips

2013-05-14 Thread Matthias Klose
Package: src:eglibc Version: 2.17-2 Severity: serious seen when trying to build gcc-4.8: In file included from /usr/include/features.h:395:0, from /usr/include/stdio.h:27, from ../../../../src/libgcc/../gcc/tsystem.h:87, from

Bug#663150: Backport ARM makecontext() routines.

2012-03-08 Thread Matthias Klose
Package: eglibc Please backport ARM makecontext() routines from trunk, or https://code.launchpad.net/~michaelh1/ubuntu/precise/eglibc/lp696794/+merge/96465 -- To UNSUBSCRIBE, email to debian-glibc-requ...@lists.debian.org with a subject of unsubscribe. Trouble? Contact

Bug#654744: eglibc: non-standard gcc/g++ used for build (gcc-4.4)

2012-01-05 Thread Matthias Klose
Package: eglibc Version: 2.13-24 Severity: important User: debian-...@lists.debian.org Usertags: non-standard-compiler, gcc-4.4 This package builds with a non standard compiler version; please check if this package can be built with the default version of gcc/g++, or with gcc-4.6/g++-4.6. Please

Bug#637141: file conflicts in libc6-dev and libc6-dev-amd64

2011-08-08 Thread Matthias Klose
Package: libc6-dev Version: 2.13-15 Severity: serious $ dpkg -c libc6-dev_2.13-15_i386.deb | grep fpu_control -rw-r--r-- root/root 3163 2011-08-08 20:21 ./usr/include/fpu_control.h -rw-r--r-- root/root 3291 2011-08-08 20:10 ./usr/include/i386-linux-gnu/fpu_control.h -- To

Bug#634850: [patch] provide the multiarch libdir for the non-default multilibs

2011-07-20 Thread Matthias Klose
Package: eglibc Version: 2.13-10 Severity: normal Tags: patch User: ubuntu-de...@lists.ubuntu.com Usertags: origin-ubuntu oneiric ubuntu-patch this is for a pending change for the multiarch updates in GCC. On multilib enabled archs the include and library directories are looked up using a prefix

Bug#632667: empty biarch -dev packages

2011-07-04 Thread Matthias Klose
Package: eglibc Version: 2.13-9 Severity: serious trying to build gcc-4.x: make[7]: Entering directory `/home/packages/gcc/4.6/gcc-4.6-4.6.1/build/x86_64-linux-gnu/32/libgcc' # If this is the top-level multilib, build all the other # multilibs.

Bug#594807: openjdk-6 segfaults on armel with libc6 2.11.2-2

2010-09-01 Thread Matthias Klose
On 01.09.2010 11:35, Aurelien Jarno wrote: On Mon, Aug 30, 2010 at 06:05:15AM +0200, Aurelien Jarno wrote: On Sun, Aug 29, 2010 at 07:30:10PM +0200, Matthias Klose wrote: Package: libc6 Version: 2.11.2-2 Severity: grave This change breaks OpenJDK on armel: * Add patches/any/cvs-flush

Bug#594807: openjdk-6 segfaults on armel with libc6 2.11.2-2

2010-08-29 Thread Matthias Klose
Package: libc6 Version: 2.11.2-2 Severity: grave This change breaks OpenJDK on armel: * Add patches/any/cvs-flush-cache-textrels.diff to fix random crashes on ARM, if the executable or shared library has TEXTREL. Reverting this change unbreaks openjdk. $ java -version -zero Segmentation

Re: Bug#585051: (no subject)

2010-06-12 Thread Matthias Klose
On 12.06.2010 15:19, André Wöbbeking wrote: I can confirm this also for C++ programs. It's an interaction of eglibc 2.11 and gold. eglibc 2.10 and gold work together and eglibc 2.11 without gold also works. no, it's not 2.11, but 2.11 glibc built --with-multi-arch. Would the glibc

Re: Bug#585051: (no subject)

2010-06-12 Thread Matthias Klose
On 12.06.2010 19:00, André Wöbbeking wrote: On Saturday 12 June 2010, Aurelien Jarno wrote: Moreover we can also backport the optimized functions that have been added in 2.12, but the current goal is to move 2.11 to squeeze, so it will be for later. All that said, I don't plan to disable

Bug#584610: [mips] gcc-4.4 build failure after upgrade to eGLIBC-2.11

2010-06-07 Thread Matthias Klose
On 06.06.2010 00:51, Aurelien Jarno wrote: On Sat, Jun 05, 2010 at 03:50:51AM +0200, Matthias Klose wrote: Package: eGLIBC Version: 2.11.1-2 Severity: serious gcc-4.4 and gcc-4.5 fail to build after the upgrade to eGLIBC-2.11: https://buildd.debian.org/fetch.cgi?pkg=gcc-4.4;ver=4.4.4-4;arch

Bug#584610: [mips] gcc-4.4 build failure after upgrade to eglibc-2.11

2010-06-04 Thread Matthias Klose
Package: eglibc Version: 2.11.1-2 Severity: serious gcc-4.4 and gcc-4.5 fail to build after the upgrade to eglibc-2.11: https://buildd.debian.org/fetch.cgi?pkg=gcc-4.4;ver=4.4.4-4;arch=mips;stamp=1275677666 -- To UNSUBSCRIBE, email to debian-glibc-requ...@lists.debian.org with a subject of

Bug#583839: eglibc 2.11 ftbfs on kfreebsd

2010-05-30 Thread Matthias Klose
Package: eglibc Version: 2.11.1-1 Severity: serious see https://buildd.debian.org/fetch.cgi?pkg=gcc-snapshot;ver=20100530-1;arch=kfreebsd-amd64;stamp=1275239549 gnatgcc -c -g -DIN_GCC -W -Wall -Wwrite-strings -Wcast-qual -Wstrict-prototypes -Wmissing-prototypes -Wold-style-definition

Bug#564685: regressions in binutils testsuite on armel, when built against eglibc-2.10.x

2010-01-11 Thread Matthias Klose
Package: eglibc Version: 2.10.2-5 Severity: serious The following tests fail: Test results, compared with installed binutils: W: [ld-elfvsb/elfvsb.exp] REGRESSION (PASS - FAIL): visibility (normal) (non PIC, load offset) W: [ld-elfvsb/elfvsb.exp] REGRESSION (PASS - FAIL): visibility (normal)

Re: Bug#556951: [binutils] objcopy fails with 'Invalid operation'

2009-11-18 Thread Matthias Klose
On 18.11.2009 14:54, Peter Fritzsche wrote: forwarded 556951 http://sourceware.org/bugzilla/show_bug.cgi?id=10982 thanks Matthias Klose wrote: [] `debian/sauerbraten-dbg/usr/lib/debug//usr/lib/games/sauerbraten/sauer_cl ient': Invalid operation dh_strip: objcopy returned exit code 1

Re: Bug#556951: [binutils] objcopy fails with 'Invalid operation'

2009-11-18 Thread Matthias Klose
On 18.11.2009 21:43, Aurelien Jarno wrote: On Wed, Nov 18, 2009 at 07:58:47PM -0600, Matthias Klose wrote: I only see this when upgrading to current glibc in unstable; not with testing. Could you be more precise with the versions? glibc in testing and unstable have the same version. sorry

Bug#556534: gcc-4.4 testsuite errors when build with current eglibc

2009-11-16 Thread Matthias Klose
Package: eglibc Vesion: 2.10.1-7 Severity: grave seen on i386, most of the g++/libstdc++ tests are failing. seen with current gcc-4.4 package and with the packaging in the gcc svn. -- To UNSUBSCRIBE, email to debian-glibc-requ...@lists.debian.org with a subject of unsubscribe. Trouble?

Bug#553722: almost all execution test in gcj-4.4 broken with eglibc-2.10.1-3 on hppa

2009-11-09 Thread Matthias Klose
On 08.11.2009 20:47, Carlos O'Donell wrote: On Sun, Nov 8, 2009 at 1:42 PM, Carlos O'Donellcar...@systemhalted.org wrote: Always the same crash for all the failures I've looked at. Hopefully this is something trivial that was missed. The current libc is missing my patches to fix

Bug#539950: when /etc/hosts doesn't exist, apt fails to resolve hostnames using libc6 2.10.1

2009-08-04 Thread Matthias Klose
Package: libc6 Version: 2.10.1-0exp1 Severity: important E.g. apt-get's call to getaddrinfo() returns with EAI_SYSTEM when /etc/hosts is missing and EAI_NONAME if /etc/hosts is empty. This is different from 2.9, where EAI_NONAME is returned in both cases, resulting in the regression in

Re: Bug#533767: Missing Pre-Depends: libc6-i386 (= 2.9-17)

2009-06-20 Thread Matthias Klose
Goswin von Brederlow schrieb: Hi, small update to the bug report. The libc6-i386 package screwed up the transition by forgetting to delete the /lib32 and /usr/lib32 in preinst. So on upgrades all files remain under /emul/ia32-linux/ and the only thing that changes is the way dpkg sees

Bug#533474: unsufficent versions for lib32 libs

2009-06-17 Thread Matthias Klose
Package: libc6-i386 Severity: serious the current conflict (= 4.4.0-5) is not enough. it has to be 4.4.0-7. -- To UNSUBSCRIBE, email to debian-glibc-requ...@lists.debian.org with a subject of unsubscribe. Trouble? Contact listmas...@lists.debian.org

Bug#533482: wrong version in libc6-i386-dev conflict

2009-06-17 Thread Matthias Klose
Package: libc6-i386 Version: 2.9-16 Severity: serious conficts with libc6-dev-i386 (= 2.9.14), which should be 2.9-14. -- To UNSUBSCRIBE, email to debian-glibc-requ...@lists.debian.org with a subject of unsubscribe. Trouble? Contact listmas...@lists.debian.org

Bug#524046: tzdata doesn't include timezones from the pacificnew file

2009-04-14 Thread Matthias Klose
Package: tzdata Version: 2009e-1 tzdata doesn't include timezones from the pacificnew file, please include these. some testcase complain about the missing zones. -- To UNSUBSCRIBE, email to debian-glibc-requ...@lists.debian.org with a subject of unsubscribe. Trouble? Contact

Bug#504031: don't assume expected and current testsuite results in same order

2008-10-30 Thread Matthias Klose
Package: glibc Tags: patch updated compare.sh sorting both files before comparing. Matthias #!/bin/bash if [ $# -ne '2' ]; then echo -e \nUsage: Compare a test-expected-* file and a test-results-* file. echo -e $0 : Expected testsuite results Testsuite results \n; exit 1 fi;

Bug#490622: please generate zoneinfo files in file format known by openjdk/sun-java

2008-07-13 Thread Matthias Klose
Package: tzdata Version: 2008c-1 Please generate zoneinfo files in the file format known by openjdk/sun-java; this should be built from the tzdata source to avoid duplication of the data and put into a separate binary package. please use either use the sources included in the ubuntu patch

Bug#482902: please provide libc6-hppa64 and libc6-hppa64-dev packages

2008-05-25 Thread Matthias Klose
Package: glibc Version: 2.7-11 Severity: important Please build libc6-hppa64 and libc6-hppa64-dev packages; there is no package build-depending on libc6-hppa64-dev, but we need these packages to run the testsuites for binutils and gcc-4.X. Currently these packages are completely untested,

Bug#482902: please provide libc6-hppa64 and libc6-hppa64-dev packages

2008-05-25 Thread Matthias Klose
clone 482902 -1 reassign -1 general severity -1 serious thanks Aurelien Jarno writes: severity 482902 wishlist tag 482902 + upstream tag 482902 + wontfix thanks Matthias Klose a écrit : Package: glibc Version: 2.7-11 Severity: important Please build libc6-hppa64 and libc6-hppa64

Bug#480295: [alpha] missing asm/page.h

2008-05-09 Thread Matthias Klose
Package: glibc Version: 2.7-10 http://experimental.ftbfs.de/fetch.php?pkg=binutilsver=2.18.50.20080507-1arch=alphastamp=1210319481file=logas=raw In file included from ../../bfd/trad-core.c:45: /usr/include/sys/user.h:27:22: error: asm/page.h: No such file or directory make[5]: *** [trad-core.lo]

Re: glibc 2.7

2007-10-08 Thread Matthias Klose
Glibc upstream announced recently that the glibc 2.7 will be tagged and released very soon (probably on Oct 17[0]). which toolchain versions are required as build dependencies? Matthias -- To UNSUBSCRIBE, email to [EMAIL PROTECTED] with a subject of unsubscribe. Trouble? Contact [EMAIL

Bug#434626: [powerpc] broken 64bit packages

2007-07-25 Thread Matthias Klose
Package: libc6-ppc64 Version: 2.6-3 Severity: serious Seen while rebuilding gcc-4.2 / gcj-4.2; 64bit configure tests fail with a segfault. Reverting to 2.6-2 lets the bootstrap succeed. -- To UNSUBSCRIBE, email to [EMAIL PROTECTED] with a subject of unsubscribe. Trouble? Contact [EMAIL

Bug#434626: [powerpc] broken 64bit packages

2007-07-25 Thread Matthias Klose
Aurelien Jarno writes: clone 434626 -1 reassign -1 gcc-4.2 retitle -1 [powerpc] generate broken 64-bit binaries thanks On Wed, Jul 25, 2007 at 01:18:43PM +0200, Matthias Klose wrote: Package: libc6-ppc64 Version: 2.6-3 Severity: serious Seen while rebuilding gcc-4.2 / gcj-4.2

Bug#427398: Bug#427907: [hppa] git-core selftest failure with -O2 and -O1, -O0 works

2007-06-07 Thread Matthias Klose
probably related to #427398. Gerrit Pape writes: Package: gcc-4.1 Version: 4.1.2-11 See http://buildd.debian.org/fetch.cgi?pkg=git-corever=1%3A1.5.2.1-1arch=hppastamp=1180881720file=log I can reproduce this in paer's sid chroot as follows: $ apt-get source git-core Reading package

Bug#405738: glibc should build-depend on binutils (= 2.17.50)

2007-04-11 Thread Matthias Klose
reopen 405738 found 405738 2.5-1 apparently the build dependency has been dropped again; was there a reason to rush the glibc upload and not to wait for the binutils update? -- To UNSUBSCRIBE, email to [EMAIL PROTECTED] with a subject of unsubscribe. Trouble? Contact [EMAIL PROTECTED]

Bug#413370: libssp32, libssp64 removed in experimental

2007-03-04 Thread Matthias Klose
Package: glibc Version: 2.5 Severity: important libssp32, libssp64 are not built anymore by gcc in experimental, glibc b-d on these. -- To UNSUBSCRIBE, email to [EMAIL PROTECTED] with a subject of unsubscribe. Trouble? Contact [EMAIL PROTECTED]

Bug#413370: libssp32, libssp64 removed in experimental

2007-03-04 Thread Matthias Klose
Aurelien Jarno writes: Matthias Klose a écrit : Package: glibc Version: 2.5 Severity: important libssp32, libssp64 are not built anymore by gcc in experimental, glibc b-d on these. This means we will have to build-depends on gcc-4.1 from experimental. or maybe provide libssp32

Bug#405738: glibc should build-depend on binutils (= 2.17.50)

2007-01-05 Thread Matthias Klose
Package: glibc Version: 2.5 Tags: experimental Severity: important glibc uses --hash-style for linking, when detected. Please build-depend on the appropriate binutils version, so that glibc is always built using --hash-style=both. -- To UNSUBSCRIBE, email to [EMAIL PROTECTED] with a subject of

Bug#391858: FTBFS: gcc-4.x with glibc from experimental

2006-10-08 Thread Matthias Klose
Package: glibc Version: 2.5-0exp1 Tags: experimental Severity: serious see #374535, it's the GNU_TYPE, not the Debian architecture. $ find /usr/include/ -name stubs*/usr/include/gnu/stubs.h /usr/include/gnu/stubs-32.h /usr/include/ppc64-linux-gnu/gnu/stubs.h

glibc build-depends on gcc-4.0 on hurd-i386?

2006-09-05 Thread Matthias Klose
Is this a leftover, which can be changed to gcc-4.1 now? -- To UNSUBSCRIBE, email to [EMAIL PROTECTED] with a subject of unsubscribe. Trouble? Contact [EMAIL PROTECTED]

Re: Bug#364231: [parisc-linux] Re: Bug#364231: exception catching

2006-05-02 Thread Matthias Klose
[should we drop parisc-linux?] John David Anglin writes: Er, no; we're talking about official Debian packages here, and the libstdc++.so.6 in Debian is now from gcc-4.1. The problem is precisely that GMP *is* being built using gcc-4.0, but libstdc++ is from gcc-4.1, resulting in the

Bug#361642: i386 gconv modules not found on amd64

2006-04-09 Thread Matthias Klose
Package: libc6-i386 Severity: important Version: 2.3.6 Tags: patch third party applications like 32bit acroread won't start. http://people.ubuntu.com/patches/glibc-amd64.diff -- To UNSUBSCRIBE, email to [EMAIL PROTECTED] with a subject of unsubscribe. Trouble? Contact [EMAIL PROTECTED]

Bug#355800: [powerpc] GCC 3.4.6 test suite failures with current glibc-3.2.6

2006-03-07 Thread Matthias Klose
Package: glibc Version: 2.3.6 Severity: important Running the gcc testsuite from gcc-3.4.6-1 (or gcc-3.4.5-3) on both current Debian unstable and Ubuntu dapper shows some test failures, which are only seen on unstable's glibc. --- ../../gcc-3.4-3.4.6/test-summary2006-03-07 05:30:43.0

Re: Multiarch support (was Moving 32-bit libraries to (/usr)/lib32 on amd64)

2006-02-23 Thread Matthias Klose
Bdale Garbee writes: On Fri, 2006-02-24 at 01:12 +0100, Aurelien Jarno wrote: The only change planned is to make libc6-dev-i386 and libc6-i386 provide a glibc on amd64 instead of ia32-libs. It will be in /emul/ia32-linux (I still have to find how to do that cleanly in the debhelper

Re: Moving 32-bit libraries to (/usr)/lib32 on amd64

2006-02-20 Thread Matthias Klose
Kurt Roeckx writes: In the end, I'd like to get rid of ia32-libs, and have it be a dummy package. But on the other hand, I don't want to make a biarch version of things like the X libraries. you can't get rid of it on ia64 unless you either drop the 32bit support or else you provide a

Re: Bug#341147: libg2c0-dev: Has file in /usr/lib32 instead of /emul/ia32-linux/usr/lib

2005-11-28 Thread Matthias Klose
Kurt Roeckx writes: Package: libg2c0-dev Version: 3.4.4-10 Severity: serious Hi, libg2c0-dev installs files in /usr/lib32, which conflict with the symlink from ia32-libs. It should be putting the files in /emul/ia32-linux/usr/lib instead. Note that this works as long as you install

Bug#340835: sparc: /lib64/libc.so.6: unexpected reloc type 0x4f

2005-11-26 Thread Matthias Klose
Package: glibc Version: 2.3.5-8 Severity: serious makes gcc* FTBFS on sparc, 2.3.5-6 looks ok. long longval () { return (long) (sizeof (int)); } unsigned long ulongval () { return (long) (sizeof (int)); } #include stdio.h #include stdlib.h int main () { FILE *f = fopen (conftest.val, w); if

Re: Bug#329108: gcc-4.0 FTBFS on, uh, i386

2005-09-23 Thread Matthias Klose
GOTO Masanori writes: At Mon, 19 Sep 2005 19:27:15 +0200, Matthias Klose wrote: On the latest i386 Sid, gcc-4.0 does not build from source, on my machine, and on a buildd (see the logs). With dash as sh, I get: this is known, we're waiting on proper 64bit support from glibc. I'd

Re: [parisc-linux] glibc binary NMU for hppa, built with gcc-3.4

2005-09-20 Thread Matthias Klose
John David Anglin writes: Following the discussion on parisc, I uploaded glibc built with gcc-3.4. Validated, that gcc-4.0 bootstraps again and the python build errors are gone. Does this fix GCC PR 23731? can't check, it currently segfaults trying to generate the classmap.db (same thing

Re: [parisc-linux] glibc binary NMU for hppa, built with gcc-3.4

2005-09-20 Thread Matthias Klose
John David Anglin writes: Following the discussion on parisc, I uploaded glibc built with gcc-3.4. Validated, that gcc-4.0 bootstraps again and the python build errors are gone. Does this fix GCC PR 23731? down to 475 test failures. Maybe related to PR23602 -- To UNSUBSCRIBE, email to

Re: Bug#329108: gcc-4.0 FTBFS on, uh, i386

2005-09-19 Thread Matthias Klose
On the latest i386 Sid, gcc-4.0 does not build from source, on my machine, and on a buildd (see the logs). With dash as sh, I get: this is known, we're waiting on proper 64bit support from glibc. I'd like to downgrade this one until we have the support. Goto, you did say, you wanted address

glibc binary NMU for hppa, built with gcc-3.4

2005-09-17 Thread Matthias Klose
Following the discussion on parisc, I uploaded glibc built with gcc-3.4. Validated, that gcc-4.0 bootstraps again and the python build errors are gone. Please make this change for the next sourceful upload. Matthias -- To UNSUBSCRIBE, email to [EMAIL PROTECTED] with a subject of

Bug#326594: fpsetdefaults function missing in glibc-2.3.5

2005-09-12 Thread Matthias Klose
GOTO Masanori writes: At Sun, 4 Sep 2005 11:41:17 +0200, Matthias Klose wrote: glibc-2.3.5 doesn't have the fpsetdefaults function anymore, which was available in 2.3.2. Is the omission intended? If yes, is there a replacement function? Currently the python fpectl module fpectl FTBFS. I

Bug#326581: gcc-4.0_4.0.1-6 FTBFS on hppa

2005-09-06 Thread Matthias Klose
The current package in the archive FTBFS as well, with a strange error in libjava. The headers are not yet built at this point. Using glibc-2.3.2 or breezy's glibc doesn't show the problem. /scratch/packages/gcc/4.0/gcc-4.0-4.0.1/build/gcc/gcj

Bug#326581: [hppa] glibc-2.3.5 let's python builds FTBFS

2005-09-04 Thread Matthias Klose
Package: glibc Version: 2.3.5-6 Severity: grave The python2.3 package (as well as the 2.2 and 2.4 package) FTBFS on hppa (see the buildd logs). The failures do not occur when downgrading glibc to 2.3.2 from sarge, or using breezy's glibc. Not further tracked down. -- To UNSUBSCRIBE, email to

Bug#326594: fpsetdefaults function missing in glibc-2.3.5

2005-09-04 Thread Matthias Klose
Package: glibc Version: 2.3.5-6 glibc-2.3.5 doesn't have the fpsetdefaults function anymore, which was available in 2.3.2. Is the omission intended? If yes, is there a replacement function? Currently the python fpectl module fpectl FTBFS. -- To UNSUBSCRIBE, email to [EMAIL PROTECTED] with a

Bug#323552: 64bit -dev packages should depend on libXXgcc1

2005-08-17 Thread Matthias Klose
Package: glibc gcc itself cannot depend on those, without sucking in 64bit glibc packages. diff -u glibc-2.3.5/debian/control.in/sparc64 glibc-2.3.5/debian/control.in/sparc64 --- glibc-2.3.5/debian/control.in/sparc64 +++ glibc-2.3.5/debian/control.in/sparc64 @@ -13,7 +13,7 @@ Architecture:

Re: Bug#321785: fakeroot: segfaults on [hppa]

2005-08-09 Thread Matthias Klose
--j79F1xXV029481.1123599719/bolero.cs.tu-berlin.de-- -- To UNSUBSCRIBE, email to [EMAIL PROTECTED] with a subject of unsubscribe. Trouble? Contact [EMAIL PROTECTED]

Re: fakeroot: segfaults on [hppa]

2005-08-08 Thread Matthias Klose
fakeroot-tcp shows the same behaviour. reverting back to glibc-2.3.2 is a workaround. Matthias -- To UNSUBSCRIBE, email to [EMAIL PROTECTED] with a subject of unsubscribe. Trouble? Contact [EMAIL PROTECTED]

Bug#318297: isdnutils FTBFS, error in kernel headers

2005-07-14 Thread Matthias Klose
Package: linux-kernel-headers Severity: important Tags: patch In file included from capidyn.c:23: /usr/include/linux/capi.h:80: error: variable or field '__user' declared void /usr/include/linux/capi.h:80: error: syntax error before '*' token /usr/include/linux/capi.h:115: error: syntax error

Bug#317082: libc6-s390x: missing depends on lib64gcc1

2005-07-12 Thread Matthias Klose
GOTO Masanori writes: At Tue, 05 Jul 2005 20:09:59 -0700, Ryan Murray wrote: libc6-s390x is missing a depends on lib64gcc1 that causes gcc to fail to link when -m64 is used on an s390 system. I'm filling the bug here rather than on the gcc-VERSION packages because the sparc64

Re: Bug#317501: amd64-libs-dev conflicts with linux-kernel-headers

2005-07-09 Thread Matthias Klose
Daniel Jacobowitz writes: On Sat, Jul 09, 2005 at 09:29:33AM +0200, Matthias Klose wrote: Package: amd64-libs-dev Version: 1.1 Severity: grave Conflicts against linux-kernel-headers_2.6.12.0-1, the biarch build for gcc-3.4 and gcc-4.0 on i386 have to be disabled, therefore severity

Bug#313404: glibc update needed for dpkg-architecture changes

2005-06-13 Thread Matthias Klose
Package: glibc Version: 2.3.2.ds1-22 Severity: important For the toolchain update to use the new GNU_TYPE's, the hppa builds needs a /usr/hppa64-linux-gnu/include symlink. Please keep the old /usr/hppa64-linux/include symlink until all compilers are using the new path. The debian build files

Bug#293154: /usr/include/pthread.h: No valid ANSI C

2005-02-02 Thread Matthias Klose
GOTO Masanori writes: At Tue, 1 Feb 2005 15:16:17 +0100, Matthias Klose wrote: patch at http://people.ubuntu.com/patches/glibc-pthread-sigsetjmp.diff breaks gcc-4.0 bootstraps on architectures with nptl threads. would be nice to fix for sarge ... see http://gcc.gnu.org/ml/gcc

Bug#293154: /usr/include/pthread.h: No valid ANSI C

2005-02-01 Thread Matthias Klose
Package: glibc Version: 2.3.2.ds1-20 Severity: important Tags: sid, sarge patch at http://people.ubuntu.com/patches/glibc-pthread-sigsetjmp.diff breaks gcc-4.0 bootstraps on architectures with nptl threads. would be nice to fix for sarge ... see

Bug#284793: libc6-prof: Running programs compiled with -profile fails

2004-12-14 Thread Matthias Klose
severity 284793 minor reassign 284793 gcc thanks the -profile option isn't recognized. please use -p or --profile. in earlier gcc versions, -profile did link in the gcrt0 start file, but gcc-3.3 and later link crt0. I didn't any documentation actually mentioning -profile. Matthias

Bug#284563: status of libunwind patches for ia64

2004-12-13 Thread Matthias Klose
David Mosberger writes: I wanted to try this but found that the gcc-3.3 has a libgcc1 package for hppa only. Is this intentional? I thought a new libgcc1 package for ia64 was needed so we pick up the libunwind built from the libunwind sources. please get the libgcc1 package from the

Bug#284563: status of libunwind patches for ia64

2004-12-12 Thread Matthias Klose
of Jeff Bailey. Closes: #284563. -- Matthias Klose [EMAIL PROTECTED] Fri, 10 Dec 2004 11:05:00 -0800 diff -u glibc-2.3.2.ds1/debian/control.in/main glibc-2.3.2.ds1/debian/control.in/main --- glibc-2.3.2.ds1/debian/control.in/main +++ glibc-2.3.2.ds1/debian/control.in/main @@ -1,7 +1,7

Bug#284563: libunwind in unstable

2004-12-10 Thread Matthias Klose
H. J. Lu writes: On Thu, Dec 09, 2004 at 12:49:38PM +0100, Matthias Klose wrote: H. J. Lu writes: On Tue, Dec 07, 2004 at 12:16:56AM -0800, David Mosberger wrote: On Tue, 7 Dec 2004 09:01:33 +0100, Matthias Klose [EMAIL PROTECTED] said: Matthias glibc now fails to build

Bug#284563: libunwind in unstable

2004-12-09 Thread Matthias Klose
H. J. Lu writes: On Tue, Dec 07, 2004 at 12:16:56AM -0800, David Mosberger wrote: On Tue, 7 Dec 2004 09:01:33 +0100, Matthias Klose [EMAIL PROTECTED] said: Matthias glibc now fails to build from source: Matthias undefined reference to `__gcc_personality_v0' Argh, looks

Bug#283461: new patch glibc232-nptl-pthread to build g++/libsupc++ with nptl headers

2004-11-28 Thread Matthias Klose
not +use C99 designators, as C++ does not have support for them. + + -- Matthias Klose [EMAIL PROTECTED] Mon, 29 Nov 2004 00:11:44 +0100 diff -u glibc-2.3.2.ds1/debian/patches/00list glibc-2.3.2.ds1/debian/patches/00list --- glibc-2.3.2.ds1/debian/patches/00list +++ glibc-2.3.2.ds1/debian

Re: libunwind in unstable

2004-11-25 Thread Matthias Klose
Matthieu Delahaye writes: On Wed, 2004-11-24 at 17:36, Ian Wienand wrote: On Wed, Nov 24, 2004 at 12:46:12AM +0100, Matthias Klose wrote: ok, Ian, if it's ok with you, I'll prepare a libunwind upload, which plays well with a libgcc1 package including the libunwind7 shared libs

Re: libunwind in unstable

2004-11-23 Thread Matthias Klose
Ian Wienand writes: On Mon, Nov 22, 2004 at 05:30:38PM -0800, David Mosberger wrote: That would make sense. libstdc++5 calls _Unwind_Resume() which is/should be implemented by libunwind.so.7. With older versions of GCC, it was implemented as part of libgcc_eh.a/libgcc_s.so. Actually,

Re: libunwind in unstable

2004-11-23 Thread Matthias Klose
David Mosberger writes: On Tue, 23 Nov 2004 09:27:52 +0100, Matthias Klose [EMAIL PROTECTED] said: Matthias Is the patch in #278836 a prerequisite for the above Matthias changes, or can it be done without it? If the gas-patch isn't applied, you run the risk of getting wrong unwind

Re: libunwind in unstable

2004-11-23 Thread Matthias Klose
David Mosberger writes: On Wed, 24 Nov 2004 00:26:01 +0100, Matthias Klose [EMAIL PROTECTED] said: Matthias From my point of view we can get around with it by Matthias including the libunwind shared library in libgcc1 for the Matthias sarge release. I'm worried about the version

Bug#274738: on mips{,el} atexit.o should be compiled with -mxgot

2004-10-03 Thread Matthias Klose
Package: glibc Severity: serious Tags: sid current mainline libgcj fails to build on mips{,el}: /home/doko/gcc/gcc-snapshot-20041003/build/gcc/xgcc -shared-libgcc -B/home/doko/gcc/gcc-snapshot-20041003/build/gcc/ -nostdinc++

  1   2   >