Bug#572895: ldconfig issue: priority of /lib and /usr/lib is too high

2010-03-07 Thread Harald Dunkel
-BEGIN PGP SIGNED MESSAGE- Hash: SHA1 Package: libc-bin Version: 2.10.2-6 I would like to override the standard libGL.so files by a private library installed in a special directory. Problem: It seems that the libraries in in /lib and /usr/lib have a higher priority than any other

Bug#572895: ldconfig issue: priority of /lib and /usr/lib is too high

2010-03-13 Thread Harald Dunkel
-BEGIN PGP SIGNED MESSAGE- Hash: SHA1 Of course I ran ldconfig (as root). # ldconfig -p | grep libGL.so.1 libGL.so.1 (libc6,x86-64, OS ABI: Linux 2.4.20) = /usr/lib/libGL.so.1 libGL.so.1 (libc6,x86-64) = /usr/lib/nvidia-current/libGL.so.1 libGL.so.1 (libc6, OS

Bug#572895: ldconfig issue: priority of /lib and /usr/lib is too high

2010-03-13 Thread Harald Dunkel
-BEGIN PGP SIGNED MESSAGE- Hash: SHA1 PS: I found this thread: http://www.mail-archive.com/mesa3d-...@lists.sourceforge.net/msg11607.html AFAICS the issue is still unresolved. What would be your suggestion? Is there some configure option to tell ldconfig or ld.so to ignore the OS ABI

Bug#584914: metoo

2010-11-22 Thread Harald Dunkel
I got the same problem for version 2.11.2-7. If I replace the compat in nsswitch.conf by nis files _and_ stop nscd, then it works. IMHO nscd should not ignore nsswitch.conf. Is this another bug? Please mail if I can help to track this down. Regards Harri -- To UNSUBSCRIBE, email to

Bug#572895: ldconfig issue: priority of /lib and /usr/lib is too high

2010-12-05 Thread Harald Dunkel
-BEGIN PGP SIGNED MESSAGE- Hash: SHA1 Are there any news about this? Is this unique to eglibc? Regards Harri -BEGIN PGP SIGNATURE- Version: GnuPG v1.4.10 (GNU/Linux) Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

Bug#584914: this serious

2011-05-05 Thread Harald Dunkel
Hi folks, of course fixing bugs is an ugly business, but would it be possible to increase the priority of this bug report? This problem produced 30 minutes downtime on our CVS server. Many thanx Harri -- To UNSUBSCRIBE, email to debian-glibc-requ...@lists.debian.org with a subject of

question about overriding ld.so.conf

2011-06-01 Thread Harald Dunkel
-BEGIN PGP SIGNED MESSAGE- Hash: SHA1 Hi folks, Looking at http://bugs.debian.org/572895 I wonder if it is reasonable to allow a hard-coded priority (the os abi tag set in a library) to override a configurable priority (ld.so.conf and ld.so.conf.d/*)? Shouldn't the package providing the

Re: question about overriding ld.so.conf

2011-06-14 Thread Harald Dunkel
-BEGIN PGP SIGNED MESSAGE- Hash: SHA1 On 06/07/11 13:00, Aurelien Jarno wrote: I think the problem has to be fixed in the libraries themselves, this can be done in two ways: - the library not providing an os abi tag should be changed to provide one. - the library providing an

Bug#584914: backport from wheezy?

2011-07-11 Thread Harald Dunkel
AFAICS the problem doesn't exist for Wheezy (correct me if I am wrong), so I wonder if it would be possible to backport the fix to Squeeze? Regards Harri -- To UNSUBSCRIBE, email to debian-glibc-requ...@lists.debian.org with a subject of unsubscribe. Trouble? Contact

Bug#584914: security issue?

2011-07-12 Thread Harald Dunkel
PS: If -@netgroup doesn't work as expected, doesn't this mean that a user might be granted _more_ group permissions than configured? Wouldn't this mean that this problem is a security issue? Regards Harri -- To UNSUBSCRIBE, email to debian-glibc-requ...@lists.debian.org with a subject of

Bug#572895: resolved?

2013-07-14 Thread Harald Dunkel
AFAICS the mesa folks don't rely upon the os abi tag anymore: https://bugs.freedesktop.org/show_bug.cgi?id=26663 Regards Harri -- To UNSUBSCRIBE, email to debian-glibc-requ...@lists.debian.org with a subject of unsubscribe. Trouble? Contact listmas...@lists.debian.org Archive:

Bug#717629: please document LANG and LC_ALL in locale(1)

2013-07-23 Thread Harald Dunkel
Package: locales Version: 2.13-38 Seems that LANG and LC_ALL have been lost in locale(1). It would be nice if they could be added. http://pubs.opengroup.org/onlinepubs/007908799/xbd/envvar.html Many thanx Harri -- To UNSUBSCRIBE, email to debian-glibc-requ...@lists.debian.org with a subject

Bug#572895: ldconfig issue: priority of /lib and /usr/lib is too high

2013-09-18 Thread Harald Dunkel
-BEGIN PGP SIGNED MESSAGE- Hash: SHA256 Sorry to say, but I doubt that it is reasonable to set a bug to wishlist, just because the OS ABI tag issue is complex. This does not help. My suggestion is to keep things simple. Since mesa doesn't need it anymore, are there any other packages in

Bug#166914: glibc 2.1 binary says: __strtoul_internal not defined in file libpthread.so.0

2002-10-29 Thread Harald Dunkel
Package: libc6 Version: 2.3.1-3 Hi folks, I've got this error message at runtime, using glibc 2.3.1-3: myexec: relocation error: myexec: symbol __strtoul_internal, version GLIBC_2.0 \ not defined in file libpthread.so.0 with link time reference FATAL: Exec 'myexec' failed: status = 127 Some

Bug#218408: libc6 2.3.2.ds1-8 breaks NVidia's driver

2003-10-30 Thread Harald Dunkel
Package: libc6 Version: 2.3.2.ds1-8 Hi folks, After upgrading glibc in Sid to version 2.3.2.ds1-8 the NVidia driver for XFree86 did not work anymore. Instead of the usual splash screen I got a white screen with just a few horizontal lines, then the screen was frozen. Downgrading glibc back to

glibc 2.3.3 not in?

2004-08-08 Thread Harald Dunkel
Hi folks, I am just curious: Why isn't glibc 2.3.3 in Debian? Regards Harri -- To UNSUBSCRIBE, email to [EMAIL PROTECTED] with a subject of unsubscribe. Trouble? Contact [EMAIL PROTECTED]

Bug#267594: libc6 depends on bash

2004-08-23 Thread Harald Dunkel
Package: libc6 Version: 2.3.2.ds1-16.0.0.1.amd64 Hi folks, libc6 depends on bash (see /var/lib/dpkg/info/libc6.preinst), but doesn't list it in the Depends list. Would it be possible to fix the package header? Regards Harri -- To UNSUBSCRIBE, email to [EMAIL PROTECTED] with a subject of

Bug#267594: libc6 depends on bash

2004-08-23 Thread Harald Dunkel
PS.: Maybe you could consider to use /bin/sh instead? This would make it easier to setup a minimum system based upon dash or ash, for example. Most packages use /bin/sh for their dpkg scripts, as it seems. -- To UNSUBSCRIBE, email to [EMAIL PROTECTED] with a subject of unsubscribe. Trouble?

Bug#267594: libc6 depends on bash

2004-08-27 Thread Harald Dunkel
GOTO Masanori wrote: Bash is required package, so minimum base system should have bash. If you don't use such debian base system, then libc6.postinst becomes meaningless because you don't use the normal debian system. I do not understand why you refuse to add this dependency to the control file.

Bug#267594: libc6 depends on bash

2004-08-29 Thread Harald Dunkel
GOTO Masanori wrote: BTW, even we use /bin/bash, do we have reason to use /bin/sh? If so, why? bash is included in the base system. We use various tools for postinst/preinst, because those tools are also in the bootstrapping base system. Most of the other packages don't work without libc6,

Bug#267594: libc6 depends on bash

2004-08-31 Thread Harald Dunkel
GOTO Masanori wrote: My point is: installing debian package needs the debian base system that includes bash. Moreover it's not only glibc package issue. If you have plan to support all base packages with /bin/sh, and that makes easier installation for bootstrapping, I don't complain it. If not,

Bug#57195: bugfix for libc6 2.1.2-13, /etc/init.d/devpts.sh

2000-02-06 Thread Harald Dunkel
Package: libc6 Version: 2.1.2-13 Small typo in /etc/init.d/devpts.sh. Patch: # diff -c /etc/init.d/devpts.sh~ /etc/init.d/devpts.sh *** /etc/init.d/devpts.sh~ Sat Jan 29 05:39:14 2000 --- /etc/init.d/devpts.sh Sun Feb 6 20:07:50 2000 *** *** 13,19 make_devpts() {

Bug#267594: libc6 depends on bash

2004-08-30 Thread Harald Dunkel
GOTO Masanori wrote: At Mon, 30 Aug 2004 06:20:06 +0200, Harald Dunkel wrote: IMHO libc6 should not depend upon other packages at all. If there is no way around this, then it should work with any /bin/sh, not just bash. Why does there is no way around this lead it should work with any /bin/sh

Bug#274367: serious conflict between ia32-libs and libc6

2005-04-18 Thread Harald Dunkel
Frederik Schueler wrote: Hello, On Mon, Apr 18, 2005 at 07:25:41AM +0200, Harald Dunkel wrote: Preparing to replace ia32-libs 0.7.0.0.1.gcc4 (using .../ia32-libs_1.2.0.0.1.gcc4_amd64.deb) ... Unpacking replacement ia32-libs ... dpkg: error processing /var/cache/apt/archives/ia32

Bug#743866: getaddrinfo(3) failure for zeroconf (avahi)

2014-04-07 Thread Harald Dunkel
Package: libc6 Version: 2.18-4 Sometimes avahi-resolve-host-name and getaddrinfo(3) disagree about DNS. Sample: % avahi-resolve-host-name pepe.local; ./getaddrinfo pepe.local pepe.local 10.42.100.198 getaddrinfo: Name or service not known nscd is not running. /etc/nsswitch.conf says

Bug#895981: please cleanup /var/cache/nscd on restart

2018-06-08 Thread Harald Dunkel
Any news on this? Did you report this bug upstream? Here is a sample session showing the effect: # ping lxc01 PING lxc01.example.de (172.16.99.198) 56(84) bytes of data. From dpcl082.example.de (172.16.97.128) icmp_seq=1 Destination Host Unreachable From dpcl082.example.de (172.16.97.128)

Bug#895981: please cleanup /var/cache/nscd on restart

2018-04-30 Thread Harald Dunkel
Not sure if it matters, but if resolvconf is active, then /etc/resolv.conf is a symbolic link. Regards Harri

Bug#895981: please cleanup /var/cache/nscd on restart

2018-04-18 Thread Harald Dunkel
Package: nscd Version: 2.24-11+deb9u3 If I change nscd.conf (to adjust some ttl or to disable some cache) and restart the service, then the cache files in /var/cache/nscd are not adjusted accordingly, AFIACS. In worst case the passwd cache is kept forever and never adjusted, even though it has

Bug#895981: please cleanup /var/cache/nscd on restart

2018-04-19 Thread Harald Dunkel
Hi Aurelien, I am using both systemd and sysvinit-core, but I am not sure which one was active when I ran into this problem. Consider a split DNS setup for a remote network. I had started an IPsec connection to the remote side. /etc/resolv.conf was changed to include the new internal DNServer

Bug#921913: locales: character map file `C' not found: No such file or directory

2019-02-18 Thread Harald Dunkel
Metoo. Hopefully this is not too difficult to fix before Buster? Regards Harri