Bug#702962: file conflicts in libc6-dev-i386 and libc6-dev-mips64

2013-03-13 Thread YunQiang Su
-dev (ia64) and may other libc*-dev-${arch} packages. This is found when I try to build a cross gcc whose build platform is amd64 while target platform is mips64el. -- YunQiang Su -- To UNSUBSCRIBE, email to debian-glibc-requ...@lists.debian.org with a subject of unsubscribe. Trouble? Contact

Bug#694964: libc6:amd64: binary debian target fails - /usr/include/locale.h cannot be removed

2013-05-14 Thread YunQiang Su
I meet the same problem when build 2.17-1 and 2.17-2. While the your patch doesn't work. -- YunQiang Su -- To UNSUBSCRIBE, email to debian-glibc-requ...@lists.debian.org with a subject of unsubscribe. Trouble? Contact listmas...@lists.debian.org Archive: http://lists.debian.org

Bug#715038: add mips64(el) mipsn32(el) support to eglibc

2013-10-06 Thread YunQiang Su
I refresh the patches with 2.17-93. It's time to consider to merge it. Now we have about 7000 packages build successfully already. This architecture may be in debian-ports in near future. -- YunQiang Su mips64.diff Description: Binary data

Bug#730092: Missing EFD_SEMAPHORE in bits/eventfd.h for sparc

2013-11-21 Thread YunQiang Su
=1379844378 -- YunQiang Su -- To UNSUBSCRIBE, email to debian-glibc-requ...@lists.debian.org with a subject of unsubscribe. Trouble? Contact listmas...@lists.debian.org Archive: http://lists.debian.org/CAKcpw6UXmxX-GxAdtRobQ4URMNRrmKLB=ovj9_8z1dhfflc...@mail.gmail.com

Bug#715038: add mips64(el) mipsn32(el) support to eglibc

2014-04-25 Thread Yunqiang Su
I refresh this patch with 2.18-4, and let libc6 breaks: libc6-mips64 [mips64 mips64el], libc6-mipsn32 [mipsn32 mipsn32el], libc6-mips32 [mips mipsel], On Thu, Feb 27, 2014 at 9:20 AM, Yunqiang Su wzss...@gmail.com wrote: I refresh this patch with 2.18-3 On Mon

Bug#715038: add mips64(el) mipsn32(el) support to eglibc

2014-05-07 Thread Yunqiang Su
On Wed, May 7, 2014 at 11:02 PM, Aurelien Jarno aurel...@aurel32.net wrote: On Fri, Apr 25, 2014 at 10:25:55PM +0800, Yunqiang Su wrote: On Fri, Apr 25, 2014 at 10:25 PM, Yunqiang Su wzss...@gmail.com wrote: I refresh this patch with 2.18-4, and let libc6 breaks: libc6-mips64

Bug#715038: add mips64(el) mipsn32(el) support to eglibc

2014-05-19 Thread Yunqiang Su
I refreshed this patch with 2.18-6. On Thu, May 8, 2014 at 10:53 AM, Yunqiang Su wzss...@gmail.com wrote: On Wed, May 7, 2014 at 11:02 PM, Aurelien Jarno aurel...@aurel32.net wrote: On Fri, Apr 25, 2014 at 10:25:55PM +0800, Yunqiang Su wrote: On Fri, Apr 25, 2014 at 10:25 PM, Yunqiang Su wzss

Bug#715038: add mips64(el) mipsn32(el) support to eglibc

2014-06-05 Thread Yunqiang Su
Hi, as I asked that guys, they insist on using /usr/lib but not /usr/libo32. :-( Then, maybe this patch should be OK. please consider it. On Tue, May 20, 2014 at 4:24 AM, Yunqiang Su wzss...@gmail.com wrote: I refreshed this patch with 2.18-6. On Thu, May 8, 2014 at 10:53 AM, Yunqiang Su wzss

Bug#715038: add mips64(el) mipsn32(el) support to eglibc

2014-06-09 Thread Yunqiang Su
On Mon, Jun 9, 2014 at 10:11 PM, Aurelien Jarno aurel...@aurel32.net wrote: On Thu, Jun 05, 2014 at 11:34:37PM +0800, Yunqiang Su wrote: Hi, as I asked that guys, they insist on using /usr/lib but not /usr/libo32. :-( Who are the guys? What is the argument on using /usr/lib instead of /usr

Bug#715038: add mips64(el) mipsn32(el) support to eglibc

2014-06-11 Thread Yunqiang Su
to look at the SVN to check everything is ok. Great, thank you so much. -- Aurelien Jarno GPG: 4096R/1DDD8C9B aurel...@aurel32.net http://www.aurel32.net -- To unsubscribe, send mail to 715038-unsubscr...@bugs.debian.org. -- Yunqiang Su

Bug#773300: Improve glibc bootstrap

2014-12-16 Thread YunQiang Su
consider it in the future version (2.20?) -- YunQiang Su glibc.debdiff Description: Binary data

Bug#773300: Improve glibc bootstrap

2014-12-18 Thread YunQiang Su
Thank you for pointing them out. On Wed, Dec 17, 2014 at 3:10 AM, Helmut Grohne hel...@subdivi.de wrote: On Tue, Dec 16, 2014 at 11:39:40PM +0800, YunQiang Su wrote: Hi, the attached patch can improve bootstrapping of glibc. Partially, this seems to be a duplicate of #766877. Maybe

Bug#773300: Improve glibc bootstrap

2014-12-18 Thread YunQiang Su
Sorry, forgot to attach the new patch. On Thu, Dec 18, 2014 at 11:44 PM, YunQiang Su wzss...@gmail.com wrote: Thank you for pointing them out. On Wed, Dec 17, 2014 at 3:10 AM, Helmut Grohne hel...@subdivi.de wrote: On Tue, Dec 16, 2014 at 11:39:40PM +0800, YunQiang Su wrote: Hi, the attached

Bug#773300: Improve glibc bootstrap

2015-05-01 Thread YunQiang Su
On Thu, 18 Dec 2014 23:44:33 +0800 YunQiang Su wzss...@gmail.com wrote: Sorry, forgot to attach the new patch. On Thu, Dec 18, 2014 at 11:44 PM, YunQiang Su wzss...@gmail.com wrote: Thank you for pointing them out. On Wed, Dec 17, 2014 at 3:10 AM, Helmut Grohne hel...@subdivi.de wrote

Bug#773300: Improve glibc bootstrap

2015-05-10 Thread YunQiang Su
在 2015年5月2日,上午4:52,YunQiang Su wzss...@gmail.com 写道: On Thu, 18 Dec 2014 23:44:33 +0800 YunQiang Su wzss...@gmail.com wrote: Sorry, forgot to attach the new patch. On Thu, Dec 18, 2014 at 11:44 PM, YunQiang Su wzss...@gmail.com wrote: Thank you for pointing them out. On Wed, Dec 17

Bug#773300: Improve glibc bootstrap

2015-05-10 Thread YunQiang Su
, dh_shdeps will not look for in it. So when $(curpass) includes mips32, we pass an option to it. On Mon, May 11, 2015 at 6:49 AM, YunQiang Su wzss...@gmail.com wrote: 在 2015年5月2日,上午4:52,YunQiang Su wzss...@gmail.com 写道: On Thu, 18 Dec 2014 23:44:33 +0800 YunQiang Su wzss...@gmail.com wrote: Sorry

Bug#824985: glibc 2.22: add MIPS r6 support

2016-06-01 Thread YunQiang Su
On Tue, May 31, 2016 at 11:29 PM, Aurelien Jarno <aurel...@aurel32.net> wrote: > On 2016-05-23 11:09, YunQiang Su wrote: >> On Mon, May 23, 2016 at 2:59 AM, Aurelien Jarno <aurel...@aurel32.net> wrote: >> > control: merge 824985 824996 >> > thanks >>

Bug#827802: glibc/mips o32: please use the default march level for mips o32

2016-06-21 Thread YunQiang Su
to mips32r2. -- YunQiang Su diff --git a/debian/sysdeps/mips64el.mk b/debian/sysdeps/mips64el.mk index d6fffbe..b80230e 100644 --- a/debian/sysdeps/mips64el.mk +++ b/debian/sysdeps/mips64el.mk @@ -3,16 +3,14 @@ extra_cflags = -mno-plt # main library libc_rtlddir = /lib64 -libc_CC = $(CC) -march=mips3

Bug#827802: glibc/mips o32: please use the default march level for mips o32

2016-06-21 Thread YunQiang Su
On Tue, 21 Jun 2016 17:23:34 +0800 YunQiang Su <wzss...@gmail.com> wrote: > Package: src:glibc > > Since we have removed the 2f machines from Debian officially, > and gcc-5+ also support FPXX which can help to workaround > Loongson 3A bugs. > > And now we have some more

Bug#824985: glibc 2.22: add MIPS r6 support

2016-05-22 Thread YunQiang Su
On Mon, May 23, 2016 at 2:59 AM, Aurelien Jarno <aurel...@aurel32.net> wrote: > control: merge 824985 824996 > thanks > > On 2016-05-22 14:37, YunQiang Su wrote: >> Package: src:glibc >> Version: 2.22-9 >> >> Hi, I am working add MIPS r6 support for base

Bug#824996: glibc 2.23: add MIPS r6 support

2016-05-22 Thread YunQiang Su
Sorry, the above patch has some tiny problem about spaces mistake. I updated it. On Sun, May 22, 2016 at 5:14 PM, YunQiang Su <wzss...@gmail.com> wrote: > On Sun, 22 May 2016 16:57:39 +0800 YunQiang Su <wzss...@gmail.com> wrote: >> Package: src:glibc >> Version: 2.23-1

Bug#824985: glibc 2.22: add MIPS r6 support

2016-05-22 Thread YunQiang Su
Package: src:glibc Version: 2.22-9 Hi, I am working add MIPS r6 support for base toolchains. This is the patch for glibc (2.22 only) I am also working on 2.23 also, and will submit soon. -- YunQiang Su diff -urN glibc-2.22/debian/control glibc/debian/control --- glibc-2.22/debian/control

Bug#824996: glibc 2.23: add MIPS r6 support

2016-05-22 Thread YunQiang Su
Package: src:glibc Version: 2.23-1 Hi, I am working add MIPS r6 support for base toolchains. This is the patch for glibc (2.23 only) The patch for 2.22 was submit by bug: #824985 -- YunQiang Su

Bug#824996: glibc 2.23: add MIPS r6 support

2016-05-22 Thread YunQiang Su
On Sun, 22 May 2016 16:57:39 +0800 YunQiang Su <wzss...@gmail.com> wrote: > Package: src:glibc > Version: 2.23-1 > > Hi, I am working add MIPS r6 support for base toolchains. > This is the patch for glibc (2.23 only) > > The patch for 2.22 was submit by bug: #824

Bug#884774: glibc: add mips r6 architectures into the list of gcc-6-multilib dep

2017-12-19 Thread YunQiang Su
Package: src:glibc Version: 2.25-5 Since current mips r6 architectures are multilibed. Please add mipsr6 mipsr6el mipsn32r6 mipsn32r6el mips64r6 mips64r6el into the list of list of depending gcc-6-multilib. -- YunQiang Su

Bug#881457: glibc: please add mips r6 support

2017-11-11 Thread YunQiang Su
architectures. There are also 6 flavors: mipsr6 mipsr6el mipsn32r6 mipsn32r6el mips64r6 mips64r6el In this patch, I also include: symbol file for mipsn32/mipsn32el/mips64. -- YunQiang Su diff --git a/debian/control.in/mips32 b/debian/control.in/mips32 index 1d5008a..7831000 100644

Bug#881454: glibc: don't try build shared library packages when stage1

2017-11-11 Thread YunQiang Su
Package: src:glibc Version: 2.24-17 Since libc6/libc6.1 etc are marked as Build-Profiles: So we need to disabled them in DEB_ARCH_REGULAR_PACKAGES -- YunQiang Su diff --git a/debian/rules b/debian/rules index a7a6ed1..a18e268 100755 --- a/debian/rules +++ b/debian/rules

Bug#881455: glibc: don't build hardware enhancement library packages when stage1

2017-11-11 Thread YunQiang Su
Package: src:glibc Version: 2.24-17 hardware enhancement library packages like xen on i386/hurd-i386, and alphpaev67 on alpha, are not needed for stage1 They are also marked as Build-Profiles: So we need to remove them. -- YunQiang Su diff --git a/debian/sysdeps/alpha.mk b/debian/sysdeps

Bug#881646: don't build multilib library packages in stage1

2017-11-13 Thread YunQiang Su
Control: merge 881454 881646 On Mon, 13 Nov 2017 21:37:57 +0100 Matthias Klose wrote: > Package: src:glibc > Version: 2.24-17 > Severity: important > Tags: patch > > The recent debhelper changes expose a bug building stage1, because glibc build > the multilib library packages in

Bug#881147: glibc/debian/script.in/nohwcap.sh: alpha's libc is libc6.1 instead of libc6

2017-11-08 Thread YunQiang Su
Package: src:glibc Version: 2.24-17 In debian/script.in/nohwcap.sh, there is a line: hwcappkgs="libc6-alphaev67" But in fact the name of this package should be libc6.1-alphaev67. This mistake will lead this package to be built on stage1. -- YunQiang Su

Re: Arch qualification for buster: call for DSA, Security, toolchain concerns

2018-07-07 Thread YunQiang Su
l We are plan to drop mips(eb) and keep mipsel/mips64el. > * Other: ppc64el, s390x > > If the blocking issues cannot be resolved, affected architectures are at > risk of removal from testing before buster is frozen. > > We are currently unaware of any new architectures likely to be ready in > time for inclusion in buster. > > On behalf of the release team, > Niels Thykier > -- YunQiang Su

Bug#933513: glibc: mips{64,n32}r6{,el} ln wrong ld.so filename

2019-07-30 Thread YunQiang Su
/libc6-mips32/lib +ln -sf /libo32/ld-linux-mipsn8.so.1 debian/libc6-mips32/lib endef endif # multilib -- YunQiang Su