Re: Bug#948257: depmod: ERROR: ../libkmod/libkmod.c:515 lookup_builtin_file() could not open builtin file '/var/tmp/mkinitramfs_N1a1Mk/lib/modules/5.4.0-1-amd64/modules.builtin.bin'

2020-01-06 Thread Marco d'Itri
Control: severity -1 normal Control: tags -1 patch Control: reassign -1 initramfs-tools On Jan 06, crvi wrote: >* What outcome did you expect instead? > > Successful ramfs generation Do you have any reason to believe that the initrfamfs was not generated successfully? This is only

Bug#857790: sun4i_ss broken on Cubieboard (Allwinner A10)

2020-01-04 Thread Marco d'Itri
On Mar 15, Marco d'Itri wrote: > Package: src:linux > Version: 4.9.13-1 > Severity: normal > > Upgrading from 4.4.0-1 to 4.9.0-2 broke Kerberos security for NFS, at > least as a server. FYI, 4.19.0-5-armmp is still broken. -- ciao, Marco signature.asc Description: PGP signature

Bug#948041: impossible to update libbpf without updating the kernel

2020-01-03 Thread Marco d'Itri
On Jan 03, Sudip Mukherjee wrote: > Do we package libbpf from their github repo independent of the kernel > update? Then we will need to remove the libbpf building bits from the > Debian kernel source and create a separate package for libbpf. This is what some of the upstream libbpf developers

Re: Bug#925167: kmod: add softdep dwc3 to have GBit network on Odroid

2019-04-07 Thread Marco d'Itri
Control: reassign -1 src:linux Control: retitle -1 add a modules softdep to dwc3 to fix it on odroid On Mar 22, Jochen Sprickerhof wrote: > Not apart from that I was not aware of that option :). I've send a patch > upstream: > > https://marc.info/?l=linux-usb=155321315512949=2 > > and will

Bug#911023: memory leak in the backlight control of the dell-laptop module

2019-01-28 Thread Marco d'Itri
Control: close -1 4.19.16-1 On Oct 16, Gabriele Mazzotta wrote: > there are a couple of commits queued for 4.19 that fix some memory > leaks: https://patchwork.kernel.org/patch/10594683/ and > https://patchwork.kernel.org/patch/10594681/. Looking at the call > trace I'd say the first patch is

Bug#911023: memory leak in the backlight control of the dell-laptop module

2018-10-14 Thread Marco d'Itri
Package: src:linux Version: 4.18.10-2 Severity: normal Tags: upstream (I am Cc'in the maintainers of the dell-laptop module, accordingly to modinfo.) After running this for about 1H: while true; do echo 1 > /sys/devices/platform/dell-laptop/leds/dell::kbd_backlight/brightness sleep 0.25

Re: Sid: please fix dependences of nfs-common

2018-08-21 Thread Marco d'Itri
On Aug 20, Michael Stone wrote: > This should probably actually be in the rpcbind package rather than > nfs-common. Once upon a time, when rpcbind was still portmap, it was > actually part of netbase so a dependency was unnecessary. But rpcinfo is And after my slimming cure nowadays netbase is

Bug#894022: 4.15 kernels need CONFIG_DELL_SMBIOS_{WMI,SMM}

2018-03-25 Thread Marco d'Itri
Package: src:linux Version: 4.15.4-1 Severity: normal See this thread for details: https://www.spinics.net/lists/platform-driver-x86/msg15066.html . -- ciao, Marco signature.asc Description: PGP signature

Re: recommends for apparmor in newest linux-image-4.13

2017-11-28 Thread Marco d'Itri
On Nov 28, Christoph Hellwig wrote: > It's just a bad idea of a security model that implements ad-hoc > and mostly path based restrictions instead of an actually verified > security model. Using that by default makes it much harder to actually > use a real MAC based security model,

Bug#857790: sun4i_ss broken on Cubieboard (Allwinner A10)

2017-03-14 Thread Marco d'Itri
Package: src:linux Version: 4.9.13-1 Severity: normal Upgrading from 4.4.0-1 to 4.9.0-2 broke Kerberos security for NFS, at least as a server. kernel: CPU: ARMv7 Processor [413fc082] revision 2 (ARMv7), cr=10c5387d kernel: OF: fdt:Machine model: Cubietech Cubieboard Unless I blacklist the

Re: Bug#812928: udev: cdrom_id terminated by signal BUS

2016-01-27 Thread Marco d'Itri
Control: reassign -1 src:linux Control: found -1 4.3.0-1 Control: retitle -1 getauxval(AT_RANDOM) broken on sparc64 On Jan 27, Anatoly Pugachev wrote: > Program terminated with signal SIGUSR1, User defined signal 1. > #0 0x0101b9b8 in initialize_srand () at

Bug#652459: too little, too late?

2014-09-24 Thread Marco d'Itri
On Sep 25, Joey Hess jo...@debian.org wrote: My calendar says 10 days until freeze start. I sincerely hope someone does something. Would anybody mind if I just uploaded straight to unstable a new initramfs-tools package with no concern at all for the maintainer's unexpressed wishes? --

Bug#677475: Sun Fire X4140 with NVIDIA Corporation MCP55 Ethernet cards and bridge interface resets on boot

2014-08-27 Thread Marco d'Itri
subscribe 677475 found 3.2.54-2 found 3.14.15-2~bpo70+1 thanks I *do* have a few Sun Fire X4140 lying around, and I have been hit by this bug too. We do not use bridging, but eth0 and eth1 are slaved to the bonding driver. So far everything works fine, but if I connect eth2 while it is still

Bug#652459: Bug#697002: jessie: -R skips check of /etc and /usr in addition to /

2014-08-05 Thread Marco d'Itri
On Aug 05, Michael Biebl bi...@debian.org wrote: Agreed. The actual patch to mount /usr is rather small. The one for mounting /etc complicates things quite a bit. Please let's not entangle the two and just upload the bits for mounting /usr. If there is later demand for the /etc-mount feature,

Bug#652459: mounting /usr from initramfs

2014-08-05 Thread Marco d'Itri
-BEGIN PGP SIGNED MESSAGE- Hash: SHA256 On Aug 05, Klaus Ethgen kl...@ethgen.ch wrote: MU--: monolithic kernel, /usr is separate, / is mounted ro by the kernel (we currently try to support this but it is not reliable) But this situation is the one that is used out there at many

Bug#652459: initramfs-tools: [patch] Please support mounting of /usr in the initramfs

2014-07-21 Thread Marco d'Itri
Are there any news? Do you need help with this? -- ciao, Marco signature.asc Description: Digital signature

cpufreq-applet broken on Sandy Bridge systems

2014-01-19 Thread Marco d'Itri
Package: gnome-applets Version: 3.4.1-4 Severity: normal cpufreq-applet is unable to display the CPU speed on my system because the scaling_cur_freq file does not exist. See http://www.phoronix.com/scan.php?page=news_itempx=MTI5Mzc for details. cpufreq-info uses the cpuinfo_cur_freq file, but

Bug#652459: initramfs-tools: [patch] Please support mounting of /usr in the initramfs

2014-01-01 Thread Marco d'Itri
-BEGIN PGP SIGNED MESSAGE- Hash: SHA1 On Jan 01, Klaus Ethgen kl...@ethgen.de wrote: What is being discussed in this bug is not if /usr should be mounted in the initramfs or not. This is a widely accepted design. The purpose of this bug is to implement it in the best way. This will

Bug#723761: irq 16: nobody cared errors for the mptsas driver

2013-09-19 Thread Marco d'Itri
Package: src:linux Version: 3.2.46-1+deb7u1 Severity: normal This is an IBM x3250 server. At boot time I get: [7.160384] scsi2 : ioc0: LSISAS1064E B1, FwRev=0110h, Ports=1, MaxQ=511, IRQ=16 [7.184758] mptsas: ioc0: attaching sata device: fw_channel 0, fw_id 5, phy 0, sas_addr

Bug#711461: Recursive fault crash on resume

2013-08-30 Thread Marco d'Itri
On Jun 07, Marco d'Itri m...@linux.it wrote: Since about one year ago (while I was tracking the unstable kernels), my Dell Latitude E6400 from time to time crashes on resume. This appears to have been fixed in 3.10-1, since I reached one month of uptime. -- ciao, Marco signature.asc

Bug#707960: rpc.gssd segfaults when mounting a nfsv4 volume

2013-05-16 Thread Marco d'Itri
reopen 707960 found 1:1.2.8-2 thanks On May 12, Luk Claes l...@zomers.be wrote: Still broken. Does statd run? No changes with or without statd. Does installing nfs-kernel-server by any chance fix the bug? No changes with or without mountd and svcgssd. -- ciao, Marco signature.asc

Bug#707960: rpc.gssd segfaults when mounting a nfsv4 volume

2013-05-12 Thread Marco d'Itri
Package: nfs-common Version: 1:1.2.8-1 Severity: grave (elided):/ /media/nfs nfs4noauto,soft,intr,sec=krb5p 0 0 [2262594.734234] rpc.gssd[2729]: segfault at 1 ip f74714ba sp ff830170 error 4 in libgssglue.so.1.0.0[f746e000+8000] Reverting nfs-common to

Bug#707960: rpc.gssd segfaults when mounting a nfsv4 volume

2013-05-12 Thread Marco d'Itri
On May 12, Luk Claes l...@zomers.be wrote: Does statd run? No, because it is not needed for NFSv4. Does installing nfs-kernel-server by any chance fix the bug? I cannot test this right now, I will try in a few days. -- ciao, Marco signature.asc Description: Digital signature

Bug#706818: NFSv4.1 breaks suspend

2013-05-09 Thread Marco d'Itri
On May 05, Marco d'Itri m...@linux.it wrote: If I try to suspend my laptop when a NFSv4.1 file system is mounted then the processes freezer fails. It works fine with NFSv4.0. The same thing also happens with NFSv4.0 if some operation on a mounted file system is waiting because a ticket has

Re: Bug#706999: Writing ISO to USB results in an unkillable blkid process

2013-05-06 Thread Marco d'Itri
reassign 706999 linux-2.6 thanks On May 06, Christian Kastner deb...@kvr.at wrote: When attempting to write an ISO installer image to a USB stick, at some point there is an unkillable blkid process (state: uninterruptible sleep) and syslog gets spammed with the following message once every

Bug#706818: NFSv4.1 breaks suspend

2013-05-05 Thread Marco d'Itri
Package: linux-2.6 Version: 3.2.41-2 Severity: normal If I try to suspend my laptop when a NFSv4.1 file system is mounted then the processes freezer fails. It works fine with NFSv4.0. The file system is mounted with: noauto,soft,intr,minorversion=1,sec=krb5p This is 100% reproducible, the logs

Bug#697709: linux-image-3.2.0-4-amd64: pcspkr and snd-pcsp fighting

2013-01-19 Thread Marco d'Itri
On Jan 19, Ben Hutchings b...@decadent.org.uk wrote: I prefer option 2, since option 1 would make it difficult to switch the preferred driver in the linux package later. Anyone have any other Agreed. -- ciao, Marco signature.asc Description: Digital signature

Re: Bug#683972: modular nfs clients, Linux 3.6

2013-01-13 Thread Marco d'Itri
On Jan 12, Ben Hutchings b...@decadent.org.uk wrote: The module alias has been added in 3.2.29 and 2.6.32.60 (which will go into stable-proposed-updates soon). Shouldn't this change be made to kmod in wheezy so it's prepared for a kernel change in jessie? No objections on my part, I have a

Bug#686847: KVM guest slows down and finally hangs on I/O

2012-09-10 Thread Marco d'Itri
On Sep 06, Marco d'Itri m...@linux.it wrote: The system suddenly slows down and then all processes hang. The getty on the virtual console is responsive to input, but it hangs when it tries to fork+exec login. After installing the backported wheezy kernel I have found out that this is related

Bug#686847: KVM guest slows down and finally hangs on I/O

2012-09-06 Thread Marco d'Itri
Package: linux-2.6 Version: 2.6.32-45 Severity: normal Linux vm.cs16.seeweb.it 2.6.32-5-amd64 #1 SMP Sun May 6 04:00:17 UTC 2012 x86_64 GNU/Linux This is a fully up to date squeeze system running as a guest on a RHEL 6.2 host. 1 CPU, 1 GB of RAM, virtio net and disk (using XFS). We have

Re: Bug#673747: Please support the modules-load.d directories in /usr/local/lib and /usr/lib

2012-05-21 Thread Marco d'Itri
block 673747 by 652459 thanks On May 21, Josh Triplett j...@joshtriplett.org wrote: My code in bug 672960 read the same five directories. However, the code added to /etc/init.d/kmod does not look at /usr/local/lib/modules-load.d or /usr/lib/modules-load.d. Please consider including those as

Re: Bug#671859: udev: Udev hangs on boot for 120 seconds, times out then eats CPU failing to rename files

2012-05-21 Thread Marco d'Itri
reassign 671859 linux-2.6 thanks On May 21, eyck eyck.deb...@kuszelas.eu wrote: /lib/udev/path_id /devices/pci:00/:00:1d.0/usb2/2-1/2-1.3/2-1.3:1.0/block/uba /lib/udev/udisks-part-id /dev/uba Looks like this driver is broken. Kernel bug. -- ciao, Marco signature.asc Description:

Re: amd64 as default architecture

2012-05-20 Thread Marco d'Itri
On May 20, Ben Hutchings b...@decadent.org.uk wrote: No, keep i386 userland only. Though we might consider reducing even that to a 'partial architecture' that has only libraries (similar to ia32-libs today, only cleaner). Don't you believe in x32? -- ciao, Marco signature.asc Description:

Re: amd64 as default architecture

2012-05-20 Thread Marco d'Itri
On May 20, Ben Hutchings b...@decadent.org.uk wrote: No, keep i386 userland only. Though we might consider reducing even that to a 'partial architecture' that has only libraries (similar to ia32-libs today, only cleaner). Don't you believe in x32? What do you mean, 'believe'? I'm

Re: amd64 as default architecture

2012-05-19 Thread Marco d'Itri
On May 20, Ben Hutchings b...@decadent.org.uk wrote: Then in wheezy+1: 3. amd64 kernel flavour for i386 dropped. Why can't we use the multiarch package in wheezy? -- ciao, Marco signature.asc Description: Digital signature

Re: Bug#670480: udev: Boot hangs with discrete video card set in BIOS on ThinkPad W520

2012-04-25 Thread Marco d'Itri
reassign 670480 linux-2.6 thanks On Apr 26, Stephen Byrne deb...@sbyrne.org wrote: ThinkPad W520 with NVidia Quadro 1000M usually hangs on boot at waiting for dev to be fully populated when the discrete card is selected in the BIOS. When either the onboard card or NVidia Optimus is selected,

Re: Bug#668655: udev: USB device update are broken

2012-04-13 Thread Marco d'Itri
reassign 668655 linux-2.6 thanks On Apr 13, Sergiy Gorel's'kiy kt...@bigmir.net wrote: Card reader connected to the system constantly. Then i run: tail -f /vat/log/syslog udevadm --monitor And when i insert the sd-card, there was no reaction. Not my problem then. -- ciao, Marco

Re: Bug#663433: udev: does not load acpiphp on ThinkPad T520 although it is needed for ExpressCard hotplugging

2012-03-11 Thread Marco d'Itri
reassign 663433 linux-2.6 thanks On Mar 11, Martin Steigerwald mar...@lichtvoll.de wrote: I reported it upstream on kernel.org back then, but maybe it is more of a userspace, of a udev issue, cause when the module is loaded hot plugging of Express Cards does work as expected. The module does

Re: Bug#663433: udev: does not load acpiphp on ThinkPad T520 although it is needed for ExpressCard hotplugging

2012-03-11 Thread Marco d'Itri
On Mar 11, Martin Steigerwald mar...@lichtvoll.de wrote: So please advice. Is it sufficient for ask for module aliases being added upstream? If I know how I can provide the necessary info for my ThinkPad T520. I am not familiar with ExpressCard, so I do not know exactly what is needed. --

Re: Bug#662664: [libkmod2] Numerous, possibly spurious error message on update-initramfs

2012-03-05 Thread Marco d'Itri
reassign 662664 initramfs-tools thanks On Mar 05, David Baron d_ba...@012.net.il wrote: these:libkmod: ERROR ../libkmod/libkmod-config.c:713 conf_files_filter_out: Directories inside directories are not supported: /etc/modprobe.d/arch.conf Yes. Don't do this. Looks like you have some stale

Re: Bug#659866: Errors regarding builtin modules when updating initramfs

2012-02-14 Thread Marco d'Itri
reassign 659866 initramfs-tools thanks On Feb 14, Marco d'Itri m...@linux.it wrote: WARNING: could not open /tmp/mkinitramfs_PEoSkD/lib/modules/3.2.0-1-amd64/modules.builtin: No such file or directory This is a kernel bug, our kernel packages must start distributing this file. I stand

Re: Linux 3.2 in wheezy

2012-01-29 Thread Marco d'Itri
On Jan 29, Ben Hutchings b...@decadent.org.uk wrote: If there are particular container features that should be enabled or backported to provide a useful replacement for OpenVZ or VServer, please let us know. We cannot promise that these will all be enabled but we need to know what is

Re: Bug#657123: USB modem hotplugging no longer works.

2012-01-24 Thread Marco d'Itri
reassign 657123 linux-2.6 thanks Then recent kernels for some reason removed your VID/PID from usbserial. This is not related to udev. On Jan 24, dE . de.tec...@gmail.com wrote: On 01/24/12 16:44, Marco d'Itri wrote: On Jan 24, dE .de.tec...@gmail.com wrote: modprobe usbserial vendor

Bug#651199: iwlwifi: Connection lost on WPA: Group rekeying

2012-01-23 Thread Marco d'Itri
On Dec 16, Jonathan Nieder jrnie...@gmail.com wrote: There have been a few iwlwifi fixes upstream recently. Could you try[1] v3.2-rc5 or later? The bug is still present in 3.2. -- ciao, Marco signature.asc Description: Digital signature

Bug#652459: initramfs-tools: [patch] Please support mounting of /usr in the initramfs

2011-12-17 Thread Marco d'Itri
On Dec 17, Roger Leigh rle...@debian.org wrote: 1) Generation of /etc/fstab in the initramfs, including the rootfs and all the filesystems desired to be mounted This is highly suboptimal, because it suddenly makes the initramfs not generic anymore. The initramfs should: - mount / as usual -

Bug#651199: iwlwifi: Connection lost on WPA: Group rekeying

2011-12-15 Thread Marco d'Itri
This could be the same bug I am experiencing. Facts: - 3.1 has it, 3.0 does not - everything works fine while I am at home (WPA2 PSK) - my connections break very often when I am at work (WEP) - wpa_cli reassociate fixed the link - iw event -t does not log anything when the link breaks - I do not

Re: Increasing minimum 'i386' processor

2011-11-20 Thread Marco d'Itri
On Nov 19, Ben Hutchings b...@decadent.org.uk wrote: I think it is time to increase the minimum requirement to 586-class, if not for wheezy then immediately after. I agree, it's time to weight the costs and benefits of supporting obsolete hardware at the expense of most users. (Later it

Re: Bug#647825: udevd[XXX]: unable to receive ctrl connection: Function not implemented

2011-11-10 Thread Marco d'Itri
clone 647825 -1 block 647825 by -1 thanks On Nov 10, Émeric Maschino emeric.masch...@gmail.com wrote: Well, it seems that the problem isn't in fact that SOCK_CLOEXEC isn't implemented on ia64, but simply that sys_accept4() isn't implemented, right? Right. But I do not understand why nobody

Re: Bug#647825: udevd[XXX]: unable to receive ctrl connection: Function not implemented

2011-11-10 Thread Marco d'Itri
On Nov 10, Ben Hutchings b...@decadent.org.uk wrote: I would like to know from the kernel people which conflicts I need to add to the udev package. Don't bother; there's no reasonable way to write conflicts against kernel versions. We can backport sys_accept4 plumbing for ia64 to squeeze

Re: Bug#648386: Resolution of USB driver does not use EHCI (USB 2.0) after detecting it in Debian 6.0.2.1......

2011-11-10 Thread Marco d'Itri
reassign 648386 linux-2.6 thanks On Nov 11, yekta.gursel yekta.gur...@att.net wrote: Looks like a kernel issue. I have determined that the USB connection and USB storage drivers in Debian 6.0.2.1 with a USB 2.0 enabled, single chip, dual processor (3.0 GHz) motherboard (MSI MS-7108) with 2

Bug#579496: virtio_net loses outbound connectivity

2011-11-06 Thread Marco d'Itri
On Feb 24, Ben Hutchings b...@decadent.org.uk wrote: Please try the kernel package from squeeze with the addition of the attached patches. (These patches fix different bugs which can also cause virtio_net to stop passing traffic. They are not applicable to Linux 2.6.26.) I have not tested

Re: Bug#647011: update

2011-10-29 Thread Marco d'Itri
reassign 647011 linux-2.6 thanks On Oct 29, Christoph Keller keller.christop...@googlemail.com wrote: Then i switched back to tty1 and executed exec /sbin/init single - freeze Great, then this is not my problem. I suggest that you use udev.exec-delay and udev.children-max=1 as explained in

Bug#627594: access to SUBSYSTEM=power_supply sysfs nodes causes a remove/add/change events flood

2011-09-12 Thread Marco d'Itri
On Sep 12, Jonathan Nieder jrnie...@gmail.com wrote: Alas, I'm not able to reproduce it with v3.1-rc5. What kernel version do you use? Does this still happen? Could you attach output from the /usr/share/bug/$(uname -r)/script 31 command? I can still reproduce the bug with 3.0.0. If I do not

Re: Bug#641313: udev: blu-ray writer not detected - no /dev/sr0

2011-09-12 Thread Marco d'Itri
reassign 641313 linux-2.6 thanks On Sep 12, Gary Dale garyd...@eol.ca wrote: After the last kernel update I rebooted the computer. Now there is no /dev/sr0 listed for the blu-ray writer. Blame the kernel then. Kernel: Linux 2.6.32-5-686 (SMP w/1 CPU core) -- ciao, Marco signature.asc

Bug#639538: de4x5 is obsolete

2011-08-27 Thread Marco d'Itri
Package: linux-2.6 Severity: normal Md is there any reason to keep building the de4x5 driver, which has been blacklisted by default by udev since forever? trave11er i think it was relevant for alpha, there were two drivers claiming the same PCI IDs (de4x5 and tulip?) trave11er

Re: Bug#638887: udev: cdrom_id process can not be killed

2011-08-24 Thread Marco d'Itri
reassign 638887 linux-2.6 thanks On Aug 22, Jameson Graef Rollins jroll...@finestructure.net wrote: Occasionally I find a cdrom_id process stuck in the D (uninterruptible sleep) state that can not be killed. I'm not This is always a kernel bug. -- ciao, Marco signature.asc Description:

Re: Bug#638887: udev: cdrom_id process can not be killed

2011-08-24 Thread Marco d'Itri
On Aug 24, Jameson Graef Rollins jroll...@finestructure.net wrote: Hi, Marco. Can you explain why this is always a kernel bug? It's certainly not obvious to me. Thanks. Because processes are not supposed to get stuck in D state. -- ciao, Marco signature.asc Description: Digital signature

Re: Bug#628750: udev: takes too long to detect and configure mouse (steelseries XAI)

2011-06-01 Thread Marco d'Itri
reassign 628750 linux-2.6 thanks On Jun 01, Ismael ismael...@gmail.com wrote: Udev is taking around 15 secs to detect and configure my mouse. If you take a look at my bootchart, you see a big hole: http://i.imgur.com/whbA8.png . That udev is waiting for modprobe, which is waiting for the

Re: Bug#628782: udev: Does not start: waiting for /dev to be fully populated

2011-06-01 Thread Marco d'Itri
reassign 628782 linux-2.6 thanks On Jun 01, Erling Bahnsen erlin...@yahoo.dk wrote: When starting the computer it freezes completely and switches off screen, while often (but not always) the lights of the numlock, caps lock and scroll lock flashes. The last what have been written on the

Re: Linux 3.0

2011-05-30 Thread Marco d'Itri
On May 30, Ben Hutchings b...@decadent.org.uk wrote: There are likely to be many programs and build scripts that test for a kernel version prefix of '2.6' vs '2.4' and will behave incorrectly when they find '3.0'. Others require that there are at least 3 numeric Expect module-init-tools and

Bug#627594: access to SUBSYSTEM=power_supply sysfs nodes causes a remove/add/change events flood

2011-05-22 Thread Marco d'Itri
Package: linux-2.6 Severity: important This has been happening for a few months and makes upowerd unusable since the events flood make it use too much CPU and disk bandwidth. How to reproduce: Monitor the events with udevadm monitor --env --kernel and then access sysfs with a command like:

Re: Bug#624443: udev: Device files for usb satnav (Windows CE 5.0 fat filesystem) no longer created: perhaps kernel/module bug.

2011-05-02 Thread Marco d'Itri
reassign 624443 linux-2.6 thanks On Apr 28, ael law_ence@ntlworld.com wrote: Apr 28 13:54:11 precise kernel: [ 91.941826] scsi scan: INQUIRY result too short (5), using 36 --- Given the INQUIRY result too short

Bug#621803: Add support for /run directory

2011-04-26 Thread Marco d'Itri
On Apr 26, rleigh rle...@codelibre.net wrote: -mount -t tmpfs -o nodev,noexec,nosuid,mode=0755 none /run +mount -t tmpfs -o nosuid,size=20%,mode=0755 tmpfs /run Why does /run should not be noexec? I've added the block above because we can't make an upload of sysvinit/ initscripts to

Bug#621803: Add support for /run directory

2011-04-26 Thread Marco d'Itri
On Apr 26, rleigh rle...@codelibre.net wrote: Testing with initramfs-tools (maks/run) with current unstable shows udev appearing to work correctly with it using /dev/.udev when /run is not present on the host system. And also with /run present on Did you check with LVM and that all its

Re: Bug#607533: udev hangs at boot for 180 sec because of a C$R570 bios version

2011-04-19 Thread Marco d'Itri
reassign 607533 linux-2.6 thanks On Apr 04, marco ghidinelli marc...@linux.it wrote: as you guessed, i tried to start rcS services, and the system freezes when launching S03udev start. i attached below the output from 'ps faxw': the process sleeps waiting for something: /sbin/modprobe

Re: Bug#617511: udev didn't create new device node when plug a memory card

2011-04-03 Thread Marco d'Itri
(32-bit, non-prefetchable) [size=256] Capabilities: [80] Power Management version 2 Kernel driver in use: sdhci-pci On Mar 09, Viet Nguyen meta...@gmail.com wrote: Sorry but nothing printed, neither dmesg. Did i miss anything? On Wed, Mar 9, 2011 at 9:18 PM, Marco d'Itri m

Re: Bug#619549: [Pkg-acpi-devel] Bug#619549: thinkpad_acpi does not control fans

2011-03-25 Thread Marco d'Itri
reassign 619549 linux-2.6 thanks On Mar 25, Michael Meskes mes...@debian.org wrote: The PC would shutdown saying Critical temperature reached (128 C) when doing CPU intensive work. The fans were not turning on at all. The installer should create the file

Bug#615831: [PATCH] Load modules for USB keyboard if not keyboard is present at panic

2011-02-28 Thread Marco d'Itri
On Feb 28, maximilian attems m...@stro.at wrote: Md any feedback from your side? I have never seen a system where the BIOS does not provide a working USB keyboard, but I have no objections in principle. My only request is that the loading in panic() of *every* module is preceded by printing on

Bug#579496: virtio_net loses outbound connectivity

2011-02-23 Thread Marco d'Itri
On Apr 28, Marco d'Itri m...@linux.it wrote: On some of my systems, some time after boot (from about 1 to 8 days) the kernel stops emitting packets (?). Using tcpdump on eth0 on the guest I could see incoming ARP requests from the host but no answers. No errors have been logged by the kernel

Re: Bug#609747: udev: snd-powermac.ko not loaded automatically on iBook (first generation), resulting in no audio

2011-01-12 Thread Marco d'Itri
reassign 609747 linux-2.6 thanks On Jan 12, Daniel Kahn Gillmor d...@fifthhorseman.net wrote: Could udev have detected this and loaded the module automatically somehow? I saw the same behavior on an eMac recently as well. I can Maybe, as long as the kernel is fixed to provide the information

Bug#609747: udev: snd-powermac.ko not loaded automatically on iBook (first generation), resulting in no audio

2011-01-12 Thread Marco d'Itri
On Jan 12, Daniel Kahn Gillmor d...@fifthhorseman.net wrote: So that looks likely. I'll try to get a patched kernel built. Any recommendation on the best way to deviate least from the stock squeeze kernel while minimizing compile time? The powerpc machines i have access to for compilation

Bug#609747: udev: snd-powermac.ko not loaded automatically on iBook (first generation), resulting in no audio

2011-01-12 Thread Marco d'Itri
On Jan 12, Ben Hutchings b...@decadent.org.uk wrote: in the meantime, is there a simple way for me to check the existing openfirmware device IDs from userspace to ensure that the system actually uses one of the listed compatible devices? Sorry, I don't know how to do that. There must be

Bug#609747: udev: snd-powermac.ko not loaded automatically on iBook (first generation), resulting in no audio

2011-01-12 Thread Marco d'Itri
On Jan 12, Daniel Kahn Gillmor d...@fifthhorseman.net wrote: other suggestions on how to minimize compile time, ben? I meant using the self-compiled patched module with the kernel binary package corresponding to that source, this way the symbols should match. -- ciao, Marco signature.asc

Re: Bug#606895: udevd-work[358]: kernel-provided name 'uinput' and NAME= 'input/uinput' disagree

2010-12-12 Thread Marco d'Itri
reassign 606895 linux-2.6 thanks On Dec 12, Chris fisch@gmx.de wrote: udevd-work[358]: kernel-provided name 'uinput' and NAME= 'input/uinput' disagree, please use SYMLINK+= or change the kernel to provide the proper name The name is correct, the kernel name change should be backported.

Bug#606895: udevd-work[358]: kernel-provided name 'uinput' and NAME= 'input/uinput' disagree

2010-12-12 Thread Marco d'Itri
On Dec 12, Ben Hutchings b...@decadent.org.uk wrote: The name is correct, the kernel name change should be backported. Please explain (1) why udev knows better than the kernel what the canonical name is and The name has always been input/uinput, but in the last year udev deprecated changing

Bug#606895: udevd-work[358]: kernel-provided name 'uinput' and NAME= 'input/uinput' disagree

2010-12-12 Thread Marco d'Itri
reassign 606895 udev thanks On Dec 13, Ben Hutchings b...@decadent.org.uk wrote: Is this summary correct: 1. The kernel called this device 'uinput' for a long time. 2. There is a longstanding udev rule that renames it to 'input/uinput'. 3. udev has deprecated such renaming rules. 4. New

Re: Bug#604817: udev-acl: Start after hibernate cause kernel crash

2010-11-24 Thread Marco d'Itri
reassign 604817 linux-2.6 thanks On Nov 24, Michele Petrazzo michele.petra...@unipex.it wrote: If the kernel crashes, the kernel needs to be fixed. Nov 24 15:01:37 miclin kernel: [20933.428181] Process udev-acl.ck (pid: 19811, threadinfo 880075e94000, task 880029a63170) Nov 24

Re: Minutes of the Debian linux-2.6 Group Meeting

2010-11-11 Thread Marco d'Itri
On Nov 11, maximilian attems m...@stro.at wrote: waldi proposes to remove old untouched stuff like ax25 and atm. Remove from where? The ATM stack is needed to support USB DSL modems, and while the code is not beautiful I think it can be considered mature. The cost of it has not yet been

Re: persistent naming of network interfaces

2010-11-08 Thread Marco d'Itri
On Nov 07, Ben Hutchings b...@decadent.org.uk wrote: Is there any interest from the release team in supporting the biosdevname method in squeeze? [...] FWIW, it looks easy to add the new PCI device attributes to 2.6.32. This might be preferable to adding the biosdevname utility. Definitely

Re: Bug#594782: udev: Leads to black screen with omnibook XE-GF

2010-08-29 Thread Marco d'Itri
reassign 594782 linux-2.6 thanks On Aug 29, Aleksi .P ale...@ajp.dy.fi wrote: Kernel: Linux 2.6.32-5-686 (SMP w/1 CPU core) Everytime i boot my omnibook XE-GF laptop without acpi=off option in grub kernel section my laptops output to screen stops when udev runs and it shows black screen

Re: ppp-udeb depending on ppp-modules

2010-08-12 Thread Marco d'Itri
Can anybody comment on this? On Aug 06, md wrote: ppp-udeb/armel unsatisfiable Depends: ppp-modules ppp-udeb/s390 unsatisfiable Depends: ppp-modules http://release.debian.org/migration/testing.pl?package=ppp Please advise. ppp-udeb has been this way for a long time, does it need to be

ppp-udeb depending on ppp-modules

2010-08-06 Thread Marco d'Itri
ppp-udeb/armel unsatisfiable Depends: ppp-modules ppp-udeb/s390 unsatisfiable Depends: ppp-modules http://release.debian.org/migration/testing.pl?package=ppp Please advise. ppp-udeb has been this way for a long time, does it need to be changed due to kernel changes? -- ciao, Marco

Re: Bug#587065: udev breaks everything

2010-06-24 Thread Marco d'Itri
reassign 587065 linux-2.6 thanks On Jun 25, Jasen Betts ja...@xnet.co.nz wrote: running /etc/init.d/udev start (like is done by /etc/rcS/S04udev ) renders keyboard and video inoperable and halts the boot process (as far as I can tell - network never comes up, case power button does

Re: Bug#582903: udev eats 100%

2010-06-05 Thread Marco d'Itri
reassign 582903 linux-2.6 thanks On Jun 03, Greg KH g...@kroah.com wrote: This is a kernel bug, not a udev one. A kernel patch fixes this. -- ciao, Marco signature.asc Description: Digital signature

[PATCH #upstream-fixes] libata: disable ATAPI AN by default

2010-06-05 Thread Marco d'Itri
- Forwarded message from Tejun Heo t...@kernel.org - From: Tejun Heo t...@kernel.org To: Jeff Garzik j...@garzik.org, linux-...@vger.kernel.org linux-...@vger.kernel.org CC: Kay Sievers kay.siev...@vrfy.org, Nick Bowler nbow...@elliptictech.com, David Zeuthen

Bug#582481: [pkg-cryptsetup-devel] Bug#582481: initramfs-tools: System won't boot anymore if it was encrypted by debian squeeze setup

2010-05-25 Thread Marco d'Itri
On May 25, Jonas Meurer jo...@freesources.org wrote: in the former case you most probably spotted another bug (or misconfigured your system), in the latter case this bugreport should be reassigned to package dmsetup, where the respective udev rules need to be updated. The warning is harmless

Bug#582737: libata: disable ATAPI AN by default

2010-05-23 Thread Marco d'Itri
Package: linux-2.6 Tags: patch upstream Blocks: 581791 This should fix #581791. - Forwarded message from Tejun Heo t...@kernel.org - From: Tejun Heo t...@kernel.org To: Jeff Garzik j...@garzik.org, linux-...@vger.kernel.org linux-...@vger.kernel.org CC: Kay Sievers

Bug#582481: initramfs-tools: System won't boot anymore if it was encrypted by debian squeeze setup

2010-05-22 Thread Marco d'Itri
On May 21, maximilian attems m...@stro.at wrote: kernel-provided name 'dm-0' and NAME='/mapper/sda2_crypt' disagree, please use SYMLINK+= or change the kernel to provide the proper name This is just a warning and is not related to whatever problem you have. -- ciao, Marco signature.asc

Re: Bug#581715: acpi-fakekey: kernel-provided name 'uinput' and NAME= 'input/uinput' disagree

2010-05-18 Thread Marco d'Itri
reassign 581715 linux-2.6 thanks On May 15, Marco d'Itri m...@linux.it wrote: I'm not sure if this is a problem in acpi_fakekeyd or in udev; loading I'd say that the kernel should be fixed to hint input/uinput. Kay confirmed, the kernel should be changed to hint input!uinput instead of just

Bug#581952: please backport vhost_net

2010-05-17 Thread Marco d'Itri
Package: linux-2.6 Severity: wishlist Tags: patch We want this for squeeze because it greatly improve networking performances of KVM guest to almost native levels. The patch is fully self-contained, so hopefully it will be trivial to backport.

Bug#568755: please backport the macvtap driver

2010-05-17 Thread Marco d'Itri
On Feb 07, Marco d'Itri m...@linux.it wrote: (The patch is not yet upstream but it is expected to be merged as soon as the next merge window is opened. If you want to wait then the bug can serve as a reminder.) macvtap has been merged in 2.6.34: http://git.kernel.org/?p=linux/kernel/git

Bug#579496: virtio_net loses outbound connectivity

2010-04-28 Thread Marco d'Itri
On Apr 28, Vincent Danjean vincent.danj...@ens-lyon.org wrote: On some of my systems, some time after boot (from about 1 to 8 days) the kernel stops emitting packets (?). It is related to #576838 ? AFAIK no, because no errors are logged by the kernel. -- ciao, Marco signature.asc

Bug#579496: virtio_net loses outbound connectivity

2010-04-27 Thread Marco d'Itri
Package: linux-2.6 Version: 2.6.26-21lenny4 Severity: normal On some of my systems, some time after boot (from about 1 to 8 days) the kernel stops emitting packets (?). Using tcpdump on eth0 on the guest I could see incoming ARP requests from the host but no answers. No errors have been logged by

Bug#531785: tcp-wrappers support not working

2010-04-07 Thread Marco d'Itri
On Apr 05, Ben Hutchings b...@decadent.org.uk wrote: echo mountd statd portmap lockd: ALL /etc/hosts.deny # the second line is acually not needed, but shows that the problem is # not a wrong service name echo 32767: ALL /etc/hosts.deny telnet servername 32767 Port number 32767 is

Re: Bug#576724: udev: [drm:drm_fill_in_dev] *ERROR* Cannot initialize the agpgart module.

2010-04-06 Thread Marco d'Itri
reassign 576724 linux-2.6 thanks On Apr 06, Juan Ramon Chan mainjrc...@yahoo.com wrote: After some rebootings, i suddenly got this error. before not. [1.739777] Linux agpgart interface v0.103 [1.861458] [drm:drm_fill_in_dev] *ERROR* Cannot initialize the agpgart module. [

Re: Bug#574585: udev 151-3 does not load eata scsi driver, udev 151-2 does.

2010-03-31 Thread Marco d'Itri
reassign 574585 linux-2.6 thanks On Mar 31, Arthur Marsh arthur.ma...@internode.on.net wrote: I had tried several kernels including kernels that had previously worked with just an eata entry in /etc/modules without getting eata loading before it was needed to check and mount filesystems

Re: Bug#575648: Lots of udevd --daemon running 100% CPU all the time.

2010-03-27 Thread Marco d'Itri
reassign 575648 linux-2.6 forcemerge 572537 575648 thanks On Mar 27, leonardo.fava...@email.it wrote: Running htop I can see many udevd --daemon entries. Most of them are running 0.0% whilst the top two are runnin 90/100% of both cpus. If I stop the top two they restart and reach the 100%

Bug#575133: please backport ND_OPT_RDNSS support

2010-03-23 Thread Marco d'Itri
Package: linux-2.6 Severity: wishlist This patch allows autoconfiguration of the name server address on IPv6 networks without DHCPv6. http://kernel.linkfanel.net/rdnss-2.6.23.1.patch http://rdnssd.linkfanel.net/ -- ciao, Marco signature.asc Description: Digital signature

Re: PATA transition

2010-03-18 Thread Marco d'Itri
elen...@planet.nl wrote: I don't think the first would be a very good idea as it means that we'll still not be rid of the IDE drivers. It seems better to concentrate the Indeed. Please remember that udev has at least a couple of open bugs about things like persistent links breaking with the IDE

Re: Bug#574401: udevadm trigger crashes system

2010-03-17 Thread Marco d'Itri
reassign 574401 linux-2.6 thanks On Mar 17, Dave Williams d.r.williams...@cantab.net wrote: If 'udevadm trigger' is run once the system is booted and running normally it also crashes the system in the same manner (blank screen, hard reset required). Obviously a kernel bug. Kernel: Linux

  1   2   3   4   >