Bug#954778: Patch: Suppress irrelevant warning when generating a debian package

2020-03-29 Thread Reinhard Karcher
There was a blank line missing between the package definitions. Sorry for late testing. -- Best regards Reinhard Karcher from Reinhard.Karcher reinhard.karc...@gmx.net Creating a Debian package by compiling the kernel make bindeb-pkg without creating debug information creates a warning

Bug#954778: Patch: Suppress irrelevant warning when generating a debian package

2020-03-29 Thread Reinhard Karcher
Am Sonntag, 29. März 2020, 15:30 schrieb Masahiro Yamada: > > I want you to directly use > > if is_enabled CONFIG_DEBUG_INFO; then > ... > fi > Corrected patch attached -- Best regards Reinhard Karcher from Reinhard.Karcher reinhard.karc...@gmx.net Creating a Debian

Bug#954778: Patch: Suppress irrelevant warning when generating a debian package

2020-03-29 Thread Reinhard Karcher
always false, isn't it? > > It should be: > > if is_enabled CONFIG_DEBUG_INFO; then > The definition of BUILD_DEBUG is copied from builddeb too. See attached patch. -- Best regards Reinhard Karcher from Reinhard.Karcher reinhard.karc...@gmx.net Creating a Debian package by compiling the

Bug#954778: Patch: Suppress irrelevant warning when generating a debian package

2020-03-24 Thread Reinhard Karcher
a contribution to this project, I certify that: The contribution was created in whole or in part by me and I have the right to submit it under the open source license indicated in the file. Signed-off-by: Reinhard Karcher --- The condition to include the debug package is copied from the file builddeb

Bug#954778: linux-image-amd64: if using make bindeb-pkg there is a warning about the missing debug package

2020-03-23 Thread Reinhard Karcher
Package: linux-image-amd64 Version: 5.4.19-1 Severity: wishlist Tags: patch Dear Maintainer, * What led up to the situation? Compiling a new kernel from the source * What exactly did you do (or not do) that was effective (or ineffective)? make -j10 bindeb-pkg * What

Bug#934304: linux-image-5.2.0-2-amd64: powertop aborts on version 5.2

2019-08-09 Thread Reinhard Karcher
A selfcompiled kernel from git (version 5.3-rc3) does not show that error.

Bug#934304: linux-image-5.2.0-2-amd64: powertop aborts on version 5.2

2019-08-09 Thread Reinhard Karcher
As I rebooted the system after the abort, the abort is not seen in the log. Attached is the relevant part of the log on the system, where the abort happened. ReinhardAug 09 09:00:41 apollon kernel: BUG: kernel NULL pointer dereference, address: Aug 09 09:00:41 apollon kernel:

Bug#934304: linux-image-5.2.0-2-amd64: powertop aborts on version 5.2

2019-08-09 Thread Reinhard Karcher
Package: src:linux Version: 5.2.7-1 Severity: normal Dear Maintainer, starting with version 5.2.0-2, powertop aborts, version 4.19.0-5 is OK -- Package-specific info: ** Version: Linux version 5.2.0-2-amd64 (debian-kernel@lists.debian.org) (gcc version 8.3.0 (Debian 8.3.0-19)) #1 SMP Debian

Bug#924690: wlan broken with intel 6205

2019-03-16 Thread Reinhard Karcher
Using the new kernel 4.19.28-2 the WLAN is working again. Reinhard

Bug#914495: linux-image-4.18.0-3-amd64: does not boot here

2018-11-26 Thread Reinhard Karcher
I have got the same poblem lspci gives: 00:00.0 Host bridge: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub (rev 03) 00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (primary) (rev 03) 00:02.1 Display controller: Intel

Bug#897589: linux-image-4.17.0-rc3-amd64-unsigned: uvcvideo doesn't work, spams boot console

2018-07-06 Thread Reinhard Karcher
reopen -1 found 4.17.3-1 thanks

Bug#897589: 897589:linux-image-4.17.0-rc3-amd64-unsigned: uvcvideo doesn't work, spams boot console

2018-06-21 Thread Reinhard Karcher
Hi, I just compiled and tested 4.18.0-rc1 from kernel.org and the bug is there no longer. So we have to wait for 4.18.0 reaching Debian. Reinhard

Bug#897618: linux-image-4.17.0-rc3-amd64-unsigned: xrandr gives a black screen for some resolutions

2018-05-03 Thread Reinhard Karcher
Package: src:linux Version: 4.17~rc3-1~exp1 Severity: normal My laptop has a resolution of 1920x1080. xrandr -s 800x600 results in a black screen. Using KDE, I can leave the session by typing ctrl-alt-delete while the screen is black. A resolution of 1360x768 is working.

Bug#897589: linux-image-4.17.0-rc3-amd64-unsigned: uvcvideo doesn't work, spams boot console

2018-05-03 Thread Reinhard Karcher
Package: src:linux Version: 4.17~rc3-1~exp1 Severity: normal Dear Maintainer, * What led up to the situation? Booting linux-image-4.17.0-rc3-amd64-unsigned * What was the outcome of this action? Here are the lines from boot log relevant for UVC video : Mai 03 09:02:39 apollon kernel:

Bug#802464: Hyperthreaded cpu not enabled (smpboot: do_boot_cpu failed(-1) to wakeup CPU#1)

2015-10-23 Thread Reinhard Karcher
The bug is apparently solved upstream: fcafddec4e78a7776db4b6685db6b2902d4300fc x86/smpboot: Fix CPU #1 boot timeout Reinhard

Bug#802464: linux-image-4.3.0-rc5-amd64: Hyperthreaded cpu not enabled (Intel Core2) (smpboot: do_boot_cpu failed(-1) to wakeup CPU#1)

2015-10-20 Thread Reinhard Karcher
Package: src:linux Version: 4.3~rc5-1~exp1 Severity: normal Tags: upstream Dear Maintainer, * What led up to the situation? Booting the kernel I got the message on the console: smpboot: do_boot_cpu failed(-1) to wakeup CPU#1 * What exactly did you do (or not do) that was

Bug#780295: net bridge devices no longer brought up correctly

2015-03-12 Thread Reinhard Karcher
It's a problem with kmod, module-init-tools and libkmod2 version 20-1. Replacing these packages with version 18-3 removes that problem. Reinhard -- To UNSUBSCRIBE, email to debian-kernel-requ...@lists.debian.org with a subject of unsubscribe. Trouble? Contact listmas...@lists.debian.org

Bug#780295: net bridge devices no longer brought up correctly

2015-03-12 Thread Reinhard Karcher
It's a duplicate of bug 780255. Reinhard -- To UNSUBSCRIBE, email to debian-kernel-requ...@lists.debian.org with a subject of unsubscribe. Trouble? Contact listmas...@lists.debian.org Archive: https://lists.debian.org/4184457.PkU13AxYZP@apollon

Bug#780295: net bridge devices no longer brought up correctly

2015-03-12 Thread Reinhard Karcher
I don't think that to be kernel problem. Booting linux-image-3.16.0-4-amd64 showed the same problem. Putting tun into /etc/modules restored the old correct behavior. Reinhard -- To UNSUBSCRIBE, email to debian-kernel-requ...@lists.debian.org with a subject of unsubscribe. Trouble? Contact

Bug#762458: [src:linux] Please enable CONFIG_IP_NF_NAT

2014-09-22 Thread Reinhard Karcher
Package: src:linux Version: linux-image-3.17-rc5-amd64 Severity: normal Between linux version 3.16 and 3.17 the option CONFIG_NF_NAT_IPV4 changed the name to CONFIG_IP_NF_NAT. This option is not enabled in linux-image-3.17-rc5-amd64 Therefore I can't reach the internet from my KVM guest. Please

Bug#752878: lsinitramfs: fails to list contents with recent kernels

2014-06-27 Thread Reinhard Karcher
I have no problems listing /boot/initrd.img-3.14-1-amd64 using lsinitramfs 0.115. My system is nearly the same, with the exception of udev (204-12 from testing) and kernel (3.15-trunk-amd64 from experimental) Reinhard -- To UNSUBSCRIBE, email to debian-kernel-requ...@lists.debian.org with

Bug#721607: linux-image-3.11-rc7-amd64: suspend doesn't work

2013-09-13 Thread Reinhard Karcher
notfound -1 3.11-1~exp1 close -1 3.11-1~exp1 thanks -- To UNSUBSCRIBE, email to debian-kernel-requ...@lists.debian.org with a subject of unsubscribe. Trouble? Contact listmas...@lists.debian.org Archive: http://lists.debian.org/1561965.2zylWxBFOm@apollon

Bug#721607: linux-image-3.11-rc7-amd64: suspend doesn't work

2013-09-02 Thread Reinhard Karcher
Package: src:linux Version: 3.11~rc7-1~exp1 Severity: important Dear Maintainer, Trying to do pm-suspend causes the computer to hang, display is black, no response to any key, hard reset necessary. No information in logfiles found. Trying to to pm-hibernate returns after a few seconds without

Bug#664064: linux-image-3.3.0-rc6-amd64: 4 messages every minute in syslog from netlink

2012-03-18 Thread Reinhard Karcher
Am 18.03.2012 04:15, schrieb Ben Hutchings: OK, so it's something running in your KDE session. And the results you got from lsof suggest that it's some kind of network monitor that's hosted by kded4, using the ntrack library https://launchpad.net/ntrack. I've never heard of this before.

Bug#664064: linux-image-3.3.0-rc6-amd64: 4 messages every minute in syslog from netlink

2012-03-16 Thread Reinhard Karcher
Am 15.03.2012 18:14, schrieb Ben Hutchings: It would be useful if we could tell which program is sending the message, but I think that may be difficult to do. Some further investigation showed that the 1st occurrence of the message is related to the start of KDE. After stopping X (and KDE)

Bug#664064: netlink messages

2012-03-16 Thread Reinhard Karcher
It's not an effect of Debian specific changes, a kernel generated from latest kernel git shows the same messages. Reinhard -- To UNSUBSCRIBE, email to debian-kernel-requ...@lists.debian.org with a subject of unsubscribe. Trouble? Contact listmas...@lists.debian.org Archive:

Bug#664064: linux-image-3.3.0-rc6-amd64: 4 messages every minute in syslog from netlink

2012-03-15 Thread Reinhard Karcher
Package: linux-2.6 Version: 3.3~rc6-1~experimental.1 Severity: normal The kernel log says all! I have 2 laptops showing the messages, both amd64. One of them runs a 32-bit system in a VM with the linux-image-3.3.0-rc6-686-pae kernel, that does not have this problem. The amd64 kernel from

Bug#656668: 3.2 has different /sys/class/power

2012-01-20 Thread Reinhard Karcher
Do you use module-init-tools 4.0.3-1 from experimental? I get similar errors with that version. Reinhard -- To UNSUBSCRIBE, email to debian-kernel-requ...@lists.debian.org with a subject of unsubscribe. Trouble? Contact listmas...@lists.debian.org Archive:

Bug#656668: 3.2 has different /sys/class/power

2012-01-20 Thread Reinhard Karcher
Am 20.01.2012 21:51, schrieb Adam Heath: I use module-init-tools 3.16-1. No problems with that version and linux-image-3.2.0-1-amd64. I see both, the battery(CMB1) and the power-supply(AC). Reinhard -- To UNSUBSCRIBE, email to debian-kernel-requ...@lists.debian.org with a subject of

Bug#651382: linux-image-3.2.0-rc4-amd64: webcam stops working

2011-12-08 Thread Reinhard Karcher
Package: linux-2.6 Version: 3.2~rc4-1~experimental.1 Severity: normal Dear Maintainer, My webcam doesn't work any longer, neither vlc nor guvcview nor cheese can use it any longer. The error message from cheese: libv4l2: error turning on stream: Auf dem Gerät ist kein Speicherplatz mehr

Bug#651382: linux-image-3.2.0-rc4-amd64: webcam stops working

2011-12-08 Thread Reinhard Karcher
It's a kernel bug, that vanished with the latest git from kernel.org. The bugs exists in the 3.2-rc4 revision at git.kernel.org. Reinhard -- To UNSUBSCRIBE, email to debian-kernel-requ...@lists.debian.org with a subject of unsubscribe. Trouble? Contact listmas...@lists.debian.org Archive:

Bug#633078: initramfs-tools: lsinitramfs doesn't understand xy-compression

2011-07-08 Thread Reinhard Karcher
Package: initramfs-tools Version: 0.99 Severity: normal lsinitramfs can only list initrds compressed by gzip, but mkinitramfs can use an other compression option. From initramfs.conf: # COMPRESS: [ gzip | bzip2 | lzma | lzop | xz ] If I use e.g. xy-compression lsinitramfs can't list the initrd.

Bug#624135: linux-image-2.6.39-rc4-amd64: Moduls for intel wlan legacy missing

2011-04-25 Thread Reinhard Karcher
Package: linux-2.6 Version: 2.6.39~rc4-1~experimental.1 Severity: normal The support for older Intel wlan cards (3945 and 4965) was removed from the iwlagn module and new modules iw-legacy, iwl3945 and iwl4965 where created. These modules are not present in the packages. Please enable the

Bug#624135: Acknowledgement (linux-image-2.6.39-rc4-amd64: Moduls for intel wlan legacy missing)

2011-04-25 Thread Reinhard Karcher
A diff between the original .config file and the one, that produces the modules: --- .config.old 2011-04-25 01:20:00.0 +0200 +++ .config 2011-04-25 22:28:04.0 +0200 @@ -1,7 +1,7 @@ # # Automatically generated make config: don't edit -# Linux/x86 2.6.39-rc4 Kernel

Bug#558237: linux-source-2.6.32: X with xserver-xorg-video-intel does not work any longer

2009-12-08 Thread Reinhard Karcher
Status update for kernel-image-2.6.32-trunk-amd64: things improved a little bit. Console switching is now possible, but in X only a black screen is visible, with the exception of the mouse cursor, which is visible and moves as it should. The following message vanished from Xorg.0.log with the

Bug#558237: linux-source-2.6.32: X with xserver-xorg-video-intel does not work any longer

2009-12-08 Thread Reinhard Karcher
reported upstrem 25510 bugs.freedesktop.org Reinhard -- To UNSUBSCRIBE, email to debian-kernel-requ...@lists.debian.org with a subject of unsubscribe. Trouble? Contact listmas...@lists.debian.org

Bug#558237: linux-source-2.6.32: X with xserver-xorg-video-intel does not work any longer

2009-11-27 Thread Reinhard Karcher
Package: linux-source-2.6.32 Version: 2.6.32~rc8-1~experimental.1 Severity: important X doesn't work, but doesn't abort; system is unusable. The following message is printed on the console that started X: .../../../libdrm/intel/intel_bufmgr_gem.c:825: Error setting to CPU domain 96:

Bug#558237: linux-source-2.6.32: X with xserver-xorg-video-intel does not work any longer

2009-11-27 Thread Reinhard Karcher
Am Freitag 27 November 2009 11:53:08 schrieb Uwe Kleine-König: My system still works with xserver-xorg-video-intel 2:2.9.0-1 on 2.6.32~rc8-1~experimental.1. Best regards Uwe My versions of libdrm: libdrm2: Installiert: 2.4.15-1 Kandidat: 2.4.15-1 Versions-Tabelle: *** 2.4.15-1 0

Bug#558237: linux-source-2.6.32: X with xserver-xorg-video-intel does not work any longer

2009-11-27 Thread Reinhard Karcher
Am Freitag 27 November 2009 12:49:23 schrieb Reinhard Karcher: Am Freitag 27 November 2009 11:53:08 schrieb Uwe Kleine-König: My system still works with xserver-xorg-video-intel 2:2.9.0-1 on 2.6.32~rc8-1~experimental.1. Best regards Uwe My versions of libdrm: libdrm2