fbpdf license doubt

2015-01-07 Thread Dmitry Bogatov
for the same purpose, and fbdjvu uses djvulibre library for rendering djvu files. -- Best regards, Dmitry Bogatov kact...@gnu.org, Free Software supporter, esperantisto and netiquette guardian. GPG: 54B7F00D -- To UNSUBSCRIBE, email to debian-mentors-requ...@lists.debian.org with a subject

btpd torrent client lost in history

2015-03-01 Thread Dmitry Bogatov
debianization repository? [Please, keep in CC.] -- Best regards, Dmitry Bogatov kact...@gnu.org, Free Software supporter, esperantisto and netiquette guardian. GPG: 54B7F00D pgpgC5zCCxYvM.pgp Description: PGP signature

Bug#784732: RFS: liquidprompt/1.9-1 [ITP]

2015-05-13 Thread Dmitry Bogatov
Non-DD review. I propose to remove override, since `liquidprompt` never executed, only sources. Consider applying attached patch. -- Best regards, Dmitry Bogatov kact...@gnu.org, Free Software supporter, esperantisto and netiquette guardian. GPG: 54B7F00D diff -r -U 7 -N liquidprompt-1.9

Closing superseeded RFP

2015-05-15 Thread Dmitry Bogatov
Hello! Scrolling RFP requests, I found #461915, lockrun, which is superseeded by `cronutils`. Can I somehow make this fact availiable, for #461915 not clutter list? Should I? -- Best regards, Dmitry Bogatov kact...@gnu.org, Free Software supporter, esperantisto and netiquette guardian. GPG

RFS Complexity -- tool for measuring C program complexity

2015-04-15 Thread Dmitry Bogatov
Hello, dear mentors! Please, review following RFS: #781952. For some reason RFS did not hit `debian-mentors`, altho I sent it twice. Maybe it will have luck this time? -- Best regards, Dmitry Bogatov kact...@gnu.org, Free Software supporter, esperantisto and netiquette guardian. GPG: 54B7F00D

Re: Building a Debian package - is it normal to require that the package itself be installed?

2015-04-16 Thread Dmitry Bogatov
), buildd) and you can't assume access to anywhere other than root of source package. Seems you will have to patch build system. See quilt(1). -- Best regards, Dmitry Bogatov kact...@gnu.org, Free Software supporter, esperantisto and netiquette guardian. GPG: 54B7F00D pgpXWj6DAWhTI.pgp

Bug#781952: RFS:complexity/1.2-1 [ITP] -- tool for analyzing the complexity of C program functions

2015-06-24 Thread Dmitry Bogatov
Thanks for review. Please, review again and compare with my vision what is done. As this is on my TODO list for check-all-the-things, I'm willing to review and sponsor. In exchange for the upload, I will require a patch for check-all-the-things to support complexity. Okay, I will make the

Bug#781952: RFS:complexity/1.2-1 [ITP] -- tool for analyzing the complexity of C program functions

2015-11-11 Thread Dmitry Bogatov
* Gianfranco Costamagna [2015-11-04 17:38:33+] > Hi, according to [1] [2] [3] FDL with the "no invariant" section is not > considered DFSG. Well, I moved complexity-doc into 'non-free/doc' (!) section. Lintian complains, that I build free and non-free

Re: Bug#781952: RFS:complexity/1.2-1 [ITP] -- tool for analyzing the complexity of C program functions

2015-11-12 Thread Dmitry Bogatov
On 2015-11-11, Jakub Wilk <jw...@debian.org> wrote: > * Peter Pentchev <r...@ringlet.net>, 2015-11-11, 11:28: >>On Wed, Nov 11, 2015 at 11:45:10AM +0300, Dmitry Bogatov wrote: >>>Well, I moved complexity-doc into 'non-free/doc' (!) section. >>> >>>L

Bug#781952: RFS:complexity/1.2-1 [ITP] -- tool for analyzing the complexity of C program functions

2015-11-03 Thread Dmitry Bogatov
* Gianfranco Costamagna [2015-10-12 12:38:29+0200] > Hi Dmitry, > > please check the copyrights carefully. > > e.g. some documentation files are released under FDL license (some 1.2 > and some others 1.3) Upstram maintainer was kind to apply patches and release

Bug#781952: RFS:complexity/1.2-1 [ITP] -- tool for analyzing the complexity of C program functions

2015-10-05 Thread Dmitry Bogatov
I keep getting 500 from mentors, so would you be so kind to take from /srv/home/users/kaction-guest/public_git/complexity.git? > > I would suggest using https in all the debian/copyright URLs. I fixed, but duck(1) complains about gnutls error. No idea, w3m opens just fine these urls. > > gcc

Re: Bug#781952: RFS:complexity/1.2-1 [ITP] -- tool for analyzing the complexity of C program functions

2015-11-18 Thread Dmitry Bogatov
* Gianfranco Costamagna [2015-11-18 13:41:45+] > Hi, > > >E: complexity source: section-area-mismatch Package complexity-doc > > > So how can we proceed with this one? > Move to non-free, remove the file and repack? > > I don't think overriding the

Re: How to determine when being packaged under Debian?

2015-09-30 Thread Dmitry Bogatov
> We try to minimize external dependencies (even a package maintainer is > a dependency in the process). So we were hoping/looking for something > like (its a C++ library): > > #if defined(PACKAGE_BUILD) && !defined(CRYPTOPP_INIT_PRIORITY) > # pragma message "It is recommended you define

Bug#781952: RFS:complexity/1.2-1 [ITP] -- tool for analyzing the complexity of C program functions

2015-10-02 Thread Dmitry Bogatov
* Paul Wise [2015-10-02 18:16:57+0200] > > does this package have any showstopper to you? > > The only ones I know of are the ones I mentioned in my initial review, > which Dmitry says he has fixed. > > If you want to check on those and upload, go ahead :) Just in case, I am

Re: Bug#781952: RFS:complexity/1.2-1 [ITP] -- tool for analyzing the complexity of C program functions

2015-12-07 Thread Dmitry Bogatov
* Paul Wise <p...@debian.org> [2015-12-07 14:04:57+0800] > On Mon, Dec 7, 2015 at 12:52 PM, Dmitry Bogatov wrote: > > * Gianfranco Costamagna [2015-11-18 17:37:28+] > >> Hi, sure > >> thanks! > > > > Can you please git-clone > > > > gi

Re: Bug#781952: RFS:complexity/1.2-1 [ITP] -- tool for analyzing the complexity of C program functions

2015-12-06 Thread Dmitry Bogatov
* Gianfranco Costamagna [2015-11-18 17:37:28+] > Hi, sure > thanks! Can you please git-clone git://anonscm.debian.org/users/kaction-guest/complexity.git git://anonscm.debian.org/users/kaction-guest/complexity-doc.git Both contains only debian/ and seems that

Re: Bug#781952: RFS:complexity/1.2-1 [ITP] -- tool for analyzing the complexity of C program functions

2015-12-07 Thread Dmitry Bogatov
> >I remember, there was another mail, stating opposite opinion. As far as > >I know, GNU Make documentation lacks of invariant sections, but it is > >still in non-free. But, > > > >Paul, if you are sure that keeping everything in main is okay and > >willing to sponsor, I will gladly revert. > >

Re: Bug#781952: RFS:complexity/1.2-1 [ITP] -- tool for analyzing the complexity of C program functions

2015-12-16 Thread Dmitry Bogatov
* Gianfranco Costamagna [2015-12-16 12:38:28+] > Pong! > > Cloning your git repo hasn't been an easy task :) Sorry for it. If I will still expirience problems with mentors.debian, I would provide shell snippet. > Built, thanks for your contribution to

Re: Bug#781952: RFS:complexity/1.2-1 [ITP] -- tool for analyzing the complexity of C program functions

2015-12-15 Thread Dmitry Bogatov
* Dmitry Bogatov <kact...@gnu.org> [2015-12-07 23:03:23+0300] > > >I remember, there was another mail, stating opposite opinion. As far as > > >I know, GNU Make documentation lacks of invariant sections, but it is > > >still in non-free. But, > > &g

Bug#809272: RFS: pygithub/1.26.0-1 ITP

2016-01-05 Thread Dmitry Bogatov
> This package is quite cool already, just two bits: > > * Vcs-* points to github, which 404 (same as the other, I guess) Yes. Fixed > * please consider handing a spellchecked to upstream, looks like there > are some typos Fix spelling in comments or disabled and not-installed tests? Are you

Bug#809272: RFS: pygithub/1.26.0-1 ITP

2016-01-05 Thread Dmitry Bogatov
* Mattia Rizzolo <mat...@debian.org> [2016-01-05 16:34:13+] > On Tue, Jan 05, 2016 at 06:51:01PM +0300, Dmitry Bogatov wrote: > > > * please consider handing a spellchecked to upstream, looks like there > > > are some typos > > > > Fix spelling in

Bug#826266: RFS: dvtm/0.15-1~bpo8+1 ITP

2016-06-03 Thread Dmitry Bogatov
> >http://mentors.debian.net/debian/pool/main/d/dvtm/dvtm_0.15-1~bpo8+1.dsc > 404 Sorry. Should work now. -- Accept: text/plain, text/x-diff Accept-Language: eo,en,ru X-Keep-In-CC: yes X-Web-Site: sinsekvu.github.io

Bug#826266: RFS: dvtm/0.15-1~bpo8+1 ITP

2016-06-03 Thread Dmitry Bogatov
http://www.brain-dump.org/projects/dvtm Changes since last upload: * Rebuild for jessie-backports. Regards, Dmitry Bogatov

Importing ubuntu package

2016-06-09 Thread Dmitry Bogatov
Hello! What is common practice about adopting ubuntu packages? I want to adopt ubuntu `btpd' package, but it already have it's changelog. I think it would be impolite to just discard it. What is recommended way to follow Debian policy and still make a credit to previous maintainer? -- Accept:

Bug#822856: Another try for dvtm?

2016-05-25 Thread Dmitry Bogatov
> Hi Dmitry, due to the partial orphaning of the package in #824284, > are you interested in this package, and starting to maintain it properly? Last version is on mentors. I think it is okay to upload, the only thing I am not sure is about close-multiple-bug syntax. -- Accept: text/plain,

Bug#827043: RFS: gdbm/1.12-1 ITP

2016-06-11 Thread Dmitry Bogatov
> I am not a DD and thus cannot sponsor your package, but here are a few > remarks. Thank you for review. > Your debian/changelog file is actually missing the entry of the last > upload (1.8.3-14), please incorporate it. That version already included > a few of your changes, plus there is a

Bug#827043: RFS: gdbm/1.12-1 ITP

2016-06-11 Thread Dmitry Bogatov
in debian/control Regards, Dmitry Bogatov

Bug#827090: RFS: runit/2.1.2-4 ITP

2016-06-11 Thread Dmitry Bogatov
ntation with doc-base (Policy 9.10) * Move communication files under /run to work with read-only /etc * Move getty runscripts into separate binary package * Emulalate sysv runlevel 5 by default. Regards, Dmitry Bogatov

Bug#827089: RFS: dh-runit/0.1 ITP

2016-06-11 Thread Dmitry Bogatov
Package: sponsorship-requests Severity: wishlist Dear mentors, I am looking for a sponsor for my package "dh-runit" * Package name: dh-runit Version : 0.1 Upstream Author : Dmitry Bogatov <kact...@gnu.org> * Url : https://anonscm.debian.org/cgit/use

Bug#827089: RFS: dh-runit/0.1 ITP

2016-06-13 Thread Dmitry Bogatov
> while I did some work on runit package a while ago, I'm not sure about > how you want the packages to use your new shiny dh call? > how do you plan to notify them about it? > do you plan to open a lot of bugs for packages exposing a runit script? First of all, runit supports (as policy

Bug#827090: RFS: runit/2.1.2-4 ITP

2016-06-13 Thread Dmitry Bogatov
> + * New maintainer > did Gerrit asked for help? > stepping in as maintainer needs an RFH or Orphan package. > (well, Gerrit was fine on giving up some packages IIRC) Gerrit gave up fgetty (which I picked up), so I think he will be okay with this. But explicit is better then implicit. >

dh_install globbing

2016-05-30 Thread Dmitry Bogatov
Hello! I want dh_install to install according following globbing: src/doc/*[a-z].html /usr/share/doc/runit/html (There is also html pages in form foo.1.html, which duplicate man pages. I do not want to install them.) But it does not work -- nothing is installed. dh_install(1) does not

Bug#825509: RFS: cdist/4.0.0-2 ITP

2016-05-27 Thread Dmitry Bogatov
about cdist can be obtained from http://www.nico.schottelius.org/software/cdist/ Changes since last upload: * patches/ensure-reproducible-build.patch: ensure deterministic file processing order. Thanks to Chris Lamb <ch...@chris-lamb.co.uk>. (Closes: #825406) Regards, Dmitry Bogatov

Bug#822856: Another try for dvtm?

2016-05-26 Thread Dmitry Bogatov
> Hi, still missing a build-dependency on libncurses5-dev > > the package just FTBFS > http://debomatic-amd64.debian.net/distribution#unstable/dvtm/0.15-1/buildlog > If it is ok for you I can add it, sign and upload. Yes, proceed, please. My bad. Some time ago I installed ghc into blessed image,

Re: Helping maintain debian packages

2016-06-01 Thread Dmitry Bogatov
> I have created a debian package > https://packagecloud.io/waghanza/plunder/packages/debian/jessie/phantomjs_2.1.1_amd64.deb Phantomjs is good. But as I remember it, that upstream release contains some bundled library, and do not support linking with system one. About documentation, apt-get

Re: dh_install globbing

2016-05-31 Thread Dmitry Bogatov
> * Dmitry Bogatov <kact...@gnu.org>, 2016-05-31, 13:15: > > $ git clone -b demonstrate > > https://anonscm.debian.org/cgit/users/kaction-guest/runit.git/ > > > >Glob in 'runit.install'. Try to build package, and notice, that no html > >files installed

Re: dh_install globbing

2016-05-31 Thread Dmitry Bogatov
> * Dmitry Bogatov <kact...@gnu.org>, 2016-05-30, 18:27: > >I want dh_install to install according following globbing: > > > > src/doc/*[a-z].html /usr/share/doc/runit/html > > > >(There is also html pages in form foo.1.html, which duplicate man=20

Re: dh_install globbing

2016-05-31 Thread Dmitry Bogatov
> >I upgraded dh-exec from jessie to sid, and it started to work. > > This is probably #801516. > > Anyway, if replaced "${RUNIT}" with "runit-*" in the *.install file, you > wouldn't need dh-exec at all. In some cases I need renaming feature, but thank you for advice. -- Accept: text/plain,

Bug#825509: RFS: cdist/4.0.0-2 ITP

2016-05-27 Thread Dmitry Bogatov
> the rationale is: > what you have on git is different from what is in unstable. > > I had to change UNRELEASED to unstable > and to change the timestamp of the -1 version > https://anonscm.debian.org/cgit/users/kaction-guest/cdist.git/commit/?id=3D= > 3527e379aad6e7d2621652b308676e000e7f866b >

Bug#827907: RFS: evil/1.2.12-1 ITP

2016-06-22 Thread Dmitry Bogatov
ined from https://bitbucket.org/lyro/evil/wiki/Home Changes since last upload: * Initial release. (Closes: #827897) Regards, Dmitry Bogatov

Bug#827913: RFS: goto-chg/1.6-1 ITP

2016-06-22 Thread Dmitry Bogatov
to-chg.git More information about goto-chg can be obtained from https://www.emacswiki.org/emacs/goto-chg.el Changes since last upload: * Initial release. (Closes: #827910) Regards, Dmitry Bogatov

Bug#827090: RFS: runit/2.1.2-4 ITP

2016-06-16 Thread Dmitry Bogatov
> On Mon, Jun 13, 2016 at 10:18:04PM +0300, Dmitry Bogatov wrote: > > > + * New maintainer > > > did Gerrit asked for help? > > > stepping in as maintainer needs an RFH or Orphan package. > > > (well, Gerrit was fine on giving up some packages IIRC) > &

Bug#827685: RFS: elpa-undo-tree/0.6.4-1 ITP

2016-06-21 Thread Dmitry Bogatov
> > > 2. Is there some reason you packaged version 0.6.4? 0.6.6 is > > > available. > >=20 > > $ git tag | grep 0.6.6 > > [empty] > Hmm, nevermind, not sure where I thought I'd found 0.6.8. There is Version: 0.6.6 header in elisp file in upstream master. But there is no corresponding tag. I

Bug#827685: RFS: elpa-undo-tree/0.6.4-1 ITP

2016-06-19 Thread Dmitry Bogatov
/pkg-emacsen/pkg/paredit-el.git More information about elpa-undo-tree can be obtained from http://www.dr-qubit.org/git/undo-tree.git Changes since last upload: * Initial release. (Closes: #827679) Regards, Dmitry Bogatov

Bug#827090: RFS: runit/2.1.2-4 ITP

2016-06-19 Thread Dmitry Bogatov
> I've been there, done that. Many years ago, if interested search > history for the runit-init package. Today I don't think runit is the > right choice for integrating as init system into Debian. Would you be so kind to be more verbose/provide link? What is wrong for runit provide init? >

Re: Proposing patch for packages, affected by transition

2016-06-23 Thread Dmitry Bogatov
> >Okay. But if they apply this patch right now, package will not build > >aganist unstable. Is it okay? > just mention that in the bug report, this will allow me/you to NMU when the > transition starts Okay. > >FAIL camldbm_1.0-2.dsc -- patch ready > >FAIL courier_0.73.1-1.6.dsc > >

Re: Proposing patch for packages, affected by transition

2016-06-23 Thread Dmitry Bogatov
> >Recently, I took over gdbm package and got new version into > >experimental. Now I work on fixing reverse dependencies FTBFS. > > > >Given I have patch for one of rdependency (camldbm, namely). What now? > >Should I ask maintainer to apply it and make upload into experimental? > >Or something

Proposing patch for packages, affected by transition

2016-06-23 Thread Dmitry Bogatov
Hello! Recently, I took over gdbm package and got new version into experimental. Now I work on fixing reverse dependencies FTBFS. Given I have patch for one of rdependency (camldbm, namely). What now? Should I ask maintainer to apply it and make upload into experimental? Or something else? --

Bug#827913: RFS: goto-chg/1.6-1 ITP

2016-06-23 Thread Dmitry Bogatov
> 1. The long description is not grammatical English. I appreciate you're >not a native speaker, so I fixed it for you in the team git >repository. Thanks. > 2. I noticed with all of your packages that I reviewed that there is no >trailing newline at the end of your files. My

Bug#827685: RFS: elpa-undo-tree/0.6.4-1 ITP

2016-06-20 Thread Dmitry Bogatov
> 1. The /source/ package name should actually be undo-tree not >elpa-undo-tree (team convention to use upstream's name). Probably >not worth changing now, but you should be aware of this for packaging >other addons (you mentioned you wanted to package evil). Ok. In self-protection

Bug#827765: RFS: gdbm/1.12-2 ITP

2016-06-20 Thread Dmitry Bogatov
from http://directory.fsf.org/project/gdbm/ Changes since last upload: * Install localization into libgdbm4 binary package * Install info manual into libgdbm-dev binary package * Separate dbm and ndbm compat layer into separate package Regards, Dmitry Bogatov

Bug#827913: RFS: goto-chg/1.6-1 ITP

2016-06-23 Thread Dmitry Bogatov
> Enjoy: > > ;; require a buffer to have a final newline > (setq require-final-newline 'visit-save) Nice. Thanks. > > > 3. Any particular reason you are using gz and not xz compression in > > > gbp.conf? Also, it might be a good idea to check the tarball into > > > git with

Bug#828029: RFS: surf/0.7-2~bpo8+1

2016-06-23 Thread Dmitry Bogatov
b-maint/surf.git More information about surf can be obtained from http://surf.suckless.org Changes since last upload: * Rebuild for jessie-backports. Regards, Dmitry Bogatov

Bug#828030: RFS: gdbm/1.12-3

2016-06-23 Thread Dmitry Bogatov
to gnu.org Regards, Dmitry Bogatov

Bug#827913: RFS: goto-chg/1.6-1 ITP

2016-06-23 Thread Dmitry Bogatov
[moved discussion to debian-emacsen. Please, keep me in cc if you want me to reply] > > No idea why, but dh-make-elpa (seems to violate debhelper naming > > convention) > It does? My bad. debhelper claims dh_* namespace. But I would find just make-elpa more intuitive. > > Adding note about xz

Bug#827907: RFS: evil/1.2.12-1 ITP

2016-06-27 Thread Dmitry Bogatov
1. How about using the source package name "emacs-evil"? I've been doing this for my packages where upstream's name is a very generic word (e.g. emacs-buttercup), but maybe evil is a significant enough package that it can just be "evil", I'm not sure. Your judgement. Renamed as

Bug#827907: RFS: evil/1.2.12-1 ITP

2016-06-27 Thread Dmitry Bogatov
> The function `evil-mode' doesn't seem to be properly autoloaded. > I.e. if I install elpa-evil-mode and then I open Emacs and type M-x, > evil-mode is not available. However, if I type M-x describe-function > RET evil-mode RET it works. Something is going wrong with the > autoloading. I

Bug#827907: RFS: evil/1.2.12-1 ITP

2016-06-28 Thread Dmitry Bogatov
> * Dmitry Bogatov <kact...@gnu.org>, 2016-06-27, 17:32: > >Mercurial upstream repository, and tarballs are named not after > >version, but after hashes. I fail to extract anything useful from this > >page: [1] > > > >[1] https://bitbucket.org/lyro/evil

Bug#828030: RFS: gdbm/1.12-3

2016-06-24 Thread Dmitry Bogatov
> On 2016-06-24 00:19 -0400, Dmitry Bogatov wrote: > > > I am looking for a sponsor for my package "gdbm" > > > > Changes since last upload: > > > > * Separate translation files (/usr/share/locale/*) into new binary > > package 'libgdbm

Bug#828030: RFS: gdbm/1.12-3

2016-06-27 Thread Dmitry Bogatov
> The changes in debian/control look good to me, but your changelog says > you added Breaks when it's actually Replaces. > > There is one change in 1.8.3-14 which you have not incorporated, namely > making libgdbm-dev "Multi-Arch: same". Please check whether the files > outside of /usr/lib are

Re: Bug#781952: RFS:complexity/1.2-1 [ITP] -- tool for analyzing the complexity of C program functions

2016-02-07 Thread Dmitry Bogatov
Hi! Complexity hit testing. Would you be so kind to upload this version (just one more changelog entry) to jessie-backports? Since complexity depends on libopts25, version from testing can't directly be installed on stable.

RFS: eoconv/1.4-1 ITP

2016-02-07 Thread Dmitry Bogatov
about eoconv can be obtained from http://en.nothingisreal.com/wiki/Eoconv Changes since last upload: * Initial release (Closes: #809817) Regards, Dmitry Bogatov

Bug#815799: RFS: kateperlcheck/1.7-1 [put in ITP ]

2016-02-24 Thread Dmitry Bogatov
I am no DD, so I would not be able to sponsor. But here is review: > Dear mentors, > > I am looking for a sponsor for my package "kateperlcheck" > > * Package name: kateperlcheck >Version : 1.7-1 >Upstream Author : dirk Lindner > * URL :

Bug#816004: RFS: [ITP] python-nameparser/0.3.11-1

2016-02-26 Thread Dmitry Bogatov
[2016-02-26 15:34] Edward Betts > > Package: sponsorship-requests > Severity: wishlist > > Dear mentors, > > I am looking for a sponsor for my package "python-nameparser" > > * Package name: python-nameparser >Version : 0.3.11 >Upstream Author : Derek

Re: Bug#781952: RFS:complexity/1.2-1 [ITP] -- tool for analyzing the complexity of C program functions

2016-01-23 Thread Dmitry Bogatov
There was some time without movement. I fixed my access to mentors, here is: http://mentors.debian.net/debian/pool/main/c/complexity/complexity_1.3+dfsg-1.dsc I fixed copyright issues (I believe) and some other minor stuff. Lintian is absolutely happy. Would you be so kind to upload it? --

Re: Bug#781952: RFS:complexity/1.2-1 [ITP] -- tool for analyzing the complexity of C program functions

2016-01-23 Thread Dmitry Bogatov
> >http://mentors.debian.net/debian/pool/main/c/complexity/complexity_1.3+dfsg-1.dsc > > > >I fixed copyright issues (I believe) and some other minor > >stuff. Lintian is absolutely happy. Would you be so kind to upload it? > the package is already on new queue (1.3+dfsg-1 and 1.3+dfsg-2) do you

Bug#816433: RFS: complexity/1.5+dfsg-1 ITP

2016-03-01 Thread Dmitry Bogatov
(Closes: #816244) * Standards version bump -- 3.9.7 (No changes needed) Regards, Dmitry Bogatov

[RFS] eoconv -- convert text files between various Esperanto encodings

2016-02-29 Thread Dmitry Bogatov
ion about eoconv can be obtained from http://en.nothingisreal.com/wiki/Eoconv Changes since last upload: * Initial release (Closes: #809817) Regards, Dmitry Bogatov -- Accept: text/plain, text/x-diff Accept-Language: eo,en,ru X-Keep-In-CC: yes X-Web-Site: sinsekvu.github.io

RFS: fgetty/0.7-0.1 [NMU] -- very small, efficient, console-only getty

2016-02-29 Thread Dmitry Bogatov
overrides about static build and lack of dependencies * Write manpage for login1 and login2 * New standards version -- 3.9.7 (No changes needed) Regards, Dmitry Bogatov

Bug#816363: RFS: fgetty/0.7-0.1 [NMU] -- very small, efficient, console-only getty

2016-03-14 Thread Dmitry Bogatov
> 1) I see you dropped patches, but they aren't applied upstream. > fgetty-login.diff > ro-dev.diff I knew what I did, but feel free to disagree with my reasoning. fgetty-login.diff essentially just renames /bin/login1 to /bin/fgetty-login. I find it confusing, when binaries are renamed. Either

Bug#817213: RFS: fgetty/0.7-1 ITP

2016-03-08 Thread Dmitry Bogatov
assword with gnu libc (Closes: #563335) with hardening * Add lintian overrides about static build and lack of dependencies * Write manpage for login1 and login2 * New standards version -- 3.9.7 (No changes needed) Regards, Dmitry Bogatov

Bug#820348: RFS: fgetty/0.7-1~bpo8+1 ITP

2016-04-07 Thread Dmitry Bogatov
about fgetty can be obtained from https://www.fefe.de/fgetty Changes since last upload: * Rebuild for jessie-backports. Regards, Dmitry Bogatov

Bug#820234: RFS: cligh/0.2-4 ITP

2016-04-06 Thread Dmitry Bogatov
about cligh can be obtained from http://the-brannons.com/software/cligh.html Changes since last upload: * Change section from python to vcs (Closes: #811127) * Bump standards version (no changes needed) * Change insecure git:// uri in Vcs-Git field to secure https:// * Check GPG signature R

Bug#820234: RFS: cligh/0.2-4 ITP

2016-04-07 Thread Dmitry Bogatov
> >Vcs-Browser: > >https://anonscm.debian.org/cgit/users/kaction-guest/complexity.git > >Vcs-Git: https://anonscm.debian.org/cgit/users/kaction-guest/complexity.git > please note: std-version is 3.9.8 now. Fixed. New version on mentors. -- Accept: text/plain, text/x-diff Accept-Language:

Re: Packaging mmh (fork of nmh)

2016-04-11 Thread Dmitry Bogatov
> >So, it is okay to use alternatives to manage /usr/bin/mh symlink (I > >will need your cooperation, Jakub) > I think you're confusing me with someone else... Sorry again. With your statement about nmh content I thought, that you are nmh maintainer. > >, but what about manpages? > > >

Packaging mmh (fork of nmh)

2016-04-09 Thread Dmitry Bogatov
[CC nmh maintainer] Hello! I am packaging mmh (http://marmaro.de/prog/mmh), which is fork of nmh. Both of them are mail user agents. nmh installs it's binaries (~20) into /usr/bin/nmh. Now I try to do the same, and install mmh's binaries into /usr/bin/mmh, but Lintian complain about FHS

Re: Packaging mmh (fork of nmh)

2016-04-11 Thread Dmitry Bogatov
[2016-04-10 17:15] Jakub Wilk > > * Wookey , 2016-04-10, 15:49: > >>nmh installs it's binaries (~20) into /usr/bin/nmh. > > Actually it installs to /usr/bin/mh, ... Sorry, my memory served me bad. > >Are nmh and mmh intended to be co-installable? I

Bug#814064: [RFS] eoconv -- convert text files between various Esperanto encodings

2016-04-06 Thread Dmitry Bogatov
> >Too fast. I improved d/rules and installed THANKS file. New revision > >in on mentors. I do not expect new release anytime soon, so probably > >it worth reject previous version and upload new one. Sad to bother > >FTP-masters. > I asked that on irc a few seconds ago :) > >Sorry for

Bug#820203: RFS: cdist/4.0.0~pre3-2 ITP

2016-04-06 Thread Dmitry Bogatov
pload: * Bump standards version to 3.9.7 (no changes needed) * Do not hardcode python version dependency (Closes: #802784) * Replace insecure git:// uri in Vcs-Git field with secure https:// * Fix spelling errors in manpages Regards, Dmitry Bogatov

Bug#816363: RFS: fgetty/0.7-0.1 [NMU] -- very small, efficient, console-only getty

2016-03-19 Thread Dmitry Bogatov
Uploaded new version on mentors. > >I knew what I did, but feel free to disagree with my reasoning. > > > >fgetty-login.diff essentially just renames /bin/login1 to /bin/fgetty-login. > >are never invoked directly, so I considered installing them into /lib/fgetty. > >It would eliminate need in

Bug#817118: RFS: complexity/1.5+dfsg-1~bpo8+1 ITP

2016-03-08 Thread Dmitry Bogatov
s package debian/ directory via git from URL: git://anonscm.debian.org/users/kaction-guest/complexity.git More information about complexity can be obtained from https://gnu.org/software/complexity Changes since last upload: * Rebuild for jessie-backports. Regards, Dmitry Bogatov

Bug#816919: RFS: newsbeuter/2.9-1 [ITA]

2016-03-08 Thread Dmitry Bogatov
[2016-03-06 19:48] Nikos Tsipinakis > Package: sponsorship-requests > Severity: normal > > Dear mentors, > > I am looking for a sponsor for my package "newsbeuter" > > * Package name: newsbeuter > Version : 2.9-1 > Upstream Author : Andreas Krennmair

Packaging fork

2016-03-01 Thread Dmitry Bogatov
Hello! I am interested in packaging [mmh](

Re: Bug#816363: RFS: fgetty/0.7-0.1 [NMU] -- very small, efficient, console-only getty

2016-03-01 Thread Dmitry Bogatov
-up > correctly. In this particular case you also risked a double email, > since debian-mentors receive bugs against sponsorship-request. > And you mistyped the pseudo-package name, missing the trailing s. Sorry about it. > On Tue, Mar 01, 2016 at 02:51:51AM -0500, Dmitry Bogatov wrote: > >

Bug#814064: [RFS] eoconv -- convert text files between various Esperanto encodings

2016-04-05 Thread Dmitry Bogatov
> control: > std-version is 3.9.7 Fixed. > rules: no upstream makefile is sad. > makedocs? not run? Forgot it. Fixed. New version on mentors. What do you think about NEWS, AUTHORS and THANKS? I doubt NEWS is of any use, AUTHORS is mirrored in d/copyright, but I think it would be fair for

Bug#822856: RFS: dvtm/0.15-0.1 NMU

2016-04-28 Thread Dmitry Bogatov
y available command for fifo scripting Regards, Dmitry Bogatov

Bug#822856: RFS: dvtm/0.15-0.1 NMU

2016-04-28 Thread Dmitry Bogatov
> > * Bump debhelper compat level (9 -> 10), > Compat level 10 is an experimental feature. NMUs is not a place to make > experiments. > > > * Convert debian/changelog into DEP-5 format > > ITYM debian/copyright, but this is not appropriate for an NMU either. Will fix it. > > * Bump standards

cdist: TeX in sid

2016-05-21 Thread Dmitry Bogatov
Hello! When building cdist-4.0.0, I encountered listed error with sbuild. Seems it is issues with TeX, not with my package. Any suggestions? How read this '/tmp/fmtutils.C8RsuPiw' file, for example? Processing triggers for tex-common (6.05) ... Running updmap-sys. This may take

Bug#821907: RFS: fbless/0.2.3-1 ITP

2016-05-16 Thread Dmitry Bogatov
> > > Please rename README to README.ru, preferably upstream. > >=20 > > dh_install'ed > >=20 > > > Please consider using hyphenation data from hyphen-* packages. > >=20 > > dh_linktree'ed > >=20 > > Please, review once more. > Please build this in a clean sid chroot. > > dpkg-query: no path found

Bug#821907: RFS: fbless/0.2.3-1 ITP

2016-05-14 Thread Dmitry Bogatov
> Please rename README to README.ru, preferably upstream. dh_install'ed > Please consider using hyphenation data from hyphen-* packages. dh_linktree'ed Please, review once more.

Bug#824411: RFS: stterm/0.6-0.1 NMU

2016-05-15 Thread Dmitry Bogatov
tained from http://st.suckless.org Changes since last upload: * Non-maintainer upload. * New upstream upload (Closes: #820376) * Update debian/watch * Refresh patches Regards, Dmitry Bogatov

Bug#823292: RFS: dh-haskell/0.2 ITP

2016-05-03 Thread Dmitry Bogatov
Package: sponsorship-requests Severity: wishlist Dear mentors, I am looking for a sponsor for my package "dh-haskell" * Package name: dh-haskell Version : 0.2 Upstream Author : Dmitry Bogatov <kact...@gnu.org> * Url : https://anonscm.debian.org/cg

Bug#822856: RFS: dvtm/0.15-0.1 NMU

2016-05-03 Thread Dmitry Bogatov
> >Is it imperative to revert it? > if you want a speedy NMU yes, if you want to wait some months no, we can let > MIA team ping the maintainer, and then take over the package. It already waited for almost year. I think we are not in a hurry. So I would rather wait for MIA. -- Accept:

Bug#822856: RFS: dvtm/0.15-0.1 NMU

2016-05-02 Thread Dmitry Bogatov
> >I do not want to put a pressure on anyone, but if it is the only way > >to make big changes to package, let's do it. > I could understand that, but > 1) lets avoid experimental features > 2) lets try to keep changes minimal. Okay, I can agree that compat 10 is unnecessery. But still someone

Bug#821907: RFS: fbless/0.2.3-1 ITP

2016-04-20 Thread Dmitry Bogatov
ined from https://github.com/matimatik/fbless Changes since last upload: * Initial release (Closes: #821903) Regards, Dmitry Bogatov

Bug#820938: RFS: complexity/1.9+dfsg-1 ITP

2016-04-13 Thread Dmitry Bogatov
ps:// in Vcs-Git field Regards, Dmitry Bogatov

Bug#825230: RFS: cdist/4.0.0-1

2016-05-24 Thread Dmitry Bogatov
o changes needed) Regards, Dmitry Bogatov

libgdbm transition

2016-07-12 Thread Dmitry Bogatov
lue. +Author: Dmitry Bogatov <kact...@gnu.org> +Last-Update: 2016-06-23 +--- +This patch header follows DEP-3: http://dep.debian.net/deps/dep3/ +--- a/configure b/configure +@@ -35,7 +35,7 @@ hasgot() { + ${CC:-cc} -I$1 -o hasgot.exe hasgot.c $3 $4 + res=$? + rm -f hasgot.c hasgot.exe +

Re: Dealing with "duplicate-font-file" lintian warning

2016-07-22 Thread Dmitry Bogatov
> I'm updating the "grip" package (bug #832000[1]), which resulted in > the following lintian warning: > > W: grip: duplicate-font-file > usr/share/grip/grip/static/octicons/octicons.ttf also in > fonts-octicons > > Is there a helper to deal with this kind of issue? Like the > "sphinxdoc"[2] one,

Re: hardening Issue

2016-07-27 Thread Dmitry Bogatov
> I'm adopting package lostirc with problems to solve hardening issue. > > The package builds ok but with lintian: > I: lostirc: hardening-no-fortify-functions usr/bin/lostirc Can't reproduce it. The only warning I have is P: lostirc source: debian-watch-may-check-gpg-signature Other

  1   2   3   >