Re: more recent version with python3 support

2016-07-13 Thread Herbert Fortes
Hi Gianfranco, > TLTR, Tiago seems to be *completely* correct here, you didn't state the > package name, > so you might want to try to grasp a solution before reading this email. > > But *please* read it eventually, because the Python3 package is probably > broken > > > > I have packaged a

Re: more recent version with python3 support

2016-07-12 Thread Herbert Fortes
Hi people, I am doing a QA (do not need a sponsor) and packaging a more recent version of the app. This new version has support for python3, as said in setup.py, so I created debian/*.install files and edited debian/control and debian/rules. cat debian/rules: #!/usr/bin/make -f %: dh

Re: more recent version with python3 support

2016-07-14 Thread Herbert Fortes
> > I have some nitpicks :) > "usign" <-- typo > > "python" "python3" should be used with upper case "P" > > I did a debdiff between unstable and mentors, and I see many print that > aren't Python3 ready > > (not really sure if and when are used in the code) > -... print 'somefile', 'is

Re: more recent version with python3 support

2016-07-14 Thread Herbert Fortes
Hi, > BTW I see it in deferred/1, but you didn't push on git... :) > if you want to do it, I can see the changes (not that I'm a powerful > Python man, but I like to learn from other folks ;) ) > Good. I just did the upload to mentors: https://mentors.debian.net/package/django-notification

same upstream version but different orig.tar.gz

2016-08-02 Thread Herbert Fortes
Hi, I am packaging a new version of webcamoid. This new version has some files with Ms-LPL license(nonfree). First I removed libAvKys/Plugins/VirtualCamera/ directory. Generated a new .symbols file and uploaded to experimental. Then I tested the software. It did not run. An email to the

Re: same upstream version but different orig.tar.gz

2016-08-03 Thread Herbert Fortes
Hi, > > You can work around this locally by rewriting your .changes files; the > changestool utility in the reprepro packages can help with that.  But > you won't be able to upload different files with the same name.  The > usual solution is adding a numeric part to the version after +dfsg, like

Re: same upstream version but different orig.tar.gz

2016-08-03 Thread Herbert Fortes
Hi Ferenc Wágner, > > > You can work around this locally by rewriting your .changes files; the > > > changestool utility in the reprepro packages can help with that.  But > > > you won't be able to upload different files with the same name.  The > > > usual solution is adding a numeric part to

Re: reproducible-builds

2016-07-18 Thread Herbert Fortes
Em Seg, 2016-07-18 às 20:28 +0800, Paul Wise escreveu: > On Mon, Jul 18, 2016 at 8:18 PM, Herbert Fortes wrote: > > > I did a QA and reproducible-builds says that > > it FTBFS with armhf on 2016-07-09. The > > build was not tried again. > > Which package ? dvbac

reproducible-builds

2016-07-18 Thread Herbert Fortes
Hi, I did a QA and reproducible-builds says that it FTBFS with armhf on 2016-07-09. The build was not tried again. I did a build with harris (ssh) and the build ran fine. I can do something about the status of the  package on reproducible-builds ? Or just wait for a new try by them ?

Re: reproducible-builds

2016-07-19 Thread Herbert Fortes
Hi, > Something failed somewhere in the second build, not in the package build > itself but rather in the building script and was not properly detected > as an infrastructure error (but rather as a FTBFS). > I triggered another build of the package and not it has built > successfully. Thanks for

Re: reproducible-builds

2016-07-19 Thread Herbert Fortes
Em Ter, 2016-07-19 às 12:42 +, Mattia Rizzolo escreveu: > On Tue, Jul 19, 2016 at 09:38:44AM -0300, Herbert Fortes wrote: > > I do not have a special interest in the package. Just > > a QA to do. I also did a repository (collab-maint) for > > it. > > You coul

Re: /usr/share/pyshared dir

2016-07-16 Thread Herbert Fortes
Em Sáb, 2016-07-16 às 21:24 +0500, Andrey Rahmatullin escreveu: > On Sat, Jul 16, 2016 at 01:05:47PM -0300, Herbert Fortes wrote: > > The package in Sid[0] has a /usr/share/pyshared > > directory that will not be present if > > you build (withour changes) the package today, 

/usr/share/pyshared dir

2016-07-16 Thread Herbert Fortes
Hi, I am doing a QA for python-extractor. The package in Sid[0] has a /usr/share/pyshared directory that will not be present if you build (withour changes) the package today,  my sid chroot env at least. But it is reproducible[1]. [0] - 

Re: more recent version with python3 support

2016-07-13 Thread Herbert Fortes
Hi Tiago, > On 12 July 2016 at 16:46, Herbert Fortes <h...@ig.com.br> wrote: > > This new version has support for python3, as > > said in setup.py, so I created debian/*.install > > files and edited debian/control and debian/rules. > > What are the contents of

QA for dvbackup

2016-07-05 Thread Herbert Fortes
Hi, I do not think this a practice, but telling that I will do a QA for dvbackup[0]. [0] - https://packages.qa.debian.org/d/dvbackup.html regards, -- Herbert Parentes Fortes Neto (hpfn) signature.asc Description: This is a digitally signed message part

wrong version number ?

2016-07-07 Thread Herbert Fortes
Hi, I am doing a QA for dvbackup package. I do not need a Sponsor. debian/changelog: dvbackup (1:0.0.4-8) unstable; urgency=low ( I am doing ) dvbackup (1:0.0.4-7) unstable; urgency=low ( current version ) After 'debuild': dvbackup_0.0.4-8_amd64.deb ( no epoch ) $ apt-get download dvbackup

Re: wrong version number ?

2016-07-07 Thread Herbert Fortes
Em Qui, 2016-07-07 às 18:38 +, Gianfranco Costamagna escreveu: > Hi > > debian/changelog: > > > dvbackup (1:0.0.4-8) unstable; urgency=low ( I am doing ) > > dvbackup (1:0.0.4-7) unstable; urgency=low ( current version ) > > > > After 'debuild': > > > > > sure, it has an epoch since a lot

Re: wrong version number ?

2016-07-07 Thread Herbert Fortes
Em Qui, 2016-07-07 às 18:38 +, Gianfranco Costamagna escreveu: > Hi > > debian/changelog: > > > dvbackup (1:0.0.4-8) unstable; urgency=low ( I am doing ) > > dvbackup (1:0.0.4-7) unstable; urgency=low ( current version ) > > > > After 'debuild': > > > > > sure, it has an epoch since a lot

Re: wrong version number ?

2016-07-07 Thread Herbert Fortes
Em Qui, 2016-07-07 às 17:05 -0300, Herbert Fortes escreveu: > Em Qui, 2016-07-07 às 20:01 +, Gianfranco Costamagna escreveu: > > Hi, > > > > > I'm not entirely sure, but it's been like this since forever. > > > > I guess a filename containing ":

update .preinst file

2016-09-13 Thread Herbert Fortes
Hi, I have to update 4 debian/*.preinst files. Right now the files are like here[0]: | if dpkg --compare-versions "$2" lt "1.2.4+dfsg1-7" ; then rm -rf /usr/share/doc/bogofilter || true fi [0] - https://anonscm.debian.org/git/collab-maint/bogofilter.git/tree/debian/bogofilter.preinst

Re: update .preinst file

2016-09-14 Thread Herbert Fortes
Hi, > Due to the way dpkg-maintscript-helper is implemented, the symlink > created with dh_installdocs is ignored, so dpkg-maintscript-helper will > create it for you. The manpage for dpkg-maintscript-helper also contains > an explanation of why 'just removing the directory in preinst' can cause

remove a git repository

2016-11-14 Thread Herbert Fortes
Hi, I did a mess on gthumb repository and I tried to fix it. What I want to do is a kind of roll back because I jumped one Debian revision. Right now the 'Tag' section is ok and if you click on 'Branch' links everything seems ok too. But the process to fix the mess was not 100% correct as

Re: remove a git repository

2016-11-14 Thread Herbert Fortes
On 14-11-2016 11:26, Sean Whitton wrote: > Hello Herbert, > > On Mon, Nov 14, 2016 at 10:32:28AM -0200, Herbert Fortes wrote: >> I did a mess on gthumb repository and I tried to >> fix it. What I want to do is a kind of roll back >> because I jumped one Debian revi

Re: remove a git repository

2016-11-14 Thread Herbert Fortes
On 14-11-2016 17:45, Sean Whitton wrote: Hello Herbert, On Mon, Nov 14, 2016 at 04:05:42PM -0200, Herbert Fortes wrote: I can not edit .git/config that's the problem. I tried. I think because I am using a guest account. I doubt it is this. Who owns the repo? You could just ask them to do

gthumb fails to build on all architectures

2017-08-01 Thread Herbert Fortes
Hi, I uploaded version 3:3.5.1-3 of gThumb Debian package an something went wrong. The main problem seems to be[0] (amd64 - Mon, 31 Jul 2017): Found cached translation database Merging translations into gthumb-import.desktop. Traceback (most recent call last): File "/usr/bin/glib-mkenums",

Re: gthumb fails to build on all architectures

2017-08-02 Thread Herbert Fortes
On 02-08-2017 04:22, Andrey Rahmatullin wrote: > On Tue, Aug 01, 2017 at 09:03:05PM -0300, Herbert Fortes wrote: >> The main problem seems to be[0] (amd64 - Mon, 31 Jul 2017): >> >> Found cached translation database >> Merging translations into gthumb-import.desktop. >

Bug#875693: RFS: python-meshio/1.8.16-1

2017-09-14 Thread Herbert Fortes
Hi Ghislain Vaillant, > Package: sponsorship-requests > Severity: normal > > Dear mentors, > > I am looking for a sponsor for the following package: > > * Package name    : python-meshio >   Version : 1.8.16-1 >   Upstream Author : Nico Schlömer > * URL :

Re: Bug#875876: RFS: python-dtcwt/0.12.0-1

2017-09-16 Thread Herbert Fortes
Hi Ghislain Vaillant, > Package: sponsorship-requests > Severity: normal > > Dear mentors, > > I am looking for a sponsor for my package "python-dtcwt" > > * Package name    : python-dtcwt >   Version : 0.12.0-1 >   Upstream Author : Rich Wareham > * URL   

Re: Bug#875764: RFS: pybind11/2.2.1-1 [experimental]

2017-09-16 Thread Herbert Fortes
Hi Ghislain Vaillant, > Package: sponsorship-requests > Severity: normal > > Dear mentors, > > I am looking for a sponsor for the following package: > > * Package name    : pybind11 >   Version : 2.2.1-1 >   Upstream Author : Wenzel Jakob > * URL :

Re: Bug#875693: RFS: python-meshio/1.8.16-1

2017-09-13 Thread Herbert Fortes
Hi Ghislain Vaillant, > Package: sponsorship-requests > Severity: normal > > Dear mentors, > > I am looking for a sponsor for the following package: > > * Package name    : python-meshio >   Version : 1.8.16-1 >   Upstream Author : Nico Schlömer > * URL :

Bug#858155: RFS: stenc/1.0.7-1 [ITP]

2017-10-10 Thread Herbert Fortes
Em 10-10-2017 16:31, Andrey Rahmatullin escreveu: > On Tue, Oct 10, 2017 at 04:06:59PM -0300, Herbert Fortes wrote: >> It seems that the package is ready. Andrey Rahmatullin >> did the review. >> >> The last activity was on 01 Oct 2017;  I can take one last >&g

Bug#858155: RFS: stenc/1.0.7-1 [ITP]

2017-10-10 Thread Herbert Fortes
Hi Denys Berkovskyy and Andrey Rahmatullin, >On Tue, 26 Sep 2017 15:34:35 +0100 Denys Berkovskyy >wrote: > > > On 8 Aug 2017, at 19:22, Andrey Rahmatullin wrote: > > > > On Mon, Aug 07, 2017 at 11:52:33AM +0100, Denys Berkovskyy wrote: > >> Thank you for

Bug#858155: RFS: stenc/1.0.7-1 [ITP]

2017-10-11 Thread Herbert Fortes
Em 10-10-2017 16:31, Andrey Rahmatullin escreveu: > On Tue, Oct 10, 2017 at 04:06:59PM -0300, Herbert Fortes wrote: >> It seems that the package is ready. Andrey Rahmatullin >> did the review. >> >> The last activity was on 01 Oct 2017;  I can take one last >&g

Re: Bug#873630: RFS: python-qtpy/1.3.1-1

2017-08-29 Thread Herbert Fortes
Hi Ghislain Vaillant, > Package: sponsorship-requests > Severity: normal > > Dear mentors, > > I am looking for a sponsor for the following package: > > * Package name: python-qtpy > Version : 1.3.1-1 > Upstream Author : The Spyder Development Team > * URL :

Bug#873630: RFS: python-qtpy/1.3.1-1

2017-08-29 Thread Herbert Fortes
Hi Ghislain Vaillant, > Package: sponsorship-requests > Severity: normal > > Dear mentors, > > I am looking for a sponsor for the following package: > > * Package name: python-qtpy > Version : 1.3.1-1 > Upstream Author : The Spyder Development Team > * URL :

Re: Bug#873631: RFS: pytest-qt/2.1.2-3 [RC]

2017-08-29 Thread Herbert Fortes
Hi Ghislain Vaillant, > Package: sponsorship-requests > Severity: normal > > Dear mentors, > > I am looking for a sponsor for the following package: > > * Package name: pytest-qt > Version : 2.1.2-3 > Upstream Author : Bruno Oliveira > * URL :

Re: Bug#874703: RFS: rednotebook/2.2-1.1 [ITP] [NMU] -- A cross-platform journal

2017-09-09 Thread Herbert Fortes
Em 09-09-2017 13:16, Phil Wyett escreveu: >> I have emailed the person concerned and asked that I get the package back >> into >> debian and they learn from this, how to work with upstream and debian alike. I never saw something like this 'debian/changelog'. But this is not a problem. There is

Re: Bug#874703: RFS: rednotebook/2.2-1.1 [ITP] [NMU] -- A cross-platform journal

2017-09-09 Thread Herbert Fortes
Hi Phil Wyert, > On Fri, 2017-09-08 at 22:21 +0100, Phil Wyett wrote: >> Package: sponsorship-requests >> Severity: wishlist >> Owner: Phil Wyett >> >> I am looking for a sponsor for my package "rednotebook": >> >> * Package name: rednotebook >> Version :

Bug#868086: RFS: beautify-bash/1.1-1 [ITP]

2017-09-25 Thread Herbert Fortes
Em 25-09-2017 17:16, Andrey Rahmatullin escreveu: > On Mon, Sep 25, 2017 at 05:07:29PM -0300, Herbert Fortes wrote: >> The debian/watch file is not working. > It is working here. > Ok. It is working on Sid. I am sorry. Regards, Herbert

Bug#877047: RFS: sane-backends-extras/1.0.22.5 [QA]

2017-09-28 Thread Herbert Fortes
Hi Hugh McMaster, > Package: sponsorship-requests > Severity: normal > > Dear mentors, > > I am looking for a sponsor for my package "sane-backends-extras". > > * Package name: sane-backends-extras >Version: 1.0.22.5 >Upstream Author: SANE > * URL: http://www.sane-project.org/ > *

Re: Bug#877047: RFS: sane-backends-extras/1.0.22.5 [QA]

2017-09-28 Thread Herbert Fortes
Hi Hugh McMaster, > Package: sponsorship-requests > Severity: normal > > Dear mentors, > > I am looking for a sponsor for my package "sane-backends-extras". I can review this RFS. I did the last QA upload. Regards, Herbert > > * Package name: sane-backends-extras >Version: 1.0.22.5 >

Bug#868086: RFS: beautify-bash/1.1-1 [ITP]

2017-09-26 Thread Herbert Fortes
Em 25-09-2017 17:16, Andrey Rahmatullin escreveu: > On Mon, Sep 25, 2017 at 05:07:29PM -0300, Herbert Fortes wrote: >> The debian/watch file is not working. > It is working here. > Again, debian/watch is working. Here are my comments about: debian/changelog: - ITP bug nu

Bug#868086: RFS: beautify-bash/1.1-1 [ITP]

2017-09-26 Thread Herbert Fortes
Em 26-09-2017 06:26, gregor herrmann escreveu: > On Tue, 26 Sep 2017 06:12:54 -0300, Herbert Fortes wrote: > >> override_dh_installchangelogs: >> dh_installchangelogs CHANGES > > This can be removed from debian/rules, dh_installchangelogs finds > CHANGES and

Bug#868086: RFS: beautify-bash/1.1-1 [ITP]

2017-09-25 Thread Herbert Fortes
Hi Mike Mestnik, > Package: sponsorship-requests > Severity: wishlist > > -BEGIN PGP SIGNED MESSAGE- > Hash: SHA256 > > Dear mentors, > > I am looking for a sponsor for my package "beautify-bash" The debian/watch file is not working. And I assume that you know where to look for

Re: Bug#876624: RFS: qr-tools/1.4~bzr23-1 [QA]

2017-09-24 Thread Herbert Fortes
Hi Boyuan Yang, Uploaded. Thanks for your work! Regards, Herbert > Package: sponsorship-requests > Severity: normal > X-Debbugs-CC: david4...@gmail.com algoz...@gmail.com > > Dear mentors, > > This is a QA upload for package "qr-tools", which might went a little bit too > far from simply

package pynmea2

2017-11-14 Thread Herbert Fortes
Hi, There was a ITP-RFS for pynmea2. But python-nmea2 already exists. https://packages.qa.debian.org/p/python-nmea2.html I asked the contributor (2017-11-12) to close the bugs with an n-d...@bugs.debian.org but he sent -cl...@bugs.debian.org to ITP only. RFS still open.

Re: package pynmea2

2017-11-21 Thread Herbert Fortes
Em 21-11-2017 15:51, Joachim Langenbach escreveu: > Good evening, > > I've seen all the messages today. Is there something I need to do now? > A RC bug was opened (blocks the package in unstable) and a request to remove the package was done. So, I believe there is nothing else to do. Thanks

Re: package pynmea2

2017-11-16 Thread Herbert Fortes
Em 14-11-2017 20:22, Adam Borowski escreveu: > On Tue, Nov 14, 2017 at 12:13:55PM -0200, Herbert Fortes wrote: >> There was a ITP-RFS for pynmea2. But python-nmea2 already >> exists. >> >> https://packages.qa.debian.org/p/python-nmea2.html >> >> I aske

Re: package pynmea2

2017-11-15 Thread Herbert Fortes
Em 14-11-2017 20:22, Adam Borowski escreveu: > On Tue, Nov 14, 2017 at 12:13:55PM -0200, Herbert Fortes wrote: >> There was a ITP-RFS for pynmea2. But python-nmea2 already >> exists. >> >> https://packages.qa.debian.org/p/python-nmea2.html >> >> I aske

Re: package pynmea2

2017-11-14 Thread Herbert Fortes
Hi Geert Stappers, > On Tue, Nov 14, 2017 at 12:13:55PM -0200, Herbert Fortes wrote: >> Hi, >> >> There was a ITP-RFS for pynmea2. >> But python-nmea2 already exists. >> >> https://packages.qa.debian.org/p/python-nmea2.html >> >> I a

Bug#880491: RFS: budgie-desktop/10.4+git20171031.10.g9f71bb8-1

2017-11-01 Thread Herbert Fortes
Em 01-11-2017 06:06, foss.freedom escreveu: > Package: sponsorship-requests > Severity: normal > Dear mentors, > > I am looking for a sponsor for my package "budgie-desktop" > > * Package name: budgie-desktop >Version : 10.4+git20171031.10.g9f71bb8-1 >Upstream Author :

Re: Bug#880491: RFS: budgie-desktop/10.4+git20171031.10.g9f71bb8-1

2017-11-01 Thread Herbert Fortes
Hi, Em 01-11-2017 06:06, foss.freedom escreveu: > Package: sponsorship-requests > Severity: normal > Dear mentors, > > I am looking for a sponsor for my package "budgie-desktop" > > * Package name: budgie-desktop >Version : 10.4+git20171031.10.g9f71bb8-1 >Upstream

Bug#883305: RFS: sqldeveloper-package/0.5.0

2017-12-10 Thread Herbert Fortes
Hi Lazarus Long, > Package: sponsorship-requests > Severity: normal > > Dear mentors, > > I am looking for a sponsor for my package "sqldeveloper-package" > I did the upload. Please close this RFS. Regards, Herbert > * Package name : sqldeveloper-package > Version : 0.5.0 > Upstream Author

Bug#898231: RFS: budgie-extras/0.5.0-1

2018-05-20 Thread Herbert Fortes
Hi, Em 08-05-2018 20:25, foss.freedom escreveu: Package: sponsorship-requests Severity: normal Dear mentors, I am looking for a sponsor for my package "budgie-extras" * Package name: budgie-extras Version : 0.5.0-1 Upstream Author : Ubuntu Budgie Developers *

Re: Help to clarify an issue

2017-12-31 Thread Herbert Fortes
Em 31-12-2017 15:38, Mattia Rizzolo escreveu: > Hello, > > On Sun, Dec 31, 2017 at 01:23:51PM -0200, Herbert Fortes wrote: >> Can someone read the bug report[0] an give >> an second opinion? >> >> [0] - https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=885

Help to clarify an issue

2017-12-31 Thread Herbert Fortes
Hi, I am having difficult to end a situation with duc Debian package. Can someone read the bug report[0] an give an second opinion? [0] - https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=885404 We disagree when an NMU is necessary and how important the request is. Regards, Herbert

Re: Help to clarify an issue

2018-01-01 Thread Herbert Fortes
Em 01-01-2018 12:06, Mattia Rizzolo escreveu: > On Mon, Jan 01, 2018 at 11:01:59AM -0200, Herbert Fortes wrote: >> It is impossible that someone has both - duc and duc-nox - installed ? > > Using the alternatives system you can have both installed, and the the > system administ

Re: Help to clarify an issue

2018-01-01 Thread Herbert Fortes
Em 01-01-2018 14:02, Mattia Rizzolo escreveu: > On Mon, Jan 01, 2018 at 10:47:26AM -0500, The Wanderer wrote: >> On 2018-01-01 at 10:39, Mattia Rizzolo wrote: >>> On Mon, Jan 01, 2018 at 01:30:16PM -0200, Herbert Fortes wrote: >>>> The package is orphan now and what i

Re: Help to clarify an issue

2018-01-01 Thread Herbert Fortes
Em 01-01-2018 10:56, The Wanderer escreveu: > On 2018-01-01 at 05:48, Herbert Fortes wrote: > >> >>> Well said, I agree 100%. >>> >>> I consider both parties to be wrong here: >>> * Jonathan went very hasty on the NMU >>> * Herbert refuses

Re: Help to clarify an issue

2018-01-01 Thread Herbert Fortes
> Well said, I agree 100%. > > I consider both parties to be wrong here: > * Jonathan went very hasty on the NMU > * Herbert refuses a patch for a quite annoying thing, fixing which requires > no effort on his side (as the submitter did all the work), without > providing any rationale > >

Re: Help to clarify an issue

2018-01-01 Thread Herbert Fortes
Em 01-01-2018 13:39, Mattia Rizzolo escreveu: > On Mon, Jan 01, 2018 at 01:30:16PM -0200, Herbert Fortes wrote: >> The package is orphan now and what it is seems as best >> can be done by who wants to do the job. > > So your argument is "the package is not developed an

Bug#905375: RFS: bitz-server/2.0.1-1

2018-08-04 Thread Herbert Fortes
Hi, > -BEGIN PGP SIGNED MESSAGE- > Hash: SHA512 > > retitle 905375 RFS: bitz-server/2.0.1-1 > thanks > I ran 'blhc --all ../*.build and there are some CXXFLAGS missing (-fPIE) LDFLAGS missing (-fPIE -pie) I saw debian/rules has 'hardening=+all' but can you please add: export

Bug#905375: RFS: bitz-server/2.0.1-1

2018-08-05 Thread Herbert Fortes
Em 04-08-2018 19:21, Jörg Frings-Fürst escreveu: -BEGIN PGP SIGNED MESSAGE- Hash: SHA512 Hi Herbert, Am Samstag, den 04.08.2018, 09:05 -0300 schrieb Herbert Fortes: Hi, > -BEGIN PGP SIGNED MESSAGE- > Hash: SHA512 > > retitle 905375 RFS: bitz-server/2.0.1-

Bug#905455: RFS: dmidecode/3.1-2

2018-08-05 Thread Herbert Fortes
Hi, -BEGIN PGP SIGNED MESSAGE- Hash: SHA512 Package: sponsorship-requests Severity: normal Dear mentors, I am looking for a sponsor for my package "dmidecode" Package name: dmidecode Version : 3.1-2 Upstream Author : dmidecode-de...@nongnu.org URL

Bug#905455: RFS: dmidecode/3.1-2

2018-08-05 Thread Herbert Fortes
Em 05-08-2018 15:10, Andrey Rahmatullin escreveu: On Sun, Aug 05, 2018 at 03:02:39PM -0300, Herbert Fortes wrote: Sorry, but can you please add to debian/rules: export DEB_LDFLAGS_MAINT_APPEND = -fPIE -pie export DEB_CFLAGS_MAINT_APPEND = -fPIE Why? Becauso of 'blhc --all'

Bug#905455: RFS: dmidecode/3.1-2

2018-08-05 Thread Herbert Fortes
Em 05-08-2018 15:47, Andrey Rahmatullin escreveu: On Sun, Aug 05, 2018 at 03:23:33PM -0300, Herbert Fortes wrote: Sorry, but can you please add to debian/rules: export DEB_LDFLAGS_MAINT_APPEND = -fPIE -pie export DEB_CFLAGS_MAINT_APPEND = -fPIE Why? Becauso of 'blhc --all' I'm sorry

Bug#905455: RFS: dmidecode/3.1-2

2018-08-05 Thread Herbert Fortes
Em 05-08-2018 15:27, Jörg Frings-Fürst escreveu: -BEGIN PGP SIGNED MESSAGE- Hash: SHA512 Hello Herbert, thanks for your review. Am Sonntag, den 05.08.2018, 15:02 -0300 schrieb Herbert Fortes: Hi, -BEGIN PGP SIGNED MESSAGE- Hash: SHA512 Package: sponsorship-requests

Bug#905455: RFS: dmidecode/3.1-2

2018-08-05 Thread Herbert Fortes
Em 05-08-2018 16:14, Andrey Rahmatullin escreveu: On Sun, Aug 05, 2018 at 03:54:23PM -0300, Herbert Fortes wrote: Sorry, but can you please add to debian/rules: export DEB_LDFLAGS_MAINT_APPEND = -fPIE -pie export DEB_CFLAGS_MAINT_APPEND = -fPIE Why? Becauso of 'blhc --all' I'm sorry

Bug#907664: RFS: budgie-desktop/10.4+git20180830.01.f2dbc215fdb-1

2018-09-01 Thread Herbert Fortes
Hi David Mohammed, I am giving you budgie-desktop upload permission. Regards, Herver

Bug#907664: RFS: budgie-desktop/10.4+git20180830.01.f2dbc215fdb-1

2018-09-05 Thread Herbert Fortes
Thanks Herver - due to the new binary with this upload (libbudgie-private0) FTP-Master has rejected the package with this message "ACL dm: NEW uploads are not allowed binary:libbudgie-private0 is NEW." Can this be sponsored this time around please? Uploaded to experimental. But please

Bug#894307: RFS: pgn2web/0.4-2 [ITA]

2018-04-01 Thread Herbert Fortes
Em 01-04-2018 05:25, Jose G. López escreveu: > On Sat, 31 Mar 2018 09:29:02 -0300 > Herbert Fortes <terb...@gmail.com> wrote: > >> Hi Jose G. López, >> >> I ran 'blhc --all' and there are some CFLAGS, CXXFLAGS and LDFLAGS >> missing '-fPIE' '-fPIE -pie'. &g

Bug#894307: RFS: pgn2web/0.4-2 [ITA]

2018-03-31 Thread Herbert Fortes
Hi Jose G. López, > Package: sponsorship-requests > Severity: wishlist > > Dear mentors, > > I am looking for a sponsor for my package "pgn2web": > > * Package name : pgn2web > Version : 0.4-2 > Upstream Author : William Hoggarth > * URL :

Bug#887403: Acknowledgement (RFS: budgie-extras/0.4.0-1)

2018-02-25 Thread Herbert Fortes
Em 27-01-2018 14:06, foss.freedom escreveu: > The team has completed a minor release with lots of useful bug-fixes. > > These are summarised in the source ChangeLog file > > dget -x > https://mentors.debian.net/debian/pool/main/b/budgie-extras/budgie-extras_0.4.1-1.dsc > > The debian/changelog

Bug#910913: RFS: ghostwriter/1.7.3-1 [ITP]

2018-10-14 Thread Herbert Fortes
On 10/13/18 7:56 PM, ghost wrote: Thanks for reviewing! I am neither the upstream nor the person who originally uploaded to mentors.d.n, though I am doing the most fixing part for the package for it to get into Debian... OK. I am reading files from 1.7.3-4 and there is only Sebastien name in

Bug#910966: RFS: 4pane

2018-10-14 Thread Herbert Fortes
Hi, On 10/13/18 6:23 PM, David Hart wrote: Package: sponsorship-requests Severity: normal Dear mentors, I am looking for a sponsor for an update of my package "4pane" I can not build the package right now. I did a download of the debian dir. debian/changelog - is "UNRELEASED". - a

Bug#910966: RFS: 4pane/5.0-2

2018-10-14 Thread Herbert Fortes
On 10/14/18 11:24 AM, David Hart wrote: Hi Herbert, debian/changelog - is "UNRELEASED". - a comment: I never saw a changelog going to 'testing'. Like version 5.0-1. It is in Sid anyway. But there are less 4 lines in that part of the file I wasn't sure what was right for that field.

Bug#910913: RFS: ghostwriter/1.7.3-1 [ITP]

2018-10-14 Thread Herbert Fortes
On 10/14/18 8:38 AM, ghost wrote: Hi, I've uploaded my version to mentors.d.n. I thought it would cause conflict since Sebastien already uploaded the same version, but never mind. Thank you very much! I did the upload. Let's see what FTP-Master thinks. Regards, Herbert

Bug#910913: RFS: ghostwriter/1.7.3-1 [ITP]

2018-10-13 Thread Herbert Fortes
Hi, On 10/13/18 7:52 AM, ghost wrote: Package: sponsorship-requests Severity: wishlist Forwarded Message Subject:RFS: ghostwriter/1.7.3-1 [ITP] Date: Mon, 08 Oct 2018 05:49:14 +1300 From: Sebastien CHAVAUX To: 894...@bugs.debian.org, ghost Dear

Bug#910966: RFS: 4pane/5.0-2

2018-10-15 Thread Herbert Fortes
Hi, My final comments so I can upload the package: The history of debian/changelog is been changed. Please, keep the history. https://tracker.debian.org/media/packages/4/4pane/changelog-5.0-1 diff -Nru 4pane-5.0/debian/changelog 4pane-5.0/debian/changelog --- 4pane-5.0/debian/changelog

Bug#911867: RFS: frr/6.0.1-1 [ITP]

2018-10-27 Thread Herbert Fortes
Hi, On 10/25/18 3:17 PM, David Lamparter wrote: Package: sponsorship-requests Severity: wishlist Dear mentors, I am looking for a sponsor for my package "frr" * Package name: frr Version : 6.0.1-1 Upstream Author : FRRouting-dev * URL :

Bug#911867: RFS: frr/6.0.1-1 [ITP]

2018-10-27 Thread Herbert Fortes
Hi, On 10/25/18 3:17 PM, David Lamparter wrote: Package: sponsorship-requests Severity: wishlist Dear mentors, I am looking for a sponsor for my package "frr" * Package name: frr Version : 6.0.1-1 Upstream Author : FRRouting-dev * URL :

Bug#908629: RFS: biometric-authentication/0.9.55-1 [ITP]

2018-10-27 Thread Herbert Fortes
Hi, On Wed, 12 Sep 2018 10:54:44 +0800 handsome_feng wrote: > Package: sponsorship-requests > Severity: wishlist > > Dear mentors, > > I am looking for a sponsor for my package "biometric-authentication" About these lintians: I: libbiometric0: hardening-no-bindnow

Bug#908629: RFS: biometric-authentication/0.9.55-1 [ITP]

2018-10-27 Thread Herbert Fortes
> > Another lintian: > > I: libbiometric0: symbols-file-missing-build-depends-package-field > > > It is a whislist and I do not know how to fix it. But > > the version in it is not 0.9.56. The version that will > > be in Debian. Please redo the file. > > As an information, lintian stops with:

Bug#913261: RFS: chkboot/1.2-1 [ITP]

2018-11-10 Thread Herbert Fortes
Hi, On 08/11/2018 17:30, Baptiste BEAUPLAT wrote: Package: sponsorship-requests Severity: normal -BEGIN PGP SIGNED MESSAGE- Hash: SHA256 Dear mentors, I am looking for a sponsor for my package "chkboot" The package does not build twice in a row: dpkg-source: info: using

Bug#906721: RFS: plowshare/2.1.7-2

2018-09-29 Thread Herbert Fortes
Hi Carl Suster, > Package: sponsorship-requests > Severity: normal > > Dear mentors, > > I am looking for a sponsor for my package "plowshare" and the related > package "plowshare-modules". The main reason this is worth an upload is > that I'm shifting the way the two packages are related in

Bug#910245: RFS: engauge-digitizer/10.10+ds.1-1

2018-10-10 Thread Herbert Fortes
On 10/8/18 3:55 PM, Tobias Winchen wrote: Dear Herbert, I executed cowbuilder 2x in a fresh virtual machine and could not reproduce this problem. Please let me know if I can do anything else. Something was wrong with cowbuilder here. I reinstall it. Then the package was compiled. Uploading.

Bug#906721: RFS: plowshare/2.1.7-2

2018-09-30 Thread Herbert Fortes
On 9/30/18 2:43 AM, Carl Suster wrote: Hi Herbert, Thanks for looking at my packages. I'm not really sure how the old changelog diff happened other than that the commit responsible must have been lost somewhere in the migration of the repository from GitHub to GitLab to salsa. I fixed the

Bug#910134: RFS: dmidecode/3.2-1

2018-10-06 Thread Herbert Fortes
Hi, On 10/3/18 3:58 AM, Jörg Frings-Fürst wrote: -BEGIN PGP SIGNED MESSAGE- Hash: SHA512 Package: sponsorship-requests Severity: normal Dear mentors, I am looking for a sponsor for my package "dmidecode" There are two changes made by Jean Delvare that is not in debian/copyright:

Bug#910245: RFS: engauge-digitizer/10.10+ds.1-1

2018-10-06 Thread Herbert Fortes
Hi, On 10/3/18 4:16 PM, Tobias Winchen wrote: Package: sponsorship-requests Severity: normal Dear mentors, I am looking for a sponsor for my package "engauge-digitizer" I ran 'cowbuilder' 2x and got this error: # cowbuilder --build engauge-digitizer_10.10+ds.1-1.dsc cklistWizardPoints.o

Bug#909134: RFS: budgie-extras/0.6.1-1

2018-09-22 Thread Herbert Fortes
Hi David Mohammed, Package: sponsorship-requests Severity: normal Dear mentors, I am looking for a sponsor for my package "budgie-extras" I did a review and have two questions: The budgie-quicknote/QuickNoteApplet.vala file is GPL-2+. It does not have an entry in debian/copyright.

Bug#909134: Info received (Bug#909134: RFS: budgie-extras/0.6.1-1)

2018-09-22 Thread Herbert Fortes
Uploaded. And also sent the dak-comands to FTP-Master too. Enjoy! Regards, Herbert

Bug#920218: RFS: webcamoid/8.5.0+dfsg-1

2019-01-22 Thread Herbert Fortes
Package: sponsorship-requests Severity: normal Dear mentors, I am looking for a sponsor for my package "webcamoid". It is a upload to experimental. To test the new .symbols file, install via apt and run the software. My key is not in the archive yet. The new release closes two

Re: Bug#920218: RFS: webcamoid/8.5.0+dfsg-1

2019-01-23 Thread Herbert Fortes
On 1/23/19 4:14 AM, Sune Vuorela wrote: > On 2019-01-22, Herbert Fortes wrote: >> akqml - full featured webcam capture application - qml module > > shouldn't this be called qml-module-something instead ? It is for Webcamoid only. I used the lib name. /usr/lib/x86_64-linux-gn

Bug#913363: RFS: desktopfolder/1.0.10-1 [ITP]

2018-12-07 Thread Herbert Fortes
On 07/12/2018 08:10, foss.freedom wrote: It has been about a month since the initial package was uploaded to mentors. Still hoping for some feedback please. Yesterday I've tweaked the package to remove an unnecessary build-dependency after discussing with upstream. I note one new

Bug#913261: RFS: chkboot/1.2-1 [ITP]

2018-11-21 Thread Herbert Fortes
On 21/11/2018 13:31, Baptiste BEAUPLAT wrote: Hello Herbert, I hope you are well. I was wondering if you had time to take a second look at this package? No. I had to improve the Debian CI tests for some of the packages I take care. Anyone can take of that package if necessary. I can not

Bug#918580: RFS: libgphoto2/2.5.22-1

2019-01-07 Thread Herbert Fortes
Package: sponsorship-requests Severity: normal Dear mentors, I am looking for a sponsor for my package "libgphoto2" as I am without my key and no access to Salsa * Package name: libgphoto2 Version : 2.5.22-1 Upstream Author : Marcus Meissner and others * URL

Bug#918571: RFS: python-gphoto2/1.9.0-1

2019-01-07 Thread Herbert Fortes
Package: sponsorship-requests Severity: normal Dear mentors, I am looking for a sponsor for my package "python-gphoto2" as I am without my key and access to Salsa * Package name: python-gphoto2 Version : 1.9.0-1 Upstream Author : Jim Easterbrook * URL :

Bug#906877: RFS: yuma123/2.11-1

2018-09-15 Thread Herbert Fortes
Em 15-09-2018 14:36, Vladimir Vassilev escreveu: Hi Herbert, I fixed this issue and updated the package now uploaded on mentors.debian.net Removed the netconf/src/yangdiff/Makefile target from configure.ac with new patch 0004-Removed-unused-autoconf-targets.patch Updated debian/changelog.

Bug#906877: RFS: yuma123/2.11-1

2018-09-15 Thread Herbert Fortes
Hi Vladimir Vassilev, > Package: sponsorship-requests > Severity: normal > > Dear mentors, > > I am looking for a sponsor for my package "yuma123" The package does not build twice because the generated netconf/src/yangdiff/Makefile file. Please add the file to dh_clean's routine. A

Re: Lintian - pkg-config-references-unknown-shared-library

2019-02-15 Thread Herbert Fortes
On 2/15/19 10:34 AM, Andreas Metzler wrote: > On 2019-02-15 Herbert Fortes wrote: >> I working on a Debian revison for libgphoto2 and >> have this Lintian about pkg-config. > >> pkg-config-references-unknown-shared-library > >> The libgphoto2_port/libgphoto2_po

  1   2   >