Re: request to join PAPT

2018-11-27 Thread Ondrej Novy
Hi,

út 20. 11. 2018 v 20:44 odesílatel Stéphane Blondon <
stephane.blon...@gmail.com> napsal:

> I accept the policy.
>

welcome :)

-- 
Best regards
 Ondřej Nový

Email: n...@ondrej.org
PGP: 3D98 3C52 EB85 980C 46A5  6090 3573 1255 9D1E 064B


Re: Request to join PAPT (Was: Bug#914230: ITP: git-imerge -- incremental merge and rebase for git)

2018-11-27 Thread Ondrej Novy
Hi,

čt 22. 11. 2018 v 1:36 odesílatel James Clarke  napsal:

> It turns out policy.rst is lying, I don't have permission to create a
> repository. Therefore I would like to request to join PAPT, please (and
> accept the policy even in spite of its lies).
>

welcome :)

-- 
Best regards
 Ondřej Nový

Email: n...@ondrej.org
PGP: 3D98 3C52 EB85 980C 46A5  6090 3573 1255 9D1E 064B


Re: Request Access to Salsa

2018-11-27 Thread Ondrej Novy
Hi,

st 21. 11. 2018 v 0:33 odesílatel Per Andersson 
napsal:

> I would like to join the Debian Python team on Salsa ...


welcome :)

-- 
Best regards
 Ondřej Nový

Email: n...@ondrej.org
PGP: 3D98 3C52 EB85 980C 46A5  6090 3573 1255 9D1E 064B


Re: Request to join python-team/modules on salsa

2018-11-27 Thread Alex Mestiashvili

On 11/27/18 4:01 PM, Ondrej Novy wrote:
> Hi,
> 
> pá 23. 11. 2018 v 11:59 odesílatel Alex Mestiashvili
> mailto:ames...@rsh2.donotuse.de>> napsal:
> 
> please grant "mes...@debian.org " access
> to Debian Python Modules Team
> 
> 
> do you accept our team policy please?
> https://salsa.debian.org/python-team/tools/python-modules/blob/master/policy.rst

Sorry for not mentioning this.
Yes, I do, I am actually a member of DPMT since 2016 :)

 https://lists.debian.org/debian-python/2016/01/msg00034.html

Thank you!
Alex

> 
> -- 
> Best regards
>  Ondřej Nový
>  
> Email: n...@ondrej.org 
> PGP: 3D98 3C52 EB85 980C 46A5  6090 3573 1255 9D1E 064B
> 



signature.asc
Description: OpenPGP digital signature


Re: Request to join python-team/modules on salsa

2018-11-27 Thread Ondrej Novy
Hi,

pá 23. 11. 2018 v 11:59 odesílatel Alex Mestiashvili <
ames...@rsh2.donotuse.de> napsal:

> please grant "mes...@debian.org" access to Debian Python Modules Team
>

do you accept our team policy please?
https://salsa.debian.org/python-team/tools/python-modules/blob/master/policy.rst

-- 
Best regards
 Ondřej Nový

Email: n...@ondrej.org
PGP: 3D98 3C52 EB85 980C 46A5  6090 3573 1255 9D1E 064B


Re: DPMT Join Request from @rbalint

2018-11-27 Thread Ondrej Novy
Hi,

po 26. 11. 2018 v 15:04 odesílatel Balint Reczey <
balint.rec...@canonical.com> napsal:

> Hi,
>
> I would like to join the team to be able to contribute the team's
> packages more easily.
>

welcome :)

-- 
Best regards
 Ondřej Nový

Email: n...@ondrej.org
PGP: 3D98 3C52 EB85 980C 46A5  6090 3573 1255 9D1E 064B


Re: Request to join python-team/modules on salsa

2018-11-27 Thread Ondrej Novy
Hi,

út 27. 11. 2018 v 16:36 odesílatel Alex Mestiashvili <
ames...@rsh2.donotuse.de> napsal:

> Sorry for not mentioning this.
> Yes, I do, I am actually a member of DPMT since 2016 :)
>

welcome (back) :)

-- 
Best regards
 Ondřej Nový

Email: n...@ondrej.org
PGP: 3D98 3C52 EB85 980C 46A5  6090 3573 1255 9D1E 064B


Re: [Python-modules-team] Bug#914592: Upcoming pytest-4 problems

2018-11-27 Thread Ole Streicher
Hi Ondrej,

On 26.11.18 21:29, Ondrej Novy wrote:
> my plan is:
> 
>   * keep 3.x for Buster
>   * upgrade to >= 4.x just after Buster release
> 
> Because we are going to drop Python after Buster release, I think it's
> perfectly fine that Astropy (Py2 version) will not support Pytest 4.x.

Thanks, however it turns out that this will unfortunately not work for
me: from astropys POV, pytest seems to be broken in versions 3.7 - 3.10;
see

https://github.com/astropy/astropy/issues/8177

I also observed diverse failures on other (astropy dependent) packages
with 3.10. Which basically means that I need to switch off the tests,
unless pytests upstream provides a bugfixed 3.X version.

However, it seems that I need to start with the removal of the Python 2
astropy ecosystem, which may be in any case not the worst decision.
Personally, I like to put pressure to move towards Python 3.

Cheers

Ole



Re: [Python-modules-team] Bug#914592: Upcoming pytest-4 problems

2018-11-27 Thread Ondrej Novy
Hi,

út 27. 11. 2018 v 8:46 odesílatel Ole Streicher  napsal:

> Thanks, however it turns out that this will unfortunately not work for
> me: from astropys POV, pytest seems to be broken in versions 3.7 - 3.10;
> see
>
> https://github.com/astropy/astropy/issues/8177


according to linked issue, that bug is fixed in 3.10.1, which is in Debian
unstable now.


> I also observed diverse failures on other (astropy dependent) packages
> with 3.10. Which basically means that I need to switch off the tests,
> unless pytests upstream provides a bugfixed 3.X version.
>

maybe just disable some of that tests? Not whole testsuite?

-- 
Best regards
 Ondřej Nový

Email: n...@ondrej.org
PGP: 3D98 3C52 EB85 980C 46A5  6090 3573 1255 9D1E 064B


Re: [Python-modules-team] Bug#914592: Upcoming pytest-4 problems

2018-11-27 Thread Ole Streicher
On 27.11.18 09:35, Ondrej Novy wrote:
> út 27. 11. 2018 v 8:46 odesílatel Ole Streicher  > napsal:
> 
> Thanks, however it turns out that this will unfortunately not work for
> me: from astropys POV, pytest seems to be broken in versions 3.7 - 3.10;
> see
> 
> https://github.com/astropy/astropy/issues/8177
> 
> 
> according to linked issue, that bug is fixed in 3.10.1, which is in
> Debian unstable now.

Thanks for updating, but I still get failures. And I asked pytest
upstream about possible fixes of the 3.X branch, which they are not
going to do:

https://github.com/astropy/astropy/pull/8173#issuecomment-441959185

> I also observed diverse failures on other (astropy dependent) packages
> with 3.10. Which basically means that I need to switch off the tests,
> unless pytests upstream provides a bugfixed 3.X version.
> 
> maybe just disable some of that tests? Not whole testsuite?

The current failure in python-astropy is

E   UsageError: Plugin specs must be a ','-separated string or a
list/tuple of strings for plugin names. Given: 

which blocks the whole suite. Other packages have errors that really
look strange (data files are missing, submodules not found etc). Sure,
that all could be workarounded somehow, but in a few weeks the next
update of a dependency may make trouble again.

We will publish Debian Buster not earlier than summer/fall next year,
and this is just ~6-9 months before Python 2 EOL. I don't want to put
too many efforts in keeping this alive.

Best

Ole



Joining DPMT and PAPT

2018-11-27 Thread gustavo panizzo



Hi

I want to join both teams to maintain my python packages under their
umbrella. Currently they are under the Debian salsa group.

My salsa login is gfa

I accept both policies (with Yao and Ondřej's updates in MRs)

https://salsa.debian.org/python-team/tools/python-apps/blob/master/policy.rst
https://salsa.debian.org/python-team/tools/python-modules/blob/master/policy.rst


I'll update the packages to match the team(s) policy


--
IRC: gfa
GPG: 0X44BB1BA79F6C6333