Re: Removal of easy_install

2018-05-07 Thread Ben Finney
Scott Talbert writes: > Installing the egg means that all the wxpython4.0 files are installed > under: > /usr/lib/python2.7/dist-packages/wxPython-4.0.1-py2.7-linux-amd64.egg > > Thus, any program or user who does an 'import wx' will get the > wxpython3.0 module and if instead

Re: Removal of easy_install

2018-05-07 Thread Scott Talbert
On Tue, 8 May 2018, Ben Finney wrote: The source package in question is wxpython4.0. The reason I use easy_install is for installing the python2 version of the module as an egg. Okay, so from that I understand that the Debian package is not invoking ‘easy_install’ to fetch files from the

Re: Removal of easy_install

2018-05-07 Thread Ben Finney
Scott Talbert writes: > The source package in question is wxpython4.0. The reason I use > easy_install is for installing the python2 version of the module as an > egg. Okay, so from that I understand that the Debian package is not invoking ‘easy_install’ to fetch files from the

Request for acces to salsa project

2018-05-07 Thread eamanu15
Hello everybody, I resend this mail. I was maintaining pygtihub project ( https://salsa.debian.org/python-team/modules/pygithub/) But, I lost my privileges when the project was migrate to salsa. Could you give me access to pygithub? I have some commits. My salsa user is: eamanu-guest Thanks

Re: Removal of easy_install

2018-05-07 Thread Scott Talbert
On Mon, 7 May 2018, Ben Finney wrote: About a month ago, Matthias removed easy_install from setuptools. I have sent him a few mails and bugs asking about it, but I haven't heard anything back. Anyone know why he did it? I have a package that currently FTBFS because of it. :( Why does a

Re: Removal of easy_install

2018-05-07 Thread Thomas Goirand
On 05/07/2018 04:19 AM, Ben Finney wrote: > Scott Talbert writes: > >> About a month ago, Matthias removed easy_install from setuptools. I >> have sent him a few mails and bugs asking about it, but I haven't >> heard anything back. Anyone know why he did it? I have a package

How to make sure PATH is set correctly (Was: foo FTBFS with dh-python >= 3.20180313)

2018-05-07 Thread Andreas Tille
Hi again, sorry for nagging again but what else than I did in https://salsa.debian.org/med-team/snakemake/blob/master/debian/rules can I do to set PATH in pbuilder. Possibly I've understand all your hints incorrectly - the PATH is just not set inside pbuilder chroot. :-( Kind regards

Re: input into perl 6 packaging required

2018-05-07 Thread Dmitry Shachnev
Hi Robert! On Sat, May 05, 2018 at 09:21:28PM +0200, Robert Lemmen wrote: > hi folks, > > we are currently thinking about how to package perl 6 modules, some > background and information at https://wiki.debian.org/Perl6PreCompProposal > > Perl 6 does pre-compile modules on loading, a bit like the