Re: pybuilder help -- why no python3- pkg proper build/tests?

2018-06-04 Thread Andrey Rahmatullin
On Mon, Jun 04, 2018 at 05:01:21PM -0400, Yaroslav Halchenko wrote: > I would've expected some info or error message though > (since I do request python3 explicitly in the call to dh), I think pybuild doesn't care about --with python3 Maybe it could, though. -- WBR, wRAR signature.asc

Re: Broken dbgsym packages for Python 3

2018-06-04 Thread Andrey Rahmatullin
On Tue, Jun 05, 2018 at 12:11:21AM -0400, Scott Talbert wrote: > Yes, I'm talking about the automatically generated -dbgsym packages that > contain the /usr/lib/debug/.build-id/... files. Have you read Scott's email? -- WBR, wRAR signature.asc Description: PGP signature

Re: Broken dbgsym packages for Python 3

2018-06-04 Thread Scott Talbert
On Mon, 4 Jun 2018, Matthias Klose wrote: I've got a package (wxpython4.0) that builds modules for both Python 2.7 and Python 3. When I rebuilt the package in early May, I started getting the lintian warning debug-file-with-no-debug-symbols for the Python 3 dbgsym packages only. Sure enough,

Re: pybuilder help -- why no python3- pkg proper build/tests?

2018-06-04 Thread Yaroslav Halchenko
On Tue, 05 Jun 2018, Andrey Rahmatullin wrote: > On Mon, Jun 04, 2018 at 03:38:09PM -0400, Yaroslav Halchenko wrote: > > I am trying to make our DataLad package to be bi-python finally, but I > > cannot make pybuilder > It's "pybuild". yeah ;-) > > neither populate python3-datalad package,

Re: pybuilder help -- why no python3- pkg proper build/tests?

2018-06-04 Thread Andrey Rahmatullin
On Mon, Jun 04, 2018 at 03:38:09PM -0400, Yaroslav Halchenko wrote: > I am trying to make our DataLad package to be bi-python finally, but I > cannot make pybuilder It's "pybuild". > neither populate python3-datalad package, nor > to run tests (using nose) during the build against python3 (runs

pybuilder help -- why no python3- pkg proper build/tests?

2018-06-04 Thread Yaroslav Halchenko
Dear Debian Pythonistas, I am trying to make our DataLad package to be bi-python finally, but I cannot make pybuilder neither populate python3-datalad package, nor to run tests (using nose) during the build against python3 (runs only against python2). It does invoke dh_python3 at the end

Re: Broken dbgsym packages for Python 3

2018-06-04 Thread Matthias Klose
On 04.06.2018 06:34, Scott Kitterman wrote: On Sunday, June 03, 2018 09:26:58 PM Scott Talbert wrote: Hi, I've got a package (wxpython4.0) that builds modules for both Python 2.7 and Python 3. When I rebuilt the package in early May, I started getting the lintian warning

Please add my DD account to the Salsa group

2018-06-04 Thread Elena ``of Valhalla''
Hello I'm already a member of DPMT and in the salsa group with my valhalla-guest account. I now have a DD account (valhalla) and I would like to start using it instead. I couldn't find what is the proper procedure to do so, could somebody point me to the right documentation? If the right

Re: Joining DPMT

2018-06-04 Thread Piotr O┼╝arowski
[Willem van den Akker, 2018-05-31] > I am maintaining python-ldap and want to make it a team-package. > My login name: wvdakker-guest > I have read and accept the Debian Python Modules Team - Policy on > salso (there is in invalid link to alioth in the document). > > A 3.10 package is available