Re: reducing matplotlib2 build-depends.

2019-11-12 Thread Sandro Tosi
On Tue, Nov 12, 2019 at 9:24 AM peter green wrote: > I am guessing that many of these are to get testsuite coverage for optional > features and are not strictly needed for the build, while testing stuff is > nice I don't think it's vital for software that is on it's way out. I tried > removing

Re: Adding Python 3.8 as a supported Python3 version

2019-11-12 Thread Matthias Klose
On 07.11.19 15:08, Matthias Klose wrote: > This weekend, I am planning to upload python3-defaults, adding python3.8 as a > supported Python3 version.  This may introduce some churn in unstable until > the > basic binNMUs are available as well. > > Details for the addition can be found at [1],

Re: reducing matplotlib2 build-depends.

2019-11-12 Thread Rebecca N. Palmer
By itself, removing those dependencies reduces the big tangle [0] from 148 packages to 141, the freed ones being: ipywidgets pyqt5 pep8 autopep8 xcffib xlwt cairocffi. (Note that "not in a tangle" means "no *circular* dependencies", *not* "leaf / can be removed immediately".) There may also

Re: reducing matplotlib2 build-depends.

2019-11-12 Thread Dmitry Shachnev
Hi all, On Tue, Nov 12, 2019 at 02:13:51PM +, peter green wrote: > matplotlib2 seems to be an important node in the python2 removal/reduction > problem (and the qt4 removal problem). I have noticed there are a > substantial number of python module packages that it build-depends on but > does

Re: getmail: Python2 removal in sid/bullseye

2019-11-12 Thread Mattia Rizzolo
On Wed, Nov 13, 2019 at 12:37:27AM +0900, Osamu Aoki wrote: > Upstream is active and prides to keep python 2.5 compatibility code in > it ... (Not just 2.7). I (Osamu Aoki ) and dkg even > made some effort to support both 2 and 3 but the idea was rejected by > upstream in 2018. (Then we both

getmail: Python2 removal in sid/bullseye

2019-11-12 Thread Osamu Aoki
Hi, It seems I need to discuss here before adding followings. | Package: src:getmail | Version: 5.13-1 | Severity: normal | Tags: sid bullseye | User: debian-python@lists.debian.org | Usertags: py2keep Upstream is active and prides to keep python 2.5 compatibility code in it ... (Not just 2.7).

reducing matplotlib2 build-depends.

2019-11-12 Thread peter green
matplotlib2 seems to be an important node in the python2 removal/reduction problem (and the qt4 removal problem). I have noticed there are a substantial number of python module packages that it build-depends on but does not depend on. python-backports.functools-lru-cache python-cairocffi

Re: Policy About Maintainer and Uploaders Fields (was: PAPT: join request)

2019-11-12 Thread Thomas Goirand
On 11/12/19 2:38 AM, Sandro Tosi wrote: > please also realize not everyone shares the > same ideas as yours and you should try sometimes to respect those > people decisions too. With all due respect, the point that I'm trying to make is that this policy is only there because what I believe is a