Bug#976629: ITP: python-build -- Simple, correct PEP517 package builder

2020-12-05 Thread Sergio Durigan Junior
Package: wnpp
Severity: wishlist
Owner: Sergio Durigan Junior 

* Package name: python-build
  Version : 0.1.0
  Upstream Author : Filipe LaĆ­ns 
* URL : https://github.com/pypa/build
* License : Expat
  Programming Lang: Python
  Description : Simple, correct PEP517 package builder

 python-build will invoke the PEP 517 hooks to build a distribution
 package. It is a simple build tool and does not perform any
 dependency management.

I will maintain this package with the Python Team.

-- 
Sergio
GPG key ID: 237A 54B1 0287 28BF 00EF  31F4 D0EB 7628 65FC 5E36
Please send encrypted e-mail if possible
https://sergiodj.net/


signature.asc
Description: PGP signature


Bug#976622: ITP: python3-oscrypto -- cryptography library for Python

2020-12-05 Thread Joseph Nahmias
Package: wnpp
Severity: wishlist

* Package name: python3-oscrypto
  Version : 1.2.1
  Upstream Author : Will Bond 
* URL : https://github.com/wbond/oscrypto
* License : MIT
  Programming Lang: Python
  Description : cryptography library for Python

TLS (SSL) sockets, key generation, encryption, decryption, signing,
verification and KDFs using the OS crypto libraries. Does not require a
compiler, and relies on the OS for patching. Works on Windows, OS X and
Linux/BSD.

I plan to maintain this under the Debian Python Team.

Used by a number of cross-platform projects including for verifying LineageOS
builds.



Re: python3-(py)crypto(dome)?

2020-12-05 Thread Andrey Rahmatullin
On Sat, Dec 05, 2020 at 06:29:32PM +0100, Martin wrote:
> The fix in wokkel should not lead to a problem after the next upload of
> python3-pycryptodome.
I disagree. Currently wokkel clearly has a problem and it's most lilely a
typo. If python3-pycryptodome will be renamed to python3-cryptodome, that
will be a separate matter, and it will most likely be done via a
transition package so wokkel won't need a revert.


-- 
WBR, wRAR


signature.asc
Description: PGP signature


Re: python3-(py)crypto(dome)?

2020-12-05 Thread Martin
On 2020-12-05 19:51, Andrey Rahmatullin wrote:
> On Sat, Dec 05, 2020 at 02:43:44PM +0100, Martin wrote:
> > Package wokkel has changed the dependency from python3-crypto to
> > python3-cryptodome, leading to #975748 and #975770.
> The changelog entry says "Switch to python3-pycryptodome" but the control
> field says "python3-cryptodome". This is a bug in python3-wokkel,
> unrelated to the initial question here.

Related in the sense: If python3-pycryptodome would provide
python3-crypto, the old dependency were correct. If
python3-pycryptodome would be renamed to python3-cryptodome, the
current dependency were correct. The fix in wokkel should not
lead to a problem after the next upload of python3-pycryptodome.
Anyway, if nobody objects, I just upload the fixed wokkel.

Cheers



Re: python3-(py)crypto(dome)?

2020-12-05 Thread Andrey Rahmatullin
On Sat, Dec 05, 2020 at 02:43:44PM +0100, Martin wrote:
> Dears,
> 
> I'm a little confused about what the correct name for the
> binary package python3-pycryptodome should or will be.
Depends on the module name it provides.
So python3-cryptodome, it seems.

> Because https://bugs.debian.org/891619 talks about renaming it
> and/or providing python3-crypto.
If it doesn't provide a "crypto" module it shouldn't be named
python3-crypto.
I don't know what did the reporter mean in their first message.

> Package wokkel has changed the dependency from python3-crypto to
> python3-cryptodome, leading to #975748 and #975770.
The changelog entry says "Switch to python3-pycryptodome" but the control
field says "python3-cryptodome". This is a bug in python3-wokkel,
unrelated to the initial question here.

-- 
WBR, wRAR


signature.asc
Description: PGP signature


python3-(py)crypto(dome)?

2020-12-05 Thread Martin
Dears,

I'm a little confused about what the correct name for the
binary package python3-pycryptodome should or will be.

Because https://bugs.debian.org/891619 talks about renaming it
and/or providing python3-crypto.

Package wokkel has changed the dependency from python3-crypto to
python3-cryptodome, leading to #975748 and #975770.

For now, I would upload wokkel with changed dependency, from
python3-cryptodome to python3-pycryptodome. Any objections?

Cheers