Re: Backport of Python 3.6 for Debian Stretch?

2018-04-25 Thread Nguyễn Hồng Quân
Thank you, Andrey and Jeremy. I didn't know these sites. I will try again. On Wed, Apr 25, 2018 at 9:09 PM, Jeremy Stanley <fu...@yuggoth.org> wrote: > On 2018-04-25 10:06:47 +0700 (+0700), Nguyễn Hồng Quân wrote: > [...] > > I spent much time to research on it, so th

Re: Backport of Python 3.6 for Debian Stretch?

2018-04-24 Thread Nguyễn Hồng Quân
On Wed, Apr 25, 2018 at 7:43 AM, Brian May <b...@debian.org> wrote: > Nguyễn Hồng Quân <ng.hong.q...@gmail.com> writes: > > If using pip to install packages is fine (which can result in compiling > from source although increasing use of wheels helps), then I personally &

Re: Backport of Python 3.6 for Debian Stretch?

2018-04-24 Thread Nguyễn Hồng Quân
On Wed, Apr 25, 2018 at 3:16 AM, Matthew Woodcraft <matt...@woodcraft.me.uk> wrote: > Nguyễn Hồng Quân wrote: > > You didn't say what dependency problem you're seeing. Is it python3.6 > depending on python3-distutils? > ​Yes, and when I tried to backport python3-disutils,

Re: Backport of Python 3.6 for Debian Stretch?

2018-04-24 Thread Nguyễn Hồng Quân
On Wed, Apr 25, 2018 at 12:58 AM, Jeremy Stanley <fu...@yuggoth.org> wrote: > On 2018-04-24 23:42:30 +0700 (+0700), Nguyễn Hồng Quân wrote: > [...] > I completely understand the reason for using packages, but Debian is > a volunteer project which does not exist solely to solve

Re: Backport of Python 3.6 for Debian Stretch?

2018-04-24 Thread Nguyễn Hồng Quân
On Wed, Apr 25, 2018 at 12:21 AM, Andrey Rahmatullin wrote: > > No, you are talking about the 3.6.4 packaging files while I'm suggesting > to not use them. > Do you mean to use " ​​python3.6_3.6.1-1.debian.tar.xz" (of 3.6.1) and change its number to

Re: Backport of Python 3.6 for Debian Stretch?

2018-04-24 Thread Nguyễn Hồng Quân
On Wed, Apr 25, 2018 at 12:05 AM, Andrey Rahmatullin wrote: > > How is this related to my suggestion? > ​Your suggestion is: ​" ​ ​Adapt it from the 3.6.1 one. Replacing the tarball and changing the version in the changelog" ​And I'm proving that it is not enough.​ There

Re: Backport of Python 3.6 for Debian Stretch?

2018-04-24 Thread Nguyễn Hồng Quân
On Tue, Apr 24, 2018 at 11:45 PM, Andrey Rahmatullin wrote: > > > Adapt it from the 3.6.1 one? > > > > > > > ​Excuse me. What do​ ​you mean by "adapt"? > Replacing the tarball and changing the version in the changelog, for a > start. > As I told: "But there is difference in

Re: Backport of Python 3.6 for Debian Stretch?

2018-04-24 Thread Nguyễn Hồng Quân
On Tue, Apr 24, 2018 at 10:19 PM, Jeremy Stanley <fu...@yuggoth.org> wrote: > On 2018-04-24 22:07:03 +0700 (+0700), Nguyễn Hồng Quân wrote: > [...] > > I don't need to "not disturb" system. > > If have to use conda, pyenv, I would rather build Python3.6 from sou

Re: Backport of Python 3.6 for Debian Stretch?

2018-04-24 Thread Nguyễn Hồng Quân
build for Debian stretch. Btw, what I need is just a build/packaging script. I don't need you to build and publish Python3.6 to official repository. -- Quân Nguyễn Hồng Quân ☎ 093 9030 338 Facebook: ng.hong.quan  quan.hoabinh.vn agriconnect.vn

Re: Backport of Python 3.6 for Debian Stretch?

2018-04-24 Thread Nguyễn Hồng Quân
On Tue, Apr 24, 2018 at 5:41 PM, Andrey Rahmatullin <w...@debian.org> wrote: > On Tue, Apr 24, 2018 at 05:27:08PM +0700, Nguyễn Hồng Quân wrote: > > > It's not enough to backport the interpreter, all binary modules will > need > > > to be recompiled too. > >

Re: Backport of Python 3.6 for Debian Stretch?

2018-04-24 Thread Nguyễn Hồng Quân
On Tue, Apr 24, 2018 at 3:12 PM, W. Martin Borgert <deba...@debian.org> wrote: > This is interesting! Did you also compare Python 2.7 with 3.5/3.6? > > ​No, I'm not interested in Python 2. Every my project is started with Python 3.​ -- Quân Nguyễn Hồng Quân ☎ 093 90

Re: Backport of Python 3.6 for Debian Stretch?

2018-04-24 Thread Nguyễn Hồng Quân
. Don't convert python3-xxx to be usable with Python3.6. -- Quân Nguyễn Hồng Quân ☎ 093 9030 338 Facebook: ng.hong.quan  quan.hoabinh.vn agriconnect.vn

Re: Backport of Python 3.6 for Debian Stretch?

2018-04-24 Thread Nguyễn Hồng Quân
org> wrote: > Could you elaborate, why you need Python 3.6 instead of 3.5? > Maybe there is a way to make your application work with 3.5? > E.g. by backporting specific modules? > -- Quân Nguyễn Hồng Quân ☎ 093 9030 338 Facebook: ng.hong.quan  quan.hoabinh.vn agriconnect.vn

Backport of Python 3.6 for Debian Stretch?

2018-04-24 Thread Nguyễn Hồng Quân
Stretch and Buster, so the found script produces *.deb files which are not installable (due to missing dependencies). Could you please provide an official packaging script for Python 3.6 and Debian 9? Thank you. -- Quân Nguyễn Hồng Quân ☎ 093 9030 338 Facebook: ng.hong.quan  quan.hoabinh.vn