Re: Bug#486654: adonthell: FTBFS on arm and armel

2008-07-28 Thread peter green
tags 486654 +patch thanks Rebuilding with gcc-4.2 fails in the same way, so I guess it is due to Python changes. The package builds succesfully on arm (I don't have armel availible to test but I presume the issue is the same on both) with python2.4. I have attatched a patch to make it use

Re: Bug#486654: adonthell: FTBFS on arm and armel

2008-07-27 Thread Martin Michlmayr
* peter green [EMAIL PROTECTED] [2008-06-17 20:48]: *** warning: prefs::read_adonthellrc: creating config file failed Fatal Python error: exceptions bootstrapping error. Something is going wrong with the intitalisation of the embedded python interpreter. What I can't figure out is what and

Re: Bug#486654: adonthell: FTBFS on arm and armel

2008-07-27 Thread Martin Michlmayr
* Martin Michlmayr [EMAIL PROTECTED] [2008-07-27 15:20]: I suggest you ask on an upstream Python list rather than on debian-python. Anyway, given that 0.3.4.cvs.20050813-3 compiled but 0.3.4.cvs.20050813-4 didn't, I guess this is somehow related to gcc-4.3. -- Martin Michlmayr

Re: Bug#486654: adonthell: FTBFS on arm and armel

2008-07-27 Thread peter green
Anyway, given that 0.3.4.cvs.20050813-3 compiled but 0.3.4.cvs.20050813-4 didn't, I guess this is somehow related to gcc-4.3. It looks like the default python version also changed between the two builds from 2.4 to 2.5 so that would be a suspect too. -- To UNSUBSCRIBE, email to [EMAIL

Re: Bug#486654: adonthell: FTBFS on arm and armel

2008-07-27 Thread Martin Michlmayr
* peter green [EMAIL PROTECTED] [2008-07-28 01:47]: 0.3.4.cvs.20050813-4 didn't, I guess this is somehow related to gcc-4.3. It looks like the default python version also changed between the two builds from 2.4 to 2.5 so that would be a suspect too. Rebuilding with gcc-4.2 fails in the