Re: Strange encoding problem in setup.py of biopython 1.71

2018-04-13 Thread Peter Cock
I ended up doing something similar to catch any future problematic characters: https://github.com/biopython/biopython/pull/1607 Peter On Fri, Apr 6, 2018 at 10:36 AM, Peter Cock wrote: > Thanks Andreas, > > Piotr, I think your fix would be worth including in

Re: Strange encoding problem in setup.py of biopython 1.71

2018-04-06 Thread Andreas Tille
Hi Peter, On Thu, Apr 05, 2018 at 04:19:50PM +0100, Peter Cock wrote: > > https://github.com/biopython/biopython/commit/6421d365a511c0de71748737ba6e1cd8518658ac > > Can you pull in that commit as a patch for the Biopython 1.71 package? Thanks. I'm using this as patch. I can confirm that this

Re: Strange encoding problem in setup.py of biopython 1.71

2018-04-05 Thread Peter Cock
Confirmed - not sure if my earlier email made it? https://github.com/biopython/biopython/commit/6421d365a511c0de71748737ba6e1cd8518658ac Can you pull in that commit as a patch for the Biopython 1.71 package? Peter On Thu, Apr 5, 2018 at 3:39 PM, Klaus Zimmermann

Re: Strange encoding problem in setup.py of biopython 1.71

2018-04-05 Thread Klaus Zimmermann
Hi Andreas, here, the culprit is U+2019 : RIGHT SINGLE QUOTATION MARK {single comma quotation mark} that is used as an apostrophe in two places in "Apple's". I found this by looking for 0xe2 (from your error message) in an hexdump (od -A d -xc README.rst |less ) at the named position (7116).

Re: Strange encoding problem in setup.py of biopython 1.71

2018-04-05 Thread Piotr O┼╝arowski
[Andreas Tille, 2018-04-05] > Traceback (most recent call last): > File "setup.py", line 435, in > readme_rst = handle.read() > File "/usr/lib/python3.6/encodings/ascii.py", line 26, in decode > return codecs.ascii_decode(input, self.errors)[0] > UnicodeDecodeError: 'ascii' codec

Re: Strange encoding problem in setup.py of biopython 1.71

2018-04-05 Thread Andreas Tille
Hi Olivier, On Thu, Apr 05, 2018 at 04:19:37PM +0200, Olivier Sallou wrote: > > On 04/05/2018 04:10 PM, Andreas Tille wrote: > > (maybe?) setup.py: > > > > > > ... > > dh_auto_clean > > pybuild --clean -i python{version} -p 2.7 > > I: pybuild base:217: python2.7 setup.py clean > >

Strange encoding problem in setup.py of biopython 1.71

2018-04-05 Thread Andreas Tille
Hi, I imported BioPython version 1.71 into the packaging Git[1] and tried to build it. Unfortunately I'm stumbling upon some encoding problem in (maybe?) setup.py: ... dh_auto_clean pybuild --clean -i python{version} -p 2.7 I: pybuild base:217: python2.7 setup.py clean running clean