Re: Updating Celery, Kombu, python-amqp

2017-03-24 Thread Thomas Goirand
On 03/24/2017 09:30 AM, Brian May wrote: > So if we upgrade python-amqp *and* that (worse case) requires > python-oslo.messaging be upgraded too, that is a lot of packages (listed > below) that *directly* depend on python-oslo.messaging. Eventually we > will have to deal with this, maybe during

Re: Updating Celery, Kombu, python-amqp

2017-03-24 Thread Christopher Hoskin
4.0.2+really3.0.35+dfsg-2 has been accepted into unstable. Hopefully that sorts this mess out for now. Thanks for your patience. Christopher On 24 March 2017 at 11:22, Christopher Hoskin wrote: > Agreed - I didn't know that was an option before. I'll try it this

Re: Updating Celery, Kombu, python-amqp

2017-03-24 Thread Christopher Hoskin
Agreed - I didn't know that was an option before. I'll try it this evening, unless someone beats me to it. Thank you for your help. Christopher On 24 March 2017 at 11:18, Scott Kitterman wrote: > > > On March 24, 2017 4:30:12 AM EDT, Brian May wrote: >

Re: Updating Celery, Kombu, python-amqp

2017-03-24 Thread Scott Kitterman
On March 24, 2017 4:30:12 AM EDT, Brian May wrote: ... >Alternative: maybe I should go to the other plan of uploading the old >version of kombu with an increased epoch? Please use newversion+reallyoldverssion instead of an epoch. It's generally better to avoid epochs for

Re: Updating Celery, Kombu, python-amqp

2017-03-24 Thread Brian May
Michael Fladischer writes: > This seems to be the best way to deal with this. I don't think that > python-amqp 2.x should be uploaded to unstable as it would potentially > break a lot of things in OpenStack. I will wait a little bit in case there is a response to

Re: Updating Celery, Kombu, python-amqp

2017-03-24 Thread Brian May
Christopher Hoskin writes: > I've filed a bug: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=858586 > > Very sorry about this mess. This is what comes of trying to do > something complex and precise late at night after a long day's work :( I can't complain. I

Re: Updating Celery, Kombu, python-amqp

2017-03-24 Thread Michael Fladischer
On 2017-03-24 03:55, Brian May wrote: > * Upload previous Kombu to unstable, using an epoch for the version (and > all subsequent uploads). This seems to be the best way to deal with this. I don't think that python-amqp 2.x should be uploaded to unstable as it would potentially break a lot of

Re: Updating Celery, Kombu, python-amqp

2017-03-24 Thread Brian May
Christopher Hoskin writes: > What worries me is: > > apt-rdepends -r python-amqp I wasn't aware of this command. Thanks for this. If I understand this command correctly, it is showing everything that depends directly and indirectly on python-amqp? Hmm. Looks like

Re: Updating Celery, Kombu, python-amqp

2017-03-24 Thread Christopher Hoskin
I've filed a bug: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=858586 Very sorry about this mess. This is what comes of trying to do something complex and precise late at night after a long day's work :( Christopher

Re: Updating Celery, Kombu, python-amqp

2017-03-24 Thread Christopher Hoskin
What worries me is: apt-rdepends -r python-amqp Reading package lists... Done Building dependency tree Reading state information... Done python-amqp Reverse Depends: python-kombu (>= 3.0.35-1.1) Reverse Depends: python-oslo.messaging (>= 5.10.0-2) python-kombu Reverse Depends: murano-agent

Re: Updating Celery, Kombu, python-amqp

2017-03-24 Thread Brian May
Brian May writes: > * Upload python-amqp 2.1.4 to unstable (plus anything that this > breaks??). I an inclined to think this might be the best option. There are only two packages that depend on python-amqp - that I can see anyway, and one of them is python-kombu. #

Re: Updating Celery, Kombu, python-amqp

2017-03-23 Thread Christopher Hoskin
Presumably it will also run into trouble as python-amqp is at 1.4.9 in unstable, but 2.1.4 from experimental is required. Christopher On 23 March 2017 at 21:19, Brian May wrote: > Christopher Hoskin writes: > >> I've made a mistake, and kombu has

Re: Updating Celery, Kombu, python-amqp

2017-03-23 Thread Brian May
Brian May writes: > Looks like this change has problems, see #858540. Suspect a missing > depends on the vine package. Trying to fix this, I notice it also depends on python{,3}-amqp that only exists in experimental :-( -- Brian May

Re: Updating Celery, Kombu, python-amqp

2017-03-23 Thread Brian May
Christopher Hoskin writes: > I've made a mistake, and kombu has got uploaded to unstable instead of > experimental. (I had experimental in the changelog, but didn't pass > "-d experimental" to sbuild on the final build). I'm very sorry about > this. What is the best

Re: Updating Celery, Kombu, python-amqp

2017-03-22 Thread Brian May
Christopher Hoskin writes: > I've made a mistake, and kombu has got uploaded to unstable instead of > experimental. (I had experimental in the changelog, but didn't pass > "-d experimental" to sbuild on the final build). I'm very sorry about > this. What is the best

Re: Updating Celery, Kombu, python-amqp

2017-03-22 Thread Christopher Hoskin
I've made a mistake, and kombu has got uploaded to unstable instead of experimental. (I had experimental in the changelog, but didn't pass "-d experimental" to sbuild on the final build). I'm very sorry about this. What is the best way to resolve this? Should I file a bug against the

Re: Updating Celery, Kombu, python-amqp

2017-03-20 Thread Scott Kitterman
On Monday, March 20, 2017 07:28:47 AM Christopher Hoskin wrote: ... > A Python 2 package for the vine dependency is currently in the NEW queue. ... It was just accepted. Scott K

Re: Updating Celery, Kombu, python-amqp

2017-03-20 Thread Christopher Hoskin
Thanks for the feedback. I've pushed my debian/experimental branch of python-amqp to Alioth [0] and uploaded it to experimental [1]. Hopefully this is what you had in mind. Please let me know if I've made any mistakes. A Python 2 package for the vine dependency is currently in the NEW queue.

Re: Updating Celery, Kombu, python-amqp

2017-03-20 Thread Michael Fladischer
On 2017-03-17 15:53, Christopher Hoskin wrote: > Thanks - are you happy for me to remove the Python 2 package? > > Otherwise I'll need to add Python 2 packages to some of the new dependencies. I'd like to keep them. Right now popcon indicates that the majority of installations is still using

Re: Updating Celery, Kombu, python-amqp

2017-03-18 Thread Thomas Goirand
On 03/15/2017 09:56 PM, Christopher Hoskin wrote: > On 15 March 2017 at 08:45, Brian May wrote: > >> Your changes looks good to me, I have now made them. FYI, I believe >> anybody can create an account and make changes to the wiki. > > Thanks. I have a wiki account, but the

Re: Updating Celery, Kombu, python-amqp

2017-03-18 Thread Scott Kitterman
On Saturday, March 18, 2017 05:58:49 PM Brian May wrote: > Christopher Hoskin writes: > > python-amqp depends on vine, but when I previously packaged vine[0], I > > only built the python3 package. Is it too soon to start dropping > > python2 packages from uploads

Re: Updating Celery, Kombu, python-amqp

2017-03-18 Thread Brian May
Christopher Hoskin writes: > python-amqp depends on vine, but when I previously packaged vine[0], I > only built the python3 package. Is it too soon to start dropping > python2 packages from uploads intended for Buster? I am hardly any authoritative source for this

Re: Updating Celery, Kombu, python-amqp

2017-03-17 Thread Christopher Hoskin
Thanks - are you happy for me to remove the Python 2 package? Otherwise I'll need to add Python 2 packages to some of the new dependencies. Christopher On 17 March 2017 at 10:36, Michael Fladischer wrote: > On 2017-03-14 04:48, Christopher Hoskin wrote: >> Would people be

Re: Updating Celery, Kombu, python-amqp

2017-03-17 Thread Michael Fladischer
On 2017-03-14 04:48, Christopher Hoskin wrote: > Would people be happy for me to start updating Celery and its dependancies, > uploading the results to experimental, or should I keep my work to myself for > the time being? Please go ahead with any upload to experimental. I was planning to upgrade

Re: Updating Celery, Kombu, python-amqp

2017-03-15 Thread Christopher Hoskin
On 15 March 2017 at 08:45, Brian May wrote: > Your changes looks good to me, I have now made them. FYI, I believe > anybody can create an account and make changes to the wiki. Thanks. I have a wiki account, but the last time I updated the Python/GitPackaging page my edit was

Re: Updating Celery, Kombu, python-amqp

2017-03-14 Thread Christopher Hoskin
Dear Brian, Thanks. I'm new to gbp pq, but beginning to get the hang of it. At the end of https://wiki.debian.org/Python/GitPackagingPQ#Converting_git-dpm_to_gbp_pq I think it would probably be a good idea to add instructions to refresh the patches (and create the patch-queue). Something like:

Re: Updating Celery, Kombu, python-amqp

2017-03-13 Thread Brian May
On 2017-03-14 14:48, Christopher Hoskin wrote: > For reasons of my own, I need to create a Celery 4.0.2 Debian package. This > means also updating the Kombu and AMQP packages. As I'm doing this work > anyway, > my preference would be to share it with the World through DPMT. > > However, I

Updating Celery, Kombu, python-amqp

2017-03-13 Thread Christopher Hoskin
For reasons of my own, I need to create a Celery 4.0.2 Debian package. This means also updating the Kombu and AMQP packages. As I'm doing this work anyway, my preference would be to share it with the World through DPMT. However, I notice that python-amqp has a lot of other reverse dependancies,