pytest 4 and autopkgtest dependency loops

2019-08-09 Thread Scott Talbert
Hi, Ondřej, I saw you uploaded pytest 4. This has caused autopkgtest failures in a few of the packages I maintain, which I've been working on fixing. I think those should be fine once they migrate to testing, as it should clear the autopkgtest failure from pytest 4. However, there's one

Re: pytest 4 and autopkgtest dependency loops

2019-08-09 Thread Graham Inggs
Hi Scott On Fri, 9 Aug 2019 at 18:01, Scott Talbert wrote: > However, there's one package that seems like it is going to cause a > problem. I uploaded pytest-xdist 1.29.0-1, which *requires* pytest 4, so > pytest-xdist won't migrate to testing until pytest 4 does. On the other > hand, pytest 4

Re: pytest 4 and autopkgtest dependency loops

2019-08-09 Thread Scott Talbert
On Fri, 9 Aug 2019, Graham Inggs wrote: However, there's one package that seems like it is going to cause a problem. I uploaded pytest-xdist 1.29.0-1, which *requires* pytest 4, so pytest-xdist won't migrate to testing until pytest 4 does. On the other hand, pytest 4 won't migrate to testing

Re: pytest 4 and autopkgtest dependency loops

2019-08-09 Thread Graham Inggs
On Fri, 9 Aug 2019 at 19:28, Scott Talbert wrote: > Thanks. As an aside, what does the tilde at the end of the version number > mean? I have seen that in control files before, but I've been unable to > find anything in the documentation about it. The tilde is to accommodate backports. e.g. a

Re: pytest 4 and autopkgtest dependency loops

2019-08-09 Thread Felix Zielcke
Am Freitag, den 09.08.2019, 20:05 +0200 schrieb Graham Inggs: > On Fri, 9 Aug 2019 at 19:28, Scott Talbert wrote: > > Thanks. As an aside, what does the tilde at the end of the version > > number > > mean? I have seen that in control files before, but I've been > > unable to > > find anything

Re: pytest 4 and autopkgtest dependency loops

2019-08-09 Thread Ondrej Novy
Hi, pá 9. 8. 2019 v 19:22 odesílatel Graham Inggs napsal: > I believe the solutions is for python-pytest and python3-pytest to add > Breaks: python-pytest-xdist (<< 1.29.0-1~) > and > Breaks: python3-pytest-xdist (<< 1.29.0-1~) > respectively. > right. Prepared in git: