Re: [packaging] wurlitzer

2019-10-22 Thread merkys
On 2019-10-21 18:00, Dmitry Shachnev wrote:
> A downside of this debian/watch is that it only sees the latest tarball,
> but not the historic releases.
>
> I think using one of these two pages will be better:
>
> - https://pypi.org/simple/wurlitzer/
> - https://pypi.debian.net/wurlitzer/

Right, these addresses should be used instead. I wasn't aware of that, thanks 
for pointing out.

Best,
Andrius



Re: [packaging] wurlitzer

2019-10-21 Thread Dmitry Shachnev
Hi all,

On Mon, Oct 21, 2019 at 04:26:10PM +0300, Andrius Merkys wrote:
> On 2019-10-21 16:15, MARIE Alexandre wrote:
> > I tried it as you said but I still get the same error : 
>
> Hmm. The layout on PyPI seems to have changed. Could you try this now?:
>
> version=4
> opts="pgpmode=none" \
>  https://pypi.python.org/pypi/wurlitzer/ \
>  https://files.pythonhosted.org/packages/.*/.*/.*/\
>  wurlitzer-([\d\.]+).tar.gz debian uupdate

A downside of this debian/watch is that it only sees the latest tarball,
but not the historic releases.

I think using one of these two pages will be better:

- https://pypi.org/simple/wurlitzer/
- https://pypi.debian.net/wurlitzer/

--
Dmitry Shachnev


signature.asc
Description: PGP signature


Re: [packaging] wurlitzer

2019-10-21 Thread Andrius Merkys
On 2019-10-21 16:29, MARIE Alexandre wrote:
> This one works perfectly fine, thanks a lot for giving me some time to help !

You're welcome :)

Andrius



RE:[packaging] wurlitzer

2019-10-21 Thread MARIE Alexandre
This one works perfectly fine, thanks a lot for giving me some time to help !

Have a nice day,

Alexandre Marie

De : Andrius Merkys [andrius.mer...@gmail.com]
Envoyé : lundi 21 octobre 2019 15:26
À : debian-python@lists.debian.org
Objet : Re: [packaging] wurlitzer

On 2019-10-21 16:15, MARIE Alexandre wrote:
> I tried it as you said but I still get the same error :

Hmm. The layout on PyPI seems to have changed. Could you try this now?:

version=4
opts="pgpmode=none" \
 https://pypi.python.org/pypi/wurlitzer/ \
 https://files.pythonhosted.org/packages/.*/.*/.*/\
 wurlitzer-([\d\.]+).tar.gz debian uupdate



Re: [packaging] wurlitzer

2019-10-21 Thread Andrius Merkys
On 2019-10-21 16:15, MARIE Alexandre wrote:
> I tried it as you said but I still get the same error : 

Hmm. The layout on PyPI seems to have changed. Could you try this now?:

version=4
opts="pgpmode=none" \
 https://pypi.python.org/pypi/wurlitzer/ \
 https://files.pythonhosted.org/packages/.*/.*/.*/\
 wurlitzer-([\d\.]+).tar.gz debian uupdate



Re: [packaging] wurlitzer

2019-10-21 Thread Andrius Merkys
On 2019-10-21 16:01, MARIE Alexandre wrote:
> Thanks for your fast answer, but I made a mistake when I pasted the error 
> from the bash.
>
> Here is the real error (according to the d/watch file I gave you) :

I see. Have you tried the third PyPI watch file example from the manpage of 
uscan?:

 version=4
 opts="pgpmode=none" \
 https://pypi.python.org/pypi/cfn-sphere/ \
 https://pypi.python.org/packages/.*/.*/.*/\
 cfn-sphere-([\d\.]+).tar.gz#.* debian uupdate

Just replace 'cfn-sphere' with the name of your package.

Best,
Andrius



RE:[packaging] wurlitzer

2019-10-21 Thread MARIE Alexandre
Thanks for your fast answer, but I made a mistake when I pasted the error from 
the bash.

Here is the real error (according to the d/watch file I gave you) :

___

uscan info: uscan (version 2.19.5+deb10u1) See uscan(1) for help
uscan info: Scan watch files in .
uscan info: Check debian/watch and debian/changelog in .
uscan info: package="wurlitzer" version="1.0.3-1" (as seen in debian/changelog)
uscan info: package="wurlitzer" version="1.0.3" (no epoch/revision)
uscan info: ./debian/changelog sets package="wurlitzer" version="1.0.3"
uscan info: Process watch file at: debian/watch
package = wurlitzer
version = 1.0.3
pkg_dir = .
uscan info: opts: 
pasv,repacksuffix=+dfsg1,pgpsigurlmangle=s/$/.asc/,uversionmangle=s/(rc|a|b|c)/~$1/,dversionmangle=s/\+dfsg\d*//
uscan info: line: 
https://www.pypi.org/project/wurlitzer/wurlitzer-((?:[-_]?(\d[\-+\.:\~\da-zA-Z]*)))(?:_src)?(?i)(?:\.(?:tar\.xz|tar\.bz2|tar\.gz|zip|tgz|tbz|txz))
 debian uupdate
uscan info: Parsing pasv
uscan info: Set passive mode: 1
uscan info: Parsing repacksuffix=+dfsg1
uscan info: Parsing pgpsigurlmangle=s/$/.asc/
uscan info: Parsing uversionmangle=s/(rc|a|b|c)/~$1/
uscan info: Parsing dversionmangle=s/\+dfsg\d*//
uscan info: line: 
https://www.pypi.org/project/wurlitzer/wurlitzer-((?:[-_]?(\d[\-+\.:\~\da-zA-Z]*)))(?:_src)?(?i)(?:\.(?:tar\.xz|tar\.bz2|tar\.gz|zip|tgz|tbz|txz))
 debian uupdate
uscan info: Last orig.tar.* tarball version (from debian/changelog): 1.0.3
uscan info: Last orig.tar.* tarball version (dversionmangled): 1.0.3
uscan info: Requesting URL:
   https://www.pypi.org/project/wurlitzer/
uscan info: redirections: https://pypi.org/project/wurlitzer/
uscan info: Matching pattern:
   
(?:(?:https://www.pypi.org)?\/project\/wurlitzer\/)?wurlitzer-((?:[-_]?(\d[\-+\.:\~\da-zA-Z]*)))(?:_src)?(?i)(?:\.(?:tar\.xz|tar\.bz2|tar\.gz|zip|tgz|tbz|txz))
 
(?:(?:https://pypi.org)?\/project\/wurlitzer\/)?wurlitzer-((?:[-_]?(\d[\-+\.:\~\da-zA-Z]*)))(?:_src)?(?i)(?:\.(?:tar\.xz|tar\.bz2|tar\.gz|zip|tgz|tbz|txz))
uscan warn: In debian/watch no matching files for watch line
  
https://www.pypi.org/project/wurlitzer/wurlitzer-((?:[-_]?(\d[\-+\.:\~\da-zA-Z]*)))(?:_src)?(?i)(?:\.(?:tar\.xz|tar\.bz2|tar\.gz|zip|tgz|tbz|txz))
 debian uupdate
___

Have a good day,

Alexandre Marie

De : Andrius Merkys [andrius.mer...@gmail.com]
Envoyé : lundi 21 octobre 2019 14:53
À : debian-python@lists.debian.org
Objet : Re: [packaging] wurlitzer

Hi Alexandre,

On 2019-10-21 15:47, MARIE Alexandre wrote:
> @PACKAGE@-@ANY_VERSION@(?:_src)?@ARCHIVE_EXT@ debian uupdate

Try putting @ANY_VERSION@ inside parenthesis:

@PACKAGE@-(@ANY_VERSION@)(?:_src)?@ARCHIVE_EXT@ debian uupdate

Hope this helps,
Andrius



Re: [packaging] wurlitzer

2019-10-21 Thread Andrius Merkys
Hi Alexandre,

On 2019-10-21 15:47, MARIE Alexandre wrote:
> @PACKAGE@-@ANY_VERSION@(?:_src)?@ARCHIVE_EXT@ debian uupdate

Try putting @ANY_VERSION@ inside parenthesis:

@PACKAGE@-(@ANY_VERSION@)(?:_src)?@ARCHIVE_EXT@ debian uupdate

Hope this helps,
Andrius