Bug#895419: Acknowledgement (python3-dolfin: JIT compilation fails as python3-instant tries to includes petsc4py from python2)

2018-04-13 Thread Nico Schlömer
I've had that issue in the past, but never bothered looking into it. Me, I'll hold out for 2018.1 (which kills Python 2 support) to fix these kind of bugs. Cheers, Nico On Fri, Apr 13, 2018 at 4:54 PM Fabrice Silva wrote: > Additional information from Johannes Ring

Re: vtk7_7.1.1+dfsg1-1~exp1_amd64.changes REJECTED

2018-04-04 Thread Nico Schlömer
Whoop whoop! Thanks everyone! [1] https://packages.debian.org/experimental/libvtk7-dev On Tue, Apr 3, 2018 at 11:55 PM Chris Lamb wrote: > Hi Gert et al., > > Thanks again for re-uploading; I have just ACCEPTed it. > > > [I] replicated here what I did, kind of to acknowledge

Re: vtk7_7.1.1+dfsg1-1~exp1_amd64.changes REJECTED

2018-03-29 Thread Nico Schlömer
Wait, VTK7 is no longer in NEW [1]. Does anyone know what happened? Cheers, Nico [1] https://ftp-master.debian.org/new.html On Wed, Mar 7, 2018 at 1:28 PM Gert Wollny <gw.foss...@gmail.com> wrote: > Am Dienstag, den 06.03.2018, 21:37 + schrieb Nico Schlömer: > > Perhaps it'

Re: vtk7_7.1.1+dfsg1-1~exp1_amd64.changes REJECTED

2018-03-06 Thread Nico Schlömer
Perhaps it's time to bring this up again. At six months in the queue, VTK7 has been the leader in the NEW queue for a while now. It'd be great if we could work on this again, particularly since VTK8 is already out there. Cheers, Nico On Thu, Nov 9, 2017 at 10:56 AM Gert Wollny

Bug#890364:

2018-02-21 Thread Nico Schlömer
I depend on this as well. As a stop-gap measure, I've set of a PPA [1]. Cheers, Nico [1] https://launchpad.net/~nschloe/+archive/ubuntu/pybind11-backports/ -- debian-science-maintainers mailing list debian-science-maintainers@lists.alioth.debian.org

Accepted trilinos 12.12.1-5 (source) into unstable

2018-02-05 Thread Nico Schlömer
libtrilinos-zoltan12 libtrilinos-zoltan-dev libtrilinos-zoltan2-12 libtrilinos-zoltan2-dev trilinos-doc Architecture: source Version: 12.12.1-5 Distribution: unstable Urgency: medium Maintainer: Debian Science Maintainers <debian-science-maintainers@lists.alioth.debian.org> Changed-By

Bug#881881: libtrilinos-kokkos-kernels-dev: fails to upgrade from 'testing' - trying to overwrite /usr/include/trilinos/Kokkos_ArithTraits.hpp

2017-11-17 Thread Nico Schlömer
Ah, yes, these files seem to have moved from Tpetra to Kokkos. These two upstream packages are tightly related, so no surprise there. I'll see if I can get this fixed. Cheers, Nico On Thu, Nov 16, 2017 at 2:15 AM Andreas Beckmann wrote: > Package:

Bug#881873: trilinos: FTBFS on sparc64: Bus errors in 11 tests

2017-11-17 Thread Nico Schlömer
Chances are slim for to ever be resolved. Upstream only supports amd64, and PRs to fix building for other architectures are rejected. (See, e.g., [1].) I'd say we'll have to live with trilinos not running on sparc64. Cheers, Nico [1] https://github.com/kokkos/kokkos/pull/576 On Thu, Nov 16,

Re: gmsh update

2017-10-26 Thread Nico Schlömer
gt; the libname to libgmsh3. > > Cheers > > Anton > > > 2017-10-26 14:07 GMT+02:00 Nico Schlömer <nico.schloe...@gmail.com>: > > Hi Anton, > > > > Just returning from holidays here. I trust you managed to work around the > > issue? > > > > Bt

Re: gmsh update

2017-10-26 Thread Nico Schlömer
ll now abort, > ... > == > > There are some more errors. I think we had some similar problems with MPI, > running under the fakeroot. But I am not able to find a quick solution > for this issue now. > > Best regards > > Anton > > > 2

Re: gmsh update

2017-09-22 Thread Nico Schlömer
th oce and gmsh. > Oce is in experimental and requires transition process, which > is not started because not all reverse dependencies can be > built against 0.18. Hopefully will be fixed soon. > > Cheers > > Anton > > > 2017-09-22 18:50 GMT+02:00 Nico Schlömer <nico.

gmsh update

2017-09-22 Thread Nico Schlömer
Hi everyone, I did some work on Gmsh 3.* which should hopefully soon be ready for prime time. One thing I've had to disable for now is OpenCascade support; Gmsh requires 6.9.1 which is wrapped in OCE 0.18, but the latter is still only in experimental [1] (and has the ~exp extension, whatever that

Bug#868523: FTBFS: test failed 617 ML_MLP_NonSym_MPI_4, 668 Phalanx_dag_manager_MPI_1

2017-07-24 Thread Nico Schlömer
n 24/07/2017 10:40, Nico Schlömer wrote: > > Sounds more like a gAM bug then. Can this be closed? > > I intentionally didn't close this bug because the tests still fail if > they are enabled. > > If the problem is caused by another package, then this bug should be > r

Bug#868873: dependence on libmumps-4.10.0 _AND_ libmumps-5.1.1 breaks make

2017-07-24 Thread Nico Schlömer
Thanks, Graham, for the analysis. It appears that with 12.10.1-4 we're on top of things, so I guess this can be closed. Cheers, Nico On Sun, Jul 23, 2017 at 9:51 PM Graham Inggs <gin...@debian.org> wrote: > On 23 July 2017 at 18:07, Nico Schlömer <nico.schloe...@gmail.com> wrote

Bug#868523: FTBFS: test failed 617 ML_MLP_NonSym_MPI_4, 668 Phalanx_dag_manager_MPI_1

2017-07-24 Thread Nico Schlömer
> Still comes out corrupted in the gnome Archive Manager, but extracts fine on the command line. Sounds more like a gAM bug then. Can this be closed? Cheers, Nico On Mon, Jul 17, 2017 at 4:33 AM Drew Parsons wrote: > On Mon, 17 Jul 2017 10:21:03 +0800 Drew Parsons

Bug#868873: dependence on libmumps-4.10.0 _AND_ libmumps-5.1.1 breaks make

2017-07-23 Thread Nico Schlömer
Hm, funny! I don't get how libtrilinos-amesos12 should depend on libmumps-4.10.0 when 5.1.1 is available. I've rebuild this on ubuntu artsy [1] and it selects all the right versions. Perhaps this got corrupted in the transition somehow? We've recently uploaded 12.10.1-4, perhaps this rebuild will

Bug#868894: find_package option COMPONENTS ineffective because of hard-coded includes in TrilinosConfig.cmake

2017-07-23 Thread Nico Schlömer
Thanks, Joachim, for the report! This definitely sounds like an upstream bug. Would you mind reporting it on [1]? Together with the Trilinos devs, we'll be able to take it from there. That being said, at first glance the inclusion of the subpackage configs doesn't seem to override anything. I'd

Bug#868523: FTBFS: test failed 617 ML_MLP_NonSym_MPI_4, 668 Phalanx_dag_manager_MPI_1

2017-07-16 Thread Nico Schlömer
I've disabled the phalanx tests in master, and also fixed two other things. Perhaps it's time for an upload? Cheers, Nico On Sun, Jul 16, 2017 at 2:16 PM Nico Schlömer <nico.schloe...@gmail.com> wrote: > The issue was reported to upstream in May [1]. I think until we get a fix, &g

Bug#868523: FTBFS: test failed 617 ML_MLP_NonSym_MPI_4, 668 Phalanx_dag_manager_MPI_1

2017-07-16 Thread Nico Schlömer
The issue was reported to upstream in May [1]. I think until we get a fix, it's best to disable that specific test. Cheers, Nico [1] https://github.com/trilinos/Trilinos/issues/1332 On Sun, Jul 16, 2017 at 1:51 PM Graham Inggs wrote: > On 16 July 2017 at 13:12, Drew

Bug#864779: Epetra doc missing

2017-06-15 Thread Nico Schlömer
Let me add also that Epetra isn't that important anymore. Trilinos devs try to get people to switch over to Tpetra, and in fact Epetra hasn't seen substantial development in many years now. Cheers, Nico On Thu, Jun 15, 2017 at 5:22 PM Nico Schlömer <nico.schloe...@gmail.com> wrote: &g

Bug#864779: Epetra doc missing

2017-06-15 Thread Nico Schlömer
Thanks Joachim for report. This is more of an upstream issue, see [1]. Once that is done, the package will have the Epetra documentation shipped. Cheers, Nico [1] https://github.com/trilinos/Trilinos/issues/1431 On Wed, Jun 14, 2017 at 6:42 PM Joachim Wuttke wrote: >

Bug#862111: python-slepc4py: Python 3 support

2017-05-08 Thread Nico Schlömer
Package: python-slepc4py Version: 3.7.0-2build3 Severity: wishlist slepc4py is compatible with Python 3.2 and up (see [1]), and it'd be nice to this reflected in the package. [1] https://bitbucket.org/slepc/slepc4py -- System Information: Debian Release: stretch/sid APT prefers

Bug#862110: python-petsc4py: Python 3 support

2017-05-08 Thread Nico Schlömer
Package: python-petsc4py Version: 3.7.0-2build1 Severity: wishlist petsc4py is compatible with Python 3.2 and up (see [1]) and it'd be nice to see this reflected in the package. [1] https://bitbucket.org/petsc/petsc4py -- System Information: Debian Release: stretch/sid APT prefers

Bug#810254:

2017-04-14 Thread Nico Schlömer
Hi everyone, I did some work on this in the last few days and I got to something. As requested, it's all committed to the vtk6 repo (and also available from [1]). As far as I can tell, it's all in good order. I'm already running a bunch of applications against it with no nasty surprises so far.

Bug#854624: fenics: vcs information incorrect

2017-02-08 Thread Nico Schlömer
Package: fenics Version: 1:2016.2.0.1~ppa1~yakkety Severity: minor Tags: newcomer Dear Maintainer, on [1], the VCS is still listed as SVN and has a dysfunctional link. This should be updated to the new Git repo (in debian/control). Cheers, Nico [1] https://tracker.debian.org/pkg/fenics --

Bug#810254:

2017-02-04 Thread Nico Schlömer
gt; > thanks for your contribution! We will definitely upload VTK7 after > Stretch will be released. Feel free to commit into the alioth > into the vtk7-branch. > > Best regards > > > Anton > > 2017-02-04 10:54 GMT+01:00 Nico Schlömer <nico.schloe...@gmail.com>: >

Bug#810254:

2017-02-04 Thread Nico Schlömer
Alright, so I've spend last night packaging VTK7 (nightly master) [1]. It's basically a clone of the vtk6 package with a bunch of fixes. Will have to be tested some more, but for certain it's already a better-than-nothing. Comments and PRs are more than welcome; the code is on GitHub [2].

Bug#853686: trilinos: ftbfs with GCC-7

2017-01-31 Thread Nico Schlömer
I see now that you've already filed one for Debian as well [1]. Cheers, Nico [1] https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=853679 On Tue, Jan 31, 2017 at 12:11 PM Nico Schlömer <nico.schloe...@gmail.com> wrote: > Thanks Matthias for reporting. > > This looks like a TBB er

Bug#853686: trilinos: ftbfs with GCC-7

2017-01-31 Thread Nico Schlömer
Thanks Matthias for reporting. This looks like a TBB error; I've filed a bug at [1]. Cheers, Nico [1] https://github.com/01org/tbb/issues/12 On Tue, Jan 31, 2017 at 10:52 AM Matthias Klose wrote: > Package: src:trilinos > Version: 12.10.1-3 > Severity: normal > Tags: sid

Bug#848770: trilinos: FTBFS: Test failures

2016-12-19 Thread Nico Schlömer
Thanks Lucas for the report. A new version (12.10.1-2) has already been submitted to NEW, fixing the test failures. Cheers, Nico On Mon, Dec 19, 2016 at 10:43 PM Lucas Nussbaum wrote: > Source: trilinos > Version: 12.10.1-1 > Severity: serious > Tags: stretch sid > User:

Bug#835406: trilinos: FTBFS on 32-bit architectures

2016-12-09 Thread Nico Schlömer
rg> wrote: > On 9 December 2016 at 09:49, Nico Schlömer <nico.schloe...@gmail.com> > wrote: > > The patch looks really simple. Great! Do you think it'd be worthwhile > > updating the PR [1] (or opening a new one)? Perhaps the kokkos devs can > > figure out why th

Bug#835406: trilinos: FTBFS on 32-bit architectures

2016-12-08 Thread Nico Schlömer
The patch looks really simple. Great! Do you think it'd be worthwhile updating the PR [1] (or opening a new one)? Perhaps the kokkos devs can figure out why the remaining tests are failing. Cheers, Nico [1] https://github.com/kokkos/kokkos/pull/410 On Fri, Dec 9, 2016 at 8:18 AM Graham Inggs

Bug#835406: trilinos: FTBFS on 32-bit architectures

2016-08-29 Thread Nico Schlömer
t 2016 at 21:55, Nico Schlömer <nico.schloe...@gmail.com> > wrote: > > When uploading, we could perhaps also include the point release 12.6.4. > > (Current Debian is 12.6.3.) > > Sure, let's do that. > > Do you have time now to prepare 12.6.4 for upload? I can reba

Bug#835406: trilinos: FTBFS on 32-bit architectures

2016-08-29 Thread Nico Schlömer
> I have successfully built trilinos on i386 and armhf, This is amazing! We can certainly upstream those patches, too. When uploading, we could perhaps also include the point release 12.6.4. (Current Debian is 12.6.3.) Cheers, Nico On Mon, Aug 29, 2016 at 5:09 PM Graham Inggs

Bug#831790: fenics: version bump (2016.1.0)

2016-07-19 Thread Nico Schlömer
Package: fenics Version: version bump Severity: wishlist FEniCS 2016.1.0 has been released recently (cf. https://fenicsproject.org/download/); note that the versioning scheme has changed. Bump in Debian, please. -- System Information: Debian Release: stretch/sid APT prefers xenial-updates

Bug#831788: OSError: libmpi.so.1: cannot open shared object file: No such file or directory

2016-07-19 Thread Nico Schlömer
Package: python-gmsh Version: 2.10.1+dfsg1-1ubuntu4 Severity: normal Dear Maintainer, The python-gmsh appears to be broken: ``` $ python -c "import gmshpy" Traceback (most recent call last): File "", line 1, in File "/usr/lib/python2.7/dist-packages/gmshpy/__init__.py", line 3, in mpi

Bug#830681: trilinos-all-dev: Updating binutils breaks trilinos

2016-07-18 Thread Nico Schlömer
I've tested and pushed a build without binutils. @Graham, would you like to upload? Cheers, Nico On Mon, Jul 18, 2016 at 1:26 PM Felix Salfelder <fe...@salfelder.org> wrote: > On Mon, Jul 18, 2016 at 11:18:30AM +0000, Nico Schlömer wrote: > > [binutils] just turn it off > &

Bug#830681: trilinos-all-dev: Updating binutils breaks trilinos

2016-07-18 Thread Nico Schlömer
The binutils support in trilinos is far from being critical, so I'd say for making things a little easier we just turn it off. @Felix Agreed? Cheers, Nico On Fri, Jul 15, 2016 at 12:15 AM Helmut Grohne wrote: > On Sun, Jul 10, 2016 at 01:04:13PM +0200, Felix Salfelder

Bug#825824: libmumps-dev: MUMPS 5.0.1 version bump

2016-05-30 Thread Nico Schlömer
Package: libmumps-dev Version: 4.10.0.dfsg-4 Severity: wishlist MUMPS 5.0.1 has been released a while ago. Please bump. -- System Information: Debian Release: stretch/sid APT prefers xenial-updates APT policy: (500, 'xenial-updates'), (500, 'xenial-security'), (500, 'xenial'), (100,

Bug#822255: python-dolfin: remove dependency on python-numpy

2016-04-22 Thread Nico Schlömer
Package: python-dolfin Severity: normal Dear Maintainer, python-dolfin depends on the unmaintained python-netcdf. Keeping the dependency has serious implications. For example, since python-netcdf is no longer included in Ubuntu 16.04, so isn't FEniCS. For this reason, please consider removing

Bug#805010: VTK 6.3.0 released

2015-11-13 Thread Nico Schlömer
Source: vtk6 Severity: wishlist Dear Maintainer, VTK 6.3.0 has been released on Sep 10, 2015 [1]. Please bump. Cheers, Nico [1] http://www.kitware.com/blog/home/post/963 -- System Information: Debian Release: jessie/sid APT prefers wily-updates APT policy: (500, 'wily-updates'), (500,

Bug#789169: libvtk6-dev: fix upstream Xdmf3 build bug

2015-07-31 Thread Nico Schlömer
-source was dropped from Debian for vtk6_6.2.0, so I am not able to apply the patch. But it looks like release candidate of vtk6 is already available. So your patch will be there. Thus I am reducing the bug`s severity. Thanks Anton 2015-06-18 7:30 GMT-07:00 Nico Schlömer nico.schloe

Re: Trilinos packages

2014-03-27 Thread Nico Schlömer
us; it also serves me well as a test bed for changes in debian/. Cheers, Nico On Wed, Mar 26, 2014 at 5:03 PM, Felix Salfelder fe...@salfelder.org wrote: On Wed, Mar 26, 2014 at 10:22:23AM +0100, Nico Schlömer wrote: I would suggest to first go with a monolithic package and split it up

Re: Trilinos packages

2014-03-26 Thread Nico Schlömer
if we can get in more of those before the next release freeze. I'll keep you all posted. Cheers, Nico On Tue, Mar 18, 2014 at 12:56 PM, Felix Salfelder fe...@salfelder.org wrote: On Tue, Mar 18, 2014 at 12:15:49PM +0100, Nico Schlömer wrote: A quick poll on the Trilinos package naming

Re: Trilinos packages

2014-03-18 Thread Nico Schlömer
, Anton Gladky gl...@debian.org wrote: Hi Nico, I have built locally your package. But if you run lintian over .changes file, it gives a lot of errors and warnings. Please, deal with them. Thanks Anton 2014-03-10 16:35 GMT+01:00 Nico Schlömer nico.schloe...@gmail.com: Did you repack

Re: Trilinos packages

2014-03-10 Thread Nico Schlömer
Strange, libparmetis-dev should be in jessie, cf. https://packages.debian.org/jessie/libparmetis-dev. --Nico On Mon, Mar 10, 2014 at 10:22 AM, Felix Salfelder fe...@salfelder.org wrote: On Sat, Mar 08, 2014 at 12:39:57AM +0100, Nico Schlömer wrote: 1) Set VCS=fields 2) Standards-Version

Re: Trilinos packages

2014-03-10 Thread Nico Schlömer
. Are there general Debian guidelines for such situations? What's your opinion on this? --Nico On Mon, Mar 10, 2014 at 11:23 AM, Felix Salfelder fe...@salfelder.org wrote: On Mon, Mar 10, 2014 at 10:52:19AM +0100, Nico Schlömer wrote: Strange, libparmetis-dev should be in jessie, cf. https

Re: Trilinos packages

2014-03-10 Thread Nico Schlömer
I checked all other dependencies manually and found that libparmetis-dev was the only thing from non-free. I removed it from the list; please retry building. --Nico On Mon, Mar 10, 2014 at 12:27 PM, Nico Schlömer nico.schloe...@gmail.com wrote: my recommendation is to disable parmetis

Re: Trilinos packages

2014-03-10 Thread Nico Schlömer
on the website and in pristine-tar branch is not the same. Anton 2014-03-10 13:51 GMT+01:00 Nico Schlömer nico.schloe...@gmail.com: I checked all other dependencies manually and found that libparmetis-dev was the only thing from non-free. I removed it from the list; please retry building

Re: Trilinos packages

2014-03-10 Thread Nico Schlömer
. This should fix your error, please retry. --Nico On Mon, Mar 10, 2014 at 3:02 PM, Felix Salfelder fe...@salfelder.org wrote: On Mon, Mar 10, 2014 at 01:51:24PM +0100, Nico Schlömer wrote: I checked all other dependencies manually and found that libparmetis-dev was the only thing from non-free

Re: Trilinos packages

2014-03-10 Thread Nico Schlömer
Did you repack it? Nope. For creating the printine-tar branch, I used the --git-pristine-tar option as described on https://wiki.debian.org/PackagingWithGit#pristine-tar. --Nico On Mon, Mar 10, 2014 at 4:30 PM, Anton Gladky gl...@debian.org wrote: 2014-03-10 16:25 GMT+01:00 Nico Schlömer

Re: Trilinos packages

2014-03-07 Thread Nico Schlömer
confortable with git we may move to Debian Science git repository. Git would be great. --Nico On Fri, Mar 7, 2014 at 11:36 AM, trophime christophe.troph...@lncmi.cnrs.fr wrote: On Fri, 2014-03-07 at 11:21 +0100, Nico Schlömer wrote: Hi all, I've noticed that Trilinos for Debian is dead now

Re: Trilinos packages

2014-03-07 Thread Nico Schlömer
me. [1] http://lists.alioth.debian.org/pipermail/debian-science-maintainers/2013-April/017553.html [2] http://debian-science.alioth.debian.org/debian-science-policy.html Regards Anton 2014-03-07 11:21 GMT+01:00 Nico Schlömer nico.schloe...@gmail.com: Hi all, I've noticed that Trilinos

Re: Trilinos packages

2014-03-07 Thread Nico Schlömer
with lintian. I will upload it shortly. Anton 2014-03-07 22:20 GMT+01:00 Nico Schlömer nico.schloe...@gmail.com: I hadn't, but I now found https://wiki.debian.org/PackagingWithGit which I now followed. upstream and pristine-tar are now in place. --Nico On Fri, Mar 7, 2014 at 6:40 PM