Re: Em podeu donar un cop de ma amb un bug?

2019-01-14 Conversa Robert Marsellés



El 12/1/19 a les 12:40, a...@probeta.net ha escrit:
> Bon dia a tothom,
> 
> Fa molt de temps que em barallo amb un bug, que intento acorralar, però
> no hi ha manera.
> 
> Afecta a Debian Testing en el sistema gràfic, i aquí em veig molt
> perdut, entre controladors, servidors de finestres, gestors de
> finestres, compositors, mesas, cairos, egl, etc.

[...]
> 
> Crec que el bug afecta a molta gent, i que alguns missatges que es poden
> 

[...]

> 
> Treballo amb targeta gràfica [AMD/ATI] Turks XT [Radeon HD 6670/7670] a
> Debian Testing, actualment amb nucli 4.19
> 
> Fins al nucli 4.13 tot anava bé, però en actualitzar al nucli 4.14
> l’escriptori Gnome es «congelava» cada pocs minuts. A tots els següents
> nuclis fins el 4.19 el problema persisteix. A aquest enllaç hi ha els
> canvis que aporta el nucli 4.14 a Radeon, però no els sé interpretar:
> https://kernelnewbies.org/Linux_4.14#Graphics
> 
>  Pista: Es congelava Gnome amb Xorg, però no Gnome amb Wayland
> 

Jo també en tinc un de llarga durada i uso Debian Testin g des d'uns 3 -
4 mesos després del darrer canvi d'estable (juny o juliol 2017). El
primer nucli que vaig usar tot anava bé. A partir del següent (no
recordo quin) van començar els maldecaps.

El meu hardware no té rés a veure amb el teu. Tot i això, els problemes
que descrius són força similars als que a mi m'afecten i, en el meu cas,
estan relacionats amb la targeta gràfica [1,2].

De vegades ni tant sols es carregava el sistema gràfic. D'altres no
podia canviar entre entorn gràfic o no (usant CTRL+ALT+n), d'altres és
"gelava" la imatge, d'altres és bloquejava mentre parava la maquina.

L'únic en comú entre la multitud de diverses marques de proveïdors de
portàtils afectats sembla ser el fet de tenir el sistema gràfic integrat
Intel + targeta gràfica dedicada NVIDIA (diversos models):

$ lspci | egrep "VGA|3D"
00:02.0 VGA compatible controller: Intel Corporation HD Graphics 630
(rev 04)
01:00.0 3D controller: NVIDIA Corporation GP107M [GeForce GTX 1050 Ti
Mobile] (rev a1)


>
>  Pista: no es congelava XFCE
> 

Únicament he provat GNOME. Als "bugs" que jo he revisat no importa gaire
l'entorn gràfic usat però hi ha majoria de GNOMEs. Suposo que el motiu
és que és l'entorn majoritari.

>  Pista: fent CTRL+ALT+F8 i després CTRL+ALT+F7 tot tornava a funcionar
> 

No ho vaig provar això.

[...]

> 
> No sé ni per on començar. Algun consell?
> 

Jo vaig provar altres coses. Al final, solament funciona bé modificar
les opcions del nucli a /etc/default/grub. Concretament, jo tinc:

GRUB_CMDLINE_LINUX_DEFAULT="acpi_osi=!"

hi ha gent que ho combina amb diferents versions de Windows:

"acpi_osi='Windows '"

he vist molts 2009 i 2015 però altres també. Tots amb resultats
diversos. Jo vaig provar-ho amb 2009 i funciona de la mateixa manera que
sense.

Totes les noves versions del nucli que han sortit a Testing les provo
sense les opcions de nucli i es tornen a reproduir els problemes.

Salut i peles,

robert

[1] https://bugzilla.kernel.org/show_bug.cgi?id=156341
[2] https://github.com/Bumblebee-Project/Bumblebee/issues/764



Re: Em podeu donar un cop de ma amb un bug?

2019-01-14 Conversa Ernest Adrogué
Àlex  writes:
> Sí així vaig fer. Vaig descarregar el nucli 4.9 de la Debian estable i
> el vaig instal.lar, i quan vull veure vídeo arrenco amb aquest nucli.
> Des de la versió 4.14 a la 4.19 la cosa ha anat malament i no sé si amb
> el temps es corregirà, però sempre puc canviar de hardware gràfic.
>
> A internet vaig llegir usuaris de Linux amb problemes semblants que
> comentaven que encara guardaven la partició de Windows per poder veure
> vídeos, i em va sabre greu.

A vegades hi ha algun problema, però en general les targetes AMD estan
ben suportades a Linux.  Un dels motius és que AMD col·labora amb els
programadors dels drivers oberts, a diferència d'altres fabricants.

Fa bastant temps vaig tenir un problema semblant al teu.  Al final els
de Xfce em van recomanar que utilitzés el driver X11 "modesetting" en
lloc del "radeon", i es va solucionar.  Tampoc tinc gaire idea de com
funciona el sistema gràfic de Linux, però em sembla entendre que
actualment el driver de X11 és un driver genèric per a totes les
targetes (el tal "modesetting"), i el driver específic per a cada
targeta ara es troba integrat en el kernel.  L'usuari no ha de
configurar res.  Si ho tens de l'altra manera, es van trencant coses
perquè els drivers antics de X11 actualment ja no es desenvolupen.



Re: Em podeu donar un cop de ma amb un bug?

2019-01-14 Conversa Eduard Selma

El 14/1/19 a les 13:09, Àlex ha escrit:


El teu hardware gràfic és Radeon?


- Sí, és el AMD/ATI Richland (Radeon HD 8670D). Està integrat amb la 
CPU: Quad Core AMD A10-6800K, és el que anomenen APU. Deu ser del 2013 o 
14, tecnologia de 32 nm. Res de darrera generació. Evidenment, és un 
model diferent del teu.


Cordialment,

Eduard Selma.



Re: Em podeu donar un cop de ma amb un bug?

2019-01-14 Conversa Àlex
El 12/1/19 a les 18:33, Eduard Selma ha escrit:
> El 12/1/19 a les 12:40, a...@probeta.net ha escrit:
>> Bon dia a tothom,
>>
>> Fa molt de temps que em barallo amb un bug, que intento acorralar,
>> però no hi ha manera.
>>
>> Afecta a Debian Testing en el sistema gràfic, i aquí em veig molt
>> perdut, entre controladors, servidors de finestres, gestors de
>> finestres, compositors, mesas, cairos, egl, etc.
>
> - No crec que t'ajudi gaire, només són més dades... (i potser més
> "soroll"):
>
> Treballo amb Debian 9.6 (Stretch, stable) però amb nucli
> 4.17.0-0.bpo.3-amd64 (el que instal·la per omissió Neptune). El
> servidor gràfic és X.Org 1.19.6, gestor de finestres i compositor
> kwin-X11. L'Open GL és AMD ARUBA (DRM 2.50.0 / 4.17.0-0.bpo.3-amd64
> LLVM 6.0.0) v: 4.3 Mesa 18.2.6.
>
> El meu entorn d'escriptori és KDE/Plasma Frameworks 5.45.0 amb Qt 5.7.1.
>
> No uso cap altre compositor, panels virguers, ni rés més quant a
> gràfics. El meu reproductor VLC és el 3.0.3.
>
> Fins ara, no he observat el fenomen que ens descrius. 


Gràcies Eduard


El teu hardware gràfic és Radeon?


Salutacions



    Àlex



Re: Em podeu donar un cop de ma amb un bug?

2019-01-14 Conversa Àlex
> Pel que dius, semblaria un problema del compositor, que no actualitza
> l'estat de la pantalla correctament.  Ara bé, si et passa amb Gnome i
> també amb Xfce, que utilitzen compositors diferents, aleshores m'inclino
> a pensar que és una altra cosa.


Sí, i amb Gnome amb Xorg es congelava tot l'escriptori i amb Gnome amb
Wayland no. Tot molt estrany.


La pròxima trobada Debian, si algú s'anima a fer una xerrada tècnica per
explicar tots els elements que formen el sistema gràfic de Linux, jo ho
agrairé molt.



> Probablement és més pràctic tornar a una versió anterior que saps que
> funciona i posar-la en estat "hold", i esperar que solucionin el
> problema a les versions més recents.


Sí així vaig fer. Vaig descarregar el nucli 4.9 de la Debian estable i
el vaig instal.lar, i quan vull veure vídeo arrenco amb aquest nucli.
Des de la versió 4.14 a la 4.19 la cosa ha anat malament i no sé si amb
el temps es corregirà, però sempre puc canviar de hardware gràfic.

A internet vaig llegir usuaris de Linux amb problemes semblants que
comentaven que encara guardaven la partició de Windows per poder veure
vídeos, i em va sabre greu.

A mi, que m'agrada buscar bugs, m'ha servit per no asumir que quan una
aplicació es "congela" es l'aplicació, sino que l'aplicació pot no estar
congelada i es tracta del sistema gràfic de Linux que ha deixat de
renovar el contingut de la finestra o de tot l'escriptori.


Salut





Re: Em podeu donar un cop de ma amb un bug?

2019-01-13 Conversa Ernest Adrogué
Hola,

2019-01-12, 12:40 (+0100); a...@probeta.net escriu:
> Fins al nucli 4.13 tot anava bé, però en actualitzar al nucli 4.14
> l’escriptori Gnome es «congelava» cada pocs minuts. A tots els següents
> nuclis fins el 4.19 el problema persisteix. A aquest enllaç hi ha els canvis
> que aporta el nucli 4.14 a Radeon, però no els sé interpretar:
> https://kernelnewbies.org/Linux_4.14#Graphics
> 
>  Pista: Es congelava Gnome amb Xorg, però no Gnome amb Wayland
> 
>  Pista: no es congelava XFCE
> 
>  Pista: fent CTRL+ALT+F8 i després CTRL+ALT+F7 tot tornava a funcionar
> 
> Vaig treure Gnome i vaig continuar amb XFCE i amb Mate, però algunes
> aplicacions importants es continuen congelant cada pocs minuts: VLC,
> Mplayer, Chromium, però no Firefox
> 
>  Pista: fent CTRL+ALT+F8 i després CTRL+ALT+F7 tot torna a funcionar
> 
>  Pista: no apareix res als logs amb «dmesg», ni als logs de Xorg, ni als
> logs de VLC
> 
>  Pista potser gran: en realitat he descobert que les aplicacions «no es
> congelen». Continuen funcionant bé, però ja no es «dibuixen» a la finestra,
> el que fa semblar que l’aplicació «s’ha congelat».

Pel que dius, semblaria un problema del compositor, que no actualitza
l'estat de la pantalla correctament.  Ara bé, si et passa amb Gnome i
també amb Xfce, que utilitzen compositors diferents, aleshores m'inclino
a pensar que és una altra cosa.

> Resum: del kernel 4.14 en endavant, amb targetes gràfiques Radeon, i amb
> Xorg però no amb Wayland, alguna cosa fa que aleatòriament les finestres de
> VLC, Mplayer, Chromium es deixin de dibuixar («es congelin») malgrat
> aquestes aplicacions estiguin funcionant perfectament. Tot torna a funcionar
> fent CTRL+ALT+F8 seguit de CTRL+ALT+F7
> 
> No sé ni per on començar. Algun consell?

Els problemes que tenen a veure amb el sistema gràfic són difícils de
solucionar pel teu compte, a no ser que siguis un expert en el tema.  Si
el bug és reproduïble (és a dir es produeix sempre que fas alguna cosa
concreta), pots anar provant diferents versions del programari sospitós
de causar-lo i veure exactament quina versió introdueix el problema.
Amb aquest mètode podries veure fins i tot quina línia de codi és la
culpable, però clar, si has d'anar compilant versions i sub-versions del
kernel, o de altres components complexos, és una feinada considerable.
Probablement és més pràctic tornar a una versió anterior que saps que
funciona i posar-la en estat "hold", i esperar que solucionin el
problema a les versions més recents.

Salut.



Re: Em podeu donar un cop de ma amb un bug?

2019-01-12 Conversa Eduard Selma

El 12/1/19 a les 12:40, a...@probeta.net ha escrit:

Bon dia a tothom,

Fa molt de temps que em barallo amb un bug, que intento acorralar, però 
no hi ha manera.


Afecta a Debian Testing en el sistema gràfic, i aquí em veig molt 
perdut, entre controladors, servidors de finestres, gestors de 
finestres, compositors, mesas, cairos, egl, etc.


- No crec que t'ajudi gaire, només són més dades... (i potser més "soroll"):

Treballo amb Debian 9.6 (Stretch, stable) però amb nucli 
4.17.0-0.bpo.3-amd64 (el que instal·la per omissió Neptune). El servidor 
gràfic és X.Org 1.19.6, gestor de finestres i compositor kwin-X11. 
L'Open GL és AMD ARUBA (DRM 2.50.0 / 4.17.0-0.bpo.3-amd64 LLVM 6.0.0) v: 
4.3 Mesa 18.2.6.


El meu entorn d'escriptori és KDE/Plasma Frameworks 5.45.0 amb Qt 5.7.1.

No uso cap altre compositor, panels virguers, ni rés més quant a 
gràfics. El meu reproductor VLC és el 3.0.3.


Fins ara, no he observat el fenomen que ens descrius.

Són els meus cinc cèntims.  

Eduard Selma



Re: Em podeu donar un cop de ma amb un bug?

2019-01-12 Conversa alex




Fins al nucli 4.13 tot anava bé, però en actualitzar al nucli 4.14
l’escriptori Gnome es «congelava» cada pocs minuts. A tots els
següents nuclis fins el 4.19 el problema persisteix. A aquest enllaç
hi ha els canvis que aporta el nucli 4.14 a Radeon, però no els sé
interpretar: https://kernelnewbies.org/Linux_4.14#Graphics




He oblidat dir que això només em passa al PC de sobretaula amb el que 
treballo, on tinc una targeta gràfica Radeon.


Tinc dos portàtils més amb hardware gràfic diferent treballant amb 
Debian Testing i van perfectes.