Re: Pasar de Firefox (release) a Firefox ESR

2022-10-02 Por tema Camaleón
El 2022-10-01 a las 21:10 +0200, Alfonso García Rodríguez escribió:

(...)

> > Manda la salida de «grep -i flags /proc/cpuinfo».
> >  
> 
> Ahí va:
> 
> flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov 
> pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx pdpe1gb rdtscp 
> lm constant_tsc art arch_perfmon pebs bts xtopology nonstop_tsc cpuid 
> aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx smx est tm2 ssse3 sdbg fma 
> cx16 xtpr pdcm sse4_1 sse4_2 x2apic movbe popcnt tsc_deadline_timer aes xsave 
> avx f16c rdrand lahf_lm abm 3dnowprefetch cpuid_fault epb pti ibrs ibpb stibp 
> tpr_shadow vnmi flexpriority ept vpid ept_ad fsgsbase tsc_adjust bmi1 hle 
> avx2 smep bmi2 erms invpcid rtm mpx rdseed adx smap clflushopt intel_pt 
> xsaveopt xsavec xgetbv1 xsaves dtherm ida arat pln pts hwp hwp_notify 
> hwp_act_window hwp_epp
> vmx flags : vnmi preemption_timer invvpid ept_x_only ept_ad ept_1gb 
> flexpriority tsc_offset vtpr mtf vapic ept vpid unrestricted_guest ple 
> shadow_vmcs pml

(...)

Según la salida de cpupinfo¹ (aparece la extensión «lm») y las 
especificaciones del procesador² puedes instalar perfectamente un 
sistema de 64 bits.

Salvo que hayas elegido manualmente instalar un kernel PAE para tener 
binarios de 32 bits y poder usar más de 4 GiB de RAM o se trate de una 
máquina virtual donde hayas alterado en el equipo anfitrión las 
banderitas de las opciones del procesador... no se me ocurre ningún 
otro motivo para que tengas instalado la versión PAE del kernel.

O eso o se trata de un bug del instalador de Debian, pero en cualquier 
caso, con las características de tu portátil (bien dotado) notarás una 
merma de rendimiento con un sistema de 32 bits (nativo o PAE) en lugar 
de un entorno de 64 bits.

¹ https://www.baeldung.com/linux/proc-cpuinfo-flags
² 
https://ark.intel.com/content/www/es/es/ark/products/88190/intel-core-i56300u-processor-3m-cache-up-to-3-00-ghz.html

Saludos,

-- 
Camaleón 



Re: Pasar de Firefox (release) a Firefox ESR

2022-10-01 Por tema Camaleón
El 2022-10-01 a las 13:44 +0200, Alfonso García Rodríguez escribió:

> > Hum... para que Firefox vaya suavecito en sistemas viejitos como los 
> > nuestros, tienes que desactivar la aceleración gráfica por hardware y 
> > las demás animaciones y efectos, seguro que notas la diferencia. 
> > 
> > Eso es válido tanto para la ESR como la Release.
> > 
> > Y bueno, si te animas a probar la 105 Release, es sencillo, sólo tienes 
> > que descargar el paquete de la página de Firefox, lo descomprimes en 
> > /opt y antes de ejecutar el binario, renombra el perfil de tu usuario 
> > de firefox actual para que no lo sobreescriba.
> > 
> > Pero si quieres mantener la ESR que instala Debian, intenta primero 
> > desactivando la aceleración por hardware de la GPU.
> > 
> 
> ¡Ostras! ¿Y cómo hago eso?

Pues... a ver, que yo hice un montón de cambios porque odio las 
animaciones esas de la wonderbar que te ampliaban la barra de 
direcciones, los iconos que saltan y los efectos de degradados y 
demás... he tuneado tanto a Firefox que ya ni lo reconozco :-)

about:config → ui.prefersReducedMotion → true

También tengo habilitado en Privacidad el modo Estricto y siempre qe 
cierro el navegador elimino las cookies y los datos y el historial de 
navegación (vamos, que mi Firefox es anmésico).

Pero lo de la aceleración por hardware sí es sencillo, desde los 
Ajustes, opción de Renidmiento, ahí tengo desactivadas las dos:

Rendimiento

[ ] Usar configuración de rendimiento recomendada
  [ ] Usar aceleración de hardware cuando esté disponible

Si las habilito, Firefox se vuelve lentorro del copón y casca cada dos 
por tres. Un horror.

También puedes probar desactivando WebGL (about:config → webgl.disabled → 
true), eso sí, algunas páginas que usen esta tecnología dejarán de 
funcionar, claro está.

> > > * Sistema operativo: <>
> > > 
> > > * Núcleo: < > > (debian-ker...@lists.debian.org) (gcc-10 (Debian 10.2.1-6) 10.2.1 
> > > 20210110, GNU ld (GNU Binutils for Debian) 2.35.2) #1 SMP Debian 
> > > 5.10.140-1 (2022-09-02)>>
> > > 
> > ¿Existe algún motivo para usar un kernel PAE? :-?
> >
> 
> Perdona mi ignorancia. Pero ¿qué es un kernel PAE?

Es un kernel de 32 bits pero que permite al sistema acceder a más de 4 
GiB de memoria RAM que sería lo normal en un kernel de 32 bits.

Lo que no entiendo es cómo Debian ha instalado el kernel PAE, tu equipo 
es lo bastante moderno para que admita las extensiones de 64 bits 
nativas, es raro.

Manda la salida de «grep -i flags /proc/cpuinfo».
 
> > Con 8 GiB de RAM te recomiendo una versión de 64 bits, no para ahora 
> > sino cuando tengas que actualizar el sistema operativo.
> 
> ¿Qué paquete de Debian uso para esto?
 
Ninguno, tendrías que volver a instalar todo el sistema desde cero :-(, 
por eso te digo, que si tienes que volver a instalar, y tu sistema lo 
admite, mejor instala un kernel de 64 bits.

Saludos,

-- 
Camaleón 



Re: Pasar de Firefox (release) a Firefox ESR

2022-10-01 Por tema Camaleón
El 2022-10-01 a las 11:16 +0200, Alfonso García Rodríguez escribió:

> El día 29/09/2022, a las 19:55, Camaleón escribió:
> > Hola,
> > 
> > Me estoy planteando el cambio de Firefox (release) a Firefox (ESR), 
> > ambos instalados directamente desde Mozilla, manteniendo el perfil 
> > actual del usuario pero desconozco si la transición tendrá algún 
> > inconveniente.
> > 
> > El motivo es que mi equipo es viejito (Intel(R) Core(TM)2 Quad CPU Q9550
> >  @ 2.83GHz, NVIDIA Corporation NV43 [Quadro NVS 440]) y las aplicaciones 
> > cada vez son más demandantes (sobre todo en cuestión de gráfica y 
> > controladores de aceleración de la GPU). 
> > 
> > Ya he pasado de LibreOffice Fresh a LibreOffice Still porque la Fresh 
> > tiene algunos fallos que ronca el mango y yo tampoco estoy para sustos, 
> > por eso quiero hacer lo mismo con Firefox.
> > 
> > La versión actual de Firefox es la 105.0.1 (la que tengo instalada) y la 
> > ESR creo que va por la 102.3.0.
> > 
> > Si alguien ha hecho esa transición, se agradece cualquier comentario o 
> > sugerencia, problemas encontrados o cómo le ha ido.
> 
> Hola Camaleón,
> 
> Yo estoy usando <> en Debian y me va fatal.
> Estoy desesperado. Se cuelga cada 2 x 3 hasta el punto de que me estoy
> planteando usar otro navegador. Cada actualización que hago complica 
> la situación, haciéndome sufrir cuelgues con más frecuencia. 
> 
> O sea que mi experiencia es malísima. No te puedo decir otra cosa.

Hum... para que Firefox vaya suavecito en sistemas viejitos como los 
nuestros, tienes que desactivar la aceleración gráfica por hardware y 
las demás animaciones y efectos, seguro que notas la diferencia. 

Eso es válido tanto para la ESR como la Release.

Y bueno, si te animas a probar la 105 Release, es sencillo, sólo tienes 
que descargar el paquete de la página de Firefox, lo descomprimes en 
/opt y antes de ejecutar el binario, renombra el perfil de tu usuario 
de firefox actual para que no lo sobreescriba.

Pero si quieres mantener la ESR que instala Debian, intenta primero 
desactivando la aceleración por hardware de la GPU.

> A continuación listo las características de mi equipo y versiones del
> sistema operativo y núcleo:
> 
> * Sistema operativo: <>
> 
> * Núcleo: < (gcc-10 (Debian 10.2.1-6) 10.2.1 20210110, GNU ld (GNU Binutils for Debian) 
> 2.35.2) #1 SMP Debian 5.10.140-1 (2022-09-02)>>
> 
> * Microprocesador: 4 x <>
> 
> * Modelo portátil: Dell Latitude 7280 - 8GB RAM
> 
> * Gráfica: 00:02.0 VGA compatible controller: Intel Corporation Skylake GT2 
> [HD Graphics 520] (rev 07)

¿Existe algún motivo para usar un kernel PAE? :-?

Con 8 GiB de RAM te recomiendo una versión de 64 bits, no para ahora 
sino cuando tengas que actualizar el sistema operativo.

Saludos,

-- 
Camaleón 



Re: Pasar de Firefox (release) a Firefox ESR

2022-09-30 Por tema Camaleón
El 2022-09-29 a las 12:40 -0600, estebanmo...@riseup.net escribió:

(mando a la lista, se fue al privado)

> Con esa solución solo le esta hechando mas agua a la sopa... 91.0 esr 
> ya salio de soporte... Le queda solo el soporte que le pueda dar 
> Debian al paquete del repo. 

No uso los paquetes de Debian para Firefox, suelen estar muy 
desactualizados.

La versión de Firefox ESR es la 102.3.0 que tiene soporte de seguridad 
extendididísimo, lo que no incluye son las nuevas caracteríticas y 
novedades de la versión Release.

Pero es verdad que hasta en Firefox piden cautela si vas a pasar a la 
ESR... no sé, me da qué pensar:

Cambiar a Firefox Extended Support Release (ESR) para uso personal
https://support.mozilla.org/es/kb/cambiar-firefox-extended-support-release-esr-para-uso-personal

***
Advertencia: Las diferentes versiones de Firefox utilizarán de forma 
predeterminada la misma información de perfil del usuario. Si la 
versión que instalas de Firefox ESR es anterior a la versión de Firefox 
que estás utilizando, se pueden producir pérdidas de datos y otros 
problemas. Si reinicias Firefox puede que se solucionen algunos 
problemas, pero te recomandamos que te crees un nuevo perfil de Firefox 
y utilizarlo con Firefox ESR.
***

Si no me da ningún problema con el hardware actual, creo que sería más 
prudente mantener la versión Release.

> Considere cambiar de tarro. Su procesador. salió en el 2008, no 
> entiendo como alguien usa la misma computadora por 14 años, bueno si lo
> entiendo alguien que piensa que le está sacando el jugo a un hardware 
> fácilmente reemplazable, ignorando que es a costillas de un tiempo 
> irrecuperable, pero bueno cada quien le da valor a sus cosas.

El equipo es viejo ¡pero es que va como un cohete! 

Y no sé por qué, quizá sea por el uso que le doy (nada exigente) pero es 
extremadamente rápido, no tengo queja ni puedo retirarlo con el buen 
servicio que me hace. Acabo de ampliar el disco duro a uno de 1 TiB (el 
antiguo inicialmente instalado para el sistema operativo era de 250 GiB 
y se me quedaba corto al tenerlo dividido en dos por mi esquema de 
particiones) y a correr otros 3/4 años.

> Las PC como mucho tienen una vida útil de 3 años...

Bueno, normalmente la vida útil de un ordenador va (o debe ir) de 4 a 6 
años (uso particular) y de 5 a 8 años (empresa). Y eso pensaba yo hasta
que compré una placa base Supermicro. 

Ese fabricante no sabe lo que es la obsolescencia. Sencillamente es-pec-
ta-cu-lar, es otro mundo. He trabajado con placas base Asus, MSI, Iwill, 
Gigabyte, Biostar, DFI, etc... pero no he visto nada igual a Supermicro 
en cuanto a robustez y fiabilidad (eso, sí, son un poco pijoteras :-))

Esta placa en concreto es:

root@stt008:~# dmesg | grep -i super
[0.00] DMI: Supermicro C2SBX/C2SBX, BIOS 1.2a   12/19/2008

Saludos,

-- 
Camaleón 



Re: Pasar de Firefox (release) a Firefox ESR

2022-09-30 Por tema Camaleón
El 2022-09-29 a las 18:22 -0300, JavierDebian escribió:

> El 29/9/22 a las 14:55, Camaleón escribió:
> > Hola,
> > 
> > Me estoy planteando el cambio de Firefox (release) a Firefox (ESR),
> > ambos instalados directamente desde Mozilla, manteniendo el perfil
> > actual del usuario pero desconozco si la transición tendrá algún
> > inconveniente.
> > 
> 
> Sí, si la "release" que tenés instalada es de una versión posterior a la
> ESR, que suele ir MUY atrasada.

La idea es hacer el cambio ahora que ambas versiones son casi idénticas.
 
> > El motivo es que mi equipo es viejito (Intel(R) Core(TM)2 Quad CPU Q9550
> >   @ 2.83GHz, NVIDIA Corporation NV43 [Quadro NVS 440]) y las aplicaciones
> > cada vez son más demandantes (sobre todo en cuestión de gráfica y
> > controladores de aceleración de la GPU).
> > 
> > Ya he pasado de LibreOffice Fresh a LibreOffice Still porque la Fresh
> > tiene algunos fallos que ronca el mango y yo tampoco estoy para sustos,
> > por eso quiero hacer lo mismo con Firefox.
> > 
> > La versión actual de Firefox es la 105.0.1 (la que tengo instalada) y la
> > ESR creo que va por la 102.3.0.
> > 
> 
> Lo que te decía; vas a tener problemas.
> Y la ESR está en versión 91.13.0., más vieja aún.

Hum... salvo que me haya perdido algo, la Release va por la 105.0.1:

https://www.mozilla.org/en-US/firefox/105.0.1/releasenotes/

La ESR va por la 102.3.3:

https://www.mozilla.org/en-US/firefox/102.3.0/releasenotes/

Nunca instalo Firefox desde los repos Debian (tampoco LibreOffice), uso 
los paquetes de Mozilla y los de la Fundación.

> > Si alguien ha hecho esa transición, se agradece cualquier comentario o
> > sugerencia, problemas encontrados o cómo le ha ido.
> > 
> > 
> 
> La forma de pasar, es que tengas una cuenta Firefox sincronizada en la nube.
> Elimines y purgue la "release".
> Instales la ESR y arrancas desde cero, ingresando a tu cuenta Firefox y que
> se sincronice.

No tengo cuenta en la nube. Normalmente renombro el perfil de Firefox 
actual para no perder el original, exporto los marcadores a un archivo 
bookmark.html y ya está. Instalo la nueva versión de Firefox en /opt y 
dejo que use el mismo perfil que ya existía. 

Ese era el plan para cambiar de la Release a la ESR.

> ¿Qué vas a perder?
> Las "cookies", que deberá bajarlas nuevamente, y la "caché" del historial
> (no el historial de visita, ese se mantiene en la sincronización, como
> también todos los marcadores y claves).
> 
> O sea, no se pierde nada.

Esos datos ya los elimino cada vez que cierro Firefox (trabajo en un 
modo semi-anónimo), así que, cierto, no pierdo nada.

> Pero no intentes instalar versión vieja sobre nueva, porque ahí se te va a
> liar.

Eso lo voy a tener que valorar por si, por el motivo que sea, tengo que 
volver a usar la Release.

Muchas gracias.

Saludos,

-- 
Camaleón 



Re: Pasar de Firefox (release) a Firefox ESR

2022-09-30 Por tema Camaleón
El 2022-09-29 a las 17:58 -0300, Gerardo Braica escribió:

> Como va?
> 
> Si te sirve yo hice el cambio exactamente al reves nada mas que por
> curiosidad,
> 
> tenia el ESR y me cambie a version 105 usando el repositorio de MX.
> 
> La verdad es que no note nada diferente en un uso de exigencias normales,
> lease
> 
> redes, noticias, youtube, etc.
> 
> Tambien con un equipo viejo, AMD Athlon X2 250, ( de RAM y una GeForce
> viejisima GS7100.

Gracias por comentar cómo te fue.
En tu caso creo que eras más completo (pasar de ESR a Release) pero si 
no has tenido problemas es una buena señal.
Si me animo este fin de semana haré el cambio a ver cómo va.

> El 29/9/22 a las 14:55, Camaleón escribió:
> > Hola,
> > 
> > Me estoy planteando el cambio de Firefox (release) a Firefox (ESR),
> > ambos instalados directamente desde Mozilla, manteniendo el perfil
> > actual del usuario pero desconozco si la transición tendrá algún
> > inconveniente.
> > 
> > El motivo es que mi equipo es viejito (Intel(R) Core(TM)2 Quad CPU Q9550
> >   @ 2.83GHz, NVIDIA Corporation NV43 [Quadro NVS 440]) y las aplicaciones
> > cada vez son más demandantes (sobre todo en cuestión de gráfica y
> > controladores de aceleración de la GPU).
> > 
> > Ya he pasado de LibreOffice Fresh a LibreOffice Still porque la Fresh
> > tiene algunos fallos que ronca el mango y yo tampoco estoy para sustos,
> > por eso quiero hacer lo mismo con Firefox.
> > 
> > La versión actual de Firefox es la 105.0.1 (la que tengo instalada) y la
> > ESR creo que va por la 102.3.0.
> > 
> > Si alguien ha hecho esa transición, se agradece cualquier comentario o
> > sugerencia, problemas encontrados o cómo le ha ido.
> > 
> > Saludos,

Saludos,

-- 
Camaleón 



Pasar de Firefox (release) a Firefox ESR

2022-09-29 Por tema Camaleón
Hola,

Me estoy planteando el cambio de Firefox (release) a Firefox (ESR), 
ambos instalados directamente desde Mozilla, manteniendo el perfil 
actual del usuario pero desconozco si la transición tendrá algún 
inconveniente.

El motivo es que mi equipo es viejito (Intel(R) Core(TM)2 Quad CPU Q9550
 @ 2.83GHz, NVIDIA Corporation NV43 [Quadro NVS 440]) y las aplicaciones 
cada vez son más demandantes (sobre todo en cuestión de gráfica y 
controladores de aceleración de la GPU). 

Ya he pasado de LibreOffice Fresh a LibreOffice Still porque la Fresh 
tiene algunos fallos que ronca el mango y yo tampoco estoy para sustos, 
por eso quiero hacer lo mismo con Firefox.

La versión actual de Firefox es la 105.0.1 (la que tengo instalada) y la 
ESR creo que va por la 102.3.0.

Si alguien ha hecho esa transición, se agradece cualquier comentario o 
sugerencia, problemas encontrados o cómo le ha ido.

Saludos,

-- 
Camaleón 



Re: placa de sonido ALC887-VD no detectada

2022-09-25 Por tema Camaleón
El 2022-09-24 a las 20:49 -0300, Marcelo Eduardo Giordano escribió:

> No encuentro solución a este problema pero sigo intentando.
> 
> que les parece esto que encuentro? Si ejecuto el comando "pulseaudio" pasa
> lo siguiente. Gracias desde ya a todos
> 
> pulseaudio
> E: [pulseaudio] pid.c: Daemon already running.
> E: [pulseaudio] main.c: Ha fallado pa_pid_file_create().

A mí me dice lo mismo y el sonido funciona bien:

sm01@stt008:~$ pulseaudio
E: [pulseaudio] pid.c: Daemon already running.
E: [pulseaudio] main.c: Ha fallado pa_pid_file_create().

Para depurar problemas con la tarjeta de sonido, tienes algunos pasos a 
seguir en la wiki de Debian, apartado Troubleshooting:

https://wiki.debian.org/Sound

Cuanta más información nos facilites (errores que te aparecen al 
ejecutar esas órdenes) mejor podremos indicarte.

De todas formas, parece que se trata de un chipset problemático:

https://www.google.com/search?q=ALC887-VD+debian+11+not+detected

Saludos,

-- 
Camaleón 



Re: Mal particionado?...

2022-09-24 Por tema Camaleón
El 2022-09-23 a las 22:41 -0300, Gonzalo Rivero escribió:

> El 23/9/22 a las 18:08, judedi sago escribió:
> > Buenas tardes…
> > Otra vez a molestarlos un poco con una justa inquietud.
> > 
> > Según me muestra fdisk, aquí se están perdiendo 52.2 G en la partición
> > extendida que quedó como primera partición.

La partición extendida es una partición lógica que sirve a modo de 
contenedor y que en tu caso, ocupa 51,2 GiB donde tienes instalado 
Linux, entiendo.

> > Disco /dev/sda: 465,76 GiB, 500107862016 bytes, 976773168 sectores
> > Modelo de disco: WDC WD5000AVDS-6
> > Unidades: sectores de 1 * 512 = 512 bytes
> > Tamaño de sector (lógico/físico): 512 bytes / 512 bytes
> > Tamaño de E/S (mínimo/óptimo): 512 bytes / 512 bytes
> > Tipo de etiqueta de disco: dos
> > Identificador del disco: 0xcbe73cf0
> > 
> > Disposit.  Inicio  Comienzo Final  Sectores Tamaño Id Tipo
> > /dev/sda1  *   2046 107438079 107436034  51,2G  5 Extendida
> > /dev/sda2 107438080 976773167 869335088 414,5G  7 HPFS/NTFS/exFAT
> > /dev/sda5  2048  20269055  20267008   9,7G 83 Linux
> > /dev/sda6  20271104  27674623   7403520   3,5G 83 Linux
> > /dev/sda7  27676672  31848447   4171776 2G 82 Linux swap / 
> > Solaris
> > /dev/sda8  31850496  33257471   1406976   687M 83 Linux
> > /dev/sda9  33259520 107438079  74178560  35,4G 83 Linux
> > 
> > Las entradas de la tabla de particiones no están en el orden del disco.
> > 
> > (Hasta aquí fdisk)...
> > 
> > Es verdad?…
> > 
> > Y es posible recuperarlos sin que haya que borrar las otras particiones?…

Ojo, si la borras pierdes todo lo que contiene la partición, que en tu 
caso es el sistema y datos de Linux.

Fíjate que el tamaño que te ocupa la partición extendida es 51,5 GiB 
que es la suma de sda5 + sda6 + sda7 + sda8 + sda9.

Además, ahora mismo la tienes marcada como partición de arranque (*), 
que es donde tienes GRUB2, si la eliminas no iniciará el sistema, 
tendrás que cambiar la bandera a otra partición que contenga un 
cargador de arranque, claro está.

> En realidad no estás perdiendo nada, parece que estás usando el formato de
> particiones que al no recordar el nombre real le llamaré "clásico". En este
> esquema solo podías tener hasta 4 particiones. Cuando se vió que se podría
> necesitar mas que 4 inventaron las particiones extendidas, que básicamente
> es otra partición con particiones dentro.
> 
> En ese disco, sda5,sda6,sda7,sda8 y sda9 viven dentro de sda1. Entonces tu
> disco está organizado mas o menos así:
> 
> [sda1(sda5 |sda6 |sda7 |sda8 |sda9) | sda2]
> 
> Y por eso también se estará quejando que las particiones no aparecen en 
> orden. A menos que tengas un backup de todo el disco, no vayas a borrar nada.
> 
> pd/offtopic: no veo en thunderbird una opción para enviar como texto
> plano... espero que el mail no salga en html

Hum... está donde siempre. En el modo de edición de un nuevo correo, 
Opciones →  Formato → Sólo texto sin formato.

Saludos,

-- 
Camaleón 



Re: PHP7 vs PHP8

2022-09-23 Por tema Camaleón
El 2022-09-23 a las 17:17 +0300, Julián Daich escribió:

(reenvío a la lista)

> El 22/9/22 a las 9:01, Camaleón escribió:
> > El 2022-09-21 a las 21:43 +0200, Julian Daich escribió:
> > 
> >> Tengo un Wordpress montado en un Debian 10. Después de una
> >> actualización se instaló PHP8 y ahora se cuelga cada do por tres.
> > 
> > La versión que viene con Debian 10 y 11 es la 7.x, tendrás que ver por 
> > qué se ha actualizado a una versión superior y de dónde vienen esos 
> > paquetes.
> > 
> 
> Hola,
> 
> Tengo el repositorio  https://packages.sury.org/php
> Con PHP en las versiones 7.3 y 8.1 instaladas

El repositorio parece una fuente segura/fiable.
 
> >> Quiero desinstalar una de las versriones, pero no se cual de las dos.
> >> Leí que ten teoría PHP8 es más eficiente, pero seguramente más pesado.
> >> Mi máquina no tiene muchos recurso.
> > 
> > Si la versión 8 se cuelga, poca opción tienes :-)
> 
> Probé primero pasar a PHP 8.1
> Cuando hago
> sudo a2dismod php7.3
> sudo a2enmod php8.1
> Me sale
> ERROR: Module php8.1 does not exist!

Ah, entonces lo que te falla es la integración de php8.1 cn Apache2, 
eso es distinto y seguramente con fácil solución. Tendrás que ver qué 
archivo de configuración tienes que editar para decirle a apache que 
quieres usar una versión concreta de php, además de tener todos los 
paquetes / módulos instalados.

Seguramente tengas instalado desde los repos de debian el paquete de 
integración con los módulos de apache (libapache2-mod-php) y por eso te 
funcione con la versión más antigua. Si quieres probar la 8.1 tendrás 
que configurar los módulos de apache a mano.

> No tengo dependencias que me falten por lo que volví a PHP 7.3
> sudo a2dismod php8.1
> sudo a2enmod php7.3
> sudo service apache2 restart
> 
> De momento volvió a andar bien.
> 
> > 
> > Desconozco si PHP tiene algún requerimiento en cuanto a harwdare, quizá 
> > sí tenga requisitos con ciertas versiones bibliotecas que quieriran 
> > componentes modernos. 
> > Seguramente la exigencia venga de las aplicacioens que lo usan (Wordpress,
> > etc...)
> > 
> 
> Está todo montado en una máquina de Google porque no cuesta dinero. Para
> eso la máquina tiene que ser lo más imple posible. El problema puede ser
> las cosas que instala Google en sus imágenes que según leí pueden traer
> problemas de seguridad. Pienso que mejor es armar mi propia imagen,
> probarla y subirla a la nube.

Saludos,

-- 
Camaleón 



Re: systemctl status degraded

2022-09-23 Por tema Camaleón
El 2022-09-23 a las 09:40 +0200, Antonio Trujillo Carmona escribió:

> Un servidor que funciona sin error aparente da:
> # systemctl status
> ● gr00swebhgra28
>     State: *degraded*
>  Jobs: 0 queued
>    Failed: 1 units
> ...

¿Qué tipo de servicio es ese?

> revisando todos los servicios me dan todos correctos, por ejemplo:
> 
> 
> # systemctl status dbus
> ● dbus.service - D-Bus System Message Bus
>    Loaded: loaded (/lib/systemd/system/dbus.service; static; vendor preset:
> enabled)
> *Active: active* (running) since Mon 2022-08-08 08:57:31 CEST; 1 months 15
> days ago
>  Docs: man:dbus-daemon(1)
>  Main PID: 605 (dbus-daemon)
>     Tasks: 1 (limit: 7088)
>    Memory: 5.3M
>    CGroup: /system.slice/dbus.service
>    └─605 /usr/bin/dbus-daemon --system --address=systemd: --nofork
> --nopidfile --systemd-activation --syslog-only
> 
> sep 23 09:19:33 gr00swebhgra28 dbus-daemon[605]: [system] Activating via
> systemd: service name='org.freedesktop.PackageKit' unit='packagekit.service'
> requested by ':1.92399' (uid=0 pid=112608 comm="/usr/bin/gdbu
> sep 23 09:19:33 gr00swebhgra28 dbus-daemon[605]: [system] Successfully
> activated service 'org.freedesktop.PackageKit'
> Warning: Journal has been rotated since unit was started. Log output is
> incomplete or unavailable.
> 
> ¿Alguien sabe porque lo marca como degradado?

No se habrá podido iniciar, la cuestión es saber por qué.
Prueba con «systemctl --failed» o «systemctl» sin más.

Saludos,

-- 
Camaleón 



Re: PHP7 vs PHP8

2022-09-22 Por tema Camaleón
El 2022-09-21 a las 21:43 +0200, Julian Daich escribió:

> Tengo un Wordpress montado en un Debian 10. Después de una
> actualización se instaló PHP8 y ahora se cuelga cada do por tres.

La versión que viene con Debian 10 y 11 es la 7.x, tendrás que ver por 
qué se ha actualizado a una versión superior y de dónde vienen esos 
paquetes.

> Quiero desinstalar una de las versriones, pero no se cual de las dos.
> Leí que ten teoría PHP8 es más eficiente, pero seguramente más pesado.
> Mi máquina no tiene muchos recurso.

Si la versión 8 se cuelga, poca opción tienes :-)

Desconozco si PHP tiene algún requerimiento en cuanto a harwdare, quizá 
sí tenga requisitos con ciertas versiones bibliotecas que quieriran 
componentes modernos. 
Seguramente la exigencia venga de las aplicacioens que lo usan (Wordpress,
etc...)

Saludos,

-- 
Camaleón 



Re: Asunto: Re: Usar llvmpipe en vez de amdgpu

2022-09-19 Por tema Camaleón
El 2022-09-18 a las 23:00 -, Jefferson Smith Pizarro Gutierrez escribió:

> Asus AMD® Ryzen 3 3200u with radeon vega mobile gfx × 4
> Portatil: Asus M509D
> Debian: Debian 11 - Bullseye
> Gpu Drivers: uso Amdgpu pero quisiera usar solo llvmpipe

(...)

Si puedes subir el archivo «/var/log/Xorg.0.log» a algún¹ sitio² para que 
podamos ver su contenido, mejor.

En cualquier caso, para intentar que no cargue el driver amdgpu puedes 
probar a pnerlo en la lista negra:

How to blacklist amdgpu driver?
https://askubuntu.com/questions/1080217/how-to-blacklist-amdgpu-driver

Ahora bien, no me queda del todo claro que lo que quieras hacer sea 
posible, es decir, me parece que LLVMPIPE no es un reemplazo del driver 
gráfico (amdgpu, radeon, etc...) sino que forma parte de la capa de 
aceleración OpenGL (por software, además).

Es decir, si pones en la lista negra el driver amdgpu desconozco qué 
driver te cargarará el kernel :-?

¹https://paste.debian.net/
²https://pastebin.com/

Saludos,

-- 
Camaleón 



Re: sources.list en bullseye

2022-09-17 Por tema Camaleón
El 2022-09-16 a las 21:50 -0300, Gonzalo Rivero escribió:

> Holas,
> tengo el siguiente sources.list para un debian 11:
> deb http://deb.debian.org/debian/ bullseye main contrib
> deb http://deb.debian.org/debian/ bullseye-updates main contrib
> deb http://security.debian.org/debian-security bullseye-security main contrib
> 
> deb-src http://deb.debian.org/debian/ bullseye main contrib
> deb-src http://deb.debian.org/debian/ bullseye-updates main contrib
> deb-src http://security.debian.org/debian-security bullseye-security main 
> contrib

No veo nada raro en los repos.
 
> pero me está faltando algo que no se que es, por ejemplo si quiero instalar
> freetype6-dev me pasan los siguientes errores:
> root@debian11-uni:~/php/php-5.3.4# apt-get update; apt-get install
> libfreetype6-dev

(...)

> Se instalarán los siguientes paquetes NUEVOS:
>   libfreetype-dev libfreetype6-dev
> 0 actualizados, 2 nuevos se instalarán, 0 para eliminar y 88 no
> actualizados.
> Se necesita descargar 654 kB de archivos.
> Se utilizarán 2.143 kB de espacio de disco adicional después de esta
> operación.
> ¿Desea continuar? [S/n]
> Err:1 http://deb.debian.org/debian bullseye/main amd64 libfreetype-dev
> amd64 2.10.4+dfsg-1
>   404  Not Found [IP: 151.101.218.132 80]
> Err:2 http://deb.debian.org/debian bullseye/main amd64 libfreetype6-dev
> amd64 2.10.4+dfsg-1
>   404  Not Found [IP: 151.101.218.132 80]
> E: Fallo al obtener
> http://deb.debian.org/debian/pool/main/f/freetype/libfreetype-dev_2.10.4%2bdfsg-1_amd64.deb
>  404  Not Found [IP: 151.101.218.132 80]
> E: Fallo al obtener
> http://deb.debian.org/debian/pool/main/f/freetype/libfreetype6-dev_2.10.4%2bdfsg-1_amd64.deb
>  404  Not Found [IP: 151.101.218.132 80]
> E: No se pudieron obtener algunos archivos, ¿quizás deba ejecutar «apt-get
> update» o deba intentarlo de nuevo con --fix-missing?
> 
> navegando el repositorio manualmente veo que el paquete disponible es un
> poquito mas nuevo (2.10.4+dfsg-1 vs 2.10.4+dfsg-1+deb11u1) :
> http://ftp.debian.org/debian/pool/main/f/freetype/libfreetype-dev_2.10.4+dfsg-1+deb11u1_amd64.deb
> 
> me cansé de apt-get update, sin embargo sigue buscando esa versión
> ligeramente anterior. Podría descargarlo manualmente e instalarlo con dpkg,
> de hecho lo intenté, pero entonces este paquete depende de otro que tengo
> la versión muy cercana pero inferior que depende de otro que depende de
> otro que depende de otro y así sucesivamente.
> Hace mcho que para escritorio solo uso testing (creo que desde sarge
> que puse testing y no volví a cambiar mis sources.list) y actualizo
> regularmente si mayores problemas, pero esto es para un servidor y necesito
> que quede en este estable, ¿que me puede estar faltando, o sobrando?

La pregunta del millón es por qué te quiere instalar un paquete que no 
existe en los repos desde el año 2020 :-?

https://metadata.ftp-master.debian.org/changelogs//main/f/freetype/freetype_2.10.4+dfsg-1+deb11u1_changelog

freetype (2.10.4+dfsg-1) unstable; urgency=medium

  * New upstream version:

(...)

 -- Hugh McMaster   Sat, 05 Dec 2020 
19:20:58 +1100

Mira a ver qué versión de Freetype6 tienes actualmente instalada:

sm01@stt008:~$ dpkg -l | grep -i freetype6
ii  libfreetype6:amd642.10.4+dfsg-1+deb11u1   amd64FreeType 
2 font engine, shared library files

sm01@stt008:~$ apt list -a libfreetype6
Listando... Hecho
libfreetype6/stable,now 2.10.4+dfsg-1+deb11u1 amd64 [instalado, automático]

Saludos,

-- 
Camaleón 



Re: Usar llvmpipe en vez de amdgpu

2022-09-15 Por tema Camaleón
El 2022-09-15 a las 04:07 -, Jefferson Smith Pizarro Gutierrez escribió:

> Hola quiero saber com puedo calibrar el brillo de mi pantalla usando 
> llvmpipe en vez de amdgpu. puesto que aunque me sale en la pantalla 
> que bajo al maximo el brillo lo que sucede es que ni sube ni baja el 
> brillo solo se mantiene al maimo .Deseo modificar el brillo de mi 
> pantalla.xrandr: Failed to get size of gamma for output defaultScreen 
> 0: minimum 1366 x 768, current 1366 x 768, maximum 1366 x 768default 
> connected primary 1366x768+0+0 0mm x 0mm   1366x768  76.00*

Mejor si nos dices marca y modelo de portátil (entiendo que se trata de 
un ordenador portátil), versión de Debian instalada, si usas Xorg o 
Wayland y qué controladores usas para el sistema gráfico (libres, 
propietarios...).

Saludos,

-- 
Camaleón 



Re: Menu - configuración Grub

2022-09-14 Por tema Camaleón
El 2022-09-13 a las 20:34 +0200, Josu Zaloña escribió:

(...)

> Necesito ayuda con una "pequeñez"... no soy capaz de acertar con la tecla o
> combinación de ellas para seleccionar una de las opciones...

¿Seleccionar una de las opciones del menú de GRUB?

Con las teclas de dirección para posicionarte en la opción elegida ↓↑ y 
Enter ↲ para aceptar la opción y cargar el sistema, si mal no recuerdo.

Para editar alguna entrada antes de ejecutarla, pulsar la tecla «e» y 
después F10 o la techa «b» para seguir con el proceso de arranque.

Saludos,

-- 
Camaleón 



Re: Shikitega Malware Criptominer

2022-09-11 Por tema Camaleón
El 2022-09-10 a las 17:38 +0200, Juan Gómez "Txonta" escribió:

> Acabo de recibir la noticia de un criptominero muy sofisticado que ataca
> servidores y sistemas linux, le llaman Shikitega.
> He buscado el tema en las listas de Debian y no he visto nada, en internet
> he encontrado bastante información pero relativo a prevención, detección y
> eliminación muy poca cosa.
> 
> Me gustaría poder sentirme seguro ante esto y poder certificar la integridad
> de mis maquinas.
> 
> ¿Algún consejo u orientación?
> 
> Muchas gracias.
> 
> Salud.
> 
> https://unaaldia.hispasec.com/2022/09/nuevo-malware-para-linux-elude-la-deteccion-mediante-un-despliegue-en-varias-fases.html

Ayer lo leí en Hispasec, que sigo mediante RSS, pero sinceramente, no 
entendí absolutamente nada :-)

Normalmente de estos anuncios de vulnerabilidades me fijo en el vector 
de ataque (cómo entra el bicho en el sistema) y el rastro que deja una 
vez dentro (para poder comprobar si el bicho está dentro) pero en este 
caso no lo dice (o no he podido descifrarlo de la noticia), no sé si por
desconocimiento porque no saben aún cómo logra acceder a los sistemas o 
por cualquier otro motivo.

En fin, se trata de una noticia interesante por el riesgo que supone, 
pero que me ha dejado así → (·_·)
  
Cualquier aclaración o traducción a los efectos prácticos de saber cómo 
mitigar/evitar la infección o una vez dentro, cómo detectarla, se 
agradecerá.

Saludos,

-- 
Camaleón 



Re: Actualizar Debian Jessie a la última versión.

2022-09-09 Por tema Camaleón
El 2022-09-09 a las 14:00 +0200, Ramses escribió:

(...)

> > Sigo con la actualización.
> > 

(...)

> 
> Bueno, ya por fin tengo el Container LXC en Debian Bullseye:

(...)

> Ahora sólo me queda un problema que no veo cómo solucionar. Cuando hago un 
> "apt update" me aparecen los siguientes Warnings:
> 
> --
> root@maquina:~# apt update
> Hit:1 http://deb.debian.org/debian bullseye InRelease
> Hit:2 http://deb.debian.org/debian bullseye-updates InRelease
> Get:3 http://security.debian.org/debian-security bullseye-security/updates 
> InRelease [48.4 kB]
> Fetched 48.4 kB in 2s (25.1 kB/s)
> Reading package lists... Done
> Building dependency tree... Done
> Reading state information... Done
> All packages are up to date.
> W: http://deb.debian.org/debian/dists/bullseye/InRelease: The key(s) in the 
> keyring /etc/apt/trusted.gpg are ignored as the file is not readable by user 
> '_apt' executing apt-key.
> W: http://deb.debian.org/debian/dists/bullseye-updates/InRelease: The key(s) 
> in the keyring /etc/apt/trusted.gpg are ignored as the file is not readable 
> by user '_apt' executing apt-key.
> W: 
> http://security.debian.org/debian-security/dists/bullseye-security/updates/InRelease:
>  The key(s) in the keyring /etc/apt/trusted.gpg are ignored as the file is 
> not readable by user '_apt' executing apt-key.
> root@maquina:~#
> --
> 
> ¿Alguna idea de por dónde meterle mano?

Mira a ver si te sirve esta solución:

https://forums.debian.net/viewtopic.php?p=629511#p629511

Saludos,

-- 
Camaleón 



Re: [OT] Just curious... Debian Logo?

2022-09-08 Por tema Camaleón
El 2022-09-08 a las 13:57 -0400, Ali Moreno escribió:

> ¿No es esta una vulgar copia del logo de Debian?
> 
> WTF???
> 
> https://www.facebook.com/NutritionSchool/

Hombre... no sé, es un símbolo muy genérico:

https://www.google.com/search?q=swirl%20logo=isch=en=itp:clipart=X=0CAIQpwVqFwoTCLCZi4vthfoCFQAdABAC=1265=1011

Saludos,

-- 
Camaleón 



Re: Actualizar Debian Jessie a la última versión.

2022-09-07 Por tema Camaleón
El 2022-09-07 a las 19:47 +0200, Ramses escribió:

> > > >> W: Failed to fetch
> > > >> https://packages.sury.org/php/dists/jessie/main/binary-amd64/Packag
> > > >> es server certificate verification failed. CAfile:
> > > >> /etc/ssl/certs/ca-certificates.crt CRLfile: none
> > > >>
> > > >> E: Some index files failed to download. They have been ignored, or
> > > >> old ones used instead.
> > > >
> > > >Cambia de servidor, ese no tiene el archivo que necesitas:
> > > >
> > > >https://packages.sury.org/php/dists/
> > > >
> > > >Está vacío.
> > > >
> > > >Por eso siempre uso los alemanes:
> > > >
> > > >http://ftp.de.debian.org/debian/dists/jessie/main/binary-amd64/
> > > >
> > > >Aquí hay más chicha :-)
> > > >
> > > >> ¿A alguien le suena este error y cómo solucionarlo?
> > > >
> > > >Parece un error tontín, al fin y al cabo sólo estás actualizando los
> > > >paquetes de Debian Jessie; la «fiesta» de la actualización aún no ha
> > > >empezado...
> > > >
> > >
> > > Camaleón, tengo esto en el sources.list:
> > >
> > > deb http://ftp.de.debian.org/debian/ jessie main contrib non-free
> > > deb-src http://ftp.de.debian.org/debian/ jessie main contrib non-free
> > >
> > >
> > > deb http://httpredir.debian.org/debian jessie-updates main contrib
> > > non-free
> >  ^
> > > deb-src http://httpredir.debian.org/debian jessie-updates main contrib
> > > non-free

(...)

> > > ¿Los cambio y dejó sólo el que tú me has puesto?
> > 
> > No, sólo el que te falla, que es un redirector y te lleva a un servidor que 
> > no
> > tiene todos los paquetes.
> > 
> > Es decir, cambia este:
> > 
> > # deb http://httpredir.debian.org/debian jessie-updates main contrib non-
> > free # deb-src http://httpredir.debian.org/debian jessie-updates main
> > contrib non-free
> > 
> > Por este:
> > 
> > deb http://ftp.de.debian.org/debian jessie-updates main contrib non-free
> > deb-src http://ftp.de.debian.org/debian jessie-updates main contrib non-
> > free
> > 
> > Y prueba de nuevo:
> > 
> > apt-get update
> > 
> 
> Camaleón, buenas tardes,
> 
> He cambiado el sources.list:
> 
> 
> root@maquina:/etc/apt# cat sources.list
> #deb http://ftp.debian.org/debian wheezy main contrib
> 
> #deb http://ftp.debian.org/debian wheezy-updates main contrib
> 
> #deb http://security.debian.org wheezy/updates main contrib
> 
> deb http://ftp.de.debian.org/debian/ jessie main contrib non-free
> deb-src http://ftp.de.debian.org/debian/ jessie main contrib non-free
> 
> 
> #deb http://httpredir.debian.org/debian jessie-updates main contrib non-free
> #deb-src http://httpredir.debian.org/debian jessie-updates main contrib 
> non-free
> deb http://ftp.de.debian.org/debian jessie-updates main contrib non-free
> deb-src http://ftp.de.debian.org/debian jessie-updates main contrib non-free
> 
> 
> deb http://security.debian.org/ jessie/updates main contrib non-free
> deb-src http://security.debian.org/ jessie/updates main contrib non-free
> 
> 
> root@maquina:/etc/apt#
> 
> 
> Y me sigue dando el mismo problema, tanto con apt update como con apt-get 
> update:
> 
> 
> root@soporte:/etc/apt# apt-get update
> Hit http://security.debian.org jessie/updates InRelease
> Ign https://packages.sury.org jessie InRelease
 ^^

Ese servidor que falla te sigue apareciendo, pero no sé de dónde viene.

¿Tienes instalado alǵun paquete/aplicación/programa que consulte su 
propia lista de servidores para actualizar? Como Google Chrome o algo 
así que instala una especie de servicio y añade sus propios 
repositorios.

> Err https://packages.sury.org jessie/main amd64 Packages
>   server certificate verification failed. CAfile: 
> /etc/ssl/certs/ca-certificates.crt CRLfile: none

(...)

> E: Some index files failed to download. They have been ignored, or old ones 
> used instead.
> root@soporte:/etc/apt#
> 
> 
> ¿Alguna idea?

En prinicpio el mensaje que te aparece no te impide actualizar los 
paquetes, sólo te dice que ese servidor no se ha podido actualizar.

En cualquier caso, te lo está tomando por algún motivo que tendrás que 
revisar, lo debes de tener definido en alguna parte 
(p. ej., en «/etc/apt//sources.list.d/*») o en caché :-?

Saludos,

-- 
Camaleón 



Re: Actualizar Debian Jessie a la última versión.

2022-09-06 Por tema Camaleón
El 2022-09-06 a las 21:13 +0200, Ramses escribió:

> El 6 de septiembre de 2022 20:19:03 CEST, "Camaleón"  
> escribió:
> >> 
> >> Quiero actualizar una máquina con Debian Jessie, concretamente es un
> >> contenedor LXC, a la última versión de Debian.
> >> 
> >> El problema que tengo es que, cuando hago un "apt update" me aparece el
> >> siguiente error:

(...)

> >> Get:7 http://httpredir.debian.org jessie/main Translation-en [4581 kB]
> >> Ign https://packages.sury.org jessie/main Translation-en
> >> Err https://packages.sury.org jessie/main amd64 Packages
> >>   server certificate verification failed. CAfile:
> >> /etc/ssl/certs/ca-certificates.crt CRLfile: none
> >> Get:8 http://httpredir.debian.org jessie/non-free Translation-en [72.0 kB]

(...)

> >> W: Failed to fetch
> >> https://packages.sury.org/php/dists/jessie/main/binary-amd64/Packages
> >> server certificate verification failed. CAfile:
> >> /etc/ssl/certs/ca-certificates.crt CRLfile: none
> >> 
> >> E: Some index files failed to download. They have been ignored, or old ones
> >> used instead.
> >
> >Cambia de servidor, ese no tiene el archivo que necesitas:
> >
> >https://packages.sury.org/php/dists/
> >
> >Está vacío.
> >
> >Por eso siempre uso los alemanes:
> >
> >http://ftp.de.debian.org/debian/dists/jessie/main/binary-amd64/
> >
> >Aquí hay más chicha :-)
> >
> >> ¿A alguien le suena este error y cómo solucionarlo?
> >
> >Parece un error tontín, al fin y al cabo sólo estás actualizando los 
> >paquetes de Debian Jessie; la «fiesta» de la actualización aún no ha 
> >empezado...
> >
> 
> Camaleón, tengo esto en el sources.list:
> 
> deb http://ftp.de.debian.org/debian/ jessie main contrib non-free
> deb-src http://ftp.de.debian.org/debian/ jessie main contrib non-free
> 
> 
> deb http://httpredir.debian.org/debian jessie-updates main contrib non-free
 ^
> deb-src http://httpredir.debian.org/debian jessie-updates main contrib 
> non-free
> 
> 
> deb http://security.debian.org/ jessie/updates main contrib non-free
> deb-src http://security.debian.org/ jessie/updates main contrib non-free
> 
> 
> ¿Los cambio y dejó sólo el que tú me has puesto?

No, sólo el que te falla, que es un redirector y te lleva a un servidor 
que no tiene todos los paquetes.

Es decir, cambia este:

# deb http://httpredir.debian.org/debian jessie-updates main contrib non-free
# deb-src http://httpredir.debian.org/debian jessie-updates main contrib 
non-free

Por este:

deb http://ftp.de.debian.org/debian jessie-updates main contrib non-free
deb-src http://ftp.de.debian.org/debian jessie-updates main contrib non-free

Y prueba de nuevo:

apt-get update

Saludos,

-- 
Camaleón 



Re: Actualizar Debian Jessie a la última versión.

2022-09-06 Por tema Camaleón
El 2022-09-06 a las 19:54 +0200, Ramses escribió:

> Buenas a tod@s.
> 
> Quiero actualizar una máquina con Debian Jessie, concretamente es un
> contenedor LXC, a la última versión de Debian.
> 
> El problema que tengo es que, cuando hago un "apt update" me aparece el
> siguiente error:
> 
> -
> root@maquina:/# apt-get update
> Hit http://security.debian.org jessie/updates InRelease
> Ign http://httpredir.debian.org jessie InRelease
> Hit http://httpredir.debian.org jessie-updates InRelease
> .
> .
> .
> Get:7 http://httpredir.debian.org jessie/main Translation-en [4581 kB]
> Ign https://packages.sury.org jessie/main Translation-en
> Err https://packages.sury.org jessie/main amd64 Packages
>   server certificate verification failed. CAfile:
> /etc/ssl/certs/ca-certificates.crt CRLfile: none
> Get:8 http://httpredir.debian.org jessie/non-free Translation-en [72.0 kB]
> .
> .
> .
> Hit http://security.debian.org jessie/updates/contrib Translation-en
> Fetched 11.7 MB in 2min 1s (96.8 kB/s)
> W: Failed to fetch
> https://packages.sury.org/php/dists/jessie/main/binary-amd64/Packages
> server certificate verification failed. CAfile:
> /etc/ssl/certs/ca-certificates.crt CRLfile: none
> 
> E: Some index files failed to download. They have been ignored, or old ones
> used instead.

Cambia de servidor, ese no tiene el archivo que necesitas:

https://packages.sury.org/php/dists/

Está vacío.

Por eso siempre uso los alemanes:

http://ftp.de.debian.org/debian/dists/jessie/main/binary-amd64/

Aquí hay más chicha :-)

> ¿A alguien le suena este error y cómo solucionarlo?

Parece un error tontín, al fin y al cabo sólo estás actualizando los 
paquetes de Debian Jessie; la «fiesta» de la actualización aún no ha 
empezado...

Saludos,

-- 
Camaleón 



Re: Re: Fwd: Recuperar el espacio de lo ilegible.

2022-09-04 Por tema Camaleón
El 2022-09-04 a las 11:13 -0500, Aristobulo Pinzon escribió:

> > ¿ Puedo eliminar los otros sin ningún problema?
> 
> >> Sí, y elimina todo lo relacionado a esos kernels. Quédate con uno, el que 
> >> esté en uso.
> >>
> >>apt purge *5.10.0-9*
> >>
> 
> 
> >>Saludos,
> 
> >>Saludos también a todos y muchas gracias...
> 
> >>Saludos
> 
> >>JAP
> 
> Muchas gracias, Se recuperaron 800 megas.
> Eliminaré:
> synaptic: me defiendo bien con apt-get

A mí me hace cosas raras, no lo uso mucho pero me saca unos mensajes 
de error extraños que reiniciando la aplicación se van, pero creo que a 
Synaptic lo están dejando un poco «abandonado» :-(

(...)

> mutt que ya no funciona con yahoo ni gmail

(...)

Le has tomado manía al pobre Mutt :-)
A mí me funciona perfectamente con mi cuenta de Gmail, de hecho escribo 
este correo desde Mutt.

Saludos,

-- 
Camaleón 



Re: Fwd: Recuperar el espacio de lo ilegible.

2022-09-02 Por tema Camaleón
El 2022-09-01 a las 16:21 -0500, Aristobulo Pinzon escribió:

> Hola gente inteli...
> 
> Me estoy quedando sin espacio en la partición raíz y me aparece esto:
> 
> Tamaño:
> 
> 278107 elementos, en total 8,6 GiB (9.204.394.052 bytes)
> 
> (parte del contenido es ilegible)
> 
> 18,0 MiB libres de 9,4 GiB (99% en uso)
> 
> Cómo recupero el espacio de lo ilegible?

El mensaje debe ser del gestor de archivos Nemo, que ejecutado como 
usuario no tiene acceso a ciertos archivos, de ahí el mensaje críptico.

El cuando al espacio recuerda que el sistema de archivos ext3/4 se 
reserva el 5% del tamaño de la partición para sus cositas (5% de 9,5 GiB 
son unos 470 MiB).

Busca archivos gordos (en mi chuleta tengo esta orden: «du -BM | sort -nr | 
less») y mira a ver si los puedes eliminar (por ser de caché, paquetes 
deb que ya hayas instalado, registros que no necesites, etc...).

Saludos,

-- 
Camaleón 



Re: OT - "tuples" en Python

2022-08-31 Por tema Camaleón
El 2022-08-31 a las 12:18 -0300, Debian escribió:

> Buen día.
> 
> Estoy aprendiendo Python. Y como no puede ser de otra manera, la
> bibliografía está en inglés, o spanglish.
> 
> Entiendo informáticamente lo que es "tuples" según el diccionario Oxford: "a
> data structure consisting of multiple parts", o sea, una lista consistente e
> inalterable.
> 
> Ahora bien; no encuentro la traducción al español en el DRAE.
> Se estaría usando una palabra "spanglish" que es "tupla".
> 
> ¿Es correcto este término, o hay alguno más específico?

Es correcto. 
La RAE no alcanza términos científicos, hay que tirar de un corpus 
especializdo;

https://enclavedeciencia.rae.es/tupla

Saludos,

-- 
Camaleón 



Re: Error dirvish-expire bug #434334 : cannot open config file: /*/summary

2022-08-30 Por tema Camaleón
El 2022-08-30 a las 13:40 +0200, Sysadmin atlanTTic escribió:

Buf... no veo nada. 
Todo el cuerpo del correo está en formato multipart/mixed y ni el 
mailcap de Mutt lo puede reconocer.

>   He intentado encontrar una solución sobre este bug de Debianhref="mailto:434...@bugs.debian.org;>#434334 pero sin éxito. 
>   Realizo backups incrementales con dirvish dentro de un vault
>   /backup/vault1/. Al lanzar dirvish-expire falla con todos los
>   archivos con nombre "summary", parece que realiza una búsqueda
>   recursiva en la carpeta de origen de los datos, en lugar de
>   realizar solo en la carpeta /backup/vault1/ sin recursividad,
>   dando el mensaje de error:

> cannot open config file: 
> /opt/gitlab/embedded/service/gitlab-rails/lib/gitlab/cycle_analytics/summary

>   Lo más grave es que no solo informa,
>   también para el proceso de dirvish-expire, saturando la capacidad
>   del servidor y desbordando los sistemas de backup dejándolos
>   anulados

(...)

Parece que haste el Dirvish conocen el problema y «están trabajando en 
ello»:

Dirvish ToDo List

dirvish-expire
https://dirvish.org/svn/dirvish_1_2/TODO.html

Mientras tanto... pues no sabría decirte, quizá este hilo de su lista 
te pueda dar alguna idea:

[Dirvish] non-dirvish directories in the bank confuse dirvish-expire 
https://lists.dirvish.org/pipermail/dirvish/2005-February/thread.html#117

Saludos,

-- 
Camaleón 



Re: Error con claves repositorios

2022-08-30 Por tema Camaleón
El 2022-08-29 a las 09:57 -0400, Carlos Alberto Viur Diaz escribió:

(...)

> root@debian:/home/cviur# sudo apt-get update

> Err:4 https://ftp.postgresql.org/pub/pgadmin/pgadmin4/apt/bullseye pgadmin4
> InRelease
> Las firmas siguientes no se pudieron verificar porque su clave pública no
> está disponible: NO_PUBKEY 8881B2A8210976F2
> Leyendo lista de paquetes... Hecho
> W: Error de GPG:
> https://ftp.postgresql.org/pub/pgadmin/pgadmin4/apt/bullseye pgadmin4
> InRelease: Las firmas siguientes no se pudieron verificar porque su clave
> pública no está disponible: NO_PUBKEY 8881B2A8210976F2
> E: El repositorio «
> https://ftp.postgresql.org/pub/pgadmin/pgadmin4/apt/bullseye pgadmin4
> InRelease» no está firmado.
> N: No se puede actualizar de un repositorio como este de forma segura y por
> tanto está deshabilitado por omisión.
> N: Vea la página de manual apt-secure(8) para los detalles sobre la
> creación de repositorios y la configuración de usuarios.

Tendrás que actualizar la clave del repositorio de PostgreSQL:

How to Install pgAdmin on Ubuntu?
https://daxdax89.com/how-to-install-pgadmin-on-ubuntu/

Saludos,

-- 
Camaleón 



Re: [OT] Debian decide sobre su política de paquetes firmware «non-free»

2022-08-29 Por tema Camaleón
El 2022-08-29 a las 10:33 +0200, Javier Barroso escribió:

> Hola,
> 
> El lun., 29 ago. 2022 9:10, Camaleón  escribió:
> 
> > El 2022-08-29 a las 07:35 +0200, Javier Barroso escribió:
> >
> > Hola Javier,
> >
> > > El dom., 28 ago. 2022 10:11, Camaleón  escribió:
> > >
> > > > Hola,
> > > >
> > > > A través de Phoronix¹ leo que en Debian² se está llevando a cabo una
> > > > consulta sobre la política a seguir con los paquetes de firmware
> > > > non-free, que actualmente se tienen que instalar por separado y de
> > > > manera plenamente consciente, con el consiguiente perjuicio que causa
> > > > en las instalaciones, principalmente a los nuevos usuarios.
> >
> > (...)
> >
> > > >  ...
> > > >
> > > > ¿Qué pensáis?
> > >
> > >
> > > La opción A sí informa de qué se instala (al menos lo interpreto así),
> >
> > No me queda claro este punto.
> >
> > Si el usuario va a descargar la ISO de Debian para instalar y sólo ve
> > una opción (porque con la opción A sólo hay una imagen oficial que
> > contiene firmware non-free) pocas alternativas tiene ese usuario.

(...)

> > > Aún con un instalador libre vas a estar corriendo tu equipo con firmwares
> > > no libres (los que van integrados en la tarjeta gráfica, de red, etc),
> >
> > No, no... eso no es así, Javier.
> >
> > Yo ahora mismo no tengo habilitado el repo «non-free» y espero que mi
> > equipo no tenga ninguna pieza de software de código cerrado, faltaría
> > más.
> >
> 
> Ese es el tema da igual que tengas habilitado o no el repo non-free, las
> tarjetas gráficas y demás ya tienen incorporados su propio firmware antes
> de que el SO ponga nada. Ese firmware no es libre en el 99.9% de las veces
> 
> ¿Ahora me explico mejor?

La BIOS/UEFI tampoco es libre pero no es algo sobre lo que tengamos el 
control, ni nosotros ni Debian.

De lo que se trata en la decisión que tenga que tomar Debian es, 
primero de carácter técnico (¿quién y cómo se determina si debo/tengo 
que instalar cierto firmaware propietario o no?) y luego de carácter 
vocacional (¿hacia dónde queremos dirigirnos, debemos fomentar el uso de 
códígo porpietario?).

La opción A pretende «automatizar» y «simplificar» en exceso esa 
decisión, yo prefiero que sea el usuario quien decida lo que quiere 
hacer y que sea consecuente y plenamente consciente de sus actos, y que
de manera predeterminada se fomente desde Debian las opciones libres, 
obviamente.

Para que decidan por mi ya están Windows o Android :-)

Saludos,

-- 
Camaleón 



Re: Cursos en Madrid

2022-08-29 Por tema Camaleón
El 2022-08-29 a las 09:08 +0200, Yair De la cruz escribió:

> Buenos días estimada comunidad @debian-user-spanish@lists.debian.org
> ,
> 
> Vengo a solicitar su amable y siempre apreciado consejo,
> 
> Quiero realizar un curso de Linux, tengo conocimientos en debian pero algo
> muy básico,
> 
> Me podrían recomendar algún curso completo y económico?

El mejor curso autodidacta, la guía de referencia de Debian y el manual
del administrador (también en español):

https://www.debian.org/doc/user-manuals

https://www.debian.org/doc/manuals/debian-reference/index.en.html
https://debian-handbook.info/
 
> Puede ser tanto online como presencial, vivo en Madrid.
> 
> Saludo y muchas gracias.

Para algo oficial y reglado, los cursos y certificados de LPI (online y 
presencial) para linux en general:

https://www.lpi.org/es

Saludos,

-- 
Camaleón 



Re: [OT] Debian decide sobre su política de paquetes firmware «non-free»

2022-08-29 Por tema Camaleón
El 2022-08-29 a las 07:35 +0200, Javier Barroso escribió:

Hola Javier,

> El dom., 28 ago. 2022 10:11, Camaleón  escribió:
> 
> > Hola,
> >
> > A través de Phoronix¹ leo que en Debian² se está llevando a cabo una
> > consulta sobre la política a seguir con los paquetes de firmware
> > non-free, que actualmente se tienen que instalar por separado y de
> > manera plenamente consciente, con el consiguiente perjuicio que causa
> > en las instalaciones, principalmente a los nuevos usuarios.

(...)

> >  ...
> >
> > ¿Qué pensáis?
> 
> 
> La opción A sí informa de qué se instala (al menos lo interpreto así), 

No me queda claro este punto.

Si el usuario va a descargar la ISO de Debian para instalar y sólo ve 
una opción (porque con la opción A sólo hay una imagen oficial que 
contiene firmware non-free) pocas alternativas tiene ese usuario.

Porque una vez que el instalador está en ejecución, poco margen de 
maniobra tienes. Es decir, con la opción A facilitas las cosas al lado 
oscuro y se las complicas a los caballeros Jedi.

Es como darle un sable de luz a Vader y una ramita a Skywalker... y que 
luchen :-)

No me parece justo, además de con esa acción fomentas el uso de 
firmware non-free en lugar de hacer pensar al usuario sobre las 
consecuencias de su uso, instruirle sobre el hardware que compra o las 
opciones que tiene.

> lo que yo creo que sería deseable es que te dijera el instalador , 
> "se va a instalar los componentes non free que te proporcionan la 
> siguientes funcionalidades:
> 
> - 
> - 
> 
> Aceptar / instalar sin esos componentes (o incluso, (de)seleccione los
> componentes non free y pulsa siguiente)
> 
> Donde  e  son tanto los nombres de los componentes como su
> descripción corta

Ojalá fuera tan sencillo.

Me temo que simplemente si el kernel «piensa» que necesita cierto 
código para funcionar, lo instalará, sin más, pero queda por resolver 
la cuestión técnica de si realmente el sistema necesita ese chorro de 
software binario cerrado para funcionar sin problemas.

La parte técnica NO es está resuelta.
 
> En la lista de debian-vote daban el argumento de la accesibilidad (para
> ciegos por ejemplo) como algo fundamental para el instalador.

Desconozco qué tipo de software-hardware gestiona esto, pero supongo 
que será como en todo: lo habrá cerrado y lo habrá libre. Y los 
usuarios que necesiten usarlo están en la misma tesitura que los demás: 
decidir qué usar y con pleno conocimiento de lo que hacen.

> Aún con un instalador libre vas a estar corriendo tu equipo con firmwares
> no libres (los que van integrados en la tarjeta gráfica, de red, etc), 

No, no... eso no es así, Javier.

Yo ahora mismo no tengo habilitado el repo «non-free» y espero que mi 
equipo no tenga ninguna pieza de software de código cerrado, faltaría 
más.

Aunque se trata de algo distinto¹, hubo un momento en que sí instalaba 
el controlador propiedario de nvidia, pero ahora, aún y todo lo mal que 
está nouveau, me vale con el libre.

> en mi opinión facilitar al usuario el mejor rendimiento del equipo es lo
> deseable. Los firmwares llevan "toda la vida" en los repositorios, esto es
> ponerlos en el instalador al alcance de cualquiera.

Llevan toda la vida en repos separados y no habilitados de manera 
predeterninada, que no es lo mismo. 

Creo, sinceramente, que la base de Debian, y de cualquier sistema Linux 
debe ser la educación consciente del usuario, en hacer bien las cosas y 
no en atender a una necesidad o capricho puntual del usuario (eso 
significa pan para hoy y hambre para mañana).

Uno de los fines últimos de un sistema operativo libre debe ser hacer 
pensar. Si perdemos eso, perderemos nuestra esencia.
 
> Para los puristas con activar el modo libre al arrancar (igual que hemos
> estado usando el modo experto mucho tiempo) les tendría que ser suficiente

Yo quiero más ;-)

Quiero poder indentificarme con los valores que promueve mi sistema 
operativo, que el sistema operativo que elijo esté en mi misma línea de 
acción y de pensamiento. Y con este paso que dan se aleja más de lo que 
espero de una distribución como Debian.

De RedHat o Ubuntu lo puedo esperar; de Debian, no.

> Cualquiera de las tres opciones será buena para Debian y sus usuarios

Me cuesta ver algo bueno en recomendar y promover software propietario, 
la verdad :-/

¹Lo que se debate ahora en Debian está relacionado exclusivamente con 
el código firmware, no con programas o controladores propietarios.

Saludos,

-- 
Camaleón 



[OT] Debian decide sobre su política de paquetes firmware «non-free»

2022-08-28 Por tema Camaleón
Hola,

A través de Phoronix¹ leo que en Debian² se está llevando a cabo una 
consulta sobre la política a seguir con los paquetes de firmware 
non-free, que actualmente se tienen que instalar por separado y de 
manera plenamente consciente, con el consiguiente perjuicio que causa 
en las instalaciones, principalmente a los nuevos usuarios.

En fin, la habitual dicotomía entre hacer lo correcto y sufrir un poco 
las consecuencias o pasarse al lado oscuro (lo que yo llamo «el 
modo vago»).

Las alternativas que hay sobre la mesa son:

A. Meter los paquetes de firmware non-free dentro del medio de 
instalación, como si fueran uno más, sin que sea obligatoio informar al 
usuario de esto.

B. Meter los paquetes non-free en el medio de instalación oficial pero 
sólo cargarlos / instalarlos si son necesarios, informando al usuario y 
permitiendo desactivar previamente esta opción.

Se mantienen dos medios por separado, dando preeminencia al medio de 
instalación que contienen los paquetes de non-free.

C. Un poco como la situación actual, dos medios de instalación separados
para que el usuario elija cuál descargar e instalar.

Desde mi punto de vista, la opción A no me convence en absoluto, 
significa claudicar.

De la opción B no me fío, porque el kernel recomienda paquetes non-free 
que no son necesarios así que el automatismo no funciona.

La opción C es la menos mala y la más sincera con los usuarios, pero 
perjudica a los nuevos o a los más novatos que tienen que buscar e 
informarse... lo que tampoco es malo >:-)

¿Qué pensáis?

¹https://www.phoronix.com/news/Debian-Non-Free-Firmware-GR
²https://www.debian.org/vote/2022/vote_003

Saludos,

-- 
Camaleón 



Re: OT Al instalar Debian borre las particiones incluido la de arranque

2022-08-27 Por tema Camaleón
El 2022-08-27 a las 00:09 +, Eduardo Jorge Gil Michelena escribió:

(...)

> Primero... las distribuciones "netinstall" suelen dar más problemas que las 
> "completas" por dos razones: la primera es que si la instalación no detecta 
> bien el puerto de red... sonaste; la segunda es que si la conexión de 
> internet no es fiable y se corta... también sonaste.

Cierto, pero si sólo instalas el sistema base me parece que no se 
conecta a Internet.

Yo normalmente instalo la NETISO sin entorno gráfico, y una vez 
iniciado el sistema tras el primer arranque, empiez con la fiesta de los 
paquetes, desactivando previamente las recomendaciones y las 
sugerencias en APT.

> Segundo... las distribuciones "testing" suelen ser muy apetecibles para los 
> genios de las pruebas pero no tanto para los usuarios comunes.

(...)

Cierto, pero muchas veces sucede al revés, que de tan antigua que es la 
versión estable de Debian tiene un montón de paquetes con fallos sin 
corregir.

La versión testing de Debian es suficientemente estable, la verdad, y 
salvo en determinados momentos críticos (cuando sala una nueva estable 
y los repos van locos) conviene no actualizar los paquetes pero poco más.

Para un usuario domético con cierta cautela, testing es una buena opción.

Saludos,

-- 
Camaleón 



Re: OT Al instalar Debian borre las particiones incluido la de arranque

2022-08-27 Por tema Camaleón
El 2022-08-26 a las 19:42 +0100, José Manuel (Abogado) escribió:

> Tengo un portátil ASUS F552C que tenía Windows, y quería instalar Debian, me
> descargue la imagen debian-testing-amd64-netinst, y al instalar borre todas
> las particiones incluida la de arranque que tenía el disco duro e instale
> Debian y iba bien hasta que se reinicio y no arranca el sistema, entra
> siempre en los BIOS.
> He mirado en Google pero no encuentro la solución, si es que la hay. Por lo
> que me dirijo a la lista para ver si me puede ayudar indicándome  si hay
> alguna solución o tengo que dar por perdido el portátil. Gracias de antemano
> 
> Espero noticias.

Por el síntoma que indicas (arranca directamente con la BIOS), me da la 
sensación de que la UEFI/BIOS del portátil estaba configurada para 
iniciar con la partición de Windows, y al no encontrarla, se para.

No he tocado aún ninguna UEFI así que no sabría darte indicaciones 
exactas para resolver el problema, pero me da las ensución de que 
tendrás que ver la forma de decirle al portátil que no haga caso de 
todas las configuraciones de seguirdad que tendrá configuradas por eso 
del Trusted Computing y demás gaitas de Intel-Microsoft, y que quieres 
cargar con la partición de la UEFI que te te habrá instalado la NETISO 
de Debian.

Saludos,

-- 
Camaleón 



Re: placa de sonido ALC887-VD no detectada

2022-08-25 Por tema Camaleón
El 2022-08-24 a las 17:52 -0300, Marcelo Eduardo Giordano escribió:

> Usando debian 11 kde no logro hacer funcionar la placa de sonido ALC887-VD.
> 
> Al ejecutar el comando "aplay -l" me sale la placa, pero cuando hago click
> en el ícono del parlantito no me da la posibilidad de cambiar el
> "Dispositivo de Reproducción" ya que no me aparece.

No me queda claro el origen del problema.

Entiendo que el sistema detecta la tarjeta correctamente pero que no 
aparece disponble para configurar en el complemento de la bandeja del 
sistema (el icono del altavoz).

Esto puede ser por un error del servidor de sonido (entiendo que usas 
pulseaudio) o también a que tienes una tarjeta de sonido digital (HDMI) 
que está como predeterminada en lugar de la analógica.

Revisa los registros (como root, «journalctl | grep -i audio» y «dmesg | 
grep -i audio») por si vieras algún error.

En cualquier caso, te paso algunos enlaces por si te sirven:

How to get Realtek ALC887-VD to play any sound or be recognized in 
Debian 11 (fresh install)?
https://unix.stackexchange.com/questions/691396/how-to-get-realtek-alc887-vd-to-play-any-sound-or-be-recognized-in-debian-11-fr

No Sound Fix Tips
http://mreen.epizy.com/SoundFixTips.html?i=2

Sortie audio analogique indisponible (ALC887)
https://forums.linuxmint.com/viewtopic.php?t=337580

Saludos,

-- 
Camaleón 



Re: Ltsp + windows

2022-08-20 Por tema Camaleón
El 2022-08-19 a las 17:10 -0400, Eriel Perez Orihuela escribió:

> Hola Lista.
> 
> No se si puse bien el asunto, pero necesito poner clientes ligeros:
> 
> Server: Solucion linux. (Ltsp u otro)
> 
> Cliente: Windows 10 - 11
> 
> Algun manual, video, tutorial, foto, lo que sea es bienvenido.
> 
> Desde ya Gracias.

No sé si he entendido lo que buscas o lo que quieres / necesitas hacer.

Una solución LTSP requiere que servidor y clientes compartan el mismo 
sistema operativo. Quizá con máquinas virtuales en el host pero me 
parece muy enrevesado :-/

¿Has pensando en usar máquinas virtuales puras en lugar de LTSP?

Como ves, no han cambiado mucho las cosas desde la última vez que lo 
preguntaste:

LTSP Server con clientes Windows
https://lists.debian.org/debian-user-spanish/2019/01/msg00090.html

Saludos,

-- 
Camaleón 



Re: Instalar Linux a un SSD

2022-08-20 Por tema Camaleón
El 2022-08-19 a las 20:25 +, Eduardo Jorge Gil Michelena escribió:

> Estimada gente:
> 
> Este fin de semana voy a instalar un linux a un disco SSD.
> ¿Alguna recomendación?
> Me han dicho que NO haga particiones (me parece correcto pero pregunto por 
> las dudas)

Desde que instalé mi primer Linux (SuSE 8.2 allá por el año 2005) nunca he 
hecho 
particiones de disco (salvo las estrictamente necesarias, esto es, para 
la partición de la memoria virtual de intercambio /swap) y me han 
llovido críticas a raudales :-). 

Ahora que los discos son gigantes, soy más partidaria de particionar 
para no tener volúmenes mayores de 500 GiB. En cambio, ahora se 
recomienda no hacer particiones. Je.

Si la SSD tiene «poca» capacidad (<500 GiB) yo no haría ninguna 
partición. Eso sí, ten un buen plan para copias de seguridad (p. ej., 
usar un segundo disco local de tipo mecánico gordote o conectado en 
red).

La única sugerencia sería sobre el sistema de archivos a usar (yo he 
pasado de ReiserFS a XFS) y que si necesitas definir memoria virtual, 
uses un archivo para swap en lugar de una partición, no recuerdo si el 
instalador haca esa sugerencia.

> La PC tendrá dos discos SSD (uno de arranque y uno de datos) y eventualmente 
> un disco más de los tradicionales.

Los discos duros, sean mecánicos o SSD, mejor siempre con garantía de 5 
años (los que llaman de gama empresarial) y te olvidas de problemas (si 
fallan, ejecutas la garantía y si en 5 años no han fallado normalmente te
duran toda la vida).

> Me gustaría, luego de instalar, anular la escritura de log porque en 
> verdad... nunca los leo y eso que llevo años con linux. ahorraría 
> escrituras/escrituras y un poquito de espacio. 

Creo que eso es una MALA idea. Los registros de Linux son un regalo 
divino que no debes menospreciar ya que te ayudan mucho con la depuración 
de problemas. Siempre puedes reducir la verbosidad pero de verdad que 
con el logrotate configurado como viene de serie no te va a dar 
guerra. Más vale prevenir que lamentar.

> Para instalar usaré PEN drive booteable creado con el Unetbootin ¿hay alguno 
> mejor?

Para instalar Windows sí tiro de Rufus o similares pero si tengo que 
instalar Debian desde una la llave USB (normalmente bajo la NETISO y la 
quemo en un miniCD), directamente desde la ISO híbrida de Debian:

4.3.1. Preparación de una memoria USB utilizando una imagen híbrida de CD/DVD
https://www.debian.org/releases/stable/amd64/ch04s03.es.html#usb-copy-isohybrid

Saludos,

-- 
Camaleón 



Re: IP por DHCP dejó de funcionar en Debian "bullseye"

2022-08-19 Por tema Camaleón
El 2022-08-18 a las 21:59 -0300, JavierDebian escribió:

> Buenas noches.
> 
> Me ha pasado algo extraño.
> Debian 11 "bullseye" con kernel 5.10.0-16-amd64.
> Network-manager prohibido en el sistema, lo odio porque hace lo que quiere.
> Computadora que funciona desde hace 6 años con configuración de red por DHCP
> automática, configurado "a mano" por interfaces.
> resolvconf corriendo como demonio.
> 
> Hace un par de días, se puso remolona para tomar dirección IP. Reiniciado el
> enrutador y el equipo un par de veces, lo achaqué a problemas del enrutador
> o del servicio provisto por mi ISP, un CISCO Technicolor DPC3848VE DOCSIS
> 3.0, empresa Flow/Personal/Fibertel Argentina.

El problema de tener el servidor de DHCP en equipos restringidos 
(routers, switches o dispositivos integrados) es que apenas permiten 
depurar los errores en caso de presentarse problemas.

> Hoy hizo lo mismo; intenté la solución anterior y no hubo caso.
> Cambié cable de conexión, sin éxito.
> "¿Será la placa de red?"
> Arranqué Windows desde otra partición; conexión impecable, no es ni el cable
> ni la placa ni el enrutador.
> Arranco un SystemRescueCD, y toma la dirección sin problemas.
> Vuelvo a Debian, no toma dirección IP.
> Levanto una máquina VirtualBox en Debian que corre un Win7 con la red en
> modo puente... toma la dirección sin inconvenientes
> 
> Configuro la red en forma manual, con IP fija y todo a mano
> Funciona sin inconvenientes.
> 
> Vuelvo atrás, a configurar por DHCP automático; no funciona, pero sólo en
> Debian 11.
> Cambio a kernel 5.10.0-13, no sea que el kernel nuevo tenga algún problema,
> aún siendo "stable"; sigue sin funcionar.
> 
> Ahora estoy en modo IP estático, funcionando sin problemas... salvo que no
> puedo volver a DHCP dinámico, porque no funciona.
> 
> Para usar la máquina, no me afecta, pero... NO ME GUSTA QUE EL SISTEMA HAGA
> COSAS QUE NO DEBERÍA HACER, O NO HAGA LO QUE SÍ.
> 
> Seguiré investigando.
> 
> Si a alguno le pasó algo así, escucho sugerencias.

Yo probaría lo siguiente:

1. Fuerza la renovación de la IP, a ver si el Cisco le asigna otra 
nueva y se puede configurar el adaptador de red sin problemas.

Dependiendo de qué cliente dhcp uses (hoy en día me pierdo con tantas 
opciones: systemd, dhclient, network-manager...) tendrás que hacer una 
cosa u otra para renovar los datos del adaptador:

Linux Force DHCP Client (dhclient) to Renew IP Address
https://www.cyberciti.biz/faq/howto-linux-renew-dhcp-client-ip-address/

2. A modo de prueba, y si te resulta posible, configura otro servidor o 
sistema (router/switch) como servidor DHCP (desconecta el Cisco de la 
red para evitar conflictos) a ver si el Debian 11 puede configurarse 
preguntando a otro servidor.

3. Revisa los registros para ver qué puede estar fallando (syslog, 
journalctl) o intenta configurar el adpatador de red desde línea de 
órdenes (con dhclient -v...) para ver si tienes más información del 
problema, recibes un timeout, etc...

Saludos,

-- 
Camaleón 



Re: problema con Processing, Java y OpenGL

2022-08-02 Por tema Camaleón
El 2022-08-02 a las 03:27 -0300, Daniel escribió:

Buf... quito el formato html, mi pobre Mutt sólo ve una morcilla.

(...)

>   Resumiendo: la misma aplicación/script hecha en Processing (y
>   ejemplos similares que usan OpenGL) funciona perfecto desde el
>   fuente, con el IDE de Processing corriendo (ejecutado usando la
>   sintaxis con la variable de entorno antes ya comentada). Pero el
>   ejecutable compilado no funciona si usa "P2D" o "P3D" (incluso
>   seteando la variable de entorno que soluciona todo corriendo
>   Processing).

(...)

Prueba con algunas de las opciones que indican por aquí:

3D amb processing
https://wiki.controlonline.net:1029/doku.php?id=tutorials:processing:19_3d

Principalmente, introducir dentro del código de la aplicación la opción 
para desactivar «openglcore», porque entiendo que las otras dos 
opciones ya las has probado sin éxito.

La página está en valenciano, si quieres traducirla con Google elige 
la pareja Catalán a Español.

Saludos,

-- 
Camaleón 



Re: Nouveau me pide firmware de non-free (?)

2022-07-29 Por tema Camaleón
El 2022-07-28 a las 20:26 +0200, Camaleón escribió:

> Al instalar Debian 11, tras generar la imagen del kernel, me aperece 
> este mensaje (lo recorto porque la lista es larga):
> 
> Configurando linux-image-5.10.0-16-amd64 (5.10.127-2) ...
> /etc/kernel/postinst.d/initramfs-tools: update-initramfs: Generating 
> /boot/initrd.img-5.10.0-16-amd64
> W: Possible missing firmware /lib/firmware/nvidia/gp100/acr/ucode_load.bin 
> for module nouveau
> W: Possible missing firmware /lib/firmware/nvidia/gp100/acr/bl.bin for module 
> nouveau
> W: Possible missing firmware /lib/firmware/nvidia/gm206/acr/ucode_load.bin 
> for module nouveau
> W: Possible missing firmware /lib/firmware/nvidia/gm206/acr/bl.bin for module 
> nouveau
> W: Possible missing firmware /lib/firmware/nvidia/gm204/acr/ucode_load.bin 
> for module nouveau
> W: Possible missing firmware /lib/firmware/nvidia/gm204/acr/bl.bin for module 
> nouveau
> W: Possible missing firmware /lib/firmware/nvidia/gm200/acr/ucode_load.bin 
> for module nouveau
> W: Possible missing firmware /lib/firmware/nvidia/gm200/acr/bl.bin for module 
> nouveau
> W: Possible missing firmware /lib/firmware/nvidia/gp100/acr/ucode_unload.bin 
> for module nouveau
> W: Possible missing firmware /lib/firmware/nvidia/gm206/acr/ucode_unload.bin 
> for module nouveau
> 
> (...)
> 
> Bien, quiere que instale el paquete "firmware-misc-nonfree 
> (20210315-3)" (non-free).
> 
> Tengo una viejita Quadro NVS 440 y desde hace ya varios años no instalo 
> el driver propietario de nvidia sino Nouveau, pero nunca he necesitado 
> instalar firmware binario para eta tarjeta.
> 
> root@stt008:~# lspci | grep -i vga
> 03:00.0 VGA compatible controller: NVIDIA Corporation NV43 [Quadro NVS 440] 
> (rev a2)
> 04:00.0 VGA compatible controller: NVIDIA Corporation NV43 [Quadro NVS 440] 
> (rev a2)
> 
> ¿Desde cuándo hay que instalar estos firmwares con el driver libre? :-?

Después de indagar un poco (foros, listas, revisar bugzillas, etc...) he 
llegado a la conclusioón de que se trata de un mensajer verboso habitual, 
al generar la imagen del kernel cuando cargas el módulo nouveau, pero 
nada más.

Supongo que instalando el paquetón «firmware-misc-nonfree» disponible 
en los repos, o descargando manualmente¹ sólo los archivos que pide y 
dejándolos en su ruta (/lib/firmware/nvidia...) ya no se quejará pero 
mi duda era más bien si necesitaba esos binarios y la respuesta es que, 
para mi tarjeta (nv43²), entiendo que no, que no hay necesidad alguna ni 
tampoco ganancia, más allá de no ver el mensaje de aviso.

Se ve que los binarios propietarios los pueden necesitar las tarjetas 
gráficas de nvidia más modernas, para activar o mejorar la aceleración 
por hardware, reproducción de vídeo, etc...

¹https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git/tree/nvidia
²https://nouveau.freedesktop.org/CodeNames.html

Saludos,

-- 
Camaleón 



Nouveau me pide firmware de non-free (?)

2022-07-28 Por tema Camaleón
Hola,

Al instalar Debian 11, tras generar la imagen del kernel, me aperece 
este mensaje (lo recorto porque la lista es larga):

Configurando linux-image-5.10.0-16-amd64 (5.10.127-2) ...
/etc/kernel/postinst.d/initramfs-tools: update-initramfs: Generating 
/boot/initrd.img-5.10.0-16-amd64
W: Possible missing firmware /lib/firmware/nvidia/gp100/acr/ucode_load.bin for 
module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp100/acr/bl.bin for module 
nouveau
W: Possible missing firmware /lib/firmware/nvidia/gm206/acr/ucode_load.bin for 
module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gm206/acr/bl.bin for module 
nouveau
W: Possible missing firmware /lib/firmware/nvidia/gm204/acr/ucode_load.bin for 
module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gm204/acr/bl.bin for module 
nouveau
W: Possible missing firmware /lib/firmware/nvidia/gm200/acr/ucode_load.bin for 
module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gm200/acr/bl.bin for module 
nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp100/acr/ucode_unload.bin 
for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gm206/acr/ucode_unload.bin 
for module nouveau

(...)

Bien, quiere que instale el paquete "firmware-misc-nonfree 
(20210315-3)" (non-free).

Tengo una viejita Quadro NVS 440 y desde hace ya varios años no instalo 
el driver propietario de nvidia sino Nouveau, pero nunca he necesitado 
instalar firmware binario para eta tarjeta.

root@stt008:~# lspci | grep -i vga
03:00.0 VGA compatible controller: NVIDIA Corporation NV43 [Quadro NVS 440] 
(rev a2)
04:00.0 VGA compatible controller: NVIDIA Corporation NV43 [Quadro NVS 440] 
(rev a2)

¿Desde cuándo hay que instalar estos firmwares con el driver libre? :-?

Saludos,

-- 
Camaleón 



Re: [OT] Tema para XFCE 4.16

2022-07-25 Por tema Camaleón
El 2022-07-24 a las 19:21 +0200, Camaleón escribió:

> El caso es que al instalar XFCE4 no me ha instalado ningún tema/estilo, 
> está un poco feote :-P y me preguntaba cuál es el tema que instala 
> Debian de mansera predeterminada en XFCE cuando eliges ese entorno de 
> escritorio.

(...)

Pues después de indagar un poco, parece que ninguno... bueno, 
oficiosamente Greybird, está muy pulido para XFCE.

(...)

> Se busca:
> 
> - Tema claro, vamos, el de toda la vida, blanco de fondo, barras grises
> 
> - En Stretch tenía instalado Clearlooks-Phenix, eltipo industrial  de 
> Gnome de toda la vida que es lo que busco.
> 
> - Prefiero un tema que no sea plano, no los entiendo.
> 
> - A ser posible, que esté disponible en los repos de Debian.
> 
> Se admiten, y se agradecen, sugerencias :-)

Menudo susto me he llevado al abrir The Gimp sin tener un tema
instalado. Raleigh en estado puro :-D

Al final he instalado Greybird, desde los repos de Debian, para 
tener alguno que sea compatible con la versión de GTK+3 instalada y 
también he instalado manualmente XFCE ClassicLooks, que aunque no lo he 
encontrado en los repos, al menos no es un tema tan oscuro.

Como nota curiosa añado que Clearlooks-Phenix sigue estando disponible 
(no en los repos pero sí desde su web), pero arroja muchos errores de 
estilo, no me termina de convencer.

Saludos,

-- 
Camaleón 



Re: Asunto: Re: https://debian.pkgs.org ( Es seguro)

2022-07-24 Por tema Camaleón
El 2022-07-24 a las 17:59 -, Jefferson Smith Pizarro Gutierrez escribió:

Reenvío a la lista, me llegó al privado.

> Gracias, lo que sucede es que necesito instalar este plugin: kodi-vfs-rar
> esta pagina ofrece la posibilidad de utilizarlo: 
> https://debian.pkgs.org/11/multimedia-main-amd64/kodi-vfs-rar_19.0.1-dmo0+deb11u1_amd64.deb.html

Apunta al repositorio de Debian multimedia, que es un viejo conocido:

https://wiki.debian.org/DebianRepository/Unofficial

Hace mucho que no oía nada de ese repo, pero hace unos años (casi) todos 
los usaurios de Debian lo teníamos añadido en nuestro «sources.list» :-)

Si lo necesitas y no lo encuentras en la página oficial del proyecto, 
puedes instalarlo desde esa fuente, sólo *ten cuidado con las 
dependencias* y no dejes el repo habilitado: instala el paquete y 
desactívalo de nuevo (vete buscando actualizaciones de ese paquete 
manualmente).

> El 22 de jul. de 2022, a las 12:50 a. m., Camaleón  ha(n)
> escrito:El 2022-07-22 a las 01:29 -, Jefferson Smith Pizarro Gutierrez
> escribió:Esta pagina es segura para descargar apps y demas en
> debian?https://debian.pkgs.org¿Contiene paquetes .deb? :-?Para localizar
> paquetes y saber cómo instalarlos no viene mal.Ahora bien, como de cada
> paquete te dice dónde está el recurso o paquete original, personalmente
> preferiría ir a la fuente originaria y bajarlo de ahí y creo que de hecho es
> así como funciona la página, es decir, no es un mega repositorio sino que te
> dice dónde puedes descargarlo.Saludos,-- Camaleón

Saludos,

-- 
Camaleón 



[OT] Tema para XFCE 4.16

2022-07-24 Por tema Camaleón
Hola,

Acabo de instalar Debian 11 y, como siempre, lo hago desde una NETISO y 
voy instalando paquetes después. 

El caso es que al instalar XFCE4 no me ha instalado ningún tema/estilo, 
está un poco feote :-P y me preguntaba cuál es el tema que instala 
Debian de mansera predeterminada en XFCE cuando eliges ese entorno de 
escritorio.

En mi equipo de pruebas (Debian testing) he probado con varios temas 
pero ninguno me termina de convencer. He descartado:

- Arc, es precioso, el tema ideal para mi gusto pero el texto es tan claro
que resulta ilegible.

- Greybird, no tiene un tema claro (gris), la barra de tareas es negra.

- Materia, tampoco pinta la barra de tareas en gris.

Se busca:

- Tema claro, vamos, el de toda la vida, blanco de fondo, barras grises

- En Stretch tenía instalado Clearlooks-Phenix, eltipo industrial  de 
Gnome de toda la vida que es lo que busco.

- Prefiero un tema que no sea plano, no los entiendo.

- A ser posible, que esté disponible en los repos de Debian.

Se admiten, y se agradecen, sugerencias :-)

Saludos,

-- 
Camaleón 



Re: https://debian.pkgs.org ( Es seguro)

2022-07-21 Por tema Camaleón
El 2022-07-22 a las 01:29 -, Jefferson Smith Pizarro Gutierrez escribió:

> Esta pagina es segura para descargar apps y demas en 
> debian?https://debian.pkgs.org

¿Contiene paquetes .deb? :-?

Para localizar paquetes y saber cómo instalarlos no viene mal.

Ahora bien, como de cada paquete te dice dónde está el recurso o 
paquete original, personalmente preferiría ir a la fuente originaria y 
bajarlo de ahí y creo que de hecho es así como funciona la página, es 
decir, no es un mega repositorio sino que te dice dónde puedes 
descargarlo.

Saludos,

-- 
Camaleón 



Re: [OT][OT][OT][OT]Protocolo de comunicación con relojes de asistencia de personal

2022-07-19 Por tema Camaleón
El 2022-07-18 a las 20:08 -0300, Jorge A. Secreto escribió:

> Hola, Disculpen el OT pero ya no sé dónde/cómo buscar.
> Necesito comunicarme (leer los registros) por IP, con unos relojes de
> asistencia que no reportan todas las asistencias al programa de personal.

Entiendo que el sistema de control biométrico tendrá algún tipo de software 
propietario para gestionar/acceder a esos datos ¿no te permite el 
software depurar el error para el saber el motivo de por qué no se entregan 
todos los registros?

Salvo contadas excepciones, ese tipo de software es cerrado (muy 
cerrado) y complejo de integrar salvo que tengas contacto directo con 
el fabricante como desarrollador o asociado.

> Supongo que tiene que haber algún protocolo razonablemente estándar porque
> varios programas de diferentes fabricantes pueden comunicarse con estos
> relojes, a pesar de que son chinos, rebranded. El proveedor no provee esa
> info y llevo mas de un mes (de a ratos) intentando distintas formas de
> preguntar en Google y lo mas cerca que llego es a que me ofrezca relojes
> parecidos en Ali Express.

Normalmente se comunican a través de RS232/485, TCP/IP, USB (depuración en 
local), o los más modernitos, WiFi.

> Intenté analizar el tráfico IP con wireshark pero es todo binario. Supongo
> que no está encriptado porque programas no relacionados lo pueden manejar.
> Por eso también supongo que debe estár definido en el protocolo de
> comunicación la manera de convertir eso a texto.
> Si alguien ya renegó con esto y me puede dar una pista me dará una gran
> mano.
> Sepan disculpar la molestia
> Muchas gracias

En la empresa usamos un control de acceso (con lectores de PIN + tarjeta 
de proximidad RFID), y a duras penas está funcionando, vamos, 
que si deja de funcionar -y requiere de windows xp) no sabría ni por 
dónde empezar (el aplicativo se llama NStar de Honeywell).

Si puedes contactar con el fabricante, aunque sólo sea para que te dé 
alguna pista de por dónde tirar para resolver el problema con los 
registros que no se reportan, mejor.

Saludos,

-- 
Camaleón 



Re: DebConf 2022

2022-07-19 Por tema Camaleón
El 2022-07-18 a las 21:34 +, Alejandro escribió:

> Hola Ladies and Gentlemen, he visto que se está celebrando la reunión anual 
> de la comunidad Debian y no he podido evitar fijarme en los sponsors, donde 
> aparece google como sponsor platinum y microsoft como sponsor dorado.
> 
> Es una pregunta obvia pero...¿Qué significa esto? 

Pues significa que Google ha pagado 2 EUR y Microsoft 1 EUR para 
patrocinar el evento de la conferencia anual de Debian :-)

Patrocinios sin los cuales seguramete no habría DebConf (no creo que 
sólo con las donaciones fuera suficiente). Está bien explicado aquí:

https://media.debconf.org/dc22/fundraising/debconf22_sponsorship_brochure_en.pdf

> Esos tipos son los reyes de tratar a las personas como a productos, verlos 
> como sponsors preferenciales en el principal evento a nivel mundial de una 
> distribución GNULinux considerada pilar fundamental del software libre, no es 
> muy alagüeño.

Pues entonces mejor que no sepas quiénes conforman la plana mayor de la 
Fundación Linux :-P:

https://www.linuxfoundation.org/board-of-directors/

Microsoft, Meta, Oracle, IBM...

Ni las empresas que colaboran en el kernel:

https://www.linuxfoundation.org/wp-content/uploads/linux-kernel-report-2017.pdf

Intel, Google, Oracle, Facebook...

> Alguien tiene alguna explicación al respecto?

Pues que algún interés tienen esas empresas en colaborar o patrocinar 
el software libre, evidentemente.

Si el interés es lícito o no, eso ya dependerá de la naturaleza y 
objetivo de cada compañía, pero no percola en la labor ni de Debian, ni 
de la Fundación Linux ni del kernel, ya que todas esos proyectos de 
software libre tienen directrices y directivas de obligado cumplimiento.

Saludos,

-- 
Camaleón 



Re: OT: RAID-5 sobre SSD

2022-07-18 Por tema Camaleón
El 2022-07-18 a las 10:21 -0300, Debian escribió:

> Buenos días.
> 
> Esta pregunta va para Camaleón, pues creo que es la única persona que tiene
> experiencia en el tema de los que suelen leer por acá.

Con RAID mi experiencia es escasa (sólo he trabajado con hardware raid, 
niveles 1 y 5) y mala (falsos positivos, lento del copón para reconstuir 
y bajo rendimiento pero aquí la culpa se debe a que el servidor que lo 
monta es MUY viejito, del año 2004, pero no desfallece y sigue al pie del
cañón).

No creo que pueda dar buen consejo ni práctico en este caso, si tuviera 
que montar el servidor de nuevo me replantería la estragegia y el uso 
del RAID y buscaría la redundancia de datos y de discos por otro lado 
(integrada en el sistema de archivos, copia-imagen-clon en disco 
independiente, etc...).

> Tengo que reemplazar un pequeño servidor con RAID-5 por software sobre un
> Debian con 4 discos HDD de 1Tb cada uno que está tirando desde hace ya 4
> años. Vamos a cambiar equipo y discos, ya que la máquina en sí es un i7 de
> hace 6 años.
> 
> La primera opción de reemplazo era un RAID-10 sobre 4 HDD de 2Tb cada uno;
> esto nos da mayor redundancia.

Ventaja: tecnología de discos conocida y fiable, tendrías disponible 4 
TiB de espacio (50%), puede fallar 1 disco de cada matriz.

Inconveniente: más lento (por el uso de discos mecánicos), pero al ser 
un raid por software, si el disco es rápido y la controldora sata 
decente, quizá sea inapreciable.
 
> La segunda, montar un RAID-5 sobre 4 discos SSD M.2 NVMe de 1Tb cada uno;
> estos irían colocados sobre placa adaptadora NVMe PCIe; esto nos da mejor
> tiempo de respuesta.

Ventaja: discos más rápidos y de menor tamaño, la reconstrucción no 
será muy penalizada aunque sea un RAID-5, ya has trabajado con ese 
nivel de raid y sabes cómo funciona y gestionarlo.

Inconvenientes: menos espacio disponible (3 TiB).

En cualqesquiera de los casos sólo te daré una recomendación: los discos 
duros, sean mecánicos o SSD, SIEMPRE con garantía de 5 años (empresariales). 
Hoy en día fallan más que una escopeta de feria :-/

> El cálculo por carga de escritura del sistema hace que los SSD NVMe empiecen
> a generar fallas en 5 años, tiempo más que suficiente para amortizarlos.
> 
> Esto implica un costo de un 30% superior al reemplazo de los HDD, pero la
> estimación en los tiempos de respuesta hace que que valga la pena la
> inversión. Lo que he leído en la red indica que es una opción recomendable.
> Con los HDD sólo tuvimos un reemplazo hace 2 años.
> (Se hacen copias de seguridad una vez al día en discos externos.)
> 
> La preguntonta:
> ¿Alguien ha armado RAID-5 sobre SSD?

No he trabajado aún con discos SSD, y menos bajo RAID.

> ¿Cómo les fue?
> ¿Qué sugerencias tienen para realizar un montaje de estas características?

A ver qué te recomiendan. En principio, tratándose de un equipo nuevo, 
me decantaría por el RAID-5 con discos SSD, si el uso del volumen RAID 
es para almacén de datos. Si es para albergar el SO, el RAID-10.

Saludos, 

-- 
Camaleón 



Re: Partición /datos compartida

2022-07-11 Por tema Camaleón
El 2022-07-10 a las 20:22 -0300, Simeón Ignacio Martirén escribió:

> Hola Lista Debian. Pido ayuda.

Hola :-)

(...)

> ¿Podría instalar un Bulleye desde la ISO con una partición aparte para
> /DATOS y luego en el segunto (LUBUNTU Jammy)editar el archivo fstab para
> que acceda a la partición /DATOS de Bulleye siempre al arrancar?

Sí, claro. 
Yo lo tengo así, aunque no con una partición sino con discos completos 
decicados a datos.

sm01@stt008:~$ mount | grep data
systemd-1 on /data/backup2 type autofs 
(rw,relatime,fd=27,pgrp=1,timeout=0,minproto=5,maxproto=5,direct,pipe_ino=1341)
systemd-1 on /data/backup3 type autofs 
(rw,relatime,fd=37,pgrp=1,timeout=0,minproto=5,maxproto=5,direct,pipe_ino=9370)
/dev/sdb1 on /data/backup1 type ext3 (rw,relatime,data=ordered)

sm01@stt008:~$ cat /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
#
# / was on /dev/sda3 during installation
UUID=521fe2d5-7d87-4117-b136-e1e68f11d2bc /   xfs defaults  
  0   0
# swap was on /dev/sda1 during installation
UUID=6abe498c-a75f-4ff3-abc9-c281a6316ff2 noneswapsw
  0   0
/dev/sr0/media/cdrom0   udf,iso9660 user,noauto 0   0
# 500 GiB hd / sdb1
UUID=8ab7cc61-8d69-42d6-bfb8-112f0e0f8a40 /data/backup1 ext3 acl,user_xattr 1 2
# 500 GiB part / sdc2
UUID=a0bce6f8-7f08-4ead-a647-de4f6e16be87 /data/backup2 ext3 
acl,user_xattr,noauto,nofail,x-systemd.automount,x-systemd.device-timeout=1 1 2
# 500 GiB part / sdc1
UUID=2151d682-7969-4684-848a-72a401e59604 /data/backup3 ext3 
acl,user_xattr,noauto,nofail,x-systemd.automount,x-systemd.device-timeout=1 1 2

> Por ejemplo, en este momento escribo desde Lubuntu jammy y tengo las
> siguientes líneas del fstab:
> UUID=aca6de29-faed-4eea-aed9-26f256e3dda1 /  ext4defaults 0 1
> /swapfile swap   swapdefaults 0 0
> 
> rompo algo si agrego una línea como la que sigue para acceder a los datos
> compartiendo con Bulleye?
> UUID=5d822baa-bba7-4466-a9e5-96020024ac1f /datos  ext4defaults   
> 0 2
> 
> (aclaro: este último UUID lo saqué de otra máquina, sólo es a modo de
> ejemplo)
> Gracias desde ya.

No pasa nada, puedes probar a montar la partición antes de reiniciar, 
para ver si se monta bien y con los permisos adecuados.

Eso sí, si vas a compartir la partición entre dos sistemas operativos 
distintos, asegúrate de que la montas con los permisos apropiados para 
que puedas acceder, eliminar, escribir... sin problemas desde Debian y 
Lubuntu, ya que serán usuarios distintos los que accedan/guarden/elimen 
los mismos archivos.

Saludos,

-- 
Camaleón 



Re: [OT] Error en kdenlive

2022-07-03 Por tema Camaleón
El 2022-07-03 a las 00:51 +0100, José Manuel (Abogado) escribió:

> Tengo Debian Bullseye con kde, y la manipulación de vídeos lo hago con
> kdenlive desde hace tiempo, pero en las últimas versiones al iniciar el
> programa me aparece la siguiente imagen (adjunto pantallazo),

Vaya con la traducción, no hay quien entienda ese español :-P

> y no se a que es debido ni como solucionarlo, a ver si alguien del 
> foro utilice este programa o sepa de que se trata el error me puede 
> ayudar. Gracias de antemano

Bueno, hay un bug abierto en KDE por ese mensaje:

On startup, error popup: Unable to create io-slave 
https://bugs.kde.org/show_bug.cgi?id=454185

Si buscas por el mensaje de error en inglés verás que hay varios 
usaurios afectados. Seguramente se trate de un error cosmético que no 
afecte al uso de la aplicación, relacionado con los protocolos que 
maneja internamente el entorno de KDE (smb:/, tags:/, etc...).

Saludos,

-- 
Camaleón 



LibreOffice 7.3.4 no se inicia en Stretch

2022-07-02 Por tema Camaleón
Hola,

Pues eso, aviso a navegantes :-)

Aunque a mi querida Strecth le queda poco, al instalar la versión de 
LibreOffice 7.3.4 desde la página oficial del proyecto, no se puede 
iniciar ninguna aplicaión (writer, calc...).

Parece que ahora LO requiere una versión de libnss3 (>=3.34) superior a 
la que trae Strecth (3.26).

LO 7.3.3.2 funciona sin problemas.

El bug (aunque más que un bug más bien es un nuevo requerimiento, pero 
que debería estar indicado en alguna parte) lo he puesto aquí:

Bug 149813 - LibreOffice 7.3.4 not opening on Debian Stretch, requires 
libnss3.so version 3.34 or higher
https://bugs.documentfoundation.org/show_bug.cgi?id=149813

Saludos,

-- 
Camaleón 



Finaliza el soporte extendido de Debian 9 (Stretch)

2022-07-01 Por tema Camaleón
Hola,

Pues eso, que hoy finaliza el soporte extendido para Debian 9, que ya 
no tendrá actualizaciones:

[SECURITY] [DLA 3067-1] Debian 9 Long Term Support reaching end-of-life
https://lists.debian.org/debian-lts-announce/2022/07/msg2.html

A quienes la estamos usando, nos toca actualizar a una nueva versión.

Gracias Debian, por mantener una política de actualizaciones de 
seguridad por término de 5 años, que se dice pronto. Rememorando a Don 
Pedro Vargas: «muy agradecido, muy agradecido, muy agradecido».

Gracias Debian Strech, por hacerme sentir bien cada vez que enciendo el 
equipo. Desde que tengo Linux no recuerdo ningún sobresalto, así 
gordote, en los sistemas (aka: cuelgues, bloqueos)... Todo fluye en paz 
y harmonía.

Ahora, a por Debian 11.
Espero que no me dé mucha guerra en mi equipo del año 2008 O:-P

sm01@stt008:~$ cat /proc/cpuinfo | grep -m1 "model name"
model name  : Intel(R) Core(TM)2 Quad CPUQ9550  @ 2.83GHz

Saludos,

-- 
Camaleón 



Re: IPMI Service error al actualizar

2022-06-21 Por tema Camaleón
El 2022-06-21 a las 18:53 +0200, Juan Gómez "Txonta" escribió:

> Hola.
> 
>Después de actualizar los paquetes en el servidor debian
>me devuelve un error que no me llega mi conocimiento a saber la
>transcendencia
>ni como actuar. Agradezco comentarios y consejos.
>Mensaje en apt upgrade:
> 

(...)

>jun 21 16:48:15 xx--ovh systemd[1]: Starting IPMI event
>daemon...
>jun 21 16:48:15 xx--ovh ipmievd[17846]: Could not open
>device at /dev/ipmi0 or /dev/ipmi/0 or /dev/ipmidev/0: No such
>file or directory

(...)

IPMI es un sistema para gestionar el hardware de los servidores, muy útil 
en funciones de mantenimiento y control de los equipos cuando  trabajas 
en remoto.

Por los mensajes que veo me da la sensación de que estás en una máquina 
virtual y que el servidor físico tendrá instalada una tarjeta IPMI, que 
tendrás que configurar para poder usarla, normalmente cargando el 
módulo del kernel e instalado alguna herramienta de monitorización.

(...)

>¿Que me aconsejan?

Te puede venir bien tener configurado el módulo IPMI, pero ten cuidado 
si accedes en remoto y no tienes acceso físico al servidor, porque 
puedes dejarlo sin comunicación o inaccesible.

Busca información sobre lo que te ofrece el servicio¹ y si le ves 
utilidad, trata de configurarlo instalando las herramientas neecsarias 
de gestión (ipmitool o similares)

Si decides que no lo necesitas, podrás desactivar el servicio para que 
no te dé guerra.

¹https://www.ibm.com/docs/es/power8?topic=power8-p8eih-p8eih-ipmitool-htm

Saludos,

-- 
Camaleón 



Re: Re: [OT] Error de autenticación en cuentas @gmail.com en Clientes de Correo que no son el de Gmail.

2022-06-14 Por tema Camaleón
El 2022-06-14 a las 19:40 +0200, Ramses escribió:

> El 14 de junio de 2022 19:28:48 CEST, "Camaleón"  
> escribió:
> >El 2022-06-14 a las 13:56 -0300, Gonzalo Rivero escribió:
> >
> >> El mar, 14 jun 2022 a la(s) 13:47, Gonzalo Rivero (fishfromsa...@gmail.com)
> >> escribió:

(...)

> >> sabía que estaba en algún lugar: en la pantalla principa de gmail hay que
> >> ir hasta abajo a la derecha, donde pone "Última actividad de la cuenta:
> >> hace 1 minuto. Detalles" ese 'detalles' es un enlace, que por la hoja de
> >> estilo no es obvio hasta que uno pasa por allí con el mouse. Entonces se
> >> despliega algo como esto:

^

> >
> >Ahí sí veo las sesiones que usan una contraseña de aplicación. Indica 
> >el tipo de sesión (KMAP/POP3/Atom/esconocido), la IP y la fecha/hora del
> >acceso. Veo los accesos desde Mutt y también desde el complemento XFCE 
> >Mailwatch.
> >
> >Saludos,
> >
> 
> ¿En qué enlace aparece esa información?

En la que te dice Gonzalo más arriba ^^^

;-)

Saludos,

-- 
Camaleón 



Re: Re: [OT] Error de autenticación en cuentas @gmail.com en Clientes de Correo que no son el de Gmail.

2022-06-14 Por tema Camaleón
El 2022-06-14 a las 13:56 -0300, Gonzalo Rivero escribió:

> El mar, 14 jun 2022 a la(s) 13:47, Gonzalo Rivero (fishfromsa...@gmail.com)
> escribió:

(...)

> > > > holas, tampoco se si habrá algún límite (no creo, son menos
> > > > dispositivos donde podría meter su publicidad (en los clientes de
> > > > mail
> > > > de verdad no hay, punto para lo que no sea webmail muajajaja)) pero
> > > > si
> > > > que lleva la cuenta de los inicios de sesión, por ejemplo ver la
> > > > captura de mi propia cuenta
> > >
> > > A mi no me aparecen las sesiones que usan la contraseña de aplicación
> > > (Mutt con IMAP), sólo veo los inicios de sesión desde el webmail.
> > >
> > > ¿Usas OAuth2 en Thunderbird o lo tienes configurado omo cuenta POP3?
> > >
> > oauth y con imap. También en evolution. Y uso imap porque tengo
> > demasiado correo repartido en demasiadas carpetas y con las etiquetas
> > no termino de aclararme.
> > Eso si, para buscar aglo muy antiguo que no se en que carpeta lo tiré
> > si voy al webmail.
> > De todas maneras, había un listado mas detallado que no pude encontrar
> > ahora y al que podía llegar desde el propio webmail.
> > La captura de mi correo anterior la obtuve navegando las opciones de la
> > cuenta de google, no específico del correo. Si llego a encontrarlo
> > mando en un siguiente mensaje una muestra y como llegar hasta ahí ;)
> >
> sabía que estaba en algún lugar: en la pantalla principa de gmail hay que
> ir hasta abajo a la derecha, donde pone "Última actividad de la cuenta:
> hace 1 minuto. Detalles" ese 'detalles' es un enlace, que por la hoja de
> estilo no es obvio hasta que uno pasa por allí con el mouse. Entonces se
> despliega algo como esto:

Ahí sí veo las sesiones que usan una contraseña de aplicación. Indica 
el tipo de sesión (KMAP/POP3/Atom/esconocido), la IP y la fecha/hora del
acceso. Veo los accesos desde Mutt y también desde el complemento XFCE 
Mailwatch.

Saludos,

-- 
Camaleón 



[OT] Thunderbird + K-9 Mail (era: [OT] Error de autenticación en cuentas @gmail.com en Clientes de Correo que no son el de Gmail.)

2022-06-14 Por tema Camaleón
El 2022-06-14 a las 19:06 +0200, Ramses escribió:

> El 14 de junio de 2022 17:06:34 CEST, "Camaleón"  
> escribió:

(...)

> >Por cierto, para los que usamos Thunderbird y K-9 Mail, una buena 
> >noticia:
> >
> >K-9 Mail joins the Thunderbird family
> >https://k9mail.app/2022/06/13/K-9-Mail-and-Thunderbird.html
> >
> >Aunque preferiría lo inverso: K-9 Mail en Linux :-P
> 
> Buenas.
> 
> Pues lo que no me simpatiza es esto:
> 
> "The app on Google Play will be moved to a different publisher account."
> 
> Quiero entender que lo que cambian es la cuenta de publicación en Google 
> Play, pero que lo seguirán publicando en Google Play...

No creo que la quiten de Google Play, quizá se refieran a esto:

Transfer apps to a different developer account
https://support.google.com/googleplay/android-developer/answer/6230247?hl=en

Saludos,

-- 
Camaleón 



Re: Re: [OT] Error de autenticación en cuentas @gmail.com en Clientes de Correo que no son el de Gmail.

2022-06-14 Por tema Camaleón
El 2022-06-14 a las 11:21 -0300, Gonzalo Rivero escribió:
> El lun, 13-06-2022 a las 19:23 +0200, Camaleón escribió:
> > El 2022-06-13 a las 19:00 +0200, Ramses escribió:
> > 
> > > El 13 de junio de 2022 18:28:12 CEST, "Camaleón"
> > >  escribió:
> > > > El 2022-06-13 a las 11:19 -0500, Aristobulo Pinzon escribió:
> > > > 
> > > > > Buenos días...
> > > > > Y una pregunta: ¿Cómo configurar todas las cuentas de Gmail con
> > > > > 2FA?
> > > > > Gracias por facilitar ayuda.
> > > > 
> > > > Sigue estos pasos:
> > > > 
> > > > Activar la verificación en dos pasos
> > > > https://support.google.com/accounts/answer/185839?hl=es=GENIE.Platform%3DDesktop=0
> > > > 
> > > > Ojo, activar este sistema va bien para quienes NO usamos el
> > > > webmail y 
> > > > mantenemos cuentas configuradas «a la antigua usanza», esto es,
> > > > con 
> > > > clientes IMAP/POP3 que requieren usuario y contraseña.
> > > > 
> > > > Cuando activas el 2FA cada vez que accedes a tu cuenta de
> > > > Google/Gmail 
> > > > a través del webmail te manda un código SMS o te llama para
> > > > permitr el 
> > > > acceso, lo cual no e s nada práctico si el webmail es el sistema
> > > > de 
> > > > acceso más utilizado.
> > > > 
> > > > Luego sólo tendrías que generar una contraseña de aplicación para
> > > > que 
> > > > Google te cree una contraseña automáticamente, que es la que
> > > > pones en 
> > > > la aplicación de correo o donde la vayas a usar.
> > > > 
> > > 
> > > Una duda: ¿Puedes crear una única Contraseña de Aplicación en una
> > > cuenta y usarla en todas las aplicaciones / clieide correo en las
> > > que uses esa cuenta?.
> > 
> > Sí, al menos yo lo tengo así (una contraseña para gobernarlos a 
> > todos...) y de momento no me ha dado problemas.
> > 
> > Desconozco si hay algún límite o si Google lleva la cuenta los
> > inicios
> >  de sesión desde las distintas aplicaciones... yo me creo todo ya :-(
> > 
> 
> holas, tampoco se si habrá algún límite (no creo, son menos
> dispositivos donde podría meter su publicidad (en los clientes de mail
> de verdad no hay, punto para lo que no sea webmail muajajaja)) pero si
> que lleva la cuenta de los inicios de sesión, por ejemplo ver la
> captura de mi propia cuenta

A mi no me aparecen las sesiones que usan la contraseña de aplicación 
(Mutt con IMAP), sólo veo los inicios de sesión desde el webmail.

¿Usas OAuth2 en Thunderbird o lo tienes configurado omo cuenta POP3?

Por cierto, para los que usamos Thunderbird y K-9 Mail, una buena 
noticia:

K-9 Mail joins the Thunderbird family
https://k9mail.app/2022/06/13/K-9-Mail-and-Thunderbird.html

Aunque preferiría lo inverso: K-9 Mail en Linux :-P

Saludos,

-- 
Camaleón 



[OT] Entrevista a Richard Stallman (en español)

2022-06-14 Por tema Camaleón
Hola,

No es habitual leer entrevistas de contenido original (no simplemente 
traducidas) en español relacionadas con el mundo de la informática en 
general, y con el software libre en particular.

Os dejo esta¹ de Chema Alonso a Richard Stallman, donde hablan sobre los 
grandes repositorios para desarrolladores de software (GitHub et al) y los 
problemas con las licencias propietarias.

No sé por qué, pero leer a Richard Stallman siempre me deja una buena 
sensación, quizá porque dice verdades como puños, sin aspavientos y de 
manera sencilla y clara... sus palabras tienen algo de místico, o quizá 
sea por la inherente universalidad del concepto de softare libre que se 
expande más allá de los bits y transciende cuestiones vitales.

¹https://unaaldia.hispasec.com/2022/06/chema-alonso-entrevista-a-richard-stallman-parte-i.html

Saludos,

-- 
Camaleón 



Re: Re: [OT] Error de autenticación en cuentas @gmail.com en Clientes de Correo que no son el de Gmail.

2022-06-13 Por tema Camaleón
El 2022-06-13 a las 19:00 +0200, Ramses escribió:

> El 13 de junio de 2022 18:28:12 CEST, "Camaleón"  
> escribió:
> >El 2022-06-13 a las 11:19 -0500, Aristobulo Pinzon escribió:
> >
> >> Buenos días...
> >> Y una pregunta: ¿Cómo configurar todas las cuentas de Gmail con 2FA?
> >> Gracias por facilitar ayuda.
> >
> >Sigue estos pasos:
> >
> >Activar la verificación en dos pasos
> >https://support.google.com/accounts/answer/185839?hl=es=GENIE.Platform%3DDesktop=0
> >
> >Ojo, activar este sistema va bien para quienes NO usamos el webmail y 
> >mantenemos cuentas configuradas «a la antigua usanza», esto es, con 
> >clientes IMAP/POP3 que requieren usuario y contraseña.
> >
> >Cuando activas el 2FA cada vez que accedes a tu cuenta de Google/Gmail 
> >a través del webmail te manda un código SMS o te llama para permitr el 
> >acceso, lo cual no e s nada práctico si el webmail es el sistema de 
> >acceso más utilizado.
> >
> >Luego sólo tendrías que generar una contraseña de aplicación para que 
> >Google te cree una contraseña automáticamente, que es la que pones en 
> >la aplicación de correo o donde la vayas a usar.
> >
> 
> Una duda: ¿Puedes crear una única Contraseña de Aplicación en una cuenta y 
> usarla en todas las aplicaciones / clieide correo en las que uses esa cuenta?.

Sí, al menos yo lo tengo así (una contraseña para gobernarlos a 
todos...) y de momento no me ha dado problemas.

Desconozco si hay algún límite o si Google lleva la cuenta los inicios
 de sesión desde las distintas aplicaciones... yo me creo todo ya :-(

Saludos,

-- 
Camaleón 



Re: Re: [OT] Error de autenticación en cuentas @gmail.com en Clientes de Correo que no son el de Gmail.

2022-06-13 Por tema Camaleón
El 2022-06-13 a las 11:19 -0500, Aristobulo Pinzon escribió:

> Buenos días...
> Y una pregunta: ¿Cómo configurar todas las cuentas de Gmail con 2FA?
> Gracias por facilitar ayuda.

Sigue estos pasos:

Activar la verificación en dos pasos
https://support.google.com/accounts/answer/185839?hl=es=GENIE.Platform%3DDesktop=0

Ojo, activar este sistema va bien para quienes NO usamos el webmail y 
mantenemos cuentas configuradas «a la antigua usanza», esto es, con 
clientes IMAP/POP3 que requieren usuario y contraseña.

Cuando activas el 2FA cada vez que accedes a tu cuenta de Google/Gmail 
a través del webmail te manda un código SMS o te llama para permitr el 
acceso, lo cual no e s nada práctico si el webmail es el sistema de 
acceso más utilizado.

Luego sólo tendrías que generar una contraseña de aplicación para que 
Google te cree una contraseña automáticamente, que es la que pones en 
la aplicación de correo o donde la vayas a usar.

Saludos,

-- 
Camaleón 



Re: [OT] Me he perdido con Java

2022-06-06 Por tema Camaleón
El 2022-06-05 a las 12:18 -0600, estebanmo...@riseup.net escribió:

> Pues eso, que me he perdido con Java :-)

(...)

> ¿Dónde puedo descargar Java *JRE* 18 (si es que existe), no la *JDK/SE*?
> 
> ¹https://jdk.java.net/18
> ²https://www.java.com/es/download/

> Hola:
>
> Hasta donde yo entiendo Oracle dejo de desarrollar Java en su versión 
> 8, las versiones 9 a 16 se lanzaron bajo la nueva estrategia de 
> openjdk, que a su vez incluye el jre, la versión 17 es la primera con 
> LTS, y la que le recomiendo instalar. También esa versión es con la que 
> Oracle cambio de parecer acerca de su estupidez de cobrar por el JDK.

Ah... desconocía el dato de que la versión OpenJK llevara integrado el 
JRE. Qué follón.

> Puede leer mas aca
> https://www.oracle.com/java/technologies/java-se-support-roadmap.html
>
> En la buena teoría si esa aplicación te esta pidiendo una versión 
> superior a 11 de java, debería de correr con openjdk... 

Interesante enlace, explica muchas cosas.

Creo que podemos resumirlo en la posibilidad de instalar:

Java de Oracle (el paquetón incluye el JRE):
https://www.oracle.com/java/technologies/downloads/

OpenJDK (el paquetón incluye el JRE):
http://jdk.java.net/18/

Sólo el JRE:
https://adoptium.net/es/temurin/releases

Sólo el JRE (la versión dependerá del sabor de Debian instalado):
https://packages.debian.org/search?searchon=names=openjdk

Muchas gracias por las respuestas, creo que me quedan más claras las 
opciones y los cambios que ha hecho Oracle.

Ya cayó Adobe Flash Player (R.I.P) y pocos le echan de menos, ahora le 
toca a Java >>>:-)

Saludos,

-- 
Camaleón 



Re: [OT] Me he perdido con Java

2022-06-06 Por tema Camaleón
El 2022-06-05 a las 14:01 -0400, Roberto C. Sánchez escribió:

> On Sun, Jun 05, 2022 at 07:54:05PM +0200, Camaleón wrote:
> > Hola,
> > 
> > Pues eso, que me he perdido con Java :-)
> > 
> > No es que me guste tenerlo instalado pero en España para algunas cosas 
> > (léase administraciones y registros electrónicos variopintos) aún lo 
> > requieren.
> > 
> > Bien, yo siempre he tenido (tengo) instalada la JRE, además del 
> > complemento para el navegador, que ya no funciona, pero que me permite 
> > ejecutar aplicaciones Java desde el escritrio.
> > 
> > Ahora algunas aplicaciones me piden Java 11 (mínimo) y yo tengo la JRE
> > 8 (332) y sé que hay una versión abierta (OpenJDK¹) pero que no siempre 
> > funciona bien, y otra propietaria que descargaba desde la web de 
> > Java/Oracle/Sun pero que ahora no encuentro (sólo tiene la versión 8² 
> > que ya tengo instalada).
> > 
> > ¿Dónde puedo descargar Java *JRE* 18 (si es que existe), no la *JDK/SE*?
> > 
> Yo encuentro el proyecto Adoptium (desarrolado por Eclipse y otros) de
> lo más bien.  

Gracias Roberto, no conocía ese proyecto y parece que compilan las 
últimas versiones JRE desde fuentes OpenJDK, me podría servir para tener
la última versión disponible instalada caso de que la necesite.

Hay paquetes .tar.gz pero no parece complicado de instalar¹.

Tengo Debian 9 (Stretch) ya viejita pero con soporte LTS hasta finales 
de junio de este año, tendré que actualizarla en breve, pero mientras 
aguanta firme, la fiesta de Java debe seguir. 

> Pero, si estás usando la versión estable de Debian, solo
> hace falta instalar openjdk-17-jre.  La versión 17 de Java es la versión
> LTS actual.  Me quedaré surproendido si algún sitio exigiera la version
> 18, que salió ni hace 3 meses.

Hum... en los repos de Debian veo la versión JRE 11 de OpenJDK en los 
backports², sería la opción más lógica de instalar mientras ninguna 
aplicación me pida subir la versión de Java.

Lo que me extrañaba era que OpenJDK no compilara binarios para JRE, 
pero por vuestros comentarios veo que efectivamente no lo hace :-?

¹https://techviewleo.com/install-adoptium-temurin-openjdk-on-ubuntu/
²https://packages.debian.org/stretch-backports/openjdk-11-jre

Saludos,

-- 
Camaleón 



[OT] Me he perdido con Java

2022-06-05 Por tema Camaleón
Hola,

Pues eso, que me he perdido con Java :-)

No es que me guste tenerlo instalado pero en España para algunas cosas 
(léase administraciones y registros electrónicos variopintos) aún lo 
requieren.

Bien, yo siempre he tenido (tengo) instalada la JRE, además del 
complemento para el navegador, que ya no funciona, pero que me permite 
ejecutar aplicaciones Java desde el escritrio.

Ahora algunas aplicaciones me piden Java 11 (mínimo) y yo tengo la JRE
8 (332) y sé que hay una versión abierta (OpenJDK¹) pero que no siempre 
funciona bien, y otra propietaria que descargaba desde la web de 
Java/Oracle/Sun pero que ahora no encuentro (sólo tiene la versión 8² 
que ya tengo instalada).

¿Dónde puedo descargar Java *JRE* 18 (si es que existe), no la *JDK/SE*?

¹https://jdk.java.net/18
²https://www.java.com/es/download/

Saludos,

-- 
Camaleón 



Re: [OT] Error de autenticación en cuentas @gmail.com en Clientes de Correo que no son el de Gmail.

2022-06-03 Por tema Camaleón
El 2022-06-03 a las 14:27 +0200, Ramses escribió:

> El 3 de junio de 2022 8:36:13 CEST, "Camaleón"  escribió:
> >El 2022-06-02 a las 19:54 +0200, Ramses escribió:
> >
> >> ¿Sabéis si han habilitado ya que sólo los Clientes de Correo que no se
> >> puedan autenticar con “Iniciar sesión con Google” puedan conectarse a 
> >> Gmail?
> >
> >Sí, en España desde ayer me daba problemas.
> >
> >> Es que tengo en el móvil el Cliente de Correo K-9 con un par de cuentas
> >> @gmail.com, entre otras, y me están dando error de autenticación.
> >
> >Tienes que tener configurado algún sistema de autentificación que 
> >admita Google. Para que funcione con contraseña en aplicaciones 
> >antiguas, he tenido que configurar todas las cuentas de Gmail con 2FA 
> >(en la mía personal ya la tenía) y crear una contraseña de aplicación 
> >para que todo vuelva a funcionar en clientes antiguos que no admiten 
> >OAuth 2.0 y demás mandangas.
> >
> >Lo que no entiendo es por qué la contraseña que genera Google 
> >automáticamente es tan «blandita»: no alterna mayúsculas/minúsculas, no 
> >incluye caracteres no alfanuméricos... menudo ejemplo de contraseña 
> >segura >>:-)
> >
> >> Sin embargo, estoy enviando este correo desde Outlook 2016 y, hasta el
> >> momento, parece que me funcionan las 2 cuentas @gmail.com.
> 
> Camaleón, crear una Contraseña de Aplicación para cada cuenta, ¿no?

Sí, eso es lo que he hecho: para cada cuenta de Gmail he creado una 
contraseña de aplicación (no le veo sentido a crear más contraseñas, 
una misma contraseña sirve para varias aplicaciones), así puedo seguir 
usando programas que no tienen soporte para OAuth2 (Mutt, Fetchmail, 
etc...) sin problemas.
 
> De todas formas, a mí se me recuperó ayer...

Quizá se tratara de un error temporal, o que van cambiando poco a poco 
las cuentas, pero vamos, que en mi caso ayer mismo cayeron todas las que 
gestiono (la mía personal, la de usuarios, clientes...).

Saludos,

-- 
Camaleón 



Re: [OT] Error de autenticación en cuentas @gmail.com en Clientes de Correo que no son el de Gmail.

2022-06-03 Por tema Camaleón
El 2022-06-02 a las 19:54 +0200, Ramses escribió:

> ¿Sabéis si han habilitado ya que sólo los Clientes de Correo que no se
> puedan autenticar con “Iniciar sesión con Google” puedan conectarse a Gmail?

Sí, en España desde ayer me daba problemas.

> Es que tengo en el móvil el Cliente de Correo K-9 con un par de cuentas
> @gmail.com, entre otras, y me están dando error de autenticación.

Tienes que tener configurado algún sistema de autentificación que 
admita Google. Para que funcione con contraseña en aplicaciones 
antiguas, he tenido que configurar todas las cuentas de Gmail con 2FA 
(en la mía personal ya la tenía) y crear una contraseña de aplicación 
para que todo vuelva a funcionar en clientes antiguos que no admiten 
OAuth 2.0 y demás mandangas.

Lo que no entiendo es por qué la contraseña que genera Google 
automáticamente es tan «blandita»: no alterna mayúsculas/minúsculas, no 
incluye caracteres no alfanuméricos... menudo ejemplo de contraseña 
segura >>:-)

> Sin embargo, estoy enviando este correo desde Outlook 2016 y, hasta el
> momento, parece que me funcionan las 2 cuentas @gmail.com.

Saludos,

-- 
Camaleón 



Re: Problema De Login en debian

2022-05-30 Por tema Camaleón
El 2022-05-30 a las 11:37 -0300, Antonio Munno escribió:

> Estimados : Acudo a Uds. para pedirles ayuda. Desde la terminal de un
> Debian 6, ingreso como usuario root y contraseña correcta y me devuelve el
> login, sin darme ningun error. No es contraseña equivocada ni login
> incorrecto. Simplemente, hace un "clear screen" y me vuelve a
> pedir usuario.¿alguna idea?

Habrás iniciado bien en la terminal pero sin cargar entorno gráfico.
Prueba con «startx» (mejor desde tu usaurio) si lo que quieres es 
cargar el escritorio.

Saludos,

-- 
Camaleón 



Re: No puede conectarme a ssh

2022-05-26 Por tema Camaleón
El 2022-05-26 a las 05:56 -0400, Adolfo Luque escribió:

> hola lista
> 
> El asunto es que no me puedo conectar por ssh. Al hacer:
> 
> $systemctl status ssh me da:
> 
> ssh.service - OpenBSD Secure Shell server
>  Loaded: loaded (/lib/systemd/system/ssh.service; enabled; vendor preset: 
> enabled)
> Drop-In: /run/systemd/system/service.d
>  └─zzz-lxc-service.conf
>  Active: inactive (dead)
>   Condition: start condition failed at Thu 2022-05-26 04:04:21 -04; 10min ago
>  └─ ConditionPathExists=!/etc/ssh/sshd_not_to_be_run was not met
>Docs: man:sshd(8)
>  man:sshd_config(5)

(...)

Del primer enlace que devuelve Google al buscar por le mensaje de error:

Starting SSH client in Debian Linux on a Lenovo Chromebook
https://serverfault.com/questions/1036712/starting-ssh-client-in-debian-linux-on-a-lenovo-chromebook

A ver si te sirve.

Saludos,

-- 
Camaleón 



Re: Parches de seguridad Jessie 8.11

2022-05-20 Por tema Camaleón
El 2022-05-20 a las 09:26 -0300, Héctor Ariel Rotela escribió:

> El vie, 20 may 2022 a las 3:44, Camaleón () escribió:
> 
> > El 2022-05-19 a las 20:33 -0300, Héctor Ariel Rotela escribió:
> >
> > > Estimados
> > >
> > > Pudieron ver mi caso?
> > >
> > > Esta en el mail anterior.
> >
> > Pues no lo vi porque no me llegó el mensaje de abajo.
> > Y tampoco me aperece tu correo en la carpeta de /spam de Gmail :-?
> > ¿Lo enviaste a mi cuenta?
> >
> > > El jue, 19 de may. de 2022 12:43, Héctor Ariel Rotela <
> > ariel3...@gmail.com>
> > > escribió:
> > >
> > > > Camaleón,
> > > >
> > > > Muchas gracias por la pronta respuesta. Yo saque un listado de todos
> > los
> > > > paquetes te los adjunto, para que los mires y me des una idea, de como
> > > > puedo saber si cada uno de esos paquetes están con la última versión
> > > > disponible.
> > > >
> > > > Todo sin tener la posibilidad de conectarme a internet y que no pueda
> > > > armar el repositorio local.
> > > >
> > > > Lo que quiero tener es un comparativo como por ejemplo:
> > > >
> > > > APT  el paquete que se actualizo con el 8.11 es : 1.0.9.8.1
> > > >
> > > > Si verificas en lo que te envié
> > > >
> > > > APT tiene la 1.0.9.8.6 (o sea que esta actualizado después de la 8.11
> > pero
> > > > no se si es la última )
> > > >
> > > > No se si se entendio lo que necesito.
> >
> > (...)
> >
> > Hombre, a ver... sí te he entendido, pero ¿no sería mejor que revisaras
> > tú mismo la diferencia? >:-)
> >
> > Dime si tu instalación es de 32 o 64 bits y te mando la lista de los
> > paquetes (main/contrib/non-free) con su última versión para Jessie (el
> > archivo ocupa unos 9 MiB).
> >
> > http://ftp.de.debian.org/debian/dists/jessie/

> Disculpen soy novato y quiero poder entender.
> 
> Camaleón, si puedes enviarme la lista te lo voy a agradecer. Es de 32 bits

Te lo anvio a tu cuenta personal.

En total son 6 archivos comprimidos que enumeran las versiones 32 bits 
de los paquetes para Jessie.

main contrib non-free (.GZ)
security-main security-contrib security-nonfree (.BZ2)

Para buscar, por ejemplo, la última versión de «apt» en Jessie:

sm01@stt008:~/Escritorio$ zgrep -A 1 "^Package: apt$" *.gz; bzgrep -A 1 
"^Package: apt$" *.bz2
main_Packages.gz:Package: apt
main_Packages.gz:Version: 1.0.9.8.4
security_main_Packages.bz2:Package: apt
security_main_Packages.bz2:Version: 1.0.9.8.6

Saludos,

-- 
Camaleón 



Re: Parches de seguridad Jessie 8.11

2022-05-20 Por tema Camaleón
El 2022-05-19 a las 20:33 -0300, Héctor Ariel Rotela escribió:

> Estimados
> 
> Pudieron ver mi caso?
> 
> Esta en el mail anterior.

Pues no lo vi porque no me llegó el mensaje de abajo. 
Y tampoco me aperece tu correo en la carpeta de /spam de Gmail :-?
¿Lo enviaste a mi cuenta?

> El jue, 19 de may. de 2022 12:43, Héctor Ariel Rotela 
> escribió:
> 
> > Camaleón,
> >
> > Muchas gracias por la pronta respuesta. Yo saque un listado de todos los
> > paquetes te los adjunto, para que los mires y me des una idea, de como
> > puedo saber si cada uno de esos paquetes están con la última versión
> > disponible.
> >
> > Todo sin tener la posibilidad de conectarme a internet y que no pueda
> > armar el repositorio local.
> >
> > Lo que quiero tener es un comparativo como por ejemplo:
> >
> > APT  el paquete que se actualizo con el 8.11 es : 1.0.9.8.1
> >
> > Si verificas en lo que te envié
> >
> > APT tiene la 1.0.9.8.6 (o sea que esta actualizado después de la 8.11 pero
> > no se si es la última )
> >
> > No se si se entendio lo que necesito.

(...)

Hombre, a ver... sí te he entendido, pero ¿no sería mejor que revisaras 
tú mismo la diferencia? >:-)

Dime si tu instalación es de 32 o 64 bits y te mando la lista de los 
paquetes (main/contrib/non-free) con su última versión para Jessie (el 
archivo ocupa unos 9 MiB).

http://ftp.de.debian.org/debian/dists/jessie/

Saludos,

-- 
Camaleón 



[OT] OAuth y 2FA (Era: Servidor imap.gmail.com y mutt falla.)

2022-05-19 Por tema Camaleón
El 2022-05-18 a las 09:20 +0200, alfon escribió:

> > 2. Configurar OAuth2 en Mutt y Fetchmail, si lo permiten, o buscar
> > alguna aplicación alternativa que sí tenga soporte.
> >
> > Seguramente, y para curarme en salud, haga las dos cosas (1 y 2) :-)
> >
> > > Las opciones son usar OAuth (no tengo claro que mutt lo soporte) o una
> > > contraseña de aplicación (pero Google no te las ofrece a menos que
> > > tengas activado el 2FA)
> >
> > Para Mutt he visto esto (no lo he probado):
> >
> > mutt integration with Gmail using OAuth
> > https://luxing.im/mutt-integration-with-gmail-using-oauth/
> 
> Yo tengo configurado mutt con Oauth2 y funciona perfectamente. Existe
> un script proporcionado por Google que automatiza en parte el proceso.
> 
> Si tenéis problemas concretos configurándolo lo podemos resolver en
> este u otro hilo de la lista.

Me parece especialmente interesante este tema, y creo que nos puede ser 
de utilidad a todos, por un motivo u otro.

He estado leyendo sobre OAuth en la página de la Wikipedia para empezar 
a entender de qué va :-)

Si no lo he entendido mal, se trata de un sistema/mecanismo/protocolo 
por el que un servicio/servidor permite a un cliente generar un token 
para permitir el acceso de terceros (o a él mismo) a sus datos/
servicidos/credenciales.

Es decir, en lugar de decirle a Gmail, «soy fulanito y este es mi 
usuario y contraseña», habría que primero generar un token para 
permitir el acceso a fulanito, y dado que ese token no contiene los 
datos en sí de las credenciales, resulta más seguro contra ataques.

Hum... sería algo así como decirle al cortafuegos que en vez de 
permitir todo y después ir cerrando puertos, que primero cierre todo y 
después ir permitiendo cosas concretas.

Entiendo las ventajas que supone para la parte servidora usar ese 
sistema, pero no para el cliente, y menos aún cuando se trata de correo 
electrónico. El correo convencional (no el webmail) no es una API, no 
es un servicio, y hacia eso lo quieren arrastrar (desnaturalizar la 
esencia del coreo electrónico) pero preferiría que el servidor de correo 
me pidiera en certificado digital para autentificarme que usar ese 
sistema farragoso de OAuth; auguro problemas de todo tipo y máxima 
incomodidad para los clientes.

Ahora bien, lo que ya me pierde es la mezcla de OAuth con la 
doble, triple o multi autentificación (2FA). Estos sistemas de doble 
seguridad los entendería razonables para validar ciertas operaciones 
críticas o autentificaciones ante servicios delicados, pero no para 
iniciar sesión en un buzón de correo convencional (POP/IMAP, no 
webmail), espero que no sean tan vacaburros de forzar también su uso o 
derivarnos al webmail :-/

Saludos,

-- 
Camaleón 



Re: Parches de seguridad Jessie 8.11

2022-05-19 Por tema Camaleón
El 2022-05-19 a las 12:01 -0300, Héctor Ariel Rotela escribió:

> Mi consulta es por los update de seguridad para Debian 8.11.
> 
> 1-  ¿Donde puedo obtener el listado completo hasta los ultimos parches de
> seguridad desde el release que tengo?

Según esta página¹, la 8.11 es la última version de Jessie.

> 2- El equipo no tiene salida a internet por lo que no puedo ejecutar APT

(...)

No tienes más parches para aplicar, salvo que necesites algo en 
concreto.

Normalmente, cuando no tienes acceso a Internet, puedes crear un 
repositorio local y actualizar desde ahí.

¹https://wiki.debian.org/DebianJessie#Release_and_updates

Saludos,

-- 
Camaleón 



Re: Array IBM x3100 M4 on Debian 11

2022-05-18 Por tema Camaleón
El 2022-05-17 a las 15:18 -0300, OLCESE, Marcelo Oscar.- escribió:

> Estoy tratando de instalar Debian 11 en un servidor IBM System x3100 M4
> 2582AC1 y no me reconoce el ARRAY.
> 
> Estoy buscando en IBM, pero solo lo tienen REDHAT y Susex.
> 
> Alguien que tenga un driver o que haya podido instalarlo en ese ordenador?

Parece que la contradora que lleva integrada es ServeRAID C100. 

Eso es una controladora de tipo software, no es hardware RAID.

Piensa MUY bien lo que quieres hacer, empezando por si quieres utilizar 
RAID en el equipo u otro tipo de opción (p. ej., uno de esos sistemas de 
archivos modernitos que permiten pseudo-RAID, como brtfs o zfs) y después 
pensando qué tipo de RAID quieres (software/hardware) y si finalmente 
optas por usar sofware RAID, qué tipo de driver vas a instalar 
(md/dm/firmware propietario, si es que existe, etc...).

El buen camino has de elegir, joven Padawan.

Saludos,

-- 
Camaleón 



Re: Servidor imap.gmail.com y mutt falla.

2022-05-16 Por tema Camaleón
El 2022-05-16 a las 08:43 +0200, Camaleón escribió:

> El 2022-05-16 a las 03:18 +0200, Ángel escribió:
> 
> > On 2022-05-14 at 19:26 +0200, Camaleón wrote:
> > > > Parece que gmail canceló mutt y otros clientes de correo para
> > > > favorecer su
> > > > monopolio?...
> > > 
> > > Todavía no, pero todo llegará ;-/
> > 
> > Lamento traer malas noticias, pero a finales de mes (30 de mayo) ya no
> > permitirá iniciar sesión en los clientes con la contraseña de Google:
> > 
> > https://support.google.com/accounts/answer/6010255?hl=es
> 
> Sí, cierto.
>  
> He recibido el correo de Google avisando de las «buenas nuevas» (nótese 
> la ironía) hace un par de meses.
> 
> Actualmente para Mutt tengo configurada una contraseña de aplicación 
> pero me da la sensación de que Gmail ya no va a permitir ese sistema.

(...)

Hum... no me queda claro, pero me parece que está opción (usar una 
contraseña de aplicación que requiere tener activado la doble 
autentificación) seguirá estando disponible en Gmail a partir del día 
30-5.

Si es así, para quienes la tengan configurada no tendrán que hacer nada. 
Veremos cómo va la cosa...

Saludos,

-- 
Camaleón 



Re: Servidor imap.gmail.com y mutt falla.

2022-05-16 Por tema Camaleón
El 2022-05-16 a las 03:18 +0200, Ángel escribió:

> On 2022-05-14 at 19:26 +0200, Camaleón wrote:
> > > Parece que gmail canceló mutt y otros clientes de correo para
> > > favorecer su
> > > monopolio?...
> > 
> > Todavía no, pero todo llegará ;-/
> 
> Lamento traer malas noticias, pero a finales de mes (30 de mayo) ya no
> permitirá iniciar sesión en los clientes con la contraseña de Google:
> 
> https://support.google.com/accounts/answer/6010255?hl=es

Sí, cierto.
 
He recibido el correo de Google avisando de las «buenas nuevas» (nótese 
la ironía) hace un par de meses.

Actualmente para Mutt tengo configurada una contraseña de aplicación 
pero me da la sensación de que Gmail ya no va a permitir ese sistema.

Las opciones que he barahado son:

1. Abrir una cuenta en GMX (o similar) y reenviar los correo que 
lleguen a Gmail a esa cuenta (que dialoguen con toda la seguridad que 
quieran los servidores de correo entre ellos mismos).

Esta opción no me termina de convencer por los bounces y demás, sé que 
a la larga dará problemas :-(

2. Configurar OAuth2 en Mutt y Fetchmail, si lo permiten, o buscar 
alguna aplicación alternativa que sí tenga soporte.

Seguramente, y para curarme en salud, haga las dos cosas (1 y 2) :-)

> Las opciones son usar OAuth (no tengo claro que mutt lo soporte) o una
> contraseña de aplicación (pero Google no te las ofrece a menos que
> tengas activado el 2FA)

Para Mutt he visto esto (no lo he probado):

mutt integration with Gmail using OAuth
https://luxing.im/mutt-integration-with-gmail-using-oauth/

Para Thunderbird:

Using OAuth2 with Thunderbird and Gmail
https://www.supertechcrew.com/thunderbird-oauth2-gmail/

Y para mi querido Fetchmail... pues me parece que tocará instalar la 
versión 7, aplicar el parche que hay para la versión 6... o buscar 
alguna alternativa.

P.S. Si a partir del día 30 no me leéis por la lista es que mis 
optimistas planes han salido mal :-P

Saludos,

-- 
Camaleón 



Re: OT: Repositorio GIT

2022-05-15 Por tema Camaleón
El 2022-05-14 a las 19:39 -0400, Roberto C. Sánchez escribió:

> On Sat, May 14, 2022 at 04:32:04PM -0300, JavierDebian wrote:
> > Buenas tardes.
> > 
> > Preguntonta:
> > 
> > ¿Qué tan seguro es el repositorio git éste?
> > 
> > https://salsa.debian.org/public
> > 
> Depende en tu modelo de seguridad.  Si hay un paquete y te hace falta
> alguna versión que todavía no ha llegado a la versión de Debian que
> estás usado, entonces es posible que te sirva.  Pero a la vez es
> importante tener en cuenta que no todo que se encuentra en
> salsa.debian.org terminará en paquetes oficiales.

https://wiki.debian.org/Salsa

En ese repositorio hay de todo, pero más que paquetes para instalar son 
herramientas internas para los desarrolladores.

Saludos,

-- 
Camaleón 



Re: Servidor imap.gmail.com y mutt falla.

2022-05-14 Por tema Camaleón
El 2022-05-14 a las 11:10 -0500, Aristobulo Pinzon escribió:

> Servidor imap.gmail.com y mutt falla.

Por aquí funciona correctamente.

> Al enviar o consultar el correo ya no funciona normal.
> Presenta esta respuesta:
> "No se encontró la dirección del servidor imap.gmail.com"

Ese error parece provenir del servidor de nombres.
Cuando tengas problemas con Mutt, ejecútalo en modo depuración para ver 
más información (mutt -d 2) en ~/.muttdebug0.

Pero vaya, primero revisa que puedes resolver bien los dominios:

host imap.gmail.com

> Parece que gmail canceló mutt y otros clientes de correo para favorecer su
> monopolio?...

Todavía no, pero todo llegará ;-/

Saludos,

-- 
Camaleón 



Re: Debian pure blends

2022-05-12 Por tema Camaleón
El 2022-05-12 a las 16:05 +, Alejandro escribió:

(reenvío a la lista, me llegó d enuevo al privado)

> --- Original Message ---
> El jueves, 12 de mayo de 2022 a las 08:45, Camaleón  
> escribió:
> 
> 
> > El 2022-05-11 a las 22:03 +, Alejandro escribió:
> >
> > (reenvío a la lista, este sí me llegó bien pero al privado)
> >
> > > --- Original Message ---
> > > El miércoles, 11 de mayo de 2022 a las 15:25, Camaleón noela...@gmail.com 
> > > escribió:
> > >
> > > > El 2022-05-11 a las 11:29 +, Alejandro escribió:
> > > >
> > > > (este correo también se me fue a la lista de spam) :-?
> > > >
> > > > > Hola amigos, estaba buscando una alternativa a Celestia y me he 
> > > > > topado con Debian Astro, pero no entiendo muy bien: no se trata de un 
> > > > > programa con un montón de metapaquetes, sino de un sistema operativo 
> > > > > completo verdad?
> > > > > PD: Alguien tiene instalado Celestia en Debian 11?
> > > >
> > > > Parece que quitaron¹ el paquete de los repos de Debian proque no salían
> > > > nuevas versiones, pero quizá puedas sugerir que lo vuelvan a incluir²,
> > > > no debe haber muchas aplicaciones de este tipo para Linux.
> > > >
> > > > ¹RM: celestia -- ROM; Dead upstream
> > > > https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=809916
> > > >
> > > > ²Request For Package
> > > > https://wiki.debian.org/RFP
> >
> > > Vale gracias hubble y Camaleon. Ya probé a instalarlo pero ese fichero en 
> > > sources.list.d no funciona porque no hay ninguna verión incluida en los 
> > > repositorios de bullseye al parecer. Entonces lo de sugerir que lo 
> > > vuelvan a incluir pues está muy bien, seguramente lo haga.
> >
> >
> > Si no han sacado los bianrios para Debian 11, pregunta en su foro o
> > mira... parece que alguien ya lo preguntó, mira a ver si te srve lo que
> > sugieren:
> >
> > Celestia Not Running After Upgrading to Debian 11
> > https://celestia.space/forum/viewtopic.php?f=15=21492=155231
> >
> > > No, la verdad es que me gusta la Astronomía pero sé más bien poco, en 
> > > realidad necesito grabar un video que sea un pequeño viaje estelar para 
> > > un proyecto de web que estoy haciendo. El viaje tiene que finalizar en el 
> > > punto del planeta Tierra de donde sea el usuario que se ha hecho el 
> > > perfil en la web y ha subido unos archivos. La llamo Earth's Inner 
> > > Childhood, es para que las personas no perdamos relación con nuestro niño 
> > > interior. Cuando tenga la web suficientemente desarrollada seguramente 
> > > haré una campaña kickstarter, se me ocurre que podría ser buena idea 
> > > compartirla por aquí también si nadie tiene inconveniente.
> >
> >
> > ¿Y Google Earth no te serviría?
> > Recuerdo que lo tuve instalado en mi Debian hace varios años, no sé si
> > seguirá habiendo versión para linux :-?
> >
> > > Con Celestia podría grabar ese vídeo y hacer el montaje que necesito y 
> > > quedaría muy chulo, por eso lo buscaba hubble.
> > >
> > > Si, lamento lo de spam, cuando envio mails desde protonmail a muchos 
> > > sitios entra como spam me dice la gente xd...no sé si puedo hacer algo 
> > > con eso pero creo que no.
> >
> >
> > Ah, pues es verdad... pues me parece que todavía no lo han solucionado
> > del todo:
> >
> > Gmail accidentally marking ProtonMail emails as spam has been fixed by
> > Google
> > https://www.reddit.com/r/ProtonMail/comments/r800yz/gmail_accidentally_marking_protonmail_emails_as/

> Ya sé que haré Camaleón, tengo una buena solución para usuarios de Debian y 
> derivados, aunque estaré pendiente por si puedo volver a disponer de Celestia 
> en bullseye a falta de conocer algún módulo de Debian Astro que pudiera 
> instalar y que permita hacer desplazamientos guiados entre cuerpos celestes.
> 
> Usaré un portátil que tengo con ubuntu 20.04 ( supongo que podré instalar 
> Celestia allí ) para hacer el video y luego transferiré el archivo entre los 
> equipos via el programa gFTP o en su defecto una memoria externa usb...El 
> portátil no es muy potente, pero supongo que servirá, así me evito usar los 
> servicios de google que más o menos me vienen haciendo la misma gracia que 
> usar microsoft la verdad...no me gusta mucho.
> 
> Gracias de nuevo hasta la próxima!

Saludos,

-- 
Camaleón 



Re: Debian pure blends

2022-05-12 Por tema Camaleón
El 2022-05-11 a las 22:03 +, Alejandro escribió:

(reenvío a la lista, este sí me llegó bien pero al privado)

> --- Original Message ---
> El miércoles, 11 de mayo de 2022 a las 15:25, Camaleón  
> escribió:
> 
> 
> > El 2022-05-11 a las 11:29 +, Alejandro escribió:
> >
> > (este correo también se me fue a la lista de spam) :-?
> >
> > > Hola amigos, estaba buscando una alternativa a Celestia y me he topado 
> > > con Debian Astro, pero no entiendo muy bien: no se trata de un programa 
> > > con un montón de metapaquetes, sino de un sistema operativo completo 
> > > verdad?
> > > PD: Alguien tiene instalado Celestia en Debian 11?
> >
> >
> > Parece que quitaron¹ el paquete de los repos de Debian proque no salían
> > nuevas versiones, pero quizá puedas sugerir que lo vuelvan a incluir²,
> > no debe haber muchas aplicaciones de este tipo para Linux.
> >
> > ¹RM: celestia -- ROM; Dead upstream
> > https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=809916
> >
> > ²Request For Package
> > https://wiki.debian.org/RFP

> Vale gracias hubble y Camaleon. Ya probé a instalarlo pero ese fichero en 
> sources.list.d no funciona porque no hay ninguna verión incluida en los 
> repositorios de bullseye al parecer. Entonces lo de sugerir que lo vuelvan a 
> incluir pues está muy bien, seguramente lo haga.

Si no han sacado los bianrios para Debian 11, pregunta en su foro o 
mira... parece que alguien ya lo preguntó, mira a ver si te srve lo que 
sugieren:

Celestia Not Running After Upgrading to Debian 11
https://celestia.space/forum/viewtopic.php?f=15=21492=155231

> No, la verdad es que me gusta la Astronomía pero sé más bien poco, en 
> realidad necesito grabar un video que sea un pequeño viaje estelar para un 
> proyecto de web que estoy haciendo. El viaje tiene que finalizar en el punto 
> del planeta Tierra de donde sea el usuario que se ha hecho el perfil en la 
> web y ha subido unos archivos. La llamo Earth's Inner Childhood, es para que 
> las personas no perdamos relación con nuestro niño interior. Cuando tenga la 
> web suficientemente desarrollada seguramente haré una campaña kickstarter, se 
> me ocurre que podría ser buena idea compartirla por aquí también si nadie 
> tiene inconveniente.

¿Y Google Earth no te serviría? 
Recuerdo que lo tuve instalado en mi Debian hace varios años, no sé si 
seguirá habiendo versión para linux :-?
 
> Con Celestia podría grabar ese vídeo y hacer el montaje que necesito y 
> quedaría muy chulo, por eso lo buscaba hubble.
> 
> Si, lamento lo de spam, cuando envio mails desde protonmail a muchos sitios 
> entra como spam me dice la gente xd...no sé si puedo hacer algo con eso pero 
> creo que no.

Ah, pues es verdad... pues me parece que todavía no lo han solucionado 
del todo:

Gmail accidentally marking ProtonMail emails as spam has been fixed by 
Google
https://www.reddit.com/r/ProtonMail/comments/r800yz/gmail_accidentally_marking_protonmail_emails_as/

> Bueno gracias por la ayuda!

Saludos,

-- 
Camaleón 



Re: reinicio de servicios después de editar configuraciones

2022-05-12 Por tema Camaleón
El 2022-05-11 a las 16:21 -0400, José Betancourt Mondeja escribió:

> En algún momento, instalé una herramienta que me reiniciaba
> automáticamente el squid una vez que detectaba que había hecho algún
> cambio en la configuración. Alguien sabe como se llama esa aplicación
> ? Lo mismo servía para cualquier otro servicio. Gracias.

Quizá sea «inotify» o alguna aplicación similar.

Saludos,

-- 
Camaleón 



Re: Debian pure blends

2022-05-11 Por tema Camaleón
El 2022-05-11 a las 11:29 +, Alejandro escribió:

(este correo también se me fue a la lista de spam) :-?

> Hola amigos, estaba buscando una alternativa a Celestia y me he topado con 
> Debian Astro, pero no entiendo muy bien: no se trata de un programa con un 
> montón de metapaquetes, sino de un sistema operativo completo verdad?
> PD: Alguien tiene instalado Celestia en Debian 11?

Parece que quitaron¹ el paquete de los repos de Debian proque no salían 
nuevas versiones, pero quizá puedas sugerir que lo vuelvan a incluir², 
no debe haber muchas aplicaciones de este tipo para Linux.

¹RM: celestia -- ROM; Dead upstream
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=809916

²Request For Package
https://wiki.debian.org/RFP

Saludos,

-- 
Camaleón 



Re: /etc/resolv.conf en Debian Bookworm

2022-05-05 Por tema Camaleón
El 2022-04-28 a las 16:32 +, Guillermo Sosa escribió:

Este correo tampoco me ha llegado a la bandeja de entrada.
No veía los correos de Guillermo porque Gmail los marca como spam :-?

(...)

> El jueves, 28 de abril de 2022 a las 11:27, Camaleón  
> escribió:
> 
> 
> > El 2022-04-28 a las 10:24 +0200, fernando sainz escribió:
> >
> > > El mié, 27 abr 2022 a las 23:55, Guillermo Sosa (auxt...@protonmail.com)
> > > escribió:
> >
> >
> > No sé por qué pero este correo de Guillermo no me llegó (no está en
> > spam ni en la carpeta Todos de Gmail) :-?
> >
> > > > Buenas tardes aquí en Argentina.
> > > > Desde hace años, mas precisamente desde Stretch, construyo mi 
> > > > distribución
> > > > (con lb build) personalizada; hoy uso la "estable" Bullseye, pero ya 
> > > > estoy
> > > > experimentando con Bookworm. De hecho hace un mes mas o menos que estoy
> > > > probandola con escritorios Cinnamon, Mate y Xfce. Hasta 10 ó 12 días 
> > > > atrás
> > > > todas funcionaban perfecto, pero de repente, con cualquier DE, 
> > > > comenzaron a
> > > > tener problemas con /etc/resolv.conf tanto en live-system como 
> > > > instaladas a
> > > > disco. De hecho ese archivo, que en la jaula chroot se activa (ustedes 
> > > > lo
> > > > deben saber) con el comando; *cp /etc/resolv.conf 
> > > > chroot/etc/resolv.conf,
> > > > *o sea copiando el resolv.conf del sistema anfitrión al sistema en
> > > > construcción en la carpeta chroot. El mismo es un archivo de texto plano
> > > > con el siguiente contenido:
> > > >
> > > > # Generated by NetworkManager
> > > > search fibertel.com.ar http://fibertel.com.ar
> > > > nameserver 192.168.0.1
> > > >
> > > > Donde fibertel.com.ar es mi proovedor de internet, y el nameserver
> > > > calculo que se asigna de acuerdo a mi dirección IP
> > > >
> > > > /etc/resolv.conf al salir de la jaula chroot o al salir del sistema en
> > > > modo live, se borra y cada vez que iniciamos "network-manager" como dice
> > > > mas arriba vuelve a generarlo.
> > > > Y acá viene el tema, desde hace diez días ocurre que una vez terminado 
> > > > el
> > > > sistema, hacer la imágen ISO y correrla se genera un /etc/resolv.conf 
> > > > que
> > > > en realidad es un enlace a:
> > > > /run/systemd/resolve/resolv.conf, pero es un enlace vacío, ya que en
> > > > /run/systemd/ el directorio "resolve" y por lo tanto el archivo
> > > > "resolv.conf" NO EXISTEN. Lo mismo ocurre si se instala el sistema en 
> > > > disco
> > > > duro. Como consecuencia no se encuentran los DNS y lógicamente no se 
> > > > puede
> > > > acceder a la web.
> > > > Cabe aclarar que si instalo a disco, y luego reemplazo el 
> > > > /etc/*resolv.conf
> > > > enlace *por el un resolv.conf con el contenido que dejé mas arriba,
> > > > arranca la conexión.
> > > >
> > > > Esperando no haber sido demasiado extenso y que se aya entendido me 
> > > > quedo
> > > > a la espera de una respuesta, ya sea porque le haya ocurrido a alguien o
> > > > bien sepa de donde se genera el error/problema.
> > > > He buscado mucho en internet (y lo sigo haciendo) pero hasta ahora no
> > > > encuentro nada.
> >
> >
> > Hay varias formas de gestionar la red en Debian. Decide cuál vas a usar
> > o a darle prioridad, y en base a tu elección, configura el servicio
> > asociado para que se encargue de buscar el archivo de configuración de
> > los parámetros de la interfaz (IP, DNS, pasarela, enrutado, etc...).
> >
> > NetworkConfiguration
> > https://wiki.debian.org/NetworkConfiguration#A3_ways_to_configure_the_network
> >
> > systemd-resolved.service, systemd-resolved — Network Name Resolution
> > manager
> > https://www.freedesktop.org/software/systemd/man/systemd-resolved.service.html
> >
> > > > Muchas gracias y saludos
> > > >
> > > > Guillermo E. Sosa
> > > > San Nicolás de los Arroyos
> > > > Bs. As. - Argentina
> > > >
> > > > Enviado con ProtonMail https://protonmail.com/ correo seguro.
> > >
> > > Mira a ver si está instalado el paquete "resolvconf"
> > >
> > > S2.
> >
> >
> > Saludos,
>

Re: No puedo imprimir en impresora en red

2022-04-29 Por tema Camaleón
El 2022-04-28 a las 18:02 -0300, Marcelo Eduardo Giordano escribió:

> Seguramente se trata de este bug:
> > CUPS fails to print to autodetected printers because of cups-browsed
> > error
> > https://bugs.launchpad.net/ubuntu/+source/cups-filters/+bug/1855595
> > 
> > Mira a ver si lo que sugieren para resolverlo te sirve.
> 
> No es este bug. El sistema me autodetecta la impresora en red

Revisa bien ese bug porque precisamente se trata de eso, de que las 
impresoras detectadas automáticamente no impimen, independientemente de 
si son remotas (red) o locales.

> > > Tampoco puedo imprimir en una Epson L3110 que esta conectada en red en 
> > > otra
> > > pc con debian y me dice "la configuracion de la impresora es incorrecta o 
> > > la
> > > impresora ya no existe"
> > Esta parece más complicada de instalar. Mira a ver si has instalado los
> > drivers correctamente y si en el equipo donde está instalada
> > físicamente imprimime bien.
> Lo corroboré y aparte de que el host imprime bien, puedo imprimir desde otra
> pc (cliente) con Arch
> > Si no es un problema de controladores, revisa la configuración de CUPS,
> > tanto en el equipo cliente como en el servidor, relacionada con la
> > compartición de la impresora.

> Hay que cambiar algo en cups para imprimir en un servidor? esa solución
> puede ser

Sí, claro. Al menos en el lado de la parte servidora, eso seguro.
Por motivos de seguridad, de manera predeterminada CUPS no comparte las 
impresoras que detecta, tienes que decirle expresamente que los clientes
pueden acceder desde la red esos recursos y darle los permisos adecuados.

> > CUPS/Printer sharing
> > https://wiki.archlinux.org/title/CUPS/Printer_sharing
> > 
> > > Ambas impresoras puedo imprimir perfectamente desde otra pc con Arch
> 
> Esta solución es para clientes en Arch cierto? eso entiendo. Igual en Arch
> me funciona bárbaro

Esa guía sirve para todos los sistemas Linux. La wiki de Archlinux es 
muy completa, práctica y está muy bien explicada, la vedad.
Y también puedes consultar el manual del propio CUPS, para tener claros 
los conceptos básicos y la propia wiki de Debian, que es un poco 
caótica pero también te puede dar alguna idea:

https://www.cups.org/doc/sharing.html
https://wiki.debian.org/Printing
https://wiki.debian.org/SystemPrinting

Toda ayuda es poca :-) pero recuerda que cada distribución tiene su 
propio sistema de configuración o ubicación de archivos, sólo tienes 
que entender y después adecuar las instrucciones que leas a tu entorno 
Debian.
 
> Es mas, estuve probando con otra computadora con debian bullseye y funciona
> perfecto todo. Es esa notebook.

Compara las configuraciones de CUPS en ambos equipos, el cliente con el 
que puedes imprimir bien y el portátil donde te da error.

Lo más sencillo suele ser eliminar y volver a añadir la impresora, 
aunque no siempre resuelve el problema.

Saludos,

-- 
Camaleón 



Re: /etc/resolv.conf en Debian Bookworm

2022-04-28 Por tema Camaleón
El 2022-04-28 a las 10:24 +0200, fernando sainz escribió:

> El mié, 27 abr 2022 a las 23:55, Guillermo Sosa ()
> escribió:

No sé por qué pero este correo de Guillermo no me llegó (no está en 
spam ni en la carpeta Todos de Gmail) :-?
 
> > Buenas tardes aquí en Argentina.
> > Desde hace años, mas precisamente desde Stretch, construyo mi distribución
> > (con lb build) personalizada; hoy uso la "estable" Bullseye, pero ya estoy
> > experimentando con Bookworm. De hecho hace un mes mas o menos que estoy
> > probandola con escritorios Cinnamon, Mate y Xfce. Hasta 10 ó 12 días atrás
> > todas funcionaban perfecto, pero de repente, con cualquier DE, comenzaron a
> > tener problemas con /etc/resolv.conf tanto en live-system como instaladas a
> > disco. De hecho ese archivo, que en la jaula chroot se activa (ustedes lo
> > deben saber) con el comando; *cp /etc/resolv.conf chroot/etc/resolv.conf,
> > *o sea copiando el resolv.conf del sistema anfitrión al sistema en
> > construcción en la carpeta chroot. El mismo es un archivo de texto plano
> > con el siguiente contenido:
> >
> > *# Generated by NetworkManager*
> > *search fibertel.com.ar <http://fibertel.com.ar>*
> > *nameserver 192.168.0.1*
> >
> > Donde fibertel.com.ar es mi proovedor de internet, y el nameserver
> > calculo que se asigna de acuerdo a mi dirección IP
> >
> > /etc/resolv.conf al salir de la jaula chroot o al salir del sistema en
> > modo live, se borra y cada vez que iniciamos "network-manager" como dice
> > mas arriba vuelve a generarlo.
> > Y acá viene el tema, desde hace diez días ocurre que una vez terminado el
> > sistema, hacer la imágen ISO y correrla se genera un /etc/resolv.conf que
> > en realidad es un enlace a:
> > /run/systemd/resolve/resolv.conf, pero es un enlace vacío, ya que en
> > /run/systemd/ el directorio "resolve" y por lo tanto el archivo
> > "resolv.conf" NO EXISTEN. Lo mismo ocurre si se instala el sistema en disco
> > duro. Como consecuencia no se encuentran los DNS y lógicamente no se puede
> > acceder a la web.
> > Cabe aclarar que si instalo a disco, y luego reemplazo el /etc/*resolv.conf
> > enlace *por  el un resolv.conf con el contenido que dejé mas arriba,
> > arranca la conexión.
> >
> > Esperando no haber sido demasiado extenso y que se aya entendido me quedo
> > a la espera de una respuesta, ya sea porque le haya ocurrido a alguien o
> > bien sepa de donde se genera el error/problema.
> > He buscado mucho en internet (y lo sigo haciendo) pero hasta ahora no
> > encuentro nada.

Hay varias formas de gestionar la red en Debian. Decide cuál vas a usar 
o a darle prioridad, y en base a tu elección, configura el servicio 
asociado para que se encargue de buscar el archivo de configuración de 
los parámetros de la interfaz (IP, DNS, pasarela, enrutado, etc...).

NetworkConfiguration
https://wiki.debian.org/NetworkConfiguration#A3_ways_to_configure_the_network

systemd-resolved.service, systemd-resolved — Network Name Resolution 
manager
https://www.freedesktop.org/software/systemd/man/systemd-resolved.service.html

> >
> > Muchas gracias y saludos
> >
> >
> > Guillermo E. Sosa
> > San Nicolás de los Arroyos
> > Bs. As. - Argentina
> >
> >
> > Enviado con ProtonMail <https://protonmail.com/> correo seguro.
> >
> 
> 
> Mira a ver si  está instalado el paquete "resolvconf"
> 
> S2.

Saludos,

-- 
Camaleón 



Re: No puedo imprimir en impresora en red

2022-04-27 Por tema Camaleón
El 2022-04-26 a las 16:13 -0300, Marcelo Eduardo Giordano escribió:

> Amigos:
> 
> Acabo de instalar debian en mi nueva notebook e instalo mis dos impresoras y
> en ambas no puedo imprimir
> 
> una impresora es una impresora XEROX B215 que se conecta directamente a la
> red y que me el sistema me la detectó automaticamente. Sin embargo al
> imprimir me dice "No suitable destinacion host found by cups browsed"

Seguramente se trata de este bug:

CUPS fails to print to autodetected printers because of cups-browsed 
error 
https://bugs.launchpad.net/ubuntu/+source/cups-filters/+bug/1855595

Mira a ver si lo que sugieren para resolverlo te sirve.
 
> Tampoco puedo imprimir en una Epson L3110 que esta conectada en red en otra
> pc con debian y me dice "la configuracion de la impresora es incorrecta o la
> impresora ya no existe"

Esta parece más complicada de instalar. Mira a ver si has instalado los 
drivers correctamente y si en el equipo donde está instalada 
físicamente imprimime bien.

Si no es un problema de controladores, revisa la configuración de CUPS, 
tanto en el equipo cliente como en el servidor, relacionada con la 
compartición de la impresora.

CUPS/Printer sharing
https://wiki.archlinux.org/title/CUPS/Printer_sharing

> Ambas impresoras puedo imprimir perfectamente desde otra pc con Arch

Saludos,

-- 
Camaleón 



Re: Consulta /

2022-04-19 Por tema Camaleón
El 2022-04-19 a las 00:55 +, Ricardo Delgado escribió:

> Buenas noches,
> 
> Una consulta de novato, la ultima instalacion realizada, tome la sugerencia 
> de particionado de DEBIAN
> 
> entonces me genero / y /home como particiones separadas

Parece un particionamiento sensato cuando no hay mucho espacio en disco 
pero teniendo en cuenta que la mayoría de aplicaciones y archivos del 
sistema (bibliotecas) se van a instalar en la partición raíz y debes 
tener espacio suficiente para que el sistema funcione sin problemas.
 
> teniendo /dev/sda1 para / y /dev/sda6 para /home

¿Y cuánto espacio has dedicado para cada partición?

> en / genere 30 gb, el tema surge porque los 30 gb se llenaron, luego para 
> limpiar realice un APT CLEAN y tambien borre LINUX-IMAGE viejos.
> 
> Ahora tengo utilizado un 70% de la particion, pero quiero limpiar mas la 
> misma, y ahi surge la duda, duda de novato, QUE ARCHIVOS y/o CARPETAS podria 
> borrar o mover a /HOME, veo que tengo una carpeta /SNAP la cual tiene 7 gb, 
> no se si esta en / 
> 
> y asi para borrar/mover y liberar espacio de /, logicamente primero necesito 
> saber que tengo en / y luego que podria borrar o mover.

Yo suelo buscar directorios gordos con esta orden:

du -d1 -h -x /

Y conforme voy viendo qué directorios están llenos, busco si puedo 
eliminar esos archivos, que normalmente suelen ser de caché de paquetes 
que he descargado.

En tu caso, dices que tienes un directorio /SNAP, seguramente será el 
directorio de instalación del gestor de paquetes Snap, que tendrás 
instalado bajo la raíz «/» ya que de otra forma estaría bajo 
/home/usuario/SNAP.

No sé cómo funciona SNAP, nunca me he puesto con estos nuevos gestores 
que han ido apareciendo (Flatpak, Zero Install, etc...), es decir, sé 
que existen pero poco más. 

Revisa la documentación de SNAP¹ y mira aver qué puedes eliminar, si es 
que lo permite, porque seguramente bajo el directorio del sistema de 
SNAP tengas los paquetes instalados y si los eliminas dejarán de estar 
disponibles, como es natural.

Lo que quizá sí puedas hacer es, como sucede con APT, eliminar la caché 
de paquetes antiguos de SNAP que ya no tengas instalados para ganar algo
de espacio en tu ráiz sin sacrificar las aplicaciones que sí usas o 
tienes instaladas actualmente:

How to remove uninstalled snaps from cache?
https://askubuntu.com/questions/1075050/how-to-remove-uninstalled-snaps-from-cache

¹https://snapcraft.io/docs/getting-started

Saludos,

-- 
Camaleón 



Re: SOS... Modo gráfico deshabilitado.

2022-04-13 Por tema Camaleón
El 2009-12-21 a las 23:11 -0500, luis escribió:

Mando a la lista...

> > > update-rc.d gdm3 disable
> > 
> > ¿Qué te devuelve la orden «systemctl get-default»?
> 
> Me devuelve que tengo el modo gráfico, pero no lo levanta automáticamente.

¿Has probado a reconfigurar el gestor de sesiones?

sudo dpkg-reconfigure gdm3

> > ¿Tampoco puedes cargar el entorno gráfico con «startx»? (si no te
> > funciona el comando con el usuario prueba a ejecutarlo desde root)
> 
> startx: órden no encontrada :)
> 
> Con root tampoco.

Será que no tienes instalado xinit :-?

> Al ejecutar estos,
> 
> sudo systemctl set-default multi-user.target
> sudo systemctl set-default
> multi-user.target
> sudo systemctl reboot
> 
> sudo systemctl set-default graphical.target
> sudo systemctl set-default
> graphical.target
> sudo systemctl reboot
> 
> Hacen los cambios bien pero no levanta gnome al iniciar. Obviamente,
> update-rc.d gdm3 disable, este es quien tiene la culpa, y no yo  :D

Si estás en lo cierto, reconfigurando el paquete se solventará... en 
caso contrario, ya sabes a quién culpar :-P

Saludos,

-- 
Camaleón 



Re: SOS... Modo gráfico deshabilitado.

2022-04-13 Por tema Camaleón
El 2022-04-12 a las 22:52 -0400, luis escribió:

> Estaba tratando de resolver el cambio de la interfaz gráfica a texto y use
> un comando para versiones anteriores de debian,
> 
> update-rc.d gdm3 disable
> 
> Y ahora no logro levantar la interfaz gráfica. Hice lo siguiente, pero
> nada...
> 
> update-rc.d gdm3 enable
> 
> No funciona  '<

Pues menos mal que te copié/pegué las instrucciones con las órdenes en 
otro correo >>>:-)

> La forma correcta es:
> 
> To change boot target to the text mode:
> 
> sudo systemctl set-default multi-user.target
> 
> Reboot the system using the reboot command:
> 
> sudo systemctl reboot
> 
> How to switch boot target to GUI (graphical UI).
> 
> Find which target unit is used by default:
> 
> systemctl get-default
> 
> To change boot target to the GUI mode:
> 
> sudo systemctl set-default graphical.target
> 
> Make sure you reboot the Linux box using the reboot command:
> 
> sudo rebootPero ya metí la pata, y necesito revertir esto,
> 
> update-rc.d gdm3 disable

¿Qué te devuelve la orden «systemctl get-default»?

¿Tampoco puedes cargar el entorno gráfico con «startx»? (si no te 
funciona el comando con el usuario prueba a ejecutarlo desde root)

Saludos,

-- 
Camaleón 



Tipo de fuente de GRUB2 (era: Tildes y eñes en consola de X.)

2022-04-12 Por tema Camaleón
El 2022-04-12 a las 09:41 -0500, Aristobulo Pinzon escribió:

> Algo fuera de lugar. :-)
> 
> En el /boot/grub/grub.cfg hay una linea que dice
> font="/usr/share/grub/unicode.pf2" y supongo que es las fuentes que se usan
> en el menú de inicio del sistema y que solo duran un poco.
> 
> Pregunta: ¿ Habrá alguna manera de seguirlas utilizando como como fuentes
> para las tty?

Si existe una aplicación para generar tipos de letra pf2 (grub2-mkfont) 
debe haber otra para hacer lo contrario, es decir, para convertir tipos 
de letra con formato pf2 a ttf u otf, etc...

De todas formas, si tiene sinterés en tipos de letra para usar en 
terminales y consolas, yo miraría las del paquete «fonts-terminus-otb», 
quizá te sirvan.

En cualquier caso, me parece que el origen del tipo de letra que usa 
GRUB2 es éste:

https://unifoundry.com/unifont/index.html

Saludos,

-- 
Camaleón 



Re: Tildes y eñes en consola de X.

2022-04-11 Por tema Camaleón
El 2022-04-11 a las 06:35 -0400, luiseded...@nauta.cu escribió:

> Quoting Camaleón :
> 
> > El 2009-12-22 a las 01:35 -0500, luis escribió:
> > 
> > > - Alguna sugerencia para activar las tildes y eñes en la consola de X?
> > > 
> > > Todo bien en la consola modo texto pero no así en la consola de X.
> > 
> > ¿Y qué «consola de X» es esa? >:-)
> > 
> > Porque está gnome-terminal, konsole, xfce4-terminal, xterm, terminator,
> > guake...
> > entre otras.
> 
> Tantas? Despu'es de instalar el sistema base y gnome veo una sola, terminal
> de gnome :)

Yo revisaría la configuración regional del sistem (Ajustes de GNOME), 
la salida de la orden «locale -a», la configuración de la codificación 
de la propia gnome-terminal y probaría a iniciar gnome-terminal 
desde otra consola que tengas instalada (p. ej., xterm) a ver si al 
iniciarla te saca algún mensajito.

Saludos,

-- 
Camaleón 



Re: Tildes y eñes en consola de X.

2022-04-11 Por tema Camaleón
El 2009-12-22 a las 01:35 -0500, luis escribió:

> - Alguna sugerencia para activar las tildes y eñes en la consola de X?
> 
> Todo bien en la consola modo texto pero no así en la consola de X.

¿Y qué «consola de X» es esa? >:-)

Porque está gnome-terminal, konsole, xfce4-terminal, xterm, terminator, 
guake... 
entre otras.

Normalmente no hay que hacer nada, una vez defines el idioma en el 
sistema las aplicaciones se configuran automáticamente, así que cuantos más 
detalles nos des sobre la configuración de tu sistema y el problema que 
tienes, mejor.

> - Se mantiene la desactivación de X para que al iniciar, el sistema se quede
> en consola?
> 
> Recuerdo en las versiones anteriores era así: update-rc.d gdm3 disable
> 
> luego, para levantar la interfaz gráfica ejecutar: startx
> 
> Pregunto pues no quiero echar a perder nada pues volver a instalar algo
> gordo, y sin una buena conexión, es una odisea  '<

Si lo que quieres es iniciar Debian sin entorno gráfico, con systemd 
tendrás que decirle que inicie en el modo apropiado:

How to switch boot target to text or GUI in systemd Linux
https://www.cyberciti.biz/faq/switch-boot-target-to-text-gui-in-systemd-linux/


Switching boot target to text

The procedure is as follows to change into a text mode runlevel under 
systemd:

Open the terminal application.
For remote Linux servers, use the ssh command.

Find which target unit is used by default:
systemctl get-default

To change boot target to the text mode:
sudo systemctl set-default multi-user.target

Reboot the system using the reboot command:
    sudo systemctl reboot
***

Saludos,

-- 
Camaleón 



Re: Problemas con Mutt (era: Resolución de pantalla en las tty)

2022-04-10 Por tema Camaleón
El 2022-04-09 a las 13:42 -0500, Aristobulo Pinzon Gmail escribió:

> ​ Gracias por tu interés. 
> Tenía mutt como aplicación de correo configurada en el navegador y en 
> aplicaciones predeterminadas.
> Pero de pronto sucede que cuando deseo contestar algún mensaje, no abre el 
> Mutt para escribir la respuesta si no que envía un mensaje vacío al clicar en 
> la dirección. Y además no conserva el hilo de los mensajes ni se como 
> contestar incluyendo el mensaje enviado como Usted los hace… :-(
> Debo tener algunos errores en el .muttrc.

Por lo que dices, me da la sensación de que lo que falla es la 
integración de Mutt con el navegador.

Pero vayamos por partes.

Para responder a los mensajes de esta lista manteniendo el contenido 
del remitente, tienes que recibir los correos a través de Mutt o desde 
cualquier cliente de correo electrónico, como p. ej., el webmail de 
Gmail.

Si pulsas en los enlaces de respuesta que hay en la página web del 
archivo de la lista¹ no te funcionará, ni con Mutt ni con ningún cliente 
de correo electrónico, ya que esos enlaces preformarteados sólo generan 
un nuevo correo con el asunto y el campo «in-reply-to:» para matener el 
hilado pero el nuevo correo que generas no mantiene el texto del cuerpo 
del mensaje al que respondes. 

Eso también me sucede a mí y tengo Thunderbird configurado como cliente 
de correo predeterminado.

Quizá si explicas con más detalle cómo haces para enviar y recibir los 
correos de la lista te podamos concretar algo más.

¹https://lists.debian.org/debian-user-spanish/2022/04/msg00049.html

Saludos,

-- 
Camaleón 



Problemas con Mutt (era: Resolución de pantalla en las tty)

2022-04-09 Por tema Camaleón
El 2022-04-08 a las 17:50 -0500, Aristobulo Pinzon escribió:

> Disculpen por favor estos mensajes, y es por que el mutt ya no está
> funcionando bien con email.
> abrazos.

También uso Mutt con mi cuenta de Gmail pero no experimento ningún problema 
con la lista ni con el cliente de correo.

¿Qué te sucede exactamente? ¿O por qué crees que el problema viene de 
Mutt? :-?

Saludos,

-- 
Camaleón 



Re: VPN sin ethernet ni ip pública...

2022-04-08 Por tema Camaleón
El 2022-04-07 a las 17:18 -0400, luis escribió:

> Es posible tener una vpn en debian 11 sin tener una conexión ethernet(cable)
> ni ip pública?

Sí.
 
> Aquí en Cuba, muchos tenemos internet compartiendo los datos del móvil. De
> este modo no tienes ip pública.
> 
> He visto un par de video tutoriales para configurar openVPN pero se refieren
> a una conexión ethernet y a una ip pública.
> 
> Es posible configurarse una vpn mediante la conexión a un ap de un móvil?

Sí.
 
> En el móvil si podemos tener vpn y de este modo podemos conectarnos a donde
> querramos pero cuando te conectas desde una laptop al ap del móvil, entonces
> no te funciona la vpn del móvil cuando navegas desde la laptop.
> 
> Solución???

Es una limitación de Android, que no permite enrutar paquetes entre 
dispositivos cuando compartes los datos de la VPN a través del punto de 
acceso.

Instala alguna app para evitar esa restricción. En Google encuentras 
varias opciones y alternativas, por ejemplo:

VPN Hotspot lets you share your VPN connection over a hotspot
https://www.xda-developers.com/vpn-hotspot-share-vpn-connection/

https://www.google.com/search?q=vpn+cell+phone+share+ap

Saludos,

-- 
Camaleón 



Re: Resolución de pantalla en las tty

2022-04-08 Por tema Camaleón
El 2022-04-07 a las 17:23 -0500, Aristobulo Pinzon escribió:

> Como configuro la pantalla en las tty para que la resolución sea:
> 1920 x 1080* 16:9. O al menos sea superior a 800 x 600, para que
> la información se muestre completa.
> 
> LA VERSIÓN DE DEBIAN ES LA:
> 11.3
> 5.10.0-9-amd64
> 
> 
> Agradeciendoles mucho.

Se me ocurren dos sitios para configurar esto:

/etc/default/grub
/etc/default/console-setup

Revisa estos dos artículos:

How to change display resolution in TTY console
https://feitam.es/how-to-change-display-resolution-in-tty-console/

How to Change Your Linux Console Fonts
https://www.linux.com/topic/desktop/how-change-your-linux-console-fonts/

Saludos,

-- 
Camaleón 



Re: Problemas con llave pública para mongodb.

2022-04-07 Por tema Camaleón
El 2009-12-21 a las 23:30 -0500, luis escribió:

(reenvío a la lista)

> On Thu, 07 Apr 2022 01:55:39 -0400, Camaleón  wrote:
> 
> > El 2022-04-06 a las 23:51 -0400, luis escribió:
> > 
> > > On Wed, 06 Apr 2022 07:25:34 -0400, Roberto C. Sánchez
> > > 
> > > wrote:
> > > 
> > > > On Tue, Apr 05, 2022 at 11:53:48PM -0400, luis wrote:
> > > > > Hola,
> > > > >
> > > > > Me estoy instalando MongoDB con debian 11, y como no está en los
> > > repos
> > > > > oficiales de debian, hago lo siguiente,
> > > > >
> > > > > sudo apt-get update
> > > > > sudo apt install curl apt-transport-https software-properties-common
> > > > > gnupg2
> > > > > echo "deb https://repo.mongodb.org/apt/debian buster /
> > > mongodb-org / 4.4
> > > > > main"� | tee /etc/apt/sources.list.d/mongodb-org.list
> > > > > wget -qO "https://www.mongodb.org/static/pgp/server-4.4.asc |
> > > > > apt-key add -"
> > > > > Warning: apt-key is deprecated. Manage keyring files in
> > > trusted.gpg.d
> > > > > instead (see apt-key(8)).
> > > > > gpg: no se han encontrados datos OpenPGP válidos [1]
> > > > > sudo apt-get update
> > > > > sudo ap-get install mongodb-org
> > > > >
> > > > Luis,
> > > >
> > > > En lugar de apt-key, se debe hacer lo siguiente:
> > > >
> > > > sudo sh -c 'curl -s
> > > https://www.mongodb.org/static/pgp/server-4.4.asc |
> > > > gpg --dearmor >/etc/apt/trusted.gpg.d/mongodb-org-4.4.gpg
> > > 
> > > Aun sin resolver mi problema con MongoDB. He revisado varios
> > > tutoriales que
> > > he encontrado y todos me dan el mismo problema
> > 
> > ¿Y qué problema es ese? :-)
> 
> Es este,
> 
> gpg: no se han encontrados datos OpenPGP válidos [1]
> 
> A pesar de que empleo el método alternativo para apt-key que se emplean en
> las guías. He encontrado varios tutoriales, con pequenas variaciones, y
> siempre me da este error [1]
> 
> Luego probé accediendo directamente al sitio www.mongodb.org para ver si era
> ese el problema, y parece ser que nos bloquean el acceso. Probé con vpn en
> el móvil, ya que comparto los datos del móvil, y sigue igual, ni con vpn me
> da acceso.
> 
> 403 ERROR
> The request could not be satisfied.
> The Amazon CloudFront distribution is configured to block access from your
> country. We can't connect to the server for this app or website at this
> time. There might be too much traffic or a configuration error. Try again
> later, or contact the app or website owner.

Ah, ahora ya entiendo.

Si no puedes acceder al servidor de MongoDB no podrás añadir el repo ni 
la clave, eso es evidente. Tendrás que descargar los paquetes a mano y 
crearte un mini-mongo-repo local para gestionar tu instalación, si es 
que son varios los paquetes que necesitas.

Si quieres que te enviemos algún paquete en concreto nos lo dices, veo 
que hay varios (paquete mongos, server, shell y tgz):

https://repo.mongodb.org/apt/debian/dists/buster/mongodb-org/4.4/main/binary-amd64/

> > Sin saber lo que estás haciendo exactamente, ese mensaje no es de Mongo
> > sino de la nube de Amazon (AWS). Desconozco por qué motivo Mongo quiere
> > acceder a AWS pero evidentemente, si es un servicio que trabaja en la
> > nube y no tienes acceso al servidor, pues la respuesta es más que clara
> 
> No llega a descagar, así que no me deja instalar. Cuando hago apt-get
> update, se ve que no tiene acceso al sitio de mongodb  :(

Entendido, pues eso sí te lo podemos enviar sin problemas, tanto los 
bianrios como el GPG y el ASC si aún lo necesitas.

Saludos,

-- 
Camaleón 



Re: Problemas con llave pública para mongodb.

2022-04-06 Por tema Camaleón
El 2022-04-06 a las 23:51 -0400, luis escribió:

> On Wed, 06 Apr 2022 07:25:34 -0400, Roberto C. Sánchez 
> wrote:
> 
> > On Tue, Apr 05, 2022 at 11:53:48PM -0400, luis wrote:
> > > Hola,
> > > 
> > > Me estoy instalando MongoDB con debian 11, y como no está en los repos
> > > oficiales de debian, hago lo siguiente,
> > > 
> > > sudo apt-get update
> > > sudo apt install curl apt-transport-https software-properties-common
> > > gnupg2
> > > echo "deb https://repo.mongodb.org/apt/debian buster / mongodb-org / 4.4
> > > main"� | tee /etc/apt/sources.list.d/mongodb-org.list
> > > wget -qO "https://www.mongodb.org/static/pgp/server-4.4.asc |
> > > apt-key add -"
> > > Warning: apt-key is deprecated. Manage keyring files in trusted.gpg.d
> > > instead (see apt-key(8)).
> > > gpg: no se han encontrados datos OpenPGP válidos [1]
> > > sudo apt-get update
> > > sudo ap-get install mongodb-org
> > > 
> > Luis,
> > 
> > En lugar de apt-key, se debe hacer lo siguiente:
> > 
> > sudo sh -c 'curl -s https://www.mongodb.org/static/pgp/server-4.4.asc |
> > gpg --dearmor >/etc/apt/trusted.gpg.d/mongodb-org-4.4.gpg
> 
> Aun sin resolver mi problema con MongoDB. He revisado varios tutoriales que
> he encontrado y todos me dan el mismo problema 

¿Y qué problema es ese? :-)

Porque te hemos dado varios enlaces y sugerencias para que puedas 
importar la clave del repositorio pero si no nos dices qué es lo que haces 
y qué error te aparece pues poco más podemos hacer.

> y resulta que he descubierto y corroborado en la red, que este sitio 
> bloquea a nuestro país por cuestiones de las leyes de restricciones de
> EUA.
> 
> Intentando levantar www.mongodb.org

Vamos a ver... ¿cuándo te aparece ese error? ¿Has podido añadir ya el 
repositorio y tienes MongoDB instalado?

> 403 ERROR
> The request could not be satisfied.
> The Amazon CloudFront distribution is configured to block access from your
> country. We can't connect to the server for this app or website at this
> time. There might be too much traffic or a configuration error. Try again
> later, or contact the app or website owner.
> If you provide content to customers through CloudFront, you can find steps
> to troubleshoot and help prevent this error by reviewing the CloudFront
> documentation.
> Generated by cloudfront (CloudFront)
> Request ID: UusuTs8f6JYbA5ZqnQprfuozpBlQuIZ-bu8vlo4EPh1V8Ubmtfpy0Q==
> 
> Qué prodré hacer? ):

Sin saber lo que estás haciendo exactamente, ese mensaje no es de Mongo 
sino de la nube de Amazon (AWS). Desconozco por qué motivo Mongo quiere 
acceder a AWS pero evidentemente, si es un servicio que trabaja en la 
nube y no tienes acceso al servidor, pues la respuesta es más que clara 
>:-)

Saludos,

-- 
Camaleón 



Re: Recuperar archivos con Photorec

2022-04-06 Por tema Camaleón
El 2022-04-06 a las 13:21 +0200, fjpi escribió:

> borré accidentalmente todos los archivos de una partición en la que tenía
> instalado Ubuntu 20.04 y los recuperé con Photorec. Los archivos
> recuperados han quedado distribuidos en miles de carpetas llamadas
> recup_dir.* que contienen archivos png, pdf, txt y sobre todo elf.
> 
> Según he leído, la mayoría de mis datos estarían incluidos en los archivos
> elf, que son ejecutables. Me gustaría saber cómo extraer mis datos
> originales (ficheros .txt, .py, .tex, etc...) de esos ficheros elf
> generados por Photorec.

Serán binarios que tengas en el sistema (p. ej., /bin/*), pero entiendo 
que te interesará recuperar los datos planos (imágenes, vídeos, 
documentos...) y no los archivos de la instalación del sistema en sí.

sm01@stt008:~$ file /bin/bash
/bin/bash: ELF 64-bit LSB executable, x86-64, version 1 (SYSV), dynamically 
linked, interpreter /lib64/ld-linux-x86-64.so.2, for GNU/Linux 2.6.32, 
BuildID[sha1]=4be0cc32aba02ec4e0f010047be5ae9dee756960, stripped

Saludos,

-- 
Camaleón 



Re: Problemas con llave pública para mongodb.

2022-04-06 Por tema Camaleón
El 2022-04-05 a las 23:53 -0400, luis escribió:

> Me estoy instalando MongoDB con debian 11, y como no está en los repos
> oficiales de debian, hago lo siguiente,

Mongo es un clásico... ¿Qué le pasó al paquete en Debian? ¿Se volvió de 
licencia inmanejable? Podría estar en la sección «non-free» pero veo 
que la mayoría de distribuciones lo han eliminado de sus repositorios :-?

[arch-dev-public] Mongodb and SSPL
https://lists.archlinux.org/pipermail/arch-dev-public/2019-January/029430.html

> sudo apt-get update
> sudo apt install curl apt-transport-https software-properties-common gnupg2
> echo "deb https://repo.mongodb.org/apt/debian buster / mongodb-org / 4.4
> main" | tee /etc/apt/sources.list.d/mongodb-org.list
> wget -qO "https://www.mongodb.org/static/pgp/server-4.4.asc | apt-key add -"
> Warning: apt-key is deprecated. Manage keyring files in trusted.gpg.d
> instead (see apt-key(8)).
> gpg: no se han encontrados datos OpenPGP válidos [1]
> sudo apt-get update
> sudo ap-get install mongodb-org

La última versión estable de Mono es la 5.0 ¿seguro que quieres instalar
la 4.4?
 
> [1] Bueno, ya lo había intentado con la versión 5.0 de MongoDB y el sistema
> me informó que me había desactivado la opción de instalar desde este repo
> por los riesgos.
> 
> Qué debo hacer, pues reviso la página de apt-key pero no entiendo lo que
> debo hacer y no quiero saltarme este paso, aunque no me deja instalar pues
> el sistema no lo permite.
> 
> En versiones anteriores de debian 5, 6, 7, 8 y 9 usé MongoDB sin problemas
> pero aquí me da problemas con la llave pública y el sistema no me deja
> seguir.
> 
> Desde ya, muchas gracias.

Parece que Debian 11 va a ser la última versión en admitir apt-key pero 
según dice el artículo, debería seguir estando operativo:

apt-key Is Deprecated. How To Add OpenPGP Repository Signing Keys 
Without It On Debian, Ubuntu, Linux Mint, Pop!_OS, Etc.
https://www.linuxuprising.com/2021/01/apt-key-is-deprecated-how-to-add.html

¿Has comprobado si, a pesar del mensaje, se ha instalado Mongo 
correctamente? Si no se ha instalado, prueba lo que sugieren en el 
artículo anterior para añadir una clave GPG con seguridad o los pasos 
que dicen este otro:

How to Safely Add GPG key in Debian 11 or Kali Linux
https://www.how2shout.com/linux/debian-11-or-kali-linux-apt-key-is-deprecated-warning-here-is-the-solution/

Saludos,

-- 
Camaleón 



Re: Zebra TLP2844 impresion custom

2022-04-04 Por tema Camaleón
El 2022-04-04 a las 17:06 +0200, Fernando Ferraro escribió:

> El lun, 4 abr 2022 a las 13:19, Camaleón () escribió:
> 
> > El 2022-04-04 a las 12:35 +0200, Fernando Ferraro escribió:
> >
> > > Tengo hace años impresoras de etiquetas Zebra TLP2844
> > > En cualquier versión de Debian con utilizar el driver por defecto y
> > colocar
> > > una medida
> > > en custom de 59x19mm funciona todo correctamente.
> > > Las terminales estan en testing
> > > Pero cuando actualizo alguna de ellas, la impresion funciona, pero no
> > toma
> > > la medida custom
> > > Alguien me puede orientar, que es lo que se modifica y como solucionarlo
> > en
> > > el sistema CUPS ??
> >
> > Supongo que ya habrás visto esta página del fabricante:
> >
> > CUPS Driver for MAC, Linux, or Unix - Zebra Printers
> >
> > https://www.zebra.com/us/en/support-downloads/knowledge-articles/mac-linux-or-unix-driver-suggestions-for-zebra-printers.html
> >
> > Adding a Zebra Printer in a CUPS Printing System
> >
> > https://supportcommunity.zebra.com/s/article/Adding-a-Zebra-Printer-in-a-CUPS-Printing-System?language=es
> >
> > Asegúrate de que usas el PPD más actualizado que tenga el fabricante y
> > que has definido en CUPS el tamaño predeterminado para las impresiones.
> >
> > En cualquier caso, dices que imprime pero no usa la medida especificada
> > en CUPS... ¿cómo lo sabes? Es decir, ¿desde qué aplicación imprimes y
> > qué es lo que obtienes? Entiendo que el texto quedará fuera del área
> > de impresión o algo similar ¿no? :-?
> >
> > Para descartar problemas con la aplicación que genera la copia de
> > impresión, prueba a imprimir un archivo en bruto directamente a la
> > impresora (p. ej., «lp arhivo.txt»).

> Gracias por contestar
> Los drivers que utilizo están en el CUPS por defecto, nunca tuve necesidad
> de utilizar otros
> Una vez que se creó la impresora (es USB),  la pruebo con la misma opción
> del cups (localhost:631)  "Imprimir página de prueba"
> que imprime texto, logo de Debian, etc
> Si en este punto no imprime correctamente este test, no intento utilizar la
> aplicación de gestión porque se que no funcionara correctamente.
> Buscando y buscando, encontre un archivo ppd alternativo, que cuando lo
> utilizo, la impresora imprime bien la etiqueta, pero salta otra etiqueta en
> blanco
> y no he visto donde modificar para ajustarlo (el archivo hace referencia a
> una versión de CUPS mucho mas antigua)
> Mi experiencia con CUPS es instalar y utilizar. Nunca he tenido problema.
> Ahora esto no lo entiendo, porque los otros ordenadores que no fueron
> actualizados, funcionan correctamente, es algo de la actualización

Normalmente, los archivos PPD cambian con las actualizaciones de 
Debian. Puedes comparar el archivo que trae Debian testing con el PPD 
de la versión de Debian donde te funciona bien y ver si hay alguna 
diferencia.

Incluso puedes usar en testing el PPD antiguo, eso no es problema.

Si usando el mismo PPD te sigue dando errores, quizá hayan cmabiado 
algo en los filtros de CUPS de la nueva versión o te falte configurar 
algún parámetro adicional que tuvieras en la instalación antigua y 
tengas que añadirlo en la nueva.

Saludos,

Saludos,

-- 
Camaleón 



Re: Zebra TLP2844 impresion custom

2022-04-04 Por tema Camaleón
El 2022-04-04 a las 12:35 +0200, Fernando Ferraro escribió:

> Tengo hace años impresoras de etiquetas Zebra TLP2844
> En cualquier versión de Debian con utilizar el driver por defecto y colocar
> una medida
> en custom de 59x19mm funciona todo correctamente.
> Las terminales estan en testing
> Pero cuando actualizo alguna de ellas, la impresion funciona, pero no toma
> la medida custom
> Alguien me puede orientar, que es lo que se modifica y como solucionarlo en
> el sistema CUPS ??

Supongo que ya habrás visto esta página del fabricante:

CUPS Driver for MAC, Linux, or Unix - Zebra Printers
https://www.zebra.com/us/en/support-downloads/knowledge-articles/mac-linux-or-unix-driver-suggestions-for-zebra-printers.html

Adding a Zebra Printer in a CUPS Printing System
https://supportcommunity.zebra.com/s/article/Adding-a-Zebra-Printer-in-a-CUPS-Printing-System?language=es

Asegúrate de que usas el PPD más actualizado que tenga el fabricante y 
que has definido en CUPS el tamaño predeterminado para las impresiones.

En cualquier caso, dices que imprime pero no usa la medida especificada 
en CUPS... ¿cómo lo sabes? Es decir, ¿desde qué aplicación imprimes y 
qué es lo que obtienes? Entiendo que el texto quedará fuera del área 
de impresión o algo similar ¿no? :-?

Para descartar problemas con la aplicación que genera la copia de 
impresión, prueba a imprimir un archivo en bruto directamente a la 
impresora (p. ej., «lp arhivo.txt»).

Saludos,

-- 
Camaleón 



Re: indicador de batería para notebook

2022-04-03 Por tema Camaleón
El 2022-04-03 a las 08:38 -0300, Marcelo Eduardo Giordano escribió:

> El 3/4/22 a las 04:06, Camaleón escribió:
> > El 2022-04-02 a las 22:28 -0300, Marcelo Eduardo Giordano escribió:
> > 
> > > No me sale el indicador de carga de la batería para mi notebook en 
> > > Bullseye.
> > > 
> Gracias por responder.
> 
> Mi entorno es kde plasma.
> 
> Puse el applet de la batería pero me sale una bateria vacía y con una "x"

Intenta configurar powerdevil, que es gestor de la energía en KDE (botón 
derecho sobre el icono de la batería o en el centro de control de KDE > 
opciones de energía).

Saludos,

-- 
Camaleón 



  1   2   3   4   5   6   7   8   9   10   >