Re: LibreOffice y CUPS - Filter Failed [SOLUCIONADO]

2016-10-19 Por tema JAP

El 18/10/16 a las 14:16, JAP escribió:

El 17/10/16 a las 15:23, José María escribió:

El 17/10/16 a las 13:59, JAP escribió:

Buenos días:

Tengo un problema curioso, y no puedo dar con la solución.
Paso a contar la “historia larga”.
Cambié mi equipo de una placa ASRock H81M-VG4 con procesador Intel i3
por un placa GigaByte H170M-D3H-GSM con procesador i7.
Hice una migración del sistema “a lo bruto”: saqué el disco de una
máquina y lo puse en la otra. Todo resultó de maravillas, excepto por un
problemita con la impresión de algunos documentos, que más abajo detallo
y es el origen de este hilo.
Dado que luego de dos día de toquetear CUPS no pude solucionarlo, me
decidí por hacer las cosas bien, y reinstalar todo el sistema.

El problema persiste; paso a detallarlo.
Tengo conectada una impresora Xerox WorkCentre 3225 mediante cable USB,
que no funciona con todos los utilitarios.

No hay problemas para imprimir con KrViewwr de Krusader - archivos de
texto / Okular - archivos PDF / Gimp! - imágenes
La "Página de pruebas" de CUPS tampoco tiene problemas.

No puedo imprimir con LibreOffice - Writer  o Calc.

CUPS me muestra una pantalla con el estado “Parado. Filter Failed” para
las impresoras Xerox WorkCentre 3225 y PDF (Generic CUPS-PDF Printer).
Eso último es lo más raro, porque la impresora virtual PDF es nativa del
sistema Debian.

Los puertos USB-3 no son responsables; he cambiado entre distintos de
ellos y el problema persiste.
La configuración de usuario tampoco; he intentado "limpiando" los datos
de LibreOffice en mi sesión, como así también crear un nuevo usuario
"limpio".
/var y /tmp tienen espacio de sobra.

Por ahora, me las apaño en LibreOffice con “Exportar como PDF” y luego
imprimir con Okular.

Escucho opciones.

Muchas gracias.

JAP





Ahora se puso extraño.

Luego de 200 mil pruebas, he constatado que lo que no imprime, son
imágenes *.png incrustadas en los archivos.

Si es un documento Write sin imágenes, o las imágenes son *.jpg, no hay
problemas.

Si el documento tiene una imagen *.png, no hay caso de imprimirlo.

No me imprime el logo de la empresa como marca de agua en png. Lo cambié
a jpg y anda de maravillas.
Cromium no imprime si la página consta de tan solo una imagen png (lo
cual suelen ser los íconos y demás yerbas).
Si es una página con imágenes jpg o de otro tipo, no hay problemas.

Me huelo que
JAP




La solución, como siempre, llega luego de mucho buscar y mucho probar, 
buscando "la madre del borrego".


Resumen del problema: CUPS no me permitía imprimir con NINGUNA impresora 
algunos archivos.
Luego de trastear un poco, descubrí que no imprimía archivos que 
contuvieren imágenes *.png, como ser archivos de OpenOffice o páginas web.


El problema deriva de ghostscript en la rama "jessie".

http://serverfault.com/questions/602523/cups-is-not-printing-with-filter-failed-message-how-to-get-more-info 
me dio la punta del ovillo para desenmarañar el problema.


La solución fue "apt-pinning" con la rama "testing", de manera que el 
problema se solucionó con la siguiente instrucción:


  # apt-get install ghostscript -t testing
  Leyendo lista de paquetes... Hecho
  Creando árbol de dependencias
  Leyendo la información de estado... Hecho
  Se instalarán los siguientes paquetes extras:
fonts-droid-fallback fonts-noto fonts-noto-cjk fonts-noto-hinted
fonts-noto-mono fonts-noto-unhinted libgs9 libgs9-common
libopenjp2-7 libpng16-16
  Paquetes sugeridos:
ghostscript-x
  Los siguientes paquetes se ELIMINARÁN:
fonts-droid*
  Se instalarán los siguientes paquetes NUEVOS:
fonts-droid-fallback fonts-noto fonts-noto-cjk fonts-noto-hinted
fonts-noto-mono fonts-noto-unhinted libopenjp2-7 libpng16-16
  Se actualizarán los siguientes paquetes:
ghostscript libgs9 libgs9-common
  3 actualizados, 8 nuevos se instalarán, 1 para eliminar y 2197 no
  actualizados.
  Se necesita descargar 84,9 MB/90,4 MB de archivos.
  Se utilizarán 146 MB de espacio de disco adicional después de esta
  operación.
  ¿Desea continuar? [S/n]

Alguno de esos paquetes es el responsable.

Muchas gracias a todos.

JAP






Re: LibreOffice y CUPS - Filter Failed

2016-10-18 Por tema JAP

El 17/10/16 a las 15:23, José María escribió:

El 17/10/16 a las 13:59, JAP escribió:

Buenos días:

Tengo un problema curioso, y no puedo dar con la solución.
Paso a contar la “historia larga”.
Cambié mi equipo de una placa ASRock H81M-VG4 con procesador Intel i3
por un placa GigaByte H170M-D3H-GSM con procesador i7.
Hice una migración del sistema “a lo bruto”: saqué el disco de una
máquina y lo puse en la otra. Todo resultó de maravillas, excepto por un
problemita con la impresión de algunos documentos, que más abajo detallo
y es el origen de este hilo.
Dado que luego de dos día de toquetear CUPS no pude solucionarlo, me
decidí por hacer las cosas bien, y reinstalar todo el sistema.

El problema persiste; paso a detallarlo.
Tengo conectada una impresora Xerox WorkCentre 3225 mediante cable USB,
que no funciona con todos los utilitarios.

No hay problemas para imprimir con KrViewwr de Krusader - archivos de
texto / Okular - archivos PDF / Gimp! - imágenes
La "Página de pruebas" de CUPS tampoco tiene problemas.

No puedo imprimir con LibreOffice - Writer  o Calc.

CUPS me muestra una pantalla con el estado “Parado. Filter Failed” para
las impresoras Xerox WorkCentre 3225 y PDF (Generic CUPS-PDF Printer).
Eso último es lo más raro, porque la impresora virtual PDF es nativa del
sistema Debian.

Los puertos USB-3 no son responsables; he cambiado entre distintos de
ellos y el problema persiste.
La configuración de usuario tampoco; he intentado "limpiando" los datos
de LibreOffice en mi sesión, como así también crear un nuevo usuario
"limpio".
/var y /tmp tienen espacio de sobra.

Por ahora, me las apaño en LibreOffice con “Exportar como PDF” y luego
imprimir con Okular.

Escucho opciones.

Muchas gracias.

JAP





Ahora se puso extraño.

Luego de 200 mil pruebas, he constatado que lo que no imprime, son 
imágenes *.png incrustadas en los archivos.


Si es un documento Write sin imágenes, o las imágenes son *.jpg, no hay 
problemas.


Si el documento tiene una imagen *.png, no hay caso, es imposible 
imprimirlo.


No me imprime el logo de la empresa como marca de agua en png. Lo cambié 
a jpg y anda de maravillas.
Crhomium no imprime si la página consta de tan solo una imagen png (lo 
cual suelen ser los íconos y demás yerbas).

Si es una página con imágenes jpg o de otro tipo, no hay problemas.

Me huelo que algún paquete dependiente de CUPS ha sido modificado y el 
problema parte de ahí. Me tengo que fijar, pues cups 1.7.5-11+deb8u1 
desde junio de 2015 no tiene modificaciones.


JAP
















Re: LibreOffice y CUPS - Filter Failed

2016-10-18 Por tema Alberto Luaces
JAP writes:

> El 17/10/16 a las 15:23, José María escribió:
>> O sea que el problema es de LibreOffice... Puede que tengas que
>> seleccionar la impresora a mano.
>>
>> Abre un documento de LibreOffice Writer y dirígete a:
>>
>> Archivo > Configuración de la impresora...
>>
>> Y aquí deberías de seleccionar tu impresora.
>>
>> Suerte
>
> No sólo de LibreOffice, también si intento imprimir algo directamente
> de Chromium (Ctrl+P).
>
> Que es lo más raro: enciendo la computadora, y el primer archivo de
> Write que mando a imprimir, lo hace sin problemas; los subsiguientes
> se traban con el maldito "Filter failed".
>

Para los «Filter failed», generalmente se explica qué pasó en

/var/log/cups/error_log

de ahí puedes tirar con el mensaje de error para buscar más información.

-- 
Alberto



Re: LibreOffice y CUPS - Filter Failed

2016-10-18 Por tema JAP

El 17/10/16 a las 15:23, José María escribió:

O sea que el problema es de LibreOffice... Puede que tengas que
seleccionar la impresora a mano.

Abre un documento de LibreOffice Writer y dirígete a:

Archivo > Configuración de la impresora...

Y aquí deberías de seleccionar tu impresora.

Suerte


No sólo de LibreOffice, también si intento imprimir algo directamente de 
Chromium (Ctrl+P).


Que es lo más raro: enciendo la computadora, y el primer archivo de 
Write que mando a imprimir, lo hace sin problemas; los subsiguientes se 
traban con el maldito "Filter failed".


JAP




Re: LibreOffice y CUPS - Filter Failed

2016-10-17 Por tema José María

El 17/10/16 a las 13:59, JAP escribió:

Buenos días:

Tengo un problema curioso, y no puedo dar con la solución.
Paso a contar la “historia larga”.
Cambié mi equipo de una placa ASRock H81M-VG4 con procesador Intel i3
por un placa GigaByte H170M-D3H-GSM con procesador i7.
Hice una migración del sistema “a lo bruto”: saqué el disco de una
máquina y lo puse en la otra. Todo resultó de maravillas, excepto por un
problemita con la impresión de algunos documentos, que más abajo detallo
y es el origen de este hilo.
Dado que luego de dos día de toquetear CUPS no pude solucionarlo, me
decidí por hacer las cosas bien, y reinstalar todo el sistema.

El problema persiste; paso a detallarlo.
Tengo conectada una impresora Xerox WorkCentre 3225 mediante cable USB,
que no funciona con todos los utilitarios.

No hay problemas para imprimir con KrViewwr de Krusader - archivos de
texto / Okular - archivos PDF / Gimp! - imágenes
La "Página de pruebas" de CUPS tampoco tiene problemas.

No puedo imprimir con LibreOffice - Writer  o Calc.

CUPS me muestra una pantalla con el estado “Parado. Filter Failed” para
las impresoras Xerox WorkCentre 3225 y PDF (Generic CUPS-PDF Printer).
Eso último es lo más raro, porque la impresora virtual PDF es nativa del
sistema Debian.

Los puertos USB-3 no son responsables; he cambiado entre distintos de
ellos y el problema persiste.
La configuración de usuario tampoco; he intentado "limpiando" los datos
de LibreOffice en mi sesión, como así también crear un nuevo usuario
"limpio".
/var y /tmp tienen espacio de sobra.

Por ahora, me las apaño en LibreOffice con “Exportar como PDF” y luego
imprimir con Okular.

Escucho opciones.

Muchas gracias.

JAP




O sea que el problema es de LibreOffice... Puede que tengas que 
seleccionar la impresora a mano.


Abre un documento de LibreOffice Writer y dirígete a:

Archivo > Configuración de la impresora...

Y aquí deberías de seleccionar tu impresora.

Suerte