[Desktop-packages] [Bug 1034743] Re: modules loaded are reloaded again

2012-10-01 Thread Maarten Lankhorst
It's how xorg probing works, all the drivers are a few kb so I don't
think there is anything that needs to be done here. It may not look
clean but this seems more like wishful thinking than an actual bug.

** Changed in: xorg-server (Ubuntu)
   Status: Triaged = Invalid

-- 
You received this bug notification because you are a member of Desktop
Packages, which is subscribed to xorg-server in Ubuntu.
https://bugs.launchpad.net/bugs/1034743

Title:
  modules loaded are reloaded again

Status in “xorg-server” package in Ubuntu:
  Invalid

Bug description:
  Nouveau driver installed, but not found as additional driver
  and xorg.0.log is showing  that :
  - xorg is trying to load uninstalled drivers  (seems strange, it only should 
detect the installed ones)
  - xorg loads the installed drivers, then try again to load them to finally 
find they was already loaded (what a mess)

  ProblemType: Bug
  DistroRelease: Ubuntu 12.10
  Package: xserver-xorg-core 2:1.12.99.904-0ubuntu1
  Uname: Linux 3.6.0-999-generic i686
  .tmp.unity.support.test.0:
   
  ApportVersion: 2.4-0ubuntu6
  Architecture: i386
  CompizPlugins: 
[core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,workarounds,scale,expo,ezoom]
  CompositorRunning: None
  Date: Thu Aug  9 06:28:07 2012
  DistUpgraded: Fresh install
  DistroCodename: quantal
  DistroVariant: ubuntu
  GraphicsCard:
   NVIDIA Corporation G86 [GeForce 8500 GT] [10de:0421] (rev a1) (prog-if 00 
[VGA controller])
 Subsystem: ASUSTeK Computer Inc. Device [1043:824f]
  Lsusb:
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
   Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
   Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  MachineType: ASUSTEK COMPUTER INC P5W DH Deluxe
  PlymouthDebug: Error: [Errno 13] Permission non accordée: 
'/var/log/plymouth-debug.log'
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.6.0-999-generic 
root=UUID=00c5de83-479c-4ab0-9b54-9af0a727175e ro acpi_osi=Linux pci=nocrs 
quiet splash vt.handoff=7
  Renderer: Software
  SourcePackage: xorg-server
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 07/22/2010
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 3002
  dmi.board.asset.tag: To Be Filled By O.E.M.
  dmi.board.name: P5W DH Deluxe
  dmi.board.vendor: ASUSTeK Computer INC.
  dmi.board.version: Rev 1.xx
  dmi.chassis.asset.tag: Asset-1234567890
  dmi.chassis.type: 3
  dmi.chassis.vendor: Chassis Manufacture
  dmi.chassis.version: Chassis Version
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvr3002:bd07/22/2010:svnASUSTEKCOMPUTERINC:pnP5WDHDeluxe:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5WDHDeluxe:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
  dmi.product.name: P5W DH Deluxe
  dmi.product.version: System Version
  dmi.sys.vendor: ASUSTEK COMPUTER INC
  version.compiz: compiz 1:0.9.8+bzr3249-0ubuntu2
  version.libdrm2: libdrm2 2.4.37-0ubuntu2
  version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.4-1ubuntu1
  version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
  version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.4-1ubuntu1
  version.xserver-xorg-core: xserver-xorg-core 2:1.12.99.904-0ubuntu1
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 
1:2.7.0+git20120716.f5ede980-0ubuntu0ricotz
  version.xserver-xorg-video-ati: xserver-xorg-video-ati N/A
  version.xserver-xorg-video-intel: xserver-xorg-video-intel N/A
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 
1:1.0.1-4~ubuntu1

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/1034743/+subscriptions

-- 
Mailing list: https://launchpad.net/~desktop-packages
Post to : desktop-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~desktop-packages
More help   : https://help.launchpad.net/ListHelp


[Desktop-packages] [Bug 1034743] Re: modules loaded are reloaded again

2012-09-20 Thread Timo Aaltonen
the first point is not a bug, the server has a static dependency list of
driver names it's trying

** Changed in: xorg-server (Ubuntu)
   Importance: Undecided = Low

** Changed in: xorg-server (Ubuntu)
   Status: New = Triaged

-- 
You received this bug notification because you are a member of Desktop
Packages, which is subscribed to xorg-server in Ubuntu.
https://bugs.launchpad.net/bugs/1034743

Title:
  modules loaded are reloaded again

Status in “xorg-server” package in Ubuntu:
  Triaged

Bug description:
  Nouveau driver installed, but not found as additional driver
  and xorg.0.log is showing  that :
  - xorg is trying to load uninstalled drivers  (seems strange, it only should 
detect the installed ones)
  - xorg loads the installed drivers, then try again to load them to finally 
find they was already loaded (what a mess)

  ProblemType: Bug
  DistroRelease: Ubuntu 12.10
  Package: xserver-xorg-core 2:1.12.99.904-0ubuntu1
  Uname: Linux 3.6.0-999-generic i686
  .tmp.unity.support.test.0:
   
  ApportVersion: 2.4-0ubuntu6
  Architecture: i386
  CompizPlugins: 
[core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,workarounds,scale,expo,ezoom]
  CompositorRunning: None
  Date: Thu Aug  9 06:28:07 2012
  DistUpgraded: Fresh install
  DistroCodename: quantal
  DistroVariant: ubuntu
  GraphicsCard:
   NVIDIA Corporation G86 [GeForce 8500 GT] [10de:0421] (rev a1) (prog-if 00 
[VGA controller])
 Subsystem: ASUSTeK Computer Inc. Device [1043:824f]
  Lsusb:
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
   Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
   Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  MachineType: ASUSTEK COMPUTER INC P5W DH Deluxe
  PlymouthDebug: Error: [Errno 13] Permission non accordée: 
'/var/log/plymouth-debug.log'
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.6.0-999-generic 
root=UUID=00c5de83-479c-4ab0-9b54-9af0a727175e ro acpi_osi=Linux pci=nocrs 
quiet splash vt.handoff=7
  Renderer: Software
  SourcePackage: xorg-server
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 07/22/2010
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 3002
  dmi.board.asset.tag: To Be Filled By O.E.M.
  dmi.board.name: P5W DH Deluxe
  dmi.board.vendor: ASUSTeK Computer INC.
  dmi.board.version: Rev 1.xx
  dmi.chassis.asset.tag: Asset-1234567890
  dmi.chassis.type: 3
  dmi.chassis.vendor: Chassis Manufacture
  dmi.chassis.version: Chassis Version
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvr3002:bd07/22/2010:svnASUSTEKCOMPUTERINC:pnP5WDHDeluxe:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5WDHDeluxe:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
  dmi.product.name: P5W DH Deluxe
  dmi.product.version: System Version
  dmi.sys.vendor: ASUSTEK COMPUTER INC
  version.compiz: compiz 1:0.9.8+bzr3249-0ubuntu2
  version.libdrm2: libdrm2 2.4.37-0ubuntu2
  version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.4-1ubuntu1
  version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
  version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.4-1ubuntu1
  version.xserver-xorg-core: xserver-xorg-core 2:1.12.99.904-0ubuntu1
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 
1:2.7.0+git20120716.f5ede980-0ubuntu0ricotz
  version.xserver-xorg-video-ati: xserver-xorg-video-ati N/A
  version.xserver-xorg-video-intel: xserver-xorg-video-intel N/A
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 
1:1.0.1-4~ubuntu1

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/1034743/+subscriptions

-- 
Mailing list: https://launchpad.net/~desktop-packages
Post to : desktop-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~desktop-packages
More help   : https://help.launchpad.net/ListHelp


[Desktop-packages] [Bug 1034743] Re: modules loaded are reloaded again

2012-09-20 Thread dino99
hi Timo,

maybe not a bug but what a strange design : instead of blindly trying to
load an endless static  drivers list, it should scan for the installed
driver(s) only then load it (them).

maybe not a bug, but what a mess; setting an unneeded long loading time
process with useless checking loop for each unused driver.

not a bug ? but what its name ?

-- 
You received this bug notification because you are a member of Desktop
Packages, which is subscribed to xorg-server in Ubuntu.
https://bugs.launchpad.net/bugs/1034743

Title:
  modules loaded are reloaded again

Status in “xorg-server” package in Ubuntu:
  Triaged

Bug description:
  Nouveau driver installed, but not found as additional driver
  and xorg.0.log is showing  that :
  - xorg is trying to load uninstalled drivers  (seems strange, it only should 
detect the installed ones)
  - xorg loads the installed drivers, then try again to load them to finally 
find they was already loaded (what a mess)

  ProblemType: Bug
  DistroRelease: Ubuntu 12.10
  Package: xserver-xorg-core 2:1.12.99.904-0ubuntu1
  Uname: Linux 3.6.0-999-generic i686
  .tmp.unity.support.test.0:
   
  ApportVersion: 2.4-0ubuntu6
  Architecture: i386
  CompizPlugins: 
[core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,workarounds,scale,expo,ezoom]
  CompositorRunning: None
  Date: Thu Aug  9 06:28:07 2012
  DistUpgraded: Fresh install
  DistroCodename: quantal
  DistroVariant: ubuntu
  GraphicsCard:
   NVIDIA Corporation G86 [GeForce 8500 GT] [10de:0421] (rev a1) (prog-if 00 
[VGA controller])
 Subsystem: ASUSTeK Computer Inc. Device [1043:824f]
  Lsusb:
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
   Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
   Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  MachineType: ASUSTEK COMPUTER INC P5W DH Deluxe
  PlymouthDebug: Error: [Errno 13] Permission non accordée: 
'/var/log/plymouth-debug.log'
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.6.0-999-generic 
root=UUID=00c5de83-479c-4ab0-9b54-9af0a727175e ro acpi_osi=Linux pci=nocrs 
quiet splash vt.handoff=7
  Renderer: Software
  SourcePackage: xorg-server
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 07/22/2010
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 3002
  dmi.board.asset.tag: To Be Filled By O.E.M.
  dmi.board.name: P5W DH Deluxe
  dmi.board.vendor: ASUSTeK Computer INC.
  dmi.board.version: Rev 1.xx
  dmi.chassis.asset.tag: Asset-1234567890
  dmi.chassis.type: 3
  dmi.chassis.vendor: Chassis Manufacture
  dmi.chassis.version: Chassis Version
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvr3002:bd07/22/2010:svnASUSTEKCOMPUTERINC:pnP5WDHDeluxe:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5WDHDeluxe:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
  dmi.product.name: P5W DH Deluxe
  dmi.product.version: System Version
  dmi.sys.vendor: ASUSTEK COMPUTER INC
  version.compiz: compiz 1:0.9.8+bzr3249-0ubuntu2
  version.libdrm2: libdrm2 2.4.37-0ubuntu2
  version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.4-1ubuntu1
  version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
  version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.4-1ubuntu1
  version.xserver-xorg-core: xserver-xorg-core 2:1.12.99.904-0ubuntu1
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 
1:2.7.0+git20120716.f5ede980-0ubuntu0ricotz
  version.xserver-xorg-video-ati: xserver-xorg-video-ati N/A
  version.xserver-xorg-video-intel: xserver-xorg-video-intel N/A
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 
1:1.0.1-4~ubuntu1

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/1034743/+subscriptions

-- 
Mailing list: https://launchpad.net/~desktop-packages
Post to : desktop-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~desktop-packages
More help   : https://help.launchpad.net/ListHelp