Re: New Laucher

2003-07-16 Thread Stefan Bodewig
On Tue, 15 Jul 2003, Jeff Tulley <[EMAIL PROTECTED]> wrote: > Shouldn't the last if statement instead be the following?: > >if (!path.startsWith(File.separator)) { > sb.append("/"); >} Yes, I think so. > I would also add some tests to FileUtilsTest.java Thanks a lot. > in fromUR

Re: New Laucher

2003-07-15 Thread Jeff Tulley
Ok, I finally had some time to look at this. Here is my feedback: on NetWare the existing code only needed two small changes to work, in both toURI and fromURI. The change in toURI is one that I think is necessary for all platforms anyway. In toURI. there is the following code: try { path =

Re: New Laucher

2003-07-11 Thread Stefan Bodewig
On Thu, 10 Jul 2003, Jeff Tulley <[EMAIL PROTECTED]> wrote: > Looking at it, the fromURI is a method I should have considered and > added some NetWare test cases for. fromURI is rather new - compared to the other Netware related stuff you've submitted. > I'll work out some test cases, see if the

Re: New Laucher

2003-07-10 Thread Jeff Tulley
Connor, It looks like indeed this will change the behavior a little bit, though if it has any adverse effect remains to be seen. Previously NetWare would have been completely excluded from that if statement, but since NetWare's pathSeparatorChar is indeed ";", this block could conceivably run o

Re: New Laucher

2003-07-10 Thread Jeff Tulley
Yeah, I about mass-deleted my ant emails today since I've been on vacation, good thing this subject name for some reason caught my attention. Let me ponder it and get back to you shortly. Jeff Tulley ([EMAIL PROTECTED]) (801)861-5322 Novell, Inc., The Leading Provider of Net Business Solutions h

Re: New Laucher

2003-07-08 Thread Stefan Bodewig
On Tue, 8 Jul 2003, Conor MacNeill <[EMAIL PROTECTED]> wrote: > It turns out this "legacy" code works better than the commented out > code because it handles spaces in file names (which are otherwise > rendered as %20) Yes, the URI handling code in FileUtils is better than the code in the JDK, at

Re: New Laucher

2003-07-08 Thread Conor MacNeill
On Thu, 3 Jul 2003 11:16 pm, Stefan Bodewig wrote: > > It's JDK 1.1 legacy as far as I'm concerned and could those be swapped > against the commented Axis' code. > It turns out this "legacy" code works better than the commented out code because it handles spaces in file names (which are otherwise

Re: New Laucher

2003-07-03 Thread Conor MacNeill
On Thu, 3 Jul 2003 11:16 pm, Stefan Bodewig wrote: > > It's JDK 1.1 legacy as far as I'm concerned and could those be swapped > against the commented Axis' code. > OK, let's do that > > Looking at the top of JavaURLConnection's javadocs, simply stripping > the leading "jar:" and everything after

Re: New Laucher

2003-07-03 Thread Stefan Bodewig
On Tue, 1 Jul 2003, Conor MacNeill <[EMAIL PROTECTED]> wrote: > On Tue, 1 Jul 2003 10:02 pm, Stefan Bodewig wrote: >> The only thing I've stumbled over for now is the almost duplicate >> code of Locator#getClassLocationURL and >> oata.util.LoaderUtils#getClassSource > > I wanted to keep the depe

Re: New Laucher

2003-07-01 Thread Conor MacNeill
On Tue, 1 Jul 2003 10:02 pm, Stefan Bodewig wrote: > On Fri, 27 Jun 2003, Conor MacNeill <[EMAIL PROTECTED]> > > wrote: > > Thoughts? > > The only thing I've stumbled over for now is the almost duplicate code > of Locator#getClassLocationURL and > oata.util.LoaderUtils#getClassSource - I'd like to

Re: New Laucher

2003-07-01 Thread Stefan Bodewig
On Fri, 27 Jun 2003, Conor MacNeill <[EMAIL PROTECTED]> wrote: > Thoughts? The only thing I've stumbled over for now is the almost duplicate code of Locator#getClassLocationURL and oata.util.LoaderUtils#getClassSource - I'd like to see them merged in some way. Stefan ---

Re: New Laucher

2003-07-01 Thread Stefan Bodewig
On Mon, 30 Jun 2003, Conor MacNeill <[EMAIL PROTECTED]> wrote: > That should be fine. The jar is required for ant.jar, since it > provides the AntMain interface. One alternative would be to include AntMain in ant.jar as well. That way ant.jar would not depend upon ant-launcher.jar. Stefan

RE: New Laucher

2003-06-30 Thread Dominique Devienne
I was wondering about that the day, and why there's no 'eval' keyword in Java. It would be trivial for the compiler to generate the appropriate reflection code on the fly... Maybe just because if would make programming with reflection too easy and clean ;-) --DD > -Original Message- > From

Re: New Laucher

2003-06-30 Thread Conor MacNeill
On Mon, 30 Jun 2003 05:13 pm, Stefan Bodewig wrote: > > I've added ant-launcher.jar to the list of produced jars for now, but > I'm not sure that this is the proper and intended fix. > That should be fine. The jar is required for ant.jar, since it provides the AntMain interface. That interface mu

Re: New Laucher

2003-06-30 Thread Conor MacNeill
On Mon, 30 Jun 2003 05:13 pm, Stefan Bodewig wrote: > > You mean apart from "you've broken Gump"? ;-) > Oops - sorry about that. I've been busy all weekend http://www.dtek.chalmers.se/groups/icfpcontest/ :-) Conor - To unsub

Re: New Laucher

2003-06-30 Thread Stefan Bodewig
On Fri, 27 Jun 2003, Conor MacNeill <[EMAIL PROTECTED]> wrote: > Thoughts? You mean apart from "you've broken Gump"? ;-) I've added ant-launcher.jar to the list of produced jars for now, but I'm not sure that this is the proper and intended fix. More thoughts after I've found time to review (or