Re: Revisit cdiCtrl module name and how it's inconsistent with test-control?

2014-02-14 Thread Thomas Andraschko
IMHO there is no difference between our modules and cdictrl. However, we should rename it to something like container-control to match our other project names. 2014-02-14 8:55 GMT+01:00 Mark Struberg strub...@yahoo.de: I'm still -1 (veto) because I'm not convinced that it has ANY benefit.

Re: Revisit cdiCtrl module name and how it's inconsistent with test-control?

2014-02-14 Thread Karl Kildén
As far as I understand , it would be more symmetric from the outside / overview but technically asymmetric because the dependencies are different. But the name change feels harmless and would bring balance to the force. On 14 February 2014 09:31, Thomas Andraschko

Re: Revisit cdiCtrl module name and how it's inconsistent with test-control?

2014-02-14 Thread Romain Manni-Bucau
well I don't agree on modules hierarchy which looks inconsistent but I dont really care while code is here but I agree with Mark names are already used 'in fact it is true for this and for core) so we shouldn't change it anymore. Romain Manni-Bucau Twitter: @rmannibucau Blog:

Re: Revisit cdiCtrl module name and how it's inconsistent with test-control?

2014-02-14 Thread Gerhard Petracek
imo the definition should be simple: if it depends on deltaspike-core, it's a module @romain: again: there is no issue with api-/name-/... changes before v1. we had a similar change in codi (before v1) and there was no issue with it. (+ we emphasized the possibility of such changes from the

Re: Revisit cdiCtrl module name and how it's inconsistent with test-control?

2014-02-14 Thread Romain Manni-Bucau
that's not true at all, depend the virality of the code. CdiCtrl and core are viral now. So either we say users to not use DS before 0.1 or we keep stability on used modules. Honestly I don't think we have the choice if we want to promote what we propose. We are late for a 1.0 so already too much

Re: Revisit cdiCtrl module name and how it's inconsistent with test-control?

2014-02-14 Thread Gerhard Petracek
we would need a vote about your statement, because it changes our official statement. if the majority agrees, we have to postpone such discussions (e.g. until v2). a lot of users are still waiting for v1 before they start with deltaspike. - we are late, but according to our official statement we

Re: Revisit cdiCtrl module name and how it's inconsistent with test-control?

2014-02-14 Thread Romain Manni-Bucau
that's the main point of the discussion I think. We are consistent with what we said but users can't wait for years so we are too used to maintain it. +1 for a vote Romain Manni-Bucau Twitter: @rmannibucau Blog: http://rmannibucau.wordpress.com/ LinkedIn: http://fr.linkedin.com/in/rmannibucau

AW: Revisit cdiCtrl module name and how it's inconsistent with test-control?

2014-02-14 Thread it-media . kopp
Seems this way. I think this whole dicussion is becoming ridicuolus. Change it to comply with the rest. I personally never understood why this very lonely 'module' cdiCtrl is located elsewhere, regardless on whether it has different dependencies or not. Additionally it does not fit into the

Re: Revisit cdiCtrl module name and how it's inconsistent with test-control?

2014-02-14 Thread Romain Manni-Bucau
+0 for position -1 for name or maven coordinates Romain Manni-Bucau Twitter: @rmannibucau Blog: http://rmannibucau.wordpress.com/ LinkedIn: http://fr.linkedin.com/in/rmannibucau Github: https://github.com/rmannibucau 2014-02-14 13:21 GMT+01:00 it-media.k...@daimler.com: Seems this way. I

Re: Revisit cdiCtrl module name and how it's inconsistent with test-control?

2014-02-14 Thread Gerhard Petracek
+1 for changing the name and location of cdictrl regards, gerhard 2014-02-14 13:27 GMT+01:00 Romain Manni-Bucau rmannibu...@gmail.com: +0 for position -1 for name or maven coordinates Romain Manni-Bucau Twitter: @rmannibucau Blog: http://rmannibucau.wordpress.com/ LinkedIn:

Re: Revisit cdiCtrl module name and how it's inconsistent with test-control?

2014-02-14 Thread John D. Ament
I guess I'm kind of curious why this is such a polarized issue. On Fri, Feb 14, 2014 at 9:07 AM, Thomas Andraschko andraschko.tho...@gmail.com wrote: +1 for changing the name and location BEFORE 1.0 Otherwise it will probably not happen... 2014-02-14 15:04 GMT+01:00 Gerhard Petracek

Re: Revisit cdiCtrl module name and how it's inconsistent with test-control?

2014-02-14 Thread John D. Ament
I'm fine with that approach. I was thinking we could provide a shaded jar under the old coordinates and old package, perhaps even with a warning in the log that you should not be using this. On Fri, Feb 14, 2014 at 12:54 PM, Matt Benson gudnabr...@gmail.com wrote: It seems that the inertia of