[jira] [Commented] (DELTASPIKE-1319) labeled alternatives

2018-03-01 Thread ASF subversion and git services (JIRA)
[ https://issues.apache.org/jira/browse/DELTASPIKE-1319?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16382627#comment-16382627 ] ASF subversion and git services commented on DELTASPIKE-1319: - Commit

Re: [DISCUSS] require Java8 and move to Deltaspike-1.9.x version?

2018-03-01 Thread Rudy De Busscher
Strictly speaking, DS1.x is Java EE 6 based (because we are using CDI 1.0, JSF 2.0) But probably no harm in just setting compiler to java 8. (and indicate that DS 1.9 only run on Java EE 7 server with Java 8) On 1 March 2018 at 16:05, Thomas Andraschko wrote: > IMO

Re: [DISCUSS] require Java8 and move to Deltaspike-1.9.x version?

2018-03-01 Thread John D. Ament
I think assuming all EE7 vendors support Java 8 then I think its fine. But I definitely believe we can't do EE6 on Java 8. John On Thu, Mar 1, 2018 at 10:06 AM Thomas Andraschko < andraschko.tho...@gmail.com> wrote: > IMO > DS1.x = JavaEE 7 > DS2.x = JavaEE 8 > > Java8 in 1.x is fine for me,

Re: [DISCUSS] require Java8 and move to Deltaspike-1.9.x version?

2018-03-01 Thread Thomas Andraschko
IMO DS1.x = JavaEE 7 DS2.x = JavaEE 8 Java8 in 1.x is fine for me, we can try to improve our APIs with Java8 In 2.x we can even improve further and cleanup then 2018-03-01 15:55 GMT+01:00 Romain Manni-Bucau : > 2018-03-01 15:50 GMT+01:00 John D. Ament

Re: [DISCUSS] require Java8 and move to Deltaspike-1.9.x version?

2018-03-01 Thread Romain Manni-Bucau
2018-03-01 15:50 GMT+01:00 John D. Ament : > IMHO to move to Java 8 we need to drop support for EE6/EE7. So to me that > says the next version is 2.0 not 1.9.x. > It is way too early for cdi 2, almost no users rely on that yet compared to cdi 1.x. > > There are some

Re: [DISCUSS] require Java8 and move to Deltaspike-1.9.x version?

2018-03-01 Thread Rudy De Busscher
Maybe not drop EE7. I think all current app servers supporting Java EE 7 runs on Java 8. But removing EE6, means for example that we no longer need BeanProvider and other specific code for EE6. So changing to Java 8 has quite some impact (but Java 8 is wanted I guess) and thus requires 2.x

Re: [DISCUSS] require Java8 and move to Deltaspike-1.9.x version?

2018-03-01 Thread John D. Ament
IMHO to move to Java 8 we need to drop support for EE6/EE7. So to me that says the next version is 2.0 not 1.9.x. There are some weld 1.1 versions that support this, but no testable AS7 instance that we can check against. John On Thu, Mar 1, 2018 at 9:35 AM Cody Lerum

Re: [DISCUSS] require Java8 and move to Deltaspike-1.9.x version?

2018-03-01 Thread Cody Lerum
+1 there is no reason for someone running Java 7 to expect new features from Deltaspike. On Feb 28, 2018 9:48 PM, "Mark Struberg" wrote: > Hi folks! > > Our build, etc in theory still runs with Java6. > As typical with ASF projects we make battle prooven projects for

[jira] [Commented] (DELTASPIKE-1320) global alternative spi to support custom (type-safe) mechanisms

2018-03-01 Thread ASF subversion and git services (JIRA)
[ https://issues.apache.org/jira/browse/DELTASPIKE-1320?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16381663#comment-16381663 ] ASF subversion and git services commented on DELTASPIKE-1320: - Commit

[jira] [Commented] (DELTASPIKE-1318) Unsatisfied dependencies for type ApplicationContext (deltaspike-cdictrl-weld) in payara 4.1.2.174

2018-03-01 Thread Andreas Keefer (JIRA)
[ https://issues.apache.org/jira/browse/DELTASPIKE-1318?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16381650#comment-16381650 ] Andreas Keefer commented on DELTASPIKE-1318: org.jboss.weld.context.ApplicationContext is